Homepage

EnterpriseOne 8.96 APIs

Copyright J.D. Edwards World Source Company, 1997-2006

All Rights Reserved

EnterpriseOne 8.96 Tools API Reference

Application Program Interface

System Functions

Interoperability

Events

Flat File - Unicode Encoding

Comments

If you wish to make comments about this application,

please take the time to fill out the following

information. All fields are required.

Name

Company

Customer / Employee Number

E-mail Address

Phone Number

Comments


Application Program Interface

The EnterpriseOne published Application Programming Interface (API) set is a collection of functions or routines that perform predefined tasks. The API set allows third party applications to interface with EnterpriseOne applications. The published API set makes it easy for you to develop solutions for customers without learning the complexities of EnterpriseOne.

The Configurable Network Computing (CNC) architecture shields you, the developer, from database or platform specific syntax or the location of your database. For example, you do not need to know database specific Structured Query Language (SQL) to use the JDEBASE APIs for data manipulation. Because you build your products on the same architecture as the EnterpriseOne applications, they will integrate seamless. Businesses will benefit from a more extensive set of solutions while maintaining a high degree of integration. The result is that the APIs make the EnterpriseOne product an open platform independent system.

EnterpriseOne embraces the major standards that ensure the ongoing viability of your company’s solution and its compatibility with other tools. Some of the standards EnterpriseOne complies with include ANSI SQL, MAPI, OLE, TCP/IP, as well as the industry’s major languages, such as C, C++, and Java.

J.D. Edwards provides the Published API set as online help. Use the help file to access information on the EnterpriseOne tools APIs as well as definitions on events.

The J.D. Edwards APIs consist of the following major Categories:

app.gif (808 bytes) | Common Library
app.gif (808 bytes) | Data Dictionary
app.gif (808 bytes) | Imaging
app.gif (808 bytes) | JDEBASE
app.gif (808 bytes) | JDE Cache
app.gif (808 bytes) | Media Object


Data Dictionary

The EnterpriseOne Data Dictionary is a central repository for EnterpriseOne data items. It stores attributes about all data items that you can use in EnterpriseOne. When you use a data item at runtime, the formatting and validation of the data item are performed based on the information and specification stored in the Data Dictionary. The EnterpriseOne Data Dictionary APIs should be used by any third party report writers accessing any data within an EnterpriseOne database.

Data Dictionary consist of the following APIs:

 | jdeDDAllocGetValue
app.gif (808 bytes) | jdeDDCreate
app.gif (808 bytes) | jdeDDCreateDuplicate
 | jdeDDDestroy
app.gif (808 bytes) | jdeDDFreeDuplicate
app.gif (808 bytes) | jdeDDFreeValue
 | jdeDDIsValueValidated
app.gif (808 bytes) | jdeDDLoadOverrides
app.gif (808 bytes) | jdeDDSetOverrideFlags
 | jdeDDSetValue
app.gif (808 bytes) | jdeDDValidateValue
app.gif (808 bytes) | jdeDDValidateValueEx
app.gif (808 bytes) | jdeDDValidation


jdeDDAllocGetValue

Last Modified: B733

jdeDDAllocGetValue allocates and returns a formatted value stored in the Data Dictionary object described above. This value may be used as it is to display on screen.

Syntax

BOOL jdeDDAllocGetValue(LPVOID lpDDInfoTemp, PJSTR* lpString)

Parameters

Parameter | Notes | Usage
lpDDInfoTemp | Pointer to Data Dictionary object. | Required.
lpString |  |

Return Value

Return Value | Description
A pointer to the value |

Additional Notes

Memory allocated by this function needs to be freed by using jdeDDFreeValue.

See Also

  1. jdeDDFreeValue


jdeDDCreate

Last Modified: B733

jdeDDCreate creates a data object containing Data Dictionary specifications.

Syntax

LPVOID jdeDDCreate(LPVOID lpdd, ID idDict, LPVOID lpszAlias, DWORD dwOverrideFlags, LPVOID lpDDOverrides);

Parameters

Parameter | Notes | Usage
lpdd | Data Dictionary specification, if available; NULL otherwise. | Optional if either the second or third parameter is passed.
idDict | Data Dictionary ID, if available, ZERO otherwise. | Optional if either the first or third parameter is passed.
lpszAlias | Data Dictionary Alias, if available; NULL otherwise. | Optional if either the first or second parameter is passed.
dwOverrideFlags | Data Dictionary Override Flags; ZERO if not known. | Optional.
lpDDOverrides | Data Dictionary Overrides; NULL if not known. | Optional.

Return Value

Return Value | Description
Pointer to the DD specifications object | If it is successful
NULL | If it fails

Additional Notes

One of the first three parameters is required to create the Data Dictionary specification object. If more than one is passed, the following precedence will be used to create the required data object, and the others will be ignored.

  1. lpdd

  2. idDict

  3. lpszAlias

This function should always have a corresponding call to jdeDDDestroy to free the allocated memory after the object is no longer required.

See Also

  1. jdeDDDestroy


jdeDDCreateDuplicate

Last Modified: B733

jdeDDCreateDuplicate creates an exact replica of the data object passed.

Syntax

LPVOID jdeDDCreateDuplicate(LPVOID lpDDInfo)

Parameters

Parameter | Notes | Usage
lpDDInfo | Pointer to the Data Dictionary object to be duplicated. | Required.

Return Value

Return Value | Description
Pointer to the duplicate DD object |

Additional Notes

Should be destroyed by calling jdeDDFreeDuplicate.

See Also

  1. jdeDDFreeDuplicate


jdeDDDestroy

Last Modified: B733

jdeDDDestroy frees the memory allocated for the Data Dictionary specifications object created by jdeDDCreate

Syntax

void jdeDDDestroy(LPVOID lpDDInfo)

Parameters

Parameter | Notes | Usage
IpDDInfo | Pointer to the Data Dictionary object to be deleted. | Required.

Return Value

Return Value | Description
None | This does not return a value

Additional Notes

This function should be called for every call made to jdeDDCreate to free the allocated memory after the Data Dictionary specifications object is no longer required.

See Also

  1. jdeDDCreate


jdeDDFreeDuplicate

Last Modified: B733

jdeDDFreeDuplicate frees memory allocated by a jdeDDCreateDuplicate function call.

Syntax

void jdeDDFreeDuplicate(LPVOID lpDDInfo)

Parameters

Parameter | Notes | Usage
lpDDInfo | Pointer to the duplicate Data Dictionary object to be deleted. | Required.

Return Value

Return Value | Description
None | This does not return a value

Additional Notes

The lpDDInfo passed in should have been created by a call to jdeCreateDuplicate. It will free memory allocated by that API call.

See Also

  1. jdeDDCreateDuplicate


jdeDDFreeValue

Last Modified: B733

jdeDDFreeValue frees any memory allocated by jdeDDAllocGetValue.

Syntax

void jdeDDFreeValue(PJSTR lpValueToFree)

Parameters

Parameter | Notes | Usage
lpValueToFree | The memory value to free. | Required.

Return Value

Return Value | Description
None | This does not return a value

See Also

  1. jdeDDAllocGetValue


jdeDDLoadOverrides

Last Modified: B733

jdeDDLoadOverrides overrides the Data Dictionary default behavior. The DDOVERRIDES structure needs to be filled in with the appropriate information and then be passed into this API. The following is the DDOVERRIDES structure that needs to be filled in.

Layout

struct tagDDOVERRIDES

{

BOOL bAllowBlank;

BOOL bUpperCaseOnly;

unsigned short nDispDecimals;

unsigned long idEditBhvr;

unsigned long idSearchForm;

unsigned long idDispBhvr;

unsigned short nNextNumberIndex;

char szDfltValue[41];

char szNextNumberSystem[5];

char szAS400EditRule[7];

char szAS400EditParm1[41];

char szAS400EditParm2[41];

char szAS400DispRule[7];

char szAS400DispParm[41];

};

Syntax

void jdeDDLoadOverrides(LPVOID lpDDInfo, LPDDOVERRIDES lpDDOverrides)

Parameters

Parameter | Notes | Usage
lpDDInfo | Pointer to the Data Dictionary object. | Required.
lpDDOverrides | Pointer to override information. | Required.

Return Value

Return Value | Description
None | This does not return a value

Additional Notes

The following are the steps to use this API:

  1. Initialize a structure (just as a C structure) of type DDOVERRIDES.

  2. Fill in the structure with the desired overrides. If any field is not filled in then the default value for that information will be used from the original Data Dictionary specifications.

  3. Call this API passing the address of the instance of the DDOVERRIDES structure as its second parameter.

The override information will be copied into the data object.

See Also

  1. jdeDDSetOverrideFlags


jdeDDSetOverrideFlags

Last Modified: B733

jdeDDSetOverrideFlags disables the Data Dictionary default behavior and set the override flags for the data item.

Syntax

void jdeDDSetOverrideFlags(LPVOID lpDDInfo, DWORD dwFlags)

Parameters

Parameter | Notes | Usage
lpDDInfo | Pointer to the Data Dictionary object to be disabled. | Required
dwFlags | Override flag. | Required

Return Value

Return Value | Description
None | This does not return a value

Additional Notes

dwFlags may set with the following values:

  1. By default the Data Dictionary item could have one of the following rules attached to itself.

  2. This function needs to be called before calling jdeDDLoadOverrides.

Parameter | Override | Usage
Edit Rule | DD_NO_EDIT_RULE | Edit rule basically contains comparison information, for example, EQ for equal to, LT for less than, and so forth.
Default value | DD_NO_DEFAULT | Used to set no default value if one is available.
Next Numbering | DD_NO_NEXT_NUMBER | Used to turn next numbering off, if it is applicable to that data item.
Upper case | DD_NO_CASE | If upper case is applicable for this data item, then this override will cause the value not to convert to upper case.
Format rule | DD_NO_FORMAT_RULE | Used to turn off The Format rule, for example, A data item with DATE as its format rule can be overridden, by using this override flag.
Visual assist | DD_NO_VISUAL_ASSIST | May be used to do away with any visual assists.
 | DD_BYPASS_ALL | Used to override all the above cases.

The above override information needs to be “OR’ed” into the dwFlags and then the API may be called.

See Also

  1. jdeDDLoadOverrides


jdeDDSetValue

Last Modified: B733

jdeDDSetValue sets the value of the data object.

Syntax

void jdeDDSetValue(LPVOID lpDDInfo, LPVOID lpValue)

Parameters

Parameter | Parameter | Usage
lpDDInfo | Pointer to the Data Dictionary object. | Required
lpValue | Value to be set. | Required

Return Value

Return Value | Description
None | This does not return a value

Additional Notes

This is the value which will be stored in the Data Dictionary object.

See Also

  1. jdeDDIsValueValidated

  2. jdeDDValidateValue

  3. jdeDDValidateValueEx


jdeDDValidateValue

Last Modified: B733

jdeDDValidateValue validates the value stored in the data object which is tested against the Data Dictionary specifications for that item. This API calls jdeDDValidateValueEx to validate the value.

Syntax

ID jdeDDValidateValue(LPVOID lpDDInfo)

Parameters

Parameter | Notes | Usage
lpDDInfo | Pointer to the Data Dictionary object. | Required

Return Value

Return Value | Description
TRUE | The value has been validated against the DD specifications and is valid
FALSE | The value is not validated

See Also

  1. jdeDDIsValueValidated

  2. jdeDDSetValue

  3. jdeDDValidateValueEx


jdeDDValidateValueEx

Last Modified: B733

jdeDDValidateValueEx validates the value stored in the data object which is tested against the Data Dictionary specifications for that item. This API may be called to validate and retrieve the associated description for a particular Data Dictionary item.

Syntax

ID jdeDDValidateValueEx(LPVOID lpDDInfoTemp, LPVOID lpBhvrComm, LPVOID lpszDescriptionTemp,

LPVOID lpEventKeytemp, LPVOID lpSubTextDStemp, LPVOID lpErrInfo, ID idErrorMap)

Parameters

Parameter | Notes | Usage
lpDDInfoTemp | Pointer to the Data Dictionary object. | Required
lpBhvrComm | NULL |
lpszDescriptionTemp | A character array of 31 bytes, which will be loaded with the associated description. Pass a NULL pointer if associated description is not required. | Optional
lpEventKeytemp | NULL |
lpSubTextDStemp | NULL |
lpErrInfo | NULL |
idErrorMap |  |

Return Value

Return Value | Description
TRUE | The value has been validated against the DD specifications and is valid
FALSE | The value is not validated

Additional Notes

The third parameter, lpszDescription, should be a character array of size 31 bytes because the associated description is stored in the database as a description field, for example, DL01: Description field. This field is defined as size 31 bytes in the active Data Dictionary.

Example

char lpszDescription[31] = {0};

jdeDDValidateValueEx( lpDDInfo, NULL, lpszDescription, NULL, NULL, NULL);

The lpszDescription field will be loaded with the associated description if one is applicable for the data item in question.

See Also

  1. jdeDDIsValueValidated

  2. jdeDDSetValue

  3. jdeDDValidateValue


jdeDDValidation

Last Modified: B733

jdeDDValidation validates a particular data dictionary item. Mainly used by UBE and Business Functions.

Syntax

ID jdeDDValidation (LPBHVRCOM lpBhvrCom,LPVOID lpErrInfo, PJSTR lpszAlias,LPVOID lpValue,

PJSTR lpszDescription, ID idItem, DWORD dwFlags,LPDDOVERRIDES lpDDOverrides);

Parameters

Parameter | Notes | Usage
lpBhvrCom | his parameter is lpBhvrCom. |
lpErrInfo | This is the void parameter passed to a business function. NULL for UBE. |
lpszAlias | This is the data item to be validated against. NULL for UBE. |
lpValue | This is the value to be validated. |
lpszDescription | The description retrieved by the edit trigger. Can be NULL. |
idItem | This is the ID to be used when setting error messages. Data Dictionary ID for UBE. |
dwFlags | This flag is used to select the type of validation to be done. NULL means perform all edits. |
lpzDDOverrides | A structure that can be used to override various Data Dictionary fields. For example, run a different edit or format trigger for this edit. NULL means no overrides. |

Return Value

Return Value | Description
ID 0 = SUCCESS |

Example

BUSINESS FUNCTION CALLING METHOD

#include <ddval.h>

(Call with No Description, No Flags, No Overrides)

jdeDDValidation (lpBhvrCom, lpVoid, “CONV”, (LPVOID)&lpDS->mnConversionfactor, NULL, 1L, 0L, NULL);

(Call Using the DD_NO_DEFAULT flag)

{

lpszAlias char[11];

strcpy(lpszAlias, "UPMJ");

jdeDDValidation (lpBhvrCom, lpVoid, (LPSTR)lpszAlias, (LPVOID)&lpDS->jdDateupdated, 4L, DD_NO_DEFAULT);

}

(Call Using Description, Flags and Overrides)

{

DDOVERRIDES zDDOverrides;

lpszAlias char[11];

lpszDesc char[40];

strcpy(lpszAlias, "AN8");

strcpy(zDDOverrides.szDfltValue, “800”);

jdeDDValidation (lpBhvrCom, lpVoid, (LPSTR)lpszAlias, (LPVOID)&lpDS->mnAddressnumberd, lpszDesc, 4L, (DD_NO_NEXT_NUMBER | DD_NO_DEFAULT), &zDDOverrides);

}

UBE CALLING CONVENTION

#include <ddval.h>

MATH_NUMERIC mnNumber; (Value to Validate)

ID idDict = 908L; (DD id to Value)

(Call with no flags, no Desc, no Override)

jdeDDValidation(lpBhvrCom, NULL, NULL, (LPVOID)&mnNumber, NULL, idDict, 0L, NULL);

(Call with Flags)

jdeDDValidation(lpBhvrCom, NULL, NULL, (LPVOID)&mnNumber, NULL idDict, (DD_NO_NEXT_NUMBER | DD_NO_DEFAULT), NULL);

(Call with Flags, Description, Overrides)

{

char szDesc[40];

DDOVERRIDES zDDOverrides;

memset(&zDDOverrides, 0x00, size of(DDOVERRIDES));

strcpy(zDDOverrides. szDfltValue, “8008”);

jdeDDValidation(lpBhvrCom, NULL, NULL, (LPVOID)&mnNumber, szDesc, idDict, (DD_NO_NEXT_NUMBER | DD_NO_DEFAULT), &zDDOverrides);

}

Additional Notes

FLAGS:

DD_NO_EDIT_RULE Do not perform Edit (RANGE, Trigger, and so forth).

DD_NO_FORMAT_RULE Do not perform Format (*RAZ, *RAB, Trigger, and so forth).

DD_NO_DEFAULT Do not Load a Default Value.

DD_NO_NEXT_NUMBER Do not Load a Next Number.

DD_NO_CASE Do not convert lower to upper case if uppercase only flag is set in Data Dictionary.

DD_BYPASS_ALL Combination of all of the above.

OVERRIDES:

unsigned short nDispDecimals; /* Decimal positions of data item when displayed */

unsigned long idEditBhvr; /* Edit Behavior Function */

unsigned long idSearchForm; /* Search Form */

unsigned long idDispBhvr; /* Display Behavior Function */

unsigned short nNextNumberIndex; /* AS400 Next Number Index */

char szDfltValue[41]; /* Default value in AS400 format */

char szNextNumberSystem[5]; /* AS400 Next Number System */

char szAS400EditRule[7]; /* AS400 Edit Rule */

char szAS400EditParm1[41]; /* AS400 Edit Parameter 1 */

char szAS400EditParm2[41]; /* AS400 Edit Parameter 2 */

char szAS400DispRule[7]; /* AS400 Display Rule */

char szAS400DispParm[41]; /* AS400 Display Parameter */


jdeCurrency

jdeCurrency is a set of APIs used to manipulate and perform operations on data structures containing currency information. As data items and structures are processed, currency information is passed along and saved for any type of currency processing. These APIs enable you to handle currency processing without having to do any complex calculations.

jdeCurrency consist of the following APIs:

JDB_RetrieveF0010RowUsingCompanyNumber

JDB_RetrieveF0013RowUsingCurrencyCode

JDB_RetrieveF0025RowUsingLedgerType

jdeGetCurrencyCode

jdeGetDataBaseAction

jdeMathCopyCurrencyInfo

jdeMathSetCurrencyCode

jdeMathSetCurrencyDecimals

jdeUpdateMathCurrency

ParseNumericStringEx

ZeroMathNumericEx


JDB_RetrieveF0010RowUsingCompanyNumber

Last Modified: EnterpriseOne | June 06, 2000

JDB_RetrieveF0010RowUsingCompanyNumber retrieves a row from the F0010 table with the specified Company Number. The output row will be stored in the structure pointed by lpF0010.

Syntax

(JDEDB_RESULT)JDB_RetrieveF0010RowUsingCompanyNumber(HUSER hUser,LPF0010 lpF0010,char*lpCompanyNumber);

Parameters

Parameters | Notes | Usage
hUser | Valid User handle | Obtained from a call to JDB_InitUser.
lpF0010 | Pointer to F0010 table structure returned from the API |
lpCompanyNumber | Pointer to null terminated string containing a company number. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

  1. JDB_RetrieveF0013RowUsingCurrencyCode

  2. JDB_RetrieveF0025RowUsingLedgerType


JDB_RetrieveF0013RowUsingCurrencyCode

Last Modified: EnterpriseOne | June 06, 2000

JDB_RetrieveF0013RowUsingCurrencyCode retrieves a row from the F0013 table with the specified currency code. The output row will be stored in the structure pointed by lpF0013.

Syntax

(JDEDB_RESULT) JDB_RetrieveF0013RowUsingCurrencyCode (HUSER hUser ,LPF0013 lpF0013, char * lpCurrencyCode);

Parameters

Parameter | Notes | Usage
hUser | Valid User handle | Obtained from a call to JDB_InitUser.
lpF0013 | Pointer to F0013 table structure returned from the API |
lpCurrencyCode | Pointer to null terminated string containing a Currency Code. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

  1. JDB_RetrieveF0010RowUsingCompanyNumber

  2. JDB_RetrieveF0025RowUsingLedgerType


JDB_RetrieveF0025RowUsingLedgerType

Last Modified: EnterpriseOne | June 06, 2000

JDB_RetrieveF0025RowUsingLedgerType retrieves a row from the F0025 table with the specified LedgerType. The output row will be stored in the structure pointed by lpF0025.

Syntax

(JDEDB_RESULT) JDB_RetrieveF0025RowUsingLedgerType (HUSER hUser , LPF0025 lpF0025 , char * lpLedgerType);

Parameters

Parameter | Notes | Usage
hUser | Valid user handle | Obtained from a call to JDB_InitUser.
lpF0025 | Pointer to F0025 table structure returned from the API |
lpLedgerType | Pointer to null terminated string containing a Ledger Type. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

  1. JDB_RetrieveF0010RowUsingCompanyNumber

  2. JDB_RetrieveF0013RowUsingCurrencyCode


jdeGetCurrencyCode

Last Modified: EnterpriseOne Xe | June 07, 2000

jdeGetCurrencyCode returns the currency processing flag such as 'Y', 'N' or 'Z'.

Syntax

JCHAR jdeGetCurrencyCode (void);

Parameters

Parameter | Notes | Usage
None | There are no parameters associated with jdeGetCurrencyCode. |

Return Value

Returns one of the currency code values:

Code Value | Explanation
N | The currency is OFF
Y/Z | The currency is ON
Y | The domestic amount is calculated by multiplying the foreign amount by the exchange rate.
Z | The domestic amount is calculated by dividing the foreign amount by the exchange rate.

See Also

  1. jdeMathSetCurrencyCode

  2. jdeMathSetCurrencyDecimals

  3. jdeUpdateMathCurrency


jdeGetDataBaseAction

Last Modified: B733

jdeGetDataBaseAction returns the database action, such as JDB_FETCH, JDB_INSERT, JDB_UPDATE or JDB_DELETE.

Syntax

ID jdeGetDatabaseAction(LPBHVRCOM lpBhvrCom)

Parameters

Parameter | Notes | Usage
LpBhvrCom |  |

Return Value

Return Value | Description
Whatever action is being performed |

Example

If(nAction == JDB_FETCH || nAction == JDB_INSERT || nACTION == JDB_UPDATE)

Additional Notes

Pass the lpBhvrCom from within your business function.


jdeMathCopyCurrencyInfo

Last Modified: B733

jdeMathCopyCurrencyInfo copies the Currency Code and Currency Decimals from source to destination.

Syntax

(void)jdeMathCopyCurrencyInfo(MATH_NUMERIC* Dest, MATH_NUMERIC * Source);

Parameters

Parameter | Notes | Usage
* Dest | Target for the copy data. |
* Source | The source of the data. |

Return Value

Return Value | Description
None | This does not return a value

Example

ZeroMathNumeric(&mnWrkAmt);

JdeMathCopyCurrencyInfo(&mnWrkAmt,&lpDS->mnTaxableAmt);


jdeMathSetCurrencyCode

Last Modified: B733

jdeMathSetCurrencyCode updates only the Currency Code in the Math_Numeric structure.

Syntax

(void)jdeMathSetCurrencyCode(MATH_NUMERIC*Value, char*cCode)

Parameters

Parameter | Notes | Usage
Value |  |
Ccode |  |

Return Value

Return Value | Description
None | This does not return a value

Example

JdeMathSetCurrencyDecimals(&mnCurrency, nDecimals);

JdeMathSetCurrencyCode(&mnCurrency, (char * )dsF0013.cvcrd);

See Also

  1. jdeGetCurrencyCode

  2. jdeMathSetCurrencyDecimals

  3. jdeUpdateMathCurrency


jdeMathSetCurrencyDecimals

Last Modified: B733

jdeMathSetCurrencyDecimals updates only the Currency Decimals in the Math_Numeric structure.

Syntax

(void) jdeMathSetCurrencyDecimals(MATH_NUMERIC * Value, int nDecimals)

Parameters

Parameter | Notes | Usage
Value |  |
Ndecimals |  |

Return Value

Return Value | Description
None | This does not return a value

Example

JdeMathSetCurrencyCode(&mnCurrency,(char *)dsF0013.cvcrcd);

See Also

  1. jdeGetCurrencyCode

  2. jdeMathSetCurrencyCode

  3. jdeUpdateMathCurrency


jdeUpdateMathCurrency

Last Modified: B733

jdeUpdateMathCurrency updates the Currency Code and Currency Decimals in the Math_Numeric structure. If the nAction equals JDB_INSERT, this function will format the value based on the currency decimals before inserting into the database.

Syntax

void jdeUpdateMathCurrency (MATH_NUMERIC *pValue, int nDecimals, JCHAR * cCode, int nAction)

Parameters

Parameter | Notes | Usage
Pvalue |  |
Ndecimals |  |
Ccode |  |
Naction |  |

Return Value

Return Value | Description
None | This does not return a value

Example

*********************************************************

* Function: I03B0149_InitCurrency

*

* Notes:

*

* Returns:

*

* Parameters:

********************************************************/

int I03B0149_InitCurrency(HUSER hUser, MATH_NUMERIC * lpmnAmount, char * szCurrency)

{

JDEDB_RESULT eJDBReturn = JDEDB_PASSED;

char szDecimals[2] = {0};

int nDecimals = 0;

F0013 dsF0013 = {0};

/* Validate input parameters. */

if (IsStringBlank(szCurrency) == TRUE)

{

return (ER_ERROR);

}

/* Retrieve currency information and initialize return value. */

eJDBReturn = JDB_RetrieveF0013RowUsingCurrencyCode(hUser, &dsF0013, szCurrency);

if (eJDBReturn != JDEDB_PASSED)

{

return (ER_ERROR);

}

szDecimals[0] = dsF0013.cvcdec;

nDecimals = atoi(szDecimals);

ZeroMathNumeric(lpmnAmount);

jdeUpdateMathCurrency(lpmnAmount, nDecimals, szCurrency, JDB_INSERT);

return (ER_SUCCESS);

}

See Also

  1. jdeGetCurrencyCode

  2. jdeMathSetCurrencyCode

  3. jdeMathSetCurrencyDecimals


ParseNumericStringEx

Last Modified: B733

ParseNumericStringEx is the same as ParseNumericString except it includes the option to keep the Currency Information. Currency Information will not clear if the third parameter is equal to CURRENCY_KEEP.

Syntax

(MathErrorCode) ParseNumericStringEx (MATH_NUMERIC *t, char *s, int iFlag);

Parameters

Parameter | Notes | Usage
*t |  |
*s |  |
lflag |  |

Return Value

Return Value | Description
None | This does not return a value

Example

szTaxRate[iPosition] = '\0';

if ( !IsStringBlank (szTaxRate) )

{

switch ( iTaxPosition )

{

case 0 : jdeMathCopyCurrencyInfo(&mnTaxRate, &(lpDS->mnTaxRate1));

nDecimals = Decimals (&lpDS->mnTaxRate1);

break;

case 1 : jdeMathCopyCurrencyInfo(&mnTaxRate, &(lpDS->mnTaxRate2));

nDecimals = Decimals (&lpDS->mnTaxRate2);

break;

case 2 : jdeMathCopyCurrencyInfo(&mnTaxRate, &(lpDS->mnTaxRate3));

nDecimals = Decimals (&lpDS->mnTaxRate3);

break;

case 3 : jdeMathCopyCurrencyInfo(&mnTaxRate, &(lpDS->mnTaxRate4));

nDecimals = Decimals (&lpDS->mnTaxRate4);

break;

case 4 : jdeMathCopyCurrencyInfo(&mnTaxRate, &(lpDS->mnTaxRate5));

nDecimals = Decimals (&lpDS->mnTaxRate5);

break;

}

ParseNumericStringEx (&mnTaxRate, szTaxRate,CURRENCY_KEEP);

nStringDecimals = Decimals ( &mnTaxRate );

ParseNumericString (&mnThousand, "1000");

MathMultiply ( &mnTaxRate, &mnTaxRate, &mnThousand );

mnTaxRate.nDecimalPosition = (short) nDecimals;

if ( bSign == TRUE )

{

ReverseMathNumeric ( &mnTaxRate );

}

}

else

{

ZeroMathNumeric ( &mnTaxRate );

}

See Also

  1. ParseNumericString


ZeroMathNumericEx

Last Modified: B733

ZeroMathNumericEx is the same as ZeroMathNumeric but with option to keep the Currency Information.Currency Information will not clear if the second parameter is equal to CURRENCY_KEEP.

Syntax

void ZeroMathNumericEx (MATH_NUMERIC FAR *pZeroed, int iFlag)

Parameters

Parameter | Notes | Usage
*pZeroed |  |
lFlag |  |

Return Value

Return Value | Description
None | This does not return a value

See Also

  1. ZeroMathNumeric


jdeDate APIs

jdeDate

All dates in the EnterpriseOne database are stored in a JDEDATE structure. This allows the greatest flexibility for formatting the dates for a user.

Required Header Files

jdedate.h

Layout

typedef struct tagJDEDATE

{

short nYear;

short nMonth;

short nDay;

} JDEDATE. FAR *LPJDEDATE

Field | Description
nYear | Year portion of the date. All four digits, for example, 1997
nMonth | Month portion of the date, stored in a numeric representation, 1 = January, 2 = February, and so fort
nDay | Day portion of the date. Values must be between 1 and 31

Masks Available

Mask | Description
D | Day number, 1 or 2 digits
A | Day number, zero pad to 2 digits
Y | Day number, space pad to 2 digits
M | Month number, 1 or 2 digits
O | Month number, zero pad to 2 digits
N | Month number, space pad to 2 digits
T | Month number, by language, from UDC
B | Abbreviated month name, by language, from UDC
R | 2 digit year
E | 4 digit year
S | Date separator character (slash) , from configuration
C | Date separator character (comma), from configuration

jdeDate consist of the following APIs:

AdvanceDate

AdvanceOneDay

AdvanceOneMonth

DateDifference

DayOfTheWeek

DecrementOneDay

DecrementOneMonth

DeformatDate

FormatDate

IsJDEDATENull

IsLeapYear

JDEDATEToCentury

JDEDATEToCenturyAndYear

JDEDATEToday

JDEDATEToYear

NumberOfDays


AdvanceDate

Last Modified: B733

AdvanceDate takes in a date in JDEDATE form, a number of months, a number of days and returns the advanced (or decrement) date in JDEDATE form.

The month and day parameters have the following meaning:

Field | Description
nnn | Advance (or decrement) nnn days from source date
0 0 | Advance to the last day of the source month and year
nn 0 | Advance (or decrement nn months from source date
nn 1-31 | Advance (decrement) nn months from source date to a specific day of that month
nn -1 | Advance (or decrement) nn months from source date to the last day of that month

Syntax

short AdvanceDate (JDEDATE FAR *lpjdTarget, JDEDATE FAR *lpjdSource, long lMonthAdvance, Long lDayAdvance);

Parameters

Parameter | Notes | Usage
LpjdTarget | Pointer to target date to hold advance date. |
LpjdSource | Pointer to source date. |
LMonthAdvance | Number of months to advance source date. |
LDayAdvance | Number of days to advance. |

Return Value

Return Value | Description
JDEDATE_SUCCESSFUL | Return value if successful
JDEDATE_INVALIDDATE | Return value if the date is invalid

Example

JDEDATE jdToday;

JDEDATE jdDateTwo;

JDEDATEToday(&jdToday);

/* Advance the date 5 days. */

AdvanceDate (&jdDateTwo, &jdToday, 0, 5);

/* Advance a date 2 months */

AdvanceDate (&jdDateTwo, &jdToday, 2, 0);

/*Decrement a date 7 days */

AdvanceDate (&jdDateTwo, &jdToday, 0, -7);

/*Advance a date 4 months, 7 days */

AdvanceDate (&jdDateTwo, &jdToday, 4, 7);

Additional Notes

The caller needs to be aware of the resulting date's validity. If an advance to a day is outside of a month's maximum, it will be the last day of the month. In other invalid date cases, the date structure returned will be all zeros.

See Also

  1. AdvanceOneDay

  2. AdvanceOneMonth


AdvanceOneDay

Last Modified: B733

AdvanceOneDay advances the day in Georgian form by one day.

Syntax

JDEDATE AdvanceOneDay (JDEDATE jdDateIn);

Parameters

Parameter | Notes | Usage
JdDateIn | JDEDATE variable to advance. |

Return Value

Return Value | Description
JDEDATE with the date advanced by one day | Advanced date in Georgian form by one day

Example

JDEDATE jdToday;

JDEDATE jdTommorow;

JDEDATEToday(&jdToday);

jdTomorrow = AdvanceOneDay (jdToday)

See Also

  1. AdvanceDate

  2. AdvanceOneMonth

  3. DecrementOneDay


AdvanceOneMonth

Last Modified: B733

AdvanceOneMonth advances the month in Georgian form by one month.

Syntax

JDEDATE AdvanceOneMonth (JDEDATE jdDateIn);

Parameters

Parameter | Notes | Usage
jdDateIn | JDEDATE variable to advance. |

Return Value

Return Value | Description
JDEDATE with the date advanced by one month | Advanced date in Georgian form by one month

Example

JDEDATE jdToday;

JDEDATE jdMonthFromToday;

JDEDATEToday(&jdToday);

jdMonthFromToday = AdvanceOneMonth (jdToday)

See Also

  1. AdvanceDate

  2. AdvanceOneDay

  3. DecrementOneMonth


DateDifference

Last Modified: B733

DateDifference returns a long integer value that is the difference between two dates.

Syntax

long DateDifference (JDEDATE FAR *lpjdDateStart, JDEDATE FAR *lpjdDateEnd);

Parameters

Parameter | Notes | Usage
lpjdDateStart | Pointer to JDEDATE start date. |
lpjdDateEnd | Pointer to JDEDATE end date. |

Return Value

The number of days between the start date and end date.

Return Value | Description
0 | Days are the same
Negative number | End date is earlier than start date
Positive number | End date is later than start date

Example

JDEDATE jdDateOne;

JDEDATE jdDateTwo;

long lDayCount;

JDEDATEToday(&jdDateOne);

jdDateTwo = AdvanceOneMonth( jdDateOne);

lDayCount = DateDifference(jdDateOne, jdDateTwo);


DayOfTheWeek

Last Modified: B733

DayOfTheWeek returns the day of the week based upon the N value of a date.

Syntax

int DayOfTheWeek (long lDayOffset);

Parameters

Parameter | Notes | Usage
lDayOffset | This is obtained by CalcJD |

Return Value

Day of the week

Return Value | Description
0 | Sunday
1 | Monday
2 | Tuesday
3 | Wednesday
4 | Thursday
5 | Friday
6 | Saturday

Example

JDEDATE jdToday;

long 1DayOffset

int 1DayOfWeek;

JDEDATEToday(&jdToday);

1DayOffset = CalcN(jdToday);

lDayOfWeek = DayOfTheWeek(lDayOffset);

See Also

  1. NumberOfDays


DecrementOneDay

Last Modified: B733.2 | May 07, 1999

DecrementOneDay decrements the day in Georgian form by one day.

Syntax

JDEDATE DecrementOneDay (JDEDATE jdDateIn);

Parameters

Parameter | Notes | Usage
jdDateIn | JDEDATE variable to advance. |

Return Value

Return Value | Description
JDEDATE with the date decrement by one day | Decrements date in Georgian form by one day

Example

JDEDATE jdToday;

JDEDATE jdYesterday;

JDEDATEToday(&jdToday);

jdYesterday = DecrementOneDay (jdToday);

See Also

  1. AdvanceOneDay

  2. AdvanceDate


DecrementOneMonth

Last Modified: B733.2 | May 07, 1999

DecrementOneMonth decrements the month in Georgian form by one month.

Syntax

JDEDATE DecrementOneMonth (JDEDATE jdDateIn);

Parameters

Parameter | Notes | Usage
jdDateIn | JDEDATE variable to advance. |

Return Value

Return Value | Description
JDEDATE with the date decrement by one month | Decrements date in Georgian form by one month

Example

JDEDATE jdToday;

JDEDATE jdMonthBeforeToday;

JDEDATEToday(&jdToday);

jdMonthBeforeToday = DecrementOneMonth (jdToday);

See Also

  1. AdvanceOneMonth

  2. AdvanceDate

  3. JdeDate APIs


DeformatDate

Last Modified: B733

DeformatDate changes a date string into the JDEDATE format.

Syntax

short DeformatDate (JDEDATE *pFileDate, JCHAR *szDisplayDate, JCHAR *szFormatMask)

Parameters

Parameter | Notes | Usage
*pFileDate | Pointer to FILEDATE variable to format. |
*szDisplayDate | Date string. |
*szFormatMask | Mask indicating format of date input string. |

Return Value

Return Value | Description
None | This does not return a value

Example

JDEDATE jdDateOne;

char szDateOne[ ] = “03/10/1994\n”;

char szFormatMask[ ] = “OSASE”;

rc = DeformatDate (&jdDateOne, szDateOne, szFormatMask);

See Also

  1. FormatDate


FormatDate

Last Modified: B733

FormatDate formats an internal JDEDATE into a formatted string.

Syntax

short FormatDate (JCHAR *szDisplayDate, JDEDATE *pFileDate, JCHAR *szFormatMask)

Parameters

Parameter | Notes | Usage
*szDisplayDate | Pointer to string buffer for output. |
*pFileDate | Pointer to JDEDATE in. |
szFormatMask | Mask indicating format of date output string. |

Return Value

Return Value | Description
None | This does not return a value

Example

JDEDATE jdDateOne;

char szDateOne[13];

char szFormatMask[ ] = “OSASE”;

JDEDATEToday( &jdDateOne);

rc = FormatDate (szDateOne, &jdDateOne, szFormatMask);

See Also

  1. DeformatDate


IsJDEDATENull

Last Modified: B733

IsJDEDATENull tests if a JDEDATE is NULL.

Syntax

BOOL IsJDEDATENull( LPJDEDATE lpjdDate);

Parameters

Parameter | Notes | Usage
lpjdDate | Pointer to JDEDATE to test for NULL. |

Return Value

Return Value | Description
TRUE | The date is NULL
FALSE | The date is not NULL

Example

JDEDATE jdDateOne;

JDEDATEToday( &jdDateOe);

if ( IsJDEDATENull(&jdDateOne) )

{

/* date is null */

}

else

/* date is not null */

}

See Also

  1. IsLeapYear


IsLeapYear

Last Modified: B733

IsLeapYear determines if the year is a leap year, based upon a Georgian date.

Syntax

int IsLeapYear(JDEDATE jdDateIn);

Parameters

Parameter | Notes | Usage
jdDateIn | JDEDATE to test if leap year. |

Return Value

Return Value | Description
0 | It is a leap year
1 | It is not a leap year

Example

JDEDATE jdDateOne;

JDEDATEToday( &jdDateOe);

if ( IsLeapYear(jdDateOne) = 0 )

{

/* date is in leap year */

}

else

/* date is not in leap year */

}

See Also

  1. IsJDEDATENull


JDEDATEToCentury

Last Modified: B733.1 | June 08, 1999

JDEDATEToCentury gets the century from a JDEDATE and returns it in a Math_Numeric.

Syntax

enum MathErrorCode JDEDATEToCentury( LPJDEDATE lpjdDate, LPMATH_NUMERIC lpmnCentury);

Parameters

Parameter | Notes | Usage
lpjdDate | Pointer to input JDEDATE. |
lpmnCentury | Pointer to Math_Numeric variable to store century. |

Return Value

Return Value | Description
MATH_SUCCESS | If successful
A MathErrorCode | If not successful

Example

JDEDATE jdToday;

MATH_NUMERIC mnCentury;

JDEDATEToday( &jdToday);

JDEDATEToCentury( &jdToday, &mnCentury);

Additional Notes

The math_numeric value that is resulted from the API is not the century, but a value of 1 less than the century. For instance, it gives back 19 for 6/1/1999. It gives the first digits of a 4-digit year.

See Also

  1. JDEDATEToCenturyAndYear

  2. JDEDATEToday

  3. JDEDATEToYear


JDEDATEToCenturyAndYear

Last Modified: B733.1 | June 08, 1999

JDEDATEToCenturyAndYear gets the year and century from a JDEDATE and returns them in Math_Numeric fields.

Syntax

enum MathErrorCode JDEDATEToCenturyAndYear( LPJDEDATE lpjdDate, LPMATH_NUMERIC lpmnCentury, LPMATH_NUMERIC lpmnYear);

Parameters

Parameter | Notes | Usage
lpjdDate | Pointer to input JDEDATE. |
lpmnCentury | Pointer to Math_Numeric variable to store century. |
lpmnYear | Pointer to Math_Numeric variable to store year. |

Return Value

Return Value | Description
MATH_SUCCESS | If successful
A MathErrorCode | If not successful

Example

JDEDATE jdToday;

MATH_NUMERIC mnCentury;

MATH_NUMERIC mnYear;

JDEDATEToday( &jdToday);

JDEDATEToCenturyAndYear( &jdToday, &mnCentury, &mnYear);

Additional Notes

The math_numeric value that is resulted from the API is not the century, but a value of 1 less than the century. For instance, it gives back 19 for 6/1/1999. It gives the first digits of a 4-digit year.

See Also

  1. JDEDATEToCentury

  2. JDEDATEToday

  3. JDEDATEToYear


JDEDATEToday

Last Modified: B733

JDEDATEToday formats a JDEDATE with current date.

Syntax

void JDEDATEToday( LPJDEDATE lpjdDate);

Parameters

Parameter | Notes | Usage
lpjdDate | Pointer to JDEDATE to format with today’s date. |

Return Value

Return Value | Description
None | This does not return a value

Example

JDEDATE jdToday;

JDEDATEToday( &jdToday);

See Also

  1. JDEDATEToCentury

  2. JDEDATEToCenturyAndYear

  3. JDEDATEToYear


JDEDATEToYear

Last Modified: B733

JDEDATEToYear gets the year from a JDEDATE and returns it in a Math_Numeric.

Syntax

enum MathErrorCode JDEDATEToYear( LPJDEDATE lpjdDate, LPMATH_NUMERIC lpmnYear);

Parameters

Parameter | Notes | Usage
lpjdDate | Pointer to input JDEDATE. |
lpmnYear | Pointer to Math_Numeric variable to store year. |

Return Value

Return Value | Description
MATH_SUCCESS | If successful
A MathErrorCode | If not successful

Example

JDEDATE jdToday;

MATH_NUMERIC mnYear;

JDEDATEToday( &jdToday);

JDEDATEToCenturyAndYear( &jdToday, &mnYear);

See Also

  1. JDEDATEToCentury

  2. JDEDATEToCenturyAndYear

  3. JDEDATEToday


NumberOfDays

Last Modified: B733

NumberOfDays is a function to find the number of days in a month based upon a Gregorian date.

Syntax

int NumberOfDays(LPJDEDATE jdDateIn);

Parameters

Parameter | Notes | Usage
JdDateIn | JDEDATE variable. |

Return Value

Return Value | Description
Number of days in the month of the given JDEDATE |

Example

JDEDATE jdDateOne;

int nDaysThisMonth;

JDEDATEToday(&jdDateOne);

nDaysThisMonth = NumberOfDays( jdDateIn);

See Also

  1. DayOfTheWeek

  2. JdeDate APIs


LinkList APIs

LinkList

LinkList APIs is used to create and manipulate a doubly linked list.

Layout

typedef struct

{

char FAR *SortKey;

void FAR *ptrParent;

void FAR *ptrChild;

void FAR *ptrData;

} LINKLISTNODE, FAR * LPLINKLISTNODE.

typedef struct

}

LINKLISTNODE FAR *ptrFirstItem;

LINKLISTNODE FAR *ptrLastItem;

LINKLISTNODE FAR *ptrCurrentItem;

LINKLISTNODE FAR * LPLINKLIST;

typedef struct

}

char FAR *SortKey;

void FAR *ptrData;

} LINKLISTITEM, FAR * LPLINKLISTITEM;

LinkList consist of the following APIs:

app.gif (808 bytes) | AddLinkListItemSorted
 | AddLinkListItem
app.gif (808 bytes) | CreateLinkList
app.gif (808 bytes) | DeleteLinkListItem
app.gif (808 bytes) | DestroyLinkList
app.gif (808 bytes) | GetFirstLinkListItem
app.gif (808 bytes) | GetLinkListItem
app.gif (808 bytes) | GetNextLinkListItem
app.gif (808 bytes) | GetPrevLinkListItem


AddLinkListItem

Last Modified: B733

AddLinkListItem adds an item to a link list. Prior to calling this function, the LINKLISTITME structure allocated by the calling program has the pointer SortKey set to a character string and the pointer ptrData set to a data structure. The item is added after the item currently selected (ptrCurrentItem). If ptrCurrentItem is NULL, the item is added at the head of the list. The function allocates memory for a copy of SortKey (null terminated string) and the data pointed to by ptrData and copies the values passed through LINKLISTITEM to the memory it allocates.

Syntax

void FAR * AddLinkListItem (LinkList FAR *, LINKLISTITEM FAR *, unsigned short);

Parameters

Parameter | Notes | Usage
LINKLIST FAR * | Pointer to LinkList structure. |
LINKLISTITEM FAR * | Pointer to LINKLISTITEM structure that contains item to be added. |
unsigned short | Integer value containing the size of the data structure pointed to by ptrData in the LINKLISTITEM structure. |

Return Value

Return Value | Description
A pointer to the memory location of the copied date | The allocation was successful
NULL | The allocation failed

See Also

  1. AddLinkListItemSorted

  2. DeleteLinkListItem

  3. GetFirstLinkListItem

  4. GetLinkListItem

  5. GetNextLinkListItem

  6. GetPrevLinkListItem


AddLinkListItemSorted

Last Modified: B733

AddLinkListItemSorted adds an item to a link list. Prior to calling this function, the LINKLISTITME structure allocated by the calling program has the pointer SortKey set to a character string and the pointer ptrData set to a data structure. The item is added after the item currently selected (ptrCurrentItem). If ptrCurrentItem is NULL, the item is added at the head of the list. The function allocates memory for a copy of SortKey (null terminated string) and the data pointed to by ptrData and copies the values passed through LINKLISTITEM to the memory it allocates. The function returns a pointer to the memory location of the copied data if successful. The pointer is NULL if the allocation fails.

Syntax

void FAR * AddLinkListItemSorted (LINKLIST FAR *, LINKLISTITEM FAR *, unsigned short);

Parameters

Parameter | Notes | Usage
LINKLIST FAR * | Pointer to LinkList structure. |
LINKLISTITEM FAR * | Pointer to LINKLISTITEM structure that contains item to be added. |
unsigned short | Integer value containing the size of the data structure pointed to by ptrData in the LINKLISTITEM structure. |

Return Value

Return Value | Description
A pointer to the memory location of the copied date | The allocation was successful
NULL | The allocation failed

See Also

  1. AddLinkListItem

  2. DeleteLinkListItem

  3. GetFirstLinkListItem

  4. GetLinkListItem

  5. GetNextLinkListItem

  6. GetPrevLinkListItem


CreateLinkList

Last Modified: B733

CreateLinkList creates a link list structure and returns the address of that structure to the calling program.

Syntax

LINKLIST FAR * CreateLinkList (void);

Parameters

None

Return Value

  1. The function returns a pointer to the memory location of the LinkList structure if successful.

  2. The pointer is NULL if the allocation fails.

See Also

  1. DestroyLinkList


DeleteLinkListItem

Last Modified: B733

DeleteLinkListItem deletes an item from a link list. The function uses one argument, a pointer to a structure of type LinkList.

Syntax

BOOL DeleteLinkListItem (LINKLIST FAR *);

Parameters

Parameter | Notes | Usage
LINKLIST FAR * | Pointer to LinkList structure. |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | The request was not successful

Additional Notes

Prior to calling this function, the pointer ptrCurrentItem in the LinkList structure must be set through a call to one of these functions.

  1. GetFirstLinkListItem (LINKLIST * , LINKLISTITEM*);

  2. GetLinkListItem (LINKLIST * , LINKLISTITEM *, LINKLISTNODE *);

  3. GetNextLinkListItem (LINKLIST * , LINKLISTITEM*);

The function also frees the memory pointed to by ptrData and SortKey in LINKLISTNODE.

See Also

  1. AddLinkListItemSorted

  2. AddLinkListItem

  3. GetFirstLinkListItem

  4. GetLinkListItem

  5. GetNextLinkListItem

  6. GetPrevLinkListItem

  7. Using LinkList APIs


DestroyLinkList

Last Modified: B733

DestroyLinkList frees all memory allocated for a linked list including the memory pointed to by ptrData and SortKey. However, you must free any memory for any pointers that are contained within the memory space pointed to by ptrData prior to calling this function.

Syntax

BOOL DestroyLinkList (LINKLIST FAR *);

Parameters

Parameter | Notes | Usage
LINKLIST | Pointer to LinkList structure created with CreateLinkList. |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | The request was not successful

See Also

  1. CreateLinkList

  2. Using LinkList APIs


GetFirstLinkListItem

Last Modified: B733

GetFirstLinkListItem returns the first item in a link list.

Syntax

BOOL GetFirstLinkListItem (LINKLIST FAR * LINKLISTITEM FAR *);

Parameters

Parameter | Notes | Usage
LINKLIST FAR * | Pointer to LinkList structure. |
LINKLISTITEM FAR * | Pointer to LINKLISTITEM structure allocated by calling program. |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | The request was not successful

See Also

  1. AddLinkListItemSorted

  2. AddLinkListItem

  3. DeleteLinkListItem

  4. GetLinkListItem

  5. GetNextLinkListItem

  6. GetPrevLinkListItem

  7. Using LinkList APIs


GetLinkListItem

Last Modified: B733

GetLinkListItem returns an item in a link list

Syntax

BOOL GetLinkListItem (LINKLIST FAR * LINKLISTITEM FAR * LINKLISTNODE FAR*);

Parameters

Parameter | Notes | Usage
LINKLIST FAR * | Pointer to LinkList structure. |
LINKLISTITEM FAR * | Pointer to LINKLISTITEM structure allocated by calling program. |
LINKLISTNODE FAR * | Pointer to LINKLISTNODE structure (retrieved from ptrCurrent in LinkList structure). |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | The request was not successful

See Also

  1. AddLinkListItemSorted

  2. AddLinkListItem

  3. DeleteLinkListItem

  4. GetFirstLinkListItem

  5. GetNextLinkListItem

  6. GetPrevLinkListItem

  7. Using LinkList APIs


GetNextLinkListItem

Last Modified: B733

GetNextLinkListItem returns the next item in a link list.

Syntax

BOOL GetNextLinkListItem (LINKLIST FAR * LINKLISTITEM FAR *);

Parameters

Parameter | Notes | Usage
LINKLIST FAR * | Pointer to LinkList structure. |
LINKLISTITEM FAR * | Pointer to LINKLISTITEM structure allocated by calling program. |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | The request was not successful

See Also

  1. AddLinkListItemSorted

  2. AddLinkListItem

  3. DeleteLinkListItem

  4. GetFirstLinkListItem

  5. GetLinkListItem

  6. GetPrevLinkListItem

  7. Using LinkList APIs


GetPrevLinkListltem

Last Modified: B733

GetPrevLinkListltem returns the previous item in a link list.

Syntax

BOOL GetPrevLinkListItem (LINKLIST *LinkList, LINKLISTITEM *LinkListItem)

Parameters

Parameter | Notes | Usage
*LinkList | Pointer to LinkList structure. |
*LinkListItem | Pointer to LINKLISTITEM structure allocated by calling program. |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | The request was not successful

See Also

  1. AddLinkListItemSorted

  2. AddLinkListItem

  3. DeleteLinkListItem

  4. GetFirstLinkListItem

  5. GetLinkListItem

  6. GetNextLinkListItem

  7. Using LinkList APIs


MATH_NUMERIC

There are no numeric values stored within the EnterpriseOne database. Numeric values are stored as a MATH_NUMERIC data type. A MATH_NUMERIC is a structure that contains all the required information to execute mathematical operations on a stored value. This data type allows the attributes of a number to be stored directly with the value, providing greater flexibility when formatting the number for display.

Required Header Files

jdemath.h (Including abhvr.h, will indirectly include jdemath.h).

Layout

typedef struct tagMATH_NUMERIC

{

char String[MAXLEN_MATH_NUMERIC+1];

char Sign;

char EditCode;

short nDecimalPosition

short nLength

} MATH_NUMERIC. FAR *LPMATH_NUMERIC

Field | Description
String | Contains the actual digits of the value stored in this structure, without any formatting characters. For example, 1,234.56 would be represented as a character string 123456.
Sign | Specifies whether the stored number is positive or negative.
EditCode | Contains the edit that will be performed against the string value before it is displayed.
NDecimal Position | Contains the number of digits that will appear on the right side of the decimal point.
Nlength | Contains the total length of the number.

MATH_NUMERIC consist of the following APIs:

 | FormatMathNumeric
app.gif (808 bytes) | IncrementMathNumeric
 | IntTomathNumeric
app.gif (808 bytes) | LongTomathNumeric
 | MathAdd
app.gif (808 bytes) | MathCompare
 | MathCompareAbsolute
app.gif (808 bytes) | MathCopy
 | MathDivide
 | MathExecuteRoundingRule
 | MathExecuteRoundingRuleEx
app.gif (808 bytes) | MathNumericToInt
 | MathNumericToLong
 | MathRound
 | MathStringtoLong
app.gif (808 bytes) | MathSubtract
 | MathZeroTest
app.gif (808 bytes) | ParseNumericString
 | ReverseMathNumeric
app.gif (808 bytes) | ZeroMathNumeric


FormatMathNumeric

Last Modified: B733

FormatMathNumeric Formats a JDE MATH_NUMERIC into a fully formatted string, ready for output.

Syntax

void FormatMathNumeric (JCHAR FAR *s, MATH_NUMERIC FAR *a)

Parameters

Parameter | Notes | Usage
jchar FAR *s | Pointer to output string. |
MATH_NUMERIC FAR *a | Pointer to Math_Numeric variable. |

Return Value

Return Value | Description
None | This does not return a value

Example

char szString[MAXLEN_MATH_NUMERIC;

Math_Numeric mnMathNumeric;

ParseNumericString(&mnMathNumeric, “123”);

FormatMathNumeric( szString, &mnMathNumeric);

/* szString will now contain the value “123” */


IncrementMathNumeric

Last Modified: B733

IncrementMathNumeric Increments or decrements a referenced MATH_NUMERIC by one.

Syntax

void IncrementMathNumeric (LPMATH_NUMERIC lpIncremented, int nIncrement);

Parameters

Parameter | Notes | Usage
lpIncremented | Pointer to Math_Numeric variable to be incremented. |
nIncrement | Flag to indicate if incrementing or decrementing by one. Use a 1 to increment, a -1 to decrement. |

Return Value

Return Value | Description
None | This does not return a value

Example

MATH_NUMERIC mnMathNumeric;

ParseNumericString( &mnMathNumeric, “123”);

/* Increment a given MATH_NUMERIC by one */

IncrementMathNumeric(&mnMathNumeric, 1);

/* the value of mnMathNumeric is now 124 */

/*Decrement a given MATH_NUMERIC by one * /

IncrementMathNumeric( &mnMathNumeric, -1);

/* the value of mnMathNumeric is now 123 */


IntToMathNumeric

Last Modified: B733

IntToMathNumeric converts an integer to a MATH_NUMERIC.

Syntax

enum MathErrorCode IntToMathNumeric(int nNumberIn, LPMATH_NUMERIC lpmnMathOut);

Parameters

Parameter | Notes | Usage
nNumberIn | Integer input. |
lpmnMathOut | Pointer to Math_Numeric variable to be formatted. |

Return Value

Return Value | Description
MATH_SUCCESSFUL | It was successful
MathErrorCode | It was not successful

Example

int nNumber = 200;

MATH_NUMERIC mnMathNumeric;

int nMathReturn;

nMathReturn = IntToMathNumeric(nNumber, &mnMathNumeric);

/*mnMathNumeric should now have the value 200 */

Additional Notes

Currently not ANSI C.

See Also

  1. LongToMathNumeric

  2. MathNumericToInt

  3. MathNumericToLong


LongToMathNumeric

Last Modified: B733

LongToMathNumeric converts a long to a MATH_NUMERIC.

Syntax

MATHERRORCODE LongToMathNumeric (long lNumberIn, LPMATH_NUMERIC lpmnMathOut)

Parameters

Parameter | Notes | Usage
lNumberIn | Long input. |
LpmnMathOut | Pointer to Math_Numeric variable to be formatted. |

Return Value

Return Value | Description
MATH_SUCCESSFUL | It was successful
MathErrorCode | It was not successful

Example

Long lNumber = 23456789L;

MATH_NUMERIC mnMathNumeric;

int nMathReturn;

nMathReturn = LongToMathNumeric(lNumber, &mnMathNumeric);

/* mnMathNumeric should now have the value 23456789 */

Additional Notes

Currently not ANSI C.

See Also

  1. IntToMathNumeric

  2. MathNumericToInt

  3. MathNumericToLong


MathAdd

Last Modified: B733

MathAdd adds parameter two to parameter three and returns the sum in parameter one. All parameters are JDE_NUMERIC data types.

Syntax

MATHERRORCODE MathAdd (MATH_NUMERIC FAR *pSum, MATH_NUMERIC FAR *Addend0,

MATH_NUMERIC FAR *Addend1)

Parameters

Parameter | Notes | Usage
*pSum | Pointer to Math_Numeric variable to store result of add |
*Addend0 | Pointer to first Math_Numeric variable to add |
*Addend1 | Pointer to second Math_Numeric variable to add |

Return Value

Return Value | Description
MATH_SUCCESSFUL | It was successful
MathErrorCode | It was not successful

Example

MATH_NUMERIC mnMathOne;

MATH_NUMERIC mnMathTwo;

MATH_NUMERIC mnMathSum;

int nMathReturn;

LongToMathNumeric( 200000L, &mnMathOne);

LongToMathNumeric( 300000L, &mnMathTwo);

nMathReturn = MathAdd( &mnMathSum, &mnMathOne, &mnMathTwo);

/* mnMathSum should now have the value 500000 */

See Also

  1. MathCompare

  2. MathCompareAbsolute

  3. MathCopy

  4. MathDivide

  5. MathMultiply

  6. MathRound

  7. MathSubtract


MathCompare

Last Modified: B733

MathCompare returns a “1” if parameter one is greater than parameter two; returns a “-1” if parameter two is greater than parameter one. Both parameters are JDE_NUMERIC data types.

Syntax

enum MathErrorCode MathCompare (LPMATH_NUMERIC lpmnValue0. LPMATH_NUMERIC 1pmnValue1);

Parameters

Parameter | Notes | Usage
lpmn | Pointer to first Math_Numeric variable to compare. |
lpmnValue1 | Pointer to second Math_Numeric variable to compare. |

Return Value

Return Value | Description
0 | if lpmnValue0 = lpmnValue1
<0 | if lpmnValue0 <lpmnValue1
>0 | if lpmnValue0> lpmnValue1

Example

MATH_NUMERIC mnMathOne;

MATH_NUMERIC mnMathTwo;

LongToMathNumeric( 200000L, &mnMathOne);

LongToMathNumeric( 300000L, &mnMathTwo);

if ( MathCompareAbsolute( &mnMathOne, &mnMathTwo) = 0 )

{

/* mnMathOne and mnMathTwo are equal */

}

else

{

/* mnMathOne and mnMathTwo are not equal */

}

See Also

  1. MathAdd

  2. MathCompareAbsolute

  3. MathCopy

  4. MathDivide

  5. MathMultiply

  6. MathRound

  7. MathSubtract


MathCompareAbsolute

Last Modified: B733

MathCompareAbsolute is the same as MathCompare, except that it compares the absolute value of the parameters, for example, -123 would be greater than +100.

Syntax

enum MathErrorCode MathCompareAbsolute (LPMATH_NUMERIC lpmnValue0. LPMATH_NUMERIC 1pmnValue1);

Parameters

Parameter | Notes | Usage
lpmnValue0 | Pointer to first Math_Numeric variable to compare |
lpmnValue1 | Pointer to second Math_Numeric variable to compare. |

Return Value

Return Value | Description
0 | if lpmnValue0 = lpmnValue1
<0 | if lpmnValue0 <lpmnValue1
>0 | if lpmnValue0> lpmnValue1 (sign is disregarded).

Example

MATH_NUMERIC mnMathOne;

MATH_NUMERIC mnMathTwo;

LongToMathNumeric( 200000L, &mnMathOne);

LongToMathNumeric(-200000L, &mnMathTwo);

if ( MathCompareAbsolute( &mnMathOne, &mnMathTwo) = 0 )

{

/* the absolute values of mnMathOne and mnMathTwo are equal */

}

else

{

/* the absolute values of mnMathOne and mnMathTwo are not equal */

}

See Also

  1. MathAdd

  2. MathCompare

  3. MathCopy

  4. MathDivide

  5. MathMultiply

  6. MathRound

  7. MathSubtract


MathCopy

Last Modified: B733

MathCopy copies the value of a source MATH_NUMERIC value (parameter two) to a destination MATH_NUMERIC value (parameter one).

Syntax

enum MathErrorCode MathCopy (LPMATH_NUMERIC lpmnDest, LPMATH_NUMERIC lpmnSource);

Parameters

Parameter | Notes | Usage
lpmnDest | Pointer to Math_Numeric variable to copy to. |
lpmnSour | Pointer to Math_Numeric to copy from. |

Return Value

Return Value | Description
MATH_SUCCESSFUL | It was successful
MathErrorCode | It was not successful

Example

MATH_NUMERIC mnMathOne;

MATH_NUMERIC mnMathTwo;

int nMathReturn;

ParseNumericString( &mnMathOne. “567”);

nMathReturn = MathCopy( &mnMathtwo, &mnMathOne);

/* mnMathTwo should now have the same values as mnMathOne */

See Also

  1. MathAdd

  2. MathCompare

  3. MathCompareAbsolute

  4. MathDivide

  5. MathMultiply

  6. MathRound

  7. MathSubtract


MathDivide

Last Modified: B733

MathDivide Divides parameter three by parameter four and places the quotient in parameter one. The remainder is placed in parameter two. All parameters are JDE_NUMERIC data types.

Syntax

MATHERRORCODE MathDivide(MATH_NUMERIC FAR *pQuotient, MATH_NUMERIC FAR

*pRemainder, MATH_NUMERIC FAR *pDnd, MATH_NUMERIC FAR *pDsr, int FAR

*iDecimals, int FAR *iRounded)

Parameters

Parameter | Notes | Usage
FAR *pQuotient | Pointer to Math_Numeric variable for the quotient. |
FAR *pRemainder | Pointer to Math_Numeric variable for the remainder. |
FAR *pDnd | Pointer to Math_Numeric variable to divide. |
FAR *pDsr | Pointer to Math_Numeric variable to divide by. |
FAR *iDecimals | Pointer to the number of decimals to round to. |
FAR *iRounded | Pointer to the flag indicating whether or not to round: 1 = no; 0 = yes. |

Return Value

Return Value | Description
MATH_SUCCESSFUL | It was successful
MathErrorCode | It was not successful

Example

MATH_NUMERIC mnQuotient;

MATH_NUMERIC mnRemainder;

MATH_NUMERIC mnMathOne;

MATH_NUMERIC mnMathTwo;

int nDecimals = 2;

int nRoundFlag = 1;

ParseNumericString(&mnMathOne. “45”);

ParseNumericString(&mnMathOne. “9”);

nMathReturn = MathDivide(&mnQuotient, &mnRemainder, &mnMathOne,&mnMathTwo, &nDecimals, &nRoundFlag);

/* mnQuotient should be 5.00 */

See Also

  1. MathAdd

  2. MathCompare

  3. MathCompareAbsolute

  4. MathCopy

  5. MathMultiply

  6. MathRound

  7. MathSubtract


MathAdd

MathExecuteRoundingRule

Last Modified: ERP9.0

MathExecuteRoundingRule will round a given value based on a rule defined by the Math Rounding Rules Engine.

The first parameter is a JCHAR* the rest are MATH_NUMERIC data types.

Syntax

enum MATHERRORCODE MathExecuteRoundingRule(JCHAR* ruleName, MATH_NUMERIC FAR * pmnOrigVal , MATH_NUMERIC FAR * pmnRoundedVal, MATH_NUMERIC FAR * pmnDifference)

Parameters

Parameter | Notes | Usage
ruleName | Name of Rounding Rule defined in F95701 table. |
pmnOriginalVal | Value to be rounded based on rule |
pmnRoundedVal | Rounded value |
pmnDifference | If valid pointer will contain the difference between the rounded value and original value. |

Return Value

Return Value | Description
MATH_SUCCESSFUL | It was successful
MathErrorCode | It was not successful

Example

MATH_NUMERIC mnOrig;

MATH_NUMERIC mnRounded;

MATH_NUMERIC mnDiff;

JCHAR ruleName[] = “RULE1”;

int nMathReturn;

nMathReturn = MathExecuteRoundingRule(&ruleName[0], & mnOrig, & mnRounded, & mnDiff);

/* mnRounded should now have the rounded value based on the rule. MnDiff will contain the difference between mnRounded, and mnOrig */

See Also

1. MathCompare

2. MathCompareAbsolute

3. MathCopy

4. MathDivide

5. MathMultiply

6. MathRound

7. MathSubtract

8. MathExecuteRoundingRuleEx


MathExecuteRoundingRuleEx

Last Modified: ERP9.0

MathExecuteRoundingRuleEx will round a given value based on a rule defined by the Math Rounding Rules Engine.

The first parameter is a JCHAR* the last is a BOOLEAN, the rest are MATH_NUMERIC data types.

Syntax

MATHERRORCODE MathExecuteRoundingRuleEx(JCHAR *ruleName, MATH_NUMERIC FAR * pmnOrigVal , MATH_NUMERIC FAR * pmnRoundedVal, BOOLEAN bUseCache)

Parameters

Parameter | Notes | Usage
*ruleName | Name of Rounding Rule defined in F95701 table. |
*pmnOriginalVal | Value to be rounded based on rule |
*pmnRoundedVal | Rounded value |
bUseCache | If TRUE will use the cached rule, if FALSE will fetch the rule from the F95701 table. |

Return Value

Return Value | Description
MATH_SUCCESSFUL | It was successful
MathErrorCode | It was not successful

Example

MATH_NUMERIC mnOrig;

MATH_NUMERIC mnRounded;

MATH_NUMERIC mnDiff;

JCHAR ruleName[] = “RULE1”;

int nMathReturn;

BOOLEAN bUseCache = TRUE;

nMathReturn = MathExecuteRoundingRuleEx(&ruleName[0], & mnOrig, & mnRounded, & mnDiff, bUseCache);

/* mnRounded should now have the rounded value based on the rule. MnDiff will contain the difference between mnRounded, and mnOrig */

See Also

1. MathCompare

2. MathCompareAbsolute

3. MathCopy

4. MathDivide

5. MathMultiply

6. MathRound

7. MathSubtract

8. MathExecuteRoundingRule


MathNumericToInt

Last Modified: B733.1 | June 08, 1999

MathNumericToInt converts a MATH_NUMERIC into an integer (int). For example, when you pass in 1.9, it is treated as 1.

Syntax

enum MathErrorCode MathNumericToInt(LPMATH_NUMERIC lpmnMathIn, LPINT lpmnNumberOut);

Parameters

Parameter | Notes | Usage
LpmnMathIn | Pointer to Math_Numeric variable to input. |
LpmnNumberOut | Pointer to integer for output. |

Return Value

Return Value | Description
MATH_SUCCESSFUL | It was successful
MathErrorCode | It was not successful

Example

MATH_NUMERIC mnMathOne;

int nNumber;

int nMathReturn;

nMathReturn = ParseNumericString (&mnMathOne, “487”);

nMathReturn = MathNumericToInt( &mnMathOne, &nNumber);

See Also

  1. IntToMathNumeric

  2. LongToMathNumeric

  3. MathNumericToLong


MathNumericToLong

Last Modified: B733

MathNumericToLong converts a MATH_NUMERIC to a long (checks that MATH_NUMERIC does not have decimals).

Syntax

enum MathErrorCode MathNumericToLong(LPMATH_NUMERIC lpmnMathIn, LPLONG lpmnNumberOut);

Parameters

Parameter | Notes | Usage
LpmnMathIn | Pointer to Math_Numeric variable to input. |
LpmnNumberOut | Pointer to long for output. |

Return Value

Return Value | Description
MATH_SUCCESSFUL | It was successful
MathErrorCode | It was not successful

Example

MATH_NUMERIC mnMathOne;

long 1Number;

int nMathReturn;

nMathReturn = ParseNumericString (&mnMathOne, “487.98”);

nMathReturn = MathNumericToLong(&mnMathOne, &1Number);

/* Conversion will only happen if the MATH_Numeric input has no decimals */

See Also

  1. IntToMathNumeric

  2. LongToMathNumeric

  3. MathNumericToInt


MathRound

Last Modified: EnterpriseOne Xe | May 10, 2000

MathRound rounds a JDE_NUMERIC passed in parameter two to the specified number of digits passed in parameter three. The result is returned in parameter one.

Syntax

enum MathErrorCode MathRound (LPMATH_NUMERIC lpmnRounded, LPMATH_NUMERIC lpmnMathIn, int FAR * lpnDecimals);

Parameters

Parameter | Notes | Usage
lpmnRounded | Pointer to Math_Numeric variable to input. |
lpmnMathIn | Pointer to Math_Numeric variable to round |
lpnDecimals | Pointer to the number of decimals to round to. |

Return Value

Return Value | Description
MATH_SUCCESSFUL | It was successful
MathErrorCode | It was not successful

Example

MATH_NUMERIC mnMathOne;

Int mnDecimalsToRound;

MATH_NUMERIC mnMathRounded;

int nMathReturn;

ParseNumericString(&mnMathOne. “12.45678”);

nDecimalsToRound = 3;

nMathReturn = MathRound(&mnMathRounded, &mnMathOne, &nDecimalsToRound);

/* mnMathRounded should be 12.457 */

See Also

  1. MathAdd

  2. MathCompare

  3. MathCompareAbsolute

  4. MathCopy

  5. MathDivide

  6. MathMultiply

  7. MathSubtract


MathStringToLong

Last Modified: EnterpriseOne Xe | May 10, 2000

MathStringToLong translates a number string into a long number. The value is passed as a return code.

Syntax

long MathStringToLong(JCHAR* s)

Parameters

Parameter | Notes | Usage
JCHAR *s | Math string |

Return Value

Return Value | Description
Long number |


MathSubtract

Last Modified: B733

MathSubtract subtracts parameter three from parameter two and places the result into parameter one. All parameters are JDE_NUMERIC data types.

Syntax

enum MathErrorCode MathSubtract(LPMATH_NUMERIC lpmnSum, LPMATH_NUMERIC lpmnAddend0, LPMATH_NUMERIC lpmnAddend1);

Parameters

Parameter | Notes | Usage
LpmnSum | Pointer to Math_Numeric variable to store result of subtraction. |
lpmnAddend0 | Pointer to Math_Numeric variable to subtract from. |
lpmnAddend1 | Pointer to Math_Numeric variable to subtract |

Return Value

Return Value | Description
MATH_SUCCESSFUL | It was successful
MathErrorCode | It was not successful

Example

MATH_NUMERIC mnMathOne;

MATH_NUMERIC mnMathTwo;

MATH_NUMERIC mnMathSum;

int nMathReturn;

LongToMathNumberic(400000L, &mnMathOne);

LongToMathNumberic(300000L, &mnMathTwo);

nMathReturn = MathSubtract( &mnMathSum, &mnMathOne, &mnMathTwo);

/* mnMathSum should have the value 100000 */

See Also

  1. MathAdd

  2. MathCompare

  3. MathCompareAbsolute

  4. MathCopy

  5. MathDivide

  6. MathMultiply

  7. MathRound


MathZeroTest

Last Modified: B733

MathZeroTest returns an int 0 if the string portion of the structure is equal to zero and the length is 1.

Syntax

short MathZeroTest (LPMATH_NUMERIC lpmnValue0);

Parameters

Parameter | Notes | Usage
LpmnValue0 | Pointer to Math_Numeric variable to test. |

Return Value

Return Value | Description
0 | It is a Zero
1 | It is not Zero

Example

MATH_NUMERIC mnMathOne;

short ReturnCode;

ParseNumericString(&mnMathOne, “0”);

ReturnCode = MathZeroTest(&mnMathOne);


ParseNumericString

Last Modified: B733

ParseNumericString formats a numeric string into the JDE_NUMERIC format.

Syntax

MATHERRORCODE ParseNumericString (MATH_NUMERIC FAR *t, JCHAR FAR *s)

Parameters

Parameter | Notes | Usage
FAR *t | Pointer to Math_Numeric variable to format. |
FAR *s | Numeric string input. |

Return Value

Return Value | Description
MATH_SUCCESSFUL | It was successful
MathErrorCode | It was not successful

Example

MATH_NUMERIC mnMathOne;

int nMathReturn;

nMathReturn = ParseNumericString (&mnMathOne, “487.98”);

See Also

  1. ParseNumericStringEx


ReverseMathNumeric

Last Modified: B733

ReverseMathNumeric reverses the sign on a MATH_NUMERIC.

Syntax

void ReverseMathNumeric (MATH_NUMERIC FAR *pReverse);

Parameters

Parameter | Notes | Usage
pReverse | Pointer to Math_Numeric variable to reverse. |

Return Value

Return Value | Description
None | This does not return a value

Example

MATH_NUMERIC mnMathOne;

ParseNumericString( &mnMathOne, “1”);

ReverseMathNumeric(&mnMathOne);

/*mnMathOne is now -1 */


ZeroMathNumeric

Last Modified: B733

ZeroMathNumeric sets a MATH_NUMERIC to zero.

Syntax

void ZeroMathNumeric (MATH_NUMERIC FAR *pZeroed);

Parameters

Parameter | Notes | Usage
*Pzeroed | Pointer to Math_Numeric variable to set to zero. |

Return Value

Return Value | Description
None | This does not return a value

Example

MATH_NUMERIC mnMathOne;

ParseNumericString(&mnMathOne, “1”);

ZeroMathNumeric(&mnMathOne);

/*mnMathOne is now 0 */

See Also

  1. ZeroMathNumericEx


Miscellaneous

Use these APIs for various Functions such as calling other business functions from within a function, checking for blank character strings, and allocating memory within the system.

Miscellaneous consist of the following APIs:

 | AddGenericTextName
app.gif (808 bytes) | CopyGenericTextName
 | DeleteGenericTextName
app.gif (808 bytes) | GetGenericTextName
 | GetNextNumberForMathKey
app.gif (808 bytes) | IsStringBlank
 | jdeAlloc
app.gif (808 bytes) | jdeCallObject
 | jdeFree
app.gif (808 bytes) | jdeGtCopyRecord
 | jdeReAlloc
app.gif (808 bytes) | jdeXMLRequest_DeleteXML
app.gif (808 bytes) | ModifyGenericTextName
 | StartFormDynamic
app.gif (808 bytes) | strcmpNoBlank


DoSendMessagev3.htm

DoSendMessagev3

Last Modified: EnterpriseOne | June 06, 2006

This API sends an email, internal or external, based on the recipient's preference.

Syntax

MSGPRTO_RTN(JDEDB_RESULT) DoSendMessageV3(

HUSER hUser,

Recipient * to,

Recipient * cc,

Recipient * bcc,

const JCHAR * pSubject,

const JCHAR * pText,

int numActiveMsg,

const ACTIVE_MSG_INFO_V3 * pActiveMsgArray,

const MSG_TEMPLATE_INFO * pTemplateSub,

const JCHAR * mediaObjectName,

const JCHAR * mediaObjectKey,

const JCHAR * pMailBox

);

Parameters

HUSER hUser | Input, required. The user handle that defines the context in which to send the message.
Recipient * to | Input, required. The ID of the primary individual, group, mailbox, and so forth to whom the message is to be delivered.
Recipient * cc | Input, required. The ID of the individual, group, mailbox, and so forth to whom a courtesy copy of the message is to be delivered.
Recipient * bcc | Input, required. The ID of the individual, group, mailbox, and so forth to whom a blind courtesy copy of the message is to be delivered.
const JCHAR * pSubject | Input, optional. The text to write to the subject line for the email.
const JCHAR * pText | Input, optional. The text to write to the main body for the email.
int numActiveMsg | Input, required. The number of interconnects to specific forms required.
const ACTIVE_MSG_INFO_V3 * pActiveMsgArray | Input, optional. Array holding the shortcuts. NULL is a value.
const MSG_TEMPLATE_INFO * pTemplateSub | Input, optional. A specific text substitution template.
const JCHAR * mediaObjectName | Input, optional. A specific media object used to send the attachment. NULL and <blank> are values.
const JCHAR * mediaObjectKey | Input, optional. The key of the media object used to send the attachment.
const JCHAR * pMailBox | Input, optional. The internal WorkCenter mailbox to which to deliver the email (used only for PPAT).

Example

JDEBFRTN (ID) JDEBFWINAPI functionCRMTest1 (LPBHVRCOM lpBhvrCom, LPVOID lpVoid, LPDSDCRM1 lpDS)

{

JCHAR buffer[1000] = {0};

JDEDB_RESULT rc = JDEDB_PASSED;

Recipient to = {0};

Recipient cc = {0};

HUSER hUser = NULL;

MSG_TEMPLATE_INFO zTemplateInfo = { 0 };

JDB_InitBhvr(lpBhvrCom, &hUser, (JCHAR *)NULL, JDEDB_COMMIT_AUTO);

jdeUTime_Format(buffer, (LPJDEUTIME)&lpDS->DateEntered, NULL);

/*Create TO smtp recipient*/

to.recipientType = RECIPIENT_TYPE_SMTP;

to.smtp = _J("employee@oracle.com");

/*Create CC contact recipient*/

cc.recipientType = RECIPIENT_TYPE_CONTACT;

LongToMathNumeric(1001, &cc.an8);

LongToMathNumeric(0, &cc.idln);

/*Create a template sub with dditem LM1234*/

zTemplateInfo.ddName = (JCHAR*)jdeAlloc( COMMON_POOL , (sizeof(NID)) * sizeof(JCHAR) ,MEM_ZEROINIT );

jdeNIDcpy( zTemplateInfo.ddName , _J("LM1234") );

zTemplateInfo.nbParam = 6;

zTemplateInfo.valueArray = (RT_VALUE*) jdeAlloc(COMMON_POOL, (sizeof(RT_VALUE) * 6) , MEM_ZEROINIT | MEM_RESIZEABLE);

zTemplateInfo.valueArray[0].evdtType = 2;

zTemplateInfo.valueArray[0].value = jdemalloc(sizeof(JCHAR) * (jdeStrlen(_J("1")) + 1));

jdeStrncpyTerminate(zTemplateInfo.valueArray[0].value , (LPVOID)_J("1") , jdeStrlen(_J("1")) + 1 );

zTemplateInfo.valueArray[1].evdtType = 2;

zTemplateInfo.valueArray[1].value = jdemalloc(sizeof(JCHAR) * (jdeStrlen(_J("2")) + 1));

jdeStrncpyTerminate(zTemplateInfo.valueArray[1].value , (LPVOID)_J("2") , jdeStrlen(_J("2")) + 1 );

zTemplateInfo.valueArray[2].evdtType = 2;

zTemplateInfo.valueArray[2].value = jdemalloc(sizeof(JCHAR) * (jdeStrlen(_J("3")) + 1));

jdeStrncpyTerminate(zTemplateInfo.valueArray[2].value , (LPVOID)_J("3") , jdeStrlen(_J("3")) + 1 );

zTemplateInfo.valueArray[3].evdtType = 2;

zTemplateInfo.valueArray[3].value = jdemalloc(sizeof(JCHAR) * (jdeStrlen(_J("4")) + 1));

jdeStrncpyTerminate(zTemplateInfo.valueArray[3].value , (LPVOID)_J("4") , jdeStrlen(_J("4")) + 1 );

zTemplateInfo.valueArray[4].evdtType = 2;

zTemplateInfo.valueArray[4].value = jdemalloc(sizeof(JCHAR) * (jdeStrlen(_J("5")) + 1));

jdeStrncpyTerminate(zTemplateInfo.valueArray[4].value , (LPVOID)_J("5") , jdeStrlen(_J("5")) + 1 );

zTemplateInfo.valueArray[5].evdtType = 2;

zTemplateInfo.valueArray[5].value = jdemalloc(sizeof(JCHAR) *

(jdeStrlen(_J("6")) + 1));

jdeStrncpyTerminate(zTemplateInfo.valueArray[5].value , (LPVOID)_J("6") , jdeStrlen(_J("6")) + 1 );

rc = DoSendMessageV3(

hUser, /*HUSER*/

&to, /*to*/

&cc, /*cc*/

NULL, /*bcc*/

buffer, /*subject*/

buffer, /*messageText*/

0, /*numActiveMsg number of shortcuts*/

NULL, /*pActiveMsgArray optional, NULL allowed */

&zTemplateInfo,/*pTemplateSub optional, NULL allowed */

NULL, /*mediaObjectName optional, NULL or <blank> allowed */

NULL, /*mediaObjectKey optional, NULL or <blank> allowed */

 NULL);
/*pMailBox optional, only used for PPAT
*/

FreeActiveMsgTemplate(&zTemplateInfo);

return (ER_SUCCESS);

}


JDB_SetUserTriggerOption

j deGuidCompare

Last Modified: EnterpriseOne | June 06, 2006

The GUIDs (Globally Unique IDentifier) generated by jdeCreateGuid can be ordered lexicographically. This API provides a lexicographical comparison of two GUIDs.

Syntax

int jdeGuidCompare(

        JDEGUIDBIN *pG1,

        JDEGUIDBIN *pG2

        )

Parameters

Parameter | Notes | Usage
JDEGUIDBIN *pG1 | First GUID to compare. |
JDEGUIDBIN *pG2 | Second GUID to compare. |

Return Value

An integer. The values are:

Return Value | Description
1 | pG1 > pG2
O | pG1 and pG2 point to identical GUID representations.
-1 | pG1 < pG2

Example

JDEGUIDBIN zGUID1 = {0};

JDEGUIDBIN zGUID2 = {0};

...

jdeCreateGuid(&zGUID1);

jdeCreateGuid(&zGUID2);

...

if (jdeGuidCompare(&zGUID1, &zGUID2) == 0)

{

jdePrintf(_J("GUIDs are equivalent\n"));

}

...

Additional Notes

See Also

jdeCreateGuid

jdeCreateGuidString

jdeGuidToString


JDB_SetUserTriggerOption

jdeGuidToString

Last Modified: EnterpriseOne | June 06, 2006

jdeCreateGuid generates a 36-character string representation for the 128-bit binary representation of a GUID (Globally Unique IDentifier) that is passed in to it. This is an example of a GUID: 4C32C69E-4D33-11D8-B299-72E2054054E5.

Syntax

 void jdeGuidToString(

      JDEGUIDSTR szDestStr,

      JDEGUIDBIN zGuid

)

Parameters

Parameter | Notes | Usage
JDEGUIDSTR szDestStr | Destination pointer for GUID string. |
JDEGUIDBIN zGuid | Structure containing source GUID. |

Return Value

:

Return Value | Description

Example

JDEGUIDBIN zGUID1 = {0};

JDEGUIDSTR szGUID2 = {0};

...

jdeCreateGuid(&zGUID1);

...

jdeGuidToString(szGUID2, zGUID1);

...

jdePrintf(_J("String representation: %ls\n"), szGUID2);

...

Additional Notes

See Also

jdeCreateGuid

jdeCreateGuidString

jdeGuidCompare


GetNextNumberForMathKey

Last Modified: B733

GetNextNumberForMathKey gets the next number for a MATH_NUMERIC key and verifies that a record does not already exist for that key. Continues retrieving next number until a valid key is generated.

Syntax

ID GetNextNumberForMathKey(LPBHVRCOM lpBhvrCom, LPVOID lpVoid, PJSTR lpszFileName,

LPVOID lpFileIndex, NID szTable, ID IndexID, LPVOID lpDataStruct, LPDSD0000065 lpParms)

Parameters

Parameter | Notes | Usage
lpBhvrCom | lpBhvrCom from calling business function. |
lpVoid | lpVoid from calling business function |
lpszFileName | Table name. |
lpFileIndex | Pointer to key structure for table. |
szTable | ID of table. |
IndexID | ID of index |
pDataStruct | Pointer to data structure to retrieve date. |
LpParms | Pointer to data structure with values for x0010. |

Return Value

Return Value | Description
None | This does not return a value


IsStringBlank

Last Modified: B733

IsStringBlank tests if a given string is blank.

Syntax

BOOL IsStringBlank( PJSTR pszInputString)

Parameters

Parameter | Notes | Usage
PszlnputString | Pointer to string to test. |

Return Value

Return Value | Description
TRUE | The string is blank
FALSE | The string is not blank

Example

char szString[ ] = “this is not blank”;

If ( IsStringBlank(szString) )

{

/* string is blank */

}

/* string is not blank */

}

See Also

  1. IsStringBlank


jdeAlloc

Last Modified: B733

jdeAlloc allocates a variable sized block of memory from a memory pool.

Syntax

Void * jdeAlloc(void * pMemory, unsigned long ulSize, unsigned int nFlags);

Parameters

Parameter | Notes | Usage
UIsi | Specifies the number of bytes to be allocated. |
BFlags | Specifies the characteristics of the allocated memory. |

Return Value

Return Value | Description
A void pointer to the allocated memory | The function succeeded
jdeShutdown will be called to close the application | The function did not succeed

Additional Notes

The possible values for the parameter “nFlags” are as follows:

Values | Description
MEM_DEFAULT | The allocated memory is not initialized.
MEM_ZEROINIT | The allocated memory is initialized to NULL.
MEM_RESIZEABLE | Space is reserved above the allocated memory to expedite reallocation. Use only when the need to reallocate the memory is anticipated. This is a performance hit.

See Also

  1. jdeFree

  2. jdeReAlloc


jdeCallObject

Last Modified: B733.1 | May 08, 1998

jdeCallObject is a generic call to a business function; allows one to call an external business function without having to manually build it into the project.

Syntax

ID jdeCallObject(JCHAR* szFunctionName, LPFNBHVR lpBhvrPtr, LPBHVRCOM lpBhvrCom,LPVOID

lpVoidInfo, LPVOID lpDs, LPCALLMAP pErrorMap, int nNumMap, JCHAR* szLibName, JCHAR*

szExeLocation, int nRetryCount)

Parameters

Parameter | Notes | Usage
szFunctionName | The literal name of the function placed within double quotes. | Required.
lpFnBhvr | Obsolete parameter. | Pass NULL.
lpBhvrCom | Standard lpBhvrCom. | Required.
lpVoidInfo | Standard lpVoid. | Required.
lpDS | Pointer to the data structure of the called business function. | Required.
lpErrorMap | Pointer to the call address of the CALLMAP array. | Optional - used for second level messaging.
nNumMap | The #define variable describing the number of indices used in the CALLMAP array. | Optional - used for second level messaging.
szLibName | Future Use. | Required.
szExeLocation | Future Use. | Required.
nRetryCount |  |

Return Value

Return Value | Description
None | This does not return a value

Example

  1. Business function header file - No Changes.

  2. Number of map fields(nNumMap).

  3. Open the called business function’s header file and determine the maximum number of possible map fields. For example:

Calling Function’s Header File | Called Function’s Header File
#define IDERRszComputerid_1 1L | #define IDERRcHeader_1 1L
#define IDERRmnJobNumber_5 5L | #define IDERRcEverestEvent_2 2L
#define IDERRcClearHeader_6 6L | #define IDERRcDetail_4 4L
#define IDERRcClearDetail_7 7L |
#define IDERRszDetailLineFrom_8 8L |
#define IDERRszDetailLineThru_9 9L |

In this example, the maximum number of fields that can be mapped is 2. The cHeader_1 and cDetail_4.

Create an Error map section in calling business function’s .c file and create a line for the new map fields. For example, the calling function’s .c source might look like this:

/*****************************************************************************

* Business Function: F0411FSClearStack

*

* Description: F0411 Functional Server Clear Stack

*

* Parameters:

LPBHVRCOM<tok_Tab>lpBhvrCom<tok_Tab>Business Function Communications

LPVOID<tok_Tab>lpVoid<tok_Tab>Void Parameter - DO NOT USE!

LPDS174281<tok_Tab>lpDS<tok_Tab>Parameter Data Structure Pointer

******************************************************************************/

/******************************************************************************

* Error Mapping Section

*

*

/* Map to function “EditLineNumber”

#define N174290 2

/* Map to function “UpdateLineNumber”

#define N54782112 3

/**************************************************************************/

ID F0411FSClearStack (LPBHVRCOM lpBhvrCom, LPVOID lpVoid, LPDS174281 lpDS)

{

/**************************************************************************

The number “174290” is the data structure number of the called business function. The number “2” is the number of mapped fields. Note: before each #define statement there should be a comment that refers to the business function name that this number will be used for.

Call map array (pErrorMap).

In the variable section, create a “cm_” map array for each function that needs to return back errors. For example:

ID F0411FSClearStack (LPBHVRCOM lpBhvrCom, LPVOID lpVoid, LPDS174281 lpDS)

{

/*****************************************************************************

*Variable declarations

*****************************************************************************/

CALLMAP cm_174290[N174290] = { {IDERRcClearHeader_6, IDERRcHeader_1 },

<tok_Tab><tok_Tab> {IDERRcClearDetail_7, IDERRcDetail_4}

<tok_Tab><tok_Tab> };

ID idReturnCode = BHVR_SUCCESS; /* Return Code */

If calling a function multiple times using different fields each time for edits, then multiple ”cm_’ variables will need to be defined using ”_#” appended to the ”cm_” variable name. For example:

ID F0411FSClearStack (LPBHVRCOM lpBhvrCom, LPVOID lpVoid, LPDS174281 lpDS)

{

/*****************************************************************************

*Variable declarations

*****************************************************************************/

CALLMAP cm_174290_1[N174290] = { {IDERRcClearHeader_6, IDERRcHeader_1 },

<tok_Tab><tok_Tab> {IDERRcClearDetail_7, IDERRcDetail_4}

CALLMAP cm_174290_2[N174290] = { {IDERRcClearHeader_4, IDERRcHeader_1 },

<tok_Tab><tok_Tab> {IDERRcClearDetail_5, IDERRcDetail_4}

<tok_Tab><tok_Tab> };

ID idReturnCode = BHVR_SUCCESS; /* Return Code */

/* string is not blank */

}

Function call to jdeCallObject

Replace all business function calls with ”jdeCallObject” calls. For example:

/* old call to editLineNumber */

idReturn = editLineNumber (lpBhvrCom, lpVoid, &dsEditStruct);

/* new call to editLineNumber */

idReturn = jdeCallObject ("editLineNumber", editLineNumber, (LPFNBHVR) NULL, lpBhvrCom, lpVoid dsEditStruct, cm_174290, N174290, (char*) NULL, (char*) NULL, (int) 0);

/* If there is no need to map errors, then a call might look like this */

idReturn = jdeCallObject ("editLineNumber", editLineNumber, (LPFNBHVR) NULL, lpBhvrCom, lpVoid dsEditStruct, (CALLMAP*) NULL, (int)0,(char*) NULL, (char*) NULL, (int) 0);


JDB_SetUserTriggerOption

jdeCreateGuid

Last Modified: EnterpriseOne | June 06, 2006

jdeCreateGuid generates a GUID, also known as a UUID. A GUID is a 128 bits long, but is often represented by a 36 character string. This API generates the 128 bit, binary representation.

Syntax

void jdeCreateGuid (JDEGUIDBIN *pGuid)

Parameters

Parameter | Notes | Usage
pGuid | Destination pointer for generated GUID. |

Return Value

Return Value | Description

Example

JDEGUIDBIN zGUID = {0};

jdeCreateGuid(&zGUID);

Additional Notes

See Also

jdeCreateGuidString

jdeGuidCompare

jdeGuidToString


JDB_SetUserTriggerOption

jdeCreateGuidString

Last Modified: EnterpriseOne | June 06, 2006

jdeCreateGuidString generates a GUID (Globally Unique IDentifier) also known as a UUID (Universally Unique IDentifier) and returns the string representation. A GUID is a 128 bits long, but is often represented by a 36 character string. This API generates the string representation, such as 4C32C69E-4D33-11D8-B299-72E2054054E5.

Syntax

void jdeCreateGuidString(JDEGUIDSTR szGuid)

Parameters

Parameter | Notes | Usage
JDEGUIDSTR szGuid | Destination pointer for generated GUID string. |

Return Value

Return Value | Description

Example

JDEGUIDSTR szGUID = {0};

jdeCreateGuidString(szGUID);

jdePrintf(_J("Generated GUID: %ls\n"), szGUID);

Additional Notes

See Also

jdeCreateGuid

jdeGuidCompare

jdeGuidToString


jdeFree

Last Modified: B733

jdeFree frees memory previously allocated from a memory pool.

Syntax

unsigned int jdeFree (void *pMemory);

Parameters

Parameter | Notes | Usage
PMemory | Points to the memory to be freed. (Previously allocated by jdeAlloc or subsequently reallocated by jdeReAlloc. |

Return Value

Return Value | Description
nonzero | The function succeeded
zero | The function did not succeed

See Also

  1. jdeAlloc

  2. jdeReAlloc


jdeLocaltime.htm

jdeLocaltime

Last Modified: EnterpriseOne | June 06, 2006

This is a threadsafe replacement for the standard C API localtime(). It converts the time passed in by pnTime, to a local time value. This local time is returned in the pzTime buffer parameter allocated and passed in by the caller.

Syntax

void jdeLocaltime(const time_t *pnTime, struct tm *pzTime)

Parameters

This API can take these parameters:

PnTime | A pointer to a time_t structure containing value to convert to local time.
PzTime | Return parameter to store converted local time value.

Return Values

This API has no return values.

Example

Void foo()

{ struct tm today = {0};

struct _timeb ztimeBuffer = {0};

_ftime( &ztimeBuffer );

jdeLocaltime(&ztimeBuffer.time, &today);

}


jdePPRand.htm

jdePPRand

Last Modified: EnterpriseOne | June 06, 2006

This is a threadsafe replacement for the standard C API rand(). jdePPRand returns an unique pseudo-random integer between 0 and RAND_MAX for multithreading process. If the function jdePPSRand is not called to initialize the seed, the first call to the function jdePPRand returns a random number with seed equal to 1 and then creates a new seed stored. Any following call to the function jdePPRand would use the seed created previously to return a random number and then update the seed.

Syntax

int jdePPRand(void);

Parameters

This API takes no parameters.

Return Values

This API can return this value:

Value | Description
An integer | An pseudo-random integer value greater than zero.

Example

This example creates a random number without setting the first seed.

void foo(int *rand)

{

*rand=jdePPRand();

}


jdePPSRand.htm

jdePPSRand

Last Modified: EnterpriseOne | June 06, 2006

This is a replacement for the standard C API srand(), to be used in conjunction with the API jdePPRand. The jdePPSRand function sets the seed at the process level for a new sequence of pseudo-random numbers to be returned by subsequent calls to jdePPRand. If jdePPSRand is called with the same seed value, the same sequence of pseudo-random numbers is repeated by jdePPRand. If the function jdePPSRand is not called to initialize the seed, the first call to jdePPRand returns a random number with seed equal to 1 and then creates a new seed stored.

Parameters

This API takes the following parameters, which are the same as those for the standard C API srand:

Seed

Input, required. Used to guarantee unique, pseudo-random numbers generated by jdePPRand. Must be an integer greater than zero.

Syntax

void jdePPSRand(int seed)

Return Values

This API has no return values.

Example

This example creates a random number with a seed which is unique for each process. You should call jdePPSRand only once to initialize a seed. After each call to the threadsafe function jdePPRand, a new seed is created and stored internally in the global variable.

void foo(int * rand)

{

jdePPSRand((unsigned)time( NULL ));

*rand=jdePPRand();

}


jdeReAlloc

Last Modified: B733

jdeReAlloc changes the size of an allocated block of memory.

Syntax

void * jdeReAlloc (void * pMemory, unsigned long ulNewSize, unsigned int nFlags);

Parameters

Parameter | Notes | Usage
PMemory | Points to the memory previously allocated by jdeAlloc (or previously reallocated by jdeReAlloc). |
UlNewSize | Specifies the total number of bytes to be allocated. This size may be smaller or larger than that previously allocated. |
NFlags | Specifies the characteristics of the reallocated memory. |

Return Value

Return Value | Description
A void pointer to the newly allocated memory | The function succeeded
jdeShutdown will be called to close the application | The function did not succeed

Additional Notes

The possible values for the parameter “nFlags” are as follows:

Values | Description
MEM_DEFAULT | The allocated memory is not initialized.
MEM_ZEROINIT | The allocated memory is initialized to NULL.
MEM_RESIZEABLE | Space continues to be reserved above the allocated memory to expedite additional reallocations. Use only when the need to reallocate the memory is anticipated. This is a performance hit

See Also

  1. jdeAlloc

  2. jdeFree


ModifyGenericTextName

Last Modified: B733.1 | January 26, 1999

ModifyGenericTextName modifies the generic text in the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI ModifyGenericTextName(PJSTR pObjectName, LPVOID pKey,

PJSTR pText)

Parameters

Parameter | Notes | Usage
PJSTR pObjectName | Name of the generic text object | For example, "ABGT"
LPVOID pKey | Pointer to the key of the generic text structure |
PJSTR pText | Pointer to the text to be modified |

Return Value

Return Value | Description
JDB_SUCCESS | It was successful
JDB_FAILED | It was not successful


StartFormDynamic

Last Modified: B733.1 | June 08, 1999

StartFormDynamic dynamically calls a form.

Syntax

JDERTN(int) JDEWINAPI StartFormDynamic (NID szApplication, NID szForm, HWND hwnd, LPVOID lpvoid);

Parameters

Parameter | Notes | Usage
LpszDLLName | Name of the application DLL in which the specific start form function is located. |
WFormOrdinal |  |
SzValuehwnd | Current window handle (lpBhvrCom->hDlg). | The ordinal number for the specific code generated StartForm routine.
LpFormDS | Pointer to data structure to be passed to the form (should match generated data structures in the *.cgh file). |

Return Value

Return Value | Description
None | This does not return a value

Example

#define DLLNAME “P48012.DLL” define the name of the DLL

#define FORM223632ORDINAL 2 define the ordinals of the specific StartFormnnnn

#define FORM223634ORDINAL 5 routines as set in the *.def for your application

/* SAR Detail */

typedef struct tagFORMDS23632 define the data structures for each form (copy from *.cgh)

{

MATH_NUMERIC DOCO;

char DCTO[3];

char SFXO[34;

char TYPR;

} FORMDS23632, FAR * LPFORMDS23632;

/* SAR Detail 2 */

typedef struct tagFORMDS23634

{

MATH_NUMERIC DOCO;

char DCTO[3];

char SFXO[34;

char TYPR;

} FORMDS23634, FAR * LPFORMDS23634;

ID StartSARDetailForm (LPBHVRCOM lpBhvrCom, LPVOID lpVoid, LPDS30241 lpDS)

{

WORD wFormOrdinal

FORMDS23632 dsDetailForm1; declare a local variable for form DS

FORMDS23634 dsDetailForm2;

LPVOID lpFormDS; void pointer to pass to dynamic call

switch ( lpDS->cWODetailedRecordType)

{

case ‘#’;

case ‘C’; case ‘c’

case ‘D’; case ‘d’

case ‘E’; case ‘e’

case ‘F’; case ‘f’

case ‘G’; case ‘g’

case ‘H’; case ‘h’

case ‘K’; case ‘k’

case ‘M’; case ‘m’

case ‘N’; case ‘n’

case ‘O’; case ‘o’

case ‘S’; case ‘s’

case ‘T’; case ‘t’

case ‘V’; case ‘v’

case ‘W’; case ‘w’

case ‘Z’; case ‘z’

dsDetailForm1. TYPR = lpDS->cWODetailedRecordType; initialize members of form DS

MathCopy(&dsDetailForm1,DOCO, &lpDS->mnDocumentNumber);

strcpy(dsDetailForm1,DCTO, “WO”);

strcpy(dsDetailForm1,SFXO, “ “);

wFormOrdinal = FORM223632Ordinal; assign ordinal

lpFormDS = &dsDetailForm1; assign address of DS to void pointer

break;

case ‘A’; case ‘a’

case ‘B’; case ‘b’

case ‘I’; case ‘i’

case ‘J’; case ‘j’

case ‘P’; case ‘p’

case ‘Q’; case ‘q’

case ‘R’; case ‘r’

case ‘U’; case ‘u’

dsDetailForm2. TYPR = lpDS->cWODetailedRecordType;

MathCopy(&dsDetailForm2,DOCO, &lpDS->mnDocumentNumber);

strcpy(dsDetailForm2,DCTO, “WO”);

strcpy(dsDetailForm2,SFXO, “ “);

wFormOrdinal = FORM223634Ordinal;

lpFormDS = &dsDetailForm2;

break;

default;

return (ID) BHVR_ERROR_INVALID_INPUT_PARAM;

}

StartFormDynamic( (LPSTR)DLLNAME, wFormOrdinal, lpBhvrCom->hDlg, lpFormDS);

return (ID) BHVR_SUCCESS;

}


strcmpNoBlank

Last Modified: B733

strcmpNoBlank compares two strings, ignoring leading blanks. This has the same return values as strcmp.

Syntax

int strcmpNoBlank (PJSTR szString1, PJSTR szString2)

Parameters

Parameter | Notes | Usage
szString1 | Pointer to first string to compare. |
szString2 | Pointer to second string to compare. |

Return Value

Value | Description
0 | if lpszString1 = to lpszString2
<0 | if lpszString1 < lpszString2
>0 | if lpszString1 > lpszString2 (ignoring leading blanks).

Example

char szString1[ ] = “ hello”;

char szString2[ ] = “hello”;

if ( strcmpNoBlank( szString1, szString2) = 0)

{

/* strings are the same - these strings would compare the same */

}


JDB_SetAggregate

JDB_ClearAggregate

First Available: EOne 8.94

Purpose

This API enables users to clear any SQL aggregation that existed on one or more specified columns on a table, business view or foreign table associated with a specific initialized request handle. This API followed by a call to JDB_SelectKeyed or a similar select API will generate ordinary select SQL without using any aggregation functions.

Syntax

JDEDB_RESULT JDB_ClearAggregate(HREQUEST hRequest)

Parameter | Notes | Usage
hRequest | Valid request handle. | This is the request handle by which JDB will identify all requests made to the particular table.

Return Value

Returns JDEDB_PASSED when the API succeeded or JDEDB_FAILED otherwise.

See Also

· JDB_SetGroupBy

· JDB_SetAggregate

· JDB_ClearGroupBy

· JDB_FetchAggregate

· JDB_FetchColsAggregate

· JDB_GetAggregateValue


JDB_SetAggregate

JDB_ClearGroupBy

First Available: EOne 8.94

Purpose

This API enables users to clear any SQL GROUP BY that existed on one or more specified columns on a table, business view or foreign table associated with a specific initialized request handle. This API followed by a call to JDB_SelectKeyed or a similar select API will generate select SQL without using any SQL GROUP BY clause.

Syntax

JDEDB_RESULT JDB_ClearGroupBy (HREQUEST hRequest)

Parameter | Notes | Usage
hRequest | Valid request handle. | This is the request handle by which JDB will identify all requests made to the particular table.

Return Value

Returns JDEDB_PASSED when the API succeeded or JDEDB_FAILED otherwise.

See Also

· JDB_SetGroupBy

· JDB_SetAggregate

· JDB_ClearAggregate

· JDB_FetchAggregate

· JDB_FetchColsAggregate

· JDB_GetAggregateValue


JDB_SetAggregate

JDB_FetchAggregate

First Available: EOne 8.94

Purpose

This API is similar to the JDB_Fetch API. Consumers of this API can use it to fetch ordinary column data (similar to JDB_Fetch), plus any aggregate results. Similar to JDB_Fetch, this API will fetch results of a select. Results will be fetched in order.

Similar to JDB_Fetch, this API will execute post fetch and currency triggers and perform currency conversion on all the ordinary select columns. Any aggregate data (if it exists) will not be passed to the triggers and no currency conversion will be performed on the aggregate data. Consumers of this API are responsible for performing any necessary currency conversion on the output aggregate data from this API.

Syntax

JDEDB_RESULT JDB_FetchAggregate (HREQUEST hRequest, void * lpStruct, void * lpAggregateValue)

Parameter | Notes | Usage
hRequest | Valid request handle. | This is the request handle by which JDB will identify all requests made to the particular table.
lpStruct | Pointer to ordinary column results structure or NULL | If no structure is to be used then pass NULL
lpAggregateValue | Pointer to aggregate results structure or NULL | If no structure is to be used then pass NULL

Return Value

Returns JDEDB_PASSED when the API succeeded or JDEDB_FAILED otherwise.

See Also

· JDB_SetAggregate

· JDB_SetGroupBy

· JDB_ClearAggregate

· JDB_ClearGroupBy

· JDB_FetchColsAggregate

· JDB_GetAggregateValue


JDB_SetAggregate

JDB_FetchColsAggregate

First Available: EOne 8.94

Purpose

This API is similar to the JDB_FetchCols API. Consumers of this API can use it to fetch ordinary column data (similar to JDB_FetchCols), plus any aggregate results. Similar to JDB_FetchCols, this API will fetch results of a select. Results will be fetched in order.

Similar to JDB_FetchCols, this API will execute post fetch and currency triggers and perform currency conversion on all the ordinary select columns. Any aggregate data (if it exists) will not be passed to the triggers and no currency conversion will be performed on the aggregate data. Consumers of this API are responsible for performing any necessary currency conversion on the output aggregate data from this API.

Syntax

JDEDB_RESULT JDB_FetchColsAggregate (HREQUEST hRequest, void * lpStruct, NID * pID, short nNum, void * lpAggregateValue)

Parameter | Notes | Usage
hRequest | Valid request handle. | This is the request handle by which JDB will identify all requests made to the particular table.
lpStruct | Pointer to ordinary column results structure or NULL | If no structure is to be used then pass NULL
pID | Pointer to list of columns to be fetched |
nNum | Number of columns to be fetched |
lpAggregateValue | Pointer to aggregate results structure or NULL | If no structure is to be used then pass NULL

Return Value

Returns JDEDB_PASSED when the API succeeded or JDEDB_FAILED otherwise.

See Also

· JDB_SetAggregate

· JDB_SetGroupBy

· JDB_ClearAggregate

· JDB_ClearGroupBy

· JDB_FetchAggregate

· JDB_GetAggregateValue


JDB_SetAggregate

JDB_GetAggregateValue

First Available: EOne 8.94

Purpose

This API returns a pointer to the aggregation data for the specified aggregation column. Similar to

JDB_GetTableColValue API, this API can be used to fetch the aggregation data for a specified

aggregation structure element after a call to either JDB_FetchAggregate, JDB_FetchColsAggregate,

JDB_Fetch

Syntax

JDEDB_RESULT JDB_GetAggregateValue (HREQUEST hRequest, AGGRGFUNCSTRUCT AggregateStruct)

Parameter | Notes | Usage
hRequest | Valid request handle. | This is the request handle by which JDB will identify all requests made to the particular table.
AggregateStruct | Item, table, instance ID, Aggregate Function. Valid ID’s and Aggregate Function |

Return Value

Returns null for no data or pointer to aggregate result.

See Also

· JDB_SetAggregate

· JDB_SetGroupBy

· JDB_ClearAggregate

· JDB_ClearGroupBy

· JDB_FetchColsAggregate

· JDB_FetchAggregate


JDB_SetAggregate

First Available: EOne 8.94

Purpose

This API enables users to define SQL aggregation on one or more specified columns on a table, business view or foreign table associated with a specific initialized request handle. This API followed by a call to JDB_SelectKeyed or a similar select API can generate SQL of the type

(nOption = JDB_AGGRGFUNCTION_OPT_FUNC_ONLY)

SELECT SUM(COL2), AVG(COL4) FROM TABLENAME WHERE (COL1 = X AND COL2= Y ) .

The following SQL aggregation function types can be specified by using this API :

SUM(colName)

AVG(colName)

MAX(colName)

MIN(colName)

COUNT(colName)

COUNT(*)

SUM( DISTINCT colName)

AVG(DISTINCT colName)

COUNT(DISTINCT colName)

The aggregation functions COUNT(colName) and COUNT(DISTINCT colName) can work with all columns except EVDT_LONGVARBINARY, EVDT_LONGVARCHAR, EVDT_TEXT. All the other aggregation functions that take a column name work only with the Everest numeric types.

This API is similar to other request setting API’s like JDB_SetSelection, JDB_SetSequencing (they are not independent and have to be called in conjunction with an appropriate JDB_SelectXXX API)

A combination of a call to JDB_SetSequencing , JDB_SetAggregate with a nOption of JDB_AGGRGFUNCTION_OPT_FUNC_ONLY and a JDB_SelectXXX API will not be supported

After a call to JDB_SetAggregate and before a call to JDB_ClearAggregate the following API calls are illegal :

JDB_InsertTable/JDB_InsertView/JDB_InsertTableCols/JDB_InsertFromSelect

JDB_UpdateTable/JDB_UpdateView/JDB_UpdateTableCols

JDB_DeleteTable/JDB_DeleteView/JDB_DeleteTableCols

JDB_SelectAll

In the absence of a call to the JDB_SetGroupBy API, a call to JDB_SetAggregate with a nOption of JDB_AGGRGFUNCTION_OPT_FUNC_COLUMNQUERY followed by a call to JDB_SelectXXX API will not be supported

Syntax

JDEDB_RESULT JDB_SetAggregate(HREQUEST hRequest, AGGRGFUNCSTRUCT * lpAGDs, ushort nNum, JDB_AGGRGFUNCTION_OPTION nOption)

Parameter | Notes | Usage
hRequest | Valid request handle. | This is the request handle by which JDB will identify all requests made to the particular table.
lpAGDs | Pointer to array of aggregation structures | This structure identifies the type of aggregation to process
nNum | Number of aggregation structures passed. This must equal the number of structures passed |
nOption | JDB_AGGRGFUNCTION_OPT_FUNC_COLUMNQUERY, JDB_AGGRGFUNCTION_OPT_FUNC_ONLY | JDB_AGGRGFUNCTION_OPT_FUNC_COLUMNQUERY will create SQL where the columns specified in the aggregation structures are appended to the columns specified while opening the table, business view, foreign table. This option will only work in conjunction with the JDB_SetGroupBy API. The option JDB_AGGRGFUNCTION_OPT_FUNC_ONLY will create SQL where only the columns in the aggregation structure get used. Columns specified while opening the table, business view, foreign table are ignored with this option.

Return Value

Returns JDEDB_PASSED when the API succeeded or JDEDB_FAILED otherwise.

See Also

· JDB_SetGroupBy

· JDB_ClearAggregate

· JDB_ClearGroupBy

· JDB_FetchAggregate

· JDB_FetchColsAggregate

· JDB_GetAggregateValue


JDB_SetAggregate

JDB_SetGroupBy

First Available: EOne 8.94

Purpose

This API enables users to define SQL GROUP BY criteria on one or more specified columns on a table, business view or foreign table associated with a specific initialized request handle. This API followed by a call to JDB_SelectKeyed or a similar select API can generate SQL of the type

SELECT COL2, COL3 FROM TABLENAME WHERE (COL1 = X AND COL2= Y ) GROUP BY COL1, COL2, COL3

Calls to JDB_SetGroupBy, JDB_SetAggregate (nOption = JDB_AGGRGFUNCTION_OPT_FUNC_ONLY) and JDB_SelectKeyed or a similar select API can generate SQL of the type

SELECT SUM(COL1), AVG(COL3) FROM TABLENAME WHERE (COL1 = X AND COL2= Y ) GROUP BY COL1, COL2, COL3

Calls to JDB_SetGroupBy, JDB_SetAggregate (nOption = JDB_AGGRGFUNCTION_OPT_FUNC_COLUMNQUERY) and JDB_SelectKeyed or a similar select API can generate SQL of the type

SELECT COL2, COL3 , SUM(COL1), AVG(COL3) FROM TABLENAME WHERE (COL1 = X AND COL2= Y ) GROUP BY COL1, COL2, COL3

This API is similar to other request setting API’s like JDB_SetSelection, JDB_SetSequencing, JDB_SetAggregate (they are not independent and have to be called in conjunction with an appropriate JDB_SelectXXX API)

After a call to JDB_SetGroupBy and before a call to JDB_ClearGroupBy the following API calls are illegal :

JDB_InsertTable/JDB_InsertView/JDB_InsertTableCols/JDB_InsertFromSelect

JDB_UpdateTable/JDB_UpdateView/JDB_UpdateTableCols

JDB_DeleteTable/JDB_DeleteView/JDB_DeleteTableCols

JDB_SelectAll

In compliance with the ANSI-SQL92 standard, any columns specified in the select column list (JDB_SetAggregate called with a nOption of JDB_AGGRGFUNCTION_OPT_FUNC_COLUMNQUERY) need to be specified in the GROUP BY clause using the JDB_SetGroupBy API.

In addition, another limitation imposed by JDB is that any columns specified in the ORDER BY clause (JDB_SetSequencing, JDB_SetGroupBy called in conjunction with JDB_SetAggregate with nOption of JDB_AGGRGFUNCTION_OPT_FUNC_COLUMNQUERY ) need to be specified in the SELECT column list (that is specified while opening the table, business view, or foreign table).

A select SQL created after a call to JDB_SetGroupBy API will include only the SELECT COLUMNS explicitly requested by the user (specified while opening the table, business view, or foreign table). Any currency columns that were not specified by the user will not be automatically added to the select list. It is recommended that users of JDB specify these columns explicitly to ensure that any currency triggers (that may exist) correctly work.

Syntax

JDEDB_RESULT JDB_SetGroupBy (HREQUEST hRequest, DBREF * lpGroupBy, ushort nNum)

Parameter | Notes | Usage
hRequest | Valid request handle. | This is the request handle by which JDB will identify all requests made to the particular table.
lpGroupBy | Pointer to array of DBREF’s that specify the group By criteria | This structure specifies the GROUP BY criteria for the request
nNum | Number of group by structures passed. This must equal the number of structures passed. |

Return Value

Returns JDEDB_PASSED when the API succeeded or JDEDB_FAILED otherwise.

See Also

· JDB_SetAggregate

· JDB_ClearAggregate

· JDB_ClearGroupBy

· JDB_FetchAggregate

· JDB_FetchColsAggregate

· JDB_GetAggregateValue


JDB_SetAggregate

JDB_SetNestedSelection

First Available: EOne 8.94

Purpose

This API enables users to define any type of selection on a table associated with a specific initialized request handle. This API will allow us to set any custom precedence on the conditions for the select. Example :

We can create a select statement of the form:

SELECT * FROM TABLE_NAME WHERE (((COL1 = X AND COL2= Y) OR (COL 3 = Z)) AND COL4= 5).

This API is similar to the API JDB_SetSelectionX, however this API does not restrict the number of nested parenthesis in the where clause, whereas JDB_SetSelectionX restricts the nesting to a single level.This API should be called prior to performing a JDB_Select operation.

Syntax

JDEDB_RESULT JDB_SetNestedSelection (HREQUEST hRequest, LPNESTEDSELECTSTRUCT lpSelect, ushort nNum, JDEDB_SET nSet)

Parameter | Notes | Usage
hRequest | Valid request handle. | This is the request handle by which JDB will identify all requests made to the particular table.
lpSelect | Pointer to array of nested SELECT structures | This structure identifies the type of selection to process and includes the ability to specify zero, one or more than one open or close parenthesis.
nNum | Number of SELECT structures passed. This must equal the number of structures passed |
nSet | JDEDB_SET_REPLACE or JDEDB_SET_APPEND. This indicates if you want to replace or append to the last selection. |

Return Value

Returns JDEDB_PASSED when the API succeeded or JDEDB_FAILED otherwise.

See Also

· JDB_SetSelection

· JDB_SetSelectionX


Common Library

Common library consists of APIs for that are specific to J. D. Edwards functionality, such as determining whether foreign currency is enabled, manipulating the date format, retrieving link list information, retrieving math numeric information as defined in the Data Dictionary. Common library APIs free the developer from manipulating math numeric data structures for addition or subtraction, and preserving currency information while performing math operations on currency-related data.

Common Library consist of the following APIs:

app.gif (808 bytes) | JDECurrency
 | JdeDate
app.gif (808 bytes) | LinkList
app.gif (808 bytes) | MATH_NUMERIC
app.gif (808 bytes) | Miscellaneous


chgCMTraceFilter.htm

chgCMTraceFilter

Last Modified: EnterpriseOne | June 06, 2006

Use this function to set the cache logging filter. This filter enables or prevents certain cache messages from being seen.

Syntax

bool chgCMTraceFilter (jchar filter);

Ini File Equivalent

[DEBUG] CMTraceFilter=nnnnnnnn

Parameters

filter

Input, optional. A comma or semicolon-delimited string of up to 256 characters. If the filter is longer than 256 characters, it is truncated at the 256th character. If the parameter is blank or consists of white space, the filter is set to “ALL”, meaning that all cache logging should be output to the log.

Return Values

This API always returns true.

Example

chgOutputLoggingLevel(1);

/* turn on output logging so log messages will be seen */

chgCMTraceFilter(_J("ALL"));

/* set filter to ALL meaning all cache logging will be seen*/

chgCMTraceLevel (1);

/* turn cache logging on */


chgCMTraceLevel.htm

chgCMTraceLevel

Last Modified: EnterpriseOne | June 06, 2006

Use this API to change the CM Trace logging level.

If you call this function with a valid non-zero level parameter, you should also ensure that output logging is on. If not, no log messages will be written and performance will suffer. Turn output logging on by calling: chgOutputLoggingLevel(1);.

If you call this function with a level parameter outside the valid range, an error message is written to the logs. This message does not appear if output logging is turned off.

chgCMTraceLevel works in conjunction with chgCMTraceFilter. You must set the cache logging filter with this API. If the filter is not set when you call chgCMTraceLevel, the cache logging filter will be set to “ALL”, which means that all cache logging messages will be seen, assuming that output logging is also on.

Ini File Equivalent

[DEBUG] CMTrace=1 CMTraceFilter=ALL

Syntax

bool chgCMTraceLevel (int level);

Parameters

level

Input, required. The logging level. Must be either 0 or 1.

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1);

/* turn on output logging so log messages will be seen */

chgCMTraceFilter(_J("ALL"));

/* set filter to ALL meaning all cache logging will be seen*/

chgCMTraceLevel (1);

/* turn cache logging on */

chgCMTraceLevel (0);

/* turn cache logging off */

chgOutputLoggingLevel(0);

/* turn off debug logging */


chgIEOTraceLevels.htm

chgIEOTraceLevels

Last Modified: EnterpriseOne | June 06, 2006

Use this API to change the IEO Trace levels.

If you call this function with a valid non-zero level parameter, you should also ensure that output logging is on. If not, no log messages will be written and performance will suffer. Turn output logging on by calling: chgOutputLoggingLevel(1);.

If you call this function with a level parameter outside the valid range, an error message is written to the logs. This message does not appear if output logging is turned off.

Ini File Equivalent

[Interoperability] Level=PERF,TRACE,DOC,DATA,EVENTS

Syntax

bool chgIEOTraceLevels (int level);

Parameters

The parameter level is a bitmap of the following values. To turn on the levels, add together the value in the table below for the values you want to turn on. All other levels will be turned off.

Logging Type | Value | Hex
EVENTS | 1 | 0x01
DATA | 2 | 0x02
PERF | 4 | 0x04
DOC | 8 | 0x08
TRACE | 16 | 0x10

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1);

/* turns on output logging and outputs a message in the log to indicate that it was turned on */

chgOutputLoggingLevel(0);

/* turns off debug logging, and turns off all other logging levels except for IEO Trace and EVN Save Doc levels. These must

be turned off manually if appropriate */


chgIPCTraceLevel.htm

chgIPCTraceLevel

Last Modified: EnterpriseOne | June 06, 2006

Use this API to change the IPC Trace logging level.

If you call this function with a valid non-zero level parameter, you should also ensure that output logging is on. If not, no log messages will be written and performance will suffer. Turn output logging on by calling: chgOutputLoggingLevel(1);.

If you call this function with a level parameter outside the valid range, an error message is written to the logs. This message does not appear if output logging is turned off.

Syntax

bool chgIPCTraceLevel (int level);

Ini File Equivalent

[JDEIPC] ipcTrace=x

Parameters

level

Input, required. The logging level. Must be in the range 0–3.

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1);

/* turn on output logging so log messages will be seen */

chgIPCTraceLevel(2);

/* set IPC Trace to level 2 */

chgIPCTraceLevel(0); /* turn off IPCTrace */

chgOutputLogging(0); /* turn off debug logging (and all other logging types) */

See Also

chgOutputLoggingLevel(1)


chgNetTraceLevel.htm

chgNetTraceLevel

Last Modified: EnterpriseOne | June 06, 2006

Use this API to change the Net Trace logging level.

If you call this function with a valid non-zero level parameter, you should also ensure that output logging is on. If not, no log messages will be written and performance will suffer. Turn output logging on by calling: chgOutputLoggingLevel(1);.

If you call this function with a level parameter outside the valid range, an error message is written to the logs. This message does not appear if output logging is turned off.

Syntax

bool chgNetTraceLevel (int level);

Ini File Equivalent

[JDENET] netTrace=x

Parameters

level

Input, required. The logging level. Must be in the range 0–7.

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1); /* turn on output logging so log messages will be seen */

chgNetTraceLevel (2); /* set Net Trace to level 2 */

chgNetTraceLevel (0); /* turn off Net Trace */

chgOutputLoggingLevel(0); /* turn off output logging */

See Also

chgOutputLoggingLevel(1)


chgOutputLoggingLevel.htm

chgOutputLoggingLevel

Last Modified: EnterpriseOne | June 06, 2006

Use this API to turn debug logging on or off. If output logging is turned off, all other logging levels are also turned off, except EVN SaveEVNDoc and IEO Trace logging levels. Those settings are not affected by chgOutputLoggingLevel, which you must disable manually if necessary.

If output logging is turned off, calling this API to turn it off again does not result in another log message indicating that output logging was turned off.

If the level parameter is something other than 0 or 1, an error message is written to the log indicating that the API was called with incorrect parameters. This message is not written if output logging is turned off. Output logging must be turned on for any other logging levels to have an effect. If output logging is turned off, but other logging levels are turned on, the logging output is formatted and prepared for output, but is not written to the log file. This results in a performance reduction without the benefit of extra logging.

Syntax

bool chgOutputLoggingLevel (int level);

Ini File Equivalent

[DEBUG] Output=FILE LogErrors=1

Parameters

level

Input, required. The logging level. Must be either 0 or 1.

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1);

/* turns on output logging and writes a message in the log to indicate that it was turned on */

chgOutputLoggingLevel(0);

/* turns off debug logging, and turns off all other logging levels except for IEO Trace and EVN Save Doc levels. These must

be turned off manually if appropriate */


chgPSThreadTraceLevel.htm

chgPSThreadTraceLevel

Last Modified: EnterpriseOne | June 06, 2006

Use this API to change the PSThread Trace logging level.

If you call this function with a valid non-zero level parameter, you should also ensure that output logging is on. If not, no log messages will be written and performance will suffer. Turn output logging on by calling: chgOutputLoggingLevel(1);.

If you call this function with a level parameter outside the valid range, an error message is written to the logs. This message does not appear if output logging is turned off.

Note. Setting this value to 3 results in an extremely large amount of logging and will severely affect performance on the Enterprise server. Do not use level 3 unless you are working with PSThread code and understand the performance degradation.

Ini File Equivalent

[DEBUG] ThreadTraceLevel=x

Syntax

bool chgPSThreadTraceLevel (int level);

Parameters

level

Input, required. The trace level. Must be in the range 0–3.

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1);

/* turn on output logging so log messages will be seen */

chgPSThreadTraceLevel (1);

/* set PSThread Trace to level 1 */

chgPSThreadTraceLevel (0);

/* turn off PSThread logging */

chgOutputLoggingLevel(0);

/* turn off debug logging */


chgSaveEVNDoc.htm

chgSaveEVNDoc

Last Modified: EnterpriseOne | June 06, 2006

Use this API to change the Save EVN Doc value.

If you call this function with a valid non-zero level parameter, you should also ensure that output logging is on. If not, no log messages will be written and performance will suffer. Turn output logging on by calling: chgOutputLoggingLevel(1);.

If you call this function with a level parameter outside the valid range, an error message is written to the logs. This message does not appear if output logging is turned off.

This function is available only with EVN kernels.

Syntax

bool chgSaveEVNDoc (int level);

Ini File Equivalent

[Interoperability] SaveEVNDoc=1

Parameters

level

Input, required. The save value. Must be either 0 or 1.

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1);

/* turn on output logging so log messages will be seen */

chgSaveEVNDoc (1);

/* set Save EVN Doc level to 1 */

chgSaveEVNDoc (0);

/* turn off SaveEVNDoc*/


chgSecTraceLevel.htm

chgSecTraceLevel

Last Modified: EnterpriseOne | June 06, 2006

Use this API to change the security trace logging level.

If you call this function with a valid non-zero level parameter, you should also ensure that output logging is on. If not, no log messages will be written and performance will suffer. Turn output logging on by calling: chgOutputLoggingLevel(1);.

If you call this function with a level parameter outside the valid range, an error message is written to the logs. This message does not appear if output logging is turned off.

Syntax

bool chgSecTraceLevel (int level);

Ini File Equivalent

[SECURITY] secTrace=x

Parameters

level

Input, required. The trace level. Must be in the range 0–2.

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1);

/* turn on output logging so log messages will be seen */

chgSecTraceLevel (2);

/* set security Trace to level 2 */

chgSecTraceLevel (0);

/* turn off secTrace */

chgOutputLoggingLevel(0);

/* turn off debug logging */


chgTAMTraceLevel.htm

chgTAMTraceLevel

Last Modified: EnterpriseOne | June 06, 2006

Use this API to change the TAM Trace logging level.

If you call this function with a valid non-zero level parameter, you should also ensure that output logging is on. If not, no log messages will be written and performance will suffer. Turn output logging on by calling: chgOutputLoggingLevel(1);.

If you call this function with a level parameter outside the valid range, an error message is written to the logs. This message does not appear if output logging is turned off.

Syntax

bool chgTAMTraceLevel (int level);

Ini File Equivalent

[DEBUG] TAMTraceLevel=x

Parameters

level

Input, required. The logging level. Must be in the range 0–9.

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1); /* turn on output logging so log messages will be seen */

chgTAMTraceLevel (5); /* set TAM Trace to level 5 */

chgTAMTraceLevel (0); /* turn off TAM trace logging */

chgOutputLoggingLevel(0); /* turn off debug logging */


Imaging

EnterpriseOne is designed to support a variety of imaging solutions. Although users can display images using the EnterpriseOne Media Object Viewer, this tool does not allow easy access to documents stored in a much more sophisticated document handling system. Using the guidelines in this document, you can integrate a full function document handling system into the EnterpriseOne application set.

EnterpriseOne uses the Object Linking and Embedding client/server paradigm to communicate with third-party document handling systems. J. D. Edwards supplies the OLE client interface with a standard set of APIs. You must create an OLE server and support the functions outlined in this document to communicate with this client. You can write the OLE Server using any OLE compliant language.

There are three primary tasks you must accomplish to completely integrate a document handling system with EnterpriseOne. These tasks are:

Task | Description
Search | This is the ability to search for a document stored in the indexing system of a document handling system. This search mechanism must be able to navigate the storage structures of the document handling system so that the user can easily find a particular document or documents.
Link | After the search is complete, a mechanism must be used that returns the unique document identifier so that it can be stored with the transaction.
View | This is the ability to pass a unique document identifier to a document viewing mechanism so that the user can view the image.

Imaging consist of the following APIs:

 | JDEDOC_CheckIn
app.gif (808 bytes) | JDEDOC_CheckOut
 | JDEDOC_EraseCheckOut
app.gif (808 bytes) | JDEDOC_FormatDocId
 | JDEDOC_GetDocIcon
app.gif (808 bytes) | JDEDOC_GetDocInfo
 | JDEDOC_GetDocName
app.gif (808 bytes) | JDEDOC_GetDocVersion
 | JDEDOC_GetErrorData
app.gif (808 bytes) | JDEDOC_GetLinkType
 | JDEDOC_LinkDocument
 | JDEDOC_ReleaseDocument
app.gif (808 bytes) | JDEDOC_SearchAndLinkDocument
 | JDEDOC_SearchDocument
app.gif (808 bytes) | JDEDOC_SystemInit
 | JDEDOC_SystemTerminate
app.gif (808 bytes) | JDEDOC_ViewDocument


JDEDOC_CheckIn

Last Modified: B733.1 | June 04, 1999

JDEDOC_CheckIn checks a document into the document management system provided by the vendor.

Syntax

BOOL JDEDOC_CheckIn ( BSTR * pDocumentId, BSTR * pErrorCode )

Parameters

Parameter | Notes | Usage
pDocumentId | The unique id of the document |
pErrorCode | Error identifier |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | The request was not successful

Additional Notes

If this function fails, the JDEDOC_GetErrorData() API will be called and the returned message text string will be displayed to the user within a message box.

  1. Pass in document id (key)


JDEDOC_CheckOut

Last Modified: B733.1 | June 04, 1999

JDEDOC_CheckOut checks a document out of the document management system provided by the vendor.

Syntax

BOOL JDEDOC_CheckOut ( BSTR * pDocumentId, BSTR * pErrorCode )

Parameters

Parameter | Notes | Usage
pDocumentId | The unique id of the document |
pErrorCode | Error identifier |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | An error occurred during the execution of the function

Additional Notes

If this function fails, the JDEDOC_GetErrorData() API will be called and the returned message text string will be displayed to the user within a message box.

  1. Pass in document id (key)


JDEDOC_EraseCheckOut

Last Modified: B733.1 | June 04, 1999

JDEDOC_EraseCheckOut resets the checkout status of a document (reverting to the previous status) in the document management system provided by the vendor.

Syntax

BOOL JDEDOC_EraseCheckOut ( BSTR * pDocumentId, BSTR * pErrorCode )

Parameters

Parameter | Notes | Usage
pDocumentId | The unique id of the document |
pErrorCode | Error identifier |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | An error occurred during the execution of the function

Additional Notes

If this function fails, the JDEDOC_GetErrorData() API will be called and the returned message text string will be displayed to the user within a message box.

  1. Pass in document id (key)


JDEDOC_FormatDocId

Last Modified: B733.1 | June 04, 1999

JDEDOC_FormatDocId function will allow the imaging vendor to format the document key information into something more readable to the user.

Syntax

BOOL JDEDOC_FormatDocId ( BSTR * pDocumentId, BSTR * pKeyString, BSTR * pErrorCode)

Parameters

Parameter | Notes | Usage
pDocumentId | The unique identifier of the document |
pKeyString | Pointer to string containing formatted key information |
pErrorCode | Error identifier |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | An error occurred during the execution of the function

Additional Notes

The point of this function is to allow the imaging vendor to format their document id (typically cryptic and unrecognizable to the average user) into something more readable.

The string will be displayed as a property page of the property sheet for that object in the Media Objects control. It will simply be placed into an edit control on that page.

  1. Pass in document id (key)

  2. Return string of formatted key information

See Also

  1. JDEDOC_GetErrorData

  2. JDEDOC_ReleaseDocument

  3. JDEDOC_SystemInit

  4. JDEDOC_SystemTerminate

  5. JDEDOC_ViewDocument


JDEDOC_GetDocIcon

Last Modified: B733.1 | June 04, 1999

JDEDOC_GetDocIcon retrieves the filename of the .DLL or .EXE where the icon associated with the document resides, and the index into the resource portion of the .DLL or .EXE for said icon.

Syntax

BOOL JDEDOC_GetDocIcon ( BSTR * pDocumentId, BSTR * pIconFilename, BSTR * pIconIndex, BSTR * pErrorCode )

Parameters

Parameter | Notes | Usage
pDocumentId | The unique id of the document |
pIconFilename | The binary filename where the icon resource is contained (.exe, .dll) |
pIconIndex | The index of the icon within the resource portion of the specified binary file |
pErrorCode | Error identifier |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | An error occurred during the execution of the function

Additional Notes

If this function fails, a default icon will be used.

  1. Pass in document id (key)

  2. Return the name of the document


JDEDOC_GetDocInfo

Last Modified: B733.1 | June 04, 1999

JDEDOC_GetDocInfo retrieves the detail data associated with a document (for example, last updated, user, created, version, or description).

Syntax

BOOL JDEDOC_GetDocInfo ( BSTR * pDocumentId, BSTR* pDocInfo, BSTR * pErrorCode )

Parameters

Parameter | Notes | Usage
PdocumentId | The unique id of the document |
PdocInfo | The detailed information about the document. |
PerrorCode | Error identifier |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | An error occurred during the execution of the function

Additional Notes

This gets detailed information about the selected document. The format of this BSTR* should be bar delimited with the first field representing the number of columns (n), followed by (n) column titles, followed by the actual row data (evenly divisible by the number of columns). In addition, this BSTR* should not contain any NULL characters. For example if the document information had 4 columns containing Name, Date Created, Checkout Status, Last Updated. JDEDOC_GetDocInfo() would return in the pDocInfo parameter this BSTR:

"4|Name|Date Created|Checkout Status|Last Updated|Invoice|3/5/1999|Checked out|4/4/1999|"

If there is no data for a certain column, this column can be omitted by simply placing nothing between the |s where the column data would reside. In this example, the Name column is omitted for this document:

"4|Name|Date Created|Checkout Status|Last Updated||3/5/1999|Checked out|4/4/1999|"

Since this information is in a table format, multiple rows of data can be returned as in this example:

"4|Name|Date Created|Checkout Status|Last Updated|Invoice|3/5/1999|Checked out|4/4/1999| Invoice|3/5/1999|Checked in|4/12/1999|"

The columns depicted in this example are for illustration only; the columns can be any information about the document that may interest the user.

  1. Pass in document id (key)

  1. Return string of formatted document information


JDEDOC_GetDocName

Last Modified: B733.1 | June 04, 1999

JDEDOC_GetDocName retrieves the name associated with a document.

Syntax

BOOL JDEDOC_GetDocName ( BSTR * pDocumentId, BSTR* pDocName, BSTR * pErrorCode )

Parameters

Parameter | Notes | Usage
PDocumentId | The unique id of the document |
PDocName | The name of the document. |
PErrorCode | Error identifier |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | An error occurred during the execution of the function

Additional Notes

This retrieves the name of the document.

  1. Pass in document id (key)

  2. Return the name of the document


JDEDOC_GetDocVersion

Last Modified: B733.1 | June 04, 1999

JDEDOC_GetDocVersion retrieves the version of the document.

Syntax

BOOL JDEDOC_GetDocVersion ( BSTR * pDocumentId, BSTR* pDocVersion, BSTR * pErrorCode )

Parameters

Parameter | Notes | Usage
pDocumentId | The unique id of the document |
pDocVersion | The version of the document. |
pErrorCode | Error identifier |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | An error occurred during the execution of the function

Additional Notes

This retrieves the version of the document.

  1. Pass in document id (key)

  2. Return the version of the document


JDEDOC_GetErrorData

Last Modified: B733.1 | June 04, 1999

JDEDOC_GetErrorData retrieves a description of an error that has occurred while using the imaging system.

Syntax

BOOL JDEDOC_GetErrorData ( BSTR * pErrorCode, BSTR * pErrorText )

Parameters

Parameter | Notes | Usage
pErrorCode | Error identifier. |
pErrorText | Pointer to text string containing text description of pErrorCode. |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | An error occurred during the execution of the function

Additional Notes

This reports error conditions to the user. If an error occurs in any of the previous functions, this function is invoked, and a string will return describing the error condition. This string of text will then be displayed to the user as an informational message.

  1. Pass in pErrorCode

  2. Return string to describe the error.

See Also

  1. JDEDOC_FormatDocId

  2. JDEDOC_LinkDocument

  3. JDEDOC_SearchDocument

  4. JDEDOC_SearchAndLinkDocument

  5. JDEDOC_ReleaseDocument

  6. JDEDOC_SystemInit

  7. JDEDOC_SystemTerminate

  8. JDEDOC_ViewDocument


JDEDOC_GetLinkType

Last Modified: B733.1 | June 04, 1999

JDEDOC_GetLinkType retrieves the link type associated with a document.

Syntax

BOOL JDEDOC_GetLinkType ( BSTR * pDocumentId, BSTR* pLinkType, BSTR * pErrorCode )

Parameters

Parameter | Notes | Usage
pDocumentId | The unique id of the document |
pLinkType | The link type |
pErrorCode | Error identifier |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | An error occurred during the execution of the function

Additional Information

This retrieves the link type. The link type is defined as follows: "1"-All, "2"-Specific, "3"-Current, "4"-Literal (tbd), "5"-Custom (tbd).

  1. Pass in document id (key)

  2. Return the link type used for the document


JDEDOC_LinkDocument

Last Modified: B733.1 | June 04, 1999

JDEDOC_LinkDocumen “pulls” a unique document identifier of the document currently being displayed using the JDEDOC_SearchDocument function.

Syntax

BOOL JDEDOC_LinkDocument ( BSTR * pDocumentId, BSTR * pErrorCode )

Parameters

Parameter | Notes | Usage
pDocumentId | The unique document identifier of a document that the user has selected to be linked to the current EnterpriseOne transaction. |
pErrorCode | Error Identifier. |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | An error occurred during the execution of the function

Additional Notes

This allows users to search for, view, and select documents all in one modal operation. Once the user has searched for and found the document that is required, the function will place the unique document identifier into pDocumentId variable. This value is then returned to and stored in the EnterpriseOne system and is used as the link the facilitates viewing of the document at a later time. Essentially, the unique document id is "pushed" back to the calling EnterpriseOne application when the user selects a particular document.

  1. This function initialize the search mechanism.

  2. This function allows users to search through stored documents.

  3. This function allows users to view documents.

  4. This function allows users to select a document. The unique document identifier is then returned to the EnterpriseOne application in the pDocumentId parameter.

  5. This function unloads the search form and any related programs.

See Also

  1. JDEDOC_SearchDocument

  2. JDEDOC_SearchAndLinkDocument


JDEDOC_ReleaseDocument

Last Modified: B733.1 | June 04, 1999

JDEDOC_ReleaseDocument releases the currently displayed document from the viewer.

Syntax

BOOL JDEDOC_ReleaseDocument ( BSTR * pDocumentId, BSTR * pErrorCode )

Parameters

Parameter | Notes | Usage
PDocumentId | The unique document identifier of the document to be released. |
PErrorCode | Error identifier. |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | An error occurred during the execution of the function

Additional Notes

  1. This functionality is inactive unless the JDEDOC_ViewDocument has been previously invoked.

  2. This function clears the document viewer in preparation to view another document that the user has selected. This prevents multiple documents from being displayed.

See Also

  1. JDEDOC_FormatDocId

  2. JDEDOC_GetErrorData

  3. JDEDOC_SystemInit

  4. JDEDOC_SystemTerminate

  5. JDEDOC_ViewDocument


JDEDOC_SearchAndLinkDocument

Last Modified: B733.1 | June 04, 1999

JDEDOC_SearchAndLinkDocument allows users to search for, view, and select documents all in one modal operation. Once the user has searched for and found the document that is required, the function will place the unique document identifier into pDocumentId variable. This value is then returned to and stored in the EnterpriseOne system and is used as the link that facilitates viewing of the document at a later time. Essentially, the unique document ID is “pushed” back to the calling EnterpriseOne application when the user selects a particular document.

The search mechanism for this API should be presented to the user in a MODAL format, that is, the user cannot return to the calling EnterpriseOne application until they have either selected a document or pressed the Cancel button. If a document is selected, the ID is placed in the pDocumentId parameter.

Syntax

BOOL JDEDOC_SearchAndLinkDocument (BSTR * pDocumentId, BSTR * pErrorCode )

Parameters

Parameter | Notes | Usage
pDocumentId | The unique identifier of the document selected (return value). |
pErrorCode | Error Identifier. |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | An error occurred during the execution of the function

Additional Notes

This function is used to allow users to search for, view, and select documents all in one modal operation. Once the user has searched for and found the document that is required, the function will place the unique document identifier into pDocumentId variable. This value is then returned to and stored in the EnterpriseOne system and is used as the link the facilitates viewing of the document at a later time. Essentially, the unique document id is "pushed" back to the calling EnterpriseOne application when the user selects a particular document.

  1. This function initialize the search mechanism.

  2. This function allows users to search through stored documents.

  3. This function allows users to view documents.

  4. This function allows users to select a document. The unique document identifier is then returned to the EnterpriseOne application in the pDocumentId parameter.

  5. This function unloads the search form and any related programs.

See Also

  1. JDEDOC_GetErrorData

  2. JDEDOC_LinkDocument

  3. JDEDOC_SearchDocument


JDEDOC_SearchDocument

Last Modified: B733.1 | June 04, 1999

JDEDOC_SearchDocument allows users to search, view, and select documents stored in a third party document handling system. It does not matter whether this is accomplished by using a existing search mechanism or a custom form that is developed for this process. Once the user has searched for and found the document that is required, the function will store that selection until the Link command has been issued. The ID of most recently selected documents is then returned to the EnterpriseOne application.

The search mechanism should be presented to the user in a MODELESS format, that is, the user can invoke the search, display documents as a result of that search, and be able to switch back to the calling application without waiting for the search to end.

Syntax

BOOL JDEDOC_SearchDocument (BSTR * pErrorCode )

Parameters

Parameter | Notes | Usage
pErrorCode | Error identifier. |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | An error occurred during the execution of the function

Additional Notes

This allows users to search for, view and select documents stored in a third party document handling system. It does not matter whether this is accomplished by using an existing search mechanism or a custom form that is developed for this process. Once the user has searched for and found the document that is required, the function will store that selection until the Link command has been issued. The ID of the most recently selected document is then returned to the EnterpriseOne application.

  1. This function initialize the search mechanism.

  2. This function allows users to search through stored documents.

  3. This function allows users to View documents.

  4. This function allows users to select a document. The unique document identifier is then stored internally and returned to the EnterpriseOne application when the user selects the link option.

See Also

  1. JDEDOC_GetErrorData

  2. JDEDOC_LinkDocument

  3. JDEDOC_SearchAndLinkDocument


JDEDOC_SystemInit

Last Modified: B733.1 | June 04, 1999

JDEDOC_SystemInit initializes the interface between EnterpriseOne and the document handling system.

Syntax

BOOL JDEDOC_SystemInit (BSTR * pUserName, BSTR * pUserPassword, BSTR * pErrorCode )

Parameters

Parameter | Notes | Usage
pUserName |  | Required
pUserPassword |  | Required
pErrorCode | Error identifier |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | An error occurred during the execution of the function

Additional Notes

This starts the third party document handling system. This includes loading the required OLE server, creating the required instances of the JDEDOC class, validating the user, and accomplishing any other tasks required to start the third party system. The functionality should be run through once, as there should be only one instance running.

  1. If this function is already initialized, exit.

  2. Create an instance of the JDEDOC class.

  3. Load the OLE Server for the imaging product.

  4. User Validation - (If Required) The system should validate the user using the user name and password from the jdeDoc structure. If the user is not valid, present a signon form. If the user cancels or cannot enter system, return FALSE.

  5. If the user is validated, and all is well, return TRUE

  6. Return FALSE for any error.

See Also

  1. JDEDOC_FormatDocId

  2. JDEDOC_GetErrorData

  3. JDEDOC_ReleaseDocument

  4. JDEDOC_SystemTerminate

  5. JDEDOC_ViewDocument


JDEDOC_SystemTerminate

Last Modified: B733.1 | June 04, 1999

JDEDOC_SystemTerminate terminates all imaging functions started by the JDEDOC_SystemInitFunction.

Syntax

BOOL JDEDOC_SystemTerminate ( void )

Parameters

None

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | An error occurred during the execution of the function

Additional Notes

This terminates the third party document handling system. This includes unloading the required OLE server, deleting instances of the JDEDOC class, and freeing any allocated memory. Any required housekeeping functions should be executed here.

  1. Destroy the instance of the JDEDOC class.

  2. Unload any DLL’s, or terminate any running programs

  3. Free any allocated memory

See Also

  1. JDEDOC_FormatDocId

  2. JDEDOC_GetErrorData

  3. JDEDOC_ReleaseDocument

  4. JDEDOC_SystemInit

  5. JDEDOC_ViewDocument


JDEDOC_ViewDocument

Last Modified: B733.1 | June 04, 1999

JDEDOC_ViewDocument uses a native viewer to view the selected document.

Syntax

BOOL JDEDOC_ViewDocument ( BSTR * pDocumentId, BSTR * pErrorCode )

Parameters

Parameter | Notes | Usage
PDocumentId | The unique identifier of the document to be viewed. |
PErrorCode | Error identifier. |

Return Value

Return Value | Description
TRUE | The request was successful
FALSE | An error occurred during the execution of the function

Additional Notes

  1. Initialize the viewer (if necessary).

  2. Format the document ID to the required key structure.

  3. Retrieve and place the document in the viewer.

This starts the third party viewer to view the selected document. The document ID is contained in the JDEDOCSTRUCT structure. The function parses this value and call the proper native commands to view the document.

See Also

  1. JDEDOC_FormatDocId

  2. JDEDOC_GetErrorData

  3. JDEDOC_ReleaseDocument

  4. JDEDOC_SystemInit

  5. JDEDOC_SystemTerminate


JDEBASE

EnterpriseOne supports multiple databases. an EnterpriseOne application can access data from a number of databases. JDEBASE, a multiplatform API for database access, is what makes this possible. It is the link between the application and the database. Its goal is to insulate the programmers from the intricacies of SQL and the various databases supported. JDEBASE is a consistent API. Any data access, whether in EnterpriseOne Tools or EnterpriseOne Applications, should use this API set.

The driving forces behind rewriting JDB to JDEBASE are:

  1. Ability to communicate with other database drivers such as ODBC, Oracle OCI, and DB2

  2. Ability to communicate with other JDEBASE across the network

  3. Portability to all required platforms

  4. Performance

  5. Use of triggers and stored procedures

JDEBASE offers the following advantages:

  1. Modular design

  2. Easier maintenance (Debugging, enhancements, and so forth.)

  3. Less code (JDB = 20000 lines, JDEBASE = 10000 lines.)

  4. Rapid development of native drivers

  5. Native drivers can be written to predefined specifications by JDE, customers.

  6. Additions of new native drivers without modifying or compiling JDEBASE.

  7. Data caching embedded in JDEBASE

  8. Enhanced Object Map

  9. Connection switching. Ability to identify primary and backup database in Object Map

  10. Just in Time Replication

  11. Performance enhancements (JDECACHE)

  12. Structured for distributed communications

  13. Transaction Processing

  14. Two-phase-commit transaction processing for a distributed heterogeneous database environment

JDEBASE consist of the following Categories:

Data Manipulation

Initialization

Miscellaneous

Non-JDE Table

Request Settings

Specifications

Table Management

Table Specific Selection

Table View


Data Manipulation

Data Manipulation consist of the following APIs:

app.gif (808 bytes) | JDB_CancelUserTransaction
 | JDB_CommitUser
app.gif (808 bytes) | JDB_DeleteTable
 | JDB_DeleteView
 | JDB_Fetch
app.gif (808 bytes) | JDB_FetchKeyed
 | JDB_FetchMatchingKey
 | JDE_GetTableProperties
app.gif (808 bytes) | JDB_InsertTable
 | JDB_InsertView
app.gif (808 bytes) | JDB_RollbackUser
 | JDB_SelectAll
app.gif (808 bytes) | JDB_SelectKeyed
 | JDB_SelectKeyedDistinct
app.gif (808 bytes) | JDB_SelectKeyedGetCount
 | JDB_SelectKeyedPosition
app.gif (808 bytes) | JDB_SelectKeyedPositionDistinct
 | JDB_SelectKeyedPositionForUpdate
app.gif (808 bytes) | JDB_SelectKeyedPositionGetCount
 | JDB_UpdateTable
 | JDB_UpdateTableCols
 | JDB_UpdateTableColsExtend
app.gif (808 bytes) | JDB_UpdateView
app.gif (808 bytes) | JDB_ValidateTableSpecs
app.gif (808 bytes) | OneWorld Max Values

Additional Data Manipulation API's are categorized by the following section:

Locking APIs


JDB_CancelUserTransaction

Last Modified: B733.1 | June 04, 1999

JDB_CancelUserTransaction cancels a transaction that is in progress. It can be called at any point between JDB_InitUser with a manual commit mode and a JDB_CommitUser. When the transaction is cancelled, it will never be committed but rolled back instead.

Syntax

JDEDB_RESULT JDB_CancelUserTransaction(HUSER hUser));

Parameters

Parameter | Notes | Usage
huser | Valid user handle. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails


JDB_CommitUser

Last Modified: EnterpriseOne Xe | May 10, 2000

JDB_CommitUser commits a transaction. This API should be called when all the operations in a transaction have been successful and the database needs to be permanently updated with the transaction changes.

Syntax

JDEDB_RESULT JDB_CommitUser(HUSER hUser);

Parameters

Parameter | Notes | Usage
huser | Valid user handle. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

  • JDB_RollbackUser


JDB_DeleteTable

Last Modified: EnterpriseOne | June 06, 2000

JDB_DeleteTable deletes a row from a specified table using the passed index.

Syntax

JDBDB_RESULT JDB_DeleteTable(HREQUEST hRequest, NID szTable, ID idInstance, ID idIndex, void*lpKeyStruct, short nNumKeys);

Parameters

Parameters | Notes | Usage
hRequest | Valid request handle |
SzTable | Table ID to delete |
idInstance | Instance ID of table. Used if joins, otherwise pass zero |
IdIndex | Index ID to use for delete or NULL. If NULL, then primary index will be used |
lpKeyStruct | Pointer key structure or NULL. If no structure is to be used, then pass NULL |
nNumKeys | Number of keys to be used. if ON, then the request is valid for caching |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_DeleteTable */

HREQUEST Request = NULL;

JDEDB_Result rcode;

NID szTable = NID_F0101;

ID idIndex = ID_F0101_Address;

Key1_F0101 dsKeySentStruct;

int nNumKeys =1;

ParseNumbericString(&dsKeySentStruct.aban8,"1001");

rcode=JDB_DeleteTable(hRequest,sztable, 0,idIndex,&dsKeySentStruct, nNumKeys);

if (rcode !=JDEDB_PASSED)

{

printf("JDB_DeleteTable failed\n");

} /*END IF */

See Also

· JDB_AlterTable

· JDB_CloseTable

· JDB_CreateTable

· JDB_DropTable

· JDB_InsertTable

· JDB_OpenTable

· JDB_UpdateTable


JDB_DeleteView

Last Modified: EnterpriseOne | June 06, 2000

JDB_DeleteView deletes a record from table involved in a business view.

Syntax

JDEDB_RESULT PASCAL _export JDB_DeleteView(HREQUEST hRequest, void *lpKey)

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle |
*lpKey | Pointer key structure or NULL. If no structure is to be used, then pass NULL. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

· JDB_CloseView

· JDB_InsertView

· JDB_OpenView

· JDB_UpdateView


JDB_Fetch

Last Modified: EnterpriseOne | June 06, 2000

JDB_Fetch fetches results of a select. Results are fetched in order.

Syntax

JDEDB_RESULT JDB_Fetch(HREQUEST hRequest, void * lpValue, int nLock);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
lpValue | Pointer to results structure or NULL. If no structure is to be used then pass NULL. |
nLock | NULL. Currently not in use. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/*Declare variables associated with JDB_Fetch */

HREQUEST hRequest = NULL;

F0101 dsKeyStructFetchAll = {0};

int nNotUsed = 0;

/* There must be a selection executed prior to executing a fetch */

if((rcode = JDB_SelectAll(hRequest)) == JDEDB_PASSED)

{

/* Fetch all the selected records */

while((rcode = JDB_Fetch(hRequest, &dsKeyStructFetchAll, nNotUsed)) == JDEDB_PASSED)

{

/* Process the fetched records */

} /* END WHILE */

} /* END IF *

See Also

· JDB_BuildKeyBuffer

· JDB_FetchForUpdate

· JDB_FetchKeyed

· JDB_FetchKeyedForUpdate

· JDB_FetchMatchingKey

· JDB_FreeKeyBuffer

· JDB_SelectKeyed

· JDB_SelectKeyedForUpdate

· JDB_SelectKeyedPosition

· JDB_SelectKeyedPositionForUpdate


JDB_FetchKeyed

Last Modified: EnterpriseOne | June 06, 2000

JDB_FetchKeyed performs a select as well as fetch results. This API attempts to use the cache when fetching on business views. This should be used when you do not expect multiple records to be returned as a result of your query.

Syntax

JDEDB_RESULT JDB_FetchKeyed(HREQUEST hRequest, ID idIndex, void * lpKeyStruct, short nNumKeys, void * lpValue, int nLock);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
idIndex | Valid Index ID to use for the selection. If zero then index of request will be used. |
lpKeyStruct | Pointer key structure or NULL. If no structure is to be used then pass NULL. |
nNumKeys | Number of keys to be used. If ON then the request is valid for caching. |
lpValue | Pointer to results structure or NULL. If no structure is to be used then pass NULL. |
nLock | NULL. Currently not in use. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_FetchKeyed */

HREQUEST hRequest = NULL;

ID idIndex = ID_F0101_ADDRESS;

KEY1_F0101 dsKeySentStruct = {0};

F0101 dsKeyStructAll = {0};

short nNumKeys = 1;

int nNotUsed = 0;

ParseNumericString(&dsKeySentStruct.aban8,"1002");

rcode = JDB_FetchKeyed(hRequest, idIndex, & dsKeySentStruct, nNumKeys, & dsKeyStructAll, nNotUsed);

if(rcode != JDEDB_PASSED)

{

printf(“JDB_FetchKeyed failed\n”);

} /* END IF */

See Also

· JDB_BuildKeyBuffer

· JDB_Fetch

· JDB_FetchForUpdate

· JDB_FetchKeyedForUpdate

· JDB_FetchMatchingKey

· JDB_FreeKeyBuffer

· JDB_SelectKeyed

· JDB_SelectKeyedForUpdate

· JDB_SelectKeyedPosition

· JDB_SelectKeyedPositionForUpdate


JDB_FetchMatchingKey

Last Modified: EnterpriseOne | June 06, 2000

JDB_FetchMatchingKey fetches results of a select. Results will be fetched in order. Additionally, a key structure can be passed to this API. This API will use this structure to ensure that the fetched record matches the key.

Syntax

JDEDB_RESULT JDB_FetchMatchingKey(HREQUEST hRequest, void * lpKeyStruct, short nNumKeys, void * lpValue, int nLock);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
lpKeyStruct | Pointer key structure or NULL. If no structure is to be used then pass NULL. |
nNumKeys | Number of keys to be used. If ON then the request is valid for caching. |
lpValue | Pointer to results structure or NULL. If no structure is to be used then pass NULL. |
nLock | NULL. Currently not in use. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_FetchMatchingKey */

HREQUEST hRequest = NULL;

ID idIndex = ID_F0101_ADDRESS;

KEY1_F0101 dsKeySentStruct = {0};

F0101 dsKeyStructAll = {0};

short nNumKeys = 1;

int nNotUsed = 0;

ParseNumericString(&dsKeySentStruct.aban8,"1002");

rcode = JDB_FetchMatchingKey(hRequest, & dsKeySentStruct, nNumKeys, & dsKeyStructAll, nNotUsed)

if(rcode != JDEDB_PASSED)

{

printf(“JDB_FetchMatchingKey failed\n”);

}

See Also

· JDB_BuildKeyBuffer

· JDB_Fetch

· JDB_FetchForUpdate

· JDB_FetchKeyed

· JDB_FetchKeyedForUpdate

· JDB_FreeKeyBuffer

· JDB_SelectKeyed

· JDB_SelectKeyedForUpdate

· JDB_SelectKeyedPosition

· JDB_SelectKeyedPositionForUpdate


JDB_GetTableProperties

First Available: B9

Last Modified: 01/08/03

JDB_GetTableProperties allows users to get property values for a table (i.e., Maximum Identifier Length, Max Number Of Columns in Table, etc.,). This API could be called either for a particular database or for EnterpriseOne supported values.

Syntax

JDEDB_RESULT JDB_GetTableProperties (char * DBTypeVer, char * PropertyName, int * PropertyValue)

Parameters

Parameter | Notes | Usage
DBTypeVer | NULL or EnterpriseOne or Valid Database name/version (UDC H93/DV). | When a NULL is passed, this API will return the LCD of Maximum of all values or GCD of Minimum of all values. For EnterpriseOne, EnterpriseOne supported limits will be returned and for a specific Database, valid database values would be returned otherwise.
PropertyName | Valid | PropertyName is passed as a string. Valid strings will be one of the following: MaxTableNameLength, MaxIndexNameLength, MaxColumnNameLength, MaxNumberColumnsInTable, MaxNumberColumnsInIndex, MaxNumberIndexesInTable, MaxNumberBLOBInTable, MaxTotalRowLength, MaxTotalIndexLength, MinTableNameLength, MinIndexNameLength, MinColumnNameLength, MinNumberColumnsInTable, MinNumberColumnsInIndex, MinNumberIndexesInTable, MinNumberBLOBInTable, MinTotalRowLength, MinTotalIndexLength
PropertyValue | Return value | The property value will be returned as a pointer to an integer.

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this API succeeds
JDEDB_FAILED | Return value if this API fails

Example

rcode = JDB_GetTableProperties(NULL, "MaxTableNameLength", &PropertyValue);

if (rcode == JDEDB_PASSED)

{

jdeTraceSz1(NULL, “Maximum Table Name Length = %d”, PropertyValue);

return JDEDB_PASSED;

}

else

{

jdeWriteLog(NULL,0, “Failed to get table properties”);

return JDEDB_FAILED;

}

Additional Notes

See Also

· JDB_ValidateTableSpecs


JDB_InsertTable

Last Modified: B733.1 | June 04, 1999

JDB_InsertTable inserts a record into a specific table. It is used to add new rows to a specific table.

Syntax

JDEDB_RESULT JDB_InsertTable (HREQUEST hRequest, NID szTable, ID idInstance, void * lpStruct);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
szTable | Table ID to insert. |
idInstance | Instance ID of table. Used if joins, otherwise pass zero. |
lpStruct | Pointer to structure or NULL. If no structure is to be used then pass NULL. This structure contains the data to be inserted into the table. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_InsertTable */

HREQUEST hRequest = NULL;

NID szTable = NID_F0101;

JDEDB_RESULT rcode;

F0101 dsStructToInsert;

/* Clear the column buffer */

JDB_ClearColBuffer(hRequest, &dsStructToInsert);

/* Fill in the structure containing data you wish to insert */

ParseNumericString(&dsStructToInsert.aban8, "999999");

strcpy(dsStructToInsert.abtax, "000011171");

strcpy(dsStructToInsert.abalph, "John Doe");

strcpy(dsStructToInsert.abdc, "DOEJOHN");

strcpy(dsStructToInsert.abmcu, "100");

rcode = JDB_InsertTable(hRequest, szTable, (ID)0, &dsStructToInsert);

if (rcode != JDEDB_PASSED)

{

printf(“JDB_InsertTable failed\n”);

} /* END IF */

See Also

  • JDB_AlterTable

  • JDB_CloseTable

  • JDB_CreateTable

  • JDB_DeleteTable

  • JDB_DropTable

  • JDB_OpenTable

  • JDB_UpdateTable


JDB_InsertView

Last Modified: B733.1 | June 04, 1999

JDB_InsertView inserts a record into table involved in a business view.

Syntax

JDEDB_RESULT JDB_InsertView(HREQUEST hRequest, void * lpStruct);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
lpStruct | Pointer to structure or NULL. If no structure is to be used then pass NULL. This structure contains the data to insert into the view. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

  • JDB_CloseView

  • JDB_InsertView

  • JDB_OpenView

  • JDB_UpdateView


JDB_RollbackUser

Last Modified: B733.1 | June 04, 1999

JDB_RollbackUser rolls back a transaction. This should be called when any operation in a transaction failed. This rollbacks the database to a consistent state that existed at the beginning of the transaction.

Syntax

JDEDB_RESULT JDB_RollbackUser(HUSER hUser);

Parameters

Parameter | Notes | Usage
hUser | Valid user handle. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

  • JDB_CommitUser


JDB_SelectAll

Last Modified: B733.1 | June 04, 1999

JDB_SelectAll performs a select on a table without a WHERE clause. This causes all records to be selected.

Syntax

JDEDB_RESULT JDB_SelectAll(HREQUEST hRequest);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_SelectAll */

HREQUEST hRequest = NULL;

rcode = JDB_SelectAll(hRequest);

if (rcode != JDEDB_PASSED)

{

printf("JDB_SelectAll failed\n");

} /* END IF */


JDB_SelectKeyed

Last Modified: B733.1 | June 04, 1999

JDB_SelectKeyed performs a select on a table using the identified index and any custom selection and sequencing. Sending a zero in the number of keys to be used will cause the index to be ignored; however, if custom selection was identified it will always be used in this API. This only selects records matching the index (if used) exactly.

Syntax

JDEDB_RESULT JDB_SelectKeyed(HREQUEST hRequest, ID idIndex, void * lpKey, short nNumKeys);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
idIndex | Valid Index ID to use for the selection. If zero index of request is used. |
lpKey | Pointer key structure or NULL. If no structure is to be used then pass NULL. |
nNumKeys | Number of keys to be used. If ON then the request is valid for caching. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_SelectKeyed */

HREQUEST hRequest = NULL;

KEY1_F0101 dsKeySentStruct = {0};

ID idIndex = ID_F0101_ADDRESS;

ParseNumericString(&dsKeySentStruct.aban8,"1001");

rcode = JDB_SelectKeyed(hRequest, idIndex ,&dsKeySentStruct, 1);

if (rcode != JDEDB_PASSED)

{

printf("JDB_SelectKeyed failed\n");

} /* END IF */

See Also

  1. JDB_BuildKeyBuffer

  2. JDB_Fetch

  3. JDB_FetchForUpdate

  4. JDB_FetchKeyed

  5. JDB_FetchKeyedForUpdate

  6. JDB_FetchMatchingKey

  7. JDB_FreeKeyBuffer

  8. JDB_SelectKeyedForUpdate

  9. JDB_SelectKeyedPosition

  10. JDB_SelectKeyedPositionForUpdate


JDB_SelectKeyedDistinct

Last Modified: B733

JDB_SelectKeyedDistinct performs a select on a table, view using the identified index and any custom selection and sequencing. Sending a zero in the number of keys to be used will cause the index to be ignored; however, if custom selection was identified it will always be used in this API. This only selects records matching the index (if used) exactly.

This eliminates duplicates, if they exist, from the result set. The hRequest used in this API should be obtained from a call to JDB_OpenTable or JDB_OpenView where the table is opened with a specified number of columns. If all columns are requested in JDB_OpenTable or if all keyed columns are included in the Open Table call, then JDB_SelectKeyedDistinct will give identical results as SelectKeyed.

Syntax

JDEDB_RESULT JDB_SelectKeyedDistinct(HREQUEST hRequest, ID idIndex, void * lpKey, short nNumKeys);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
idIndex | Valid Index ID to use for the selection. If zero then index of request will be used. |
lpKey | Pointer key structure or NULL. If no structure is to be used then pass NULL. |
nNumKeys | Number of keys to be used. If ON then the request is valid for caching. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_SelectKeyedDistinct*/

HUSER hUser = NULL;

HREQUEST hRequest = NULL;

NID szTable = NID_F0101;

NID nidSelectArray[2] = {NID_ALPH,ID_UPMJ};

ID idIndex = ID_F0101_ADDRESS;

KEY4_F0101 dsKeySentStruct = {0};

unsigned short nNumCols = 2;

rcode = JDB_OpenTable(hUser,szTable,idIndex,nidSelectArray,nNumCols,”Access32”,&hRequest);

ParseNumericString(&dsKeySentStruct.abtax,"1001");

rcode = JDB_SelectKeyedDistinct(hRequest, idIndex , &dsKeySentStruct, 1);

if (rcode != JDEDB_PASSED)

{

printf("JDB_SelectKeyedDistinct failed\n");

} /* END IF */


JDB_SelectKeyedGetCount

Last Modified: B733

JDB_SelectKeyedGetCount gets a count of the number of rows in a table using the identified index and / or any custom selection & sequencing. Sending a zero in the number of keys to be used will cause the index to be ignored, however, if custom selection was identified it will always be used in this API. This only counts records matching the index (if used) exactly.

If no index is used, for example, if lpKey is passed in as a NULL and nNumKeys is passed in as a zero, then a count of all the rows in the table is returned.

Syntax

Unsigned long JDB_SelectKeyedGetCount (HREQUEST hRequest, ID idIndex, void * lpKey, short nNumKeys)

Parameters

Parameter | Notes | Usage
hREQUEST | Valid request handle |
idIndex | Valid Index ID to use for selection. If zero, then index of request handle will be used. |
lpKey | Pointer to key structure or NULL. If no structure is to be used then pass NULL. |
nNumKeys | Number of keys to be used. |

Return Value

Return Value | Description
Returns number of records in table corresponding to the selection criteria. |

Example

/* Declare variables associated with JDB_SelectKeyedGetCount*/

HREQUEST hRequest = NULL;

KEY1_F0101 dsKeySentStruct = {0};

ID idIndex = ID_F0101_ADDRESS;

Unsigned long ulCount;

/* We want to know all the records present in the table therefore lpKeyStruct = NULL, NumKeys = 0 */

ulCount = JDB_SelectKeyedGetCount(hRequest, idIndex,NULL, 0);

printf("# of records = %ul",ulCount);

See Also

  • JDB_SelectAll

  • JDB_SelectKeyed

  • JDB_SelectKeyedPosition

  • JDB_SelectKeyedDistinct

  • JDB_SelectKeyedPositionDistinct

  • JDB_SelectKeyedPositionGetCount


JDB_SelectKeyedPosition

Last Modified: B733.1 | June 04, 1999

JDB_SelectKeyedPosition performs a select on a table using the identified index and any custom selection and sequencing. Sending a zero in the number of keys to be used will cause the index to be ignored; however, if custom selection was identified it will always be used in this API. This API will select all records beginning with those matching the used index.

Syntax

JDEDB_RESULT JDB_SelectKeyedPosition(HREQUEST hRequest, ID idIndex, void * lpKey, short nNumKeys);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
idIndex | Valid Index ID to use for the selection. If zero then index of request will be used. |
lpKey | Pointer key structure or NULL. If no structure is to be used then pass NULL. |
nNumKeys | Number of keys to be used. If ON then the request is valid for caching. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_SelectKeyedPosition */

HREQUEST hRequest = NULL;

KEY1_F0101 dsKeySentStruct = {0};

ID idIndex = ID_F0101_ADDRESS;

ParseNumericString(&dsKeySentStruct.aban8,"1001");

rcode = JDB_SelectKeyedPosition(hRequest, idIndex ,&dsKeySentStruct, 1);

if (rcode != JDEDB_PASSED)

{

printf("JDB_SelectKeyedPosition failed\n");

} /* END IF */

See Also

  • JDB_BuildKeyBuffer

  • JDB_Fetch

  • JDB_FetchForUpdate

  • JDB_FetchKeyed

  • JDB_FetchKeyedForUpdate

  • JDB_FetchMatchingKey

  • JDB_FreeKeyBuffer

  • JDB_SelectKeyed

  • JDB_SelectKeyedForUpdate

  • JDB_SelectKeyedPositionForUpdate


JDB_SelectKeyedPositionDistinct

Last Modified: B733

JDB_SelectKeyedPositionDistinct performs a select on a table using the identified index and / or any custom selection & sequencing. Sending a zero in the number of keys to be used will cause the index to be ignored, however, if custom selection was identified it will always be used in this API.

This selects all records beginning with those matching the used index. This also eliminates duplicates , if they exist, from the result set. The hRequest used in this should be obtained from a call to JDB_OpenTable or JDB_Open View where the table is opened with a specified no of columns. If all columns are requested in JDB_Open Table or if all unique key columns are included in the Open Table call, then JDB_SelectKeyedPositionDistinct will give identical results as JDB_SelectKeyedPosition.

Syntax

JDEDB_RESULT JDB_SelectKeyedPositionDistinct (HREQUEST hRequest, ID idIndex, void * lpKey, short nNumKeys)

Parameters

Parameter | Notes | Usage
hREQUEST | Valid request handle |
idIndex | Valid Index ID to use for selection. If zero, then index of request handle will be used. |
lpKey | Pointer to key structure or NULL. If no structure is to be used then pass NULL. |
nNumKeys | Number of keys to be used. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_SelectKeyedPositionDistinct*/

HUSER hUser = NULL;

HREQUEST hRequest = NULL;

NID szTable = NID_F0101;

NID nidSelectArray[2] = {NID_ALPH,NID_UPMJ};

ID idIndex = ID_F0101_ADDRESS;

KEY4_F0101 dsKeySentStruct = {0};

unsigned short nNumCols = 2;

rcode = JDB_OpenTable(hUser,szTable,idIndex,nidSelectArray,nNumCols,"Access32",&hRequest);

ParseNumericString(&dsKeySentStruct.abtax,"1001");

rcode = JDB_SelectKeyedPositionDistinct(hRequest, idIndex , &dsKeySentStruct, 1);

if (rcode != JDEDB_PASSED)

{

printf("JDB_SelectKeyedPositionDistinct failed\n");

} /* END IF */

See Also

  • JDB_SelectAll

  • JDB_SelectKeyed

  • JDB_SelectKeyedPosition

  • JDB_SelectKeyedDistinct

  • JDB_SelectKeyedPositionGetCount

  • JDB_SelectKeyedGetCount


JDB_SelectKeyedPositionForUpdate

Last Modified: B733.1 | June 04, 1999

JDB_SelectKeyedPositionForUpdate performs a select on a table using the identified index and/or any custom selection and sequencing. The FOR UPDATE clause tells a data source that the result set can be modified. This can cause these records to be locked on some DBMS.

Sending a zero in the number of keys to be used will cause the index to be ignored, however, if custom selection was identified it will always be used in this API. This selects all records beginning with those matching the used index. If used with a distinct business view, a Non-distinct SelectKeyedPositionForUpdate will be done as a distinct SelectKeyedPositionForUpdate is not supported.

Syntax

JDEDB_RESULT JDB_SelectKeyedPositionForUpdate(HREQUEST hRequest, ID idIndex, void FAR * lpKeyStruct, short nNumKeys, NID * pID, short nNum);

Parameters

Parameter | Notes | Usage
hRequest | Request handle. | Valid request handle.
idIndex | ID of Index to use for the selection. If zero then index of request will be used. | Valid Index ID.
lpKeyStruct | If no structure is to be used then pass NULL. | FAR Pointer to key structure or NULL.
nNumKeys | If ON then the request is valid for caching. | Number of keys to be used.
pID | These can be got by referring to the header file extension of the table whose rows are being updated. | Index of the structure that contains the column NIDs of the columns to be updated in a particular row of a given table.
nNum |  | Number of columns being updated in a given row.

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_SelectKeyedPositionForUpdate */

HREQUEST hRequest = NULL;

KEY1_F0101 dsKeySentStruct = {0};

ID idIndex = ID_F0101_ADDRESS;

NID pID[1] = {NID_ABAN8};

ParseNumericString(&dsKeySentStruct.aban8,"1001");

rcode = JDB_SelectKeyedPositionForUpdate(hRequest, idIndex ,&dsKeySentStruct, 1,pID,1);

if (rcode != JDEDB_PASSED)

{

printf("JDB_SelectKeyedPositionForUpdate failed\n");

} /* END IF */

See Also

  • JDB_BuildKeyBuffer

  • JDB_Fetch

  • JDB_FetchForUpdate

  • JDB_FetchKeyed

  • JDB_FetchKeyedForUpdate

  • JDB_FetchMatchingKey

  • JDB_FreeKeyBuffer

  • JDB_SelectKeyed

  • JDB_SelectKeyedForUpdate

  • JDB_SelectKeyedPosition


JDB_SelectKeyedPositionGetCount

Last Modified: B733

JDB_SelectKeyedPositionGetCount gets a count of the number of rows in a table using the identified index and / or any custom selection & sequencing. Sending a zero in the number of keys to be used will cause the index to be ignored, however, if custom selection was identified it will always be used in this API. This starts counting all records beginning with those matching the used index.

Syntax

Unsigned long JDB_SelectKeyedPositionGetCount (HREQUEST hRequest, ID idIndex, void * lpKey, short nNumKeys)

Parameters

Parameter | Notes | Usage
hREQUEST | Valid request handle |
idIndex | Valid Index ID to use for selection. If zero, then index of request handle will be used. |
lpKey | Pointer to key structure or NULL. If no structure is to be used then pass NULL. |
nNumKeys | Number of keys to be used. |

Return Value

Return Value | Description
Returns the number of records in the table corresponding to the selection criteria. |

Example

/* Declare variables associated with JDB_SelectKeyedPositionGetCount*/

HREQUEST hRequest = ;NULL;

KEY1_F0101 dsKeySentStruct = {0};

ID idIndex = ID_F0101_ADDRESS;

Unsigned long ulCount;

/* We want to know the count of records present in F0101 that have address book number equal to or greater than 1001 */

ParseNumericString(&dsKeySentStruct.aban8,"1001");

ulCount = JDB_SelectKeyedPositionGetCount(hRequest, idIndex, &dsKeySentStruct, 1);

printf("# of records = %ul",ulCount);

See Also

  • JDB_SelectAll

  • JDB_SelectKeyed

  • JDB_SelectKeyedPosition

  • JDB_SelectKeyedDistinct

  • JDB_SelectKeyedPositionDistinct

  • JDB_SelectKeyedGetCount


JDB_UpdateTable

Last Modified: B733.1 | June 04, 1999

JDB_UpdateTable updates a specific table using the passed index. Use this API to update existing rows in a table.

Syntax

JDEDB_RESULT JDB_UpdateTable(HREQUEST hRequest, NID szTable, ID idInstance, ID idIndex, void * lpKey, short nNumKeys, void * lpStruct);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
szTable | Table NID to update. |
idInstance | Instance ID of table. Used if joins; otherwise pass zero. |
idIndex | Index ID to use for update or NULL. If NULL then primary index will be used. |
lpKey | Pointer key structure or NULL. If no structure is to be used then pass NULL. |
nNumKeys | Number of keys to be used. If ON then the request is valid for caching. |
lpStruct | Pointer to structure or NULL. If no structure is to be used then pass NULL. This structure contains the data to be used to update the table. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_UpdateTable */

HREQUEST Request = NULL;

JDEDB_RESULT rcode;

NID szTable = NID_F0101;

ID idIndex = ID_F0101_ADDRESS;

KEY1_F0101 dsKeySentStruct = {0};

F0101 dsStructToInsert = {0};

/* Fill in the data which you wish to insert into row */

strcpy(dsStructToInsert.abalph, "John Doe”);

strcpy(dsStructToInsert.abdc, "DOEJOHN”);

rcode = JDB_UpdateTable(hRequest, szTable, 0, idIndex, &dsKeySentStruct,1, &dsStructToInsert);

if(rcode != JDEDB_PASSED)

{

printf("JDB_UpdateTable failed\n");

} /* END IF */

See Also

  • JDB_AlterTable

  • JDB_CloseTable

  • JDB_CreateTable

  • JDB_DeleteTable

  • JDB_DropTable

  • JDB_InsertTable

  • JDB_OpenTable


JDB_UpdateTableCols

Last Modified: B733.2 | August 27, 1999

This API updates certain specified columns for a table request. The table to be updated needs, however, to be opened with all its columns specified.

Syntax

JDEDB_RESULT JDB_UpdateTableCols(HREQUEST hRequest, NID szTable,ID idInstance, ID idIndex, void * lpKeyStruct,short nNumKeys, void * lpStruct, NID * pID, short nNum)

Parameters

Parameter | Notes | Usage
hRequest | Valid Request Handle for a full table. |
SzTable | Valid table NID. |
IdInstance | Instance ID of table. |
IdIndex | Index used for the update. |
LpKeyStruct | Pointer to key structure or NULL. If no structure is to be used, then pass NULL. |
NNumKeys | Number of keys in the key structure. |
lpStruct | Pointer to structure or NULL. If no structure is to be used then pass NULL This structure is used to update the table record. |
PID | Array of column NIDs that would be updated. |
NNum | Number of columns in the pID array. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

· JDB_UpdateTable

· JDB_ UpdateView

· JDB_InsertTable

· JDB_DeleteTable


JDB_UpdateTableColsExtended

Last Modified: B733.2 | September 28, 1999

This API updates certain specified columns for a table request. The table to be updated needs, however, to be opened with all its columns specified. An Update option specified is used to enable/ disable optimistic locking. An update option of JDB_API_OPTION_CHECK_RECORD_CHANGE would cause the user to receive a warning if the record that he is trying to update has been changed by another user since the time the user fetched it.

Syntax

JDEDB_RESULT PASCAL _export JDB_UpdateTableColsExtended(HREQUEST hRequest, NID szTable, ID

idInstance, ID idIndex, void * lpKeyStruct, short nNumKeys, void * lpStruct, NID * pID, short

nNum, JDB_API_OPTION nUpdateOption)

Parameters

Parameter | Notes | Usage
hRequest | Valid Request Handle for a full table. |
SzTable | Valid table NID. |
IdInstance | Instance ID of table. |
IdIndex | Index used for the update. |
*LpKeyStruct | Pointer to key structure or NULL. If no structure is to be used, then pass NULL. |
NNumKeys | Number of keys in the key structure. |
*lpStruct | Pointer to structure or NULL. If no structure is to be used, then pass NULL. This structure is used to update the table record. |
*PID | Array of column NID's that would be updated. |
NNum | Number of columns in the pID array. |
nUpdateOption | JDB_API_OPTION_DEFAULT or JDB_API_OPTION_CHECK_RECORD_CHANGE optimistic record locking option. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

  1. JDB_UpdateTableCols

  2. JDB_ UpdateView

  3. JDB_InsertTable

  4. JDB_DeleteTable


JDB_UpdateView

Last Modified: B733

JDB_UpdateView updates records for tables involved in a business view. This should be used to update records already been fetched.

Syntax

JDEDB_RESULT JDB_UpdateView (HREQUEST hRequest, void * lpstruct, void * lpKey);

Parameters

Parameter | Notes | Usage
hRequest | Valid Request Handle | Obtained from JDB_OpenView
lpStruct | Pointer to structure or NULL. If no structure is to be used then pass NULL This structure is used to update the business view with |
lpKey | Pointer to key structure or NULL. If no structure is to be used then pass NULL. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

  • JDB_UpdateTable

  • JDB_DeleteView

  • JDB_InsertView

  • JDB_InsertTable

  • JDB_DeleteTable


JDB_ValidateTableSpecs

First Available: B9

Last Modified:

JDB_ValidateTableSpecs would validate the existing table specs or the specs for the table under creation. If the limits exceed EnterpriseOne supported limits, table creation/generation would be aborted except for MaxTotalIndexLength. In this case, a warning will be returned instead.

Syntax

JDEDB_RESULT JDB_ValidateTableSpecs(HUSER hUser, NID szTable, char FAR * szDS)

Parameters

Parameter | Notes | Usage
Huser | NULL or valid user handle. | NULL or valid user handle.
SzTable | Table for which the specs have to be validated. | Valid table name
SzDS | Datasource name where the table resides | Not used.

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this API succeeds
JDEDB_FAILED | Return value if this API fails

Example

rcode = JDB_ValidateTableSpecs(hUser, szTable, szDS);

if (rcode != JDEDB_PASSED)

{

jdeWriteLog("JDB", 0, "JDB3100076 - Failed to validate table specs");

return JDEDB_FAILED;

}

else

{

jdeTraceSz(NULL, “Exiting JDB_ValidateTableSpecs With Success”);

return JDEDB_PASSED;

}

Additional Notes

See Also

· JDB_GetTableProperties


OneWorld Max Values

List of OneWorld supported property values

OneWorld Max Values

Property Name

OW Max

MaxTableNameLength

18

MaxIndexNameLength

18

MaxColumnNameLength

18

MaxNumberColumnsInTable

500

MaxNumberColumnsInIndex

16

MaxNumberIndexesInTable

250

MaxNumberBLOB

1

MaxTotalRowLength

8060

MaxTotalIndexLength

900

OneWorld Min Values

Property Name

OW Min

MinTableNameLength

1

MinIndexNameLength

1

MinColumnNameLength

1

MinNumberColumnsInTable

1

MinNumberColumnsInIndex

1

MinNumberIndexesInTable

0

MinNumberBLOB

0

MinTotalRowLength

1

MinTotalIndexLength

1


Locking APIs

Major databases use sophisticated locking techniques to handle concurrent transactions in SQL for many simultaneous users. However, the underlying concepts behind locking and transaction processing in any database are essentially the same, in that the locking technique used, temporarily gives a transaction exclusive access to a piece of a database, which may be a row or a table which is being currently modified, preventing other transactions from modifying the locked data. Locking thus resolves all three of the concurrent transaction problems.

It prevents lost updates, uncommitted data, and inconsistent data from corrupting the database.

Locking, however introduces drawbacks. It may cause a transaction to wait a long time while the pieces of the database that the transaction wants to access are locked by other transactions with priority.

Locking API's are classified into the following categories:

 | JDB_DeleteCurrent
 | JDB_FetchForUpdate
app.gif (808 bytes) | JDB_FetchKeyedForUpdate
 | JDB_SelectAllForUpdate
app.gif (808 bytes) | JDB_SelectKeyedForUpdate
 | JDB_SelectKeyedPositionForUpdate
app.gif (808 bytes) | JDB_UpdateCurrent
 | jdeGetCriticalSection
app.gif (808 bytes) | jdeLockCriticalSection
app.gif (808 bytes) | jdeUnLockCriticalSection


JDB_DeleteCurrent

Last Modified: EnterpriseOne | June 06, 2000

JDB_DeleteCurrent deletes the fetched record and releases the lock on it when it is going against a lock-supported database. Use this to delete the rows selected by one of the following APIs:

· JDB_SelectAllForUpdate

· JDB_SelectKeyedForUpdate

· JDB_SelectKeyedPositionForUpdate

· JDB_FetchKeyedForUpdate

Syntax

JDEDB_RESULT JDB_DeleteCurrent(HREQUEST hRequest, NID szTable, ID idInstance , ID idIndex, void * lpKeyStruct, short nNumKeys);

Parameters

Parameter | Notes | Usage
hRequest | Request handle. | Valid request handle.
szTable | Table NID to delete. | Table to delete.
idInstance | Used if joins; otherwise pass zero. | Instance of table.
idIndex | If NULL then primary index will be used. | Index to use for delete or NULL.
lpKeyStruct | If no structure is to be used then pass NULL. | Pointer key structure or NULL.
nNumKeys | If ON then the request is valid for caching. | Number of keys to be used.

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_DeleteCurrent */

HREQUEST Request = NULL;

JDEDB_RESULT rcode;

NID szTable = NID_F0101;

ID idIndex = ID_F0101_ADDRESS;

KEY1_F0101 dsKeySentStruct = {0};

int nNumKeys = 1;

ParseNumericString(&dsKeySentStruct.aban8,"1001");

rcode = JDB_DeleteCurrent(hRequest, szTable, 0, idIndex, &dsKeySentStruct, nNumKeys);

if (rcode != JDEDB_PASSED)

{

printf("JDB_DeleteCurrent failed\n");

} /* END IF */


JDB_FetchForUpdate

Last Modified: B733.1 | June 04, 1999

JDB_FetchForUpdate fetches results of a select for update. Results are fetched in order. This API cannot be used to fetch records that are locked. This API is to be used only when you have called a locking API prior to it. These locking APIs may be any of the following:

  • JDB_SelectKeyedForUpdate

  • JDB_SelectAllForUpdate

  • JDB_SelectKeyedPositionForUpdate

Syntax

JDEDB_RESULT JDB_FetchForUpdate(HREQUEST hRequest, void * lpStruct, int nNotUsed);

Parameters

Parameter | Notes | Usage
hRequest | Request handle. | Valid request handle.
lpStruct | If no structure is to be used then pass NULL. | Pointer to results structure or NULL.
nNotUsed |  |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/*Declare variables associated with JDB_FetchForUpdate */

HREQUEST hRequest = NULL;

F0101 dsKeyStructFetchAll = {0};

int nNotUsed = 0;

NID pID [1] = {NID_AN8};

/* There must be a selection executed prior to executing a fetch */

if((rcode = JDB_SelectAllForUpdate(hRequest,pID, 1)) == JDEDB_PASSED)

{

/* Fetch all the selected records for update */

while((rcode = JDB_FetchForUpdate(hRequest, &dsKeyStructFetchAll, nNotUsed)) ==JDEDB_PASSED)

{

/* Process the fetched records */

} /* END WHILE */

} /* END IF *

See Also

  • JDB_BuildKeyBuffer

  • JDB_Fetch

  • JDB_FetchForUpdate

  • JDB_FetchKeyed

  • JDB_FetchKeyedForUpdate

  • JDB_FetchMatchingKey

  • JDB_FreeKeyBuffer

  • JDB_SelectKeyed

  • JDB_SelectKeyedForUpdate

  • JDB_SelectKeyedPosition

  • JDB_SelectKeyedPositionForUpdate


JDB_FetchKeyedForUpdate

Last Modified: B733.1 | June 04, 1999

JDB_FetchKeyedForUpdate performs a select as well as fetch results. The FOR UPDATE clause tells a data source that the result set can be modified. This can cause these records to be locked on some DBMS.

Syntax

JDEDB_RESULT JDB_FetchKeyedForUpdate(HREQUEST hRequest, ID idIndex, void FAR * lpKeyStruct, short nNumKeys, void FAR * lpValue, NID *pID, short nNum );

Parameters

Parameter | Notes | Usage
hRequest | Request handle. | Valid request handle.
idIndex | ID of Index to use for the selection. If zero then index of request will be used. | Valid Index ID.
lpKeyStruct | If no structure is used, then NULL. | Pointer key structure or NULL.
nNumKeys | If ON then the request is valid for caching. | Number of keys to be used.
LpValue | If no structure is to be used then pass NULL. | Pointer to results structure or NULL.
PID | These can be got by referring to the header file extension of the table whose rows are being updated. | Index of the structure which contains the column NIDs of the columns to be updated in a particular row of a given table.
nNum |  | Number of columns being updated in a given row.

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_FetchKeyedForUpdate */

HREQUEST hRequest = NULL;

ID idIndex = ID_F0101_ADDRESS;

KEY1_F0101 dsKeySentStruct = {0};

F0101 dsKeyStructToInsert = {0};

short nNumKeys = 1;

NID pID[1] = {NID_AN8};

short nNum = 1;

ParseNumericString(&dsKeySentStruct.aban8,"1002");

rcode = JDB_FetchKeyedForUpdate(hRequest, idIndex, &dsKeySentStruct, nNumKeys,&dsKeyStructToInsert, pID, nNum);

if(rcode != JDEDB_PASSED)

{

printf(“JDB_FetchKeyedForUpdate failed\n”);

} /* END IF */

See Also

  • JDB_BuildKeyBuffer

  • JDB_Fetch

  • JDB_FetchForUpdate

  • JDB_FetchKeyed

  • JDB_FetchMatchingKey

  • JDB_FreeKeyBuffer

  • JDB_SelectKeyed

  • JDB_SelectKeyedForUpdate

  • JDB_SelectKeyedPosition

  • JDB_SelectKeyedPositionForUpdate


JDB_SelectAllForUpdate

Last Modified: B733.2 | June 04, 1999

JDB_SelectAllForUpdate performs a select for update on a table without a WHERE clause. This will cause all records to be selected for update. The FOR UPDATE clause tells a data source that the result set can be modified. This can cause all these records to be locked on some DBMS.

Syntax

JDEDB_RESULT JDB_SelectAllForUpdate(HREQUEST hRequest, NID *pID, short nNum);

Parameters

Parameter | Notes | Usage
hRequest | Request handle | Input
pID | These can be obtained by referring to the header file extension of the table whose rows are being updated. | Input
nNum |  | Input

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_SelectAllForUpdate */

HREQUEST hRequest = NULL;

NID pID[1] = {NID_AN8};

rcode = JDB_SelectAllForUpdate(hRequest,pID,1);

if (rcode != JDEDB_PASSED)

{

printf("JDB_SelectAllForUpdate failed\n");

} /* END IF */


JDB_SelectKeyedForUpdate

Last Modified: B733.2 | June 04, 1999

JDB_SelectKeyedForUpdate performs a select for update on a table using the identified index and/or any custom selection and sequencing. The FOR UPDATE clause tells a data source that the result set can be modified. This can cause these records to be locked on some DBMS.

Sending a zero in the number of keys to be used will cause the index to be ignored, however, if custom selection was identified it will always be used in this API. This API will only select records matching the index (if used) exactly. If used with a distinct business view then a Non-distinct SelectKeyedForUpdate will be done as distinct SelectKeyedForUpdate is not supported

Syntax

JDEDB_RESULT JDB_SelectKeyedForUpdate(HREQUEST hRequest, ID idIndex, void FAR * lpKeyStruct, short nNumKeys, NID * pID, short nNum),

Parameters

Parameter | Notes | Usage
hRequest | Request handle | Valid request handle.
idIndex | ID of Index to use for the selection. If zero index of request is used. | Index to use for update or NULL.
lpKeyStruct | If no structure is to be used then pass NULL | Pointer key structure or NULL.
nNumKeys | If ON then the request is valid for caching. | Number of keys to be used.
pID | These can be got by referring to the header file extension of the table whose rows are being updated | Index of the structure that contains the column NIDs of the columns to be updated in a particular row of a given table.
nNum |  | Number of columns being updated in a given row.

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_SelectKeyedForUpdate */

HREQUEST hRequest = NULL;

KEY1_F0101 dsKeySentStruct = {0};

ID idIndex = ID_F0101_ADDRESS;

NID pID[1] = {NID_AN8};

ParseNumericString(&dsKeySentStruct.aban8,"1001");

rcode = JDB_SelectKeyedForUpdate(hRequest, idIndex ,&dsKeySentStruct, 1,pID,1);

if (rcode != JDEDB_PASSED)

{

printf("JDB_SelectKeyedForUpdate failed\n");

} /* END IF */

See Also

  • JDB_BuildKeyBuffer

  • JDB_Fetch

  • JDB_FetchForUpdate

  • JDB_FetchKeyed

  • JDB_FetchKeyedForUpdate

  • JDB_FetchMatchingKey

  • JDB_FreeKeyBuffer

  • JDB_SelectKeyed

  • JDB_SelectKeyedPosition

  • JDB_SelectKeyedPositionForUpdate


JDB_UpdateCurrent

Last Modified: B733.1 | June 04, 1999

JDB_UpdateCurrent updates a specific table using the passed index. Use this API to update the rows selected by one of the following APIs:

  • JDB_SelectAllForUpdate

  • JDB_SelectKeyedForUpdate

  • JDB_SelectKeyedPositionForUpdate

  • JDB_FetchKeyedForUpdate

This updates the fetched record and releases the lock on it when it is going against a lock-supported database.

Syntax

JDEDB_RESULT JDB_UpdateCurrent(HREQUEST hRequest, NID szTable, ID idInstance, ID idIndex, void * lpKeyStruct, short nNumKeys, void * lpStruct);

Parameters

Parameter | Notes | Usage
hRequest | Request handle. | Valid request handle.
szTable | Table NID to update. | Table to update.
idInstance | Used if joins, otherwise pass zero. | Instance of table.
idIndex | If NULL then primary index will be used. | Index to use for update or NULL.
lpKeyStruct | If no structure is to be used then pass NULL. | Pointer key structure or NULL.
nNumKeys | If ON then the request is valid for caching. | Number of keys to be used.
lpStruct | If no structure is to be used then pass NULL This structure is used to update table with. | Pointer to structure or NULL.

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_UpdateCurrent */

HREQUEST Request = NULL;

JDEDB_RESULT rcode;

NID szTable = NID_F0101;

ID idIndex = ID_F0101_ADDRESS;

KEY1_F0101 dsKeySentStruct = {0};

F0101 dsStructToInsert = {0};

/* Fill in the data which you wish to insert into row */

strcpy(dsStructToInsert.aban8, "1089”);

rcode = JDB_UpdateCurrent(hRequest, szTable, 0, idIndex, &dsKeySentStruct,1, &dsStructToInsert);

if(rcode != JDEDB_PASSED)

{

printf("JDB_UpdateCurrent failed\n");

} /* END IF */

See Also

  • JDB_SelectAllForUpdate

  • JDB_SelectKeyedForUpdate

  • JDB_SelectKeyedPositionForUpdate

  • JDB_FetchKeyedForUpdate


jdeGetCriticalSection

Last Modified: B733.1 | June 04, 1999

jdeGetCriticalSection gets the critical section handle to be used by jdeLockCriticalSection.

Syntax

JDERTN (HJDECRITICAL) JDEWINAPI jdeGetCriticalSection(char * szName);

Parameters

Parameter | Notes | Usage
SzName | The string will contain the table name of the table under consideration. |

Return Value

Return Value | Description
A handle for the API jdeLockCriticalSection |
A handle for the API jdeUnLockCriticalSection |

See Also

  • jdeLockCriticalSection

  • jdeUnLockCriticalSection


jdeLockCriticalSection

Last Modified: B733.1 | June 04, 1999

jdeLockCriticalSection should be called before you use any JDB Locking API.

Syntax

JDERTN (void) JDEWINAPI jdeLockCriticalSection(HJDECRITICAL hCritical);

Parameters

Parameter | Notes | Usage
HCritical | Valid handle. |

Return Value

Return Value | Description
None |

See Also

  • jdeGetCriticalSection

  • jdeUnLockCriticalSection


jdeUnLockCriticalSection

Last Modified: B733.1 | June 04, 1999

jdeUnLockCriticalSection should be called just after you are finished using any JDB Locking APIs.

Syntax

JDEWINAPI jdeUnLockCriticalSection(HJDECRITICAL hCritical);

Parameters

Parameter | Notes | Usage
HCritical | Valid handle. |

Return Value

Return Value | Description
None |

Example

Sample Business Function( )

{

static HJDECRITICAL hCritical = NULL;

static int nCriticalLoaded = FALSE;

if (nCriticalLoaded == FALSE)

{

hCritical = jdeGetCriticalSection("F4101");

hCriticalLoaded = TRUE;

}

----Bunch of Code ---

jdeLockCriticalSection(hCritical);

Code to perform

SELECT FOR UPDATE,

FETCH FOR UPDATE

UPDATE/DELETE/INSERT

(We need as little code as possible here between the jdeLockCriticalSection and the jdeUnLockCriticalSection),

jdeUnLockCriticalSection(hCritical);

}

See Also

  • jdeGetCriticalSection

  • jdeLockCriticalSection


Initialization

Initialization consist of the following APIs:

 | JDB_FreeBhvr
app.gif (808 bytes) | JDB_FreeEnv
 | JDB_FreeUser
app.gif (808 bytes) | JDB_InitBhvr
 | JDB_InitEnv
 | JDB_InitEnvOvr()
 | JDB_InitSecondaryEnv()


JDB_FreeBhvr

Last Modified: B733.1 | June 04, 1999

JDB_FreeBhvr frees a user and all related requests. This means that the user is removed from the JDB environment and all of the user's pending requests are destroyed. After a call to this API, the user is no longer known within the JDB environment thus any further calls to other JDB APIs except for JDB_InitUser or JDB_InitBhvr will be unsuccessful.

This must be called for every call to JDB_InitBhvr.

Syntax

JDEDB_RESULT JDB_FreeBhvr(HUSER hUser);

Parameters

Parameter | I/O | Notes | Usage
hUser | Input | Valid user handle obtained through JDB_InitBvr. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declaration of environment variables */

HUSER hUser = NULL;

JDEDB_RESULT rcode;

/* Free Bhvr when done processing before freeing the environment */

rcode = JDB_FreeBhvr(hUser);

See Also

  • JDB_InitBhvr


JDB_FreeEnv

Last Modified: B733.1 | June 04, 1999

JDB_FreeEnv frees the JDB environment. In addition, It frees the environment handle that was initialized by JDB_InitEnv. Furthermore, it is the last JDB API called when working within the JDE environment. This function must only be called by executables.

Syntax

JDEDB_RESULT JDB_FreeEnv (HENV hEnv);

Parameters

Parameter | I/O | Notes | Usage
hEnv | Input | Valid environment handle obtained through JDB_InitEnv. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declaration of environment variables */

HENV hEnv = NULL;

JDEDB_RESULT rcode;

/* Free Environment Handle */

rcode = JDB_FreeEnv(hEnv);

if(rcode != JDEDB_PASSED)

{

printf("JDB_FreeEnv failed\n");

return(0)

} /* END IF */

See Also

  • JDB_InitEnv


JDB_FreeUser

Last Modified: B733.1 | June 04, 1999

JDB_FreeUser frees a user and all related requests. This means the user is removed from the JDB environment and all of the user's pending requests are destroyed. After a call to this, the user is no longer known within the JDB environment. Any further calls to other JDB APIs, except for JDB_InitUser or JDB_InitBhvr, will be unsuccessful.

This must be called for every call to JDB_InitUser.

Syntax

JDEDB_RESULT JDB_FreeUser(HUSER hUser);

Parameters

Parameter | I/O | Notes | Usage
hUser | Input | Valid user handle obtained through JDB_InitUser. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declaration of environment variables */

HUSER hUser = NULL;

JDEDB_RESULT rcode;

/* Free user when done processing before freeing the environment */

rcode = JDB_FreeUser(hUser);

See Also

  • JDB_InitBhvr

  • JDB_InitUser


JDB_InitBhvr

Last Modified: B733.1 | June 04, 1999

JDB_InitBhvr initializes a user and registers the user within the JDB environment identified by the ipBhvr. This is similar in function to JDB_InitUser except that it is meant to be called by business function. The user handle that is returned from the API will identify all operations within the JDB environment. A user is usually an application or business function and is a method of grouping database requests from the same application together.

In addition, the user indicates the commitment mode for all the database operation that will take place. This means that all the database operations by the user will be associated with the same commitment mode.

Please do not use the manual commitment mode unless you absolutely have to.

Syntax

JDEDB_RESULT JDB_InitBhvr(void * lpBhvr, HUSER * hUser, char * szApp, JDEDB_COMMIT nCommitMode);

Parameters

Parameter

I/O

Notes

Usage

lpBhvr

Input

Valid environment handle pointer.

hUser

Output

NULL or valid user handle.

szApp

Input

Valid string pointer of active application.

nCommitMode

Input

  1. JDEDB_COMMIT_AUTO if transactions are to be committed automatically.

  2. JDEDB_COMMIT_MANUAL if transactions are to be committed manually.

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_InitBhvr */

HUSER hUser = NULL;

LPBHVRCOM lpBhvrCom;

JDEDB_RESULT rcode;

Rcode = JDB_InitBhvr(lpBhvrCom, &hUser, “P0101”, JDEDB_COMMIT_AUTO);

if(rcode != JDEDB_PASSED)

{

printf("JDB_InitUser failed\n");

} /*END IF */

See Also

  • JDB_FreeBhvr


JDB_InitEnv

Last Modified: EnterpriseOne | June 06, 2000

JDB_InitEnv initializes a JDB environment. Without an initialized environment, no JDB API can work. The environment handle initialized here is needed for the call to JDB_InitUser.

Syntax

JDEDB_RESULT JDB_InitEnv (HENV * hEnv);

Parameters

Parameter | I/O | Notes | Usage
hEnv | Output | The environment handle is initialized by the API. This handle will be used by other APIs as input, like JDB_InitBhvr. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declaration of environment variables */

HENV hEnv = NULL;

JDEDB_RESULT rcode;

/* Initialize Environment Handle */

rcode = JDB_InitEnv(&hEnv);

if (rcode != JDEDB_PASSED)

{

printf("JDB_InitEnv failed\n");

return(0)

} /* END IF */

See Also

  • JDB_FreeEnv


JDB_InitEnvOvr()

Last Modified: EnterpriseOne | June 06, 2000

JDB_InitEnvOvr() initializes a JDB environment, usually on the servers. This API passes the environment name, user name, and password for signing on to the environment. In addition, without an initialized environment, no JDB API will work. The environment handle initialized here is needed for the call to JDB_InitUser.

Parameters

Parameter | I/O | Notes | Usage
hEnv | Input | The primary environment |
szUserName | Input | The user name to sign on this environment |
szPassword | Input | The password of the user |

Syntax

JDEDB_RESULT JDB_InitEnvOvr(HENV hEnv, char*szEnv, char*szUserName, char*szPassword)

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

HENV hEnv = NULL;

JDEDB_RESULT rcode;

rcode = JDB_initEnvOvr(&hEnv, "ADEVCLA", "AB1234567", "AB1234567_PSD");


JDB_InitSecondaryEnv()

Last Modified: EnterpriseOne | June 06, 2000

JDB_InitSecondaryEnv() initializes a secondary JDB environment after the primary environment via a call to the JDB_InitEnv API. In addition, it initializes an environment handle that can be used to initialize user handles via JDB_InitUser for the secondary environment.

Syntax

JDEDB_RESULT JDB_InitSecondaryEnv (HENV hEnv, HENV * h2ndEnv, char * szEnv);

Parameters

Parameter | I/O | Notes | Usage
hEnv | Input | The primary environment handle |
h2ndEnv | Output | The environment handle initialized by the API |
szEnv | Input | The secondary environment name |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

HENV hEnv = NULL;

HENV hEnv2 = NULL;

JDEDB_RESULT rcode;

rcode = JDB_initEnv(&hEnv);

rocde = JDB_InitSecondaryEnv(hEnv, &hEnv2, "ADEVACLA");


Miscellaneous JDEBASE

Miscellaneous JDEBASE consist of the following APIs:

 | JDB_AssignColumnValue |  | JDB_GetUserLevelCount
app.gif (808 bytes) | JDB_BuildBuffer | app.gif (808 bytes) | JDB_RegisterEnvironment
 | JDB_BuildKeyBuffer |  | JDB_ReInitUser
app.gif (808 bytes) | JDB_ClearColBuffer | app.gif (808 bytes) | JDB_SetBLOBSize
 | JDB_ColumnRequired |  | JDB_SetEnv
app.gif (808 bytes) | JDB_FreeBuffer | app.gif (808 bytes) | JDB_SetF986110
app.gif (808 bytes) | JDB_FreeKeyBuffer |  | JDB_SetF98DR
 | JDB_GetEnv | app.gif (808 bytes) | JDB_SetKernelType
 | JDB_GetEnvLevelCount |  | JDB_SetMessages
 | JDB_GetLastDBError | app.gif (808 bytes) | JDB_SetOCM
app.gif (808 bytes) | JDB_GetNumColumns |  | JDB_ShowPerformInfo
 | JDB_GetObjectDataSource | app.gif (808 bytes) | JDB_ShowReqCacheInfo
app.gif (808 bytes) | JDB_GetPassword |  | JDB_StartRetainPrevious
 | JDB_GetTableColInfo | app.gif (808 bytes) | JDB_StopRetainPrevious
app.gif (808 bytes) | JDB_GetTableColValue |  | JDB_SwitchTableLocation
 | JDB_GetUser | app.gif (808 bytes) | JDB_ValidConversion


JDB_AssignColumnValue

Last Modified: EnterpriseOne | June 06, 2000

JDB_AssignColumnValue initializes a requested column with the passed value.

Syntax

JDEDB_RESULT JDB_AssignColumnValue(HREQUEST hRequest, DBREF dbItem, ID idType, void * lpValue);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
dbItem | Structure containing valid IDs for the item, table, and the table instance. |
idType | JDE type of passed value. |
lpValue | Pointer to value |

Return Value

This will fail if the value is not the proper type.

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

zDbRef .idInstance =0;

jdeNIDCPY (zDbRef.szTable,"F41018");

jdeNIDCPY (zDbRef.szDict, "MCU");

if (JDB_AssignColumnValue (hRequest, zDbRef,2L,(LPVOID) lpDS->szBranchPlant) !=JDEDB_PASSED

{

}


JDB_BuildBuffer

Last Modified: B733.1 | June 04, 1999

JDB_BuildBuffer builds a buffer and copies passed values to the buffer based on the passed information.

Syntax

void * JDB_BuildBuffer(LPINFO lpStruct, unsigned short nNumKeys);

Parameters

Parameter | Notes | Usage
LpStruct | Pointer to structure with information on buffer columns. |
NNumKeys | Number of information structures passed. |

Return Value

Return Value | Description
Returns pointer to the buffer | Return pointer to the buffer if the API is successful
NULL | Return value if the API fails

See Also

  • JDB_FreeBuffer


JDB_BuildKeyBuffer

Last Modified: B733.1 | June 04, 1999

JDB_BuildKeyBuffer builds a buffer and copies passed values to the buffer based on the passed information.

Syntax

void * JDB_BuildKeyBuffer(LPKEYINFO lpKeyStruct, unsigned short nNumKeys);

Parameters

Parameter | Notes | Usage
lpKeyStruct | Pointer to key structure. |
nNumKeys | Number of key structures passed. |

Return Value

Return Value | Description
Returns pointer to the buffer | Return pointer to the buffer if the API is successful
NULL | Return value if the API fails

See Also

  • JDB_Fetch

  • JDB_FetchForUpdate

  • JDB_FetchKeyed

  • JDB_FetchKeyedForUpdate

  • JDB_FetchMatchingKey

  • JDB_FreeKeyBuffer

  • JDB_SelectKeyed

  • JDB_SelectKeyedForUpdate

  • JDB_SelectKeyedPosition

  • JDB_SelectKeyedPositionForUpdate


JDB_ClearColBuffer

Last Modified: EnterpriseOne | June 06, 2000

JDB_ClearColBuffer sets all values in the request buffer to NULL, 0, or ‘ ‘ based on the type of the column. lpBuffer must match the column requested on JDB_OpenTable or JDB_OpenView.

Syntax

JDEDB_RESULT JDB_ClearColBuffer (HREQUEST hRequest, void * lpBuffer);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
lpBuffer | Pointer to buffer to be cleared. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

if (JDB_ClearColBuffer (hRequest F00021, lpF00021) ! = JDEDB_PASSED

{

}


JDB_ColumnRequired

Last Modified: B733.2 | June 03, 1999

JDB_ColumnRequired identifies whether the column name passed to the API is on of the index columns in the specified table. Column for which a value must be given (NULL is not allowed).

Syntax

JDEDB_RESULT JDB_ColumnRequired(HREQUEST hRequest, DBREF dbItem);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
dbItem | Structure containing valid IDs for the item, table, and table instance. |

Return Value

This fails when the value is not one of the index columns

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails


JDB_FreeBuffer

Last Modified: EnterpriseOne | June 06, 2000

JDB_FreeBuffer frees the buffer created by JDB_BuildBuffer.

Syntax

JDEDB_RESULT JDB_FreeBuffer(void * lpStruct);

Parameters

Parameter | Notes | Usage
lpStruct | Pointer to buffer to be freed. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

· JDB_BuildBuffer


JDB_FreeKeyBuffer

Last Modified: EnterpriseOne | June 06, 2000

JDB_FreeKeyBuffer frees the buffer created by JDB_BuildKeyBuffer.

Syntax

JDEDB_RESULT JDB_FreeKeyBuffer(void * lpStruct);

Parameters

Parameter | Notes | Usage
lpStruct | Pointer to buffer to be freed. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

· JDB_BuildKeyBuffer

· JDB_Fetch

· JDB_FetchForUpdate

· JDB_FetchKeyed

· JDB_FetchKeyedForUpdate

· JDB_FetchMatchingKey

· JDB_SelectKeyed

· JDB_SelectKeyedForUpdate

· JDB_SelectKeyedPosition

· JDB_SelectKeyedPositionForUpdate


JDB_GetEnv

Last Modified: EnterpriseOne | June 06, 2000

JDB_GetEnv gets the global environment handle.

Syntax

JDEDB_RESULT JDB_GetEnv (HENV *hEnv);

Parameters

Parameter | Notes | Usage
hEnv | Valid handle. | JDB Environment handle.

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Additional Notes

This returns a valid global environment handle if it exists, otherwise, NULL will be returned.


JDB_GetEnvLevelCount

Last Modified: EnterpriseOne | June 06, 2000

JDB_GetEnvLevelCount gets the value of the nInitEnvCount element of the EXEINFO structure.

Syntax

int JDB_GetEnvLevelCount(HENV hEnv);

Parameters

Parameter | Notes | Usage
hEnv |  | Obtained from a call to JDB_InitEnv.

Return Value

Return Value | Description
Value of nInitEnvCount | Return value if this is successfully
-1 | Return value if this is unsuccessful

Example

rcode = JDB_GetEnvLevelCount(hEnv);

This call would return the integer value of the nInitEnvCount of the EXEINFO structure.

See Also

· JDB_GetUserLevelCount


JDB_GetLastDBError

Last Modified: EnterpriseOne | June 06, 2000

JDB_GetLastDBError Allows users to get the last error number associated with a particular table or view.

Syntax

JDEDB_RESULT JDB_GetLastDBError(HREQUEST hRequest, JDEDB_ErrMsgType * pnErrorNum)

Parameters

Parameter | Notes | Usage
HRequest | Valid request handle. | JDB will identify all requests made to the particular table by this request handle.
PnErrorNum | Pointer to receive the error number back. |

Return Value

Return Value | Description
Error number to the last parameter of the function | N/A

Example

JDB_GetLastDBError(hRequest, &nErrorNum)

Additional Notes

The following consists of a list of various error message types:

· JDB_ERR_DEFAULT = 0,

· JDB_ERR_TABLE_DOES_NOT_EXIST,

· JDB_ERR_INDEX_DOES_NOT_EXIST,

· JDB_ERR_DUPLICATE_KEY,

· JDB_ERR_INVALID_COLUMN,

· JDB_ERR_DOES_NOT_HAVE_AUTHORITY,

· JDB_ERR_INVALID_USER_OR_PASSWORD,

· JDB_ERR_ROW_SECURITY_INSERT_VIOLATION,

· JDB_ERR_ROW_SECURITY_DELETE_VIOLATION,

· JDB_ERR_ROW_SECURITY_UPDATE_VIOLATION,

· JDB_ERR_ROW_SECURITY_UNKNOWN_VIOLATION,

· JDB_ERR_RECORD_HAS_CHANGED,

· JDB_ERR_LOST_CONNECTION,

· JDB_ERR_QUERY_TIMEOUT,

· JDB_ERR_UNKNOWN,

· JDB_ERR_PKEY_DOES_NOT_EXIST,

· JDB_ERR_FEATURE_NOT_SUPPORTED,

· JDB_ERR_GENERAL_ERROR,

· JDB_ERR_AS400_TABLE_NOT_JOURNALED,

· JDB_ERR_PKEY_ALREADY_EXISTS,

· JDB_ERR_ALTER_COLUMN_IN_USED,

· JDB_ERR_INDEX_ALREADY_EXISTS,

· JDB_ERR_TABLE_ALREADY_EXISTS,

· JDB_ERR_DETAILS_AVAILABLE,

· JDB_ERR_NODBDATA,

· JDB_ERR_CONNECTION_BUSY,

· JDB_ERR_COLUMN_LIST_INDEXED,

· JDB_ERR_OBJECT_IN_USE,

· JDB_ERR_CURSOR_NOT_CLOSE


JDB_GetNumColumns

Last Modified: B733.2 | June 03, 1999

JDB_GetNumColumns returns the number of columns in a table or business view associated with the request handle. The total columns include both selected and non-selected columns.

Syntax

int JDB_GetNumColumns(HREQUEST hRequest)

Parameters

Parameter | Notes | Usage
HRequest | Valid request handle. |

Return Value

Return Value | Description
Total columns | The request is valid
0 | The request is not valid


JDB_GetObjectDataSource

Last Modified: EnterpriseOne | June 06, 2000

JDB_GetObjectDataSource gets the Datasource in which the object resides for a given object NID based on OCM setting.

Syntax

JDEDB_RESULT JDB_GetObjectDataSource (HUSER hUser, NID szObject, char *szObj, char cType, char *szDs);

Parameters

Parameter | Notes | Usage
hUser | Valid user handle. | From JDB_InitUser
*szObject | Object under consideration. Object NID |
szObj | Object under consideration. Object name (DEFAULT, BSFN name, GT Name) |
cType | Type of OW object (JDEDB_OMAP_TABLE, JDEDB_OMAP_BSFN, JDEDB_OMAP_UBE, JDEDB_OMAP_GT) |
*szDs | Datasource in which the object resides. |

Return Value

· Returned in char *szObj

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails


JDB_GetPassword

Last Modified: B733

JDB_GetPasswordhis gets the password for a given environment handle. If the environment handle is NULL, the API will return global password.

Syntax

PJSTR _export JDB_GetPassword( HENV hEnv )

Parameters

Parameter | Notes | Usage
hEnv | Valid handle. JDB Environment handle returned by JDB_GetEnv. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails


JDB_GetTableColInfo

Last Modified: EnterpriseOne | June 06, 2000

DB_GetTableColInfo returns a pointer to the COLINFO structure for a particular column in a requested table.

Syntax

LPCOLINFO JDB_GetTableColInfo (HREQUEST hRequest, DBREF dbItem);

Parameters

Parameter | Notes | Usage
dbItem | Valid IDs for the item, instance, and Table. This is a structure. |

Return Value

Return Value | Description
Pointer to COLINFO structure or NULL |

Example

jdeNIDcpy (dbRef.szTable, NID_F0101);

dbRef.idInstance = 0;

jdeNIDcpy (dbRef.szDict, NID_AN8);

lpCol = JDB_GetTableColInfo (hRequest F0101, dbRef);


JDB_GetTableColValue

Last Modified: EnterpriseOne | June 06, 2000

JDB_GetTableColValue returns a pointer to JDE column value for a particular column in a requested table.

Syntax

void * JDB_GetTableColValue(HREQUEST hRequest, DBREF dbItem);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
dbItem | Structure containing valid IDs for the item, table, and table instance. |

Return Value

Return Value | Description
Pointer value |
NULL |

Example

jdeNIDcpy (dbRef.szTable, NID_F0101);

dbRef. idInstance = 0;

jdeNIDcpy (dbRef.szDict, NID_AN8);

lpCol = JDB_GetTableColInfo (hRequestF0101, dbRef);


JDB_GetUser

Last Modified: B733.2 | June 03, 1999

JDB_GetUser gets the user for a given environment handle. If the given environment handle is NULL, the API will return global user.

Syntax

PJSTR _export JDB_GetUser( HENV hEnv )

Parameters

Parameter | Notes | Usage
hEnv | Valid handle. JDB Environment handle returned by JDB_GetEnv. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails


JDB_GetUserLevelCount

Last Modified: EnterpriseOne | June 06, 2000

JDB_GetUserLevel gets the value of the nCount, an element in the USERINFO structure.

Syntax

int JDB_GetUserLevelCount(HUSER hUser);

Parameters

Parameter | Notes | Usage
Huser | NULL or valid user handle. | Obtained from a call to JDB_InitUser.

Return Value

Return Value | Description
Integer value for nCount | Return value if this is successfully
-1 | Return value if this results in an error

Example

rcode = JDB_GetUserLevelCount(hUser);

This call would return the value of the nCount in the USERINFO structure.

See Also

· JDB_GetEnvLevelCount


JDB_RegisterEnvironment

Last Modified: B733.2 | June 03, 1999

JJDB_RegisterEnvironment returns the environment name and sets the environment-loaded flag to TRUE. For a non-NULL value of the input parameter, the return value is the same as the input parameter. For a NULL value of the environment name and for the environment-loaded flag turned off, the return environment name is set to JDEOPT32.

Syntax

JCHAR * PASCAL _export JDB_RegisterEnvironment(JCHAR * szEnv)

Parameters

Parameter | Notes | Usage
jchar * szEnv | Valid null terminated string pointer. Environment name |

Return Value

Return Value | Description
Environment Name | Returns the environment name


JDB_ReInitUser

Last Modified: B733.2 | June 03, 1999

JDB_ReInitUser is used to reinitialize the valid user handle. It will keep a counter on how many times this user handle has been initialized

Syntax

JDEDB_RESULT JDB_ReInitUser (HUSER hUserHandle);

Parameters

Parameter | Notes | Usage
HUserHandle | Valid user handle. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

  • JDB_InitUser

  • JDB_FreeUser


JDB_SetBLOBSize

Last Modified: B733.2 | June 03, 1999

JDB_SetBLOBSize assigns the specified size of a BLOB (binary large object) to the column passed to the API.

Syntax

void * JDB_SetBLOBSize(HREQUEST hRequest, DBREF dbRef, unsigned long lSize);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
dbRef | Structure containing valid IDs for the item, table, and table instance. |
lSize | Size of BLOB |

Return Value

Return Value | Description
None |


JDB_SetEnv

Last Modified: B733.2 | June 03, 1999

JDB_SetEnv copies the non-NULL user, password and environment strings passed to it into the corresponding global strings for the user, password and environment.

Syntax

JDEDB_RESULT PASCAL _export JDB_SetEnv(HENV hEnv, JCHAR * szUser, JCHAR * szPwd,JCHAR * szEnv, JCHAR *

szRole, JCHAR cNotUsed)

Parameters

Parameter | Notes | Usage
hEnv | Valid environment handle. |
jchar * szUser | Valid null terminated string pointer. User name |
jchar * szPwd | Valid null terminated string pointer. User password |
jchar * szEnv | Valid null terminated string pointer. User environment |
jchar * szRole |  |
jchar cNotUsed | Valid character. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails


JDB_SetF986110

Last Modified: EnterpriseOne | June 06, 2000

JDB_SetF986110 sets the override data source for the F986110 and F986113 tables (Job Control Status Master).

Syntax

Void JDB_SetF986110 (char *szHost);

Parameters

Parameter | Notes | Usage
char *szHost | Valid null terminated string pointer. Data source name. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails


JDB_SetF98DR

Last Modified: EnterpriseOne | June 06, 2000

JDB_SetF98DR sets the override data source for tables F98DRLOG and F98DRPCN.

Syntax

void JDB_SetF98DR(char *szHost)

Parameters

Parameter | Notes | Usage
char *szHost | Valid null terminated string pointer. Data source name. |

Return Value

Return Value | Description
None |


JDB_SetKernelType

Last Modified: B733.2 | June 03, 1999

JDB_SetKernelType sets the global kernel type to the value indicated by nKernelType, such as KERNEL_MDA, KERNEL_WEB, and KERNEL_INSTALL.

Syntax

JDEDB_RESULT JDB_SetKernelType (KERNEL_TYPE nKernelType);

Parameters

Parameter | Notes | Usage
nKernelType | A valid kernel type. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails


JDB_SetMessages

Last Modified: B733.2 | June 03, 1999

JDB_SetMessages sets the global message flag to the value indicated by nFlag (TRUE / FALSE).

Syntax

JDEDB_RESULT JDB_SetMessages (int nFlag);

Parameters

Parameter | Notes | Usage
int nFlag | Flag for setting messages |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails


JDB_SetOCM

Last Modified: EnterpriseOne | June 06, 2000

JDB_SetOCM sets the override data source for tables F986101 and F98611.

Syntax

void JDB_SetOCM (char *szHost);

Parameters

Parameter | Notes | Usage
char *szHost | Valid null terminated string pointer. Datasource name. |

Return Value

Return Value | Description
None |


JDB_ShowPerformInfo

Last Modified: B733

JDB_ShowPerformInfo returns statistics pertaining to the no of calls made to Open Table, Open View, Selects, Fetches, Updates, Deletes.

Syntax

JCHAR FAR * FAR PASCAL _export JDB_ShowPerformInfo(int mode)

Parameters

Parameter | Notes | Usage
int nMode | Flag that indicates the mode of keeping the statistics. |

Return Value

Return Value | Description
String that stores the statics |


JDB_ShowReqCacheInfo

Last Modified: B733.2 | June 03, 1999

JDB_ShowReqCacheInfo goes through all the valid requests in the RequestList and concatenates the table names and business view IDs to the szText string.

Syntax

Void JDB_ShowReqCacheInfo (char *szText, unsigned long lSize);

Parameters

Parameter | Notes | Usage
char * szText | Valid null terminated string pointer. String that contains information about the open tables and business views. |
unsigned long lSize | Valid string length. String length. |

Return Value

Return Value | Description
Void | Return void


JDB_StartRetainPrevious

Last Modified: B733.2 | June 03, 1999

JDB_StartRetainPrevious allocates memory for the lpPreviousValue, member of the COLINFO structure for BLOBs, if the memory has not been already allocated.

Syntax

JDEDB_RESULT JDB_StartRetainPrevious (HREQUEST hRequest);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails


JDB_StopRetainPrevious

Last Modified: B733.2 | June 03, 1999

JDB_StopRetainPrevious sets the nRetainPrevious flag in the USERREQUEST structure to zero.

Syntax

JDEDB_RESULT JDB_StopRetainPrevious (HREQUEST hRequest);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails


JDB_SwitchTableLocation

Last Modified: B733.2 | June 03, 1999

JDB_SwitchTableLocation forces OCM cache to be refreshed on the next InitUser call.

Syntax

JDEDB_RESULT JDB_SwitchTableLocation(HUSER hUser, NID szTable );

Parameters

Parameter | Notes | Usage
hUser | Valid user handle. | From JDB_InitUser.
szTable | Table NID should be entered. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails


JDB_ValidConversion

Last Modified: B733.2 | June 03, 1999

JDB_ValidConversion validates a type conversion. It returns JDEDB_PASSED or JDEDB_FAILED depending on whether the passed types are valid.

Syntax

JDEDB_RESULT JDB_ValidConversion(ID idToType, ID idFromType);

Parameters

Parameter | Notes | Usage
idToType | JDE type of passed value. |
idFromType | JDE type of passed value. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails


Non-JDE Table

Non JDE Table consist of the following APIs:

 | JDB_AssignNonJDETableName
app.gif (808 bytes) | JDB_AssignOriginalJDETableName
app.gif (808 bytes) | JDB_DropForeignTable
app.gif (808 bytes) | JDB_OpenForeignTable
app.gif (808 bytes) | JDB_TableExists
app.gif (808 bytes) | JDB_TableNames


JDB_AssignNonJDETableName

Last Modified: B733.2 | June 03, 1999

JDB_SetSelectionX enables users to define any type of selection on a table associated with a specific initialized request handle. This API will allow us to set precedence on the conditions for the select. Example: We can create a select statement: SELECT * FROM TABLE-NAME WHERE ((COL1 = X AND COL2 = Y) OR (COL 3 = Z)).Syntax

JDEDB_RESULT JDB_AssignNonJDETablename(HREQUEST hRequest, char * szNonJDETablename, char cCreateNonJDETable)

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. | From JDE_OpenTable only.
szNonJDETablename | Null terminated string containing the table name to assign. |
cCreateNonJDETable | TRUE/FALSE. | TRUE for create the table with the temporary name. FALSE denotes the table already exists under the temporary name.

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Create and use a blank copy of the Address Book table, within the same DataSource as the original */

/* Open address book to get specifications */

if ((rcode = JDB_OpenTable(hUser, NID_F0101, 0, NULL, 0, NULL, &hRequest)) == JDEDB_FAILED)

{ /* Failed to open table */};

JDB_AssignNonJDETablename(hRequest, "F0101temp", TRUE);

/* Insert and/or update records in blank temporary copy of the F0101 table */

/* Set table name back to original and delete the temporary table */

JDB_AssignOriginalJDETablename(hRequest, TRUE);

JDB_CloseTable (hRequest);

Additional Notes

  1. If cCreateNonJDETable is set to FALSE and a table with the original specifications does not exist under the new name, subsequent database operations such as SELECT, INSERT, DELETE and UPDATE will fail with a "Table does not exist" error.

  2. The qualified proxy user for used to access the database must have sufficient authority to create and delete tables to use the cCreateNonJDETable = TRUE option.

  3. If the table name has not been restored to the original name by calling JDB_AssignOriginalJDETablename, it will be restored when the hRequest is closed during JDB_CloseTable and a warning message will be generated in the JDE.LOG.

See Also

  • JDB_AssignOriginalJDETablename


JDB_AssignOriginalJDETableName

Last Modified: B733.2 | June 03, 1999

JDB_AssignOriginalJDETableName restores a table name changed by a call to JDB_AssignNonJDETableName. The parameter cDeleteNonJDETable is used to determine if the table should be dropped before the name is restored.

Syntax

JDEDB_RESULT JDB_AssignOriginalJDETablename(HREQUEST hRequest, char cDeleteNonJDETable)

Parameters

Parameters | Notes | Usage
hRequest | Valid request handle. | From JDE_Open Table only
char * cDeleteNonJDETable | TRUE/FALSE. | TRUE to drop the table with the temporary name, FALSE to leave the table in existence.

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Create and use a blank copy of the Address Book table, within the same DataSource as the original */

/* Open address book to get specifications */

if ((rcode = JDB_OpenTable(hUser, NID_F0101, 0, NULL, 0, NULL, &hRequest)) == JDEDB_FAILED)

{ /* Failed to open table */};

JDB_AssignNonJDETablename(hRequest, "F0101temp", TRUE);

/* Insert and/or update records in blank temporary copy of the F0101 table */

/* Set table name back to original and delete the temporary table */

JDB_AssignOriginalJDETablename(hRequest, TRUE);

JDB_CloseTable (hRequest);

Additional Notes

  1. If cDeleteNonJDETable is set to TRUE and a table with the original specifications does not exist under the new name, a "Table does not exist" error will occur.

  2. The qualified proxy user for used to access the database must have sufficient authority to create and delete tables to use the cDeleteNonJDETable = TRUE option.

See Also

  • JDB_AssignNonJDETablename


JDB_DropForeignTable

Last Modified: B733.2 | June 03, 1999

JDB_DropForeignTable removes a non-J.D. Edwards table identified by the given table name from a database. This API is similar to JDB_DropTable. This API has three modes of operation:

  1. szTableName = a valid table name and szTable = NULL or empty. For use with a purely non-J.D. Edwards table, the table specifications are determined through JDB_OpenForeignTable.

  2. szTableName = a valid table name and szTable = a valid NID. Used to drop a table with J.D. Edwards specifications but given an alternate name using JDB_AssignNonJDETablename. This mode uses the table specifications from szTable with the database table name contained in szTableName.

  3. szTableName = NULL or empty and szTable = a valid NID. In this mode, JDB_DropForeignTable works like JDB_DropTable.

Syntax

JDEDB_RESULT FAR PASCAL _export JDB_DropForeignTable(HUSER hUser, JCHAR * szTableNameInput,NID

szTable,JCHAR FAR * szOwner, JCHAR FAR * szPwd, JCHAR FAR * szDS)

Parameters

Parameter | Notes | Usage
hUser | A JDB user handle obtained from a prior call to JDB_InitUser or JDB_InitBhvr. |
szTableNameInput | NULL terminated string containing the database table name. Seventeen characters is the maximum length. | "F0101temp"
szTable | NID of a J.D. Edwards table that will be used as a template. | NID_F0101
szOwner | NULL terminated string containing the override database owner | NULL for default owner
szPwd | NULL terminated string containing the override database owner password | NULL for default password
szDS | NULL terminated string containing the override datasource containing the table | NULL for default datasource based on the environment

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Additional Notes

JDB_DropTable should be used for J.D. Edwards EnterpriseOne tables instead.

See Also

  1. JDB_DropTable

  2. AssignNonJDETablename

  3. AssignOriginalJDETablename


JDB_OpenForeignTable

Last Modified: B733.2 | June 03, 1999

JDB_OpenForeignTable opens a non-J.D. Edwards table identified by the given table name for input / output processing. After successfully preparing the table for input/output, the user is returned a request handle that must be used for every subsequent data manipulation action. This API is similar to JDB_OpenTable. Requests to this table are terminated with JDB_CloseTable.

Syntax

JDEDB_RESULT FAR PASCAL _export JDB_OpenForeignTable(HUSER hUser, JCHAR * szTableNameInput,JCHAR *

szIndexName, JCHAR * lpReqColsArray, ushort nNumReqCols, JCHAR FAR * szDS, JCHAR * szEnv,HREQUEST FAR

*hRequest)

Parameters

Parameter | Notes | Usage
HUSER hUser | A JDB user handle obtained from a prior call to JDB_InitUser or JDB_InitBhvr. |
szTableNameInput | NULL terminates string containing the database table name. Seventeen characters is the maximum length. | "FRST_QTR_RCPTS"
szIndexName | NULL terminates string containing the database index name for the table. Seventeen characters is the maximum length. If NULL, no index is explicitly used. | "FRST_QTR_R_INDX"
lpReqColsArray | Pointer to an array of strings containing the database columns names of the table. Performance can be enhanced if only the columns actually used in processes are opened. A NULL indicates that all columns are to be used. | {"LINE", "JDATE", "COMPANY", "AMOUNT", ....}
nNumReqCols | The number of columns listed within the array lpReqColsArray. A zero is passed if a NULL is used for lpReqColsArray. |
szDS | NULL terminated string containing a datasource name. This is used to override the location of the table as indicated by the Object Map. This is an EnterpriseOne datasource name and not the database name. | "B733_EXTERNAL_TABLES"
szEnv | NULL terminated string containing an environment string. This is used to override the environment specified during logon. This is an EnterpriseOne environment name and not a database or server name. |
HRequest | The returned request handle for this table. All subsequent JDB operations against this table must use this request handle. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

HREQUEST hRequest;

rcode = JDB_OpenForeignTable(hUser, "FRST_QTR_RCPTS", NULL, NULL, 0, "B733_EXTERNAL_TABLES", NULL, &hRequest);

if (rcode == JDEDB_PASSED)

{

/* continue with processing */

Additional Notes

This API should not be used to open tables defined within J.D. Edwards EnterpriseOne. This API queries the database to determine the table specifications and associates those specifications with a reduces set of EnterpriseOne data types. Performance is significantly less than when using JDB_OpenTable.

See Also

  1. JDB_OpenTable

  2. JDB_CloseTable


JDB_TableExists

Last Modified: B733.2 | June 03, 1999

JDB_TableExists determines the physical existence of a table identified by a given table name (not NID). Optional parameters include overrides to the datasource name and owner name.

Syntax

JDEDB_RESULT FAR PASCAL _export JDB_TableExists(HUSER hUser,JCHAR *szDS,JCHAR *szOwner,JCHAR

*szTableName,unsigned short szTableNameLen)

Parameters

Parameter | Notes | Usage
hUser | A JDB user handle obtained from a prior call to JDB_InitUser or JDB_InitBhvr. |
szDS | NULL terminated string containing the override datasource containing the table. | NULL for default datasource based on the environment of the hUser.
*szOwner | NULL terminated string containing the override database table owner. | NULL for default owner based on the datasource.
*szTableName | NULL terminates string containing the database table name. Thirty characters is the maximum length. | "FRST_QTR_RCPTS"
szTableNameLen | Unsigned short containing the length of szTableName | 14

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Additional Notes

This API can be used with both EnterpriseOne and non-EnterpriseOne defined tables.

See Also

  1. JDB_TableNames


JDB_TableNames

Last Modified: B73.1

JDB_TableNames returns the names of one or more tables in a datasource. The datasource and table owner can be overridden from the environment defaults contained within a given user handle.

Syntax

JDEDB_RESULT FAR PASCAL _export JDB_TableNames(HUSER hUser,JCHAR *szDS, JCHAR *szOwner,JCHAR

*szTableName,unsigned short szTableNameLen,int tblmode)

Parameters

Parameter | Notes | Usage
hUser | A JDB user handle obtained from a prior call to JDB_InitUser or JDB_InitBhvr. |
*szDS | NULL terminated string containing an override datasource. | NULL for default datasource based on the environment of the hUser.
*szOwner | NULL terminated string containing the override database table owner. | NULL for default owner based on the datasource.
*szTableName | A pointer to an allocated block of memory that will be returned containing the table name. | Input: "" Returned: "FRST_QTR_RCPTS"
szTableNameLen | Unsigned short containing the maximum allocated space for szTableName. | 30
tblmode | Mode parameter denoting the first usage against a datasource, to return the next table in the same datasource or if no more table names are requested. | JDB_TBNAME_FIRST, JDB_TBNAME_NEXT, JDB_TBNAME_DONE

Return Value

The table name is returned through szTableName.

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* To find the names of all tables with owner "B732CTA" in datasource "B732_Business_Data" */

szTableNameLen = 30;

szTableName = (char *) jdeAllocReturnIfError( DBCOMMON_POOL, (size_t) szTableNameLen,MEM_ZEROINIT);

/* Establish the connection */

rcode = JDB_TableNames(hUser, "B732_Business_Data", "B732CTA", szTableName,

szTableNameLen, JDB_TBNAME_FIRST);

/* Continue to get table names until no more */

while ( rcode == JDEDB_PASSED)

{

rcode = JDB_TableNames(hUser, "B732_Business_Data", "B732CTA", szTableName,

szTableNameLen, JDB_TBNAME_ NEXT);

}

/* Terminate the connection */

JDB_TableNames(hUser, "B732_Business_Data", "B732CTA", szTableName, szTableNameLen, JDB_TBNAME_DONE);

Additional Notes

Calling JDB_TableName with mode JDB_TBNAME_FIRST is used to establish the connection to the database; mode JDB_TBNAME_DONE is used to terminate the connection.

See Also

  1. JDB_TableExists


Request Settings

Request Setting consist of the following APIs:

 | JDB_ClearSelection
app.gif (808 bytes) | JDB_ClearSequencing
 | JDB_SetLowerLimit
app.gif (808 bytes) | JDB_SetRequestTriggerOption
 | JDB_SetSelectionX
app.gif (808 bytes) | JDB_SetSelection
 | JDB_SetSequencing
app.gif (808 bytes) | JDB_SetUserTriggerOption


JDB_ClearSelection

Last Modified: B733.2 | June 03, 1999

JDB_ClearSelection clears any custom selections associated with a specific initialized request handle.

Syntax

JDEDB_RESULT JDB_ClearSelection(HREQUEST hRequest);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. | All subsequent JDB operations against this table must use this request.

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_ClearSelection */

HREQUEST hRequest = NULL;

JDEDB_RESULT rcode;

rcode = JDB_ClearSelection(hRequest);

if(rcode != JDEDB_PASSED)

{

printf(“JDB_ClearSelection failed\n”);

} /* END IF */

See Also

  • JDB_SetSelection


JDB_ClearSequencing

Last Modified: B733.2 | June 03, 1999

JDB_ClearSequencing clears any custom sequencing associated with a specific initialized request handle.

Syntax

JDEDB_RESULT JDB_ClearSequencing(HREQUEST hRequest);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle | All subsequent JDB operations against this table must use this request.

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_ClearSequencing */

HREQUEST hRequest = NULL;

JDEDB_RESULT rcode;

rcode = JDB_ClearSequencing(hRequest);

if(rcode != JDEDB_PASSED)

{

printf(“JDB_ClearSequencing failed\n”);

} /* END IF */

See Also

  • JDB_SetSequencing


JDB_SetLowerLimit

Last Modified: B733.2 | June 03, 1999

JDB_SetLowerLimit achieves a position on the next row to be fetched within a table. It can be used to achieve the previous position for the next row to be fetched.

Syntax

JDEDB_RESULT JDB_SetLowerLimit(HREQUEST hRequest, LPSELECT lpSelect, ushort nNum);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
lpSelect | Pointer to array of SELECT structures. This structure identifies the type of selection to process. |
nNum | Number of SELECT structures passed. This must equal the number of structures passed. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

  • JDB_SetSelection

  • JDB_SetSequencing


JDB_SetRequestTriggerOption

Last Modified: EnterpriseOne | June 06, 2000

JDB_SetRequestTriggerOption allows users to turn on or off processing of one or more than one type of triggers at the individual table level.

Syntax

JDEDB_RESULT JDB_SetRequestTriggerOption(HREQUEST hRequest, JDB_TRIGGER_OPTION nTriggerOption, JDB_TRIGGER_TYPE nTriggerType, int nValue)

Parameters

Parameter | Notes | Usage
hRequest | NULL or valid request handle. | This is the request handle by which JDB will identify all requests made to the particular table.
nTriggerOption | Insert, Update, Delete and Fetch Trigger. |
nTriggerType | Pre or Post Operation Type. This would enable or disable the trigger option before the trigger is set. |
nValue | Integer to set the trigger ON/OFF | Default : ON

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

JDB_SetRequestTriggerOption(hRequest, JDB_OPTION_DELETETRIGGER, JDB_POST_TRIGGER, JDB_OPTION_OFF)

Additional Notes

This call would turn off the processing of the AFTER DELETE record trigger for the particular table/view.

See Also

· JDB_SetUserTriggerOption


JDB_SetSelection

Last Modified: B733.1 | March 24, 1999

JDB_SetSelection enables users to define any type of selection on a table associated with a specific initialized request handle. This API should be called prior to performing JDB_Select. This API is equivalent to a where clause in an SQL statement.

Syntax

JDEDB_RESULT JDB_SetSelection(HREQUEST hRequest, LPSELECT lpSelect, unsigned short nNum, JDEDB_SET nSet);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
lpSelect | Pointer to array of SELECT structures. This structure identifies the type of selection to process. |
nNum | Number of SELECT structures passed. This must equal the number of structures passed. |
nSet | Replaces the last sequencing or appends it. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_SetSelection */

HREQUEST hRequest = NULL;

SELECTSTRUCT zSelect[2] = NULL;

int nNumSelect = 2;

char szSelectionAlphaName[10];

/* Set a custom selection. Equivalent to the "where" clause in an SQL statement */

/* The following two structures for selection contain data specifying than in table F0101, select only records that have the field IDs NID_AN8 and NID_AN81 equal to each other AND the NID_ALPH field containing the string “EnterpriseOne” */

/* Selection Criteria : this criteria will select records having field ABAN8=ABAN81. It also specifies that this selection will be Added with another selection */

jdeNIDcpy(zSelect[0].Item1.szDict, NID_AN8);

jdeNIDcpy(zSelect[0].Item1.szTable, NID_F0101);

&zSelect[0].Item1.idInstance = 0;

jdeNIDcpy(zSelect[0].Item2.szDict, NID_AN81);

jdeNIDcpy(zSelect[0].Item2.szTable, NID_F0101);

zSelect[0].Item2.idInstance = 0;

zSelect[0].lpValue = NULL;

zSelect[0].nValues = 0;

zSelect[0].nAndOr = JDEDB_ANDOR_AND;

zSelect[0].nCmp = JDEDB_CMP_EQ;

/* Selection Criteria : this criteria will select records having ABALPH = “EnterpriseOne” */

strcpy(szSelectionAlphaName, “EnterpriseOne”);

jdeNIDcpy(zSelect[1].Item1.szDict, NID_ALPH);

jdeNIDcpy(zSelect[1].Item1.szTable, nID_F0101);

zSelect[1].Item1.idInstance = 0;

jdeNIDcpy(zSelect[1].Item2.szDict, "");

jdeNIDcpy(zSelect[1].Item2.szTable, "");

zSelect[1].Item2.idInstance = 0;

zSelect[1].lpValue = szSelectionAlphaName;

zSelect[1].nValues = 1;

zSelect[1].nAndOr = JDEDB_ANDOR_AND;

zSelect[1].nCmp = JDEDB_CMP_EQ;

/* Create WHERE clause */

if (JDB_SetSelection(hRequest, &zSelect, nNumSelect, JDEDB_SET_REPLACE) != JDEDB_PASSED)

{

printf(“JDB_SetSelection failed\n”);

} /* END IF */

See Also

  • JDB_ClearSelection

  • JDB_SetLowerLimit


JDB_SetSelectionX

Last Modified: EnterpriseOne | June 06, 2000

JDB_SetSelectionX enables users to define any type of selection on a table associated with a specific initialized request handle. This API will allow us to set precedence on the conditions for the select. Example: We can create a select statement: SELECT * FROM TABLE-NAME WHERE ((COL1 = X AND COL2 = Y) OR (COL 3 = Z)).

Syntax

JDEDB_RESULT JDB_SetSelectionX(HREQUEST hRequest, LPNEWSELECT lpSelect, ushort nNum, JDEDB_SET nSet)

Parameters

Parameter | Notes | Usage
hRequest | NULL or valid request handle. | JDB will identify all requests made to the particular table by this request handle.
lpSelect | Pointer to array of SELECT structures. | This structure identifies the type of selection to process.
nNum | Number of SELECT structures passed. This must equal the number of structures passed. |
nSet | Replace or append the last selection. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_SetSelectionX */

HREQUEST hRequest = NULL;

LPSELECT lpNewSelect = NULL;

int nNum = 2;

char szSelectionAlphaName[10];

/* Allocate memory by calling the JDE memory allocation routine */

lpNewSelect = jdeAllocReturnIfError(COMMON_POOL,nNumSelect*sizeof(SELECTSTRUCT), MEM_ZEROINIT);

if(lpNewSelect == NULL)

{

return (0);

} /* END IF */

/* Set a custom selection. Equivalent to the "where" clause in a SQL statement*/

/* The following two structures for selection contain data specifying that in table F0101, select only records that have the field ids NID_AN8 and NID_AN81 equal to each other AND the NID_ALPH field containing the string “EnterpriseOne”*/

/* Selection Criteria : this criteria will select records having field ABAN8=ABAN81. It also specifies that this selection will be ANDed with another selection*/

jdeNIDcpy(lpSelect[0].Item1.szDict ,NID_AN8);

jdeNIDcpy(lpSelect[0].Item1.szTable ,NID_F0101);

lpSelect[0].Item1.idInstance = 0;

jdeNIDcpy(lpSelect[0].Item2.szDict ,NID_AN81);

jdeNIDcpy(lpSelect[0].Item2.szTable, NID_F0101);

lpSelect[0].Item2.idInstance = 0;

lpSelect[0].lpValue = NULL;

lpSelect[0].nValues = 0;

lpSelect[0].nCmp = JDEDB_CMP_EQ;

lpSelect[0].nAndOr = JDEDB_ANDOR_AND;

/* Selection Criteria : this criteria will select records having ABALPH = “EnterpriseOne” */

strcpy(szSelectionAlphaName, “EnterpriseOne”);

jdeNIDcpy(lpSelect[1].Item1.szDict , NID_ALPH);

jdeNIDcpy(lpSelect[1].Item1.szTable, NID_F0101);

lpSelect[1].Item1.idInstance = 0;

jdeNIDclear(lpSelect[1].Item2.szDict);

jdeNIDclear(lpSelect[1].Item2.szTable);

lpSelect[1].Item2.idInstance = 0;

lpSelect[1].lpValue = szSelectionAlphaName;

lpSelect[1].nValues = 1;

lpSelect[1].nAndOr = JDEDB_ANDOR_AND;

lpSelect[1].nCmp = JDEDB_CMP_EQ;

/* Create WHERE clause */

rcode = JDB_SetSelectionX(hRequest, lpNewSelect, nNum, JDEDB_SET_REPLACE);

if(rcode != JDEDB_PASSED)

{

printf(“JDB_SetSelectionX failed\n”);

} /* END IF */

See Also

· · JDB_SetSelection

· · JDB_SetLowerLimit


JDB_SetSequencing

Last Modified: EnterpriseOne | June 06, 2000

JDB_SetSequencing enables users to define any type of sequencing (order by) on a table associated with a specific initialized request handle. This API should be called prior to performing JDB_Select.

Syntax

JDEDB_RESULT JDB_SetSequencing(HREQUEST hRequest, LPSORT lpSort, uShort nNum, JDEDB_SET nSet);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |
lpSort | Pointer to array of SORT structures. This structure identifies the type of sequencing to process. |
nNum | Number of SORT structures passed. This must equal the number of structures passed. |
nSet | Replaces or appends the existing string. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_SetSequencing */

HREQUEST hRequest = NULL;

LPSORT lpSort = NULL;

int nNumSort =2;

/* Allocate memory by calling the JDE memory allocation routine */

lpSort = jdeAllocReturnIfError(COMMON_POOL, nNumSort * size of(SORTSTRUCT), MEM_ZEROINIT);

if(lpSort == NULL)

{

return(0);

} /* END IF */

/* Sequencing criteria - this will sort records by ABAN8 and ABALPH in ascending order */

jdeNIDcpy(lpSortlpSort[0].Item.szDict = NID_AN8);

jdeNIDcpy(lpSortlpSort[0].Item.szTable = NID_F0101);

lpSort[0].Item.idInstance = 0;

lpSort[0].nSort = JDEDB_SORT_ASC;

jdeNIDcpy(lpSortlpSort[0].Item.szDict = NID_ALPH);

jdeNIDcpy(lpSortlpSort[0].Item.szTable = NID_F0101);

lpSort[0].Item.idInstance = 0;

lpSort[0].nSort = JDEDB_SORT_ASC;

rcode = JDB_SetSequencing(hRequest, lpSort, nNumSort, JDEDB_SET_REPLACE);

if(rcode != JDEDB_PASSED)

{

printf(“JDB_SetSequencing failed\n”);

} /* END IF */

See Also

· JDB_ClearSequencing


JDB_SetUserTriggerOption

Last Modified: EnterpriseOne | June 06, 2000

JDB_SetUserTriggerOption sets the trigger options at the user handle level. A call to JDB_SetUserTriggerOption can be used to turn off one or more than one triggers on all tables/views opened with that user handle.

Syntax

JDEDB_RESULT JDB_SetUserTriggerOption(HUSER hUser, JDB_TRIGGER_OPTION nTriggerOption, JDB_TRIGGER_TYPE nTriggerType, int nValue)

Parameters

Parameter | Notes | Usage
hUser | NULL or valid user handle. | Obtained from a call to JDB_InitUser.
nTriggerOption | Insert, Update, Delete, and Fetch Trigger. |
nTriggerType | Pre or Post Operation Type. This would enable or disable the trigger option before/after the trigger is set. |
nValue | Integer to set the trigger ON/OFF | Default: ON

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

JDB_SetUserTriggerOption(hUser, JDB_OPTION_FETCHTRIGGER, JDB_CURRENCY_TRIGGER, JDB_OPTION_OFF)

Additional Notes

This call would turn off the processing of the CURRENCYFETCH record trigger for all the tables/views opened with that user handle.

See Also

· JDB_SetRequestTriggerOption


Specification

The following API's all work on the same concept. A hUser handle must be passed along with the object requested. The pointer to the object will then be returned along with the started JDEDB return codes. The names of the various API's describe their functionality.

These functions cache the specifications and check the cache first. If the object is not in the cache it is retrieved from the database and added to the cache.

An additional parameter cCacheOnly will prevent the API's going to the database if the object is not in the cache (if set to TRUE).

For every GET API, an equivalent Free API must be called.

Specification consist of the following APIs:

 | JDBRS_CreateGlblTableSpecs
app.gif (808 bytes) | JDBRS_DeleteGlblTableSpecs
 | JDBRS_FreeBOBSpecs
app.gif (808 bytes) | JDBRS_FreeColumnSpecs
 | JDBRS_FreeDSTMPLSpecs
app.gif (808 bytes) | JDBRS_FreeTableSpecs
 | JDBRS_GetBOBSpecs
app.gif (808 bytes) | JDBRS_GetColumnSpecs
 | JDBRS_GetDSTMPLSpecs
app.gif (808 bytes) | JDBRS_GetTableSpecs


JDBRS_CreateGlblTableSpecs

Last Modified: B733.2 | June 03, 1999

A hUser handle must be passed along with the NID of the table whose specifications are to be created. The specifications will be created from the data dictionary RDB tables.

Syntax

JDEDB_RESULT JDBRS_CreateGlblTableSpecs(HUSER hUser, NID szTable, void*pNotUsed);

Parameters

Parameter | Notes | Usage
hUser | Valid user handle. |
szTable | Table NID | Valid Table NID
pNotUsed | A future parameter | NULL

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Additional Notes

For every GET API an equivalent Free API must be called.

See Also

  • JDBRS_DeleteGlblTableSpecs


JDBRS_DeleteGlblTableSpecs

Last Modified: B733.2 | June 03, 1999

A hUser handle must be passed along with the NID of the table whose specifications are to be deleted. The specifications will be deleted from the cache and TAM.

Syntax

JDEDB_RESULT FAR PASCAL _export JDBRS_DeleteGlblTableSpecs(HUSER hUser, NID szTable, void * pNotUsed)

Parameters

Parameter | Notes | Usage
hUser | Valid user handle |
szTable | Table NID | Valid table
PNot Used | Future parameter | NULL

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

  1. JDBRS_CreateGlblTableSpecs


JDBRS_FreeBOBSpecs

Last Modified: B733.2 | June 03, 1999

JDBRS_FreeBOBSpecs frees the business view specifications obtained by an earlier call to the JDBRS_GetBOBSpecs API.

Syntax

JDEDB_RESULT JDBRS_FreeBOBSpecs(LPBOB lpBOB);

Parameters

Parameter | Notes | Usage
lpBOB | Valid BOB specs |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Additional Notes

For every Free API an equivalent get API must have been called.

See Also

  • JDBRS_GetBOBSpecs


JDBRS_FreeColumnSpecs

Last Modified: B733.2 | June 03, 1999

JDBRS_FreeColumnSpecs frees the column specifications obtained by a call to the JDBRS_GetColumnSpecs API.

Syntax

JDEDB_RESULT JDBRS_FreeColumnSpecs(LPCOLUMNCACHE lpColumn);

Parameters

Parameter | Notes | Usage
lpColumn | Valid column cache structure |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Additional Notes

For every Free API an equivalent GET API must have been called.

See Also

  • JDBRS_GetColumnSpecs


JDBRS_FreeDSTMPLSpecs

Last Modified: B733.2 | June 03, 1999

JDBRS_FreeDSTMPLSpecs frees the specifications of the data source template object that were retrieved by a call to the JDBRS_GetDSTMPLSpecs API.

Syntax

JDEDB RESULT JDBRS_FreeDSTMPLSpecs(LPDSTMPL pDST)

Parameters

Parameter | Notes | Usage
LPDSTMPL pDST | Valid structure of type LPDSTMPL. Structure that contains the specifications of the data source template. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails


JDBRS_FreeTableSpecs

Last Modified: B733.2 | June 03, 1999

JDBRS_FreeTableSpecs frees the table specifications that were obtained by an earlier call to the JDBRS_GetTableSpecs API.

Syntax

JDEDB_RESULT JDBRS_FreeTableSpecs(LPTABLECACHE lpTable);

Parameters

Parameter | Notes | Usage
LPTABLECACHE | Valid table cache pointer |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Additional Notes

For every FREE API an equivalent GET API must have been called.

See Also

  • JDBRS_GetTableSpecs


JDBRS_GetBOBSpecs

Last Modified: B733.2 | June 03, 1999

JDBRS_GetBOBSpecs caches the specifications and check the cache first. If the object is not in the cache, it is retrieved from the TAM and is added to the cache.

A hUser handle must be passed along with the NID of the business view object requested. The pointer to the business view specs will then be returned along with the JDEDB return codes.

An additional parameter "cAdd" prevents the APIs going to TAM if the object is not in the cache (If set to FALSE).

Syntax

JDEDB_RESULT FAR PASCAL _export JDBRS_GetBOBSpecs(HUSER hUser, NID szBOB, LPBOB * lplpBob, JCHAR

cADD, void * pNotUsed)

Parameters

Parameter | Notes | Usage
hUser | Valid user handle. |
szBOB | Valid BOB NID. |
lplpBOB | Pointer to BOB Specs. |
cAdd | Specification lookup parameter. |
pNotUsed | A future parameter | NULL

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Additional Notes

For every GET API an equivalent free API must be called.

See Also

  1. JDBRS_FreeBOBSpecs


JDBRS_GetColumnSpecs

Last Modified: B733.2 | June 03, 1999

JDBRS_GetColumnSpecs caches the specifications and will check the cache first. If the object is not in the cache, it will be retrieved from TAM and will be added to the cache.

A hUser handle must be passed along with the NID of the column object requested. The pointer to the column specifications returned along with the JDEDB return codes.

An additional parameter "cAdd" will prevent the APIs going to TAM if the object is not in the cache (if set to False)

Syntax

JDEDB_RESULT JDBRS_GetColumnSpecs(HUSER hUser, NID szCol, LPCOLUMNCACHE * lpCol, char cAdd, void * pNotUsed);

Parameters

Parameter | Notes | Usage
hUser | Valid user handle. |
szColumn | Valid column NID. |
lpCol | Pointer to column cache. |
cCacheOnly | Specification lookup parameter. |
pNotUsed | Future parameter. | NULL

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Additional Notes

For every GET API an equivalent free API must be called.

See Also

  • JDBRS_FreeColumnSpecs


JDBRS_GetDSTMPLSpecs

Last Modified: B733.2 | June 03, 1999

JDBRS_GetDSTMPLSpecs retrieves the specifications for the data structure template object indicated by object NID szDST.

Syntax

JDEDB RESULT JDBRS_GetDSTMPLSpecs (HUSER hUser, NID szDST, LPDSTMPL *ppDST)

Parameters

Parameter | Notes | Usage
hUser | Valid user handle. |
NID szDST | Valid Data Source Template NID. NID of the data source template whose specifications have to be retrieved. |
LPDSTMPL *ppDST | Pointer to data structure template object specifications. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails


JDBRS_GetTableSpecs

Last Modified: B733.2 | June 03, 1999

JDBRS_GetTableSpecs caches the specifications and check the cache first. If the object is not in the cache, it is retrieved from the TAM and is added to the cache.

A hUser handle must be passed along with the NID of the table object requested. The pointer to the table specifications will then be returned along with the JDEDB return codes.

An additional parameter “cAdd” prevents the APIs going to the TAM if the object is not in the cache (If set to FALSE).

Syntax

JDEDB_RESULT JDBRS_GetTableSpecs(HUSER hUser, ID idTable, LPTABLECACHE * lpTable, char cAdd, void * pNotUsed);

Parameters

Parameter | Notes | Usage
hUser | Valid user handle. |
szTable | Valid table ID of table to process. |
lpTable | Pointer to table specifications. |
cAdd | Specification lookup parameter. |
pNotUsed | Future Parameter | NULL

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Additional Notes

For every GET API an equivalent free API must be called.

See Also

  • JDBRS_FreeTableSpecs


Table Management

Table Management consist of the following APIs:

 | JDB_AddPrimaryKey
 | JDB_AlterTable
app.gif (808 bytes) | JDB_CreateIndex
 | JDB_CreateTable
 | JDB_CreateSingleIndex
app.gif (808 bytes) | JDE_CopyTable
app.gif (808 bytes) | JDB_DropIndex
app.gif (808 bytes) | JDB_DropPrimaryKey
app.gif (808 bytes) | JDB_DropSingleIndex
 | JDB_DropTable
app.gif (808 bytes) | JDB_DropTableOvrWithSpecs
app.gif (808 bytes) | JDB_ValidateTableSpecs


JDB_AddPrimaryKey

Last Modified: B733.2 | September 28, 1998

JDB_AddPrimaryKey creates a primary key to a specified table. This API will drop the existing primary index from the table of the specified datasource unless the specified datasource is a DB2/400 datasource. Then a primary key will be created.

If the primary key already exists in the table and the JDB_AddPrimaryKey is called, the API will return JDEDB_FAILED with the error number indicating that the primary key already exists.

This API is not supported for SQL SERVER 6.5 datasource. It will return JDEDB_FAILED with the error number indicating that the feature is not supported.

Syntax

JDEDB_RESULT FAR PASCAL _export JDB_AddPrimaryKey

HUSER hUser,

NID szTable,

char FAR *szOwner,

char FAR *szPwd,

char FAR *szDS,

JDEDB_ErrMsgType * pnErrorNum)

Parameters

Parameter | Notes | Usage
hUser | Valid user handle |
szTable | Null terminated string containing the table name to add a primary key to |
szOwner | Null terminated string containing the table owner | NULL for default owner
szPwd | Null terminated string containing the password | NULL for default password
szDS | Null terminated string containing the datasource name | NULL for default datasource
pnErrorNum | Pointer to receive the returned error number |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

if (JDB_AddPrimaryKey(hUser,"F0101","USER1","PASSWORD1",

"SQL-DEVDBS",&nErrorNum) != JDEDB_PASSED)

{

/* Error handling code&ldots;*/

}

See Also

  • JDB_DropPrimaryKey


JDB_AlterTable

Last Modified: B733.2 | May 07, 1999

JDB_AlterTable alters a table passed as szTableChange using as a reference the table passed as szTableLike and the respective environments they reside in, the table owner, password and the database in which the table to be altered resides in is also passed. This kind of alteration will only add every column in the reference table, that is not in the target table, to the target table.

Syntax

JDEDB_RESULT JDB_AlterTable(HUSER hUser, NID szTable, char * szOwner, char * szPwd, char * szDS);

Parameters

Parameter | Notes | Usage
hUser | Valid user handle. |
szTable | Valid table NID of table to process. |
szEnvChange | Valid null terminated string pointer. |
szTableLike | Valid Table NID. |
szEnvLike | Valid null terminated string pointer. |
szOwner | Valid null terminated string pointer. |
szPwd | Valid null terminated string pointer. |
szDS | Valid null terminated string pointer. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Additional Notes

Fails on tables with BLOBS (Binary Large Objects)

See Also

  • JDB_CloseTable

  • JDB_CreateTable

  • JDB_DeleteTable

  • JDB_DropTable

  • JDB_InsertTable

  • JDB_OpenTable

  • JDB_UpdateTable


JDB_CreateIndex

Last Modified: B733.1 | March 24, 1999

JDB_CreateIndex creates indices based on the table specs for a datasource table.

Syntax

JDEDB_RESULT JDB_CreateIndex(HUSER hUser, NID szTable, char* szOwner, char* szPwd, char* szDS);

Parameters

Parameter | Notes | Usage
hUser | Valid user handle | From JDB_InitUser
szTable | Valid table NID for table to process |
szOwner | Valid NULL terminated string pointer | NULL for default owner
szPwd | Valid NULL terminated string pointer | NULL for default password
szDS | Valid NULL terminated string pointer | NULL for default datasource

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

  • JDB_DropIndex


JDB_CreateSingleIndex

Last Modified: EnterpriseOne | June 06, 2000

JDB_CreateSingleIndex creates one index at a time. For multiple indexes, this API must be called more than once.

Syntax

JDEDB_RESULT FAR PASCAL _export JDB_CreateSingleIndex(HUSER hUser, NID szTable, char FAR * szOwner, char FAR * szPwd, char FAR * szDS, ID idIndexId, JDEDB_ErrMsgType * pnErrorNum)

Parameters

Parameter | Notes | Usage
hUser | NULL or valid user handle. | Obtained from a call to JDB_InitUser.
SzTable | Table for which the index has to be created. |
szOwner | Owner of the table |
szPwd | Password of the owner |
szDS | Datasource for which the table belongs. |
idIndexId | The ID of the index in the table for which index has to be created. |
pnErrorNum | The error number returned if the operation fails. |

Return Value

None

Example

rcode = JDB_CreateSingleIndex(hUser, szTable, 0, 0, 0, 3, &nErrorNum);

This call would create the index for the column in a table whose index ID is 3. If the operation fails, an error number is returned.

See Also

· JDB_CreateIndex

· JDB_CreateIndexX


JDB_CreateTable

Last Modified: B733.1 | March 24, 1999

JDB_CreateTable creates a database table based on the owner and specified datasource.

Syntax

JDEDB_RESULT JDB_CreateTable(HUSER hUser, NID szTable, char* szOwner, char* szPwd, char* szDS);

Parameters

Parameter | Notes | Usage
hUser | Valid user handle | From JDB_InitUser
szTable | Valid table NID for table to process |
szOwner | Valid NULL terminated string pointer | NULL for default owner
szPwd | Valid NULL terminated string pointer | NULL for default password
szDS | Valid NULL terminated string pointer | NULL for default datasource

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

  • JDB_AlterTable

  • JDB_CloseTable

  • JDB_DeleteTable

  • JDB_DropTable

  • JDB_InsertTable

  • JDB_OpenTable

  • JDB_UpdateTable


JDB_CopyTable

First Available: N/A

Last Modified: B9 (June 13, 2002)

JDB_CopyTable is used for copying a table from one datasource to another.

Syntax

JDEDB_RESULT JDB_CopyTable(HUSER hUser, NID szFTable, ID idFIndex, NID szTTable, short nNumKeys, void * pKey,
JCHAR * szFDS, JCHAR * szTDS, JCHAR * szFEnv, JCHAR * szTEnv, JCHAR * szOwner, JCHAR * szPwd,
DSDBCREATIONPARAMETERS * dsDBCreation)

Parameters

Parameters | Notes | Usage
hUser | Valid user handle |
szFTable | From table or the source table name |
szTTable | To table or the destination table name - Not used currently |
idFIndex | From index or the source index name - Not used currently |
szFDS | From Datasource or the source datasource name |
szTDS | To Datasource or the destination datasource name |
szFEnv | Source or From Environment name. Not used currently |
szTEnv | Destination or To Environment name. Not used currently |
szOwner | Owner name for the database |
szPwd | Database password |
pKey | Not used currently |
nNumKeys | Not used currently |
dsDBCreation | Database specific parameters |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_CopyTable */

HREQUEST hUser = NULL;

JDEDB_RESULT rcode;

NID szFTable = NID_F0101;

JCHAR szFDS = _J("System - B9");

JCHAR szTDS = _J("EnterpriseOne Local");

JCHAR * szOwner = _J("dbo");

JCHAR * szPwd = _J("cptable");

DSDBCREATIONPARAMETERS dsDBCreation;

/*Initialize the table creation parameters*/
dsDBCreation.TableCreation.Create = _J('1');
dsDBCreation.TableCreation.Clear = _J('1');
dsDBCreation.TableCreation.CopyData = _J('1');
dsDBCreation.TableCreation.RunTriggers = _J('0');

/*Initialize the DB creation parameters*/
dsDBCreation.TableTableSpace[0] = _J('\0');
dsDBCreation.TableInitialStorage = -1;
dsDBCreation.TableNextStorage = -1;
dsDBCreation.TablePctIncreaseStorage = -1;
dsDBCreation.IndexTableSpace[0] = _J('\0');
dsDBCreation.IndexInitialStorage = -1;
dsDBCreation.IndexNextStorage = -1;
dsDBCreation.IndexPctIncreaseStorage = -1;
dsDBCreation.nInteractive = 1;
dsDBCreation.pnGo = &nGo;

rcode = JDB_CopyTable(hUser, szFTable, 0, szFTable, 0, NULL, szFDS, szTDS, szFEnv, szTEnv, szOwner, szPwd,&dsDBCreation);

See Also

· JDB_CreateTable

· JDB_DropTable


JDB_DropIndex

Last Modified: B733.2 | May 07, 1999

JDB_DropIndex drops indices on a table, given the table NID, table owner and password, and the database in which the table resides.

Syntax

JDEDB_RESULT JDB_DropIndex(HUSER hUser, NID szTable, char * szOwner, char * szPwd, char * szDS);

Parameters

Parameter | Notes | Usage
hUser | Valid user handle. |
szTable | Valid table NID of table to process. |
szOwner | Valid null terminated string pointer. |
szPwd | Valid null terminated string pointer. |
szDS | Valid null terminated string pointer. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

  • JDB_CreateIndex


JDB_DropPrimaryKey

Last Modified: B733.2 | September 28, 1999

JDB_DropPrimaryKey drops a primary key from a specified table.

This API is not supported for SQL SERVER 6.5 datasource. It will return JDEDB_FAILED with the error number indicating that the feature is not supported.

Syntax

JDEDB_RESULT FAR PASCAL _export JDB_DropPrimaryKey

(HUSER hUser,

NID szTable,

char FAR *szOwner,

char FAR *szPwd,

char FAR *szDS,

  JDEDB_ErrMsgType * pnErrorNum)

Parameters

Parameter | Notes | Usage
hUser | Valid user handle |
szTable | Null terminated string containing the table name to drop a primary key |
szOwner | Null terminated string containing the table owner | NULL for default owner
szPwd | Null terminated string containing the password | NULL for default password
szDS | Null terminated string containing the datasource name | NULL for default datasource
pnErrorNum | Pointer to receive the returned error number |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

if (JDB_DropPrimaryKey(hUser,"F0101","USER1","PASSWORD1",

"SQL-DEVDBS",&nErrorNum) != JDEDB_PASSED)

{

;/* Error handling code&ldots;*/

}

See Also

  • JDB_AddPrimaryKey


JDB_DropSingleIndex

Last Modified: EnterpriseOne | June 06, 2000

JDB_DropSingleIndex selectively drops table indexes. This API drops one index at a time from the table.

Syntax

JDEDB_RESULT FAR PASCAL _export JDB_DropSingleIndex(HUSER hUser, NID szTable, char FAR * szOwner, char FAR * szPwd, char FAR * szDS, ID idIndexId, JDEDB_ErrMsgType * pnErrorNum)

Parameters

Parameter | Notes | Usage
hUser | NULL or valid user handle. | Obtained from a call to JDB_InitUser.
szTable | Table for which the index has to be dropped |
szOwner | Owner of the table |
szPwd | Password of the owner |
szDS | Datasource name where the table resides. |
idIndexId | The ID of the index in the table for which index has to be dropped. |
pnErrorNum | The error number returned if the operation fails. |

Return Value

None

Example

rcode = JDB_DropSingleIndex(hUser, szTable, 0, 0, 0, 2, &nErrorNum);

This call would drop the index for the column in a table whose index ID is 3. If the operation fails, an error number is returned.

See Also

· JDB_DropIndex.


JDB_DropTable

Last Modified: B733.1 | March 24, 1999

JDB_DropTable deletes a specified table from a specified datasource.

Syntax

JDEDB_RESULT JDB_DropTable(HUSER hUser, NID szTable, char* szOwner, char* szPwd, char* szDS);

Parameters

Parameter | Notes | Usage
hUser | Valid user handle | From JDB_InitUser
szTable | Valid table NID for table to process |
szOwner | Valid NULL terminated string pointer | NULL for default owner
szPwd | Valid NULL terminated string pointer | NULL for default password
szDS | Valid NULL terminated string pointer | NULL for default datasource

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

  • JDB_AlterTable

  • JDB_CloseTable

  • JDB_DeleteTable

  • JDB_CreateTable

  • JDB_InsertTable

  • JDB_OpenTable

  • JDB_UpdateTable


JDB_DropTableOvrWithSpecs

Last Modified: B733.1 | March 24, 1999

JDB_DropTableOvrWithSpecs deletes a table with specified specs from a specified datasource.

Syntax

JDEDB_RESULT JDB_DropTableOvrWithSpecs(HUSER hUser, NID szTable, char* szOwner, char* szPwd, char* szDS, LPTABLECACHE lpTableSpecIn);

Parameters

Parameter | Notes | Usage
hUser | Valid user handle | From JDB_InitUser
szTable | Valid table NID for table to process |
szOwner | Valid NULL terminated string pointer | NULL for default owner
szPwd | Valid NULL terminated string pointer | NULL for default password
szDS | Valid NULL terminated string pointer | NULL for default datasource
lpTableSpecIn | Pointer to the table spec. | NULL for default table spec.

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

See Also

  • JDB_AlterTable

  • JDB_CloseTable

  • JDB_DeleteTable

  • JDB_CreateTable

  • JDB_InsertTable

  • JDB_OpenTable

  • JDB_UpdateTable


JDB_ValidateTableSpecs

First Available: B9

Last Modified:

JDB_ValidateTableSpecs would validate the existing table specs or the specs for the table under creation. If the limits exceed EnterpriseOne supported limits, table creation/generation would be aborted except for MaxTotalIndexLength. In this case, a warning will be returned instead.

Syntax

JDEDB_RESULT JDB_ValidateTableSpecs(HUSER hUser, NID szTable, char FAR * szDS)

Parameters

Parameter | Notes | Usage
Huser | NULL or valid user handle. | NULL or valid user handle.
SzTable | Table for which the specs have to be validated. | Valid table name
SzDS | Datasource name where the table resides | Not used.

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this API succeeds
JDEDB_FAILED | Return value if this API fails

Example

rcode = JDB_ValidateTableSpecs(hUser, szTable, szDS);

if (rcode != JDEDB_PASSED)

{

jdeWriteLog("JDB", 0, "JDB3100076 - Failed to validate table specs");

return JDEDB_FAILED;

}

else

{

jdeTraceSz(NULL, “Exiting JDB_ValidateTableSpecs With Success”);

return JDEDB_PASSED;

}

Additional Notes

Below is a list of EnterpriseOne® supported maximum values:

Property Name | OW Max
MaxTableNameLength | 18
MaxIndexNameLength | 18
MaxColumnNameLength | 18
MaxNumberColumnsInTable | 500
MaxNumberColumnsInIndex | 16
MaxNumberIndexesInTable | 520
MaxNumberBLOB | 1
MaxTotalRowLength | 8060
MaxTotalIndexLength | 900

Below is a list of EnterpriseOne® supported minimum values:

Property Name | OW Max
MinTableNameLength | 1
MinIndexNameLength | 1
MinColumnNameLength | 1
MinNumberColumnsInTable | 1
MinNumberColumnsInIndex | 1
MinNumberIndexesInTable | 0
MinNumberBLOB | 0
MinTotalRowLength | 1
MinTotalIndexLength | 1

See Also

· JDB_GetTableProperties


Table Specific Selection

Table Specific Selection consist of the following APIs:

 | JDB_RetrieveF0010RowUsingCompanyNumber
app.gif (808 bytes) | JDB_RetrieveF0013RowUsingCurrencyCode
app.gif (808 bytes) | JDB_RetrieveF0025RowUsingLedgerType


Table View

Table View consist of the following APIs:

 | JDB_CloseTable
app.gif (808 bytes) | JDB_CloseView
 | JDB_GetBufferSize
app.gif (808 bytes) | JDB_OpenTable
 | JDB_OpenTableOvr
app.gif (808 bytes) | JDB_OpenTableOvrWithSpecs
 | JDB_OpenView
app.gif (808 bytes) | JDB_OpenViewOvr


JDB_CloseTable

Last Modified: B733.2 | June 03, 1999

JDB_CloseTable results in JDB freeing a request on this table. JDB disassociates the requests from the user thus eliminating any further operations on the associated table by the user. To JDB, the table is closed to the user and this request handle cannot be used as it has been invalidated until after another call to JDB_OpenTable is issued which will either get the previous request or initialize a new request. This API has to be used in conjunction with APIs JDB_OpenTable, JDB_OpenTableOvr, JDB_OpenTableOvrWithSpecs, or JDB_OpenForeignTable.

Syntax

JDEDB_RESULT JDB_CloseTable(HREQUEST hRequest);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. | From JDB_OpenTable

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declaration of variables associated with JDB_CloseTable */

HREQUEST hRequest = NULL;

/* Free the table processing request handle ,hRequest, which was initialized by JDB_OpenTable */

rcode = JDB_CloseTable(hRequest)

if (rcode != JDEDB_PASSED)

{

printf("JDB_CloseTable failed\n");

} /* END IF */

See Also

  • JDB_AlterTable

  • JDB_CreateTable

  • JDB_DeleteTable

  • JDB_DropTable

  • JDB_InsertTable

  • JDB_OpenTable

  • JDB_UpdateTable


JDB_CloseView

Last Modified: B733.1 | March 21, 1999

JDB_CloseView results in JDB freeing a request on this table. JDB disassociates the requests from the user thus eliminating any further operations on the associated table by the user. To JDB, the table is closed to the user and this request handle cannot be used because it has been invalidated until after another call to JDB_OpenTable.

Syntax

JDEDB_RESULT JDB_CloseView(HREQUEST hRequest);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declaration of variables associated with JDB_CloseView */

HREQUEST hRequest=NULL;

/* Free the business view processing request handle ,hRequest, which was initialized by JDB_OpenView */

rcode = JDB_CloseView(hRequest);

if (rcode != JDEDB_PASSED)

{

printf("JDB_CloseView failed\n");

} /* END IF */

See Also

  • JDB_DeleteView

  • JDB_InsertView

  • JDB_OpenView

  • JDB_UpdateView


JDB_GetBufferSize

Last Modified: B733.2 | May 07, 2000

JDB_GetBufferSize returns the size of the JDE value buffer for the request handle corresponding to a table or business view. This API can be used by the calling routing to determine the memory requirement for the structures used for communicating with JDB.

Syntax

unsigned long JDB_GetBufferSize(HREQUEST hRequest);

Parameters

Parameter | Notes | Usage
hRequest | Valid request handle. |

Return Value

Return Value | Description
Size of the buffer | Returns the size of the buffer

Example

/* Declaration of variables associated with JDB_GetBufferSize */

HREQUEST hRequest = NULL;

unsigned long ulBufferSize = 0;

/* Call the JDB_GetBufferSize API returning the buffer size */

ulBufferSize = JDB_GetBufferSize(hRequest);


JDB_OpenTable

Last Modified: B733.2 | June 03, 1999

JDB_OpenTable opens the table identified by the given table NID and prepares it for input/output processing. After successfully preparing the table for input/output, JDB associates the table with the passed user handle. The user is returned a request handle. This request handle must be used on every subsequent data manipulation call to JDB on this specific table. The request handle must be used only on the specified table until a JDB_CloseTable is called which will free the request handle. This API must be called prior to any other JDB operations on the table identified by the given table NID and must be used in conjunction with JDB_CloseTable.

Syntax

JDEDB_RESULT JDB_OpenTable(HUSER hUser, NID szTable, ID idIndex, NID *lpColSelect, unsigned short nNumCols, char * szOverrideDS, HREQUEST * hRequest);

Parameters

Parameter | Notes | Usage
hUser | Valid user handle. | From JDB_InitUser
szTable | Valid table NID. |
idIndex | This is the ID of the index to ready for processing. The index used can be changed after a table has been requested. If zero, the primary index will be used. |
*lpColSelect | Pointer to an array of column NID's or NULL. These columns will be used for requests to the database. Performance is enhanced if only the required columns are asked for. This is useful when the application is only processing certain columns in the database. If all columns are required then NULL can be passed. |
nNumCols | Number of columns required or zero. This is the number of column NIDs in the lpColSelect array. If all columns are required (For example, if lpColSelect is NULL) then pass zero. |
szOverrideDS | Datasource name. This will override the location of the table indicated by the Object Map. | NULL for default datasource based on the environment.
hRequest | NULL or request handle. | The output

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declaration of variables associated with JDB_OpenTable */

HREQUEST hRequest = NULL

HENV hEnv;

HUSER hUser;

JDEDB_RESULT rcode;

NID szTable = NID_F0902;

ID idIndex = ID_F0902_ACCOUNT_ID__CENTURY;

NID nidSelectArray[2] = {NID_AID,NID_CO};

int nNumCols = 2;

/* Open table F0902 for processing using the Access32 data source. Two columns in the passed array will be used for processing. */

rcode = JDB_OpenTable(hUser, szTable, idIndex, nidSelectArray, nNumCols ,"Access32" ,&hRequest);

if (rcode != JDEDB_PASSED)

{

  printf("JDB_OpenTable failed\n");

} /*END IF*/

See Also

  • JDB_AlterTable

  • JDB_CloseTable

  • JDB_CreateTable

  • JDB_DeleteTable

  • JDB_DropTable

  • JDB_InsertTable

  • JDB_UpdateTable


JDB_OpenTableOvr

Last Modified: B733.1 | March 24, 1999

JDB_OpenTableOvr opens the table identified by the given table NID and the given environment name and prepares the table for input / output processing. After successfully preparing the table for input/output, JDB associates the table with the new user handle under the overriding environment. The user is returned a request handle. This request handle must be used on every subsequent data manipulation call to JDB on this specific table. The request handle must be used only on the specified table until a JDB_CloseTable is called which will free the request. This API must be called prior to any other JDB operations on the table identified by the given table NID and must be used in conjunction with JDB_CloseTable.

Syntax

JDEDB_RESULT JDB_OpenTableOvr(HUSER hUser, NID szTable, ID idIndex, NID *lpColSelect, unsigned short nNumCols, char * szOverrideDS, char FAR * szEnv, HREQUEST * hRequest);

Parameters

Parameter | Notes | Usage
hUser | Valid user handle. | From JDB_InitUser
szTable | Valid table NID. |
idIndex | This is the ID of the index to ready for processing. The index used can be changed after a table has been requested. If zero, the primary index will be used. |
*lpColSelect | Pointer to an array of column NID's or NULL. These columns will be used for requests to the database. Performance is enhanced if only the required columns are asked for. This is useful when the application is only processing certain columns in the database. If all columns are required then NULL can be passed. |
nNumCols | Number of columns required or zero. This is the number of column NIDs in the lpColSelect array. If all columns are required (For example, if lpColSelect is NULL) then pass zero. |
szOverrideDS | Valid datasource name or NULL. This will override the location of the table indicated by the Object Map. | NULL for default datasource based on the environment.
szEnv | Valid environment name or NULL. This will override the default environment associated with the user handle passed in. | NULL for the default environment
hRequest | NULL or request handle. | The output

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declaration of variables associated with JDB_OpenTableOvr */

HUSER hUser;

JDEDB_RESULT rcode;

NID szTable = NID_F0902;

ID idIndex = ID_F0902_ACCOUNT_ID__CENTURY;

NID nidSelectArray[2] = {NID_AID,NID_CO};

int nNumCols = 2;

HREQUEST hRequest = NULL;

/* Open table F0902 for processing using the Access32 datasource on the environment M733LOC. Two columns in the passed array will be used for processing. */

rcode = JDB_OpenTableOvr(hUser, szTable, idIndex, nidSelectArray, nNumCols ,"Access32", "M733LOC", &hRequest);

if (rcode != JDEDB_PASSED)

{

printf("JDB_OpenTablOvr failed\n");

} /*END IF*/

See Also

  • JDB_AlterTable

  • JDB_CloseTable

  • JDB_CreateTable

  • JDB_DeleteTable

  • JDB_DropTable

  • JDB_InsertTable

  • JDB_OpenTable

  • JDB_OpenTableOvrWithSpecs

  • JDB_UpdateTable


JDB_OpenTableOvrWithSpecs

Last Modified: B733.2 | June 03, 1999

JDB_OpenTableOvrWithSpecs opens the table identified by the given table NID and the given table spec and prepares it for input / output processing. After successfully preparing the table for input/output, JDB associates the table with the user handle. The user is returned a request handle. This request handle must be used on every subsequent data manipulation call to JDB on this specific table. The request handle must be used only on the specified table until a JDB_CloseTable is called which will free the request. This API must be called prior to any other JDB operations on the table identified by the given table NID and must be used in conjunction with JDB_CloseTable.

Syntax

JDEDB_RESULT JDB_OpenTableOvrWithSpecs(HUSER hUser, NID szTable, ID idIndex, NID *lpColSelect, unsigned short nNumCols, char * szOverrideDS, char FAR * szEnv, LPTABLECACHE lpTableSpecIn, HREQUEST * hRequest);

Parameters

Parameter | Notes | Usage
hUser | Valid user handle. | From JDB_InitUser
szTable | Valid table NID. |
idIndex | This is the ID of the index to ready for processing. The index used can be changed after a table has been requested. If zero, the primary index will be used. |
*lpColSelect | Pointer to an array of column NID's or NULL. These columns will be used for requests to the database. Performance is enhanced if only the required columns are asked for. This is useful when the application is only processing certain columns in the database. If all columns are required then NULL can be passed. |
nNumCols | Number of columns required or zero. This is the number of column NIDs in the lpColSelect. For example, If lpColSelect is NULL, then pass zero. |
szOverrideDS | Datasource name. This will override the location of the table indicated by the Object Map. | NULL for the default datasource
szEnv | Environment name. This will override the default environment. | NULL for the default environment
lpTableSpecIn | Pointer to the table spec. | NULL for the default table spec.
hRequest | NULL or request handle. | The output

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declaration of variables associated with JDB_OpenTableOvrWithSpecs */

HUSER hUser;

JDEDB_RESULT rcode;

NID szTable = NID_F0902;

ID idIndex = ID_F0902_ACCOUNT_ID__CENTURY;

NID nidSelectArray[2] = {NID_AID,NID_CO};

int nNumCols = 2;

LPTABLECACHE lpTableSpecIn;

HREQUEST hRequest = NULL;

/* Open table F0902 for processing using the Access32 datasource on the environment M733LOC. Two columns in the passed array will be used for processing. */

rcode = JDB_OpenTableOvrWithSpecs(hUser, szTable, idIndex, nidSelectArray, nNumCols ,"Access32", "M733LOC", lpTableSpecIn, &hRequest);

if (rcode != JDEDB_PASSED)

{

printf("JDB_OpenTableOvrWithSpecs failed\n");

} /*END IF*/

See Also

  • JDB_AlterTable

  • JDB_CloseTable

  • JDB_CreateTable

  • JDB_DeleteTable

  • JDB_DropTable

  • JDB_InsertTable

  • JDB_OpenTable

  • JDB_OpenTableOvr

  • JDB_UpdateTable


JDB_OpenView

Last Modified: B733.1 | March 24, 1999

JDB_OpenView opens the business view identified by the given business view NID and prepares it for input/output processing. After successfully preparing the business view for input/output, JDB associates the business view with the passed user handle. The user is returned a request handle. This request handle must be used on every subsequent data manipulation call to JDB on this specific business view. The request handle must be used only on the specified business view until a JDB_CloseView is called which will free the request handle. This API must be called prior to any other JDB operations on the business view identified by the given business view NID and must be used in conjunction with JDB_CloseView.

Syntax

JDEDB_RESULT JDB_OpenView(HUSER hUser, NID szBOB, char * szOverrideDS, HREQUEST * hRequest);

Parameters

Parameter | Notes | Usage
hUser | Valid user handle. | From JDB_InitUser
szBOB | Valid Business View NID to process. |
szOverrideDS | Valid null terminated string pointer This will override the location of table with the corresponding business view NID indicated by the Object Map. This means if the table you wish to work with is in AS/400 database and the Object Map states the default location of the table to be the Oracle database, you may explicitly enter the data source name for the AS/400 database here so that a call to this API will always open the table in AS/400 database. The name passed here should be the data source name, not the database name because the names of the datasource do not necessarily match the names of the databases. Use the Object Configuration Manager to identify the data source that you need. | NULL for the default datasource based on the environment.
hRequest | NULL or request handle. | The output

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declaration of variables associated with JDB_OpenView */

HREQUEST hRequest = NULL;

HUSER hUser = NULL;

JDEDB_RESULT rcode;

NID szBob = NID_V0101B;

/*Open a business view with NID_V0101B using the Access32 data source */

rcode = JDB_OpenView(hUser, idTable, szBOB ,"ORACLE" ,&hRequest);

if (rcode != JDEDB_PASSED)

{

printf("JDB_OpenView failed\n");

} /* END IF */

See Also

  • JDB_CloseView

  • JDB_DeleteView

  • JDB_InsertView

  • JDB_UpdateView


JDB_OpenViewOvr

Last Modified: B733.2 | March 24, 1999

JDB_OpenViewOvr opens the business view identified by the give business view NID and prepares it for input / output processing. After successfully preparing the business view for input/output, JDB associates the business view with the passed user handle. The user is returned a request handle. This request handle must be used on every subsequent data manipulation call to JDB on this specific business view. The request handle must be used only on the specified business view until a JDB_CloseView is called.

This must be called prior to any other JDB operations on the business view identified by the given business view NID. This API is more commonly used on the server side.

Syntax

JDEDB_RESULT FAR PASCAL _export JDB_OpenViewOvr(HUSER hUser, NID szBob, JCHAR * szDS, JCHAR FAR *

szEnv,HREQUEST FAR *hRequest)

Parameter

Parameter | Notes | Usage
hUser | Valid user handle. JDB User handle. Obtained from call to JDB_InitUser. | From JDB_InitUser.
szBOB | Valid Business View NID to process. |
JChar *szDS | Valid null terminated string pointer. This will override the location of table with the corresponding business view NID indicated by the Object Map. This means that if the table you wish to work with is in AS/400 database and the Object Map states the default location of the table to be the Oracle database, you may explicitly enter the data source name for the AS/400 database here so that a call to this API will always open the table in the AS/400 database. The name passed here should be the data source name, not the database name because the names of the data sources do not necessarily match the names of the databases. Use the Object Configuration Manager to identify the data source that you need | NULL for the default datasource based on the environment.
szEnv |  |
HRequest | NULL or request handle. This is the request handle which JDB associates with the user handle and by which JDB will identify all requests made to this business view by this user. | The output

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declaration of variables associated with JDB_OpenViewOvr */

HREQUEST hRequest = NULL

HUSER hUser = NULL;

JDEDB_RESULT rcode;

NID idszBob = 16629NID_V0101B;

/*Open a business view with id 16629 NID_V0101B using the Access32 data source on M7322LOC environment */

rcode = JDB_OpenViewOvr(hUser, idszTable, idBob ,NULL,"Access32", "M7322LOC",&hRequest);

if (rcode != JDEDB_PASSED)

{

printf("JDB_OpenVieOvrw failed\n");

} /* END IF */


JDB_TextSearchClearSelection

Last Modified: EnterpriseOne | June 06, 2006

This API clears all select criteria for text searches.

Syntax

JDERTN (JDEDB_RESULT) JDEWINAPI JDB_TextSearchClearSelection(HREQUEST hRequest);

Parameters

Parameter | Notes | Usage
hRequest | Input, required. The request handle that defines the context in which the text search selection criteria are to be cleared. |

Return Value

This API can return these values:

Return Value | Description
JDEDB_PASSED | The selection criteria we cleared successfully.
JDEDB_FAILED | The selection criteria were not cleared.

Example

JDBDB_RESULT nResult;

nResult = JDB_TextSearchClearSelection(hRequest);


JDB_TextSearchClearSelection

JDB_TextSearchCloseView

Last Modified: EnterpriseOne | June 06, 2006

This API closes a business view that was opened for text searches.

Syntax

JDERTN (JDEDB_RESULT) JDEWINAPI JDB_TextSearchCloseView(HREQUEST hRequest);

Parameters

Parameter | Notes | Usage
hRequest | Input, required. The request handle that defines the context in which the business view is to be closed. |

Return Value

This API can return these values:

Value | Description
JDEDB_PASSED | The business view was closed successfully.
JDEDB_FAILED | The business view was not closed.

Example

DBDB_RESULT nResult;

nResult = JDB_TextSearchCloseView(hRequest);


JDB_TextSearchClearSelection

JDB_TextSearchFetch

Last Modified: EnterpriseOne | June 06, 2006

This API fetches a row of text search results.

Syntax

JDERTN (JDEDB_RESULT) JDEWINAPI JDB_TextSearchFetch(

HREQUEST hRequest,

void FAR * lpValue,

void FAR * score,

void FAR * summary,

int nLock

);

Parameters

Parameter | Notes | Usage
hRequest | Input, required. The request handle that defines the context in which the text search was issued. |
lpValue | Output, required. The business view data structure where the text search results are stored. |
summary | Output, required. The summary that describes the context of the match in the text search results. |
nLock | Input, required. Not used. |

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | The text search results were fetched successfully.
JDEDB_FAILED | The search results were not fetched.

Example

DSV0101C value; /* User-defined struct */

MATH_NUMERIC mnScore;

JCHAR szSummary[256] = { 0 };

JDBDB_RESULT nResult;

nResult = JDB_TextSearchFetch(hRequest, &value, &mnScore, szSummary, 0);


JDB_TextSearchClearSelection

JDB_TextSearchOpenView

Last Modified: EnterpriseOne | June 06, 2006

This API opens a business view for text searches. You must call this API before issuing any text searches.

Syntax

JDERTN (JDEDB_RESULT) JDEWINAPI JDB_TextSearchOpenView(

HUSER hUser,

NID szBob,

JCHAR * lpszDataSource,

HREQUEST * hRequest

);

Description

This API opens a business view for text searches. You must call this API before issuing any text searches.

Parameters

Parameter | Notes | Usage
hUser | Input, required. The user handle that defines the context in which to open the business view. |
szBob | Input, required. The business view that defines the data and media objects to include in the text search index. |
lpszDataSource | Input, required. The data source that defines the location of the data and media objects to search. |
hRequest | Output, required. The request handle to use for subsequent text search operations. |

Value Return

This API can return these values:

Value | Description
JDEDB_PASSED | The business view was opened successfully.
JDEDB_FAILED | The business view was not opened.

Example

NID szBob = _J("V0101C");

JCHAR * lpszDataSource = _J("My Business Data");

HREQUEST hRequest = NULL;

JDBDB_RESULT nResult;

nResult = JDB_TextSearchOpenView(hUser, szBob, lpszDataSource, &hRequest);


JDB_TextSearchClearSelection

JDB_TextSearchSelect

Last Modified: EnterpriseOne | June 06, 2006

This API issues a text search. You must open a business view with JDB_TextSearchOpenView before you use this API to issue a text search.

Syntax

JDERTN (JDEDB_RESULT) JDEWINAPI JDB_TextSearchSelect(

HREQUEST hRequest,

const JCHAR * lpKeyWordsValue,

JDB_TEXTSEARCH_VALUE_TYPE nValueType,

JDB_TEXTSEARCH_KEYWORD_OPTION nKeyOption

);

Parameters

Parameter | Notes | Usage
hRequest | Input, required. The request handle that defines the context in which to issue the text search. |
lpKeyWordsValue | Input, required. The keywords or Verity Query Language (VQL) string for the text search. |
nValueType | Input, required.JDB_TEXTSEARCH_VALUE_TYPE_KEYWORDS = lpKeyWordsValue is a keywords string.JDB_TEXTSEARCH_VALUE_TYPE_VQL = lpKeyWordsValue is a VQL string. |
nKeyOption | Input, required. A bitmap that indicates how to treat keywords. You can use either or both of these values:JDB_TEXTSEARCH_KEYWORD_OPT_CASE_SENSITIVE = match text using case sensitivity.JDB_TEXTSEARCH_KEYWORD_OPT_SIMILARITY = match similar words. |

Return Value

This API can return these values:

Value | Description
JDEDB_PASSED | The text search was issued successfully.
JDEDB_FAILED | The text search was not issued.

Example

JDBDB_RESULT nResult;

nResult = JDB_TextSearchSelect(hRequest, _J("financial company"), JDB_TEXTSEARCH_VALUE_TYPE_KEYWORDS, JDB_TEXTSEARCH_KEYWORD_OPT_SIMILARITY);


JDB_TextSearchClearSelection

JDB_TextSearchSetSelection

Last Modified: EnterpriseOne | June 06, 2006

This API sets the selection criteria for a text search.

Syntax

JDERTN (JDEDB_RESULT) JDEWINAPI JDB_TextSearchSetSelection(

HREQUEST hRequest,

LPNEWSELECT lpSelect,

ushort nNum,

JDEDB_SET nSet

);

Parameters

Parameter | Notes | Usage
hRequest | Input, required. The request handle that defines the context to which the text search selection criteria is to be applied. |
lpSelect | Input, required. The text search selection criteria. |
nNum | Input, required. The number of selection fields. |
nSet | Input, required.JDEDB_SET_REPLACE = replace the existing selection criteria.JDEDB_SET_APPEND = append to the existing selection criteria. |

Return Value

This API can return these values:

Value | Description
JDEDB_PASSED | The text search selection criteria were set successfully.
JDEDB_FAILED | The text search selection criteria were not set.

Example

NEWSELECTSTRUCT lpSelect[1];

JCHAR szTemp[10];

MATH_NUMERIC mnTemp;

JDBDB_RESULT nResult;

/* Populate the select structure. */

jdeNIDcpy(lpSelect[0].Item1.szDict, NID_AN8);

jdeNIDcpy(lpSelect[0].Item1.szTable, NID_F0101);

lpSelect[0].Item1.idInstance = 0;

lpSelect[0].nValues = 1;

lpSelect[0].nCmp = JDEDB_CMP_EQ;

lpSelect[0].nAndOr = JDEDB_ANDOR_AND;

jdeSprintf(szTemp, _J("%d"), 4100);

ParseNumericString(&mnTemp, szTemp);

lpSelect[0].lpValue = &mnTemp;

lpSelect[0].nParen = JDEDB_PAREN_NONE;

nResult = JDB_TextSearchSetSelection(hRequest,

lpSelect, 1, JDEDB_SET_REPLACE);

/* Search in Media Objects that are associated with a GT Type Name. */

NEWSELECTSTRUCT lpSelect[1];

JCHAR szTemp[10];

MATH_NUMERIC mnTemp;

JDBDB_RESULT nResult;

jdeNIDcpy(lpSelect[0].Item1.szDict, _J("GT4801A"));

/* Provides a GT type name that searching media objects associate with here */

jdeNIDcpy(lpSelect[0].Item1.szTable, JDB_MEDIAOBJECT);

/* JDB_MEDIAOBJECT is a constant to indicate the usage of a GT type name in the above line */

lpSelect[0].Item1.idInstance = 0;

lpSelect[0].nValues = 1;

lpSelect[0].nCmp = JDEDB_CMP_EQ;

lpSelect[0].nAndOr = JDEDB_ANDOR_AND;

jdeSprintf(szTemp, _J("%d"), 4100);

ParseNumericString(&mnTemp, szTemp);

lpSelect[0].lpValue = &mnTemp;

lpSelect[0].nParen = JDEDB_PAREN_NONE;

nResult = JDB_TextSearchSetSelection(hRequest,

lpSelect, 1, JDEDB_SET_REPLACE);


JDB_TextSearchClearSelection

JDB_TextSearchSetSequencing

Last Modified: EnterpriseOne | June 06, 2006

This API sets the sequencing criteria for a text search.

Syntax

JDERTN (JDEDB_RESULT) JDEWINAPI JDB_TextSearchSetSequencing(

HREQUEST hRequest,

LPSORT lpSSort,

ushort nNum,

JDEDB_SET nSet

);

Parameters

Parameter | Notes | Usage
hRequest | Input, required. The request handle that defines the context to which the text search selection criteria is to be applied. |
lpSort | Input, required. The text search sequencing criteria. |
nNum | Input, required. The number of sort fields. |
nSet | Input, required.JDEDB_SET_REPLACE = replace the existing sequencing criteria.JDEDB_SET_APPEND = append to the existing sequencing criteria. |

Return Value

This API can return these values:

Value | Description
JDEDB_PASSED | The text search sequencing criteria were set successfully.
JDEDB_FAILED | The text search sequencing criteria were not set.

Example

SORTSTRUCT lpSort[2];

JDBDB_RESULT nResult;

/* Populate the sort structure. */

jdeNIDcpy(lpSort[0].Item.szDict, NID_AN8);

lpSort[0].Item.idInstance = 0;

jdeNIDcpy(lpSort[0].Item.szTable, NID_F0101);

lpSort[0].nSort = JDEDB_SORT_ASC;

jdeNIDcpy(lpSort[1].Item.szDict, NID_ALPH);

lpSort[1].Item.idInstance = 0;

jdeNIDcpy(lpSort[1].Item.szTable, NID_F0101);

lpSort[1].nSort = JDEDB_SORT_ASC;

nResult = JDB_TextSearchSetSequencing(hRequest, lpSort, 2, JDEDB_SET_REPLACE);


JDECache

JDE Cache is a component of JDEKERNL that runs on top of the JDE Cache Manager (JDECM). JDE Cache is simpler to use than JDECM and is geared towards application development as opposed to JDECM, which is more directed towards tools development. With JDECM, cache environment and memory management is the responsibility of the developer. With JDE Cache, cache environment and memory management this is the responsibility of the Cache Manager.

The API set is not the same. The APIs that fundamentally perform the same functions now exhibit some cosmetic changes in JDE Cache. JDE Cache APIs contain fewer parameters because all the cache management and memory management parameters have been eliminated.

JDE Cache is more powerful than JDECM because supports multiple cursors; that is, JDE Cache gives the application programmer more flexibility in terms of positioning within the cache for data manipulation. This greatly improves performance because searching within the cache is very limited.

Generally, JDE Cache is more suited toward application programming because most of the complexities associated with using JDECM have been masked. The implementation of JDE Cache Cursors makes JDE Cache a performance-enhanced version of JDECM.

JDE Cache is a component of JDEKERNL that can hold any type of indexed data that your application needs to store in memory, regardless of the platform on which the application is running. This means that a whole table can be read from a database and stored in memory. There is no limit on the type of data, size of data, or number of data caches an application can have, other than machine limitations. JDE Cache supports fixed and variable length records. Use JDE Cache with a set of API calls on any platform that is supported.

Note: Because data handled by JDE Cache is in RAM, evaluate whether it is necessary to use JDE Cache. If you must use JDE Cache, carefully design you records and indices. Try to minimize the amount of records stored in JDE Cache because EnterpriseOne and other applications use the same memory.

JDECache APIs consist of the following Categories:

JDECache Management

JDECache Manipulation

CacheErrorMessages


JDECache Management

JDECache Management APIs are responsible for setting up the cache, clearing the cache and terminating the cache. All JDE Cache Manipulation APIs should always be passed the HUSER and HCACHE handles, except for jdeCacheGetNumRecords that is passed the HCACHE handle. These two handles are essential for cache identification and cache management.

JDECache Management consist of the following APIs:

 | jdeCacheClear
app.gif (808 bytes) | jdeCacheGetNumRecords
 | jdeCacheInit
 | jdeCacheInitMultipleIndex
 | jdeCacheInitMultipleIndexUser
 | jdeCacheInitUser
app.gif (808 bytes) | jdeCacheTerminate
 | jdeCacheTerminateAll


jdeCacheClear

Last Modified: EnterpriseOne | March 29, 2000

jdeCacheClear deletes all the records in the cache but does NOT terminate the cache.

Syntax

JDECM_RESULT jdeCacheClear(HCACHE hCache);

Parameters

Parameter | Notes | Usage
hCache | Assigned cache handle. This cache handle is used to uniquely identify the cache. | Input

Return Value

Return Value | Description
JDECM_PASSED | Return value if this succeeds
JDECM_FAILED | Return value if this fails

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

/*set up index structure*/

…

/*initialize cache*/

…

/*add some records*/

…

/*do something*/

…

if (jdeCacheClear(hCache)==JDECM_FAILED)

printf(“jdeCacheClearCache Failed !\n”);

if (jdeCacheGetNumRecords(hCache)!=0)

printf(“Still have records in cache after jdeCacheClearCache !\n”);

/*do something*/

…

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf(“jdeCacheTerminate Failed \n”);


jdeCacheGetNumRecords

Last Modified: EnterpriseOne | March 29, 1999

jdeCacheGetNumRecords returns the total number of records currently stored in the cache identified by hCache. It can be used to check if the cache is empty.

Syntax

long int jdeCacheGetNumRecords (HCACHE hCache);

Parameters

Parameter | Notes | Usage
hCache | This cache handle is used to uniquely identify the cache. | Input

Return Value

Return Value | Description
long int | Total number of records currently in the cache

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

/*set up index structure*/

…

/*initialize cache*/

…

/*add some records*/

…

if (jdeCacheGetNumRecords(hCache)<1)

printf(“No records was added to cache[%s]\n”,szCacheName);

/*do something*/

…

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf(“jdeCacheTerminate Failed \n”);

See Also:

· jdeCacheGetNumCursors


jdeCacheInit

Last Modified: EnterpriseOne | March 25,2000

jdeCacheInit initializes a named cache, associates the initialized cache with a user and returns a handle to the initialized cache. This API accomplishes four things:

1. Creates a cache in memory.

2. Creates an index that will be used to access records in the cache.

3. Names the cache with the name passed in this API.

4. Associates the cache with a cache handle (HCACHE) that the user will use to reference the cache in call to JDE Cache APIs.

More than one cache handles can be initialized by using the same cache name, but the lpIndex structure must be an exact match.

Syntax

JDECM_RESULT jdeCacheInit (HUSER hUser, HCACHE *hCache, JCHAR * szCacheName, JDECMINDEXSTRUCT *lpIndex);

Parameters

Parameter | Notes | Usage
hUser | This must be the user handle obtained from a call to the JDB_ API. It must be a non-null handle. The created cache will be associated with this handle. | Input
*hCache | This cache handle is used to identify the cache on every call to a JDE Cache API. Thus if a NULL is returned by this API then any subsequent call to the operational JDE Cache APIs will fail. It is always the first parameter to all the other JDE Cache APIs except for this API and jdeCacheTerminate(). There is no limit for the number of cache handles that can be initialized. Do not reuse this handle without having called a jdeCacheTerminate; otherwise, a memory leak will occur. | Output
*szCacheName | The cache name must always be passed. It uniquely identifies the cache. If there is more than one cache, they all should have distinct names, though the szCacheName cannot be more than 45 characters. | Input
*lpIndex | Must point to one and only one JDECMINDEXSTRUCT. This index will be used to reference the data in the cache. Note, there cannot be more than 25 CacheKey in one lpIndex. | Input

Return Value

Return Value | Description
JDECM_PASSED | Return value if this succeeds
JDECM_FAILED | Return value if this fails

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

if (jdeCacheInit(hUser, &hCache, szCacheName, Index)==JDECM_FAILED)

{

printf(“Initialize cache failed \n”);

/*do something*/

return ;

}

/*do something*/

…

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf(“jdeCacheTerminate Failed \n”);

Additional Notes

Without a call to this API, none of the JDECache API will work.

See Also:

· jdeCacheInitMultipleIndex

· jdeCacheInitUser

· jdeCacheInitMultipleIndexUser.


jdeCacheInitMultipleIndex.htm

jdeCacheInitMultipleIndex

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheInitMultipleIndex initializes a named multiple indexes cache, associates the initialized cache with a user and returns a handle to the initialized cache. This API accomplishes four things:

1. Creates a cache in memory.

2. Creates indexes that will be used to access records in the cache.

3. Names the cache with the name passed with szCacheName.

4. Associates the cache with a cache handle (HCACHE) that the user will use to reference the cache in call to JDE Cache APIs.

More than one cache handle can be initialized by using the same cache name, but the lpIndex structure must be an exact match.

Note. Without a call to this API or to jdeCacheInitMultipleindexes, none of the JDECache API will work.

Syntax

JDECM_RESULT jdeCacheInitMultipleIndex(HUSER hUser, HCACHE * hCache, char * szCacheName,JDECMINDEXSTRUCT *lpIndex, short int

nNumindexes)

Parameters

hUser | Input. The user handle obtained from a call to the JDB_ API. It cannot be NULL. The created cache is associated with this handle.
hCache | Output. This cache handle identifies the cache on every call to a JDE Cache API. This means that if a NULL is returned by this API, then any subsequent call to the operational JDE Cache APIs will fail. It is always the first parameter to all the other JDE Cache APIs except for this API and jdeCacheTerminate. There is no limit for the number of cache handles that can be initialized. Do not reuse this handle without having called a jdeCacheTerminate; otherwise, a memory leak will occur.
szCacheName | Input, required. A unique cache identifier. If there is more than one cache, they all should have distinct names. szCacheName cannot be longer than 45 characters.
lpIndex | Input. This index references the data in the cache. It must point to one and only one JDECMINDEXSTRUCT. There cannot be more than 25 CacheKeys in one lpIndex.
nNumindexes | Input. Total number of indexes declared in lpIndex.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[2];

short int nNumindexes = 2;

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up multiple indexes structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT)*2);

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

Index[1].nKeyID = 2;

Index[1].nNumSegments = 1;

Index[1].CacheKey[0].nOffset = 10;

Index[1].CacheKey[0].nSize=5;

Index[1].CacheKey[0].idDataType = EVDT_STRING;

/*initialize multiple indexes*/

if (jdeCacheInitMultipleIndex(hUser, &hCache, szCacheName, Index, nNumindexes)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheInitMultipleIndexUser.htm

jdeCacheInitMultipleIndexUser

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheInitMultipleIndexUser initializes a named multiple indexes cache, associates the initialized cache with a user and returns a handle to the initialized cache. This API accomplishes five things:

1. Creates a cache in memory.

2. Creates indexes that will be used to access records in the cache.

3. Makes the cache name to be unique per application.

4. Names the cache with the created unique name.

5. Associates the cache with a cache handle (HCACHE) that the user will use to reference the cache in call to JDE Cache APIs.

More than one cache handles can be initialized by using the same cache name, but the lpIndex structure must be an exact match.

Note. Without a call to this API, none of the jdeCache APIs will work

Syntax

JDECM_RESULT jdeCacheInitMultipleIndexUser(HUSER hUser, HCACHE * hCache, char * szCacheName,JDECMINDEXSTRUCT *lpIndex, short

int nNumindexes, LPBHVRCOM lpBhvrCom)

Parameters

hUser | Input. The user handle obtained from a call to the JDB_ API. It cannot be NULL. The created cache is associated with this handle.
hCache | Output. This cache handle identifies the cache on every call to a JDE Cache API. This means that if a NULL is returned by this API, then any subsequent call to the operational JDE Cache APIs will fail. It is always the first parameter to all the other JDE Cache APIs except for this API and jdeCacheTerminate. There is no limit for the number of cache handles that can be initialized. Do not reuse this handle without having called a jdeCacheTerminate; otherwise, a memory leak will occur.
szCacheName | Input, required. A unique cache identifier. If there is more than one cache, they all should have distinct names. szCacheName cannot be longer than 45 characters.
lpIndex | Input. This index references the data in the cache. It must point to one and only one JDECMINDEXSTRUCT. There cannot be more than 25 CacheKeys in one lpIndex.
nNumindexes | Input. Total number of indexes declared in lpIndex.
lpBhvrCom | Input. Pointer to behavior com structure. This structure will provide cache with the unique manual commit hUuser address used to make cache unique per application.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[2];

short int nNumindexes = 2;

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up multiple indexes structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT)*2);

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

Index[1].nKeyID = 2;

Index[1].nNumSegments = 1;

Index[1].CacheKey[0].nOffset = 10;

Index[1].CacheKey[0].nSize=5;

Index[1].CacheKey[0].idDataType = EVDT_STRING;

/*initialize multiple indexes*/

if (jdeCacheInitMultipleIndexUser(hUser, &hCache, szCacheName, Index, nNumindexes, lpBhvrCom)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheInitUser.htm

jdeCacheInitUser

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheInitUser initializes a named cache, associates the initialized cache with a user and returns a handle to the initialized cache. This API accomplishes five things:

1. Creates a cache in memory

2. Creates an index that will be used to access records in the cache.

3. Makes the cache name to be unique per application.

4. Names the cache with the created unique name.

5. Associates the cache with a cache handle (HCACHE) that the user will use to reference the cache in call to JDE Cache APIs.

More than one cache handles can be initialized by using the same cache name, but the lpIndex structure must be an exact match.

Syntax

JDECM_RESULT jdeCacheInitUser(HUSER hUser, HCACHE * hCache, char * szCacheName , JDECMINDEXSTRUCT * lpIndex, LPBHVRCOM lpBhvrCom)

Parameters

hUser | Input. The user handle obtained from a call to the JDB_ API. It cannot be NULL. The created cache is associated with this handle.
hCache | Output. This cache handle identifies the cache on every call to a JDE Cache API. This means that if a NULL is returned by this API, then any subsequent call to the operational JDE Cache APIs will fail. It is always the first parameter to all the other JDE Cache APIs except for this API and jdeCacheTerminate. There is no limit for the number of cache handles that can be initialized. Do not reuse this handle without having called a jdeCacheTerminate; otherwise, a memory leak will occur.
szCacheName | Input, required. A unique cache identifier. If there is more than one cache, they all should have distinct names. szCacheName cannot be longer than 45 characters.
lpIndex | Input. This index references the data in the cache. It must point to one and only one JDECMINDEXSTRUCT. There cannot be more than 25 CacheKeys in one lpIndex.
lpBhvrCom | Input. Pointer to behavior com structure. This structure will provide cache with the unique manual commit hUuser address used to make cache unique per application.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

if (jdeCacheInitUser(hUser, &hCache, szCacheName, Index, lpBhvrCom)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*do something*/

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheTerminate

Last Modified: EnterpriseOne | March 25, 2000

jdeCacheTerminate dissociates given cache handle from the cache. This means that the passed cache handle cannot be used to access this cache anymore. This has the effect of destroying the cache being referenced by the cache handle to the calling application. If this is the jdeCacheTerminate call that matches the total number of jdeCacheInit calls, then the cache is not only disassociated from the cache handle but also physically destroyed from memory.

Syntax

JDECM_RESULT jdeCacheTerminate (HUSER hUser,HCACHE hCache)

Parameters

Parameter | Notes | Usage
hUser | This must be the user handle obtained from a call to the JDB_InitUser API. It must be non-null handle. The destroyed cache must be associated with this handle. | Input
hCache | This cache handle is used to identify the cache. Once this API returns, this cache cannot be accessed anymore. The user will need to start the whole caching process again. | Output

Return Value

Return Value | Description
JDECM_PASSED | Return value if this succeeds
JDECM_FAILED | Return value if this fails

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

if (jdeCacheInit(hUser, &hCache, szCacheName, Index)==JDECM_FAILED)

{

printf(“Initialize cache failed \n”);

/*do something*/

return ;

}

/*do something*/

…

…

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf(“jdeCacheTerminate Failed \n”);

Additional Notes

If more than one Cache Handles with the same cache name is initialized, this API does not terminate all of the cache handles from memory by calling it once. Each of the initialized cache handles can be terminated by calling jdeCacheTerminate or jdeCacheTerminateAll.


jdeCacheTerminateAll

Last Modified: EnterpriseOne | March 25, 2000

jdeCacheTerminateAll destroys all caches with the same name as the one with the given hCache. The caches are physically removed from memory.

Syntax

JDECM_RESULT jdeCacheTerminateAll (HUSER hUser, HCACHE hCache)

Parameters

Parameter | Notes | Usage
hUser | This must be the user handle obtained from a call to the JDB_InitUser API. It must be a non-null handle. The destroyed cache must be associated with this handle. | Input
hCache | This cache handle is used to identify the cache. Once this API returns, this cache cannot be accessed anymore. The user will need to start the whole caching process again. | Input

Return Value

Return Value | Description
JDECM_PASSED | Return value if this succeeds
JDECM_FAILED | Return value if this fails

Example

HCACHE hCache;

HCACHE hCache1;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char szCacheName1[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

memset(szCacheName1,0x00,sizeof(szCacheName1));

strcpy(szCacheName,”B4321234CMCache”);

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

if (jdeCacheInit(hUser, &hCache, szCacheName, Index)==JDECM_FAILED)

{

printf(“Initialize cache failed \n”);

/*do something*/

return ;

}

…

if (jdeCacheInit(hUser, &hCache1, szCacheName1, Index)==JDECM_FAILED)

{

printf(“Initialize cache failed \n”);

/*do something*/

return ;

}

…

if (jdeCacheInit(hUser, &hCache, szCacheName, Index)==JDECM_FAILED)

{

printf(“Initialize cache failed \n”);

/*do something*/

return ;

}

/*do something*/

…

…

/*terminates all caches*/

if (jdeCacheTerminateAll(hUser,hCache)==JDECM_FAILED)

printf(“jdeCacheTerminateAll Failed \n”);


JDECache Manipulation

JDECache Manipulation APIs are responsible for retrieving and manipulating the data in the cache. Each API implements a cursor that acts as pointer to a record that is currently being manipulated. This cursor is essential for navigation Functions within the cache. JDE Cache Manipulation APIs should be passed handles of the following types:

  • HCACHE: A handle that identifies the cache that is being worked with

  • HJDECURSOR: Identifies the position in the cache that is being worked with

JDECache Manipulation consist of the following APIs:

 | jdeCacheAdd
app.gif (808 bytes) | jdeCacheCloseCursor
 | jdeCacheDelete
app.gif (808 bytes) | jdeCacheDeleteAll
 | jdeCacheFetch
app.gif (808 bytes) | jdeCacheFetchPosition
 | jdeCacheFetchPositionByRef
 | jdeCacheGetIndex
 | jdeCacheGetNumCursors
app.gif (808 bytes) | jdeCacheOpenCursor
 | jdeCacheResetCursor
 | jdeCacheSetIndex
app.gif (808 bytes) | jdeCacheUpdate


jdeCacheAdd

Last Modified: EnterpriseOne Xe | March 29, 2000

jdeCacheAdd adds a record to the cache identified by the cache handle hCache that was obtained from the call to jdeCacheInit. The sequence order of the added record is determined by the index that was passed to jdeCacheInit.

Syntax

JDECM_RESULT jdeCacheAdd (HCACHE hCache, void * lpData, long nDataSize)

Parameters

Parameter | Notes | Usage
HCache | This cache handle is used to uniquely identify the cache. | Input
LpData | This is the full structure from which the offsets of the columns constituting the index keys were established. In a JDB environment, the structure represents one record. Use memset() on this structure before adding elements to it. | Input
nDataSize | The size of the structure record that is being passed with the data. | Input

Return Value

Return Value | Description
JDECM_PASSED | Return value if this succeeds
JDECM_FAILED | Return value if this fails

Example

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

/*set up index structure*/

&ldots;

/*initialize cache*/

&ldots;

/*add a record*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,“Testing  12345”);

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

      printf(“Add record failed !!\n”);

/*do something*/

&ldots;

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

     printf(“jdeCacheTerminate Failed \n”);


jdeCacheCloseCursor

Last Modified: EnterpriseOne | March 29, 2000

jdeCacheCloseCursor closes a cursor pointing to the data set within a cache. The cursor is closed regardless of its position within the data set. A subsequent call to any cursor API except for jdeCacheOpenCursor will fail.

For multiple opened HJDECURSOR, this API must be called to close all opened HJDECURSOR before the cache is terminated.

Syntax

JDECM_RESULT jdeCacheCloseCursor (HCACHE hCache, HJDECURSOR hCursor);

Parameters

Parameter | Notes | Usage
hCache | The cache handle is used to uniquely identify the cache. The cursor pointing to the data set within the cache associated with this cache handle will be closed. | Input
hCursor | This is the cursor handle used in calls to Data Manipulation APIs to referenced records in the cache. | Input

Return Value

Return Value | Description
JDECM_PASSED | Return value if this succeeds
JDECM_FAILED | Return value if this fails

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

/*set up index structure*/

…

/*initialize cache*/

…

/*add some records*/

…

/*open a cursor*/

…

/*do something*/

…

if (jdeCacheCloseCursor(hCache,hCursor)==JDECM_FAILED)

printf(“jdeCacheCloseCursor Failed\n”);

/*do something*/

…

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf(“jdeCacheTerminate Failed \n”);


jdeCacheDelete

Last Modified: EnterpriseOne | March 29, 2000

jdeCacheDelete deletes the record that is pointed by the cursor.

If the cache is not empty and the cursor is open, the record currently being pointed to by HJDECURSOR is deleted.

Syntax

JDECM_RESULT jdeCacheDelete (HCACHE hCache, HJDECURSOR hCursor)

Parameters

Parameter | Notes | Usage
hCache | The cache handle is used to uniquely identify the cache. The cursor pointing to the data set within the cache associated with this cache handle will be closed. | Input
hCursor | This cursor handle is to be used in calls to Data Manipulation APIs to referenced records in the cache. | Input

Return Value

Return Value | Description
JDECM_PASSED | Return value if this succeeds
JDECM_FAILED | Return value if this fails

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

char ret_Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 10;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

…

/*add records*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,“Testing”);

strcpy(Data+10, “12345”);

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf(“Add record failed !!\n”);

memset(Data,0x00,sizeof(Data));

strcpy(Data,“Testing”);

strcpy(Data+10, “67890”);

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf(“Add record failed !!\n”);

/*open a cursor*/

…

/*fetch position*/

memset(ret_Data,0x00,sizeof(ret_Data));

if (jdeCacheFetchPosition(hCache,hCursor,Data,2,ret_Data,sizeof(ret_Data))==JDECM_FAILED)

printf(“Record not found\n”);

/*delete the key that the cursor points at*/

if (jdeCacheDelete(hCache,hCursor)==JDECM_FAILED)

printf(“Delete record failed\n”);

…

/*do something*/

…

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf(“jdeCacheTerminate Failed \n”);


jdeCacheDeleteAll

Last Modified: EnterpriseOne | March 29, 2000

jdeCacheDeleteAll deletes all records matching the given key from the cache identified by the cache handle hCache that was obtained from the call to jdeCacheInit. This API works well when deleting records based on a partial key.

Syntax

JDECM_RESULT jdeCacheDeleteAll (HCACHE hCache, HJDECURSOR hCursor, void * lpKey, short int nNumKeys)

Parameters

Parameter | Notes | Usage
hCache | This cache handle is used to uniquely identify the cache. | Input
hCursor | This is the cursor handle that is be used in calls to Data Manipulation APIs to referenced records in the cache. | Input
lpKey | This key structure must first be memset before any elements are placed. The number, order, and type of the elements in this structure must match that of the defined index keys. | Input
nNumKeys | This is the number of keys in lpKey. If this number is less than the total defined in jdeCacheInit, then the key will be treated as partial keys. | Input

Return Value

Return Value | Description
JDECM_PASSED | Return value if this succeeds
JDECM_FAILED | Return value if this fails

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 10;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

…

/*add records*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,“Testing”);

strcpy(Data+10, “12345”);

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf(“Add record failed !!\n”);

memset(Data,0x00,sizeof(Data));

strcpy(Data,“Testing”);

strcpy(Data+10, “67890”);

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf(“Add record failed !!\n”);

/*open a cursor*/

…

/*delete all the records with the first key is “Testing”*/

if (jdeCacheDeleteAll(hCache,hCursor,Data,1)==JDECM_FAILED)

printf(“Delete record failed\n”);

…

/*do something*/

…

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf(“jdeCacheTerminate Failed \n”);


JdeCacheFetch

Last Modified: EnterpriseOne | May 08, 2000

JdeCacheFetch advances the cursor to the next record in the dataset relative to the current cursor position and retrieves the record. This will now be the new position associated with HJDECURSOR. This API does not search for a record in the cache but fetches whatever record is after the record that is currently being pointed to the passed HJDECURSOR. The API is ideal for performing sequential fetches.

First, the passed HJDECURSOR is checked to see if it's the current ACTIVE cursor. If it is not, the Cursor Manager is referenced and the appropriate HJDECURSOR is obtained and made to be the ACTIVE HJDECURSOR. If the cache is not empty and the cursor is open, the cursor is advanced to the next record in the data set related to the current cursor position before fetching the record at the new cursor position.

The IpData must be at least the same size as the data set that was added. If you have added different size of data sets to the same cache, then you have to use the largest data size for the IpData. Without accomplishing the above requiremenhts, you might cause memory to be overridden.

Syntax

JDECM_RESULT jdeCacheFetch (HCACHE hCache, HJDECURSOR hCursor, void *lpData, void * lpNull);

Parameters

Parameter | Notes | Usage
hCache | The cache handle is used to uniquely identify the cache. | Input
hCursor | This cursor handle is to be used in calls to Data Manipulation APIs to referenced records in the cache. | Input
lpData | Pointer structure to be filled with the fetched data. | Output
lpNull | This must be NULL; it is for future enhancements. | Input

Return Value

Return Value | Description
JDECM_PASSED | Return value if this succeeds
JDECM_FAILED | Return value if this fails

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

char ret_Data[100];

void lpNull= NULL;

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 10;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

…

/*add records*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,“Testing”);

strcpy(Data+10, “12345”);

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf(“Add record failed !!\n”);

memset(Data,0x00,sizeof(Data));

strcpy(Data,“Testing”);

strcpy(Data+10, “67890”);

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf(“Add record failed !!\n”);

/*open a cursor*/

…

/*fetch position the cursor to the first record that has the key “Testing”*/

memset(ret_Data,0x00,sizeof(ret_Data));

if (jdeCacheFetchPosition(hCache,hCursor,Data,1,ret_Data,sizeof(ret_Data))==JDECM_FAILED)

printf(“Record not found\n”);

/*continue fetching*/

memset(ret_Data,0x00,sizeof(ret_Data));

if (jdeCacheFetch(hCache,hCursor,Data,lpNull)==JDECM_FAILED)

printf(“jdeCacheFetch Failed\n”);

…

/*do something*/

…

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf(“jdeCacheTerminate Failed \n”);


jdeCacheFetchPosition

Last Modified: EnterpriseOne | March 29, 2000

jdeCacheFetchPosition retrieves the record that corresponds to the given key. This API can be used to position the HJDECURSOR to a specific location within the data set. When a call to jdeCacheFetch is made, it will start fetching from the next position. This is useful for making sequential fetches beginning at a specific location in the cache.

First, the passed HJDECURSOR is checked to see if it's the current ACTIVE cursor. If it is not, then the Cursor Manager is accessed and the appropriate HJDECURSOR is obtained and made to be the ACTIVE HJDECURSOR. If the cache is not empty and the cursor is open, then the passed number of keys is checked to see if they constitute a partial index. If they do, then the partial key is used to fetch the first record that matches the given partial key. If the cache is not empty and the cursor is open, the record that matches the given key will be returned and the cursor will point to the founded record.

Syntax

JDECM_RESULT jdeCacheFetchPosition (HCACHE hCache, HJDECURSOR hCursor, void *lpKey, short int nNumColsInKey, void * lpData, long nDataSize)

Parameters

Parameter | Notes | Usage
hCache | This cache handle is used to uniquely identify the cache. | Input
hCursor | This cursor handle is to be used in calls to Data Manipulation APIs to referenced records in the cache. | Input
lpKey | This key structure must first be memset() before any elements are placed. The number, order, and type of the elements in this structure must match that of the defined index keys. | Input
nNumColsInKey | These are the number of columns in the passed key that the user wants the search to be made with. This allows for partial indexing. Only the columns starting from the first column to the number of columns specified may be used. They must be in succession. If this number is less than the total that was defined in jdeCacheInit, then the key will be treated as partial keys. | Input
lpData | The offsets of the columns constituting the index keys were established from this full structure. In a JDB environment, the structure represents one record. | Output
nDataSize | Use sizeof() to get the size of the structure that is being passed with the data. | Input

Return Value

Return Value | Description
JDECM_PASSED | Return value if this succeeds
JDECM_FAILED | Return value if this fails

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

char ret_Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 10;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

…

/*add records*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,“Testing”);

strcpy(Data+10, “12345”);

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf(“Add record failed !!\n”);

memset(Data,0x00,sizeof(Data));

strcpy(Data,“Testing”);

strcpy(Data+10, “67890”);

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf(“Add record failed !!\n”);

/*open a cursor*/

…

/*fetch position the cursor to the first record that has the key “Testing 67890”*/

memset(ret_Data,0x00,sizeof(ret_Data));

if (jdeCacheFetchPosition(hCache,hCursor,Data,2,ret_Data,sizeof(ret_Data))==JDECM_FAILED)

printf(“Record not found\n”);

…

/*do something*/

…

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf(“jdeCacheTerminate Failed \n”);


jdeCacheFetchPositionByRef.htm

jdeCacheFetchPositionByRef

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheFetchPositionByRef retrieves the memory address of the one and only one data block in cache.

If more than one record exists in cache, this API will return failed. If the cache is empty, this API will return failed. This API will always return the same memory address.

Note. Do not free the returned data pointer address. This action may cause a memory violation problem on certain platforms.

Syntax

JDECM_RESULT jdeCacheFetchPositionByRef(HCACHE hCache, void **lplpData)

Parameters

hCache | Pointer to Data Cache memory. The cache handle must be initialized before calling this API. If the cache handle is NULL, this API will return fail. If the cache handle is not initialized or is an invalid memory, it will cause a memory violation problem. Therefore, the best way to avoid the memory violation problem is to always set the cache handle to NULL where it is defined. Input
lplpData | Output. Pointer to the data block in cache.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

void *lpData=NULL; /*a data pointer*/

/*Initialize cache handle and adds a record*/

...

if (jdeCacheFetchPositionByRef(hCache,&lpData)==JDECM_FAILED)

printf("jdeCacheFetchPositionByRef Failed !! \n");

...

/*Free the cache*/

...


jdeCacheGetIndex.htm

jdeCacheGetIndex

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheGetIndex enables you to retrieve the ID of the index to which the cursor is pointing. Use this API when you are using multiple indexes.

Syntax

long int jdeCacheGetIndex(HCACHE hCache, HJDECURSOR hCursor)

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache associated with hcache. Use this cursor handle used in calls to Data Manipulation APIs to reference records in the cache.

Return Values

This API can return this value:

long int

The ID of the Index to which the cursor is pointing.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[2];

short int nNumindexes = 2;

char szCacheName[20];

long int nKeyID = 2;

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up multiple indexes structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT)*2);

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

Index[1].nKeyID = 2;

Index[1].nNumSegments = 1;

Index[1].CacheKey[0].nOffset = 10;

Index[1].CacheKey[0].nSize=5;

Index[1].CacheKey[0].idDataType = EVDT_STRING;

/*initialize multiple indexes*/

if (jdeCacheInitMultipleIndex(hUser, &hCache, szCacheName, Index, nNumindexes)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*add some records*/

...

/*open cursor*/

...

if (jdeCacheSetIndexNumCursors(hCache,hCursor,nKeyID)==JDECM_FAILED)

printf("Set Index ID failed !!\n");

/*do something*

if (jdeCacheGetIndexNumCursors(hCache,hCursor)!=nKeyID)

printf("Cursor point at the wrong Index!!\n");

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheGetNumCursors.htm

jdeCacheGetNumCursors

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheGetNumCursors returns the total number of cursors currently opened in the cache identified by hCache.

Syntax

short int jdeCacheGetNumCursors(HCACHE hCache)

Parameters

hCache

Input. A cache handle that uniquely identifies the cache.

Return Values

This API can return this value:

Value | Description
short int | Total number of cursors currently in the cache.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up an index structure*/

...

/*initialize cache*/

...

/*add some records*/

...

/*open cursor*/

...

if (jdeCacheGetNumCursors(hCache)<1)

printf("No cursor was opened in cache[%s]\n",szCacheName);

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheOpenCursor

Last Modified: EnterpriseOne | March 29, 2000

jdeCacheOpenCursor opens a cursor for use. Without opening a cursor, all calls to the JDE Cache Data Manipulating APIs will fail. When a cursor is opened, the cache is first checked to see if it contains any records. If it does then the number of cursors for this cache is checked. If the number is less than the maximum permitted, a new cursor is created and added to the JDE Cache Cursor Manager. This cursor is then assigned to be the current ACTIVE HJDECURSOR for the HCACHE.

Syntax

JDECM_RESULT jdeCacheOpenCursor (HCACHE hCache, HJDECURSOR * hCursor);

Parameters

Parameter | Notes | Usage
hCache | The cache handle is used to uniquely identify the cache. The cursor will point to the data set within the cache associated with this cache handle. | Input.
hCursor | This is the cursor handle used in subsequent calls to Data Manipulation APIs. Here the address of the cursor handle must be passed. | Input.

Return Value

Return Value | Description
JDECM_PASSED | Return value if this succeeds
JDECM_FAILED | Return value if this fails

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

/*set up index structure*/

…

/*initialize cache*/

…

/*add some records*/

…

/*open a cursor*/

if (jdeCacheOpenCursor(hCache,&hCursor)==JDECM_FAILED)

printf(“Open cursor failed !\n”)

…

/*do something*/

…

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf(“jdeCacheTerminate Failed \n”);

Additional Notes

The maximum number of open cursors on any one cache is 100


jdeCacheResetCursor

Last Modified: EnterpriseOne | March 29, 2000

jdeCacheResetCursor resets a cursor, for example, it repositions the cursor to point to the first record in the data set using the first index. The passed cursor is assigned to be the ACTIVE HJDECURSOR cursor for the cache, and if the cache is not empty, then the repositioning takes place.

Syntax

JDECM_RESULT jdeCachResetCursor (HCACHE hCache, HJDECURSOR hCursor);

Parameters

Parameter | Notes | Usage
hCache | The cache handle is used to uniquely identify the cache. The cursor will point to the data set within the cache associated with this cache handle. | Input.
hCursor | This is the cursor handle that is be used in calls to Data Manipulation APIs to referenced records in the cache. | Input.

Return Value

Return Value | Description
JDECM_PASSED | Return value if this succeeds
JDECM_FAILED | Return value if this fails

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

/*set up index structure*/

…

/*initialize cache*/

…

/*add some records*/

…

/*open a cursor*/

…

/*do something*/

…

if (jdeCacheGetNumRecords(hCache)>0)

{

if (jdeCacheResetCursor(hCache,hCursor)==JDECM_FAILED)

printf(“jdeCacheResetCursor Failed, something very bad happened\n”);

}

else

printf(“The cache is empty and there is no record for the cursor to point at\n”);

/*do something*/

…

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf(“jdeCacheTerminate Failed \n”);


jdeCacheSetIndex.htm

jdeCacheSetIndex

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheSetIndex enables you to set a cursor point to a desired index field by passing in the index ID. Use this API when you are using multiple indexes.

Syntax

JDECM_RESULT jdeCacheSetIndex(HCACHE hCache, HJDECURSOR hCursor, long int nIndexID)

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache associated with hCache. Use this cursor handle used in calls to Data Manipulation APIs to reference records in the cache.
nIndexID | Input. One of the declared Index IDs in the Index structure.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[2];

short int nNumindexes = 2;

char szCacheName[20];

long int nKeyID = 2;

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up multiple indexes structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT)*2);

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

Index[1].nKeyID = 2;

Index[1].nNumSegments = 1;

Index[1].CacheKey[0].nOffset = 10;

Index[1].CacheKey[0].nSize=5;

Index[1].CacheKey[0].idDataType = EVDT_STRING;

/*initialize multiple indexes*/

if (jdeCacheInitMultipleIndex(hUser, &hCache, szCacheName, Index, nNumindexes)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return;

}

/*add some records*/

...

/*open cursor*/

...

if (jdeCacheSetIndexNumCursors(hCache,hCursor,nKeyID)==JDECM_FAILED)

printf("Set Index ID failed !!\n");

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheUpdate

Last Modified: EnterpriseOne | March 29, 2000

jdeCacheUpdate updates the record that is currently being pointed to by the passed HJDECURSOR with the passed data. Programmers are advised to use a cursor manipulation API that does not advance the cursor such as jdeCacheFetch or jdeCacheFetchPosition in order to position the cursor to the record to be updated before calling this API.

If the cache is not empty and the cursor is open, then the record currently being pointed to by HJDECURSOR is updated.

Syntax

JDECM_RESULT jdeCacheUpdate (HCACHE hCache, HJDECURSOR hCursor, void *lpData, long nDataSize);

Parameters

Parameter | Notes | Usage
hCache | The cache handle is used to uniquely identify the cache. | Input
hCursor | This cursor handle is to be used in calls to Data Manipulation APIs to referenced records in the cache. | Input
lpData | Pointer structure containing the data to be used to update. | Input
nDataSize | The size of the structure that is being passed with the data. | Input

Return Value

Return Value | Description
JDECM_PASSED | Return value if this succeeds
JDECM_FAILED | Return value if this fails

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

char ret_Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 10;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

…

/*add records*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,“Testing”);

strcpy(Data+10, “12345”);

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf(“Add record failed !!\n”);

memset(Data,0x00,sizeof(Data));

strcpy(Data,“Testing”);

strcpy(Data+10, “67890”);

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf(“Add record failed !!\n”);

/*open a cursor*/

…

/*fetch position the cursor to the first record that has the key “Testing 67890”*/

memset(ret_Data,0x00,sizeof(ret_Data));

if (jdeCacheFetchPosition(hCache,hCursor,Data,2,ret_Data,sizeof(ret_Data))==JDECM_FAILED)

printf(“Record not found\n”);

/*update the located record*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,“DoneTest”);

strcpy(Data+10, “45612”);

if (jdeCacheUpdate(hCache,hCursor,Data,sizeof(Data))==JDECM_FAILED)

printf(“jdeCacheUpdate Failed\n”);

/*do something*/

…

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf(“jdeCacheTerminate Failed \n”);


jdeCacheCloseCursor.htm

jdeCacheCloseCursor

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheCloseCursor closes a cursor pointing to the data set within a cache. The cursor is closed regardless of its position within the data set. A subsequent call to any cursor API except for jdeCacheOpenCursor will fail.

Note. For multiple opened HJDECURSORs, this API must be called to close all opened HJDECURSOR before the cache is terminated.

Syntax

JDECM_RESULT jdeCacheCloseCursor (HCACHE hCache, HJDECURSOR hCursor);

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache, associated with hcache, that you want to close. Use this cursor handle in calls to Data Manipulation APIs to reference records in the cache.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

...

/*initialize cache*/

...

/*add some records*/

...

/*open a cursor*/

...

/*do something*/

...

if (jdeCacheCloseCursor(hCache,hCursor)==JDECM_FAILED)

printf("jdeCacheCloseCursor Failed\n");

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheDeleteAll.htm

jdeCacheDeleteAll

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheDeleteAll deletes all records matching the given key from the cache identified by the cache handle hCache that was obtained from the call to jdeCacheInit. This API works well when deleting records based on a partial key.

Syntax

JDECM_RESULT jdeCacheDeleteAll (HCACHE hCache, HJDECURSOR hCursor, void * lpKey, short int nNumKeys)

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache associated with hcache. Use this cursor handle in calls to Data Manipulation APIs to reference records in the cache.
lpKey | Input. Use memset() on this key before adding elements to it. The number, order, and type of the elements in this structure must match that of the defined index keys.
nNumKeys | Input. The number of keys in lpKey. If this number is less than the total defined in jdeCacheInit, the key is treated as a partial key.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 10;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

...

/*add records*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "12345");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "67890");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

/*open a cursor*/

...

/*delete all the records with the first key is "Testing"*/

if (jdeCacheDeleteAll(hCache,hCursor,Data,1)==JDECM_FAILED)

printf("Delete record failed\n");

...

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheFetch.htm

jdeCacheFetch

Last Modified: EnterpriseOne | June 06, 2006

JdeCacheFetch advances the cursor to the next record in the dataset relative to the current cursor position and retrieves the record. This becomes the new position associated with HJDECURSOR. This API does not search for a record in the cache. Instead, it fetches the next record after the record that the passed HJDECURSOR is currently pointing to. The API is ideal for performing sequential fetches.

First, the passed HJDECURSOR is checked to see if it's the current ACTIVE cursor. If it is not, the Cursor Manager is referenced and the appropriate HJDECURSOR is obtained and made to be the active HJDECURSOR. If the cache is not empty and the cursor is open, the cursor is advanced to the next record in the data set related to the current cursor position before fetching the record at the new cursor position.

The IpData must be at least the same size as the data set that was added. If you have added different sizes of data sets to the same cache, you must use the size of the largest data set in IpData. If you do not, you might cause memory to be overridden.

Syntax

JDECM_RESULT jdeCacheFetch (HCACHE hCache, HJDECURSOR hCursor, void *lpData, void * lpNull);

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache associated with hcache. Use this cursor handle in calls to Data Manipulation APIs to reference records in the cache.
lpData | Output. Pointer structure to be filled with the fetched data.
lpNull | Input. Must be NULL. Reserved for future use.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

char ret_Data[100];

void lpNull= NULL;

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 10;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

...

/*add records*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "12345");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "67890");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

/*open a cursor*/

...

/*fetch position the cursor to the first record that has the key "Testing"*/

memset(ret_Data,0x00,sizeof(ret_Data));

if (jdeCacheFetchPosition(hCache,hCursor,Data,1,ret_Data,sizeof(ret_Data))==JDECM_FAILED)

printf("Record not found\n");

/*continue fetching*/

memset(ret_Data,0x00,sizeof(ret_Data));

if (jdeCacheFetch(hCache,hCursor,Data,lpNull)==JDECM_FAILED)

printf("jdeCacheFetch Failed\n");

...

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheFetchPosition.htm

jdeCacheFetchPosition

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheFetchPosition retrieves the record that corresponds to the given key. You can use this API to position the HJDECURSOR at a specific location within the data set. When you make a call to jdeCacheFetch, it starts fetching from the next position. This is useful for making sequential fetches beginning at a specific location in the cache.

First, the passed HJDECURSOR is checked to see if it's the current active cursor. If it is not, then the Cursor Manager is accessed and the appropriate HJDECURSOR is obtained and made to be the active HJDECURSOR. If the cache is not empty and the cursor is open, then the passed number of keys is checked to see if they constitute a partial index. If they do, then the partial key is used to fetch the first record that matches the given partial key. If the cache is not empty and the cursor is open, the record that matches the given key will be returned and the cursor will point to the founded record.

Syntax

JDECM_RESULT jdeCacheFetchPosition (HCACHE hCache, HJDECURSOR hCursor, void *lpKey, short int nNumColsInKey, void * lpData, long nDataSize)

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache associated with hcache. Use this cursor handle in calls to Data Manipulation APIs to reference records in the cache.
lpKey | Input. Use memset() on this structure before adding elements to it. The number, order, and type of the elements in this structure must match that of the defined index keys.
nNumColsInKey | Input. The number of columns in the passed key with which you want the search to be made. This allows for partial indexing. Only the columns starting from the first column to the number of columns specified may be used. They must be in succession. If this number is less than the total that was defined in jdeCacheInit, then the key is treated as a partial key.
lpData | Output. The offsets of the columns constituting the index keys that were established from this full structure. In a JDB environment, the structure represents one record.
nDataSize | Input. Use sizeof() to get the size of the structure that is being passed with the data.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

char ret_Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 10;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

...

/*add records*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "12345");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "67890");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

/*open a cursor*/

...

/*fetch position the cursor to the first record that has the key "Testing 67890"*/

memset(ret_Data,0x00,sizeof(ret_Data));

if (jdeCacheFetchPosition(hCache,hCursor,Data,2,ret_Data,sizeof(ret_Data))==JDECM_FAILED)

printf("Record not found\n");

...

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheClear.htm

jdeCacheClear

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheClear deletes all the records in the cache. It does not terminate the cache.

Syntax

JDECM_RESULT jdeCacheClear(HCACHE hCache);

Parameters

hCache

Input. A cache handle that uniquely identifies the cache.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

...

/*initialize cache*/

...

/*add some records*/

...

/*do something*/

...

if (jdeCacheClear(hCache)==JDECM_FAILED)

printf("jdeCacheClearCache Failed !\n");

if (jdeCacheGetNumRecords(hCache)!=0)

printf("Still have records in cache after jdeCacheClearCache !\n");

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheDelete.htm

jdeCacheDelete

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheDelete deletes the record that is pointed to by the cursor. If the cache is not empty and the cursor is open, the record currently being pointed to by HJDECURSOR is deleted.

Syntax

JDECM_RESULT jdeCacheDelete (HCACHE hCache, HJDECURSOR hCursor)

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache associated with hcache. Use this cursor handle in calls to Data Manipulation APIs to reference records in the cache.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

char ret_Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 10;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

..

/*add records*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "12345");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "67890");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

/*open a cursor*/

...

/*fetch position*/

memset(ret_Data,0x00,sizeof(ret_Data));

if (jdeCacheFetchPosition(hCache,hCursor,Data,2,ret_Data,sizeof(ret_Data))==JDECM_FAILED)

printf("Record not found\n");

/*delete the key that the cursor points at*/

if (jdeCacheDelete(hCache,hCursor)==JDECM_FAILED)

printf("Delete record failed\n");

...

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheInit.htm

jdeCacheInit

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheInit initializes a named cache, associates the initialized cache with a user and returns a handle to the initialized cache. This API:

1. Creates a cache in memory.

2. Creates an index that will be used to access records in the cache.

3. Names the cache with the name passed with szCacheName.

4. Associates the cache with a cache handle (HCACHE) that the user will use to reference the cache in call to JDE Cache APIs.

You can initialize more than one cache handle using the same cache name, but the lpIndex structure must be an exact match. jdeCacheInit creates a cache with 100 cursors. To create a cache and define the number of cursors, use jdeCacheInitEx.

Note. Without a call to this API or to jdeCacheInitEx, none of the JDECache APIs will work.

Syntax

JDECM_RESULT jdeCacheInit (HUSER hUser, HCACHE *hCache, char * szCacheName, JDECMINDEXSTRUCT *lpIndex);

Parameters

hUser | Input. The user handle obtained from a call to the JDB_ API. It cannot be NULL. The created cache is associated with this handle.
hCache | Output. This cache handle identifies the cache on every call to a JDE Cache API. This means that if a NULL is returned by this API, then any subsequent call to the operational JDE Cache APIs will fail. It is always the first parameter to all the other JDE Cache APIs except for this API and jdeCacheTerminate. There is no limit for the number of cache handles that can be initialized. Do not reuse this handle without having called a jdeCacheTerminate; otherwise, a memory leak will occur.
szCacheName | Input, required. A unique cache identifier. If there is more than one cache, they all should have distinct names. szCacheName cannot be longer than 45 characters.
lpIndex | Input. This index references the data in the cache. It must point to one and only one JDECMINDEXSTRUCT. There cannot be more than 25 CacheKeys in one lpIndex.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

if (jdeCacheInit(hUser, &hCache, szCacheName, Index)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheInitEx.htm

jdeCacheInitEx

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheInitEx initializes a named cache, associates the initialized cache with a user and returns a handle to the initialized cache. This API:

1. Creates a cache in memory.

2. Creates an index that will be used to access records in the cache.

3. Names the cache with the name passed with szCacheName.

4. Associates the cache with a cache handle (HCACHE) that the user will use to reference the cache in call to JDE Cache APIs.

5. Enables the caller to pass the maximum number of cursors within the range 1 to 100.

You can initialize more than one cache handle using the same cache name, but the lpIndex structure must be an exact match.

Note. Without a call to this API or to jdeCacheInit, none of the JDECache APIs will work.

Syntax

JDECM_RESULT jdeCacheInitEx (HUSER hUser, HCACHE * hCache, JCHAR * szCacheName, JDECMINDEXSTRUCT *lpIndex,short int nSizeCursors);

Parameters

hUser | Input. The user handle obtained from a call to the JDB_ API. It cannot be NULL. The created cache is associated with this handle.
hCache | Output. This cache handle identifies the cache on every call to a JDE Cache API. This means that if a NULL is returned by this API, then any subsequent call to the operational JDE Cache APIs will fail. It is always the first parameter to all the other JDE Cache APIs except for this API and jdeCacheTerminate. There is no limit for the number of cache handles that can be initialized. Do not reuse this handle without having called a jdeCacheTerminate; otherwise, a memory leak will occur.
szCacheName | Input, required. A unique cache identifier. If there is more than one cache, they all should have distinct names. szCacheName cannot be longer than 45 characters.
lpIndex | Input. This index references the data in the cache. It must point to one and only one JDECMINDEXSTRUCT. There cannot be more than 25 CacheKeys in one lpIndex.
nSizeCursors | Input. The maximum number of cursors per cache. It must be in the range from 1 to 100.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

short int nMaxCursors = 10;

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 30;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

if (jdeCacheInit(hUser, &hCache, szCacheName, Index, nMaxCursors ) == JDECM_FAILED )

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheInitMultipleindexEx.htm

jdeCacheInitMultipleindexEx

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheInitMultipleindexes initializes a named multiple indexes cache, associates the initialized cache with a user and returns a handle to the initialized cache. This API accomplishes four things:

1. Creates a cache in memory.

2. Creates indexes that will be used to access records in the cache.

3. Names the cache with the name passed with szCacheName.

4. Associates the cache with a cache handle (HCACHE) that the user will use to reference the cache in call to JDE Cache APIs.

5. Enables the caller to pass the maximum number of cursors within the range 1 to 100.

More than one cache handle can be initialized by using the same cache name, but the lpIndex structure must be an exact match.

Note. Without a call to this API or to jdeCacheInitMultipleIndex, none of the JDECache API will work.

Syntax

JDECM_RESULT jdeCacheInitMultipleindexes(HUSER hUser, HCACHE * hCache, char * szCacheName, JDECMINDEXSTRUCT *lpIndex, short

int nNumindexes, short int nSizeCursors);

Parameters

hUser | Input. The user handle obtained from a call to the JDB_ API. It cannot be NULL. The created cache is associated with this handle.
hCache | Output. This cache handle identifies the cache on every call to a JDE Cache API. This means that if a NULL is returned by this API, then any subsequent call to the operational JDE Cache APIs will fail. It is always the first parameter to all the other JDE Cache APIs except for this API and jdeCacheTerminate. There is no limit for the number of cache handles that can be initialized. Do not reuse this handle without having called a jdeCacheTerminate; otherwise, a memory leak will occur.
szCacheName | Input, required. A unique cache identifier. If there is more than one cache, they all should have distinct names. szCacheName cannot be longer than 45 characters.
lpIndex | Input. This index references the data in the cache. It must point to one and only one JDECMINDEXSTRUCT. There cannot be more than 25 CacheKeys in one lpIndex.
nNumindexes | Input. Total number of indexes declared in lpIndex.
nSizeCursors | Input. The maximum number of cursors per cache. It must be in the range from 1 to 100.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[2];

char szCacheName[20];

short int nMaxCursors = 10;

short totalIndexes = 2

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT)*2);

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 30;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

Index[1].nKeyID = 2;

Index[1].nNumSegments = 2;

Index[1].CacheKey[0].nOffset = 50;

Index[1].CacheKey[0].nSize=10;

Index[1].CacheKey[0].idDataType = EVDT_STRING;

Index[1].CacheKey[1].nOffset = 80;

Index[1].CacheKey[1].nSize=10;

Index[1].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

if (jdeCacheInitMultipleindexes(hUser, &hCache, szCacheName, Index , totalIndexes, nMaxCursors ) == JDECM_FAILED )

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheGetNumRecords.htm

jdeCacheGetNumRecords

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheGetNumRecords returns the total number of records currently stored in the cache identified by hCache. You can use it to check if the cache is empty.

Syntax

long int jdeCacheGetNumRecords (HCACHE hCache);

Parameters

hCache

Input. A cache handle that uniquely identifies the cache.

Return Values

This API can return this value:

Value |  | Description
long int | Total number of records currently in the cache.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

...

/*initialize cache*/

...

/*add some records*/

...

if (jdeCacheGetNumRecords(hCache)<1)

printf("No records was added to cache[%s]\n",szCacheName);

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheResetCursor.htm

jdeCacheResetCursor

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheResetCursor resets a cursor, for example, it repositions the cursor to point to the first record in the data set using the first index. The passed cursor is assigned to be the ACTIVE HJDECURSOR cursor for the cache, and if the cache is not empty, then the repositioning takes place.

Syntax

JDECM_RESULT jdeCachResetCursor (HCACHE hCache, HJDECURSOR hCursor);

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache associated with hCache. Use this cursor handle used in calls to Data Manipulation APIs to reference records in the cache.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

...

/*initialize cache*/

...

/*add some records*/

...

/*open a cursor*/

...

/*do something*/

...

if (jdeCacheGetNumRecords(hCache)>0)

{

if (jdeCacheResetCursor(hCache,hCursor)==JDECM_FAILED)

printf("jdeCacheResetCursor Failed, something very bad happened\n");

}

else

printf("The cache is empty and there is no record for the cursor to point at\n");

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheOpenCursor.htm

jdeCacheOpenCursor

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheOpenCursor opens a cursor for use. Without opening a cursor, all calls to the JDE Cache Data Manipulating APIs will fail. When a cursor is opened, the cache is first checked to see if it contains any records. If it does then the number of cursors for this cache is checked. If the number is less than the maximum permitted, a new cursor is created and added to the JDE Cache Cursor Manager. This cursor is then assigned to be the current ACTIVE HJDECURSOR for the HCACHE.

Note. The maximum number of open cursors on any one cache is 100

Syntax

JDECM_RESULT jdeCacheOpenCursor (HCACHE hCache, HJDECURSOR * hCursor);

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache associated with hCache. Use this cursor handle used in calls to Data Manipulation APIs to reference records in the cache.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

...

/*initialize cache*/

...

/*add some records*/

...

/*open a cursor*/

if (jdeCacheOpenCursor(hCache,&hCursor)==JDECM_FAILED)

printf("Open cursor failed !\n")

...

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheTerminate.htm

jdeCacheTerminate

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheTerminate dissociates a named cache handle from the cache. This means that the passed cache handle cannot be used to access this cache anymore. This has the effect of destroying the cache being referenced by the cache handle to the calling application. If this is the jdeCacheTerminate call that matches the total number of jdeCacheInit calls, then the cache is not only disassociated from the cache handle but also physically destroyed from memory.

Note. If more than one cache handle with the same cache name is initialized, one call to this API does not terminate all of the cache handles from memory. You can terminate all of them by calling jdeCacheTerminateAll.

Syntax

JDECM_RESULT jdeCacheTerminate (HUSER hUser,HCACHE hCache)

Parameters

hUser | Input. The user handle obtained from a call to the JDB_ API. It cannot be NULL. The destroyed cache is that associated with this handle.
hCache | Output. A cache handle that uniquely identifies the cache. After jdeCacheTerminate returns, this cache cannot be accessed. You must start the caching process again to access this cache.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

if (jdeCacheInit(hUser, &hCache, szCacheName, Index)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeCacheTerminateAll.htm

jdeCacheTerminateAll

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheTerminateAll destroys all caches with the same name as the one with the given hCache. The caches are physically removed from memory.

Syntax

JDECM_RESULT jdeCacheTerminateAll (HUSER hUser, HCACHE hCache)

Parameters

hUser | Input. The user handle obtained from a call to the JDB_ API. It cannot be NULL. The destroyed caches are those associated with this handle.
hCache | Output. A cache handle that uniquely identifies the cache. After jdeCacheTerminateAll returns, these caches cannot be accessed. You must start the caching process again to access this cache.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HCACHE hCache1;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char szCacheName1[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

memset(szCacheName1,0x00,sizeof(szCacheName1));

strcpy(szCacheName,”B4321234CMCache”);

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

ndex[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

if (jdeCacheInit(hUser, &hCache, szCacheName, Index)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

...

if (jdeCacheInit(hUser, &hCache1, szCacheName1, Index)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

...

if (jdeCacheInit(hUser, &hCache, szCacheName, Index)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*do something*/

...

/*terminates all caches*/

if (jdeCacheTerminateAll(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminateAll Failed \n");


jdeCacheUpdate.htm

jdeCacheUpdate

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheUpdate updates the record that is being pointed to by the passed HJDECURSOR with the passed data. You should use a cursor manipulation API that does not advance the cursor, such as jdeCacheFetch or jdeCacheFetchPosition to position the cursor to the record to be updated before calling this API.

If the cache is not empty and the cursor is open, then the record currently being pointed to by HJDECURSOR is updated.

Syntax

JDECM_RESULT jdeCacheUpdate(HCACHE hCache, HJDECURSOR hCursor, void *lpData, long nDataSize);

Parameters

hCache | Intput. A cache handle that uniquely identifies the cache.
hCursor | Input. Use this cursor handle used in calls to Data Manipulation APIs to reference records in the cache.
lpData | Input. ndPointer structure containing the data to be used to update the cache.
nDataSize | Input. The size of the structure that is being passed with the data.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

char ret_Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 10;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

...

/*add records*/

strcpy(Data,"Testing");

strcpy(Data+10, "12345");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "67890");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

/*open a cursor*/

...

/*fetch position the cursor to the first record that has the key "Testing 67890"*/

memset(ret_Data,0x00,sizeof(ret_Data));

if (jdeCacheFetchPosition(hCache,hCursor,Data,2,ret_Data,sizeof(ret_Data))==JDECM_FAILED)

printf("Record not found\n");

/*update the located record*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,"DoneTest");

strcpy(Data+10, "45612");

if (jdeCacheUpdate(hCache,hCursor,Data,sizeof(Data))==JDECM_FAILED)

printf("jdeCacheUpdate Failed\n");

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


Cache Error Messages

JDECache Error Messages

JDECache Error Message consist of the following APIs:

CacheError Messages

  1. CAC001001

  2. CAC001002

  3. CAC001004

  4. CAC001006

  5. CAC001007

  6. CAC001008

  7. CAC001009

  8. CAC001010

  9. CAC001011

  10. CAC001012

  11. CAC001013

  12. CAC001014

  13. CAC001015

  14. CAC001016

  15. CAC001017

  16. CAC001018

  17. CAC001019

  18. CAC001020

  19. CAC001021

  20. CAC001022

  21. CAC001023

  22. CAC001024

  23. CAC001026

  24. CAC001027

  25. CAC001028

  26. CAC001029

  27. CAC001030

  28. CAC001031

  29. CAC001032

  30. CAC001033

  31. CAC001059

  32. CAC001060

  33. CAC001062

  34. CAC001063

  35. CAC001064

  36. CAC001065

  37. CAC001067

  38. CAC001069

  39. CAC001075

  40. CAC001076

  41. CAC001077

  42. CAC001078


CacheError Messages

Last Modified: B733.2 | May 25, 1999

CAC001001

Description | Allocation Failed: LISTCACHEINFO
Problem | JDE Cache failed to initialize a cache on a call jdeCacheInit or jdeCacheInitMultipleIndex
Cause | jdeCacheInit failed to allocate memory space for a cache structure
Resolution | Check the amount of RAM available to EnterpriseOne when the error occurred. Close unnecessary applications

CAC001002

Description

Cache initialization failed

Problem

JDE Cache failed to initialize a cache on a call jdeCacheInit or jdeCacheInitMultipleIndex

Cause

  • JDE Cache could not create or initialize the cache

  • This commonly occurs when there is not enough memory for the allocation for certain JDE Cache internal structures.

Resolution

  • Check the amount of RAM available to EnterpriseOne when the error occurred Close unnecessary applications

  • Check to Make sure that all the passed parameters are valid

CAC001004

Description | Cache handle insert failed.
Problem | JDE Cache failed to initialize a cache on a call jdeCacheInit or jdeCacheInitMultipleIndex.
Cause | Allocation of the memory space for the cache failed.
Resolution | Check the amount of RAM available to EnterpriseOne when the error occurred. Close unnecessary applications.

CAC001006

Description

Delete all cursors while terminating a cache failed

Problem

JDE Cache failed to terminate a cache on a call to jdeCacheTerminate

Cause

  • User passed in an invalid cache handle

  • Internally, the cache handle may be corrupted

Resolution

  • Make sure that the cache handle is valid

  • Make sure that the cache handle is properly initialized

  • Make sure that there is no value assigned to a variable that occupy larger memory space than the memory space when the variable is defined

CAC001007

Description

Cache terminated failed.

Problem

JDE Cache failed to terminate a cache on a call to jdeCacheTerminate

Cause

  • User passed in an invalid cache handle

  • Internally, the cache handle may be corrupted

Resolution

  • Make sure that the cache handle is valid

  • Make sure that the cache handle is properly initialized

  • Make sure that there is no value assigned to a variable that occupy larger memory space than the memory space when the variable is defined

CAC001008

Description

Failed to delete lpListCacheInfoFind.

Problem

JDE Cache failed to terminate a cache on a call to jdeCacheTerminate

Cause

  • The Cache handle does not contain any cache memory

  • Internally, the cache handle may be corrupt

Resolution

  • Make sure that the cache handle is valid

  • Make sure that the cache handle is properly initialized

  • Make sure that there is no value assigned to a variable that occupy larger memory space than the memory space when the variable is defined

CAC001009

Description

Delete all cursors while terminating all caches failed.

Problem

JDE Cache failed to terminate all caches on a call to jdeCacheTerminateAll

Cause

  • User passed in an invalid cache handle

  • Internally the cache handle may be corrupted

Resolution

  • Make sure that the cache handle is valid

  • Make sure that the cache handle is properly initialized

  • Make sure that there is no value assigned to a variable that occupy larger memory space than the memory space when the variable is defined

CAC001010

Description

Cache terminated all failed.

Problem

JDE Cache failed to terminate all caches on a call to jdeCacheTerminateAll

Cause

  • No cache is found in the internal cache list

  • Internally, the cache handle may be corrupted

Resolution

  • Make sure that the cache handle is valid

  • Make sure that the cache handle is properly initialized

  • Make sure that there is no value assigned to a variable that occupy larger memory space than the memory space when the variable is defined

CAC001011

Description

Cache terminated failed

Problem

JDE Cache failed to terminate all caches on a call to jdeCacheTerminateAll

Cause

  • User passed in an invalid cache handle

  • Internally, the cache handle may be corrupted

Resolution

  • Make sure that the cache handle is valid

  • Make sure that the cache handle is properly initialized

  • Make sure that there is no value assigned to a variable that occupy larger memory space than the memory space when the variable is defined

CAC001012

Description

Cache terminate all failed

Problem

JDE Cache failed to terminate all caches on a call to jdeCacheTerminateAll

Cause

  • The cache handle does not contain any cache memory

  • Internally, the cache handle may be corrupted

Resolution

  • Make sure that the cache handle is valid

  • Make sure that the cache handle is properly initialized

  • Make sure that there is no value assigned to a variable that occupy larger memory space than the memory space when the variable is defined

CAC001013

Description

Delete all cursors while terminating all caches failed.

Problem

JDE Cache failed to terminate all caches on a call to jdeCacheDestroyAllUserCaches

Cause

  • User passed in an invalid cache handle

  • The cache handle is NULL

  • Internally, the cache handle may be corrupted

Resolution

  • Make sure that the cache handle is valid

  • Make sure that the cache handle is properly initialized

  • Make sure that there is no value assigned to a variable that occupy larger memory space than the memory space when the variable is defined

CAC001014

Description

Cache clear failed

Problem

JDE Cache failed to clear cache memory on a call to jdeCacheClear

Cause

  • User passed in an invalid cache handle

  • The active cursor in the cache handle is NULL

  • The structure that contains the data of cache is NULL

  • Internally, the cache handle may be corrupted

Resolution

  • Make sure that the cache handle is valid

  • Make sure that the cache handle is properly initialized

  • Make sure that all cursors are properly opened

  • Make sure that all opened cursors are a non-NULL cursor

  • Make sure that there is no value assigned to a variable that occupy larger memory space than the memory space when the variable is defined

CAC001015

Description

  • (jdecacheResetCursor) Attempt to reset a cursor on an empty cache failed

  • (jdeCacheFetch) Attempt to fetch using a cursor from an empty cache failed

  • (jdeCacheFetchPosition) Attempt to fetch a cursor position in an empty cache failed

  • (jdeCacheUpdate) Attempt to update using a cursor on an empty cache failed

  • (jdeCacheDelete) Attempt to delete all keyed records from an empty cache failed

  • (jdeCacheDeleteAll) Attempt to delete all keyed records from an empty cache failed

Problem

  • JDE Cache failed to reset a cursor points to the first record in cache memory on a call to jdeCacheResetCursor

  • JDE Cache failed to fetch a record from cache memory on a call to jdeCacheFetch

  • JDE Cache failed to set a cursor point to the desired record in cache memory on a call to jdeCacheFetchPosition

  • JDE Cache failed to update a record in cache memory on a call to jdeCacheUpdate

  • JDE Cache failed to delete a record in cache memory on a call to jdeCacheDelete

  • JDE Cache failed to delete all records (matches the given key) in cache memory on a call to jdeCacheDeleteAll

Cause

The cache handle is an empty cache (no record is added)

Resolution

Make sure that at least one record is added into the cache memory

CAC001016

Description

(jdeCacheOpenCursor) Failed to open a new cursor

Problem

JDE Cache failed to open a new cursor on a call to jdeCacheOpenCursor

Cause

  • User passed in a NULL cache handle

  • The passed in cursor does not have a valid return address

  • The internal process failed to allocate memory space for a new cursor

Resolution

  • Make sure that the cache handle is valid

  • Make sure that the cache handle is a non-NULL handle

  • Make sure that the cache handle is properly initialized

  • Make sure that the passed in cursor handle has a valid return address

  • Check the amount of RAM available to EnterpriseOne when the error occurred. Close unnecessary applications

CAC001017

Description

(jdeCacheOpenCursor) Attempt to exceed total number of simultaneous open cursors (100) per cache failed

Problem

JDE Cache failed to open a new cursor on a call to jdeCacheOpenCursor

Cause

  • The maximum number of simultaneously opened cursors per cache supported by JDE Cache has been reached

  • The maximum number of cursors currently supported by JDE Cache is 100

Resolution

  • Make sure that all the opened cursors are closed when they are no longer used

  • Make sure that the total number of opened cursors for a cache handle is not more than 100

  • If a cache is shared by business functions, Make sure that all the cursors are opened and closed appropriately

CAC001018

Description

(jdeCacheOpenCursor) Attempt to open a JDECACHE cursor failed

Problem

JDE Cache failed to open a new cursor on a call to jdeCacheOpenCursor

Cause

  • The cache handle is invalid

  • The cursor handle does not have a valid return address

  • Allocation of memory space for the new cursor failed

Resolution

  • Make sure that the cache handle is valid

  • Make sure that the cursor has a valid return address

  • Make sure that the cache handle has at least one record in the cache memory

  • Check the amount of RAM available to EnterpriseOne when the error occurred Close unnecessary applications

CAC001019

Description

  • (jdeCacheAdd) Failed to set default cursor; Current cursor retained

  • (jdeCacheResetCursor) Invalid cursor: Reset failed

  • (jdeCacheSetDefaultCursor) Failed to set default cursor: Current cursor retained

  • (jdeCacheCloseCursor) Invalid cursor: Cursor close failed

  • (jdeCacheFetch) Invalid cursor: Fetch failed

  • (jdeCacheFetchPosition) Invalid cursor: Fetch position failed

  • (jdeCacheUpdate) Invalid cursor: Update failed

  • (jdeCacheDelete) Invalid cursor: Delete failed

  • (jdeCacheDeleteAll) Invalid cursor: Delete all keyed failed

Problem

  • JDE Cache failed to add a record to cache memory on a call to jdeCacheAdd

  • JDE Cache failed to reset cursor to the default cursor on a call to jdeCacheResetCursor

  • JDE Cache failed to set the current cursor as a default cursor on a call to jdeCacheSetDefaultCursor

  • JDE Cache failed to close a cursor on a call to jdeCacheCloseCursor

  • JDE Cache failed to fetch a record from cache memory on a call to jdeCacheFetchPosition

  • JDE Cache failed set the cursor point to the desired record on a call to jdeCacheFetchPosition

  • JDE Cache failed to update a record in cache memory on a call to jdeCacheUpdate

  • JDE Cache failed to delete a record in cache memory on a call to jdeCacheDelete

  • JDE Cache failed to delete all records, matches the given key, in cache memory on a call to jdeCacheDeleteAll

Cause

  • User passed in an invalid cursor

  • The passed in cursor is not opened

  • The passed in cursor is NULL

  • The passed in cursor was not found in the Cache Manager's cursor list

  • Programmer gave an incorrect action code

Resolution

  • Make sure that the passed in cursor is properly opened

  • Make sure that the passed in cursor is a non-NULL cursor

  • Make sure that the passed in cursor is the right cursor for the cache

  • Programmed needs to Make sure the action code is defined

CAC001020

Description

(jdeCacheCloseCursor) Cursor delete failed

Problem

JDE Cache failed to close a cursor in a cache handle on a call to jdeCacheCloseCursor

Cause

  • User passed an invalid cache handle

  • The cache handle contains invalid cursor handles

  • User passed in an invalid cursor

  • The passed in cursor is not found in the internal cache cursor list

Resolution

  • Make sure that the cache handle is valid

  • Make sure that the cache handle is a non-NULL handle

  • Make sure that all cursors are properly opened

  • Make sure that the active cursor is not closed

  • Make sure that the passed in cache handle and cursor handle are matched

CAC001021

Description

(jdeCacheResetCursor) Attempt to reset a JDECACHE cursor failed

Problem

JDE Cache failed to reset a cursor point to the first record in cache memory on a call to jdeCacheResetCursor

Cause

  • User passed in an invalid cache handle

  • The cache may be empty (no record added)

  • Internally, the cursor does not have a valid return address

Resolution

  • Make sure that the cache handle is valid

  • Make sure that the cache handle is a non-NULL handle

  • Make sure that the cache handle is properly initialized

  • Make sure that the cache handle at least has a record added

  • Programmer needs to Make sure that the internal cursor handle has a valid return address.

CAC001022

Description

(jdeCacheFetch) Invalid Pointer: jdeCacheFetch has been passed a null pointer instead of a valid pointer to the returned data

Problem

JDE Cache failed to fetch a record from cache memory on a call to jdeCacheFetch

Cause

User passed in a data pointer that does not have a valid return address

Resolution

  • Make sure that the data pointer does not have NULL as the return address

  • Make sure that the data pointer has a valid return address

CAC001023

Description

  • (jdeCacheFetch) Invalid cursor (Cursor handle = NULL): Fetch failed

  • (jdeCacheFetchPosition) Invalid cursor (Cursor handle = NULL): Fetch position failed

  • (jdeCacheUpdate) Invalid cursor (Cursor handle = NULL): Update failed

  • (jdeCacheDelete) Invalid cursor (Cursor handle = NULL): Delete failed

  • (jdeCacheDeleteAll) Invalid cursor (Cursor handle = NULL): Delete all keyed failed

  • (jdeCacheCloseCursor) Invalid cursor (Cursor handle = NULL): Cursor close failed

Problem

  • JDE Cache failed to fetch a record from cache memory on a call to jdeCacheFetch

  • JDE Cache failed to set a cursor point to a desired record cache memory on a call to jdeCacheFetchPosition

  • JDE Cache failed to update a record in cache memory on a call to jdeCacheUpdate

  • JDE Cache failed to delete a record in cache memory on a call to jdeCacheDelete

  • JDE Cache failed to delete all records, that is matches the given key, in cache memory on a call to jdeCacheDeleteAll

  • JDE Cache failed to close a cursor in a cache on a call to jdeCacheCloseCursor

Cause

User passed in a data pointer that does not have a valid return address

Resolution

  • Make sure that the data pointer does not have NULL as a return address

  • Make sure that the data pointer has a valid return address

CAC001024

Description

(jdeCacheCloseCursor) Cursor close failed

Problem

JDE Cache failed to close a cursor in a cache on a call to jdeCacheCloseCursor

Cause

  • User passed in an invalid cursor handle

  • The passed in cursor is not opened

  • The passed in cursor handle is NULL

Resolution

  • Make sure that the cursor handle is valid

  • Make sure that the cursor handle is opened properly

  • Make sure that the cursor handle is a non-NULL handle

CAC001026

Description

  • (jdeCacheFetch) Attempt to fetch a record with a closed cursor failed

  • (jdeCacheFetchPosition) Attempt to fetch a record position with a closed cursor failed

  • (jdeCacheUpdate) Attempt to update with a closed cursor failed

  • (jdeCacheDelete) Attempt to delete a record with a closed cursor failed

  • (jdeCacheDeleteAll) Attempt to delete all keyed records with a closed cursor failed

Problem

  • JDE Cache failed to fetch a record from cache memory on a call to jdeCacheFetch

  • JDE Cache failed to set a cursor points to a desired record in cache memory on a call to jdeCacheFetchPosition

  • JDE Cache failed to update a record in cache memory on a call to jdeCacheUpdate

  • JDE Cache failed to delete a record in cache memory on a call to jdeCacheDelete

  • JDE Cache failed to delete all records, that are matching the given key, in cache memory on a call to jdeCacheDeleteAll

Cause

User tried to use a cursor that had already been closed

Resolution

Make sure that the cursors that you want to use are not closed

CAC001027

Description

(jdeCacheUpdate) Invalid Pointer: jdeCacheUpdate has been passed a null pointer instead of a valid pointer to the update data

Problem

JDE Cache failed to delete all records, that are matching the given key, in cache memory on a call to jdeCacheDeleteAll

Cause

  • User passed in an empty data pointer

  • The data pointer is NULL

Resolution

  • Make sure that the data pointer is not NULL

  • Make sure that the data pointer points to a non-empty record

CAC001028

Description | (jdeCacheFetchPosition) Set position failed
Problem | JDE Cache failed to set a cursor point to a desired record in cache memory on a call to jdeCacheFetchPosition
Cause | Allocate memory space for the fetch position key failed
Resolution | Check the amount of RAM available to EnterpriseOne when the error occurred Close unnecessary applications

CAC001029

Description | (jdeCacheFetchPosition) Attempting to access a cache with more keys than defined in jdeCacheInit
Problem | JDE Cache failed to set a cursor points to a desired record in cache memory on a call to jdeCacheFetchPosition
Cause | User passed in a key that has more fields than the number of fields defined in jdeCacheInit or jdeCacheInitMultipleIndex
Resolution | Make sure that they key data has less than or equal to the number of fields defined in jdeCacheInit or jdeCacheInitMultipleIndex

CAC001030

Description

(jdeCacheFetchPosition) Invalid Pointer: JdeCacheFetchPosition has been passed a null pointer instead of a valid pointer to the returned data

Problem

JDE Cache failed to set a cursor points to a desired record in cache memory on a call to jdeCacheFetchPosition

Cause

  • User passed in an invalid data pointer

  • The key data pointer returned address in NULL

Resolution

  • Make sure that the data pointer points to a valid return address

  • Make sure that the data pointer is not a NULL pointer

CAC001031

Description

(jdeCacheFetchPosition) Invalid Pointer: jdeCacheFetchPosition has been passed as a NULL pointer instead of a valid pointer to the key data

Problem

JDE Cache failed to set a cursor points to a desired record in cache memory on a call to jdeCacheFetchPosition

Cause

  • User passed in an empty key

  • The Key pointer is NULL

Resolution

  • Make sure that the key pointer points to a non-empty record

  • Make sure that the key pointer points to a non-NULL record

CAC001032

Description | (jdeCacheDeleteAll) Attempting to access a cache with more keys than defined in jdeCacheInit
Problem | JDE Cache failed to delete a record in cache memory on a call to jdeCacheDeleteAll
Cause | User passed in a key that has more fields than the number of fields defined in jdeCacheInit or jdeCacheInitMultipleIndex
Resolution | Make sure that the key data has less than or equal to the number of fields defined jdeCacheInit or jdeCacheInitMultipleIndex

CAC001033

Description

(jdeCacheDeleteAll) Invalid Pointer: jdeCacheDeleteAll has been passed as a NULL pointer instead of a valid pointer to the key data

Problem

JDE Cache failed to delete a record in cache memory on a call to jdeCacheDeleteAll

Cause

  • User passed in an empty data pointer

  • The data pointer is NULL

Resolution

  • Make sure that the data pointer is not NULL

  • Make sure that the data pointer is point to a non-empty record

CAC001059

Description

Invalid user handle

Problem

JDE Cache failed to initialize a cache on a call jdeCacheInit or jdeCacheInitMultipleIndex

Cause

  • The passed user handle is NULL

  • The passed user handle is not initialized

Resolution

  • Make sure that the passed user handle is a non-NULL handle

  • Make sure that the passe user handle is properly initialized

CAC001060

Description

Invalid environment handle

Problem

JDE Cache failed to initialize a cache on a call jdeCacheInit or jdeCacheInitMultipleIndex

Cause

  • The passed user handle contains a NULL environment handle

  • The passed user handle contains an environment handle that is not initialized

Resolution

  • Make sure that the passed in user handle has a non_NULL environment handle

  • Make sure that the passed user handle has a properly initialize environment handle

CAC001062

Description

Invalid cache handle address

Problem

JDE Cache failed to initialize a cache on a call jdeCacheInit or jdeCacheInitMultipleIndex

Cause

  • The passed cache handle has an invalid address

  • The passed cache handle has no return address

  • The passed cache handle has a NULL as a return address

Resolution

  • Make sure that the passed cache handle is valid

  • Make sure that the passed cache handle has a return address

CAC001063

Description | Invalid index
Problem | JDE Cache failed to initialize a cache on a call jdeCacheInit or jdeCacheInitMultipleIndex
Cause | The passed index is NULL
Resolution | Make sure that the passed index is a non-NULL index

CAC001064

Description

Invalid cache name

Problem

JDE Cache failed to initialize a cache on a call jdeCacheInit or jdeCacheInitMultipleIndex

Cause

  • JDE Cache could not create and initialize the cache because the cache name is invalid

  • The cache name is either an empty string or is more than 45 characters

Resolution

  • Check and Make sure that the cache name is not an empty string

  • Check and Make sure that the cache name has less than or equal to 45 characters

CAC001065

Description

(jdeCacheSetIndex) Attempt to set cache index ID failed. Invalid cache or cursor

Problem

JDE Cache failed to set an index ID for a cursor on a call to jdeCacheSetIndex

Cause

  • User passed an invalid cache handle

  • User passed an invalid cursor handle

  • The index ID is invalid

Resolution

  • Make sure that the cache handle, cursor handle, and index ID is valid

  • Make sure that all index IDs in cache are properly initialized

CAC001067

Description

(jdeCacheOpenCursor) Attempt to assign index ID failed

Problem

JDE Cache failed to open a new cursor on a call to jdeCacheOpenCursor

Cause

  • The cache handle is invalid

  • The cursor handle is invalid

  • The action code is incorrect (internal problem)

Resolution

  • Make sure that the cache handle is valid

  • Make sure that the cursor handle is valid

  • Make sure that the cache handle is a non-NULL handle

  • Make sure that the cursor handle is a non-NULL handle

  • Make sure that all cursors are opened properly

  • Programmer needs to Make sure that the action is correct

CAC001069

Description

Setting primary index failed

Problem

JDE Cache failed to initialize a cache on a call to jdeCacheInit or jdeCacheInitMultipleIndex

Cause

  • User passed in an invalid cache handle

  • The smallest index ID in the cache is a negative number

Resolution

  • Make sure that the passed cache handle is valid

  • Make sure that all index IDs are non-negative numbers

CAC001075

Description

Invalid cache registry

Problem

JDE Cache failed to initialize a cache on a call to jdeCacheInit or jdeCacheInitMultipleIndex

Cause

The user handle contains an environment handle that has a NULL cache list

Resolution

  • Make sure that the passed user handle is a valid handle

  • Make sure that the passed user handle has a valid environment handle

  • Make sure that the passed user handle is properly initialized

  • Make sure that the passed user handle has an environment handle that is properly initialized

CAC001076

Description

Initialization error. Mixed init types

Problem

JDE Cache failed to initialize a cache on a call to jdeCacheInit or jdeCacheInitMultipleIndex

Cause

  • User tried to re-initialize a multiple index cache handle using the existing single index cache name

  • User tried to re-initialize a single index cache handle using the existing multiple index cache name

Resolution

Make sure that the types of caches are unified

CAC001077

Description | Initialization error. Re-initializing with incorrect segment number
Problem | JDE Cache failed to initialize a cache on a call to jdeCacheInit or jdeCacheInitMultipleIndex
Cause | User tried to initialize a cache handle using the existing cache name but the number of the segment in the index structure is different than the default cache handle
Resolution | Make sure that the structure of the index is identical to the structure of the index in the default cache handle

CAC001078

Description | Initialization error. Re-initializing with incorrect offset, data size, or data type
Problem | JDE Cache failed to initialize a cache on a call to jdeCacheInit or jdeCacheInitMultipleIndex
Cause | User tried to initialize a cache handle using the existing cache name but the offset, data size, or data type in the CacheKey is not matching to the default cache handle's index structure
Resolution | Make sure that the structure of the index is identical to the structure of the index in the default cache handle


AddGenericTextName

Last Modified: B733.1 | January 26, 1999

AddGenericTextName adds generic text to the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI AddGenericTextName(HREQUEST hRequest,PJSTR pObjectName, LPVOID pKey, PJSTR pText)

Parameters

Parameter | Notes | Usage
HREQUEST hRequest | Handle to the F00165 TABLE request |
PJSTR pObjectName | Pointer to the name of the generic text object | For example, "ABGT"
LPVOID pKey | Pointer to the key of the generic text object |
PJSTR pText | Text to be inserted |

Return Value

Return Value | Description
JDB_PASSED | Return value if this succeeds
JDB_FAILED | Return value if this fails


AllocBuildStrFromDstmplName

Last Modified: Xe June 3, 2002

AllocBuildStrFromDstmplName will build the string formatted data from the data structure name and the data structure passed in.

Syntax

LPSTR JDECALLBACK AllocBuildStrFromDstmplName (LPDSTMPL lpDsTmplIn,

NID szDsTmpl,

LPVOID lpDs);

Parameters

Parameter | Notes | Usage
lpDSTmplIn | Input | Data structure template. Can be NULL.
szDsTmpl | Input | Structure name. Required
lpDS | Input | Data structure with data loaded. Required

Return Value

Return value will be a formatted string with the data from lpDS. This formatted string will have | as the separator between parameter of the lpDS.

Example

LPSTR pStringKey = NULL;

DSABGT dsAbGT = {0};

LPF0016D lpDetail = NULL;

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

ParseNumericString(&dsAbGT.mnAddressNumber, “1”);

pStringKey = AllocBuildStrFromDstmplName(NULL, "ABGT", &dsAbGT);

pStringKey = StripKey (pStringKey);

JDBReturn = JDEGTAllocFetch (lpBhvrCom->hEnv, (LPCSTR)"ABGT",

(LPCSTR)pStringKey, (LPCSTR) “ “, &lpDetail);

if (JDBReturn != JDEDB_PASSED)

{

...

…

JDBReturn = JDEGTAdd( lpBhvrCom->hEnv, lpDetail, (LPDBREF)NULL);

}

JDEGTFree ((LPF9860)NULL, lpDetail);

FreeStrFromDstmpl(pStringKey);

Additional Notes

1. FreeStrFromDstmpl() must be called to free the memory allocated by AllocBuildStrFromDstmplName().

2. JDEGTFree() must be called to free LPF0016D memory allocated by JDEGTAllocFetch().

See Also

1. JDEGTAllocFetch()

2. JDEGTFree()

3. JDEGTExists()

4. JDEGTAdd()

5. JDEGTAddRecord()

6. JDEGTUpdate()

7. JDEGTDelete()

8. JDEGTAllocFetchText()

9. JDEGTTextFree()


CopyGenericTextName

Last Modified: B733.1 | February 23, 1999

CopyGenericTextName copies the generic text from the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI CopyGenericTextName (PJSTR pSrcObjName,

LPVOID pSrcKey, PJSTR pDestObjName, LPVOID pDestKey )

Parameters

Parameter | Notes | Usage
PJSTR pSrcObjName | Name of the source generic text object | For example, "ABGT"
LPVOID pSrcKey | Key for the source generic text object |
PJSTR pDestObjName | Name of the destination generic text object | For example, "ABGT"
LPVOID pDestKey | Key for the destination generic text object |

Return Value

Return Value | Description
JDB_PASSED | Return value if this succeeds
JDB_FAILED | Return value if this fails


DeleteGenericTextName

Last Modified: B733.1 | January 26, 1999

DeleteGenericTextName deletes the generic text in the F00165 table.

Syntax

JDERTN (JDEDB_RESULT) JDEWINAPI DeleteGenericTextName (PJSTR pObjectName, LPVOID pKey)

Parameters

Parameter | Notes | Usage
PJSTR pObjectName | Name of the generic text object | For example, "ABGT"
LPVOID pKey | Pointer to the generic text key |

Return Value

Return Value | Description
JDB_PASSED | Return value if this succeeds
JDB_FAILED | Return value if this fails


FreeStrFromDstmpl

Last Modified: Xe June 3, 2002

FreeStrFromDstmpl will free the allocated memory of the string.

Syntax

void JDECALLBACK FreeStrFromDstmpl(LPSTR lpszStr)

Parameters

Parameter | Notes | Usage
lpszStr | Input | Pointer to allocated memory for string.

Return Value

Example

LPSTR pStringKey = NULL;

DSABGT dsAbGT = {0};

LPF0016D lpDetail = NULL;

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

ParseNumericString(&dsAbGT.mnAddressNumber, “1”);

pStringKey = AllocBuildStrFromDstmplName(NULL, "ABGT", &dsAbGT);

pStringKey = StripKey (pStringKey);

JDBReturn = JDEGTAllocFetch (lpBhvrCom->hEnv, (LPCSTR)"ABGT",

(LPCSTR)pStringKey, (LPCSTR) “ “, &lpDetail);

if (JDBReturn != JDEDB_PASSED)

{

...

…

JDBReturn = JDEGTAdd( lpBhvrCom->hEnv, lpDetail, (LPDBREF)NULL);

}

JDEGTFree ((LPF9860)NULL, lpDetail);

FreeStrFromDstmpl(pStringKey);

Additional Notes

1. FreeStrFromDstmpl() must be called to free the memory allocated by AllocBuildStrFromDstmplName().

2. JDEGTFree() must be called to free LPF0016D memory allocated by JDEGTAllocFetch().

See Also

1. JDEGTAllocFetch()

2. JDEGTFree()

3. JDEGTExists()

4. JDEGTAdd()

5. JDEGTAddRecord()

6. JDEGTUpdate()

7. JDEGTDelete()

8. JDEGTAllocFetchText()

9. JDEGTTextFree()


GetAllGenericTextName

Last Modified: Xe | May 28, 2002

GetAllGenericTextName will retrieve the default text data from media object table.

Syntax

JDERTN(LPSTR) JDEWINAPI GetAllGenericTextName(LPSTR pObjectName,

LPVOID pKey,

BOOL bConvert)

Parameters

Parameter | Notes | Usage
pObjectName | Input | GT Structure Name
pKey | Input | GT Structure with Data
bConvert | Input | TRUE = Convert RTF to plain text FALSE = Leave RTF text as is

Return Value

Memory allocated string containing text data from Media Object.

Example

DSABGT dsAbGT = {0};

LPSTR pTextStr = NULL;

ParseNumericString(&dsAbGT.mnAddressNumber, “1”);

pTextStr = GetAlGenericTextName ( “ABGT”, &dsAbGT, TRUE );

if (pTextStr)

{

JDEGTTextFree(pTextStr);

}

Additional Notes

1. FreeBuildStrFromDstmplName() must be called to free the memory allocated by AllocBuildStrFromDstmplName().

2. JDEGTFree() must be called to free LPF0016D memory allocated by JDEGTAllocFetch().

3. JDEGTTextFree() must be called to free the memory allocated string.

See Also

1. JDEGTAllocFetch()

2. JDEGTFree()

3. JDEGTExists()

4. JDEGTAdd()

5. JDEGTAddRecord()

6. JDEGTUpdate()

7. JDEGTDelete()

8. JDEGTAllocFetchText()

9. JDEGTTextFree()


GetGenericTextName

Last Modified: B733.1 | September 28, 1999

GetGenericTextName gets generic text from the F00165 table.

Syntax

JDERTN (PJSTR) JDEWINAPI GetGenericTextNameEx(HENV hEnv, PJSTR pObjectName, LPVOID pKey,

BOOL bConvert, BOOL bAllText)

Parameters

Parameter | Notes | Usage
HENV hEnv |  |
PJSTR pObjectName | Pointer to the generic text object name | For Example, "ABGT"
LPVOID pKey | Pointer to the key of the generic text object |
BOOL bConvert | Flag indicating whether to convert from RTF to text or not | usage (tab to add more rows)
BOOL bAllText |  |

Return Value

Return Value | Description
Pointer to a text string |

Additional Notes

The pointer returned by the API has to be freed by the API jdeTextFree.


JDEGTAdd

Last Modified: Xe | May 28, 2002

JDEGTAdd will add the record in Media Object Table, F00165, exists based on GT Structure Name and generic text key.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI JDEGTAdd(

HENV hEnv,

LPF0016D pdsF0016D,

LPDBREF pDbRef )

Parameters

Parameter | Notes | Usage
hEnv | Input | Pointer to the environment which the hUser will be retrieved.
pdsF0016D | Input | Structure storing the keys and blob to be added.
pDbRef | Input | Not used

Return Value

JDEDB_RESULT:

JDEDB_PASSED = Record inserts successfully

JDEDB_FAILED = Record fails to insert.

Example

LPSTR pStringKey = NULL;

DSABGT dsAbGT = {0};

LPF0016D lpDetail = NULL;

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

BOOL bMOExist = FALSE

ParseNumericString(&dsAbGT.mnAddressNumber, “1”);

pStringKey = AllocBuildStrFromDstmplName(NULL, "ABGT", &dsAbGT);

pStringKey = StripKey (pStringKey);

bMOExist = JDEGTExists(lpBhvrCom->hEnv, (LPCSTR)"ABGT",

(LPCSTR)pStringKey, (LPCSTR) “ “);

if (!bMOExist)

{

FreeBuildStrFromDstmplName(pStringKey);

return ER_ERROR;

}

JDBReturn = JDEGTAllocFetch (lpBhvrCom->hEnv, (LPCSTR)"ABGT",

(LPCSTR)pStringKey, (LPCSTR) “ “, &lpDetail);

if (JDBReturn != JDEDB_PASSED)

{

...

…

JDBReturn = JDEGTAdd( lpBhvrCom->hEnv, lpDetail, (LPDBREF)NULL);

}

JDEGTFree ((LPF9860)NULL, lpDetail);

FreeBuildStrFromDstmplName(pStringKey);

Additional Notes

1. FreeBuildStrFromDstmplName() must be called to free the memory allocated by AllocBuildStrFromDstmplName().

2. JDEGTFree() must be called to free LPF0016D memory allocated by JDEGTAllocFetch().

See Also

1. JDEGTAllocFetch()

2. JDEGTFree()

3. JDEGTExists()

4. JDEGTAdd()

5. JDEGTAddRecord()

6. JDEGTUpdate()

7. JDEGTDelete()

8. JDEGTAllocFetchText()

9. JDEGTTextFree()


JDEGTAddRecord

Last Modified: Xe | May 28, 2002

JDEGTAddRecord will add the record in Media Object Table, F00165, exists based on GT Structure Name and generic text key.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI JDEGTAddRecord(HREQUEST hRequest,

LPSTR pText,

KEY1_F0016D *pdsKey,

LPF0016D pdsF0016D)

Parameters

Parameter | Notes | Usage
hRequest | Input | Pointer to F00165 table handle.
pText | Input | String data to generict text. If NULL, pdsF0016D is required.
pdsKey | Input | Pointer to F0016D keys structure. This cannot be NULL.
pdsF0016D | Input | Pointer to F0016D data structure to be added to F00165. If NULL, pText is required.

Return Value

JDEDB_RESULT:

JDEDB_PASSED = Record inserts successfully

JDEDB_FAILED = Record fails to insert.

Example

LPSTR pStringKey = NULL;

DSABGT dsAbGT = {0};

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

KEY1_F0016D dsKey1 = {0};

HREQUREST hRequest = NULL;

MATH_NUMERIC mnOne = {0};

char szText[51] = “Test Text ”

int i=0;

/* Open Table of F00165 to get the hRequest */

…

…

ParseNumericString(&mnOne, “1”);

ParseNumericString(&dsAbGT.mnAddressNumber, “0”);

for (i=1; i<4; i++)

{

MathAdd(&dsAbGT.mnAddressNumber, &mnOne);

pStringKey = AllocBuildStrFromDstmplName(NULL, "ABGT", &dsAbGT);

pStringKey = StripKey (pStringKey);

strcpy(dsKey1.gdobnm, “ABGT”);

strcpy(dsKey1.gdtxky, pStringKey);

strncat(szText, pStringKey, 50);

JDBReturn = JDEGTAddRecord( hRequest, szText, &dsKey1, NULL);

FreeBuildStrFromDstmplName(pStringKey);

}

JDB_CloseTable (hRequest);

Additional Notes

1. FreeBuildStrFromDstmplName() must be called to free the memory allocated by AllocBuildStrFromDstmplName().

2. JDEGTFree() must be called to free LPF0016D memory allocated by JDEGTAllocFetch().

See Also

1. JDEGTAllocFetch()

2. JDEGTFree()

3. JDEGTExists()

4. JDEGTAdd()

5. JDEGTAddRecord()

6. JDEGTUpdate()

7. JDEGTDelete()

8. JDEGTAllocFetchText()

9. JDEGTTextFree()


JDEGTAllocFetch

Last Modified: Xe | May 28, 2002

JDEGTAllocFetch retrieves media object record from F00165 table based on GT structure name and generic text key data.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI JDEGTAllocFetch(

HENV hEnv,

LPCSTR pMemoId,

LPCSTR pdsKey,

LPCSTR pLang,

LPF0016D * ppdsF0016D )

Parameters

Parameter | Notes | Usage
hEnv | Input | hEnv is used to retrieve hUser. hEnv can be access from lpBhvrCom
pMemoId | Input | GT Structure name
pdsKey | Input | GT Keys in string format (generic text key)
pLang | Input | Must be blank
ppdsF0016D | Output | Allocated memory of F00165 record. The blob in F00165 will contain all the media object data.

Return Value

JDEDB_RESULT:

· JDEDB_PASSED

· JDEDB_FAILED

Example

LPSTR pStringKey = NULL;

DSABGT dsAbGT = {0};

LPF0016D lpDetail = NULL;

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

ParseNumericString(&dsAbGT.mnAddressNumber, “1”);

pStringKey = AllocBuildStrFromDstmplName(NULL, "ABGT", &dsAbGT);

pStringKey = StripKey (pStringKey);

JDBReturn = JDEGTAllocFetch (lpBhvrCom->hEnv, (LPCSTR)"ABGT",

(LPCSTR)pStringKey, (LPCSTR) “ “, &lpDetail);

if (JDBReturn != JDEDB_PASSED)

{

...

…

JDBReturn = JDEGTAdd( lpBhvrCom->hEnv, lpDetail, (LPDBREF)NULL);

}

JDEGTFree ((LPF9860)NULL, lpDetail);

FreeBuildStrFromDstmplName(pStringKey);

Additional Notes

1. FreeBuildStrFromDstmplName() must be called to free the memory allocated by AllocBuildStrFromDstmplName().

2. JDEGTFree() must be called to free LPF0016D memory allocated by JDEGTAllocFetch().

See Also

1. JDEGTAllocFetch()

2. JDEGTFree()

3. JDEGTExists()

4. JDEGTAdd()

5. JDEGTAddRecord()

6. JDEGTUpdate()

7. JDEGTDelete()

8. JDEGTAllocFetchText()

9. JDEGTTextFree()


JDEGTAllocFetchText

Last Modified: Xe | May 28, 2002

JDEGTAllocFetchText will retrieve the text data from in Media Object Table, F00165, exists based on GT Structure Name and generic text key.

Syntax

JDERTN(LPSTR) JDEWINAPI JDEGTAllocFetchText(LPSTR pObjectName,

LPVOID pKey,

BOOL bConvert)

Parameters

Parameter | Notes | Usage
pObjectName | Input | GT Structure Name
pKey | Input | Pointer to GT Structure with data loaded.
bConvert | Input | TRUE = Convert RTF text to plain Text FALSE = leave RTF text as is.

Return Value

Memory allocated string.

Example

DSABGT dsAbGT = {0};

LPSTR lpText = NULL;

ParseNumericString(&dsAbGT.mnAddressNumber, “1”);

lpText = JDEGTAllocFetchText( “ABGT”, &dsAbGT, TRUE);

if (lpText)

{

JDEGTTextFree(lpText);

}

Additional Notes

1. FreeBuildStrFromDstmplName() must be called to free the memory allocated by AllocBuildStrFromDstmplName().

2. JDEGTFree() must be called to free LPF0016D memory allocated by JDEGTAllocFetch().

3. JDETextFree() must be called to free the text memory allocated by JDEGTAllocFetchText().

See Also

1. JDEGTAllocFetch()

2. JDEGTFree()

3. JDEGTExists()

4. JDEGTAdd()

5. JDEGTAddRecord()

6. JDEGTUpdate()

7. JDEGTDelete()

8. JDEGTAllocFetchText()

9. JDEGTTextFree()


JDEGTDelete

Last Modified: Xe | May 28, 2002

JDEGTDelete will delete record from in Media Object Table, F00165, exists based on GT Structure Name and generic text key.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI JDEGTDelete(

HENV hEnv,

LPCSTR pMemoId,

LPCSTR pdsKey,

LPCSTR pLang )

Parameters

Parameter | Notes | Usage
hRequest | Input | Pointer to F00165 table handle.
pMemoID | Input | GT Structure Name
pdsKey | Input | F0016D keys structure in string format.
pLang | Input | Not Used

Return Value

JDEDB_RESULT:

JDEDB_PASSED = Record deletes successfully

JDEDB_FAILED = Record fails to delete.

Example

LPSTR pStringKey = NULL;

DSABGT dsAbGT = {0};

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

BOOL bMOExist = FALSE

KEY1_F0016D dsKey1 = {0};

ParseNumericString(&dsAbGT.mnAddressNumber, “1”);

pStringKey = AllocBuildStrFromDstmplName(NULL, "ABGT", &dsAbGT);

pStringKey = StripKey (pStringKey);

bMOExist = JDEGTExists(lpBhvrCom->hEnv, (LPCSTR)"ABGT",

(LPCSTR)pStringKey, (LPCSTR) “ “);

if (!bMOExist)

{

FreeBuildStrFromDstmplName(pStringKey);

return ER_SUCCESS;

}

 JDBReturn = JDEGTDelete(
lpBhvrCom->hEnv, “ABGT”, pStringKey, “
“);

FreeBuildStrFromDstmplName(pStringKey);

Additional Notes

1. FreeBuildStrFromDstmplName() must be called to free the memory allocated by AllocBuildStrFromDstmplName().

2. JDEGTFree() must be called to free LPF0016D memory allocated by JDEGTAllocFetch().

See Also

1. JDEGTAllocFetch()

2. JDEGTFree()

3. JDEGTExists()

4. JDEGTAdd()

5. JDEGTAddRecord()

6. JDEGTUpdate()

7. JDEGTDelete()

8. JDEGTAllocFetchText()

9. JDEGTTextFree()


jdeGTCopyRecord

Last Modified: B733.1 | March 02, 1999

jdeGTCopyRecord copies the entire media object record from the source key to the destination key. This API can only be called from the client.

Syntax

BOOL jdeGTCopyRecord( LPBHVRCOM lpBhvrComm,

LPCTSTR szDSNameSource,

LPVOID pDSKeySource,

LPCTSTR szDSNameDest,

LPVOID pDSKeyDest);

Parameters

Parameter | Notes | Usage
lpBhvrComm | Pointer to BehaviorComm |
szDSNameSource | Name of the source generic text object | For example, "ABGT"
pDSKeySource | Key for the source generic text object |
szDSNameDest | Name of the destination generic text object | For example, "ABGT"
pDestKey | Key for the destination generic text object |

Return Value

Return Value | Description
TRUE | It was successful
FALSE | It was not successful

Additional Notes

The existing CopyGenericTextName API only copies the text portion of the source generic text object into the destination. This API will copy all the media objects from the source generic text object to the destination generic text object.

See Also

  1. CopyGenericTextName


JDEGTExists

Last Modified: Xe | May 28, 2002

JDEGTExists verifies if the record in Media Object Table, F00165, exists based on GT Structure Name and generic text key.

Syntax

JDERTN(BOOL) JDEWINAPI JDEGTExists(

HENV hEnv,

LPCSTR pMemoId,

LPCSTR pdsKey,

LPCSTR pLang )

Parameters

Parameter | Notes | Usage
hEnv | Input | Pointer to the environment which the hUser will be retrieved.
pMemoID | Input | String pointer to GT structure Name.
pdsKey | Input | String pointer to Generic Text key.
pLang | Input | String pointer to language code (not used)

Return Value

TRUE = Record Found

FALSE = Record not Found

Example

LPSTR pStringKey = NULL;

DSABGT dsAbGT = {0};

LPF0016D lpDetail = NULL;

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

BOOL bMOExist = FALSE

ParseNumericString(&dsAbGT.mnAddressNumber, “1”);

pStringKey = AllocBuildStrFromDstmplName(NULL, "ABGT", &dsAbGT);

pStringKey = StripKey (pStringKey);

bMOExist = JDEGTExists(lpBhvrCom->hEnv, (LPCSTR)"ABGT",

(LPCSTR)pStringKey, (LPCSTR) “ “);

if (!bMOExist)

{

FreeBuildStrFromDstmplName(pStringKey);

return ER_ERROR;

}

JDBReturn = JDEGTAllocFetch (lpBhvrCom->hEnv, (LPCSTR)"ABGT",

(LPCSTR)pStringKey, (LPCSTR) “ “, &lpDetail);

if (JDBReturn != JDEDB_PASSED)

{

...

…

JDBReturn = JDEGTAdd( lpBhvrCom->hEnv, lpDetail, (LPDBREF)NULL);

}

JDEGTFree ((LPF9860)NULL, lpDetail);

FreeBuildStrFromDstmplName(pStringKey);

Additional Notes

1. FreeBuildStrFromDstmplName() must be called to free the memory allocated by AllocBuildStrFromDstmplName().

2. JDEGTFree() must be called to free LPF0016D memory allocated by JDEGTAllocFetch().

See Also

1. JDEGTAllocFetch()

2. JDEGTFree()

3. JDEGTExists()

4. JDEGTAdd()

5. JDEGTAddRecord()

6. JDEGTUpdate()

7. JDEGTDelete()

8. JDEGTAllocFetchText()

9. JDEGTTextFree()


JDEGTFree

Last Modified: Xe | May 28, 2002

JDEGTFree will free memory allocated for LPF9860 and LPF0016D. If pointer to F0016D is send, the JDEGTFree will also free the blob memory pointer exists within F0016D structure.

Syntax

JDERTN(void) JDEWINAPI JDEGTFree(

LPF9860 pdsF9860,

LPF0016D pdsF0016D )

Parameters

Parameter | Notes | Usage
pdsF9860 | Input | Pointer to F9860 Data structure. NULL can be passed in.
pdsF0016D | Input | Pointer to F0016D Data structure. NULL can be passed in

Return Value

Example

LPSTR pStringKey = NULL;

DSABGT dsAbGT = {0};

LPF00165D lpDetail = NULL;

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

ParseNumericString(&dsAbGT.mnAddressNumber, “1”);

pStringKey = AllocBuildStrFromDstmplName(NULL, "ABGT", &dsAbGT);

pStringKey = StripKey (pStringKey);

JDBReturn = JDEGTAllocFetch (lpBhvrCom->hEnv, (LPCSTR)"ABGT",

(LPCSTR)pStringKey, (LPCSTR) “ “, &lpDetail);

if (JDBReturn != JDEDB_PASSED)

{

...

…

JDBReturn = JDEGTAdd( lpBhvrCom->hEnv, lpDetail, (LPDBREF)NULL);

}

JDEGTFree ((LPF9860)NULL, lpDetail);

FreeBuildStrFromDstmplName(pStringKey);

Additional Notes

1. FreeBuildStrFromDstmplName() must be called to free the memory allocated by AllocBuildStrFromDstmplName().

2. JDEGTFree() must be called to free LPF0016D memory allocated by JDEGTAllocFetch().

See Also

1. JDEGTAllocFetch()

2. JDEGTFree()

3. JDEGTExists()

4. JDEGTAdd()

5. JDEGTAddRecord()

6. JDEGTUpdate()

7. JDEGTDelete()

8. JDEGTAllocFetchText()

9. JDEGTTextFree()


JDEGTMOExists

Last Modified: Xe | May 28, 2002

JDEGTMOExists will verify if certain type of Media Object exists within the BLOB.

Syntax

JDERTN(BOOL) JDEWINAPI JDEGTMOExists(

LPMOBLOB pmoBlob,

MOTYPE moType )

Parameters

Parameter | Notes | Usage
pmoBlob | Input | Blob Data
moType | Input | Media Object Type: OBJ_RTFTEXT OBJ_JDEIMAGE OBJ_JDEOLE OBJ_MISCJDESHORTCUT OBJ_MISCIMAGEVENDOR OBJ_MISCHTML

Return Value

Example

LPSTR pStringKey = NULL;

DSABGT dsAbGT = {0};

LPF00165D lpDetail = NULL;

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMOBLOB pMoBlob = NULL;

int nMOTypeExist[6] = {0};

ParseNumericString(&dsAbGT.mnAddressNumber, “1”);

pStringKey = AllocBuildStrFromDstmplName(NULL, "ABGT", &dsAbGT);

pStringKey = StripKey (pStringKey);

JDBReturn = JDEGTAllocFetch (lpBhvrCom->hEnv, (LPCSTR)"ABGT",

(LPCSTR)pStringKey, (LPCSTR) “ “, &lpDetail);

if (JDBReturn == JDEDB_PASSED)

{

pMoBlob = (LPMOBLOB)F0016DetailRecord->gdtxft.lpValue;

if(JDEGTMOExists(pMoBlob, OBJ_RTFTEXT))

{

nMOTypeExist[0]= 1;

}

if(JDEGTMOExists(pMoBlob, OBJ_JDEIMAGE))

{

nMOTypeExist[2]=1;

}

if(JDEGTMOExists(pMoBlob, OBJ_JDEOLE))

{

nMOTypeExist[3]=1;

}

if(JDEGTMOExists(pMoBlob, OBJ_MISCJDESHORTCUT))

{

nMOTypeExist[4]=1

}

if(JDEGTMOExists(pMoBlob, OBJ_MISCIMAGEVENDOR))

{

nMOTypeExist[5]=1

}

if(JDEGTMOExists(pMoBlob, OBJ_MISCHTML))

{

nMOTypeExist[6]=1

}

}

JDEGTFree ((LPF9860)NULL, lpDetail);

FreeBuildStrFromDstmplName(pStringKey);

Additional Notes

1. FreeBuildStrFromDstmplName() must be called to free the memory allocated by AllocBuildStrFromDstmplName().

2. JDEGTFree() must be called to free LPF0016D memory allocated by JDEGTAllocFetch().

3. JDETextFree() must be called to free the text memory allocated by JDEGTAllocFetchText().

See Also

1. JDEGTAllocFetch()

2. JDEGTFree()

3. JDEGTExists()

4. JDEGTAdd()

5. JDEGTAddRecord()

6. JDEGTUpdate()

7. JDEGTDelete()

8. JDEGTAllocFetchText()

9. JDEGTTextFree()


JDEGTTextFree

Last Modified: Xe | May 28, 2002

JDEGTTextFree will free memory allocated by JDEGTAllocFetchText().

Syntax

JDERTN(void) JDEWINAPI JDEGTTextFree(LPSTR szText)

Parameters

Parameter | Notes | Usage
szText | Input | Allocated memory

Return Value

Example

DSABGT dsAbGT = {0};

LPSTR lpText = NULL;

ParseNumericString(&dsAbGT.mnAddressNumber, “1”);

lpText = JDEGTAllocFetchText( “ABGT”, &dsAbGT, TRUE);

if (lpText)

{

JDEGTTextFree(lpText);

}

Additional Notes

1. FreeBuildStrFromDstmplName() must be called to free the memory allocated by AllocBuildStrFromDstmplName().

2. JDEGTFree() must be called to free LPF0016D memory allocated by JDEGTAllocFetch().

3. JDETextFree() must be called to free the text memory allocated by JDEGTAllocFetchText().

See Also

1. JDEGTAllocFetch()

2. JDEGTFree()

3. JDEGTExists()

4. JDEGTAdd()

5. JDEGTAddRecord()

6. JDEGTUpdate()

7. JDEGTDelete()

8. JDEGTAllocFetchText()

9. JDEGTTextFree()


JDEGTUpdate

Last Modified: Xe | May 28, 2002

JDEGTUpdate will update the record in Media Object Table, F00165, exists based on GT Structure Name and generic text key.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI JDEGTUpdate(

HENV hEnv,

LPF0016D pdsF0016D,

LPDBREF pDbRef )

Parameters

Parameter | Notes | Usage
hEnv | Input | Pointer to the environment which the hUser will be retrieved.
pdsF0016D | Input | Structure storing the keys and blob to be added.
pDbRef | Input | Not used

Return Value

JDEDB_RESULT:

JDEDB_PASSED = Record updates successfully

JDEDB_FAILED = Record fails to update.

Example

LPSTR pStringKey = NULL;

DSABGT dsAbGT = {0};

LPF00165D lpDetail = NULL;

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

BOOL bMOExist = FALSE

ParseNumericString(&dsAbGT.mnAddressNumber, “1”);

pStringKey = AllocBuildStrFromDstmplName(NULL, "ABGT", &dsAbGT);

pStringKey = StripKey (pStringKey);

bMOExist = JDEGTExists(lpBhvrCom->hEnv, (LPCSTR)"ABGT",

(LPCSTR)pStringKey, (LPCSTR) “ “);

if (!bMOExist)

{

FreeBuildStrFromDstmplName(pStringKey);

return ER_ERROR;

}

JDBReturn = JDEGTAllocFetch (lpBhvrCom->hEnv, (LPCSTR)"ABGT",

(LPCSTR)pStringKey, (LPCSTR) “ “, &lpDetail);

if (JDBReturn == JDEDB_PASSED)

{

...

…

JDBReturn = JDEGTUpdate( lpBhvrCom->hEnv, lpDetail, (LPDBREF)NULL);

}

JDEGTFree ((LPF9860)NULL, lpDetail);

FreeBuildStrFromDstmplName(pStringKey);

Additional Notes

1. FreeBuildStrFromDstmplName() must be called to free the memory allocated by AllocBuildStrFromDstmplName().

2. JDEGTFree() must be called to free LPF0016D memory allocated by JDEGTAllocFetch().

3. JDEGTUpdate() will delete the existing records and add the new record passed in.

See Also

1. JDEGTAllocFetch()

2. JDEGTFree()

3. JDEGTExists()

4. JDEGTAdd()

5. JDEGTAddRecord()

6. JDEGTUpdate()

7. JDEGTDelete()

8. JDEGTAllocFetchText()

9. JDEGTTextFree()


jdeGT_CloseTable.htm

jdeGT_CloseTable

Last Modified: EnterpriseOne | June 06, 2006

This function closes the F00165 table and releases the table handle. This API must be invoked after the jdeGT_OpenTable() API is used.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_CloseTable(HREQUEST hRequestGT);

Parameters

hRequestGT

Input, required. GT table handle to be closed and released.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("");

JDBReturn = JDB_InitBhvr(.., &hUser);

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

...

...

}

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

See Also

jdeGT_DeleteData/jdeGT_DeleteDataKeyStr

jdeGT_FetchData/jdeGT_FetchDataEx

jdeGT_InsertData/jdeGT_InsertDataKeyStr

jdeGT_OpenTable

jdeGT_SelectData/jdeGT_SelectDataKeyStr

jdeGT_UpdateData/jdeGT_UpdateDataKeyStr


jdeGT_DeleteData_jdeGT_DeleteDataKeyStr.htm

jdeGT_DeleteData/jdeGT_DeleteDataKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes a record in the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_DeleteData(

HREQUEST hRequestGT,

PJSTR pszOjbectName,

LPVOID lpMODSKey,

int nSeq

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_DeleteDataKeyStr(

HREQUEST hRequestGT,

PJSTR pszOjbectName,

PJSTR pszGTKeyStr,

int nSeq

);

Parameters

hRequestGT | Input, required. GT table handle to be closed and released.
pszObjectName | Input, required. GT data structure name.
lpMODSKey | Input, required. GT data structure with data loaded (use in jdeGT_SelectData). This data is formatted into the string for TXKY.
pszGTKeyStr | Input, required. GT-formatted string from the GT data structure (use in jdeGT_SelectDataKeyStr).

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Additional Notes

Invoke this API after using the jdeGT_OpenTable() API. This API is used for multiple access of the table within one function scope.

This table describes the MODATA (or LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Example

This is the first of two examples for this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

JCHAR szFormatKey[255] = _J("1");

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

JDBReturn = JDB_InitBhvr(.., &hUser);

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectDataKeyStr (hRequest, szObjectName, szFormatKey, szLang,

OBJ_JDEOLE);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

while (JDBReturn = JDEDB_PASSED)

{

jdeGT_DeleteDataKeyStr(hRequest, szObjectName, szFormatKey, lpGTData->nSeq);

jdeGTFreeMOData(lpGTData, 1);

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

}

}

jdeGTFreeMOData(lpGTData, 1);

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

This is the second example for this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

DSABGT dsAbGT = {0};

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

JDBReturn = JDB_InitBhvr(.., &hUser);

ParseNumericString(dsAbGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectData(hRequest, szObjectName, &dsAbGT, szLang, OBJ_JDEOLE);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

while (JDBReturn = JDEDB_PASSED)

{

jdeGT_DeleteData(hRequest, szObjectName, &dsAbGT, lpGTData->nSeq);

jdeGTFreeMOData(lpGTData, 1);

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

}

}

jdeGTFreeMOData(lpGTData, 1);

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

See Also

jdeGT_CloseTable

jdeGT_FetchData/jdeGT_FetchDataEx

jdeGT_InsertData/jdeGT_InsertDataKeyStr

jdeGT_OpenTable

jdeGT_SelectData/jdeGT_SelectDataKeyStr

jdeGT_UpdateData/jdeGT_UpdateDataKeyStr


jdeGT_FetchData_jdeGT_FetchDataEx.htm

jdeGT_FetchData/jdeGT_FetchDataEx

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves one record from the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_FetchData(

HREQUEST hRequestGT,

LPMODATA *lpMOData

BOOL bConvRTFText

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_FetchDataEx(

HREQUEST hRequestGT,

JCHAR *szObjectName,

JCHAR *szGTKey,

LPMODATA *lpMOData

BOOL bConvRTFText

);

Parameters

hRequestGT | Input, required. GT table handle to be closed and released.
szObjectName | Output. Object name (OBNM)-character array.
szGTKey | Output. Generic text key in the string format (TXKY)-character array.
*lpMOData | Output. Allocated memory for data.
bCovRTFText | Input. TRUE = Convert any RTF text to plain text.

Additional Notes

Invoke this API after using the jdeGT_OpenTable() API. This API is used for multiple access of the table with one function scope.

This table describes the MODATA (or LOMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of three examples for this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

JCHAR szFormatKey[255] = _J("1");

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

JDBReturn = JDB_InitBhvr(.., &hUser);

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectDataKeyStr (hRequest, szObjectName, szFormatKey, szLang,

OBJ_JDEOLE);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

while (JDBReturn = JDEDB_PASSED)

{

jdeGT_DeleteDataKeyStr(hRequest, szObjectName, szFormatKey, lpGTData->nSeq);

jdeGTFreeMOData(lpGTData, 1);

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

}

}

jdeGTFreeMOData(lpGTData, 1);

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

This is the second example of this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

DSABGT dsAbGT = {0};

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

JDBReturn = JDB_InitBhvr(.., &hUser);

ParseNumericString(dsAbGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectData(hRequest, szObjectName, &dsAbGT, szLang, OBJ_JDEOLE);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

while (JDBReturn = JDEDB_PASSED)

{

jdeGT_DeleteData(hRequest, szObjectName, &dsAbGT, lpGTData->nSeq);

jdeGTFreeMOData(lpGTData, 1);

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

}

}

jdeGTFreeMOData(lpGTData, 1);

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

This is the third example of this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

LPMODATA lpGTData = NULL;

JCHAR szGTKey[256] = _J("");

JCHAR szObjName[11] = _J("");

JDBReturn = JDB_InitBhvr(lpBhvrCom, &hUser,(JCHAR *) NULL,

JDEDB_COMMIT_AUTO

);

if (lpDS->idHRequestGT == NULL)

{

JDBReturn = jdeGT_OpenTable (hUser, lpDS->szFromDatasource,

lpDS->szObjectName, &hRequestGT);

lpDS->idHRequestGT = (ID) jdeStoreDataPtr(hUser, hRequestGT);

else

{

hRequestGT = (HREQUEST) jdeRetrieveDataPtr(hUser, lpDS->idHRequestGT);

if (hRequstGT)

{

JDBReturn = jdeGT_SelectData(hRequest, lpDS->szObjectName,

NULL, lpDS->szLang, OBJ_JDEOLE);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchDataEx(hRequest, szObjName, szGTKey, lpGTData, TRUE);

if (JDBReturn = JDEDB_PASSED)

{

jdeStrncpy(lpDS->szGTKeyData, szGTKey, 255);

jdeStrncpy(lpDS->szTextData, lpGTData->pData, 255);

jdeGTFreeMOData(lpGTData, 1);

else

{

jdeRemoveDataPtr(hUser, lpDS->idHRequestGT);

lpDS->idHRequestGT = 0L;

}

}

else

{

jdeRemoveDataPtr(hUser, lpDS->idHRequestGT);

lpDS->idHRequestGT = 0L;

}

if (hRequestGT && lpDS->idHRequestGT == 0)

{

jdeGT_CloseTable(hRequestGT);

}

JDB_FreeBhvr(hUser);

return;

See Also

jdeGT_CloseTable

jdeGT_DeleteData/jdeGT_DeleteDataKeyStr

jdeGT_InsertData/jdeGT_InsertDataKeyStr

jdeGT_OpenTable

jdeGT_SelectData/jdeGT_SelectDataKeyStr

jdeGT_UpdateData/jdeGT_UpdateDataKeyStr


jdeGT_InsertData_jdeGT_InsertDataKeyStr.htm

jdeGT_InsertData/jdeGT_InsertDataKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function inserts a record into the F00165 table.

Syntax

JDERTN(JDEDB_RESULT)JDEWINAPI jdeGT_InsertData(

HREQUEST hRequestGT,

PJSTR pszOjbectName,

LPVOID lpMODSKey,

int nSeq,

PJSTR pszGTLang,

LPMODATA lpMOData

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_InsertDataKeyStr(

HREQUEST hRequestGT,

PJSTR pszOjbectName,

PJSTR pszGTKeyStr,

int nSeq,

PJSTR pszGTLang,

LPMODATA lpMOData

);

Parameters

hRequestGT | Input, required. GT table handle to be closed and released.
pszObjectName | Input, required. GT data structure name.
lpMODSKey | Input, required. GT data structure with data loaded (use in jdeGT_SelectData). This data is formatted into the string for TXKY.
pszGTKeyStr | Input, required. GT formatted string from GT data structure (use in jdeGT_SelectDataKeyStr).
nSeq | Input, required. Sequence number for primary key.
pszGTLang | Input. Language code to be updated.
lpMOData | Input, required. Data to be updated.

Additional Notes

Invoke this API after using the jdeGT_OpenTable() API. This API is used for multiple access of the table with one function scope.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples for this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

JCHAR szFormatKey[255] = _J("1");

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

MODATA dsGTNewData = {0};

JCHAR szText[255] = _J("New Text to be inserted");

JDBReturn = JDB_InitBhvr(.., &hUser);

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectDataKeyStr (hRequest, szObjectName, szFormatKey, szLang,

OBJ_JDEALL);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

if (JDBReturn != JDEDB_PASSED)

{

dsGTNewData.nSeq = 1;

dsGTNewData.nMOType = OBJ_RTFTEXT;

dsGTNewData.pData = szText;

jdeStrcpy(dsGTNewData.szItemName, _J("New Text"));

jdeGT_InsertDataKeyStr(hRequest, szObjectName, szFormatKey, 1, szLang, &dsGTNewData);

}

else

{

jdeGTFreeMOData(lpGTData, 1);

}

}

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

This is the second example for this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

DSABGT dsAbGT = {0};

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

MODATA dsGTNewData = {0};

JCHAR szText[255] = _J("New Text to be inserted");

JDBReturn = JDB_InitBhvr(.., &hUser);

ParseNumericString(dsAbGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectData(hRequest, szObjectName, &dsAbGT, szLang, OBJ_JDEALL);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

if (JDBReturn != JDEDB_PASSED)

{

dsGTNewData.nSeq = 1;

dsGTNewData.nMOType = OBJ_RTFTEXT;

dsGTNewData.pData = szText;

jdeStrcpy(dsGTNewData.szItemName, _J("New Text"));

jdeGT_InsertData(hRequest, szObjectName, &dsAbGT, 1, szLang, &dsGTNewData);

}

else

{

jdeGTFreeMOData(lpGTData, 1);

}

}

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

See Also

jdeGT_CloseTable

jdeGT_DeleteData/jdeGT_DeleteDataKeyStr

jdeGT_FetchData/jdeGT_FetchDataEx

jdeGT_OpenTable

jdeGT_SelectData/jdeGT_SelectDataKeyStr

jdeGT_UpdateData/jdeGT_UpdateDataKeyStr


jdeGT_OpenTable.htm

jdeGT_OpenTable

Last Modified: EnterpriseOne | June 06, 2006

This function enables the F00165 table to be opened based on the object name or data source. It must be used first if the related functions are to be used. This API is used for multiple access of the table within one function scope.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_OpenTable(

HUSER hUser,

PJSTR pszDataSource,

PJSTR pszObjectName,

HREQUEST *hRequestGT

);

Parameters

hUser | Input, required. User handle.
pszDataSource | Input. If empty, use the default data source from the pszObejctName. Data source has precedence over the object name.
pszObjectName | Input, required if pszDatasource is empty.
hRequestGT | Output. If open table fails, NULL pointer is returned; otherwise, a pointer to the handle is returned.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples for this API, and it demonstrates using data source:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("");

JDBReturn = JDB_InitBhvr(.., &hUser);

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

...

...

}

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

This example demonstrates using object name:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J(" ");

JCHAR szObjectName[11] = _J("ABGT");

JDBReturn = JDB_InitBhvr(.., &hUser);

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

...

...

}

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

See Also

jdeGT_OpenTable

jdeGT_DeleteData/jdeGT_DeleteDataKeyStr

jdeGT_FetchData/jdeGT_FetchDataEx

jdeGT_InsertData/jdeGT_InsertDataKeyStr

jdeGT_SelectData/jdeGT_SelectDataKeyStr

jdeGT_UpdateData/jdeGT_UpdateDataKeyStr


jdeGT_SelectData_jdeGT_SelectDataKeyStr.htm

jdeGT_SelectData/jdeGT_SelectDataKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function enables a data selection to be applied against the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_SelectData(

HREQUEST hRequestGT,

PJSTR pszOjbectName,

LPVOID pdsGTKeyDS,

PJSTR pszLang,

MOTYPE nMOType

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_SelectDataKeyStr(

HREQUEST hRequestGT,

PJSTR pszOjbectName,

PJSTR pszGTKeyStr,

PJSTR pszLang,

MOTYPE nMOType

);

Parameters

hRequestGT | Input, required. GT table handle to be closed and released.
pszObjectName | Input, required. GT data structure name.
pszLang | Input. Language code.
nMOType | Input, required. Media object type.

Additional Notes

Invoke this API after using the jdeGT_OpenTable() API. This API is used for multiple access of the table with one function scope.

This table describes the MODATA (or LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples describing how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

JCHAR szFormatKey[255] = _J("1");

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

JDBReturn = JDB_InitBhvr(.., &hUser);

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectDataKeyStr (hRequest, szObjectName, szFormatKey, szLang,

OBJ_JDEOLE);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

while (JDBReturn = JDEDB_PASSED)

{

jdeGT_DeleteDataKeyStr(hRequest, szObjectName, szFormatKey, lpGTData->nSeq);

jdeGTFreeMOData(lpGTData, 1);

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

}

}

jdeGTFreeMOData(lpGTData, 1);

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

DSABGT dsAbGT = {0};

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

JDBReturn = JDB_InitBhvr(.., &hUser);

ParseNumericString(dsAbGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectData(hRequest, szObjectName, &dsAbGT, szLang, OBJ_JDEOLE);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

while (JDBReturn = JDEDB_PASSED)

{

jdeGT_DeleteData(hRequest, szObjectName, &dsAbGT, lpGTData->nSeq);

jdeGTFreeMOData(lpGTData, 1);

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

}

}

jdeGTFreeMOData(lpGTData, 1);

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

See Also

jdeGT_CloseTable

jdeGT_DeleteData/jdeGT_DeleteDataKeyStr

jdeGT_FetchData/jdeGT_FetchDataEx

jdeGT_InsertData/jdeGT_InsertDataKeyStr

jdeGT_OpenTable

jdeGT_UpdateData/jdeGT_UpdateDataKeyStr


jdeGT_UpdateData_jdeGT_UpdateDataKeyStr.htm

jdeGT_UpdateData/jdeGT_UpdateDataKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function updates an existing record in the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_UpdateData(

HREQUEST hRequestGT,

PJSTR pszOjbectName,

LPVOID lpMODSKey,

int nSeq,

PJSTR pszGTLang,

LPMODATA lpMOData

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_UpdateDataKeyStr(

HREQUEST hRequestGT,

PJSTR pszOjbectName,

PJSTR pszGTKeyStr,

int nSeq,

PJSTR pszGTLang,

LPMODATA lpMOData

);

Parameters

hRequestGT | Input, required. GT table handle to be closed and release.
pszObjectName | Input, required. GT data structure name.
lpMODSKey | Input, required. GT data structure with data loaded (use in jdeGT_SelectData). This data is formatted into the string for TXKY.
nSeq | Input, required. Sequence number for primary key.
pszGTLang. | Input. Language code to be updated.
lpMOData | Input, required. Data to be updated.

Additional Notes

Invoke this API after using the jdeGT_OpenTable() API. This API is used for multiple access of the table with one function scope.

This table describes the MODATA (or LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples describing how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

JCHAR szFormatKey[255] = _J("1");

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

JDBReturn = JDB_InitBhvr(.., &hUser);

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectDataKeyStr (hRequest, szObjectName, szFormatKey, szLang,

OBJ_RTFTEXT);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

if (JDBReturn == JDEDB_PASSED)

{

jdeFree(lpGTData->pData);

lpGTData->pData = jdeAlloc(COMMON_POOL, 255*sizeof(JCHAR), MEM_ZEROINIT);

jdeStrcpy(lpGTData->pData, _J("New Text to be inserted");

jdeGT_UpdateDataKeyStr(hRequest, szObjectName, szFormatKey, lpGTData->nSeq, szLang,

lpGTData);

jdeGTFreeMOData(lpGTData, 1);

}

}

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

This is the second example describing how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

DSABGT dsAbGT = {0};

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

JDBReturn = JDB_InitBhvr(.., &hUser);

ParseNumericString(dsAbGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectData(hRequest, szObjectName, &dsAbGT, szLang, OBJ_RTFTEXT);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

if (JDBReturn == JDEDB_PASSED)

{

jdeFree(lpGTData->pData);

lpGTData->pData = jdeAlloc(COMMON_POOL, 255*sizeof(JCHAR), MEM_ZEROINIT);

jdeStrcpy(lpGTData->pData, _J("New Text to be inserted");

jdeGT_UpdateData(hRequest, szObjectName, &dsAbGT, lpGTData->nSeq, szLang,

lpGTData);

jdeGTFreeMOData(lpGTData, 1);

}

}

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

See Also

jdeGT_UpdateData/jdeGT_UpdateDataKeyStr

jdeGT_DeleteData/jdeGT_DeleteDataKeyStr

jdeGT_FetchData/jdeGT_FetchDataEx

jdeGT_InsertData/jdeGT_InsertDataKeyStr

jdeGT_OpenTable

jdeGT_SelectData/jdeGT_SelectDataKeyStr


jdeGTAddUpdate_AllMOType_jdeGTAddUpdate_AllMOTypeKeyStr_ jdeGTAddUpdate_AllMOTypeWithLang.htm

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

Last Modified: EnterpriseOne | June 06, 2006

This function adds or updates all record types to the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_AllMOType(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_AllMOTypeKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_AllMOTypeWithLang(

PJSTR szObjectName,

LPVOID lpMODSKey,

PJSTR szLanguage,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
szLanguage | Input. Language code.
pMOData | Input, required. Array of data structure that stores the data to be updated.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

Parameter pData in MODATA must contain a valid pointer to update the text or shortcut media object type.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples demonstrating how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_AllMOTypeKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example demonstrating how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_AllMOType(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTAddUpdate_HTML_jdeGTAddUpdate_HTMLKeyStr.htm

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function adds or updates HTML, URL, and File record types to the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_HTML(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_HTMLKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structures that stores the data to be updated.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

Parameter pData in MODATA must contain a valid pointer to update the text or shortcut media object type.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_HTMLKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_HTML (_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTAddUpdate_Image_jdeGTAddUpdate_ImageKeyStr.htm

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function adds or updates image record types to the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_Image(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_ImageKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structures that stores the data to be updated.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

Parameter pData in MODATA must contain a valid pointer to update the text or shortcut media object type.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_ImageKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_Image(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTAddUpdate_OLE_jdeGTAddUpdate_OLEKeyStr.htm

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function adds or updates OLE record types to the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_OLE(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_OLEKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structures that stores the data to be updated.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

Parameter pData in MODATA must contain a valid pointer to update the text or shortcut media object type.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_OLEKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_OLE(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTAddUpdate_Shortcut_jdeGTAddUpdate_ShortcutKeyStr.htm

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function adds or updates Shortcut record types to the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_Shortcut (

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_ShortcutKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structures that stores the data to be updated.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

Parameter pData in MODATA must contain a valid pointer to update the text or shortcut media object type.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_ShortcutKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_Shortcut (_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTAddUpdate_Text_jdeGTAddUpdate_TextKeyStr.htm

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function adds or updates text record types to the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_Text(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_TextKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structures that stores the data to be updated.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

Parameter pData in MODATA must contain a valid pointer to update the text or shortcut media object type.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

The API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_TextKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_Text(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTAddUpdate_Vendor_jdeGTAddUpdate_VendorKeyStr.htm

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function adds or updates vendor or third-party software record types to the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_Vendor(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_VendorKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structures that stores the data to be updated.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

Parameter pData in MODATA must contain a valid pointer to update the text or shortcut media object type.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

The API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_VendorKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_Vendor (_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTDelete_AllHTML_jdeGTDelete_AllHTMLKeyStr.htm

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes all HTML, URL, and File record types in the F00165 table based on object name (OBNM) and object keys (TXKY).

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllHTML(

PJSTR szObjectName,

LPVOID lpMODSKey

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllHTMLKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

JDBReturn = jdeGTDelete_AllHTMLKeyStr(_J("ABGT") , _J("1"));

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTDelete_AllHTML(_J("ABGT") , &dsABGT);

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTDelete_AllImage_jdeGTDelete_AllImageKeyStr.htm

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes all image record types in the F00165 table based on object name (BNM) and object keys (TXKY).

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllImage(

PJSTR szObjectName,

LPVOID lpMODSKey

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllImageKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples demonstrating how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

JDBReturn = jdeGTDelete_AllImageKeyStr(_J("ABGT") , _J("1"));

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTDelete_AllImage(_J("ABGT") , &dsABGT);

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTDelete_AllMOType_jdeGTDelete_AllMOTypeStr.htm

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes all media object record types in the F00165 table based on object name (OBNM) and object keys (TXKY).

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllMOType(

PJSTR szObjectName,

LPVOID lpMODSKey

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllMOTypeKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

JDBReturn = jdeGTDelete_AllMOTypeKeyStr(_J("ABGT") , _J("1"));

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTDelete_AllMOType (_J("ABGT") , &dsABGT);

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTDelete_AllOLE_jdeGTDelete_AllOLEKeyStr.htm

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes all OLE record types in the F00165 table based on object name (BNM) and object keys (TXKY).

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllOLE(

PJSTR szObjectName,

LPVOID lpMODSKey

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllOLEKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

JDBReturn = jdeGTDelete_AllOLEKeyStr(_J("ABGT") , _J("1"));

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTDelete_AllOLE(_J("ABGT") , &dsABGT);

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTDelete_AllShortcut_jdeGTDelete_AllShortcutKeyStr.htm

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes all shortcut record types in the F00165 table based on object name (OBNM) and object keys (TXKY).

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllShortcut(

PJSTR szObjectName,

LPVOID lpMODSKey

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllShortcutKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

JDBReturn = jdeGTDelete_AllShortcutKeyStr(_J("ABGT") , _J("1"));

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTDelete_AllShortcut (_J("ABGT") , &dsABGT);

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTDelete_AllText_jdeGTDelete_AllTextKeyStr.htm

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes all text record types in the F00165 table based on object name (OBNM) and object keys (TXKY).

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllText(

PJSTR szObjectName,

LPVOID lpMODSKey

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllTextKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

JDBReturn = jdeGTDelete_AllTextKeyStr(_J("ABGT") , _J("1"));

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTDelete_AllText(_J("ABGT") , &dsABGT);

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTDelete_AllVendor_jdeGTDelete_AllVendorKeyStr.htm

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes all vendor or third-party software record types in the F00165 table based on object name (OBNM) and object keys (TXKY).

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllVendor(

PJSTR szObjectName,

LPVOID lpMODSKey

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllVendorKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

JDBReturn = jdeGTDelete_AllVendorKeyStr(_J("ABGT") , _J("1"));

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTDelete_AllVendor _J("ABGT") , &dsABGT);

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTDelete_HTML_jdeGTDelete_HTMLKeyStr.htm

jdeGTDelete_HTML/jdeGTDelete_HTMLKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes specific HTML, URL and file record types from the F00165 table based on the pMOData parameter.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_HTML(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_HTMLKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_HTMLKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_HTML(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


Media Object

Media Object consist of the following APIs:

 | AllocBuildStrFromDstmplName
app.gif (808 bytes) | FreeStrFromDstmpl
app.gif (808 bytes) | GetAllGenericTextName
app.gif (808 bytes) | JDEGTAdd
 | JDEGTAddRecord
app.gif (808 bytes) | JDEGTAllocFetch
 | JDEGTAllocFetchText
app.gif (808 bytes) | JDEGTDelete
 | JDEGTExists
 | JDEGTFree
 | JDEGTMOExists
app.gif (808 bytes) | JDEGTTextFree
 | JDEGTUpdate
 | ModifyGenericTextName
app.gif (808 bytes) | StripKey


StripKey

Last Modified: Xe | May 28, 2002

StripKey will strip all the spaces within the string.

Syntax

JDERTN(LPSTR) JDEWINAPI StripKey(LPSTR pKey )

Parameters

Parameter | Notes | Usage
pKey | Input | String to be formatted.

Return Value

The same string passed in will be returned.

Example

LPSTR pStringKey = NULL;

DSABGT dsAbGT = {0};

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

BOOL bMOExist = FALSE

KEY1_F0016D dsKey1 = {0};

ParseNumericString(&dsAbGT.mnAddressNumber, “1”);

pStringKey = AllocBuildStrFromDstmplName(NULL, "ABGT", &dsAbGT);

pStringKey = StripKey (pStringKey);

bMOExist = JDEGTExists(lpBhvrCom->hEnv, (LPCSTR)"ABGT",

(LPCSTR)pStringKey, (LPCSTR) “ “);

if (!bMOExist)

{

FreeBuildStrFromDstmplName(pStringKey);

return ER_SUCCESS;

}

 JDBReturn = JDEGTDelete(
lpBhvrCom->hEnv, “ABGT”, pStringKey, “
“);

FreeBuildStrFromDstmplName(pStringKey);

Additional Notes

1. FreeBuildStrFromDstmplName() must be called to free the memory allocated by AllocBuildStrFromDstmplName().

2. JDEGTFree() must be called to free LPF0016D memory allocated by JDEGTAllocFetch().

See Also

1. JDEGTAllocFetch()

2. JDEGTFree()

3. JDEGTExists()

4. JDEGTAdd()

5. JDEGTAddRecord()

6. JDEGTUpdate()

7. JDEGTDelete()

8. JDEGTAllocFetchText()

9. JDEGTTextFree()


JDB_SetUserTriggerOption

jdeEncryptWKey

Last Modified: EnterpriseOne | June 06, 2006

jdeEncryptWKey performs encryption with input JCHAR string data and JCHAR encrypt key string, and then returns encrypted bytes and length. The maximum length of JCHAR encrypt key is 16, and the minimum length of JCHAR encrypt key is 4. A TripleDES algorithm is implemented currently.

Syntax

int jdeEncryptWKey(

     BYTE *outbuf,

     int *poutlen,

     JCHAR *inbuf,

     int inlen,

     JCHAR *encryptkey,

     int keylen,

     int type

     )

Parameters

Parameter | Notes | Usage
outbuf | Output. The number of encrypted bytes. If NULL, this API will fail. |
poutlen | Output. The length of encrypted bytes. |
inbuf | Input. JCHAR string data. If inbuf string data is NULL or has a length of zero, this API will fail. However, if inbuf is a blank space string with length greater than zero, the API will encrypt the string as a valid JCHAR string. |
inlen | Input. The length of JCHAR string data. |
encryptkey | Input. JCHAR string encrypt key. If encryptkey is NULL, has a length of zero, or just a single blank space, this API will fail. |
keylen | Input. The length of the JCHAR encrypt key string. |
type | Input. The type of encryption algorithm. |

Return Value

This API returns these values:

Return Value | Description
1 | JDEENCRYTT_SUCCESS. Indicates the API was successful.
0 | JDEENCRYPT_FAILURE. Indicates that the API failed.

Example

/* Declare variables associated with jdeEncryptWKey */

* declare example data

         *

         *******************************************/

         JCHAR      EKey[32]=_J("12345678");

         int              EKeyLen=8;

         JCHAR      EData[1024]=_J("TESTDATA");

         int              EDataLen=8;

         BYTE       EncryptedData[1024]={0};

         int              EncryptedLen;

         int   type=eEVPTripleDES;

  int   iRet;

  iRet=jdeEncryptWKey(EncryptedData,&EncryptedLen,EData,EDataLen,EKey,EKeyLen,type);

  if (iRet!= JDEENCRYPT_SUCCESS)

  {

  jdePrintf("jdeEncryptWKey failed\n");

  } /* END IF */

Additional Notes

See Also


JDB_SetUserTriggerOption

jdeDecryptWKey

Last Modified: EnterpriseOne | June 06, 2006

jdeDecryptWKey performs decryption with input encrypted data bytes and JCHAR encrypt key string, and then return decrypted JCHAR string with its length. The TripleDES algorithm is used.

Syntax

int jdeDecryptWKey(JCHAR *outbuf,

     int *poutlen,

     BYTE *inbuf,

     int inlen,

     JCHAR *encryptkey,

     int keylen,

     int type

     );

Parameters

Parameter | Notes | Usage
outbuf | Output. Decrypted JCHAR string. If null, the API fails. |
poutlen | Output. Length of decrypted JCHAR string. |
inbuf | Input. Encrypted bytes. If null or the length is zero, the API fails. |
inlen | Input. Length of encrypted bytes. |
encryptkey | Input. JCHAR string encrypt key. Minimum length is 4; maximum length is 16. If the length is zero or it contains only a blank space, the API fails. |
keylen | Input. Length of JCHAR encrypt key string. |
type | Input. Type of encryption algorithm. |

Return Value

This API returns these values:

Return Value | Description
1 | JDEENCRYTT_SUCCESS. Indicates the API was successful.
0 | JDEENCRYPT_FAILURE. Indicates that the API failed.

Example

/* Declare variables associated with jdeEncryptWKey */

* declare example data

         *

         *******************************************/

         JCHAR      EKey[32]=_J("12345678");

         int              EKeyLen=8;

         JCHAR      EData[1024]=_J("TESTDATA");

         int              EDataLen=8;

         BYTE       EncryptedData[1024]={0};

         int              EncryptedLen;

         int   type=eEVPTripleDES;

  int   iRet;

         JCHAR      DecryptedData[1024]={0};

         int              DecryptedLen;

  iRet=jdeEncryptWKey(EncryptedData,&EncryptedLen,EData,EDataLen,EKey,EKeyLen,type);

  if (iRet!= JDEENCRYPT_SUCCESS)

  {

  jdePrintf("jdeEncryptWKey failed\n");

  } /* END IF */

  iRet=jdeDecryptWKey(DecryptedData,&DecryptedLen,EncryptedData,EncryptedLen,EKey,EKeyLen,type);

  if (iRet!= JDEENCRYPT_SUCCESS)

  {

 jdePrintf("jdeDecryptWKey failed\n");

  } /* END IF */

Additional Notes

See Also


jdeXMLRequest_DeleteXML

Last Modified: ERP 9.0| October 21, 2002

The jdeXMLRequest_DeleteXML API is provided to delete the inbound XAPI request document from both memory and disc. It should be called when you are finished with processing the inbound XAPI request document. In case the mapped business function is sending a XAPI response, this API should be called after done sending the response XAPI document using jdeXAPIResponse_Finalize API.

Syntax

BOOL jdeXMLRequest_DeleteXML (

PJSTR pXMLHandle /* XML Handle */

);

Parameters

Parameter | Description
PJSTR pXMLHandle | This is the handle to the inbound XAPI request document. It will be provided to the BSFN by the XML Service Kernel.

Return Values

BOOL : Returns TRUE or FALSE.

Example

JDEBFRTN (ID) JDEBFWINAPI DmdSchXAPISalesOrderProcess (LPBHVRCOM lpBhvrCom, LPVOID lpVoid, LPDSD4206000A lpDS)

{

/************************************************************************

* Variable declarations

************************************************************************/

ID idReturnValue = ER_SUCCESS; /*Return Code*/

ID idJDEDBResult = FALSE;

HUSER hUser = (HUSER)NULL;

BOOL bXAPIInUse = FALSE;

MATH_NUMERIC mnJobNumber = {0};

unsigned long lJobNumber = {0};

#ifdef jdeXAPI_CALLS_ENABLED

XAPI_CALL_ID ulXAPICallID = {0};

XAPI_CALL_RETURN eXAPICallReturn = eEventCallSuccess;

#endif

/************************************************************************

* Declare structures

************************************************************************/

DSD4206000I dsD4206000I = {0}; /* Inbound Demand */

DSD4206010A dsD4206010A = {0}; /* ProcessSOforDemandScheduling B4206010.c */

DSD4206030A dsD4206030A = {0}; /* CacheProcessInboundDemandRequest B4206030.c */

/************************************************************************

* Declare pointers

************************************************************************/

/************************************************************************

* Check for NULL pointers

************************************************************************/

if ((lpBhvrCom == (LPBHVRCOM) NULL) ||

(lpVoid == (LPVOID) NULL) ||

(lpDS == (LPDSD4206000A) NULL))

{

jdeErrorSet (lpBhvrCom, lpVoid, (ID) 0, _J("4363"), (LPVOID) NULL);

return ER_ERROR;

}

idJDEDBResult = JDB_InitBhvr(lpBhvrCom, &hUser, (JCHAR *)NULL, JDEDB_COMMIT_AUTO);

if (idJDEDBResult == JDEDB_FAILED)

{

jdeSetGBRError ( lpBhvrCom, lpVoid, (ID) 0, _J("4363") ) ;

return ER_ERROR ;

}

/************************************************************************

* Set pointers

************************************************************************/

/************************************************************************

* Main Processing

************************************************************************/

/* Check if the XML Handle is Valid*/

if (IsStringBlank(lpDS->szXMLHandle))

{

/* Invalid Input Parameter */

jdeErrorSet(lpBhvrCom, lpVoid, (ID) 0, _J("4377"), (LPVOID) NULL);

return ER_ERROR;

}

/* Initialize XPI Call Determing if XAPI is ready to be used */

#ifdef jdeXAPI_CALLS_ENABLED

if (jdeXAPI_CALLS_ENABLED())

{

/* XAPISOOUT - XAPI Demand Scheduling Outbound */

if(jdeXAPI_IsCallTypeEnabled(_J("XAPISOOUT")))

{

bXAPIInUse = TRUE;

}

/* Initialize outbound XAPI */

if(bXAPIInUse == TRUE)

{

ulXAPICallID = jdeXAPIResponse_Init(lpBhvrCom,

_J("DmdSchXAPISalesOrderProcess"),

_J("XAPISOOUT"),

NULL,

&eXAPICallReturn);

/* XAPI initialize fail */

if (eXAPICallReturn != eEventCallSuccess)

{

jdeErrorSet(lpBhvrCom, lpVoid, (ID) 0, _J("40R35"), (LPVOID) NULL);

/*jdeTraceSz1(NULL, "jdeXAPI_Init API failed and returned error code - %d", eXAPICallReturn);*/

return ER_ERROR;

}

}

}

#endif

/* Get Job Number for Cache */

lJobNumber = JDB_GetInternalNextNumber();

LongToMathNumeric(lJobNumber, &mnJobNumber);

/* Call Interal function to extract XML and load cache */

#ifdef jdeXAPI_CALLS_ENABLED

if(bXAPIInUse == TRUE)

{

idReturnValue = I4206000_ExtractXML(lpBhvrCom,

lpVoid,

lpDS,

hUser,

&mnJobNumber);

}

#endif

/* Proceed only if SO records is received */

if (idReturnValue == ER_SUCCESS)

{

/*Load cache function parameter for fetch */

memset((void *)(&dsD4206030A), (int)(_J('\0')), sizeof(DSD4206030A));

jdeStrncpyTerminate(dsD4206030A.szCacheActionCode , _J("6"),

DIM(dsD4206030A.szCacheActionCode ) ); /* Get next cache record */

ParseNumericString(&dsD4206030A.mnNumberKeys , _J("0") ); /* Number of Keys may changed depend on the INVRPT change*/

dsD4206030A.cSuppressErrorMessage = _J('1'); /* Suppress the error message*/

MathCopy(&dsD4206030A.mnJobnumberA, &mnJobNumber) ;

idReturnValue = jdeCallObject( _J("CacheProcessInboundDemandRequest"),

(LPFNBHVR)NULL ,

lpBhvrCom ,

lpVoid,

(LPVOID)&dsD4206030A,

(CALLMAP *) NULL,

(int) 0,

(JCHAR*)NULL ,

(JCHAR*)NULL ,

(int) 0 );

/*Fetch until the end of the cache*/

while ((IsStringBlank(dsD4206030A.szErrorMessageID))

&& (idReturnValue == ER_SUCCESS))

{

/*Load cache to DSTR*/

memset((void *)(&dsD4206000I), (int)(_J('\0')), sizeof(DSD4206000I));

I4206000_LoadParmsFromCache(&dsD4206000I, &dsD4206030A);

memset((void *)(&dsD4206010A), (int)(_J('\0')), sizeof(dsD4206010A));

dsD4206010A.idXAPICallId = (unsigned long)jdeStoreDataPtr(hUser, (void *)ulXAPICallID);

dsD4206010A.idInboundDemand = (unsigned long)jdeStoreDataPtr(hUser, (void *)&dsD4206000I);

jdeCallObject( _J("ProcessSOforDemandScheduling"),

NULL,

lpBhvrCom,

lpVoid,

(LPVOID)&dsD4206010A,

(CALLMAP *) NULL,

(int) 0,

(JCHAR *) NULL,

(JCHAR *) NULL,

(int) 0);

jdeRemoveDataPtr(hUser, (unsigned long)dsD4206010A.idXAPICallId);

jdeRemoveDataPtr(hUser, (unsigned long)dsD4206010A.idInboundDemand);

/* Fetch next available cache inbound demand record*/

memset((void *)(&dsD4206000I), (int)(_J('\0')), sizeof(DSD4206000I));

jdeStrncpyTerminate(dsD4206030A.szCacheActionCode , _J("6") ,DIM( dsD4206030A.szCacheActionCode ) );

ParseNumericString(&dsD4206030A.mnNumberKeys , _J("0") ); /* Number of Keys may changed depend on the INVRPT change*/

dsD4206030A.cSuppressErrorMessage = _J('1'); /* suppress the message */

MathCopy(&dsD4206030A.mnJobnumberA, &mnJobNumber) ;

idReturnValue = jdeCallObject( _J("CacheProcessInboundDemandRequest") ,

(LPFNBHVR)NULL ,

lpBhvrCom ,

lpVoid ,

(LPVOID)&dsD4206030A,

(CALLMAP *)NULL,

(int) 0,

(JCHAR*)NULL ,

(JCHAR*)NULL ,

(int) 0 );

} /* End of while loop reading cache */

/* Free cache */

memset((void *)(&dsD4206030A), (int)(_J('\0')), sizeof(DSD4206030A));

jdeStrncpyTerminate(dsD4206030A.szCacheActionCode , _J("5") ,DIM( dsD4206030A.szCacheActionCode ) );

ParseNumericString(&dsD4206030A.mnNumberKeys , _J("1"));

MathCopy(&dsD4206030A.mnJobnumberA, &mnJobNumber) ;

idReturnValue = jdeCallObject( _J("CacheProcessInboundDemandRequest") ,

(LPFNBHVR)NULL ,

lpBhvrCom ,

lpVoid ,

(LPVOID)&dsD4206030A,

(CALLMAP *) NULL,

(int) 0,

(JCHAR*)NULL ,

(JCHAR*)NULL ,

(int) 0 );

}

/* Free XAPI Call*/

#ifdef jdeXAPI_CALLS_ENABLED

if(bXAPIInUse == TRUE)

{

eXAPICallReturn = jdeXAPIResponse_Finalize(lpBhvrCom,

lpDS->szXMLHandle,

ulXAPICallID,

_J("DmdSchXAPISalesOrderProcess"));

if(eXAPICallReturn != eEventCallSuccess)

{

jdeErrorSet(lpBhvrCom, lpVoid, (ID) 0, _J("40R37"), (LPVOID) NULL);

idReturnValue = ER_ERROR;

}

/* XML clean up*/

jdeXMLRequest_DeleteXML(lpDS->szXMLHandle);

}

#endif

/************************************************************************

* Function Clean Up

************************************************************************/

if(hUser != (HUSER)NULL)

{

JDB_FreeBhvr(hUser);

}

return (idReturnValue);

}

Additional Notes

None

See Also

· jdeXMLRequest_GetDSCount

· jdeXMLRequest_GetDSName

· jdeXMLRequest_ParseDS

· jdeXAPIResponse_Finalize

· Interop Guide


jdeXMLRequest_ParseNextDSByName

Last Modified: ERP 9.0| October 21, 2002

The jdeXMLRequest_ParseNextDSByNameAPI is provided to parses DS till no more DS found for the particular DS Name in the XML document.

Syntax

BOOL jdeXMLRequest_ParseNextDSByName (

PJSTR pXMLHandle /* XML Handle */,

NID DSName /* Returned name of DSTR */

LPVOID pData, /* Returned name of DSTR */

int iDataSize /* Returned name of DSTR */

);

Parameters

Parameter | Description
LPSTR pXMLHandle | This is the handle to the XML document. It will be provided to the BSFN by the XML Service Kernel.
NID DSName | This is where the name of the DSTR will be returned.
LPVOID pData | This is a pointer to the actual EnterpriseOne DSTR. (i.e. if the DSTR is DSD001, you will pass “&DSD001”)
int iDataSize | This is the size of the actual EnterpriseOne DSTR. (i.e. if the DSTR is DSD001, you will pass “sizeof(DSD001)”.

Return Values

BOOL : Returns TRUE or FALSE.

Example

if(jdeXMLRequest_PrepareDSListForIterationByName(pXMLHandle, szDSNameH))

{

bGetNextDS = jdeXMLRequest_ParseNextDSByName(pXMLHandle,szDSNameH, &pDataH, sizeof(pDataH));

while(bGetNextDS)

{

jdePrintf(_J("Parsed DSD4200310H successfully\n"));

bGetNextDS = jdeXMLRequest_ParseNextDSByName(pXMLHandle,szDSNameH, &pDataH, sizeof(pDataH));

}

}

Additional Notes

None

See Also

· jdeXMLRequest_GetDSCount

· jdeXMLRequest_GetDSName

· jdeXMLRequest_ParseDS

· jdeXMLRequest_DeleteXML

· jdeXMLRequest_PrepareDSListForIterationByName

· Interop Guide


XRCS_freeParser.htm

XRCS_freeParser

Last Modified: EnterpriseOne | June 06, 2006

This function frees the resources that are used by the parser.

Syntax

XRCS_Status XRCS_freeParser(XRCS_hParser hParser);

Parameters

hParser

Input. A valid parser handle.


XRCS_getParser (DOM only).htm

XRCS_getParser (DOM only)

Last Modified: EnterpriseOne | June 06, 2006

This function initializes a DOM parser, and returns a handle to it. Do not use this function for the SAX parser. Instead, use XRCS_getParserByType with the type set to XRCS_SAX_PARSER_TYPE.

Syntax

XRCS_Status XRCS_getParser(XRCS_hParser* phParser);

Parameters

XRCS_hParser *phParser

A valid pointer to a parser handle (address IN, handle OUT).


XRCS_getParserByType.htm

XRCS_getParserByType

Last Modified: EnterpriseOne | June 06, 2006

This function initializes a SAX or DOM parser, and returns a handle to it.

Syntax

XRCS_getParserByType(

XRCS_hParser* phParser,

XRCS_ParserType eParserType

);

Parameters

phParser | A valid pointer to a parser handle (address IN, handle OUT).
eParserType | A type of parser (DOM or SAX), specified by enum value (IN).


XRCS_initEngine.htm

XRCS_initEngine

Last Modified: EnterpriseOne | June 06, 2006

This function performs a one-time initialization of the XercesWrapper and the Xerces parsing code. It must be the first XercesWrapper function called from the client code.

Syntax

XRCS_Status XRCS_initEngine (void);


XRCS_parseXMLFile.htm

XRCS_parseXMLFile

Last Modified: EnterpriseOne | June 06, 2006

This function parses the given XML file. It is used for both SAX and DOM parsers. For the SAX parser, the document handle pointer is not used, so it must be passed in as NULL. Certain error conditions could cause a process crash if the document handle pointer is not set to NULL for the SAX parser.

The SAX parser will stop parsing the XML text whenever:

· The end of the XML text has been reached.

· A callback has requested to terminate parsing (using its return code).

· The SAX parser encounters a fatal error.

In the first case, the parse function returns XRCS_SUCCESS. In the last two, the parse function returns XRCS_ERROR.

After the callback functions have been set up, the XML parse functions may be called multiple times. Multiple calls might be useful for parsing multiple XML files while using the same group of callback functions.

Syntax

XRCS_Status JDEWINAPI XRCS_parseXMLFile(

const XRCS_hParser hParser,

const JCHAR* szFileName,

XRCS_hDocument* phDoc

);

Parameters

hParser | Input. A valid parser handle.
szFileName | Input. The XML data file to be parsed.
phDoc | Input. A pointer to a DOM document handle. For SAX, pass in NULL.


XRCS_parseXMLString.htm

XRCS_parseXMLString

Last Modified: EnterpriseOne | June 06, 2006

This function is the same as XRCS_parseXMLFile, with the only difference being the source of the XML text.

Syntax

XRCS_Status JDEWINAPI XRCS_parseXMLString(

XRCS_hParser hParser,

const JCHAR* szXMLString,

XRCS_hDocument* phDoc

);

Parameters

hParser | Input. A valid parser handle.
szXMLString | Input. An XML text string to be parsed.
phDoc | Input. A pointer to a DOM document handle. For SAX, pass in NULL


XRCS_setCallback.htm

XRCS_setCallback

Last Modified: EnterpriseOne | June 06, 2006

This function sets up the given callback function for the given SAX parsing event. The function prototype of the callback function must correspond to the type of callback. The callback function must be cast to (void *). The context pointer must be cast to (void *). The context pointer typically points to a user-defined data structure, where the callback functions can maintain the state of the parsing. The context pointer may be set to NULL if it is not needed.

You can set up multiple callback functions for the same parsing event type. However, the order in which they are called cannot be specified.

Syntax

XRCS_Status XRCS_setCallback( const XRCS_hParser hParser
, XRCS_CallbackType eCallbackType
, void *pCallbackFunction
, void *pContext
);

Parameters

hParser | Input. A valid parser handle.
eCallbackType | Input. A type of callback, specified by enum value.
pCallbackFunction | Input. A pointer to callback function.
pContext | A pointer to be passed to the callback function.


XRCS_setCallbackWithOption.htm

XRCS_setCallbackWithOption

Last Modified: EnterpriseOne | June 06, 2006

This function is the same as XRCS_setCallback, with the ability to specify an option. The type of option that may be specified is based upon the type of parsing event. Some types of options require a value, in which case the value should always be cast to (void *). If no value is required, a NULL can be used. The system currently supports two types of options.

For the start-of-element and end-of-element event types, an optional, specified local name may be passed in. This option type is identified by the enum value, XRCS_CBOPT_ELEM_LOCAL_NAME. The option value would be a null-terminated string (JCHAR *) for the element name. The callback function will be triggered only when the local name for the element matches the passed-in name.

For the characters event type, you have the option to retrieve the text following the end of an element. The option type is identified by the enum value, XRCS_CBOPT_CHARS_AFTER_ELEM. The option value is ignored, so you should set it to NULL. For typical XML data, the characters after the end of an element are just white space and carriage returns and so do not provide any useful information. On the other hand, XML display documents could have useful display information after the end of an element. The default is to ignore any text following the end of an element.

Syntax

XRCS_Status XRCS_setCallbackWithOption(

const XRCS_hParser hParser,

XRCS_CallbackType eCallbackType,

void * pCallbackFunction,

void * pContext,

XRCS_CallbackOptionType eOptionType,

void * OptionValue

);

Parameters

hParser | Input. A valid parser handle.
eCallbackType | Input. A type of callback, specified by enum value.
pCallbackFunction | Input. A pointer to callback function.
pContext | Input. A pointer to be passed to the callback function.
eOptionType | Input. A type of option, specified by enum value.
pOptionValue | Input. A value for the option. Not all options require a value.


XRCS_terminateEngine.htm

XRCS_terminateEngine

Last Modified: EnterpriseOne | June 06, 2006

This function performs a one-time cleanup of resources used by XercesWrapper and Xerces parsers. It must be the last function called from the client code.

Syntax

XRCS_Status XRCS_terminateEngine(void);


jdeXML_CheckSystemError

Last Modified: ERP 9.0| October 21, 2002

The jdeXML_CheckSystemError API is provided to check if there was any system level error while processing the outbound XAPI request .

Syntax

BOOL jdeXML_CheckSystemError(

PJSTR pXMLHandle /* XML Handle */

);

Parameters

Parameter | Description
PJSTR pXMLHandle | This is the handle to the XML document. It will be provided to the BSFN by the XML Service Kernel.

Return Values

BOOL : Returns TRUE or FALSE.

Example

/************************************************************************

* Variable declarations

************************************************************************/

ID idReturnCode = ER_SUCCESS;

JDEDB_RESULT rCode;

/************************************************************************

* Declare structures

************************************************************************/

/************************************************************************

* Declare pointers

************************************************************************/

HUSER hUser = NULL;

/************************************************************************

* Check for NULL pointers

************************************************************************/

if ((lpBhvrCom == (LPBHVRCOM) NULL) ||

(lpVoid == (LPVOID) NULL) ||

(lpDS == (LPDSD907001A) NULL))

{

jdeErrorSet (lpBhvrCom, lpVoid, (ID) 0, _J("4363"), (LPVOID) NULL);

return ER_ERROR;

}

/************************************************************************

* Set pointers

************************************************************************/

rCode = JDB_InitBhvr(lpBhvrCom, &hUser, NULL, JDEDB_COMMIT_AUTO);

if (rCode != JDEDB_PASSED)

{

jdeSetGBRError(lpBhvrCom, lpVoid, 0, _J("078S"));

return ER_ERROR;

}

/************************************************************************

* Main Processing

************************************************************************/

if(jdeXML_CheckSystemError(lpDS->szXMLHandle))

{

jdeTraceSz1(NULL, _J("There is system error in XAPI %ls. Stop parsing document...\n"), lpDS->szXMLHandle);

}

else

{

if(I907001B_testDSParseAPIs(lpDS) == ER_SUCCESS)

{

jdeTraceSz1(NULL, _J("testDSParseAPIs for %ls parsed successfully...\n"), lpDS->szXMLHandle);

idReturnCode = ER_SUCCESS;

}

else

{

jdeTraceSz1(NULL, _J("Could not parse testDSParseAPIs %ls\n"), lpDS->szXMLHandle);

idReturnCode = ER_ERROR;

}

if(I907001B_testErrorParseAPIs(lpDS) == ER_SUCCESS)

{

jdeTraceSz1(NULL, _J("testErrorParseAPIs for %ls parsed successfully...\n"), lpDS->szXMLHandle);

idReturnCode = ER_SUCCESS;

}

else

{

jdeTraceSz1(NULL, _J("Could not parse testErrorParseAPIs %ls\n"), lpDS->szXMLHandle);

idReturnCode = ER_ERROR;

}

}

I907001B_SendMessageToClient(lpBhvrCom, lpDS);

/************************************************************************

* Function Clean Up

************************************************************************/

JDB_FreeBhvr(hUser);

Additional Notes

None

See Also

· jdeXML_GetDSCount

· jdeXML_GetDSName

· jdeXML_ParseDS

· jdeXML_DeleteXML

· Interop Guide


JdeXML_GetErrorCount

Last Modified: ERP 9.0| October 21, 2002

The jdeXML_GetErrorCount API will return the number of business errors present in the inbound XAPI response document.

Syntax

int jdeXML_GetErrorCount(

PJSTR pXMLHandle /* XML Handle */

);

Parameters

Parameter | Description
LPSTR pXMLHandle | This is the handle to the inbound XAPI request document. It will be provided to the BSFN by the XML Service Kernel.

Return Values

int : Returns the number of errors in the XAPI response document.

Example

NID DSName = {0};

JCHAR* szDSNameA = _J("D907001A");

DSD907001A zDSA = {0};

int iDSCount = jdeXML_GetDSCount(lpDS->szXMLHandle);

JCHAR szXMLHandle[1024];

jdeTraceSz1(NULL, _J("For XML Handle: %ls, "), lpDS->szXMLHandle);

jdeTraceSz1(NULL, _J("found: %d data structures.\n\n"), iDSCount);

jdeStrncpy( (JCHAR*)szXMLHandle, (JCHAR*)lpDS->szXMLHandle, DIM(szXMLHandle));

if( lpDS->cDefaultAddressLine1 != '2' )

{

jdeTraceSz(NULL, _J("B907001C - Calling Parsing\n"));

for(i = 0; i < iDSCount; i++)

{

jdeXML_GetDSName(lpDS->szXMLHandle, i, DSName);

if(jdeStrlen(DSName)>0)

{

if(!jdeNIDcmp(DSName, szDSNameA))

{

jdeXML_ParseDS(lpDS->szXMLHandle, i, &zDSA, sizeof(zDSA));

memcpy( lpDS, &zDSA, sizeof(zDSA) );

jdeStrncpy( (JCHAR*)lpDS->szXMLHandle, (JCHAR*)szXMLHandle, DIM(szXMLHandle));

}

}

else

{

jdeTraceSz(NULL, _J("DSNAME not found\n"));

idReturnCode = ER_ERROR;

}

}

}

else

{

if( jdeXML_GetErrorCount(lpDS->szXMLHandle) > 0 )

{

if( jdeXML_SetErrors(lpDS->szXMLHandle, lpBhvrCom, lpVoid) == FALSE )

{

jdeTraceSz(NULL, _J("jdeXML_SetErrors failed.\n"));

idReturnCode = ER_ERROR;

}

}

}

Additional Notes

None

See Also

· jdeXML_SetErrors

· jdeXML_GetDSCount

· jdeXML_GetDSName

· jdeXML_ParseDS

· jdeXML_DeleteXML

· Interop Guide


jdeXML_ParseNextDSByName

Last Modified: ERP 9.0| October 21, 2002

The jdeXML_ParseNextDSByName API parses DS till no more DS found for the particular DS Name in the XML document.

Syntax

BOOL jdeXML_ParseNextDSByName (PJSTR pXMLHandle, JCHAR* DSName, LPVOID pData, int iDataSize)

Parameters

Parameter | Description
PJSTR pXMLHandle | This is the handle to the XML document. It will be provided to the BSFN by the XML Service Kernel.
JCHAR* DSName | This is where the name of the DSTR will be returned.
LPVOID pData | This is a pointer to the actual EnterpriseOne DSTR. (i.e. if the DSTR is DSD001, you will pass “&DSD001”)
int iDataSize | This is the size of the actual EnterpriseOne DSTR. (i.e. if the DSTR is DSD001, you will pass “sizeof(DSD001)”.

Return Values

BOOL : Returns TRUE or FALSE.

Example

if(jdeXML_PrepareDSListForIterationByName(pXMLHandle, szDSNameA))

{

bGetNextDS = jdeXML_ParseNextDSByName(pXMLHandle,szDSNameA, &DSD4205030A, sizeof(DSD4205030A));

while(bGetNextDS)

{

jdePrintf(_J("Parsed DS D4205030A successfully\n"));

bGetNextDS = jdeXML_ParseNextDSByName(pXMLHandle,szDSNameA, &DSD4205030A, sizeof(DSD4205030A));

}

}

Additional Notes

None

See Also

· jdeXML_GetDSCount

· jdeXML_GetDSName

· jdeXML_ParseDS

· jdeXML_DeleteXML

· jdeXML_PrepareDSListForIterationByName

· Interop Guide


jdeXML_PrepareDSListForIterationByName

Last Modified: ERP 9.0| October 21, 2002

The jdeXML_PrepareDSListForIterationByName API will find and reset DSName list for particular DSName in the XML document specified by the XMLHandle.

Syntax

bool jdeXML_PrepareDSListForIterationByName (

PJSTR pXMLHandle, /* XML Handle */

JCHAR* DSName /* Data Structure Name */

);

Parameters

Parameter | Description
PJSTR pXMLHandle | This is the handle to the XML document. It will be provided to the BSFN by the XML Service Kernel.
JCHAR* DSName | This is the name of the data structure.

Return Values

bool : Returns true or false.

Example

if(jdeXML_PrepareDSListForIterationByName(pXMLHandle, szDSNameA))

{

bGetNextDS = jdeXML_ParseNextDSByName(pXMLHandle,szDSNameA, &DSD4205030A, sizeof(DSD4205030A));

while(bGetNextDS)

{

jdePrintf(_J("Parsed DS D4205030A successfully\n"));

bGetNextDS = jdeXML_ParseNextDSByName(pXMLHandle,szDSNameA, &DSD4205030A, sizeof(DSD4205030A));

}

}

else

{

jdePrintf(_J("DSNAME D4205030A not found\n"));

}

Additional Notes

None

See Also

· jdeXML_GetDSCount

· jdeXML_GetDSName

· jdeXML_ParseDS

· jdeXML_DeleteXML

· jdeXML_ParseNextDSByName

· Interop Guide


jdeXML_SetErrors

Last Modified: ERP 9.0| October 21, 2002

The jdeXML_SetErrors API is provided to transfer the error from the XAPI document to the BHVRCOM of the calling business function.

Syntax

BOOL jdeXML_SetErrors(

PJSTR pXMLHandle /* XML Handle */,

LPBHVRCOM lpBhvrCom /* Pointer to BHVRCOM*/,

LPVOID lpVoid /* Returned name of DSTR */,

);

Parameters

Parameter | Description
PJSTR pXMLHandle | This is the handle to the XML document. It will be provided to the BSFN by the XML Service Kernel.
LPBHVRCOM lpBhvrCom | This is a pointer to the BHVRCOM.
LPVOID lpVoid | This is a pointer to the actual error data

Return Values

BOOL : Returns TRUE or FALSE.

Example

NID DSName = {0};

JCHAR* szDSNameA = _J("D907001A");

DSD907001A zDSA = {0};

int iDSCount = jdeXML_GetDSCount(lpDS->szXMLHandle);

JCHAR szXMLHandle[1024];

jdeTraceSz1(NULL, _J("For XML Handle: %ls, "), lpDS->szXMLHandle);

jdeTraceSz1(NULL, _J("found: %d data structures.\n\n"), iDSCount);

jdeStrncpy( (JCHAR*)szXMLHandle, (JCHAR*)lpDS->szXMLHandle, DIM(szXMLHandle));

if( lpDS->cDefaultAddressLine1 != '2' )

{

jdeTraceSz(NULL, _J("B907001C - Calling Parsing\n"));

for(i = 0; i < iDSCount; i++)

{

jdeXML_GetDSName(lpDS->szXMLHandle, i, DSName);

if(jdeStrlen(DSName)>0)

{

if(!jdeNIDcmp(DSName, szDSNameA))

{

jdeXML_ParseDS(lpDS->szXMLHandle, i, &zDSA, sizeof(zDSA));

memcpy( lpDS, &zDSA, sizeof(zDSA) );

jdeStrncpy( (JCHAR*)lpDS->szXMLHandle, (JCHAR*)szXMLHandle, DIM(szXMLHandle));

}

}

else

{

jdeTraceSz(NULL, _J("DSNAME not found\n"));

idReturnCode = ER_ERROR;

}

}

}

else

{

if( jdeXML_GetErrorCount(lpDS->szXMLHandle) > 0 )

{

if( jdeXML_SetErrors(lpDS->szXMLHandle, lpBhvrCom, lpVoid) == FALSE )

{

jdeTraceSz(NULL, _J("jdeXML_SetErrors failed.\n"));

idReturnCode = ER_ERROR;

}

}

}

Additional Notes

None

See Also

· jdeXML_GetErrorCount

· jdeXML_GetDSCount

· jdeXML_GetDSName

· jdeXML_ParseDS

· jdeXML_DeleteXML

· Interop Guide


jdeXMLRequest_DeleteXML

jdeXMLRequest

Last Modified: EnterpriseOne® Xe| July 19, 2000

Purpose

Perform multiple business function calls in the scope of one or more transactions using a XML document.

This API can also be used to execute EnterpriseOne® JDB APIs using a XML document (XML based transaction) within the EnterpriseOne® Enterprise Server.

Syntax

char * jdeXMLRequest(const char *szHostName, unsigned short usPort, const

int nNetTimeout , void *XML, in size

Parameters

Parameter | Notes | Usage
szHostName | EnterpriseOne® enterprise server host name |
usPort | EnterpriseOne® enterprise server port number |
nNetTimeout | Time out value for the request |
XML | Input XML document | The format of the input XML document is described in the EnterpriseOne® XML Call Object and the EnterpriseOne® XML inbound transaction documents
size | XML document size | A value less than or equal to zero indicates that the XML parameter is a NULL terminated string. Size will be obtained from the string.

Return Value

XML response string/

Example

char* pszResp = jdeXMLRequest(“ntintel5”, 6096, 60, (void*)pszXML), 0);


JdeXMLRequest_GetDSCount

Last Modified: ERP 9.0| October 21, 2002

The jdeXMLRequest_GetDSCount API will return the number of EnterpriseOne data structures stored in the inbound XAPI request document specified by the XMLHandle.

Syntax

int jdeXMLRequest_GetDSCount(

PJSTR pXMLHandle /* XML Handle */

);

Parameters

Parameter | Description
LPSTR pXMLHandle | This is the handle to the inbound XAPI request document. It will be provided to the BSFN by the XML Service Kernel.

Return Values

int : Returns the number of EnterpriseOne Data Structures.

Example

NID DSName = {0};

int i;

JCHAR* szDSNameA = _J("D907001A");

/************************************************************************

* Main Processing

************************************************************************/

int iDSCount = jdeXMLRequest_GetDSCount(lpDS->szXMLHandle);

jdeTraceSz1(NULL, _J("For XML Handle: %ls, "), lpDS->szXMLHandle);

jdeTraceSz1(NULL, _J("found: %d data structures.\n\n"), iDSCount);

for(i = 0; i < iDSCount; i++)

{

jdeXMLRequest_GetDSName(lpDS->szXMLHandle, i, DSName);

if(jdeStrlen(DSName)>0)

{

if(!jdeNIDcmp(DSName, szDSNameA))

{

MATH_NUMERIC zAN8 = {0};

JCHAR szXMLHandle[1024];

jdeMemset(szXMLHandle, _J('\0'), sizeof(szXMLHandle));

jdeStrncpy( (JCHAR*)szXMLHandle, (JCHAR*)lpDS->szXMLHandle, DIM(szXMLHandle));

jdeXMLRequest_ParseDS(szXMLHandle, i, lpDS, sizeof(DSD907001A));

jdeStrncpy( (JCHAR*)lpDS->szXMLHandle, (JCHAR*)szXMLHandle, DIM(szXMLHandle));

I907001A_getMaxABNumber(hUser, &zAN8);

I907001A_insertRecord(hUser, lpDS, &zAN8);

}

}

else

{

jdeTraceSz(NULL, _J("DSNAME not found"));

}

}

Additional Notes

None

See Also

· jdeXMLRequest_GetDSName

· jdeXMLRequest_ParseDS

· jdeXMLRequest_DeleteXML

· Interop Guide


jdeXMLRequest_GetDSName

Last Modified: ERP 9.0| October 21, 2002

The jdeXMLRequest_GetDSName API is provided to return the name of the EnterpriseOne data structure at the given position in the inbound XAPI request document.

Syntax

BOOL jdeXMLRequest_GetDSName(

PJSTR pXMLHandle /* XML Handle */,

int index /* Index of DSTR in XML */,

NID DSName /* Returned name of DSTR */

);

Parameters

Parameter | Description
PJSTR pXMLHandle | This is the handle to the inbound XAPI request document. It will be provided to the BSFN by the XML Service Kernel.
int index | This is the 0-based location of the DSTR in the XML document. (i.e. the first DSTR is at index=0, the second DSTR is at index=1, etc.)
NID DSName | This is where the name of the DSTR will be returned.

Return Values

BOOL : Returns TRUE or FALSE.

Example

NID DSName = {0};

int i;

JCHAR* szDSNameA = _J("D907001A");

/************************************************************************

* Main Processing

************************************************************************/

int iDSCount = jdeXMLRequest_GetDSCount(lpDS->szXMLHandle);

jdeTraceSz1(NULL, _J("For XML Handle: %ls, "), lpDS->szXMLHandle);

jdeTraceSz1(NULL, _J("found: %d data structures.\n\n"), iDSCount);

for(i = 0; i < iDSCount; i++)

{

jdeXMLRequest_GetDSName(lpDS->szXMLHandle, i, DSName);

if(jdeStrlen(DSName)>0)

{

if(!jdeNIDcmp(DSName, szDSNameA))

{

MATH_NUMERIC zAN8 = {0};

JCHAR szXMLHandle[1024];

jdeMemset(szXMLHandle, _J('\0'), sizeof(szXMLHandle));

jdeStrncpy( (JCHAR*)szXMLHandle, (JCHAR*)lpDS->szXMLHandle, DIM(szXMLHandle));

jdeXMLRequest_ParseDS(szXMLHandle, i, lpDS, sizeof(DSD907001A));

jdeStrncpy( (JCHAR*)lpDS->szXMLHandle, (JCHAR*)szXMLHandle, DIM(szXMLHandle));

I907001A_getMaxABNumber(hUser, &zAN8);

I907001A_insertRecord(hUser, lpDS, &zAN8);

}

}

else

{

jdeTraceSz(NULL, _J("DSNAME not found"));

}

}

Additional Notes

None

See Also

· jdeXMLRequest_GetDSCount

· jdeXMLRequest_ParseDS

· jdeXMLRequest_DeleteXML

· Interop Guide


jdeXMLRequest_ParseDS

Last Modified: ERP 9.0| October 21, 2002

The jdeXMLRequest_ParseDS API is provided to return the actual EnterpriseOne data structure at the given position in the inbound XAPI request document.

Syntax

BOOL jdeXMLRequest_ParseDS(

PJSTR pXMLHandle /* XML Handle */,

int index /* Index of DSTR in XML */,

LPVOID pData /* Returned name of DSTR */,

int iDataSize /* Returned name of DSTR */

);

Parameters

Parameter | Description
PJSTR pXMLHandle | This is the handle to the inbound XAPI request document. It will be provided to the BSFN by the XML Service Kernel.
int index | This is the 0-based location of the DSTR in the XML document. (i.e. the first DSTR is at index=0, the second DSTR is at index=1, etc.)
LPVOID pData | This is a pointer to the actual EnterpriseOne DSTR. (i.e. if the DSTR is DSD001, you will pass “&DSD001”)
int iDataSize | This is the size of the actual EnterpriseOne DSTR. (i.e. if the DSTR is DSD001, you will pass “sizeof(DSD001)”.

Return Values

BOOL : Returns TRUE or FALSE.

Example

NID DSName = {0};

int i;

JCHAR* szDSNameA = _J("D907001A");

/************************************************************************

* Main Processing

************************************************************************/

int iDSCount = jdeXMLRequest_GetDSCount(lpDS->szXMLHandle);

jdeTraceSz1(NULL, _J("For XML Handle: %ls, "), lpDS->szXMLHandle);

jdeTraceSz1(NULL, _J("found: %d data structures.\n\n"), iDSCount);

for(i = 0; i < iDSCount; i++)

{

jdeXMLRequest_GetDSName(lpDS->szXMLHandle, i, DSName);

if(jdeStrlen(DSName)>0)

{

if(!jdeNIDcmp(DSName, szDSNameA))

{

MATH_NUMERIC zAN8 = {0};

JCHAR szXMLHandle[1024];

jdeMemset(szXMLHandle, _J('\0'), sizeof(szXMLHandle));

jdeStrncpy( (JCHAR*)szXMLHandle, (JCHAR*)lpDS->szXMLHandle, DIM(szXMLHandle));

jdeXMLRequest_ParseDS(szXMLHandle, i, lpDS, sizeof(DSD907001A));

jdeStrncpy( (JCHAR*)lpDS->szXMLHandle, (JCHAR*)szXMLHandle, DIM(szXMLHandle));

I907001A_getMaxABNumber(hUser, &zAN8);

I907001A_insertRecord(hUser, lpDS, &zAN8);

}

}

else

{

jdeTraceSz(NULL, _J("DSNAME not found"));

}

}

Additional Notes

None

See Also

· jdeXMLRequest_GetDSCount

· jdeXMLRequest_GetDSName

· jdeXMLRequest_DeleteXML

· Interop Guide


jdeXMLRequest_PrepareDSListForIterationByName

Last Modified: ERP 9.0| October 21, 2002

The jdeXMLRequest_PrepareDSListForIterationByName API will find and reset DSName list for particular DSName stored in the XML document specified by the XMLHandle.

Syntax

bool jdeXMLRequest_PrepareDSListForIterationByName (

PJSTR pXMLHandle, /* XML Handle */

JCHAR* DSName /* Data Structure Name */

);

Parameters

Parameter | Description
LPSTR pXMLHandle | This is the handle to the XML document. It will be provided to the BSFN by the XML Service Kernel.
JCHAR* DSName | This is the name of the data structure.

Return Values

bool : Returns true or false.

Example

if(jdeXMLRequest_PrepareDSListForIterationByName(pXMLHandle, szDSNameH))

{

bGetNextDS = jdeXMLRequest_ParseNextDSByName(pXMLHandle,szDSNameH, &pDataH, sizeof(pDataH));

while(bGetNextDS)

{

jdePrintf(_J("Parsed DSD4200310H successfully\n"));

bGetNextDS = jdeXMLRequest_ParseNextDSByName(pXMLHandle,szDSNameH, &pDataH, sizeof(pDataH));

}

}

else

{

jdePrintf(_J("DSNAME DSD4200310H not found\n"));

}

Additional Notes

None

See Also

· jdeXMLRequest_GetDSCount

· jdeXMLRequest_GetDSName

· jdeXMLRequest_ParseDS

· jdeXMLRequest_DeleteXML

· jdeXMLRequest_ParseNextDSByName

· Interop Guide


jdeXML_DeleteXML

Last Modified: EnterpriseOne| November 6, 2001

The jdeXML_DeleteXML API is provided to delete the XML document from both memory and disc. It should be called when you are finished with the XML document.

Syntax

BOOL jdeXML_DeleteXML(PJSTR pXMLHandle)

Parameters

Parameter | Description
PJSTR pXMLHandle | This is the handle to the XML document. It will be provided to the BSFN by the XML Service Kernel.

Return Values

BOOL : Returns TRUE or FALSE.

Example

JDEBFRTN (ID) JDEBFWINAPI OrderPromiseCallback (LPBHVRCOM lpBhvrCom, LPVOID lpVoid, LPDSD4205060 lpDS)

{

BOOL bExit;

BOOL bClientFound;

int x;

int iRecordCount;

int iCurrentRecord;

int iHeaderCount;

NID nidDSName;

char cDisplayBeforeAcceptMode;

char szOrderNum[32];

char szOrderType[3];

char szOrderCompany[6];

int iLength = 0;

int iPipeCount = 0;

char b4buf[128];

char szLogModule[42] = "OrderPromiseCallback";

char szLogString[270] = {0};

BOOL bLoggingOn = TRUE;

DSD4205030A dsD4205030A = {0};

DSD4205030B dsD4205030B = {0};

DSD4205030 dsD4205030 = {0};

if ( (lpBhvrCom == (LPBHVRCOM) NULL)

|| (lpVoid == (LPVOID) NULL)

|| (lpDS == (LPDSD4205060) NULL))

{

jdeErrorSet (lpBhvrCom, lpVoid, (ID) 0, "4363", (LPVOID) NULL);

return ER_ERROR;

}

iRecordCount= 0;

iCurrentRecord = 0;

iHeaderCount = 0;

cDisplayBeforeAcceptMode = ' ';

bExit = FALSE;

bClientFound = FALSE;

iLength = 0;

iPipeCount = 0;

memset(szOrderNum,'\0',sizeof(szOrderNum));

memset(szOrderType,'\0',sizeof(szOrderType));

memset(szOrderCompany,'\0',sizeof(szOrderCompany));

memset(&dsD4205030A,'\0',sizeof(dsD4205030A));

memset(&dsD4205030,'\0',sizeof(dsD4205030));

_strtime( b4buf );

sprintf(szLogString, "Entering CallBack, %s",b4buf );

jdeWriteLog(szLogModule, 0, szLogString);

#ifdef jdeXAPI_CALLS_ENABLED

if(jdeXAPI_IsCallTypeEnabled("XAPIOPOUT") &&

jdeXAPI_IsCallTypeEnabled("XAPIOPIN") )

{

iRecordCount = jdeXML_GetDSCount(lpDS->szXMLHandle);

_strtime( b4buf );

sprintf(szLogString, "GetDSCount, %s, Num DS %d",b4buf,iRecordCount );

jdeWriteLog(szLogModule, 0, szLogString);

iHeaderCount = 0;

_strtime( b4buf );

sprintf(szLogString, "BeginParse, %s",b4buf );

jdeWriteLog(szLogModule, 0, szLogString);

if (iRecordCount > 0)

{

for (iCurrentRecord = 0; iCurrentRecord < iRecordCount; iCurrentRecord++)

{

jdeXML_GetDSName(lpDS->szXMLHandle,

iCurrentRecord,

nidDSName);

if (jdestrcmp(nidDSName,(const char*)"D4205030A") == 0)

{

jdeXML_ParseDS( lpDS->szXMLHandle,

iCurrentRecord,

&dsD4205030A,

sizeof(DSD4205030A));

}

else

{

jdeXML_ParseDS( lpDS->szXMLHandle,

iCurrentRecord,

&dsD4205030B,

sizeof(DSD4205030B));

}

}

_strtime( b4buf );

sprintf(szLogString, "EndParse, %s , Num Recs, %d",b4buf, iCurrentRecord );

jdeWriteLog(szLogModule, 0, szLogString);

}

if (iCurrentRecord == iRecordCount)

{

jdeXML_DeleteXML(lpDS->szXMLHandle);

}

}

#endif

return (ER_SUCCESS);

}

Additional Notes

None

See Also

· jdeXML_GetDSCount

· jdeXML_GetDSName

· jdeXML_ParseDS

· Interop Guide


jdeXML_GetDSCount

Last Modified: EnterpriseOne| November 6, 2001

The jdeXML_GetDSCount API will return the number of EnterpriseOne data structures stored in the XML document specified by the XMLHandle.

Syntax

int jdeXML_GetDSCount(PJSTR pXMLHandle)

Parameters

Parameter | Description
PJSTR pXMLHandle | This is the handle to the XML document. It will be provided to the BSFN by the XML Service Kernel.

Return Values

Int : Returns the number of EnterpriseOne DataStructures.

Example

iRecordCount = 0;

iRecordCount = jdeXML_GetDSCount(lpDS->szXMLHandle);

Additional Notes

None

See Also

· jdeXML_GetDSName

· jdeXML_ParseDS

· jdeXML_DeleteXML

· Interop Guide


jdeXML_GetDSName

Last Modified: EnterpriseOne| November 6, 2001

The jdeXML_GetDSName API is provided to return the name of the EnterpriseOne data structure at the given position in the XML document.

Syntax

BOOL jdeXML_GetDSName (PJSTR pXMLHandle, int index, NID DSName)

Parameters

Parameter | Description
PJSTR pXMLHandle | This is the handle to the XML document. It will be provided to the BSFN by the XML Service Kernel.
int index | This is the 0-based location of the DSTR in the XML document. (i.e. the first DSTR is at index=0, the second DSTR is at index=1, etc.)
NID DSName | This is where the name of the DSTR will be returned.

Return Values

BOOL : Returns TRUE or FALSE.

Example

LPDSD4205030 lpDS;

iCurrentRecord = 0;

NID nidDSName;

iRecordCount = 0;

iRecordCount = jdeXML_GetDSCount(lpDS->szXMLHandle);

for (iCurrentRecord = 0; iCurrentRecord < iRecordCount; iCurrentRecord++)

{

if (!jdeXML_GetDSName(lpDS->szXMLHandle, iCurrentRecord,

nidDSName))

{

bExit = TRUE;

if (bLoggingOn)

{

sprintf(szLogString, "%s", "jdeXML_GetDSName failed.");

jdeWriteLog(szLogModule, 0, szLogString);

}

}

}

Additional Notes

None

See Also

· jdeXML_GetDSCount

· jdeXML_ParseDS

· jdeXML_DeleteXML

· Interop Guide


jdeXML_ParseDS.htm

jdeXML_ParseDS

Last Modified: EnterpriseOne| November 6, 2001

The jdeXML_ParseDS API is provided to return the actual EnterpriseOne data structure at the given position in the XML document.

Syntax

BOOL jdeXML_ParseDS(PJSTR pXMLHandle, int index, LPVOID pData, int iDataSize)

Parameters

Parameter | Description
PJSTR pXMLHandle | This is the handle to the XML document. It will be provided to the BSFN by the XML Service Kernel.
int index | This is the 0-based location of the DSTR in the XML document. (i.e. the first DSTR is at index=0, the second DSTR is at index=1, etc.)
LPVOID pData | This is a pointer to the actual EnterpriseOne DSTR. (i.e. if the DSTR is DSD001, you will pass “&DSD001”)
int iDataSize | This is the size of the actual EnterpriseOne DSTR. (i.e. if the DSTR is DSD001, you will pass “sizeof(DSD001)”.

Return Values

BOOL : Returns TRUE or FALSE.

Example

LPDSD4205030 lpDS;

iCurrentRecord = 0;

DSD4205030A dsD4205030A = {0};

if (jdeXML_ParseDS( lpDS->szXMLHandle,

iCurrentRecord,

&dsD4205030A,

sizeof(DSD4205030A)) )

{

/* Log */

if (bLoggingOn)

{

sprintf(szLogString, "%s", "D4205030A header DS found.");

jdeWriteLog(szLogModule, 0, szLogString);

}

}

Additional Notes

None

See Also

· jdeXML_GetDSCount

· jdeXML_GetDSName

· jdeXML_DeleteXML

· Interop Guide


SystemFunctions

System Functions performs generalized control functions. They are not application specific and perform a variety of general tasks, such as disabling or enabling a control or sending a message. You access and use the system function APIs by using the EnterpriseOne toolset

System Function consist of the following Categories:

 | Batch Applications
app.gif (808 bytes) | Batch Engine
 | E-Mail
 | Interactive Application
app.gif (808 bytes) | Table Conversion System Functions
 | Telephony
 | Tree


Batch Application System Functions

Batch application system functions are triggered at certain events while processing a batch job, such as a report or a UBE.

Batch Application consist of the following System Functions:

 | ABGT
app.gif (808 bytes) | CheckDataSelection/Sequence
 | ClearUserSelection
 | ClearUserSequence
app.gif (808 bytes) | CopyCurrencyInformation
 | DeleteMessage
app.gif (808 bytes) | DoCustomSection
 | DoRunningTotal
app.gif (808 bytes) | ForwardMessage
app.gif (808 bytes) | HideObject
 | HideSection
app.gif (808 bytes) | InitRunningTotal
 | SendMessage
app.gif (808 bytes) | SetSelectionAppendFlag
 | SetSequenceAppendFlag
app.gif (808 bytes) | SetUBEError
 | SetUserSelection
app.gif (808 bytes) | SetUserSequence
 | ShowObject
app.gif (808 bytes) | ShowSection
 | StopBatchProcessing
app.gif (808 bytes) | StopSectionProcessing
 | SuppressSectionWrite
app.gif (808 bytes) | TemplateSubstitution
 | UpdateMessage
app.gif (808 bytes) | UseDataSel/SeqFromASection
 | ZeroRunningTotal

The following is a subset of the Batch Application System Functions:

Transaction Processing


ABGT

Last Modified: B733

All of the entries under Media Objects allow the user to retrieve generic text into a UBE object or variable.

Parameters

Parameter | Description | I/O | Required | Notes
Action | For UBE, the only allowed action is Get Text |  |  |
Status | For UBE, the “Status” parameter should be the Report Variable or ER Variable that receives the Generic Text |  |  |
Address Number | Each entry under Media Objects will accept some key values that allow the system to retrieve the correct Generic Text. In the case of ABGT, the system will retrieve text associated with an Address Number |  |  |

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

Each of the entries under Media Objects uses the same first and second parameters. Subsequent parameters always represent the key used to retrieve the text.


CheckDataSelection/Sequence

Last Modified: B733

CheckDataSelection/Sequence performs a search to see whether a given data item exists within the data selection or data sequencing for a given section of a report. This allows the user to perform certain logic if that data item does or does not exist.

Parameters

Parameter | Description | I/O | Required | Notes
Group\Version | The report template, version name | I | N | If any of the parameters is blank or NULL, current report/version will be used.
Section | Section ID | I | Y | This parameter must be a valid section from the chosen report.
Flag | This flag determines whether the data item will be searched for with the data selection or data sequencing. | I | Y |
Data Item | This is the data item that will be searched for. | I | Y |
Result | This is the where the return value for the function will be stored. If, after the function is called, this value is zero, then the data item was not found. Otherwise, it will contain the position at which the data item was first encountered. | O | Y |

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

This function is useful in the init section to determine whether to append or replace data selection/sequencing. Based on the design, it can also be used to check if the data selection was overwritten at the version level or not.

Related Function

Function Name | Function Description | Source Name | Description
SetSelection | Set Data Selection |  |
SetSequencing | Set Data Sequencing |  |
UseDataSel/SeqFromASection | Copy Data Selection/Sequencing from another section |  |


ClearUserSelection

Last Modified: B733

ClearUserSelection removes any existing selection criteria for the section.

Parameters

None

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

Because selection criteria will only typically be used within the initialization of a section, the call to this system function would probably want to be placed in the InitSection event.

Related Functions

Function Name | Function Description | Source Name | Description
SetSelectionAppendFlag | Sets a flag used by SetUserSelection. The flag determines whether to replace or append to the existing data selection information |  |
SetUserSelection | Adds or replaces data selection information for the current section |  |
ClearUserSequence | Removes existing data sequencing information for the current section |  |
SetSequenceAppnedFlag | Sets a flag used by SetUserSequence. The flag determines whether to replace or append the existing data sequencing information |  |
SetUserSequence | Adds or replaces data sequencing information for the current section. |  |


ClearUserSequence

Last Modified: B733

ClearUserSequence removes any sequencing information for the section.

Parameters

None

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

Because sequencing information will only typically be used within the initialization of a section, the call to this system function would probably want to be placed in the InitSection event.

Related Functions

Function Name | Function Description | Source Name | Description
ClearUserSelection | Removes existing data selection information for the current section. |  |
SetSelectionAppendFlag | Sets a flag used by SetUserSelection. The flag determines whether to replace or append to the existing data selection information. |  |
SetUserSelection | Adds or replaces data selection information for the current section. |  |
SetSequenceAppnedFlag | Sets a flag used by SetUserSequence. The flag determines whether to replace or append the existing data sequencing information. |  |
SetUserSequence | Adds or replaces data sequencing information for the current section. |  |


CopyCurrencyInformation

Last Modified: B733

CopyCurrencyInformation copies currency information from one object to another. This copies both the Currency and the number of decimal places for that currency from the From Control Structure to the To Control Structure.

Parameters

Parameter | Description | I/O | Required | Notes
To Control | Math Numeric | I | Y | This is the destination math numeric object.
From Control | Math Numeric | I | Y | This is the Source math numeric object.

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

The destination and the source must be math numeric objects only.

See Also

  • System Functions


DeleteMessage

Last Modified: B733.1 | June 08, 1999

DeleteMessage removes messages that were created while using the SendMessage system function.

Parameters

Parameter | Description | I/O | Required | Notes
MessageID | The unique identifier returned in the Message Key parameter of the SendMessage system function | I | Y |

Special Handling Instructions and Prerequisites

A numeric variable should be used to store the Message Key parameter returned by the Send Message system function. The same variable should then be used with the MessageID parameter of Delete Message.

Related Functions

Function Name | Function Description | Source Name | Description
Send Message | Creates a new message |  |
Update Message | Modifies information related to a message |  |


DoCustomSection

Last Modified: B733

DoCustomSection changes the normal flow of processing to include the processing of a custom section within a report. When this system function is called, the appropriate custom section begins processing as any normal section would. Once this custom section is complete, the flow of control returns to the appropriate ER line within the section that called it.

Parameters

Parameter | Description | I/O | Required | Notes
Section | This is the name of the custom section to be processed. | Input | Yes |

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

Custom sections may not be called at the PAGE_BREAK or INIT_SECTION events.


DoRunningTotal

Last Modified: B733

DoRunningTotal prints out all the accumulated objects that were created by InitRunningTotal and accumulated internally.

Parameters

None

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

This Function must be used in conjuncture with InitRunningTotal.

Related Functions

Function Name | Function Description
ZeroRunningTotal | Clears the Running Totals created by InitRunningTotal
InitRunningTotal | Creates a new Running Total which contains all the Printable Objects to be accumulated

See Also

  • System Functions

  • DoRunningTotal

  • InitRunningTotals

  • ZeroRunningTotal


ForwardMessage

Last Modified: B733.1 | June 08, 1999

ForwardMessage forwards an EnterpriseOne message automatically using a system function.

Parameters

Parameter | Description | I/O | Required | Notes
Recipient | Address # of Recipient to Forward Message | I | Y |
Mailbox | Mailbox to Forward Message | I | Y |
Subject | Subject of Forwarded Message | I | N |
Text | Text of Forwarded Message | I | N |
Not Available | Active Message | I | N | Not Currently Available
Message | The subject and text of the message can be derived from a data dictionary Item | I | N | Selecting <Define Message> will allow you to select a data dictionary Item which contains the desired message. You can also choose which values are used for text substitution, if the data dictionary item you selected contains variables within the message.
Change Mode | Whether to create a new message or move the existing one | I | Y | See Special Handling Instructions below.
Message Key | Email Serial # of existing Message | I/O | Y | Will return the email serial # of the forwarded message

Return Values

Return Value | Description
See below |

Special Handling Instructions and Prerequisites

If Change Mode is 0, then this system function will behave as you would normally expect a Forward Message function to – it will leave the original message alone and create a new message that includes the original message text inside it. In this case, the Message Key parameter will return the new email serial number.

If Change Mode is 1, then this system function will move the original message from the original recipient’s mailbox, to the new recipient’s mailbox, pre-pending the new message text. In this case, no new email is created, so the forwarded message will have the same email serial number as the original.

Related Functions

Function Name | Function Description | Source Name | Description
Update Message | Allows you to modify message information |  |
Delete Message | Allows you to remove a message |  |
Forward Message | Allows you to forward a message to another address book number |  |


HideObject

Last Modified: B733

HideObject hides an object at the occurrence of a particular condition or event.

Parameters

Parameter | Description | I/O | Required | Notes
Object | Object to be hidden on an event | I | Y | Object being any Report Variable or Report Constant Column.

Return Values

Return Value | Description
None |

Related Functions

Function Name | Function Description | Source Name | Description
Show Object | Displays a hidden Object on an event | Show Object |

See Also

  • System Functions

  • Hide Section

  • Show Section


HideSection

Last Modified: B733

HideSection hides a section when particular conditions are met.

Parameters

None.

Special Handling Instructions and Prerequisites

This is use with conditional statements (if/else).

Related Functions

Function Name | Function Description | Source Name | Description
Show Section | Display a Conditional Section | Show Section |

See Also

  • System Functions


InitRunningTotal

Last Modified: B733

InitRunningTotal creates a list of all the objects that are printing and accumulate all those that can be accumulated internally.

Parameters

None.

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

This function creates a new list of all the objects that are available and prepares it to be able to accumulate. This function is the first step in being able to print accumulated objects through DoRunningTotal.

Related Functions

Function Name | Function Description
ZeroRunningTotal | Clears the running totals created by InitRunningTotal.
DoRunningTotal | Prints out the Accumulated running totals created by InitRunningTotals.

See Also

  • System Functions

  • DoRunningTotal

  • ZeroRunningTotal


SendMessage

Last Modified: B733.1 | June 08, 1999

SendMessage sends a message through the EnterpriseOne mail system.

Parameters

Parameter | Description | I/O | Required | Notes
Recipient | The Address Book number of the person who is to receive the message or a fully qualified Internet e-mail address | I | Y |
Mailbox | The mailbox into which the message should be placed | I | Y | It ignores when an Internet e-mail address is used.
Subject | The string of characters which will be displayed on the subject line of the message | I | N |
Text | This text will be displayed as the main body of the message | I | N |
Active | You can select an EnterpriseOne application which will be available through a shortcut when the message is being viewed. | I | N | Selecting <Define Active Message> will allow you to select an application and form, and will then allow you to choose which values will be stored with the message and sent to the application when it is launched.
Message | The subject and text of the message can be derived from a data dictionary Item | I | N | Selecting <Define Message> will allow you to select a data dictionary Item which contains the desired message. You can also choose which values are used for text substitution, if the data dictionary item you selected contains variables within the message.
MessageKey | A serial number which is used to identify the message | O | N | If you want to record the message key, you must specify a numeric variable for this parameter.

Return Values

Send Message will return a message key which uniquely identifies the message within the system. You can use the Message Key value to subsequently modify or remove the message.

Special Handling Instructions and Prerequisites

Before a user can receive a message, their address book information must specify a mail preference. Messages can then be accessed through the work center application for internal e-mail, or through the user's mail program for external e-mail.

Related Functions

Function Name | Function Description | Source Name | Description
Update Message | Allows you to modify message information |  |
Delete Message | Allows you to remove a message |  |
Forward Message | Allows you to forward a message to another address book number |  |


SetSelectionAppendFlag

Last Modified: B733

SetSelectionAppendFlag sets a flag to determine whether selection criteria added by the system function SetUserSelection will be appended to or replace the existing selection criteria for that section.

Parameters

Parameter | Description | I/O | Required | Notes
Append Flag? | YES or a NO. YES means that selection criteria will be appended to the current criteria. | I | Y |

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

Because selection criteria will only typically be used within the initialization of a section, the call to this system function would probably want to be placed in the InitSection event. This function will also need to be called before the call to SetUserSelection if the criteria to be added through that system function must be appended.

Related Functions

Function Name | Function Description | Source Name | Description
ClearUserSelection | Removes existing data selection information for the current section. |  |
SetUserSelection | Adds or replaces data selection information for the current section. |  |
ClearUserSequence | Removes existing data sequencing information for the current section. |  |
SetSequenceAppnedFlag | Sets a flag used by SetUserSequence. The flag determines whether to replace or append the existing data sequencing information. |  |
SetUserSequence | Adds or replaces data sequencing information for the current section. |  |


SetSequenceAppendFlag

Last Modified: B733

SetSequenceAppendFlag sets a flag to determine whether sequencing information added by the system function SetUserSequence will be appended to or replace the existing sequencing information for that section.

Parameters

Parameter | Description | I/O | Required | Notes
Append Flag? | YES or a NO. YES means sequencing information will be appended to the current information. | Input | Yes |

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

Since sequencing information will only typically be used within the initialization of a section, the call to this system function would probably want to be placed in the InitSection event. This function will also need to be called before the call to SetUserSequence if the information to be added through that system function needs to be appended.

See Also

Function Name | Function Description | Source Name | Description
ClearUserSelection | Removes existing data selection information for the current section. |  |
SetSelectionAppendFlag | Sets a flag used by SetUserSelection. The flag determines whether to replace or append to the existing data selection information. |  |
SetUserSelection | Adds or replaces data selection information for the current section. |  |
ClearUserSequence | Removes existing data sequencing information for the current section |  |
SetUserSequence | Adds or replaces data sequencing information for the current section. |  |


SetUBEError

Last Modified: B733

SetUBEError sends an arbitrary error message to the user who launched the UBE.

Parameters

Parameter | Description | I/O | Required | Notes
Error Value | The text of the error message. | I | Y |

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

There are no special handling instructions or prerequisites.


SetUserSelection

Last Modified: B733

SetUserSelection provides users with a method of conditionally modifying data selection for a section. This system function allows users to utilize ER to determine whether or not to make changes. This works in conjunction with the data selection for a section set up through RDA. Users should call SetSelectionAppendFlag prior to calling this function to determine whether to replace or append to the existing data selection information for this section.

Parameters

Parameter | Description | I/O | Required | Notes
Item1 | This value is a Business View Column. | I | Y | This field must be a business view, because it is this value that will be returned from a fetch. Therefore, this value must be compared to determine whether it fits the data selection criteria.
Comparison | The values for this parameter can be Equals, Not Equals, Greater Than, Less Than, Greater Than Or Equal To, or Less Than Or Equal To. | I | Y | This field determines the type of comparison to be used between Item1 and Item2 when determining whether to include values.
Item2 | This field can be any literal value or object that can be compared with Item1. | I | Y | This field can be a business view column, constant, report variable, report constant, system value, system variable, or a literal value. The value of this field will be compared with Item1 when a fetch is done, to determine if the value returned from a fetch adheres to the data selection.
And/Or | This can be three values: And, Or, or None. | I | Y | ‘None’ is used when this is to be the first line of the selection criteria. The other two values should be used for subsequent lines. The value will specify whether this line should be treated as an ‘AND’ condition or an ‘OR’ condition.

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

Because selection criteria will only typically be used within the initialization of a section, the call to this system function would probably want to be placed in the InitSection event.

Related Functions

Function Name | Function Description | Source Name | Description
ClearUserSelection | Removes existing data selection information for the current section. |  |
SetSelectionAppendFlag | Sets a flag used by SetUserSelection. The flag determines whether to replace or append to the existing data selection information. |  |
ClearUserSequence | Removes existing data sequencing information for the current section. |  |
SetSequenceAppnedFlag | Sets a flag used by SetUserSequence. The flag determines whether to replace or append the existing data sequencing information. |  |
SetUserSequence | Adds or replaces data sequencing information for the current section. |  |


SetUserSequence

Last Modified: B733

SetUserSequence provides users with a method of conditionally modifying data sequencing for a section. This system function allows users to utilize ER to determine whether or not to make changes. This works in conjunction with the data sequencing for a section set up through RDA. Users should call SetSequenceAppendFlag prior to calling this function to determine whether to replace or append to the existing data sequencing information for this section.

Parameters

Parameter | Description | I/O | Required | Notes
Item | This value is a Business View Column | Input | Yes | This item can only be a business view, because only business view fields can be sorted on. The sequence information determines the order the information is returned from the database.
Sort Order | This parameter can have a value of either ASCENDING or DESCENDING. | Input | Yes |

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

Because sequencing information will only typically be used within the initialization of a section, the call to this system function would probably want to be placed in the InitSection event.

Related Functions

Function Name | Function Description | Source Name | Description
ClearUserSelection | Removes existing data selection information for the current section. |  |
SetSelectionAppendFlag | Sets a flag used by SetUserSelection. The flag determines whether to replace or append to the existing data selection information. |  |
SetUserSelection | Adds or replaces data selection information for the current section. |  |
ClearUserSequence | Removes existing data sequencing information for the current section |  |
SetSequenceAppnedFlag | Sets a flag used by SetUserSequence. The flag determines whether to replace or append the existing data sequencing information. |  |


ShowObject

Last Modified: B733

ShowObject displays hidden objects.

Parameters

Parameter | Description | I/O | Required | Notes
Object | Displays an object previously hidden by Hide Object | I | Y | Object being any Report Constant or a Report Variable Column

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

This does not affect objects that are hidden.

Related Functions

Function Name | Function Description | Source Name | Description
Hide Object | Hides an Object on an event | Hide Object |

Related Topics

  • System Functions

  • Hide Section

  • Show Section


ShowSection

Last Modified: B733

ShowSection displays a conditional section. This is use to display a section if a condition is met.

Parameters

None

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

Use in conjunction with Hide Section to unhide a hidden section on the event a condition is met.

Related Functions

Function Name | Function Description | Source Name | Description
Hide Section | Hide a conditional Section |  |

See Also

  • System Functions


StopBatchProcessing

Last Modified: B733

StopBatchProcessing terminates all processing on a report. The Output will still exist for any section that has been processed.

Parameters

None

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

This should only be called from within the AdvanceSection or DoSection event. Calling it from anywhere else will cause the report to process as normal.

Related Functions

Function Name | Function Description | Source Name | Description
StopBatchProcessing | The current section will stop processing immediately and continue on to the next section. |  |


StopSectionProcessing

Last Modified: B733

StopSectionProcessing stops processing immediately. If the current section is a Total or a Grand Total section, then the END_TOTAL_SECTION message will be sent to end that section. Otherwise, if the section does not have a business view attached, its state will be set to OS_UNPROCESSED. Regardless of whether or not it has a business view, ADV_SECTION message will then be sent.

Parameters

None

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This system function should only be called from within the DO_SECTION event. If it is called from anywhere else, the section will continue to process as normal.

Related Functions

Function Name | Function Description | Source Name | Description
StopBatchProcessing | Stops processing the report immediately. |  |
SuppressSectionWrite | Prevents the current record for a section from printing, but continues to process the rest of the section normally. |  |


SuppressSectionWrite

Last Modified: B733

SuppressSectionWrite causes the report to skip printing the current record and continue on to the next one. To accomplish this, a LAST_OBJECT message is sent to complete processing for this section for the current record. The section still processes as normal, printing all subsequent records.

Parameters

None

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

This system function will only take effect if it is called from within the DO_SECTION or COLUMN_INCLUSION event.


TemplateSubstitution

Last Modified: B733.1 | June 08, 1999

TemplateSubstitution allows the user to fill the message template with the substitution values and then receive the completed message template back in a text string. The output string can be displayed on the screen or printed on the report as generic text.

Parameters

Data Item | Description | I/O | Required | Notes
Message Template | The subject and text of the message can be derived from a data dictionary Item. This is the message to fill in with the values. | I | Y | Selecting <Define Message> will allow you to select a data dictionary Item which contains the desired message. You can also choose which values are used for text substitution, if the data dictionary item you selected contains variables within the message. When a message template is defined, it will prompt for substitution values.
Output Text | This is the string field to receive the text back. | O | Y |

Related Functions

Function Name | Function Description | Source Name | Description
Send Message | Sends a message to the user. |  |
Update Message | Updates a current message. |  |


UpdateMessage

Last Modified: B733.1 | June 08, 1999

UpdateMessage modifies information associated with a message that has already been added using SendMessage.

Parameters

Parameter

Description

I/O

Required

Notes

MessageKey

The MessageKey is the unique identifier returned by the Send Message system function.

I

Y

A numeric variable should be used to store the MessageKey from Send Message. That same numeric variable should be used here to identify the message you wish to modify.

Original Address

The Address Number for which the original message was intended.

I

Y

Update to Mailbox

The Mailbox to which the message should now be sent.

I

N

Status

The status value which the message should now carry.

I

N

  1. Unopened - The message has not been viewed.

  2. Opened - The message has been viewed

  3. Deleted - The message has been marked for deletion.

Update To Address

The new Address Number for the message.

I

N

Special Handling Instructions and Prerequisites

You must establish a MessageKey using the Send Message system function before you can correctly use Update Message.

Related Functions

Function Name | Function Description | Source Name | Description
Send Message | Creates a new message |  |
Delete Message | Removes a message |  |
Forward Message | Allows you to forward a message to another address book number |  |


UseDataSel/SeqFromASection

Last Modified: B733

UseDataSel/SeqFromASection retrieves the data selection and/or the data sequencing for a given section in a report and use it for the current section. This section does not have to be in the current report, it can be any valid section from any report. The source section must be attached to a business view that is compatible with the business view of the current section.

Parameters

Parameter | Description | I/O | Required | Notes
Group\Version | The Report Template, Version Name | I | N | If any of the parameters is blank or NULL, current report/version will be used.
Section | Section | I | Y | This parameter must be a valid section from the chosen report.
Flag | This flag specifies whether only data selection, only data sequencing, or both will be retrieved for the current section. | I | Y |

Return Values

Return Value | Description
None |

Special Handling Instructions and Prerequisites

Because data selection and data sequencing will only typically be used within the initialization of a section, the call to this system function must be placed in the InitSection event.

See Also

Function Name | Function Description | Source Name | Description
SetSelection | Set Data Selection |  |
SetSequencing | Set Data Sequencing |  |


ZeroRunningTotal

Last Modified: B733

ZeroRunningTotal resets running totals to zero for the current tabular section.


Transaction Processing

Transaction Processing consist of the following APIs:

Begin Transaction

Commit Transaction

Rollback Transaction


Begin Transaction

Last Modified: B73.3.1 | March 03, 1999

Begin Transaction will begin a transaction boundary. Table IO can use this boundary and business functions in order to implement commitment control within a report.

Parameters

Parameter | Description | I/O | Required | Notes
TransactionID | This value will be assigned by the System Function in order to give a unique identifier to this transaction boundary. | O | Y | This parameter is not currently used. It was added to help support future functionality.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

Only one transaction boundary can be started at a time.

Related Functions

Function Name | Function Description | Source Name | Description
Commit Transaction | Commits the specified transaction to the database. |  |
Rollback Transaction | Rolls back the specified transaction from the database. |  |

See Also

  • System Functions

  • Transaction Processing


Commit Transaction

Last Modified: B73.3.1 | March 03, 1999

Commit Transaction commits the specified transaction to the database.

Parameters

None.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This transaction must be started by the BeginTransaction system function.

Related Functions

Function Name | Function Description | Source Name | Description
Begin Transaction | Begins a new transaction boundary for the report. |  |
Rollback Transaction | Rolls back the specified transaction from the database. |  |

See Also

  • System Functions

  • Transaction Processing


Rollback Transaction

Last Modified: B73.3.1 | March 03, 1999

Rollback Transaction will rollback the specified transaction from the database.

Parameters

None

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This transaction must be started by the BeginTransaction system function.

Related Functions

Function Name | Function Description | Source Name | Description
Begin Transaction | Begins a new transaction boundary for the report. |  |
Commit Transaction | Commits the specified transaction to the database. |  |

See Also

  • System Functions

  • Transaction Processing


Batch Engine

Batch Engine consist of the following categories:

 | ubeReport
app.gif (808 bytes) | ubeSection
app.gif (808 bytes) | ubeTab


ubeReport

ubeReport consist of the following System Functions:

 | ubeReport_AddSubsystemRecord
app.gif (808 bytes) | ubeReport_DisableSendMessage
app.gif (808 bytes) | ubeReport_GetName
app.gif (808 bytes) | ubeReport_GetPageNumber
 | ubeReport_GetPreviewMode
app.gif (808 bytes) | ubeReport_GetSourceEnvironment
 | ubeReport_GetTargetEnvironment
app.gif (808 bytes) | ubeReport_IsTemplate
 | ubeReport_SetPageNumber
app.gif (808 bytes) | ubeReport_StopBatchProcess
app.gif (808 bytes) | ubeReport_StopBatchProcessWithError


ubeReport_AddSubsystemRecord

Last Modified: B73.3.1 | June 04, 1999

ubeReport_AddSubsystemRecord allows users to add a record to the EnterpriseOne Subsystem table (F986110). This record is then picked up by a subsystem report that is currently processing on a server. Records may be added to the subsystem table without having an associated subsystem report running. In this case, the records are processed once an associated subsystem report is started.

Parameters

Parameter | Description | I/O | Required | Notes
HUSER | Pointer to the hUser structure. | I | Y |
char * | Name of the subsystem report. | I | Y |
char * | Name of the subsystem version. | I | Y |
char * | Name of the environment to override to. | I | Y | While this field is required, it is not currently used. It will be used in the future.
char * | Name of the server to send the subsystem record to. | I | Y |
LPVOID | Pointer to the Report Interconnect Data Structure for the associated subsystem report. | I | Y | It is the responsibility of the business function to allocate and populate this structure correctly. This data structure is the data structure defined when creating the subsystem report.

Return Values

Return Value | Description
TRUE | Return value if this succeeds
FALSE | Return value if this fails

Related Tables

  • F986113

Additional Notes

This is the renamed version of jdeAddSubsystemRecord. As of B73.3.1, all developers should use ubeReport_AddSubsystemRecord since jdeAddSubsystemRecord will be removed at the B8.1 release level.


ubeReport_DisableSendMessage

Last Modified: B73.3.1 | June 04, 1999

ubeReport_DisableSendMessage allows users to disable the automatic sending of a completion message when the batch process completes. Without calling this API, the UBE engine will always attempt to send a message to the user who ran the report to notify that person that the job is complete.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the Behavior Communication Structure. | I | Y |

Return Values

Return Value | Description
TRUE | Return value if this succeeds
FALSE | Return value if this fails

Additional Notes

This is the renamed version of jdeUpdateUBEMessageFlag. As of B73.3.1, all developers should use ubeReport_DisableSendMessage since jdeUpdateUBEMessageFlag will be removed at the B8.1 release level.


ubeReport_GetName

Last Modified: B73.3.1 | June 04, 1999

ubeReport_GetName allows users to determine the name of the report processing.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the Behavior Communication Structure. | I | Y |

Return Values

Return Value | Description
A character string | Return value if this succeeds
FALSE | Return value if this fails

Additional Notes

This is the renamed version of K2GetReportName. As of B73.3.1, all developers should use ubeReport_GetName since K2GetReportName will be removed at the B8.1 release level.


ubeReport_GetPageNumber

Last Modified: B73.3.1 | June 04, 1999

ubeReport_GetPageNumber allows users access to the page number value to be printed on the report.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to Behavior Communication Structure | I | Y |

Return Values

Return Value | Description
The value of the current page number as an integer | Returns the value of the current page number as an integer

Additional Notes

This is the renamed version of K2GetPageNumber. As of B73.3.1, all developers should use ubeReport_GetPageNumber since K2GetPageNumber will be removed at the B8.1 release level.

See Also

  • ubeReport_SetPageNumber


ubeReport_GetPreviewMode

Last Modified: B73.3.1 | June 04, 1999

ubeReport_GetPreviewMode provides users with information as to whether the current report’s output is being previewed to the screen or going directly to the printer.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to Behavior Communication Structure | I | Y |

Return Values

Return Value | Description
TRUE | The current report's output is being sent to the screen
FALSE | The current report's output is being sent to the printer

Additional Notes

This is the renamed version of K2GetPreviewMode. As of B73.3.1, all developers should use ubeReport_GetPreviewMode since K2GetPreviewMode will be removed at the B8.1 release level.


ubeReport_GetSourceEnvironment

Last Modified: B73.3.1 | June 04, 1999

ubeReport_GetSourceEnvironment allows users to determine the source environment that the Database Mapping functionality is using.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the Behavior Communication Structure. | I | Y |

Return Values

Return Value | Description
The name of the source environment being used by the report |

Additional Notes

This is the renamed version of K2GetSourceEnvironment. As of B73.3.1, all developers should use ubeReport_GetSourceEnvironment since K2GetSourceEnvironment will be removed at the B8.1 release level.

See Also

  • ubeReport_GetTargetEnvironment


ubeReport_GetTargetEnvironment

Last Modified: B73.3.1 | June 04, 1999

ubeReport_GetTargetEnvironment allows users to determine the target environment that the Database Mapping functionality is using.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the Behavior Communication Structure. | I | Y |

Return Values

Return Value | Description
The target environment name being used by the report |

Additional Notes

This is the renamed version of K2GetTargetEnvironment. As of B73.3.1, all developers should use ubeReport_GetTargetEnvironment since K2GetTargetEnvironment will be removed at the B8.1 release level.

See Also

  • ubeReport_GetSourceEnvironment


ubeReport_IsTemplate

Last Modified: B73.3.1 | June 04, 1999

ubeReport_IsTemplate allows users to determine whether the version name that they specify is a version or a template of a report.

Parameters

Parameter | Description | I/O | Required | Notes
Const NID | The version name of a report | I | Y | The special value of REPORT_TEMPLATE_NAME may be used to indicate a report template.

Return Values

Return Value | Description
TRUE | The version specified indicates a report template
FALSE | The version specified indicates a version

Additional Notes

This combines the old APIs jdeIsReportTemplate and jdeIsVersion into one function with the new naming conventions. As of B73.3.1, all developers should use ubeReport_IsTemplate since jdeIsReportTemplate and jdeIsVersion will be removed at the B8.1 release level.


ubeReport_SetPageNumber

Last Modified: B73.3.1 | June 04, 1999

ubeReport_SetPageNumber changes the value of the page number runtime variable that is printed on reports.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the behavior communications structure | I | Y |
integer | Integer value to change page number to. | I | Y |

Return Values

Return Value | Description
TRUE | If it is successful
FALSE | If it is not successful

Additional Notes

This is the renamed version of K2ChangePageNumber. As of B73.3.1, all developers should use ubeReport_SetPageNumber since K2ChangePageNumber will be removed at the B8.1 release level.

See Also

  • ubeReport_GetPageNumber


ubeReport_StopBatchProcess

Last Modified: EnterpriseOne | April 17, 1999

ubeReport_StopBatchProcess causes all processing on the report to terminate. Output will still exist for any section that has already been processed.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to Behavior Communication Structure | I | Y |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

None

Related Tables

None

Related Functions

None

Related Topics

This API has a corresponding System Function: StopBatchProcessing, which has the same functionality.


ubeReport_StopBatchProcessWithError

Last Modified: EnterpriseOne | April 17, 1999

ubeReport_StopBatchProcessWithError causes all processing on the report to terminate. Output will still exist for any section that has already been processed. This function also prints out the error message into the PDF file and the log file. User can pass in the self-defined error message.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to Behavior Communication Structure | I | Y |
LPSTR | The error messages that user wants to be printed out into the PDF file and the log file. | I | Y |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

None

Related Tables

None

Related Functions

None

Related Topics

None


ubeSection

ubeSection consist of the following System Functions:

 | ubeSection_FreeDataSelection
app.gif (808 bytes) | ubeSection_GetCurrentColumnNumber
 | ubeSection_GetCurrentRowNumber
app.gif (808 bytes) | ubeSection_GetDataSelection
 | ubeSection_GetDataSequence
app.gif (808 bytes) | ubeSection_GetDataSequenceItem
 | ubeSection_GetID
app.gif (808 bytes) | ubeSection_GetLevelNID
 | ubeSection_GetNumberLevelBreaks
app.gif (808 bytes) | ubeSection_GetReverseSign
 | ubeSection_GetTableInfo
app.gif (808 bytes) | ubeSection_IsBalanceAuditorDefined
 | ubeSection_UseDataSelection


ubeSection_FreeDataSelection

Last Modified: B73.3.1 | June 04, 1999

ubeSection_FreeDataSelection allows developers to free the Data Selection structures allocated when using the ubeSection_GetDataSelection API.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the behavior communications structure | I | Y |
LPNEWSELECTSTRUCT * | Pointer to an array of Data Selection structures | I | Y | This will be the values allocated by ubeSection_GetDataSelection
LPSTR * | Pointer to a pointer to a string describing the Data Selection type. | I | Y | This string will be allocated and populated by ubeSection_GetDataSelection.
Ulong | The count of how many data selection structures are in the array. | I | Y | This value will be populated by ubeSection_GetDataSelection.

Return Values

Return Value | Description
TRUE | Always returns this value

Special Handling Instructions and Prerequisites

This should always be called after a call to ubeSection_GetDataSelection. This API will free the memory allocated by the other one. The last three parameters passed in to this function should always be populated by ubeSection_GetDataSelection and should not be changed by the user.

Additional Notes

This is the renamed version of K2FreeDataSelection. As of B73.3.1, all developers should use ubeSection_FreeDataSelection since K2FreeDataSelection will be removed at the B8.1 release level.

See Also

  • ubeSection_GetDataSelection


ubeSection_GetCurrentColumnNumber

Last Modified: B73.3.1 | June 04, 1999

ubeSection_GetCurrentColumnNumber allows users to determine the number of the current tabular column processing.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the Behavior Communication Structure. | I | Y |
MATH_NUMErIC * | Pointer to location to return the column number. | O | Y |

Return Values

Return Value | Description
None | This does not return a value

Additional Notes

This is the renamed version of K2GetGetCurrentColumn. As of B73.3.1, all developers should use ubeSection_GetCurrentColumnNumber since K2GetGetCurrentColumn will be removed at the B8.1 release level.

See Also

  • ubeSection_GetCurrentRowNumber


ubeSection_GetCurrentRowNumber

Last Modified: B73.3.1 | June 04, 1999

ubeSection_GetCurrentRowNumber allows users to determine the number of the current tabular row processing.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the Behavior Communication Structure. | I | Y |
MATH_NUMErIC * | Pointer to location to return the row number. | O | Y |

Return Values

Return Value | Description
None | This does not return a value

Additional Notes

This is the renamed version of K2GetGetCurrentRow. As of B73.3.1, all developers should use ubeSection_GetCurrentRowNumber since K2GetGetCurrentRow will be removed at the B8.1 release level.

See Also

  • ubeSection_GetCurrentColumnNumber


ubeSection_GetDataSelection

Last Modified: B73.3.1 | June 04, 1999

ubeSection_GetDataSelection allows a business function to retrieve data selection information from the specified section.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to Behavior Communication Structure. | I | Y |
LPSTR | The name of the report the section is located in. Use NULL if the current report is desired. | I | Y | Use NULL if the current report is desired.
LPSTR | The Version name of the report the section is located. | I | Y | Use NULL if the current version is desired.
ID | The ID of the section to retrieve data selection information from. | I | Y |
LPSELECTSTRUCT * | Address of the array of SELECT structures; the requested selection information will be returned in this parameter. The memory for this array will be allocated by this function. | O | Y | This memory must be freed by calling ubeSection_FreeDataSelection.
LPSTR * | Address of the array of data type characters; the data types of the items used for selection dictate how memory is managed. The memory for this array will be allocated by this function. | O | Y | This memory must be freed by calling ubeSection_FreeDataSelection.
ushort * | Address of the number of SELECT structures; the number of SELECT items will be returned in this parameter. | O | Y |

Return Values

Return Value | Description
TRUE | Returned if successful
FALSE | Returned if not successful

Special Handling Instructions and Prerequisites

A call to this function should always be followed by a call to ubeSection_FreeDataSelection.

Additional Notes

This is the renamed version of K2GetDataSelection. As of B73.3.1, all developers should use ubeSection_GetDataSelection since K2GetDataSelection will be removed at the B8.1 release level.

See Also

  • ubeSection_FreeDataSelection

  • ubeSection_GetDataSequence


ubeSection_GetDataSequence

Last Modified: B73.3.1 | June 04, 1999

ubeSection_GetDataSequence function allows a business function to retrieve data sequence information from the specified section.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to Behavior Communication Structure | I | Y |
LPSTR | The name of the report the section is located. Use NULL if the current report is desired. | I | Y | Use NULL if the current report is desired.
ID | The ID of the section to retrieve data sequence information from. | I | Y |
lpSort * | Address of the array of SORT structures; the requested sequence information will be returned in this parameter. The memory for this array will be allocated by this function. This memory must be freed by calling jdeFree. | O | Y |
ushort * | Address of the number of SORT structures; the number of SORT items will be returned in this parameter. | O | Y |

Return Values

Return Value | Description
TRUE | Returned if successful
FALSE | Returned if not successful

Additional Notes

This function is the renamed version of K2GetDataSequence. As of B73.3.1, all developers should use ubeSection_GetDataSequence since K2GetDataSequence will be removed at the B8.1 release level.

See Also

  • ubeSection_GetDataSelection

  • ubeSection_FreeDataSelection


ubeSection_GetDataSequenceItem

Last Modified: B73.3.1 | June 04, 1999

ubeSection_GetDataSequenceItem retrieves the sequencing information for a specified index number within the current section.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the Behavior Communication Structure | I | Y |
LPSORT | Pointer to a "sort" structure. The sort information from the specified index will be copied to the structure at this address. | O | Y |
Ushort | The index number which identifies the desired sort information | I | Y |

Return Values

Return Value | Description
NULL | This always returns NULL

Additional Notes

This is the renamed version of K2GetSortInfo. As of B73.3.1, all developers should use ubeSection_GetDataSequenceItem since K2GetSortInfo will be removed at the B8.1 release level.


ubeSection_GetID

Last Modified: B73.3.1 | June 04, 1999

ubeSection_GetID allows users to determine the unique ID of the current section processing.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the Behavior Communication Structure. | I | Y |
MATH_NUMERIC * | Pointer to location to return the section ID. | O | Y |

Return Values

Return Value | Description
None | This does not return a value

Additional Notes

This is the renamed version of K2GetSectionNumber. As of B73.3.1, all developers should use ubeSection_GetID since K2GetSectionNumber will be removed at the B8.1 release level.


ubeSection_GetLevelNID

Last Modified: B73.3.1 | June 04, 1999

ubeSection_GetLevelNID retrieves the Data Dictionary NID for the item associated with the requested level break.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the Behavior Communication Structure | I | Y |
ushort | Number of the level break from which the Data Dictionary NID should be retrieved | I | Y |
NID | Location to copy the NID of the requested Data Dictionary item | O | Y |

Return Values

Return Value | Description
TRUE | Returned if successful
FALSE | Returned if not successful

Additional Notes

This is the renamed version of K2GetLevelNID. As of B73.3.1, all developers should use ubeSection_GetDataSequence since K2GetDataSequence will be removed at the B8.1 release level.


ubeSection_GetNumberLevelBreaks

Last Modified: B73.3.1 | June 04, 1999

TubeSection_GetNumberLevelBreaks allows a business function to access the "Previous Value" pointers for a number of UBE objects.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the Behavior Communication Structure. | I | Y |

Return Values

Return Value | Description
This returns an unsigned short specifying the number of level breaks within the current section |

Additional Notes

This is the renamed version of K2GetNumberLeelBreaks. As of B73.3.1, all developers should use ubeSection_GetNumberLevelBreaks since K2GetNumberLevelBreaks will be removed at the B8.1 release level.


ubeSection_GetReverseSign

Last Modified: B73.3.1 | June 04, 1999

ubeSection_GetReverseSign allows users to determine the unique ID of the current section processing.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the Behavior Communication Structure. | I | Y |
MATH_NUMERIC * | Pointer to location to return the reverse sign value of the current section. | O | Y |

Return Values

Return Value | Description
None | This does not return a value

Additional Notes

This is the renamed version of K2GetReverseSign. As of B73.3.1, all developers should use ubeSection_GetReverseSign since K2GetReverseSign will be removed at the B8.1 release level.


ubeSection_GetTableInfo

Last Modified: B73.3.1 | June 04, 1999

ubeSection_GetTableInfo retrieves the Column Information pointer for the requested database item.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the behavior communication structure | I | Y |
DBREF | A database reference structure which identifies the desired item | I | Y |

Return Values

Return Value | Description
LPCOLINFO | If successful, this function returns an LPCOLINFO, which points to column information for the requested item
NULL | If not successful

Additional Notes

This is the renamed version of K2GetTableInfo. As of B73.3.1, all developers should use ubeSection_GetTableInfo since K2GetTableInfo will be removed at the B8.1 release level.


ubeSection_IsBalanceAuditorDefined

Last Modified: B73.3.1 | June 04, 1999

ubeSection_IsBalanceAuditorDefined allows users to determine whether the Balance Auditor functionality has been defined for the section currently processing.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the Behavior Communication Structure. | I | Y |

Return Values

Return Value | Description
Y | Returns this character if the Balance Auditor has been defined
N | Returns this character if the Balance Auditor has no been defined

Additional Notes

This is the renamed version of K2GetBalanaceAuditor. As of B73.3.1, all developers should use ubeSection_IsBalanceAuditorDefined since K2GetBalanaceAuditor will be removed at the B8.1 release level.


ubeSection_UseDataSelection

Last Modified: B73.3.1 | June 04, 1999

ubeSection_UseDataSelection specifies to use the data selection items from another section in the current section.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to Behavior Communication Structure | I | Y |
LPSTR | The name of the report the section is located in. Use NULL if the current report is desired. | I | Y | Use NULL if the current report is desired.
LPSTR | The Version name of the report the section is located in. | I | Y | Use NULL if the current version is desired.
ID | The ID of the section to retrieve data selection information from. | I | Y |

Return Values

Return Value | Description
TRUE | Returned if successful
FALSE | Returned if not successful

Additional Notes

This is the renamed version of K2UseDataSelection. As of B73.3.1, all developers should use ubeSection_UseDataSelection since K2UseDataSelection will be removed at the B8.1 release level.


ubeTab

ubeSection consist of the following System Functions:

 | ubeTab_GetLevelBreak
app.gif (808 bytes) | ubeTab_GetLevelNumber
app.gif (808 bytes) | ubeTab_IsLevelBreakHeaderActive


ubeTab_GetLevelBreak

Last Modified: B73.3.1 | June 04, 1999

ubeTab_GetLevelBreak allows a business function to determine whether or not a tabular level break header is active.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the Behavior Communication Structure. | I | Y |
Integer | Integer value specifying the type of level break information to retrieve. | I | Y |

Return Values

This returns an unsigned short specifying the type of level break information specified. This will either be the total number of level breaks, the number of the current level break, or the number of the lowest level break.


ubeTab_GetLevelNumber

Last Modified: B73.3.1 | June 04, 1999

ubeTab_GetLevelNumber allows a business function to retrieve the current tabular level break header number.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the behavior communication structure | I | Y |

Return Values

Return Value | Description
Returns the number of the Tabular Level Break Header | The UBE is currently processing a Tabular Level Break Header
Returns the number of the level break which is currently being processed by UBE | The UBE is not currently processing a Tabular Level Break Header

Additional Notes

This is the renamed version of K2GetTabularCurrentLevelNumber. As of B73.3.1, all developers should use ubeTab_GetLevelNumber since K2GetTabularCurrentLevelNumber will be removed at the B8.1 release level.


ubeTab_IsLevelBreakHeaderActive

Last Modified: B73.3.1 | June 04, 1999

ubeTab_IsLevelBreakHeaderActive allows a business function to determine whether a tabular level break header is active.

Parameters

Parameter | Description | I/O | Required | Notes
LPBHVRCOM | Pointer to the Behavior Communication Structure. | I | Y |

Return Values

Return Value | Description
True | The tabular level break header section is active
False | The tabular level break header section is not active

Additional Notes

This is the renamed version of K2IsTabularHdrBrkActive. As of B73.3.1, all developers should use ubeTab_IsLevelBreakHeaderActive since K2IsTabularHdrBrkActive will be removed at the B8.1 release level.


E-Mail

E-Mail consist of the following:

JDE_SendEmailSMTP


JDE_SendEMailSMTP

Last Modified: B733.1 | December 22, 1998

JDE_SendEMailSMTP allows the caller to e-mail to one or more recipients using the Simple Mail Transport Protocol (SMTP) with support for multimedia attachments. JDE_SendEMailSMTP is exported for use in EnterpriseOne business functions and is available in both client and server environments.

JDE_SendEMailSMTP complies with the SMTP specification found in RFC 822 and supports the standard Multimedia Internet message exchange (MIME) protocol, up to and including RFC 1806.

External Dependencies

Prerequisites to using of JDE_SendEMailSMTP are that a host running the SMTP service (TCP port 25) must be accessible from the calling machine and the hostname of the SMTP service must be specified in the mailServer key of the [JDEMAIL] section of the jde.ini file in the environment from which the JDE_SendEMailSMTP API will be called.

Example

[JDEMAIL]

mailServer=mailserv1

Syntax

#include <jdekprto.h>

JDEMailError

JDE_SendEMailSMTP(char* szFrom,

char* szMessage,

char* szSubject,

JDEMailMessageAtt* pAttachments,

int nAttachments,

char* szTo,

char* szCC,

char* szBCC)

Parameters

Parameter | Type | Notes
szFrom | char * | A pointer to a NULL-terminated string that specifies the fully qualified SMTP e-mail address of the sender. Example: john_doe@jdedwards.com
szMessage | char * | A pointer to a NULL-terminated string that specifies the body of the e-mail message.
szSubject | char * | A pointer to a NULL-terminated string that specifies the subject of the e-mail message.
pAttachments | JDEMailMessageAtt * | A pointer to an array of structures that specify items to be attached to this e-mail.
nAttachments | int | A nonnegative integer that specifies the number of structures in the pAttachments array that should be attached.
szTo | char * | A pointer to a NULL-terminated string that specifies the fully qualified SMTP e-mail address or addresses of the primary recipient or recipients of the e-mail. Multiple primary recipients may be specified as a list of e-mail addresses delimited by the semicolon (;) character. Example: john_doe@jdedwards.com
szCC | char * | A pointer to a NULL-terminated string that specifies the fully qualified SMTP e-mail address or addresses of the secondary recipient or recipients of the e-mail. Multiple secondary recipients may be specified as a list of e-mail addresses delimited by the semicolon (;) character. Example: john_doe@jdedwards.com
szBCC | char * | A pointer to a NULL-terminated string that specifies the fully qualified SMTP e-mail address or addresses of the hidden, secondary recipient or recipients of the e-mail. Hidden, secondary recipients receive the message; however, the header of the message does no show the e-mail addresses of the hidden, secondary recipients. Multiple hidden, secondary recipients may be specified as a list of e-mail addresses delimited by the semicolon (;) character. Example: john_doe@jdedwards.com

Return Value

JDE_SendEMailSMTP returns a value of type JDEMailError to errors during the processing of the electronic mail transfer. Possible values are listed in the following table:

Return Value | Description
eOK | The message was sent successfully to the e-mail agent.
eBadArg | An invalid argument was passed to the function, such as a NULL pointer.
eBadFileName | A file attachment specified an invalid filename.
eConnectError | A connection could not be established to the e-mail agent. Diagnosis: The SMTP service may not be running on the host specified in the mailServer key setting in the [JDEMAIL] section of jde.ini. Check with your system administrator.
eCouldNotgetHost | The hostname of the e-mail agent could not be determined. Diagnosis: Check the jde.ini file. Be sure that the mailServer key in the [JDEMAIL] section exists and specifies the name of a host where the SMTP service is running.
eCouldNotGetIPAddress | The hostname of the e-mail agent could not be resolved. Diagnosis: Verify that the hostname specified by the mailServer setting in the [JDEMAIL] section of the jde.ini file is a valid hostname.
eEncodeError | An internal error occurred while processing the message. Diagnosis: Contact J.D. Edwards support.
eMailActionNotTaken | The e-mail agent did not complete the requested operation.
eMailSyntaxError | The e-mail agent found an error processing the message. Diagnosis: The e-mail agent does not comply with RFC 822.
eMailboxUnavailable | One or more of the primary, secondary or hidden secondary recipients was not valid. Diagnosis: Check the recipient lists to ensure that the e-mail addresses are valid.
eMemoryError | Out of memory. This is an internal error.
eNoMsgFrom | The szFrom parameter was blank. The e-mail address of the sender must be specified. Diagnosis: Check the call to the function.
eNoMsgRecips | The szTo parameter was blank. At least one recipient must be specified. Diagnosis: Check the call to the function.
eReceiveError | An unspecified communication error occurred while communicating with the e-mail agent.
eSendError | An unspecified communication error occurred while communicating with the e-mail agent.
eServiceNotAvailable | The e-mail agent was unable to perform the requested operation. Diagnosis: The e-mail agent does not comply with RFC 822.
eSmallBuffer | An internal error occurred while processing the message.
eSocketCreateFailed | A connection could not be established to the e-mail agent.
eStorageAllocExceeded | The message was too long.
eTransactionFailed | The message was not sent.
eUnknownMailError | An unknown error occurred while sending the message.
eUserNotLocal | The e-mail address of the message sender is not an e-mail address recognized by the e-mail agent.
eWinsockInitFailed | A connection could not be established to the e-mail agent.

Example

JDEMailError error;

char* szFrom = "me@jdedwards.com";

char* szSubject = "The information you requested";

char* szMessage = "Here is the information you requested!";

char* szTo = "client1@company1.com; client2@company2.ca";

char* szCC = "client1-manager@company1.com ";

char* szBCC = "me-manager@jdedwards.com";

/* Populate attachment structure */&#9;

int nAttachments = 3;

JDEMailMessageAtt pAttachments[3];

pAttachments[0].pVoid = NULL;

/* The filename gives the fully qualified pathname of the attachment: */

strcpy(pAttachments[0].filename, "c:\\data\\msword\\jdesmube.doc");

/* The displayname is what will be used to render the attachment in the receiving client application. The extension is important because it allows the correct application to be used when opening (For example.: Microsoft Word for .doc, Microsoft PowerPoint for .ppt, etc.). */

strcpy(pAttachments[0].displayname, "jdesmube.doc");

pAttachments[0].filetype = ATT_FILE;

pAttachments[1].pVoid = NULL;

strcpy(pAttachments[1].filename, "c:\\data\\msword\\rpc.doc");

strcpy(pAttachments[1].displayname, "rpc.doc");

pAttachments[1].filetype = ATT_FILE;

pAttachments[2].pVoid = NULL;

strcpy(pAttachments[2].filename, "c:\\data\\msword\\miscinfo.txt");

strcpy(pAttachments[2].displayname, "miscinfo.txt");

pAttachments[2].filetype = ATT_FILE;

error = JDE_SendEMailSMTP(szFrom, szMessage, szSubject,

Attachments, nAttachments, szTo, szCC, szBCC);

Additional Notes

The JDEMailMessageAtt structure has the form

struct JDEMailMessageAtt {

char filename[256];

char displayname[256];

unsigned long filetype;

LPVOID pVoid;

LPVOID pmID; /* ignored by this function */

LPVOID pattID; /* ignored by this function */

unsigned long ulAttNum; /* ignored by this function */

};

The filetype member specifies the attachment type. Valid values are:

  • ATT_FILE

  • ATT_MSG

Use ATT_FILE for filetype to specify a file attachment. When ATT_FILE is used:

  • The filename specifies the fully qualified name of the file to be send with the message.

  • The displayname specifies the logical name to associate with the attachment.

Failure to specify a displayname with a valid extension, such as .exe, .doc and so on, will result in the attachment not being rendered properly by the recipients mail viewer.

Use ATT_MSG for filetype to specify a nested message attachment. When ATT_MSG is used:

  • lpVoid points to a structure of type JDEMailMessage that contains the nested message information.

The JDEMailMessage structure has the form

struct JDEMailMessage {

int protocol; /* ignored by this function */

msgHandle mHandle; /* ignored by this function */

char Date[256]; /* ignored by this function */

char From[256];

char *Message;

void *RTFMessage; /* ignored by this function */

unsigned long RTFMessageSize; /* ignored by this function */

char *Subject;

char *TO;

char *CC;

char *BCC;

unsigned long flags; /* ignored by this function */

int numAttachments;

JDEMailMessageAtt *attachments;

char *szBadNamesOnSend; /* ignored by this function */

};

Note that the JDEMailMessage structure has members that mirror the parameter list of the JDE_SendEMailSMTP function.


Interactive Application System Functions

Interactive system functions process in an interactive application and perform tasks, such as hiding a control, disabling a control, setting an error message indicator, and copying currency information.

Interactive Application consist of the following Categories:

Combo Box Functions

Control System Functions

General System Functions

Grid System Functions

Media Object System Functions

Messaging System Functions

Parent Child System Functions

Text Control Functions

Workflow System Functions


Combo Box Functions

Combo Box Functions consist of the following:

 | Add Segment - API_System Functions
 | Get Description
app.gif (808 bytes) | Select Item


Add Segment - API_System Functions

AddSegment

Last Modified: EnterpriseOne | July 14, 2000

Add Segment system function allows a segment to be added to the specified text control.

Parameters

Parameter | Description | I/O | Required | Notes
Text Control |  | I | Y | Use FC Text Control
Text | String | I | Y | This field specifies the text string of the segment.
Font |  | I | Y | <Pick Font> or <Reset Font>
Clickable | Int | I | Y | This field specifies if the segment generates a "Text Clicked" event
SegmentID | Int | I | Y | Specifies the segment to be added.

Special Handling Instructions and Prerequisites

·

Available Events

Available on all events

Related Topics

· Get Segment Information, Get Last Clicked Segment, Remove Segment, Update Segment


Get Description

Last Modified: B73.3.2 | August 03, 1999

Get Description gets the UDC Description of the specified UDC item.

Parameters

Delete Item | Description | I/O | Required | Notes
FC Combo Box | Combo Box Control | I | Y | The Combo box to operate on
String | Description | I | Y | Variable to receive the UDC Description

Related Functions

Function Name | Function Description I/O | Source name | Description
Select Item | Selects a UDC item | System function | Selects a UDC Item in the Combo Box


SelectItem

Last Modified: B73.3.2 | August 03, 1999

Select item selects an item.

Parameters

Data Item | Description | I/O | Required | Notes
FC Combo Box | Combo Box Control | I | Y | The Combo box to operate on
INT | UDC Key | I | Y | Key of the UDC to select

Related Functions

Function Name | Function Description I/O | Source name | Description
Get Description | Returns the Description | System function | Returns the description of the currently selected UDC


Control System Functions

Control System Functions consist of the following:

 | ClearEditControlError
app.gif (808 bytes) | DisableControl
 | DisableTabPage
app.gif (808 bytes) | EnableControl
 | EnableTabPage
app.gif (808 bytes) | HideControl
 | HideTabPage
app.gif (808 bytes) | SetControlText
 | SetCurrentTabPage
app.gif (808 bytes) | SetDataDictionaryItemForControl
 | SetDataDictionaryOverrideForControl
app.gif (808 bytes) | SetEditControlColor
 | SetEditControlError
app.gif (808 bytes) | SetEditControlFont
 | SetStatusbarText
app.gif (808 bytes) | ShowControl
 | WasValueEntered


ClearEditControlError

Last Modified: B733

ClearEditControlError clears an error on the specified field and sets the control background to default color.

Parameters

Parameter | Description | I/O | Required | Notes
Control | Designates the control to be cleared of error |  |  |

Return Value

Return Value | Description
None | This does not return a value

See Also

  • SetEditControlColor

  • SetEditControlError

  • SetEditControlFont


DisableControl

Last Modified: B733

DisableControl causes a control to be read only

Parameters

Parameter | Description | I/O | Required | Notes
Control | Designates control to be made read only. |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This is applicable to any FC, button, HC, and Bitmaps, reversible with Enable Control and has no effect on a control that is already disabled.

See Also

  • EnableControl


DisableTabPage

Last Modified: B733

DisableTabPage disables a Tab Page in the Tab Control.

Parameters

Parameter | Description | I/O | Required | Notes
Tab Control | Identifies the Tab Control |  |  |
Tab Page | Identifies the Page that needs to be disabled |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

If a tab page is disabled, the user cannot use the mouse or keyboard to activate it.


EnableControl

Last Modified: B733

EnableControl causes a control to be input capable.

Parameters

Parameter | Description | I/O | Required | Notes
Control | Designates control to be made input capable |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This is applicable to any FC, button, HC, and Bitmaps, reversible with Disable Control and has no effect on a control that is already enabled.

See Also

  • DisableControl


EnableTabPage

Last Modified: B733

EnableTabPage enables a previously disabled Tab Page

Parameters

Parameter | Description | I/O | Required | Notes
Tab Control | Identifies the Tab Control |  |  |
Tab Page | Identifies the Page that needs to be enabled |  |  |

Return Values

Return Value | Description
None | This does not return a value


HideControl

Last Modified: B733

HideControl makes a control invisible.

Parameters

Parameter | Description | I/O | Required | Notes
Control | Designates control to be made invisible |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This is applicable to all FC, buttons, HC, and Bitmaps, reversible with Show Control, and has no effect on a control that is already invisible.

See Also

  • ShowControl


HideTabPage

Last Modified: B73.3.2 | September 07, 1999

HideTabPage hides a particular Tab Page out of the Tab Control.

Parameters

Parameter | Description | I/O | Required | Notes
Tab Control | Identifies the Tab Control |  |  |
Tab Page | Identifies the Page the need to be hidden |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This function can only be called while the Post Dialog is Initialized. At all other times, Disable Tab page should be used.


SetControlText

Last Modified: B73.3.2 | August 03, 1999

SetControlText changes the description text of a form control.

Parameters

Parameter

Description

I/O

Required

Notes

Control Text

  • Identifies the control whose description text is to be changed.

  • Identifies the new description text.

I

Y

If the control is an edit control, the description text to the left of the edit box is changed.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

None

See Also

  • SetGridColumnHeading

  • SetFormTitle

  • SetDataDictionaryItemFor Control

  • SetDataDictionaryItemForGridColumn

  • SetDataDictionaryOverridesForControl

  • SetDataDictionaryOverridesForGridColumn


SetCurrentTabPage

Last Modified: B733

SetCurrentTabPage activates and displays a particular Tab Page in the Tab control

Parameters

Parameter | Description | I/O | Required | Notes
Tab Control | Identifies the Tab Control |  |  |
Tab Page | Identifies the Page that needs to be activated |  |  |

Return Values

Return Value | Description
None | This does not return a value


SetDataDictionaryItemForControl

Last Modified: B733

SetDataDictionaryItemForControl changes the data dictionary item associated with a control. All data dictionary attributes are also changed.

Parameters

Parameter | Description | I/O | Required | Notes
Control | This designates the control whose data dictionary item is to be changed. | I | Y | The Control must be a data dictionary item, not database item.
DD Alias | This is the alias of the data dictionary item to change to. | I | Y | Can be literal or variable.
System Code | System code | I | N | Reserve for Future Use

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

The control has to be a data dictionary item, not database item. When changing data dictionary items, there are some restrictions. The data dictionary items to be switched must be of the same type except for one case. The one case is, it is possible to change a string to a character but not vice versa. It is also important to note that if a change is made between string types, the maximum size of the new string item will be the smaller size of the two switched items.

See Also

  • SetDataDictionaryOverridesForControl

  • SetControlText


SetDataDictionaryOverrideForControl

Last Modified: B733

SetDataDictionaryOverrideForControl override specific data dictionary attributes.

Parameters

Parameter | Description | I/O | Required | Notes
Control | Identifies the control whose attributes are to be changed | I | Y |
Overrides | Presents the data dictionary attributes that can be overridden | I | Y |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

The control can be a data dictionary item or a business view item.

See Also

  • SetDataDictionaryItemForControl

  • SetControlText


SetEditControlColor

Last Modified: B733

SetEditControlColor changes the background color of an edit control.

Parameters

Parameter | Description | I/O | Required | Notes
Control | This must be an edit control. |  |  |
<Color> Special Values <Pick Color> <Reset Color> | This allows you to select color information for a control or reset the color information for a control back to the default setting. |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

The first parameter must be an edit control. To clear a the color from an edit control after setting it, call this system function with the color of <default>. This can be accomplished by selecting <Reset Color> as the <Color> parameter.

See Also

  • ClearEditControlError

  • SetEditControlError

  • SetEditControlFont


SetEditControlError

Last Modified: B733

SetEditControlError sets an error on the specified field and sets the control background red.

Parameters

Parameter | Description | I/O | Required | Notes
Control | Designates the control to be set in error. |  |  |
Error Code | The data dictionary alias of the error to be set. |  |  |

Return Values

Return Value | Description
None | This does not return a value

See Also

  • ClearEditControlError

  • SetEditControlColor

  • SetEditControlFont


SetEditControlFont

Last Modified: B733

SetEditControlFont allows you to modify various attributes about the font of the text that will appear in an edit control. The following attributes can be set using this system function:

  • Font

  • Font style (bold, regular, italic, bold italic)

  • Font size

  • Font effects (strikeout, underline)

  • Font color

Parameters

Parameter | Description | I/O | Required | Notes
Control | The control to apply the font attributes. |  |  |
Font Info Special Values <Pick Font> <Reset Font> | This allows you to select font information for a control or reset the font information for a control back to the default setting. |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

Used to remove font and special font settings by calling this same system function with the <Reset Font> value for the font parameter.

See Also

  • ClearEditControlError

  • SetEditControlColor

  • SetEditControlError


SetStatusBarText

Last Modified: B733

SetStatusBarText sets the text on the status bar of a form based on the alpha description of the specified EnterpriseOne data item.

Parameters

Parameter | Description | I/O | Required | Notes
DD Alias | The Alias of an existing EnterpriseOne Data Item. (usually an error message data item). |  |  | Special Values <literal> <Blank> <Zero>

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

To clear the status bar text, use this system function with a Data Dictionary Alias parameter of <blank> or <zero>.


ShowControl

Last Modified: B733

ShowControl makes a control visible.

Parameters

Parameter | Description | I/O | Required | Notes
Control | Designates control to make visible. |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This is applicable to all FC, buttons, HC, and Bitmaps, reversible with Hide Control, and has no effect on a control that is already visible.

See Also

  • HideControl


WasValueEntered

Last Modified: B733

WasValueEntered returns a value indicating if a form control has been changed. A return value of zero indicates no change, and a return value of one indicates a change.

Parameters

Parameter | Description | I/O | Required | Notes
Control | Control to be tested for a change |  |  |
Return to | Location to return the change indicator |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

Two flags track the changes: the form flag and the control flag. When a control is changed, both flags are set to one. When “Was Value Entered” is called and a specific control is selected for the control parameter, the current value of the control flag is returned. The control value is then set to zero. The form flag remains the same. When <All Controls> is selected for the control parameter, the current value of the form flag is returned. The form flag value is then set to zero, but the control flag remains the same.


General System Functions

General System Functions consist of the following APIs:

 | CopyCurrencyInformation
app.gif (808 bytes) | Go To URL
app.gif (808 bytes) | Launch Batch Application
app.gif (808 bytes) | Launch Processing Option Dialog
 | PressButton
app.gif (808 bytes) | Run Executable
app.gif (808 bytes) | SetControlFocus
 | SetFormTitle
app.gif (808 bytes) | StopProcessing
 | SuppressAdd
app.gif (808 bytes) | SuppressDefaultVisualAssistForm
 | SuppressDelete
app.gif (808 bytes) | SuppressFind
 | SuppressUpdate
app.gif (808 bytes) | WasFormRecordFetched


Go To URL

Last Modified: B733.2 SPI

Go To URL allows users to traverse to a web site.

Parameters

Parameter | Description | I/O | Required | Notes
Text | The URL Address | I | Y | Parameter can be any available object

Return Values

Return Value | Description
None | This does not return a value


Launch Batch Application - API_System Functions

Launch Batch Application

Last Modified: EnterpriseOne | July 20, 2000

Launch Batch Application system function is used only for WEB applications that will launch the UBE. The system function will act like the Report Interconnect. It will launch the UBE.

Parameters

Parameter | Description | I/O | Required | Notes
Report Name | String | I | Y | UBE Application ID
Version Name | String | I | Y |
Print Preview? | Character | I | Y | Y/N
Data Selection? | Character | I | Y | Y/N – Override the data selection
Data Sequencing? | Character | I | Y | Y/N – Override the data sequencing
Push Spec Only? | Character | I | Y | Y/N – submit version specification only
PO Template | String | I | Y | PO Data Structure
Prompt for values? | Character | I | Y | Y/N – Display the processing options dialog
Date Last Executed | JDEDATE | I | Y | Date
Data Source Override | String | I | Y | Server Name
JDE Log? | Character | I | Y | Y/N – Create JDE.log
JDEDebug Log? | Character | I | Y | Y/N – Create Jdedebug.log
UBE Logging Level | Integer | I | Y | Level of detail for Jdedebug.log
Jargon Code | String | I | Y |
Cover page? | Character | I | Y | Y/N – print cover page
Job Queue name | String | I | Y |
TC Prompting? | Character | I | Y | Y/N
Process Type | Character | I | Y |

Special Handling Instructions and Prerequisites

· Must be used in a WEB application only.

Available Events

Available on all events.

Related Topics

· Get WEB CDA, Launch Processing Options Dialog


Launch Processing Option Dialog - API_System Functions

Launch Processing Options Dialog

Last Modified: EnterpriseOne | July 20, 2000

Launch Processing Option Dialog system function is used only for WEB applications that will launch the UBE. The system function will display the processing options dialog.

Parameters

Parameter | Description | I/O | Required | Notes
Object Name | String | I | Y | UBE Application ID
Version Name | String | I | Y |

Special Handling Instructions and Prerequisites

· Must be used in a WEB application only.

Available Events

Available on all events.

Related Topics

· Get WEB CDA, Launch Batch Application


PressButton

Last Modified: B733

PressButton simulates a Button Click.

Parameters

Parameter | Description | I/O | Required | Notes
Control | Designates the control to be pressed. |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This is applicable for form controls and HCs. The event Button Clicked will be executed for the control that is pushed. After using this system function the next tab will be the one that comes in sequence after the control, which was pushed using the system function.


Run Executable - API_System Functions

RunExecutable

Last Modified: EnterpriseOne | July 10, 2000

Run Executable system function allows the application to execute other programmable code outside EnterpriseOne.

Parameters

Parameter | Description | I/O | Required | Notes
EXE Directory | String | I | Y | Directory where the executable code reside
EXE Name | String | I | Y | Name of the executable
Parameter #1 | String | I | Y | Input to executable if any
Parameter #2 | String | I | Y | Input to executable if any
Parameter #3 | String | I | Y | Input to executable if any
Working Directory | String | I | Y |

Available Events

Available on all events


SetControlFocus

Last Modified: B733

SetControlFocus sets the focus on a specific control.

Parameters

Parameter | Description | I/O | Required | Notes
Control | Designates that the control receives the focus. |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This is applicable for form controls and HCs. The event Control is Entered will be executed for the field that receives focus.


SetFormTitle

Last Modified: B733

SetFormTitle changes the title of a form.

Parameters

Parameter | Description | I/O | Required | Notes
New Title | The new title text | I | Y |

Return Values

Return Value | Description
None | This does not return a value

See Also

  • SetControlText

  • SetGridColumnHeading


StopProcessing

Last Modified: B733

StopProcessing immediately stops the processing for the remaining ER for that particular event.

Parameters

None.

Return Values

Return Value | Description
None | This does not return a value


SuppressAdd

Last Modified: B733

SuppressAdd prevents a database record from being added by the interactive runtime engine.

Parameters

None.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This is used to prevent a form record or a grid record from being added. To prevent adding a form record, this system function must be called during the AddRecordtoDB-Before event rule. Any calls to the system function prior to that time will be ignored.

To suppress the addition of a grid record, this system function must be called during the AddGridRecordtoDB-Before event rule. Any calls to the system function prior to that time will be ignored.

See Also

  • SuppressDelete

  • SuppressFind

  • SuppressUpdate


SuppressDefaultVisualAssistForm

Last Modified: B733

SuppressDefaultVisualAssistForm suppress the default visual assist form for a control.

Parameters

None.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

Applications can use this system function in the “Visual Assist Button Clicked” event to suppress the default visual assist form that is defined by the data dictionary item and bring up any EnterpriseOne form as the visual assist form.

See Also

  • VisualAssistButtonClicked

  • PostVisualAssistButtonClicked


SuppressDelete

Last Modified: B733

SuppressDelete prevents the deletion of a record from the database.

Parameters

None.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This system function will only suppress the deletion of a record when it is called from the DeleteGridRecVerify-Before event rule, the DeleteGridRecVerify-After event rule, or the DeleteGridRecFromDB-Before event rule. Any other calls to this system function will be ignored.

See Also

  • SuppressAdd

  • SuppressFind

  • SuppressUpdate


SuppressFind

Last Modified: B733

SuppressFind prevents the interactive runtime engine from performing a fetch.

Parameters

None.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This can be called from any event and will effect the next time find is selected.

See Also

  • SuppressAdd

  • SuppressDelete

  • SuppressUpdate


SuppressUpdate

Last Modified: B733

SuppressUpdate prevents a database record from being updated by the interactive runtime engine.

Parameters

None.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This is used to prevent an update of either a form record or a grid record. To suppress the update of a form record this system function must be called during the UpdateRecordtoDB-Before event rule. Any calls to the system function prior to that time will be ignored.

To suppress the update of a grid record this system function must be called during the Update Grid Record to DB - Before ER. Any calls to the system function prior to that time will be ignored.

See Also

  • SuppressAdd

  • SuppressDelete

  • SuppressFind


WasFormRecordFetched

Last Modified: B733

WasFormRecordFetched returns a value indicating if the interactive engine for the current form fetched a form record. A return value of one indicates a record was fetched. A return value of zero indicates that there was no attempt to fetch, or the attempted fetch failed.

Parameters

Parameter | Description | I/O | Required | Notes
Return to | Location to return result (zero or one). |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This only applies to Fix/Inspect forms and Header Detail forms. Other form types never fetch form records.


Grid System Functions

Grid System Functions consist of the following APIs:

 | ClearGridBuffer
app.gif (808 bytes) | ClearGridCellError
 | ClearQBEColumn
app.gif (808 bytes) | ClearSelection
 | ClearSequencing
app.gif (808 bytes) | Continue Custom Fetch
 | CopyGridRowToGridBuffer
app.gif (808 bytes) | DeleteGridRow
 | DisableGrid
app.gif (808 bytes) | EnableGrid
 | GetGridRow
app.gif (808 bytes) | GetMaxGridRows
 | GetSelectedGridRowCount
app.gif (808 bytes) | GetSelectedGridRowNumber
 | HideGridColumn
app.gif (808 bytes) | InsertGridBufferRow
 | InsertGridRow
app.gif (808 bytes) | SetDataDictionaryItemForGridColumn
 | SetDataDictionaryOverrideForGridColumn
app.gif (808 bytes) | SetGridCellError
 | SetGridColor
app.gif (808 bytes) | SetGridColumnHeading
 | SetGridFont
app.gif (808 bytes) | SetGridRowBitmap
 | SetLowerLimit
app.gif (808 bytes) | SetQBEColumnCompareStyle
 | SetSelection
app.gif (808 bytes) | SetSelectionAppendFlag
 | SetSequencing
app.gif (808 bytes) | ShowGridColumn
 | ShowGridRow
app.gif (808 bytes) | SuppressGridLine
 | UpdateGridBufferRow
app.gif (808 bytes) | WasGridCellValueEntered


ClearGridBuffer

Last Modified: B733 | June 04, 1998

ClearGridBuffer clears all the grid buffer columns or GBs.

Parameters

Parameter | Description | I/O | Required | Notes
Grid control | Identifies the grid control |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This function can be used to initialize all the GBs at once.


ClearGridCellError

Last Modified: B733 | June 04, 1998

ClearGridCellError clears an error in the specified grid cell.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control |  |  |
Row | Row Number |  |  |
Column | Column Number |  |  |

Return Values

Return Value | Description
None | This does not return a value


ClearQBEColumn

Last Modified: B733 | June 04, 1998

ClearQBEColumn clears all columns or a specific column in the QBE.

Parameters

Parameter | Description | I/O | Required | Notes
Grid control | Identifies the grid control. |  |  |
Column | Specific Grid Column or <All columns> |  |  |

Return Values

Return Value | Description
None | This does not return a value


ClearSelection

Last Modified: B733 | June 04, 1998

ClearSelection removes all select information defined by calls to the SetSelection or SetLowerLimit System Functions. If called when no system function select information is present it will have no effect.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control | I | Y |

Related Functions

Function Name | Function Description | Source Name | Description
Set Selection | A selection system function that results in a call to JDB_SetSelection |  |
Set Lower Limit | A selection System Function that results in a call to JDB_SetLowerLimit |  |
Set Selection Append Flag | Either appends or replaces the QBE and filter select information with the System Function select information |  |

See Also

  • Set Sequencing


ClearSequencing

Last Modified: B733 | June 04, 1998

ClearSequencing removes all sort information defined by calls to the Set Sequencing System Function. If called when no System Function sort information is present it will have no effect.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control | I | Y |

Related Functions

Function Name | Function Description | Source Name | Description
Set Sequencing | A sequencing system function that results in a call to JDB_SetSequencing |  |

See Also

  • Set Selection

  • Set Lower Limits


Continue Custom Fetch

Last Modified: B733.2 | April 14, 1999

Continue Custom Fetch sets a flag for use during the Get Custom Grid Row event. If this system function is called from the Get Custom Grid Row event, then the event will be repeated until a page of grid rows has been added. This system function has no effect in any other event.

Parameters

None.

Return Values

The Continue Custom Fetch system function returns no values. It sets a flag for use during Get Custom Grid Row.

See Also

  • Get Custom Grid Row


CopyGridRowToGridBuffer

Last Modified: B733 | June 04, 1998

CopyGridRowToGridBuffer copies the current grid column values (grid columns) into the grid buffer columns (GBs).

Parameters

Parameter | Description | I/O | Required | Notes
Grid Control | Identifies the grid control whose grid columns are to be copied into the GBs |  |  |

Return Values

Return Value | Description
None | This does not return a value


DeleteGridRow

Last Modified: B733 | June 04, 1998

DeleteGridRow deletes a specified grid row, the current grid row, or all grid rows.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | The grid control |  |  |
Row | <Current Row>, <All Rows>, specific grid row. |  |  |

Return Values

Return Value | Description
None | This does not return a value


DisableGrid

Last Modified: B733 | June 04, 1998

DisableGrid allows the user to disable the entire grid, specific rows, columns, or cells.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid control |  |  |
Row | Row number |  |  |
Column | Column Number or Name. |  |  |

Return Values

Return Value | Description
None | This does not return a value


EnableGrid

Last Modified: B733 | June 04, 1998

EnableGrid allows the user to enable the entire grid, specific rows, columns, or cells.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid control |  |  |
Row | Row number |  |  |
Column | Column Number or Name. |  |  |

Return Values

Return Value | Description
None | This does not return a value


GetGridRow

Last Modified: B733 | June 04, 1998

GetGridRow causes the specified row to be used for subsequent ER on the current event. If the row specified is greater than the total number of rows, the last row is used. If the row specified is invalid, the active row becomes zero.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid control |  |  |
Row | Row number to use for subsequent ER on this event |  |  |

Return Values

Return Value | Description
None | This does not return a value


GetMaxGridRows

Last Modified: B733 | June 04, 1998

GetMaxGridRows returns the maximum number of grid rows on a form.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid control |  |  |
Row | Variable (BC, FC, and so forth) in which the maximum. number. will be stored. |  |  |

Return Values

Return Value | Description
None | This does not return a value


GetSelectedGridRowCount

Last Modified: B733 | June 04, 1998

GetSelectedGridRowCount gets the number of selected grid rows.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid control |  |  |
Row | Variable (BC, FC, and so forth) in which the number of rows is placed. |  |  |

Return Values

Return Value | Description
None | This does not return a value


GetSelectedGridRowNumber

Last Modified: B733 | June 04, 1998

GetSelectedGridRowNumber returns the first selected grid row number.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid control |  |  |
Row | Variable (BC, FC, and so forth) in which the row number is placed. |  |  |

Return Values

Return Value | Description
None | This does not return a value


HideGridColumn

Last Modified: B733 | June 04, 1998

HideGridColumn hides a specified grid column.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control |  |  |
Column | <All Columns>,or specific grid column. |  |  |

Return Values

Return Value | Description
None | This does not return a value


InsertGridBufferRow

Last Modified: B733 | June 04, 1998

InsertGridBufferRow takes the grid buffer values and inserts a grid row in the specified location. After the grid row is inserted, the row will receive focus on update grid.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Specify grid to be used |  |  |
Row | Specify row location for insert |  |  |
Selectable? | Yes/No - With this line highlighted, does Select work? |  |  |
Protected? | Yes/No - Can this line be edited? |  |  |
Updateable? | Yes/No - Should the Update/Add events be executed for this row? |  |  |
Deletable? | Yes/No - If this row is highlighted, does Delete work? |  |  |
Clear After? | Yes/No - When the operation is complete, should the GBs be cleared of their values? |  |  |

Return Values

Return Value | Description
None | This does not return a value


InsertGridRow

Last Modified: B733 | June 04, 1998

InsertGridRow produces inconsistent results when used with threaded events. It remains only for backward compatibility and should not be used. Insert Grid Buffer Row is a stable alternative.

Parameters

None.

Return Values

Return Value | Description
None | This does not return a value


SetDataDictionaryItemForGridColumn

Last Modified: B733 | June 04, 1998

SetDataDictionaryItemForGridColumn change the data dictionary item associated with a grid column. All data dictionary attributes are changed.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Identifies the grid control | I | Y |
Column | Identifies the specific grid column | I | Y | The grid column has to be a data dictionary column, not a business view column.
DD Alias | The alias of the data dictionary item to change to | I | Y | Can be a literal or string variable.
System Code | The system code of the item | I | Y | Reserved for future use.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

The specific grid column has to be a data dictionary column, not a business view column. When changing data dictionary items, there are some restrictions. The data dictionary items to be switched must be of the same type except for one case. The one case is, it is possible to change a string to a character, but not vice versa. It is also important to note that is a change is made between string types; the maximum size of the new string item will be the smaller size of the two-switched items.

See Also

  • SetDataDictionaryOverridesForGridColumn

  • SetGridColumnHeading


SetDataDictionaryOverrideForGridColumn

Last Modified: B733 | June 04, 1998

SetDataDictionaryOverrideForGridColumn overrides specific data dictionary attributes of a grid column.

Parameters

Parameter | Description | I/O | Required | Notes
Gird | Identifies the grid control | I | Y |
Column | Identifies the grid column whose attributes are to be changed | I | Y |
Overrides | Presents the data dictionary attributes that can be overridden | I | Y |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

The grid column can be a data dictionary column or a business view column.

See Also

  • SetDataDictionaryItemForGridColumn

  • SetGridColumnHeading


SetGridCellError

Last Modified: B733 | June 04, 1998

SetGridCellError sets an error in the specified grid cell.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control |  |  |
Row | Row Number |  |  |
Row Number | Column Number |  |  |
Error Code | Dictionary defined error code |  |  |

Return Values

Return Value | Description
None | This does not return a value


SetGridColor

Last Modified: B733 | June 04, 1998

SetGridColor sets the color of the entire grid, a row, a column, or a cell.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control |  |  |
Row | Row Number, <All Rows>, <Current Row> |  |  |
Column | Column Number, <All Columns> |  |  |
Color | <Reset Color>, <Pick Color> |  |  |

Return Values

Return Value | Description
None | This does not return a value


SetGridColumnHeading

Last Modified: B733 | June 04, 1998

SetGridColumnHeading sets the grid column heading text.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Identifies the grid control | I | Y |
Column | Identifies the column whose heading is to be changed | I | Y |

Return Values

Return Value | Description
None | This does not return a value

See Also

  • SetControlText

  • SetFormTitle

  • SetDataDictionaryItem

  • SetDataDictionaryItemForGridColumn

  • SetDataDictionaryOverrides

  • SetDataDictionaryOverrideForGridColumn


SetGridFont

Last Modified: B733 | June 04, 1998

SetGridFont sets the font of the entire grid, a row, a column, or a cell.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control |  |  |
Row | Row Number, <All Rows>, <Current row> |  |  |
Column | Column Name, <All Columns> |  |  |
Font | <Reset Font>, <Pick Font> |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This currently does not work well for Internationalization.


SetGridRowBitmap

Last Modified: B733 | June 04, 1998

SetGridRowBitmap sets a specified bitmap on the specified row header.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control |  |  |
Row | Row Number, <Current Row> |  |  |
Bitmap | <Special Values> |  |  |

Return Values

Return Value | Description
None | This does not return a value


SetLowerLimit

Last Modified: B733 | June 04, 1998

SetLowerLimit allows you to effect the select that will fill the grid. Each time SetLowerLimit is called, one WHERE clause is created that will be included in the call to JDB_SetSetLowerLimit. The database call will not be made at the time the system function is called. Calling the system function only creates the WHERE clause. The information will be stored and used at the time Find is pressed.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control | I | Y |
Table | Table Name | I | Y | The table and alias parameters are related, and together they should describe a field from the grid business view.
Alias | Data Dictionary Alias | I | Y | The table and alias parameters are related, and together they should describe a field from the grid business view.
Comparison Type | Comparison to be made | I | Y | Type of comparison to be made (equal, not equal, and greater than)
Comparison Value | Value to be compared against | I | Y | Value to compare the business view item (table/alias) against. This should be the same type as the business view column.
And/Or | Relation to other clauses | I | Y | Yes, No, or None. This defines how this where clause is connected to other where clauses.

Return Value

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

IIn general, this System Function should not be used in cases where the user can affect the select. For example, QBE, and filter fields are ways the user can affect the select. If the user can affect the select then the user's select information should always be taken into consideration. This system function is used in conjunction with SetSelectionAppendFlag to either append or replace the QBE/filter selection with the system function selection.

Related Functions

Function Name | Function Description | Source Name | Description
Set Selection Append Flag | Either appends or replaces the QBE and filter select information with the System Function select information |  |
Clear Selection | Removes all System Function defined where clauses for the select |  |
Set Selection | Another System Function that can affect the select. Results in a call to JDB_SetSelection instead of JDB_SetLowerLimit |  |

See Also

  • Set Sequencing


SetQBEColumnCompareStyle

Last Modified: B733 | June 04, 1998

SetQBEColumnCompareStyle allows the user to set the comparison operator on a specific QBE column.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control |  |  |
Column | Column Name, <All Columns> |  |  |
Compare Style | <Equal To>, <Not Equal To>, <Greater Than>, <Less Than>, <Greater Than or Equal To>, <Less Than or Equal To> |  |  |

Return Values

Return Value | Description
None | This does not return a value


SetSelection

Last Modified: B733 | June 04, 1998

SetSelection allows you to effect the select that will fill the grid. Each time SetSelection is called, one WHERE clause is created that will be included in the JDB_SetSelection. The database call will not be made at the time the system function is called. Calling the system function only creates the WHERE clause. The information will be stored and used at the time the Find button is clicked.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control | I | Y |
Table | Table Name | I | Y | The table and alias parameters are related, together they should describe a field from the grid business view.
Alias | Data Dictionary Alias | I | Y | The table and alias parameters are related, together and they should describe a field from the grid business view.
Comparison Type | Comparison to be made | I | Y | Type of comparison to be made, for example, equal, not equal, or greater than.
Comparison Value | Value to be compared against | I | Y | Value to compare the business view item (table/alias) against. This should be the same type as the business view column.
And/Or | Relation to other clauses | I | Y | Yes, No, or None. This defines how this where clause is connected to other where clauses.

Special Handling Instructions and Prerequisites

In general, this System Function should not be used in cases where the user can affect the select (QBE, and filter fields are ways the user can effect the select). If the user can affect the select then the user's select information should always be taken into consideration. This system function is used in conjunction with SetSelectionAppendFlag to either append or replace the QBE/filter selection with the system function selection.

Related Functions

Function Name | Function Description | Source Name | Description
Set Selection Append Flag | Appends or replaces the QBE and filter select information with the system function select information. |  |
Clear Selection | Removes all system function defined where clauses for the select. |  |
Set Lower Limit | Another System Function that can effect the select. Results in a call to JDB_SetLowerLimit instead of JDB_SetSelection. |  |

See Also

  • SetSequencing


SetSelectionAppendFlag (Grid System Function)

SetSelectionAppendFlag

Last Modified: B733 | June 04, 1998

SetSelectionAppendFlag is used in conjunction with SetSelection or SetLowerLimit. Used alone it has no effect. When used with the selection system functions it determines if the system function defined select information will append or replace the select information in the QBE and filter fields. If this system function is not called when selection system functions are used, the default is to replace.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control | I | Y |
Append | Append, Yes/No | I | Y | Yes means the system function defined select information will be appended. No means it will replace.

Related Functions

Function Name | Function Description | Source Name | Description
Set Selection | A selection system function that results in a call to JDB_SetSelection |  |
Set Lower Limit | A selection system function that results in a call to JDB_SetLowerLimit |  |
Clear Selection | Removes all system function defined where clauses for the select |  |

See Also

  • SetSequencing


SetSequencing

Last Modified: B733 | June 04, 1998

SetSequencing allows the application developer to effect the sort used in filling the grid. Each time SetSequencing is called one WHERE clause is created that will be included in the JDB_SetSequencing. The database call will not be made at the time the system function is called. Calling the system function only creates the WHERE clause. The information will be stored and used at the time the Find button is clicked.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control | I | Y |
Table | Table Name | I | Y | The table and alias parameters are related, together they should describe a field from the grid business view.
Alias | Data Dictionary Alias | I | Y | The table and alias parameters are related, together they should describe a field from the grid business view.
Sort Order | Sort Order – Ascending or Descending | I | Y | Determines if the business view column specified by the previous parameters will be sorted in ascending or descending order.

Special Handling Instructions and Prerequisites

IIn general, this system function should not be used in cases where the user can affect the sort (the presence of the sequencing option is tied to the presence of the QBE line). If the user can affect the sort then the user's sort information should always be taken into consideration.

Related Functions

Function Name | Function Description | Source Name | Description
Clear Sequencing | Removes all system function defined WHERE clauses for the sort |  |

See Also

  • SetSelection

  • SetLowerLimit


ShowGridColumn

Last Modified: B733 | June 04, 1998

ShowGridColumn shows or displays a hidden grid column

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control |  |  |
Column | Column Name, <All Columns> |  |  |

Return Values

Return Value | Description
None | This does not return a value


ShowGridRow

Last Modified: B733 | June 04, 1998

ShowGridRow shows or displays a hidden grid row.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control |  |  |
Row | Row Number, <All Rows>, <Current Row> |  |  |

Return Values

Return Value | Description
None | This does not return a value


SuppressGridLine

Last Modified: B733 | June 04, 1998

SuppressGridLine suppresses the current line about to be written to the grid.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control. |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

This function is usually used on the event GridRecordIsFetched to determine whether to allow the record to be written to the grid.


UpdateGridBufferRow

Last Modified: B733 | June 04, 1998

UpdateGridBufferRow takes the grid buffer values and overwrites the specified grid row.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Specify grid to be used |  |  |
Row | Specify row location for overwrite |  |  |
Selectable? | Yes/No - With this line highlighted, does Select work? |  |  |
Protected? | Yes/No - Can this line be edited? |  |  |
Updateable? | Yes/No - Should the Update/Add events be executed for this row? |  |  |
Deletable? | Yes/No - If this row is highlighted, does Delete work? |  |  |
Clear After? | Yes/No - When the operation is complete, should the GBs be cleared of their values? |  |  |

Return Values

Return Value | Description
None | This does not return a value


WasGridCellValueEntered

Last Modified: B733 | June 04, 1998

WasGridCellValueEntered returns a value indicating if a form control has been changed. A return value of zero indicates no change. A return value of one indicates a change.

Parameters

Parameter | Description | I/O | Required | Notes
Grid | Grid Control. |  |  |
Return to | Location to return the change indicator. |  |  |

Return Values

Return Value | Description
None | This does not return a value


Media Object System Functions

Media Object System Functions consist of the following APIs:

 | Access Media Object
 | Activate Item
 | Clear Characterization Cache
 | Delete Item
 | Get OLE Item
 | HideIconPanel
app.gif (808 bytes) | InsertText
 | Insert URL
app.gif (808 bytes) | LockSplitterBar
app.gif (808 bytes) | SetCursorPosition
app.gif (808 bytes) | SetTextColor
app.gif (808 bytes) | StartWebBrowser


Access Media Object - API_System Functions

AccessMediaObject

Last Modified: EnterpriseOne Xe | July 14, 2000

This system function is similar to the Media Object Structures system function in that it allows you to display and edit existing media objects associated with a particular generic text structure. The only difference between the functions is that Access Media Object uses a GT Data Structure name and the matching key instead of a variable number of parameters to build the key string.

Parameters

Parameter | Description | I/O | Required | Notes
Media Object Control |  | I | Y | FC (Media Object Control) or Default Media Object Control
GT Name | Generic Text Name | I | Y | The data structure created for generic text.
Key String |  | I | Y | F00165 Table Keys
Action |  | I | Y | Only Edit and Display are available
Status |  | O | Y | Implies to active status
Active Item |  | I | Y | The item that will be activated when the media object displays.

Available Events

Available on all events

Related Tables

Function Name | Function Description
F00165 | Media Object Storage

Related Topics

· Media Object Structures, Delete Item, Activate Item


Activate Item - API_System Functions

ActivateItem

Last Modified: EnterpriseOne | July 14, 2000

This system function allows the specific media object item to be brought forward or active.

Parameters

Parameter | Description | I/O | Required | Notes
Media Object Control |  | I | Y | Use <Default Media Object> or Form Control containing media object.
Item [in] |  | I | Y | Item ID to be activated

Special Handling Instructions and Prerequisites

· Media Object is required.

Available Events

Available on all events

Related Topics

· Delete Item, Access Media Object


Clear Characterization Cache - API_System Functions

ClearCharacterizationCache

Last Modified: EnterpriseOne | July 14, 2000

This system function clears all values in the characterization cache that were set previously by the Set Characterization Cache system function. After this system function is called, adding media objects will not automatically generate a record in the F00166 table.

Parameters

Parameter | Description | I/O | Required | Notes
Media Object Control |  | I | Y | Use <Default Media Object> or any Form Control media object
GTName | Generic Text Name | I | Y | Generic Text Data Structure.

Available Events

Available on all events

Related Tables

Function Name | Function Description
F00166 | Media Object Categories

Related Topics

· Set Characterization Cache, Disable Characterization


Delete Item - API_System Functions

DeleteItem

Last Modified: EnterpriseOne | July 14, 2000

This system function will delete the item from the media object.

Parameters

Parameter | Description | I/O | Required | Notes
Media Object Control |  | I | Y | Use <Default Media Object> or any form control media object
Item [in] |  | I | Y | Item define in the media object

Available Events

Available on all events

Related Tables

Function Name | Function Description
F00165 | Media Object Storage

Related Topics

· Activate Item, Access Media Object


Get OLE Item - API_System Functions

GetOLEItem

Last Modified: EnterpriseOne | July 14, 2000

This system function will replace the ExtractWordDocumentAndRunMacro API currently used by proposal generation (the API will be obsoleted). It will take a media object sequence number and an OLE automation server interface variable as parameters and will return in that interface variable a handle to the OLE object with that sequence number in the media object record.

Parameters

Parameter | Description | I/O | Required | Notes
Media Object Control |  | I | Y | Use <Default Media Object> or Form Control containing media object.
Item [in] |  | I | Y | Item ID
Object Ref [out] |  | O | Y | This is an ActiveX/COM interface variable.

Return Values

NOERROR

E_FAIL

Special Handling Instructions and Prerequisites

· Media Object is required.

Available Events

Available on all events

Related Topics

· Insert URL Item, Insert OLE Item


HideIconPanel

Last Modified: B733 | June 04, 1998

This media object system function works in conjunction with a media object control embedded in an application. If a developer does not want an end user to have access to the toolbar that is associated with the media object control, it can be hidden from view using this system function.

Parameters

Parameter | Description | I/O | Required | Notes
Hide icon panel? | fixed value | I | Y | If “Yes”: The toolbar is HIDDEN If “No”: The toolbar is VISIBLE

Return Values

Return Value | Description
None | This does not return a value

The following media object system functions are available:

  • CopyTableDataSource

  • CopyTableEnvironment

  • DeleteCurrentInputRow

  • UpdateCurrentInputRow


InsertText

Last Modified: EnterpriseOne | December 18, 1999

InsertText is a media object system function that inserts a given text into the Text Item of the Media Object Control on a form.

Parameters

Parameter | Description | I/O | Required | Notes
Media Object Control | A form control which is of Type Media Object | I | Y |
Text ID | This is the ID of the specific text Item in the media object | I | Y |
Text | This is the actual text that is going to be inserted. This could be a text variable (TV) Or any other Object of type EVDT_STRING or it can be a literal value |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

You should have media object controls on the form to use this system function


Insert URL - API_System Functions

InsertURL

Last Modified: EnterpriseOne | July 14, 2000

This system function is formerly known as StartWebBrowser (the API is now obsolete). It is used to place an HTML page in a media object control embedded in an EnterpriseOne application. This function specifies the media object queue name where the HTML file resides and the name of the file. It will then be displayed in the right-hand panel of the media object control as a web page.

Parameters

Parameter | Description | I/O | Required | Notes
Media Object Control |  | I | Y | Use <Default Media Object> or Form Control containing media object.
MO Queue Name |  | I | Y | Name of media object queue in which HTML files resides
HTML File Name |  | I | Y | Name of HTML file to be displayed

Return Values

NOERROR

E_FAIL

Special Handling Instructions and Prerequisites

· Media Object is required.

Related Tables

Function Name | Function Description
F00165 | Media Object Storage

Related Topics

· Insert OLE Item, Get OLE Item


LockSplitterBar

Last Modified: B733 | June 04, 1998

LockSplitterBar is used in conjunction with a media object control that has been embedded within an application. A splitter bar separates the left and right panes of the control. This function either locks the splitter bar so that it is not available to the user, or release it so that the splitter bar is available to the user.

Parameters

Parameter | Description | I/O | Required | Notes
Lock Splitter Bar? | Fixed value | I | Y | If “Yes”: The splitter bar is LOCKED If “No”: The splitter bar is RELEASED

Return Values

Return Value | Description
None | This does not return a value


SetCursorPosition

Last Modified: EnterpriseOne | May 09, 1999

This media object system function sets the cursor position in the Media Object Text to the HOME or END positions.

Parameters

Parameter | Description | I/O | Required | Notes
Media Object Control | This is the specific Media Object Control on the Form as the Form can have more than one Media Object Control | I | Y |
Position | <HOME> <END> | I | Y |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

You must add Media Object Controls on a Form In order to Use this function.

Remember this sets the Cursor position in the Media Object Text to the HOME or END positions


Set TextColor

Last Modified: EnterpriseOne | December 18, 1999

SetTextCoor is a media object system function that sets the color of the text in the Media Object Control as required.

Parameters

Parameter | Description | I/O | Required | Notes
Media Object Control | This is a Form control which is of Type Media Object | I | Y |
Color | this will bring up a Color palette so that the user can select a specific color. | I | Y |

Return Values

Return Value | Description
None | This does not return a value


StartWebBrowser

Last Modified: B733 | June 04, 1998

This medial object system function is used to place an HTML page in a media object control embedded in an EnterpriseOne application. Specifies the media object queue name where the HTML file resides and the name of the file. It will then be displayed in the right-hand panel of the media object control as a web page.

Parameters

Parameter | Description | I/O | Required | Notes
Queue Name | Media Object Queue Name | I | Y | Name of the Media Object queue in which the HTML file resides.
File Name | HTML File Name | I | Y | Name of the HTML file to be displayed.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

The HTML page must reside within a media object queue that is defined in EnterpriseOne. The system function will not accept an absolute address. Once the user is in the application, they may navigate when the page is designed to let them go.


Messaging System Functions

Messaging System Functions consist of the following APIs:

 | DeleteMessage
app.gif (808 bytes) | ForwardMessage
 | SendMessage
app.gif (808 bytes) | TemplateSubstitution
 | UpdateMessage


Parent Child System Functions

Parent Child System Functions consist of the following APIs:

 | ClearGridBuffer
app.gif (808 bytes) | ContractTreeNode
 | CopyGridRowToGridBuffer
app.gif (808 bytes) | DeleteAllNodes
 | DeleteGridRow
app.gif (808 bytes) | DeleteTreeNode
 | ExpandTreeNode
app.gif (808 bytes) | GetGridRow
 | GetMaxGridRows
app.gif (808 bytes) | GetNodeLevel
 | Get Node Information
app.gif (808 bytes) | GetSelectedGridRowCount
 | GetSelectedGridRowNumber
app.gif (808 bytes) | GetTreeNodeHandle
 | HIdeGridColumn
app.gif (808 bytes) | InsertGridBufferRow
 | InsertGridRow
app.gif (808 bytes) | InsertTreeNode
app.gif (808 bytes) | SetDataDictionaryItem
 | SetDataDictionaryOverrideForGridColumn
app.gif (808 bytes) | SetDragCursor
 | SetGridColor
app.gif (808 bytes) | SetGridColumnHeading
 | SetGridFont
app.gif (808 bytes) | SetGridRowBitmap
 | SetNodeBitmap
app.gif (808 bytes) | SetNodeInformation
 | SetTreeBitmapScheme
 | SetTreeNodeFont
app.gif (808 bytes) | SetTreeNodeHandle
 | ShowGridColumn
app.gif (808 bytes) | SuppressFetchOnNodeExpand
 | SuppressGridLine
app.gif (808 bytes) | UpdateGridBufferRow


ClearGridBuffer

Last Modified: B733 | June 08, 1998

Please refer to the corresponding system function documented under Grid system functions.


ContractTreeNode

Last Modified: B733.1 | March 29, 1998

ContractTreeNode collapses a particular node in the tree.

Parameters

Parameter | Description | I/O | Required | Notes
Tree Control | Identifies the tree control | I | Y |
Node | Identifies the node to collapse | I | Y | Possible Values: Currently Selected Node, Last Inserted Node, and Current Expanding/Collapsing Parent

Return Values

Return Value | Description
None | This does not return a value

See Also

  • Expand Tree Node


CopyGridRowToGridBuffer

Last Modified: EnterpriseOne | May 09, 1999

Please refer to the corresponding system function documented under Grid system functions.


DeleteAllNodes

Last Modified: EnterpriseOne | May 09, 1999

DeleteAllNodes deletes all items in the Parent/Child control.

Parameters

Parameter | Description | I/O | Required | Notes
Parent/Child | Identifies the Parent/Child Control. |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

The developer could call this system function after the fetch operation has been suppressed. This will delete all the previous items in the control. The developer can then add custom items in the parent/child control.

See Also

  • GetNodeLevel

  • SuppressFetchOnNodeExpand


DeleteGridRow

Last Modified: B733.1 | March 10, 1998

DeleteGridRow deletes a particular item (grid line and the corresponding tree node) in the Parent/Child Control.

Parameters

Parameter

Description

I/O

Required

Notes

Parent/Child – Grid

The Parent/Child Control to which this grid belongs.

Row

The row which has to be deleted. Possible Values are :

  • All Rows - All rows in the grid. All Children nodes under the current node.

  • Drag Node Row - The row corresponding to the node that is being dragged by the user during drag and drop operation.

  • Last Row - Last Row in the Grid.

  • Row No. Held in any of the BC, FC, grid column etc. in the Form

  • Literal - A literal number that can be typed by the user. For example, “1”

  • Current Row - The currently selected row in the Grid.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

The grid in the Parent/Child Control contains lines which are relative to the current parent node in the tree. The grid is refreshed when the user changes the parent level node in the tree.


DeleteTreeNode

Last Modified: B733.2 | March 29, 1999

DeleteTreeNode deletes a node in the tree control.

Parameters

Parameter | Description | I/O | Required | Notes
Tree Control | Identifies the tree control | I | Y |
Node | Identifies the node to delete | I | Y | Possible Values: Currently Selected Node, Last Inserted Node, All Children Nodes Under Current Node and All Nodes

Return Values

Return Value | Description
None | This does not return a value.


ExpandTreeNode

Last Modified: B733.1 | may 11, 1999

ExpandTreeNode expands a particular node in the tree.

Parameters

Parameter | Description | I/O | Required | Notes
Tree Control | Identifies the tree control | I | Y |
Node | Identifies the node to collapse | I | Y | Possible Values: Currently Selected Node, Last Inserted Node, and Current Expanding/Collapsing Parent

Return Values

Return Value | Description
None | This does not return a value

See Also

  • ContractTreeNode


GetGridRow

Last Modified: B733 | June 08, 1998

Please refer to the corresponding system function documented under Grid system functions.


GetMaxGridRows

Last Modified: B733 | June 08, 1998

Please refer to the corresponding system function documented under Grid system functions.


GetNodeLevel

Last Modified: B733.2 | March 22, 1999

GetNodeLevel returns the node level of a particular node. The root has a level of 0.

Parameters

Parameter | Description | I/O | Required | Notes
Tree Control | Identifies the tree control | I | Y |
Node | Identifies the node to collapse | I | Y | Possible Values: Currently Selected Node, Last Inserted Node, and Current Expanding/Collapsing Parent
Return To | Specifies the object that will hold the return value | O | Y | Should be a numeric object.

Return Values

Returns the level of the node specified.


Get Node Information

Last Modified: B733.2 | September 29, 1999

Get Node Information returns the display text of a node and its associated node value. The node value is stored by the application developer while inserting the node or by using the Set Node Information system function. A typical use is to store a key value associated with the tree node. Data of any type can be stored in the node value as long as the developer maintains consistency in storing and retrieving the value.

Parameters

Parameter | Description | I/O | Required | Notes
Tree Control | Identifies the tree control. | I | Y |
Node | Identifies the node to collapse. | I | Y | Possible Values: Currently Selected Node, Last Inserted Node, and Current Expanding/Collapsing Parent
Node Text | This parameter will hold the current display text of the node. | O | Y | The data type of this parameter should be the same as that is displayed by the node. For example, if the node is displaying a numeric value, this parameter should be a numeric value.
Node Value | This parameter will hold the value associated with this node. | O | Y | The data type of this parameter should be the same as that of the value currently stored in the node. For example, if the node currently has a numeric value, this parameter should be a numeric value.

Return Values

The node text and the node value are returned by this function.

See Also

  • Set Node Information

  • Insert Tree Node


GetSelectedGridRowCount

Last Modified: EnterpriseOne | May 09, 1999

Please refer to the corresponding system function documented under Grid system functions.


GetSelectedGridRowNumber

Last Modified: EnterpriseOne | May 09, 1999

Please refer to the corresponding system function documented under Grid system functions.


GetTreeNodeHandle

Last Modified: B733.2 | May 07, 1999

GetTreeNodeHandle retrieves the user data/table handle associated with a particular tree node.

Parameters

Parameter | Description | I/O | Required | Notes
Parent/Child Control | Identifies the parent/child control | I | Y |
Node | Identifies the specific tree node | I | Y | Available values are: <Currently Selected Node>, <Last Inserted Node>, <Root Node>, <Current Expanding/Collapsing Parent> or <Current Deleted Node>.
Index | Identifies the index of the handle | I | Y | Applications can associate more than one handles to one tree node. Use this parameter to differentiate multiple handles for the same node.
Handle | The handle associated with the given node | O | Y | The system function will put the handle value in this parameter when it returns.

Return Values

Return Value | Description
None | This does not return a value

The required handle value is returned through the output parameter.

See Also

  • SetTreeNodeHandle

  • GetTreeNodeHandle


HideGridColumn

Last Modified: B733

Please refer to the corresponding system function documented under Grid system functions.


InsertGridBufferRow

Last Modified: B733.1 | June 08, 1999

InsertGridBufferRow inserts a grid row and a tree node in the Parent/Child Control from the current values in the grid buffer columns.

Parameters

Parameter

Description

I/O

Required

Notes

Parent/Child - Grid

The Parent/Child Control to which this Grid belongs.

Row

The row after which a parent/child item has to be added. Possible Values are :

  • Under Current Expanding Parent - Insert under expanding tree node during the NodeIsExpending event or the GetCustomTreeNode event

  • Literal - A literal number that can be typed by the user. For example, “1”.

  • After Current Row - After the currently selected row in the Grid.

  • Under Drop Node - The row corresponding to the node on which the mouse is released after a drag and drop operation. This parameter must be used only in the “Tree - End Drop Operation” event.

  • Under Prop Node As First Child - The row corresponding to the node on which the mouse is released after a drag and drop operation. This parameter must be used only in the "Tree-End Drip Operation" event. The difference between this and the previous option is that this option will insert the grid row as the first child of the drop node, while "Under Drop Node" will insert it as the last child of the drop node.

  • After Last Row - Insert at the end of the Grid.

  • Row No. Held in any of the BC, FC, grid column etc. in the Form

Selectable?

Indicates whether the select event is possible for the item. If this parameter is equal to “no”, then no selection event will be handled for this item in the parent/child control.

Protected ?

Indicates whether the grid row is input capable or not. This parameter does not apply to the Find/Browse forms.

Updateable?

Indicates whether the grid row is capable of updating the database or not. This parameter does not apply to the Find/Browse forms.

Deletable?

Indicates whether the item could be deleted by the delete event.

Clear After?

Indicates whether the Grid Buffer columns have to be deleted after the system function call.

Expandable?

Indicates whether the item is capable of being expanded in the tree control. If this parameter is equal to “no”, then the item would be inserted as a child node in the tree side. Otherwise it is inserted as a node which is capable of sending the “Item is Expanding “ event.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

The Grid in the Parent/Child Control contains lines which are relative to the current parent node in the Tree. The Grid is totally refreshed when the user changes the parent level node in the tree.


InsertGridRow (Obsolete)

InsertGridRow

Last Modified: B733

Refer to the corresponding system function documented under Grid system functions.


InsertTreeNode

Last Modified: B733.2 | September 29, 1999

Insert Tree Node inserts a tree node into the tree control.

Parameters

Parameter | Description | I/O | Required | Notes
Tree Control | Identifies the tree control. | I | Y |
Node | Identifies the node to collapse. | I | Y | Possible Values: Under Currently Selected Node, After Currently Inserted Node, After Last Inserted Node, Under Root Node and Under Current Expanding Parent
Node Text | This parameter will hold the current display text of the node. | O | Y | The data type of this parameter should be the same as that is displayed by the node. For example, if the node is displaying a numeric value, this parameter should be a numeric value.
Node Value | This parameter will hold the value associated with this node. | O | Y | The data type of this parameter should be the same as that of the value currently stored in the node. For example, if the node currently has a numeric value, this parameter should be a numeric value.

Return Values

The node text and the node value are returned by this function.

See Also

  • Set Node Information

  • Get Node Information


SetDataDictionaryItem

Last Modified: B733.2 | June 29, 1998

SetDataDictionaryItem change the data dictionary item associated with a grid column. All data dictionary attributes are changed.

Parameters

Parameter | Description | I/O | Required | Notes
Parent/Child-Grid | Identifies the parent/child control | I | Y |
Column | Identifies the specific grid column | I | Y | The grid column must be a data dictionary column.
DD Alias | The alias of the data dictionary item to change to | I | Y | Can be a literal or string variable.

Return Values

Return Value | Description
None | This does not return a value

See Also

  • SetDataDictionaryOverrideForGridColumn

  • SetGridColumnHeading


SetDragCursor

Last Modified: B733

SetDragCursor sets a particular cursor during drag and drop operation in the Tree control. You can set the Default Cursor if a node on which the cursor is presently dragged over is capable of accepting the drag/drop operation. Otherwise, the No Drop Cursor should be set.

This system function must be used only on the event “Tree - Drag Over Node”.

Parameters

Parameter

Description

I/O

Required

Notes

Parent/Child

The Parent/Child Control.

Cursor

Identifies the cursor which will be used during the drag and drop operation. The possible values are:

  • Default Cursor - Indicates that drag and drop operation is possible over a particular node.

  • No Drop Cursor - Indicates that drag and drop operation is not possible over a particular node.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

The following piece of ER shows the use of this system function :

  • Event: Tree - Drag Over Node

If grid column TS is equal to “REP”

Set Drag Cursor(FC Parent/Child, <Default Cursor>)

Else

Set Drag Cursor(FC Parent/Child, <No Drop Cursor>)


SetGridColor

Last Modified: B733

Please refer to the corresponding system function documented under Grid system functions.


SetGridColumnHeading

Last Modified: B733.1 | June 29, 1998

SetGridColumnHeading set the grid column heading text.

Parameters

Parameter | Description | I/O | Required | Notes
Parent/Child - Grid | Identifies the parent/child control | I | Y |
Column | Identifies the column whose heading is to be changed | I | Y |

Return Values

Return Value | Description
None | This does not return a value

See Also

  • SetDataDictionaryItem

  • SetDataDictionaryOverrideForGridColumn


SetGridFont

Last Modified: B733

Please refer to the corresponding system function documented under Grid control system functions.

Related Topics

  • SetGridFont


SetGridRowBitmap

Last Modified: B733

Please refer to the corresponding system function documented under Grid system functions.


SetNodeBitmap

Last Modified: B733.1 | June 29, 1998

SetNodeBitmap sets the bitmap for a node in the tree control.

Parameters

Parameter | Description | I/O | Required | Notes
Tree Control | Identifies the Tree Control | I | Y |
Node | Identifies the node to collapse | I | Y | Possible Values: Under Currently Selected Node, After Currently Inserted Node, After Last Inserted Node, Under Root Node and Under Current Expanding Parent
Bitmap | Identifies the name of the bitmap | I | Y | The bitmap must be of size 16X16 and should reside in the treebmps sub-directory of the resource directory (for example, d:\b7\appl_pgf\res\treebmps). If the bitmap load fails, the application uses the default behavior for the tree node.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

Once the bitmap for a tree node is set, the default scheme changes for that node. The Open and closed bitmap are no longer applicable.

See Also

  • Set Bitmap Scheme


SetNodeInformation

Last Modified: B733.1 | June 29, 1998

SetNodeInformation can be used to display the text of a node and its associated node value. A typical use of a node value is to store a key value associated with the tree node. Data of any type can be stored in the node value as long as the developer maintains consistency in storing and retrieving the value.

Parameters

Parameter

Description

I/O

Required

Notes

Tree Control

Identifies the tree control.

I

Y

Node

Identifies the node to collapse.

I

Y

Possible Values:

  • Currently Selected Node

  • Last Inserted Node

  • Current Expanding/Collapsing Parent

Node Text

This parameter will hold the current display text of the node.

O

Y

The data type of this parameter should be the same as that is displayed by the node. For example, if the node is displaying a numeric value, this parameter should be a numeric value.

Node Value

This parameter will hold the value associated with this node.

O

Y

The data type of this parameter should be the same as that of the value currently stored in the node. For example, if the node currently has a numeric value, this parameter should be a numeric value.

Return Values

Return Value | Description
None | This does not return a value.

See Also

  • GetNodeInformation

  • InsertTreeNode


SetTreeBitmapScheme

Last Modified: B733.1 | June 29, 1998

SetTreeBitmapScheme sets the default bitmap schema that will be used by the tree nodes in the tree control. The Bitmaps must be of size 16X16 and should reside in the treebmps sub-directory of the resource directory (for example: d:\b7\appl_pgf\res\treebmps). If a bitmap fails to load, the application uses the corresponding standard bitmap.

The ideal place for using this system function is during the event "Dialog is initialized"

Parameters

Parameter | Description | I/O | Required | Notes
Tree Control | Identifies the tree control. | I | Y |
Open Bitmap | Identifies the bitmap to be used when a particular tree node is in an expanded state. | I | Y |
Closed Bitmap | Identifies the bitmap to be used when a particular tree node is in a collapsed state. | I | Y |
Leaf Bitmap | Identifies the bitmap to be used when a particular tree node does not have any children. | I | Y |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

Once the bitmap scheme is set all previously loaded Bitmaps for that particular form are lost. The application developer should not attempt to change the bitmap schema for the tree control after a number of Bitmaps have been loaded through the system function "Set Tree Node Bitmap".

See Also

  • Set Node Bitmap


SetTreeNodeFont

Last Modified: B733.2 | March 15, 1999

SetTreeNodeFont set the font of a specific tree node.

Parameters

Parameter | Description | I/O | Required | Notes
Parent/Child Control | Identifies the parent/child control | I | Y |
Node | <Currently Selected Node> or <Last Inserted Node> or <Current Expanding/Collapsing Parent> | I | Y |


Set Tree Node Handle

Last Modified: B733.1 | June 29, 1998

Set Tree Node Handle system function associates a Handle with a particular Tree Node. Typically this tree node handle can be associated during the node is expanding event and used later on to fetch data during Get Custom Tree Node event.

Parameters

Parameter | Description | I/O | Required | Notes
Tree Control | Identifies the tree control | I | Y |
Node | Identifies the node to collapse | I | Y | Possible Values: Currently Selected Node, Last Inserted Node, Current Expanding/Collapsing Parent and Currently Deleted Node
Index | Identifies the index of the node handle | O | Y | This is a number used to uniquely identify a particular node handle
Node Handle | Identifies a node handle | O | Y | This is typically a database handle or cache handle used to fetch data to fill up child nodes of a particular tree node.

Return Values

Return Value | Description
None | This does not return a value

See Also

  • Set Tree Node Handle


ShowGridColumn

Last Modified: B733

Refer to the corresponding system function documented under Grid system functions.


SuppressFetchOnNodeExpand

Last Modified: B733

SuppressFetchOnNodeExpand suppresses the fetch operation that would be normally be performed when the node is expanded on the tree.

During the fetch operation the parent/child key relationship that has been set up in FDA is utilized. However, if this system function is called, this normal behavior is suppressed. The developer could call this system function and then add custom nodes to the currently expanded tree node in parent/child control.

Parameters

Parameter | Description | I/O | Required | Notes
Parent/Child | Identifies the Parent/Child Control. |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

The grid in the parent/child control contains lines which are relative to the current parent node in the Tree. The grid is refreshed when the user expands a node in the tree. If the tree node does not contain any children, the grid is filled with items from the child items of the upper level parent item and the row corresponding to the current tree node is selected. Otherwise, the grid is filled with the child items of the expanding node and the row corresponding to the first child item is selected.

See Also

  • DeleteAllNodes

  • GetNodeLevel


SuppressGridLine

Last Modified: B733

Refer to the corresponding system function documented under Grid system functions.


UpdateGridBufferRow

Last Modified: B733

Refer to the corresponding system function documented under Grid system functions.


Text Control Functions

Text Control Functions consist of the following APIs:

app.gif (808 bytes) | Get last Clicked Segment
app.gif (808 bytes) | Get Segment Information
app.gif (808 bytes) | Remove segment
app.gif (808 bytes) | Update Segment


Get Last Clicked Segment

Last Modified: B733.2 | September 29, 1999

Get Last Clicked Segment gets the segment ID of the segment which was last selected with the mouse.

Parameters

Data Item | Description | I/O | Required | Notes
FC Text Control | Text Control | I | Y | Specifies which Text Control to get the last clicked segment from.
INT | Segment Id | O | Y | Specifies a variable to receive the segment ID of the last clicked segment.

Related Functions

Function Name | Function Description I/O | Source Name | Description
Add Segment | Adds a segment |  | Adds a segment to a text control
Get Segment Info | Returns the segment info |  | Return segment info of the specified segment
Remove Segment | Deletes a Segment |  | Deletes a segment given the specified segment
Update Segment | Updates properties of a segment |  | Updates the text and clickable properties of the specified segment


Get Segment Information

Last Modified: B733.2 | September 29, 1999

Get segment info gets the property values of the specified text segment

Parameters

Data Item | Description | I/O | Required | Notes
FC Text Control | Text Control | I | Y |
String | Text | O | Y | This field specifies the text string of the segment.
INT | Clickable | O | Y | This field specifies if the segment generates a "Text Clicked" event.
INT | Segment Id | I | Y | Specifies the segment from which to get the properties.

Related Functions

Function Name | Function Description I/O | Source Name | Description
Get Last Clicked Segment | Return segment Id |  | Returns segment ID of the last clicked segment.
Add Segment | Adds a segment |  | Adds a segment to the specified text control.
Remove Segment | Deletes a Segment |  | Deletes a segment depending on the specified segment.
Update Segment | Updates properties of a segment |  | Updates the text, and clickable properties of the specified segment.


Remove Segment

Last Modified: B733.2 | September 29, 1999

Remove Segment removes a segment from the specified text control.

Parameters

Data Item | Description | I/O | Required | Notes
FC Text Control | Text Control | I | Y | The Text control from which to remove a segment.
INT | Segment Id | I | Y | Specifies the segment to remove

Related Functions

Function Name | Function Description I/O | Source Name | Description
Add Segment | Adds a segment |  | Adds a segment to a text control
Get Segment Info | Returns the segment info |  | Return segment info of the specified segment
Get Last Clicked Segment | Return segment Id |  | Return segment Id of the last clicked segment
Update Segment | Updates properties of a segment |  | Updates the text and clickable properties of the specified segment


UpdateSegment

Last Modified: EnterpriseOne | July 10, 2000

Update Segment system function allows text and clickable properties to be updated to the specified segment.

Parameters

Parameter | Description | I/O | Required | Notes
Text Control |  | I | Y | Use FC Text Control
Text | String | I | Y | This field specifies the text string of the segment to be updated.
Font |  | I | Y | <Pick Font> or <Reset Font>
Clickable | Int | I | Y | This field specifies if the segment generates a "Text Clicked" event
SegmentID | Int | I | Y | Specifies the segment to which the text and clickable properties to be updated.

Return Values

None

Available Events

Available on all events

Related Topics

· Get Segment Information, Get Last Clicked Segment, Remove Segment, Update Segment


Workflow System Functions

Workflow System Functions consist of the following APIs:

 | Complete Activity
 | Complete Activity Inline
app.gif (808 bytes) | Get Activity Instance For Key
 | Get Process Instance Attributes
app.gif (808 bytes) | Get Process Instance For Key
app.gif (808 bytes) | Start Composer Process
 | Start Process
app.gif (808 bytes) | Start Process Inline
app.gif (808 bytes) | Update Process Instance Attributes
 | Update Process Instance Attribute Single


Complete Activity

Last Modified: EnterpriseOne | March 29, 2000

Complete Activity completes an activity instance and resumes the workflow process asynchronously.

Parameters

Parameter | Description | I/O | Required | Notes
Process Name | Name of workflow process | I | Y | Allowed values are defined in the Process Master (F98800).
Process Version | Version number of workflow process | I | Y | Can be retrieved by GetActivityInstanceForKey or GetProcessInstanceForKey
Process Instance | Instance number of workflow process | I | Y | Can be retrieved by GetActivityInstanceForKey or GetProcessInstanceForKey
Activity Name | Name of the activity | I | Y |
Activity Instance | Instance number of the activity to complete | I | Y | Can be retrieved by GetActivityInstanceForKey
Group # | Group number of the recipient | I | Y | Can be retrieved by GetActivityInstanceForKey; used for message activities sent to a distribution list only.
Sequence # | Sequence number of the recipient within a group | I | Y | Can be retrieved by GetActivityInstanceForKey; used for message activities sent to a distribution list only.
Action |  | I | Y | <Unopened><Opened><Approved> <ByPassed> <Rejected> <Expired> <Completed>

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

Function

GetActivityInstanceForKey can be used to retrieve the process and activity instance values required as input to this function.

Related Tables

Table Name | Table Description
F98865 | Process Activity Instances

See Also

· Get Activity Instance For Key

· Get Process Instance For Key

· Complete Activity In Line


CompleteActivityInline

Last Modified: EnterpriseOne | March 29, 2000

Complete Activity Inline completes an activity instance and resumes the workflow process in line.

Parameters

Parameter | Description | I/O | Required | Notes
Process Name | Name of workflow process | I | Y | Allowed values are defined in the Process Master (F98800).
Process Version | Version number of workflow process | I | Y | Can be retrieved by GetActivityInstanceForKey or GetProcessInstanceForKey
Process Instance | Instance number of workflow process | I | Y | Can be retrieved by GetActivityInstanceForKey or GetProcessInstanceForKey
Activity Name | Name of the activity | I | Y |
Activity Instance | Instance number of the activity to complete | I | Y | Can be retrieved by GetActivityInstanceForKey
Group # | Group number of the recipient | I | Y | Can be retrieved by GetActivityInstanceForKey; used for message activities sent to a distribution list only.
Sequence # | Sequence number of the recipient within a group | I | Y | Can be retrieved by GetActivityInstanceForKey; used for message activities sent to a distribution list only.
Action |  | I | Y | <Unopened><Opened><Approved> <ByPassed> <Rejected> <Expired> <Completed>

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

Function

Get Activity Instance For Key can be used to retrieve the process and activity instance values required as input to this function.

Related Tables

Table Name | Table Description
F98865 | Process Activity Instances

See Also

· Get Activity Instance For Key

· Get Process Instance For Key

· Complete Activity


Get Activity Instance For Key

Last Modified: EnterpriseOne | March 29, 2000

Get Activity Instance For Key retrieves the active Workflow activity instance information for a given key.

Parameters

Parameters | Description | I/O | Required | Notes
Process Name | Name of workflow process | I | Y | Allowed values are defined in the Process Master (F98800).
Process Key | Key Data | I | Y | Data structure of key data items identifying the instance.
Activity Name | Name of the activity | I | Y |
Resource | Address book number of message recipient | I | Y | Used for message activity. Pass zero otherwise.
Process Version | Version number of workflow process | O |  |
Process Instance | Instance number of workflow process | O |  |
Activity Instance | Instance number of the activity | O |  |
Group # | Group number of the recipient | O |  | Used for message activities sent to a distribution list only.
Sequence # | Sequence number of the recipient within a group | O |  | Used for message activities sent to a distribution list only.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

If this activity is a message activity to a distribution list, there will be more than one activity instances for this activity. If the activity instance for a particular recipient is desired, then the address book number is required. Otherwise, for all other activity types, pass zero.

Related Tables

Table Name | Table Description
F98860 | Workflow Process Instance
F98865 | Workflow Activity Instance

See Also

· Complete Activity


Get Process Instance Attributes

Last Modified: EnterpriseOne | March 29, 2000

Get Process Instance Attributes retrieves the key and attribute data structures for a given process instance.

Parameters

Parameter | Description | I/O | Required | Notes
Process Name | Name of workflow process | I | Y | Allowed values are defined in the Process Master (F98800).
Process Version | Version number of workflow process | I | Y | Can be retrieved by GetProcessInstanceForKey
Process Instance | Instance number of workflow process | I | Y | Can be retrieved by GetProcessInstanceForKey
Process Key | Key Data | O |  | Mapping of data structure data items to form controls, variables, and so forth.
Process Attributes | Additional Data | O |  | Mapping of data structure data items to form controls, variables, and so forth.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

Before calling this function, the process version and process instance values can be retrieved using functions GetProcessInstanceForKey or GetActivityInstanceForKey

See Also

· Get Process Instance For Key

· Get Activity Instance For Key


Get Process Instance For Key

Last Modified: EnterpriseOne | March 29, 2000

Get Process Instance For Key retrieves the Workflow process instance for a given key.

Parameters

Parameter | Description | I/O | Required | Notes
Process Name | Name of workflow process | I | Y | Allowed values are defined in the Process Master (F98800).
Process Key | Key Data | I | Y | Data structure of key data items identifying the instance.
Process Status | Status of the process instance to be retrieved | I | Y | <All> <Active> <Inactive> <Completed> <Suspended> <Terminated> <Error>
Set Error Y/N | Not used | I | Y | <Yes> <No> (not available)
Process Version | Version number of workflow process | O |  |
Process Instance | Instance number of workflow process | O |  |

Return Values

Return Value | Description
None | This does not return a value


StartComposerProcess

First Available: B73.2

Start Composer Process functions exactly like Start Process In Line, except that it takes the input values from variables instead of mapped process name and data structures.

Parameters

Parameter | Description | I/O | Required | Notes
Process Name | Name of workflow process | I | Y | Process name passed from form controls, business view values, variables and so forth.
Key DS | Key Data | I | Y | A vertical bar delimited string (‘|’) of values that corresponds to the Key data structure used by the process indicated in the first parameter.
Attribute DS | Additional workflow data | I | N | A vertical bar delimited string (‘|’) of values that corresponds to the Attribute data structure used by the process indicated in the first parameter.

Return Values

This function does not return a value. However, the system value, SV_StartProcStatus, will be set to one of the following three values:

Return Value | Description
Start_Process_Awaiting | An instance of this process is active for the same key. This process instance will become active when the previous instance completes.
Start_Process_Failed | Error occurred creating the process.
Start_Process_Success | Process started successfully.

Related Tables

Function Name | Function Description
F98800 | Process Definition
F98860 | Process Instances
F98865 | Process Activity Instances

See Also

Start Process In Line

Note

This system function is used primarily for Composer processes to dynamically invoke a different composer process at run time. Please use Start Process or Start Process in Line for regular workflow processes.


Start Process

Last Modified: EnterpriseOne | March 29, 2000

Start Process starts a Workflow process asynchronously.

Parameters

Parameter | Description | I/O | Required | Notes
Process Name | Name of workflow process | I | Y | Allowed values are defined in the Process Master (F98800).
Key DS | Key Data | I | Y | Mapping of data structure data items to form controls, variables, and so forth.
Attribute DS | Additional workflow data | I | N | Mapping of data structure data items to form controls, variables, and so forth.

Return Values

This function does not return a value. However, the system value, SV_StartProcStatus, will be set to one of the following two values:

Return Value | Description
Start_Process_Awaiting | An instance of this process is active for the same key. This process instance will become active when the previous instance completes; or process is successfully created on a queue and waiting to be executed.
Start_Process_Failed | Error occurred creating the process.

Related Tables

Function Name | Function Description
F98800 | Process Definition
F98860 | Process Instances
F98865 | Process Activity Instances

See Also

· Start Process In Line


Start Process In Line

Last Modified: EnterpriseOne | March 29, 2000

Start Process In Line starts a Workflow process in line.

Parameters

Parameter | Description | I/O | Required | Notes
Process Name | Name of workflow process | I | Y | Allowed values are defined in the Process Master (F98800).
Key DS | Key Data | I | Y | Mapping of data structure data items to form controls, variables, and so forth.
Attribute DS | Additional workflow data | I | N | Mapping of data structure data items to form controls, variables, and so forth.

Return Values

This function does not return a value. However, the system value, SV_StartProcStatus, will be set to one of the following three values:

Return Value | Description
Start_Process_Awaiting | An instance of this process is active for the same key. This process instance will become active when the previous instance completes.
Start_Process_Failed | Error occurred creating the process.
Start_Process_Success | Process started successfully.

Related Tables

Function Name | Function Description
F98800 | Process Definition
F98860 | Process Instances
F98865 | Process Activity Instances

See Also

· Start Process


Update Process Instance Attributes

Last Modified: EnterpriseOne | March 29, 2000

Update Process Instance Attributes updates the attributes for a given process instance.

Parameters

Parameter | Description | I/O | Required | Notes
Process Name | Name of workflow process | I | Y | Allowed values are defined in the Process Master (F98800).
Process Version | Version number of workflow process | I | Y |
Process Instance | Instance number of workflow process | I | Y |
Attribute DS | Data to be updated to | I | Y | Mapping of data structure data items to form controls, variables, and so forth.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

Use this function to update the attribute data structure with new data values stored in F98860. Use Get Process Instance For Key to retrieve the process version and process instance required as inputs to this function.

See Also

· Update Process Instance Attribute Single

· Get Process Instance Attributes


Update Process Instance Attribute Single

Last Modified: EnterpriseOne | March 29, 2000

Update Process Instance Attribute Single updates a single process attribute for a given process instance.

Parameters

Parameter | Description | I/O | Required | Notes
Process Name | Name of workflow process | I | Y | Allowed values are defined in the Process Master (F98800).
Process Version | Version number of workflow process | I | Y |
Process Instance | Instance number of workflow process | I | Y |
Data Item | Data Dictionary name of the data item in attribute data structure to be updated | I | Y | If there are multiple data of the same Data Dictionary item, only the first one will be updated.
Value | New value for the data item | I | Y |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

Use Get Process Instance For Key to retrieve the process version and instance values required as input.

See Also

· Update Process Instance Attributes


Table Conversion System Functions

Table Conversion

Table Conversion Events consist of the following:

 | CopyTableDataSource
app.gif (808 bytes) | CopyTableEnvironment
 | DeleteCurrentInputRow
app.gif (808 bytes) | DataChanged
app.gif (808 bytes) | FormatFetched
app.gif (808 bytes) | ProcessBegin
app.gif (808 bytes) | ProcessEnd
app.gif (808 bytes) | RowFetched
app.gif (808 bytes) | SetSelectionAppendFlag
app.gif (808 bytes) | SetUserSelection
app.gif (808 bytes) | StopConversionProcessing
 | StopEventProcessing
app.gif (808 bytes) | TCInsertRow
 | UpdateCurrentInputRow
app.gif (808 bytes) | UserInsertRow


CopyTableDataSource

Last Modified: B733.1 | June 08, 1999

CopyTableDataSource is used to copy a table or range of tables from one Data Source to another data source. Tables are copied based on the specifications in the login environment.

Parameters

Parameter | Description | I/O | Required | Notes
Table | If copying a single table, the table name. If copying a range of tables, the name of the first table in the range. | I | Y |
To Table | If copying a range of tables, the name of the last table in the range. If not copying a range of tables, this parameter should be Null. | I | N | Ranges are based on the Object Librarian table of the login environment.
From Data Source | Name of the input data source. | I | Y | The table(s) will be copied from this data source. This must be the name of an EnterpriseOne data source.
To Data Source | Name of the output data source. | I | Y | The table(s) will be copied to this data source. This must be the name of an EnterpriseOne data source.
Create | “Yes,” “No,” or “If Table Exists.” Indicates whether the table(s) should be created in the output data source. | I | Y | The “If Table Exists” option will only create a table in the output if the table actually exists in the input data source. If a table exists in Object Librarian, but not in the input data source then the table will not be created. In this case, or if this parameter is “Yes,” a table will be created in the output data source if it does not exist there. If the table does exist in the output data source then it will be dropped and re-created.
Clear | “Yes,” “No,” or “If Table Exists.” Indicates whether the table(s) should be cleared in the output data source. | I | Y | Similar behavior to the Create flag. This flag has no effect if the create flag is “Yes,” or “If Table Exists.”
Copy | “Yes,” or “No.” Indicates whether records from the input table(s) should be copied to the output table. | I | Y |
Owner ID | Owner ID to use when creating table(s). If this value is NULL then the login ID will be used. | I | N | Only used when creating tables.
Owner Pwd | Owner Pwd to use when creating table(s). If this value is NULL then the login password will be used. | I | N | Only used when creating tables.
Number Copied | Used to return the number of records copied in the case of a single table, or the number of tables copied in the case of a range. | O | N | If this parameter is NULL, no value will be returned.
Number Failed | Used to return the number of records copied in the case of a single table, or the number of tables copied in the case of a range. | O | N | If this parameter is NULL, no value will be returned.

Return Values

Return Value | Description
None | This does not return a value

Related Functions

Function Name | Function Description | Source Name | Description
Copy Table Environment | Copies tables from one environment to another. | System Function |

See Also

  • TableConversion


CopyTableEnvironment

Last Modified: B733.1 | June 08, 1999

CopyTableEnvironment is used to copy a table or range of tables from one environment to another environment. Tables are copied based on the specifications in the input and output environment. When the specifications differ, a mapping is created between like fields in the source and destination tables and all other fields are ignored.

Parameters

Parameter | Description | I/O | Required | Notes
Table | If copying a single table, the table name. If copying a range of tables, the name of the first table in the range. | I | Y |
To Table | If copying a range of tables, the name of the last table in the range. If not copying a range of tables, this parameter should be Null. | I | N | Ranges are based on the Object Librarian table of the login environment.
From Environment | Name of the input environment. | I | Y | The tables will be copied from this environment. This must be the name of a valid EnterpriseOne environment.
To Environment | Name of the output environment. | I | Y | The tables will be copied to this environment. This must be the name of a valid EnterpriseOne environment.
Create | “Yes,” “No,” or “If Table Exists.” Indicates whether the tables should be created in the output environment. | I | Y | The “If Table Exists” option will only create a table in the output if the table has been generated, in the input environment. If a table exists in Object Librarian, but has not been generated then the table will not be created. In this case, or if this parameter is “Yes,” a table will be created in the output environment if it does not exist there. If the table does exist in the output environment then it will be dropped and re-created. Tables are created based on the specification in the output environment.
Clear | “Yes,” “No,” or “If Table Exists.” Indicates whether the tables should be cleared in the output environment. | I | Y | Similar behavior to the Create flag. This flag has no effect if the create flag is “Yes” or “If Table Exists.”
Copy | “Yes,” or “No.” Indicates whether records from the input tables should be copied to the output table. | I | Y |
Owner ID | Owner ID to use when creating tables. If this value is NULL then the login ID will be used. | I | N | Only used when creating tables.
Owner Pwd | Owner Pwd to use when creating tables. If this value is NULL then the login password will be used. | I | N | Only used when creating tables.
Number Copied | Used to return the number of records copied in the case of a single table, or the number of tables copied in the case of a range. | O | N | If this parameter is NULL, no value will be returned.
Number Failed | Used to return the number of records copied in the case of a single table, or the number of tables copied in the case of a range. | O | N | If this parameter is NULL, no value will be returned.

Return Values

Return Value | Description
None | This does not return a value

Related Functions

Function Name | Function Description | Source Name | Description
Copy Table Data Source | Copies tables from one data source to another. | System Function |

See Also

  • Table Conversion


DeleteCurrentInputRow

Last Modified: B733.1 | June 08, 1999

DeleteCurrentInputRow is used in Table Conversion to delete the current record from the input table.

Parameters

None.

Return Values

Return Value | Description
Success or Failure | File_IO_Status

Special Handling Instructions and Prerequisites

This function is only available in Table Conversion.

Related Functions

Function Name | Function Description | Source Name | Description
Update Current Input Row | Used in Table Conversion to change the current record in the input table. | System Function |

See Also

  • Table Conversion


DataChanged

Last Modified: B733

DataChanged happens when a sequenced input column’s data changes to a new value. Data Changed events are generated from the columns selected for sequencing. Their format is “Short Name” Data Changed. For example, if an input table is sequenced on System code then the corresponding event would have the form “SY Data Changed”.

Typical Usage

This evens is used to output total information when data changes.

Processing Sequence

This event happens when the value of a sequenced column changes.


FormatFetched

Last Modified: B733

FormatFetched happens each time that a format is read from the input table.

Typical Usage

This event is used to setup relationships (mappings) among the input formats and output tables.

Processing Sequence

This event happens each time that a format record is read from the input table


ProcessBegin

Last Modified: B733

ProcessBegin allows for the set up of variables, and constant/literal data, which will exist while the Table Conversion, is executing. ProcessBegin is the first event of a Table Conversion.

Typical Usage

This event is used to initialize variables and literals.

Processing Sequence

First Event run for a Table Conversion


ProcessEnd

Last Modified: B733

ProcessEnd lends itself well to “last record” or “end of file” procedures. After Table Conversion has completed processing all of the mappings, ProcessEnd occurs.

Typical Usage

This event is used to write total, process validation, etc.

Processing Sequence

Last Event run for a Table Conversion


RowFetched

Last Modified: B733

RowFetched happens every time a record is read from the input table.

Typical Usage

This event is used to setup relationships (mappings) between the input and output tables.

Processing Sequence

Row Fetched Event happens each time that a record is read from the input table.


StopConversionProcessing

Last Modified: B733.1 | August 14, 1998

StopConversionProcessing allows the user to stop a table conversion from doing any further processing.

Parameters

Parameter | Description | I/O | Required | Notes
Log Message | A string that will be output to the log file. | I | N | This string can be used to provide a message to the user indicating why the conversion was stopped.

See Also

  • Table Conversion


StopEventProcessing

Last Modified: B733.1 | June 08, 1999

StopEventProcessing allows the user to stop processing event rules for an event.

Parameters

None.

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

When called, this function stops processing for the event currently being processed. It does not affect future events. For example, if Stop Event Processing is called while in the Row Fetched event it will stop the event and continue processing the conversion. When the next row is fetched, the Row Fetched event will be executed normally.

Related Functions

Function Name | Function Description | Source Name | Description
Stop Conversion Processing | Used to end the conversion. | System Function |

See Also

  • Table Conversion


TCInsertRow

Last Modified: B733.1 | June 08, 1999

TCInsertRow is generated by the table conversion utility when the Write Event check box is selected on the mapping page. This system function instructs the table conversion engine as to when mapped data should be inserted into the output table.

Parameters

Parameter | Description | I/O | Required | Notes
Format | The output table or format which should be written to |  |  |

Return Values

Return Value | Description
None | This does not return a value

Problems

The Table Conversion Utility owns this system function. The user should not count on the placement of the system function in event rules. The Table Conversion Utility will always attempt to move the system function to the end of the Event Rules. If conditional insert rows are required, use the User Insert Row system function.


UpdateCurrentInputRow

Last Modified: B733.1 | June 08, 1999

UpdateCurrentInputRow is used in Table Conversion to update the current record from the input table after it has been changed.

Parameters

None.

Return Values

Return Value | Description
Success or Failure | File_IO_Status

Special Handling Instructions and Prerequisites

This function is only available in Table Conversion.

Related Functions

Function Name | Function Description | Source Name | Description
Delete Current Input Row | Used in Table Conversion to delete the current record in the input table. | System Function |


UserInsertRow

Last Modified: B733.1 | June 08, 1999

This instructs the table conversion engine as to when mapped data should be inserted into the specified output table.

Parameters

Parameter | Description | I/O | Required | Notes
Format | The output table or format which should be written to |  |  |

Return Values

Return Value | Description
None | This does not return a value

Special Handling Instructions and Prerequisites

When the user needs to insert records into the output table, this function should be used instead of TCInsertRow.


Telephony

You can use the EnterpriseOne Telephony APIs to integrate telephone communications with your applications. For example, you can use these Telephony APIs to answer calls:

  • Transfer calls

  • Put calls on hold

  • Place an outgoing call

  • End a call

Configuring The J.D. Edwards EnterpriseOne Telephony Integration Feature

You use settings in the jde.ini file to configure the EnterpriseOne telephony integration feature.

You must have a ProgID entry in the jde.ini file under the [TAPI] section so that EnterpriseOne can find the correct drivers:

[TAPI]

ProgID=OwTAPI.ComTek.1

The ProgID setting identifies the logical name of the telephony driver. You can obtain this driver information from your call center administrator or from the driver vendor.

Each driver may have additional configuration settings. These configuration settings must be supplied in the jde.ini file under the [TAPI - ProgID] section. For example, if the driver ProgID setting is OwTAPI.ComTek.1, then you need settings in the jde.ini like this:

[TAPI - OwTAPI.ComTek.1]

Host=ctiserver1.jdedwards.com

You can obtain information for the entries in the [TAPI - ProgID] from your call center administrator or from the driver vendor.

Using The EnterpriseOne Telephony Test Driver

The standard EnterpriseOne distribution includes a test driver that allows developers and users of telephony enabled EnterpriseOne applications to trace the telephony system calls, as well as to simulate the CallisAlerting event.

To use the EnterpriseOne telephony test driver, set the ProgID entry in the jde.ini file under the [TAPI] section to OwTAPI.TestDriver.1. The first time an EnterpriseOne application uses the telephony integration feature, a dialog box for the "Session Controller" appears. At this time, the EnterpriseOne telephony test driver has no additional configuration settings.

The "Session Controller" shows the state of all calls for a given EnterpriseOne session. The "Session Controller" manages multiple telephony test sessions. When the "Session Controller" dialog box appears, you select the default session under the HUSER field. Click 0x00000000 in the HUSER field to select the default session.

As EnterpriseOne executes telephony system functions, the parameters passed by the application are shown in a dialog box. The user can change the return value to simulate errors.

The Session Controller also allows the user to simulate the CallIsAlerting event to make the telephony enabled EnterpriseOne applications think that a call is coming in. To simulate the CallIsAlerting event, click on the Issue Call Alerting button on the Session Controller dialog box. A dialog box appears, allowing the user to input various call data values for the simulated call. For example, the user can specify the originating number (ANI) as well as the digits that the caller punched into the interactive voice response unit (IVR) before the call was directed to the target number.

The session controller closes after all telephony-enabled EnterpriseOne applications have been closed.

Telephony consist of the following APIs:

 | Answer Call
app.gif (808 bytes) | Call Is Alerting
 | Conference Call
app.gif (808 bytes) | Drop Call
 | Extend Call
app.gif (808 bytes) | Get Agent State
 | Get Call Data
app.gif (808 bytes) | Get Call Handle
 | Get Call Handle Count
app.gif (808 bytes) | Get Call Party Number
 | Hold Call
app.gif (808 bytes) | LogAgentIn
 | LogAgentOut
app.gif (808 bytes) | MakeCall
 | ParkCall
app.gif (808 bytes) | RedirectCall
 | RejectCall
app.gif (808 bytes) | RetrieveCall
 | SetAgentState
app.gif (808 bytes) | TransferCall


Answer Call

Last Modified: B733.1 | November 23, 1998

Answer Call answers an incoming call.

Parameters

Parameter | Description | I/O | Required | Notes
call | Integer | I | Y | The call parameter identifies the call to be answered.
error | Integer | O | Y | The error parameter is an output parameter that holds the return code for the operation.

Return Values

The error parameter is an output parameter that holds the return code for the operation.

Return Value | Description
0 | Success.
4000 | Invalid Parameter.
9000 | Operation Not Supported. The telephony service provider does not support this function.
9001 | Services Not Initialized. The EnterpriseOne telephony integration feature could not initialize the telephony services implementation. Check the log file for more information.

Special Handling Instructions and Prerequisites

This function will fail with error code 4000 if the agent is currently involved in an active call.

The active call must be dropped, held, parked, or transferred before the alerting call can be answered.

The call identified by the call parameter must be in the Alerting state. If the call parameter is -1, the currently alerting call is answered.

Upon successful completion of th is function:

  • The agent terminal will be connected to the calling party

  • A call handle in the Connected state will be created

  • A call handle in the Active state will be created as the parent of the new call handle.

This function may not be available on all systems. To determine whether the Answer Call system function is available, issue the call:

  • Answer Call (0, error)

Upon return, the error parameter will hold 9000 if the system call is not available.

Related Functions

Function Name | Function Description | Source Name | Description
Call Is Alerting |  | Telephony |
Drop Call |  | Telephony |
Get Call Handle |  | Telephony |
Get Call Handle Count |  | Telephony |
Hold Call |  | Telephony |
Park Call |  | Telephony |
Redirect Call |  | Telephony |
Reject Call |  | Telephony |
Transfer Call |  | Telephony |

See Also

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Call Is Alerting

Last Modified: B733.1 | November 23, 1998

Call Is Alerting is issued whenever an incoming call is detected.

Available On

  • The Call Is Alerting event is available on any form of an interactive application.

Available Objects

None.

Typical Usage

This is typically used to generate "screen-pops."

Whenever the telephony service provider detects an incoming call, the EnterpriseOne™ forms that are enabled to receive the event may query caller identification information about the call, such as:

  • Automatic number identification (ANI) or caller ID

  • Dialed number identification service (DNIS) information

  • Interactive voice response unit (IVR) data.

The EnterpriseOne form or forms that respond to the Call Is Alerting event can use this information to track down pertinent information about the call. For example, a level 1 customer service application may use the interactive voice response unit data to retrieve the caller information records from the database as well as any existing problem ticket record for the caller.

Additional Notes

Whenever any form in any EnterpriseOne application running on a client calls one of the EnterpriseOne telephony integration feature system functions, the form is enabled to receive the Call Is Alerting event. However, the Call Is Alerting event is not issued until the Log Agent In system function is called successfully and ceases to be issued once the Log Agent Out system function is called successfully.

Any EnterpriseOne application running on a client that has been enabled to receive the Call Is Alerting event will receive the event whenever the telephony service provider detects an incoming call. Care must be taken to ensure that only pertinent or required forms ever call the EnterpriseOne telephony integration feature system functions to prevent unnecessary event generation and handling.

Processing Sequence

Whenever any form in any EnterpriseOne application running on a client calls one of the EnterpriseOne telephony integration feature system functions, the form is enabled to receive the Call Is Alerting event. However, the Call Is Alerting event is not issued until the Log Agent In system function is called successfully and ceases to be issued once the Log Agent Out system function is called successfully.


Conference Call

Last Modified: B733.1 | November 23, 1998

Conference Call retrieves a held call and join the retrieved call with another call.

Parameters

Parameter | Description | I/O | Required | Notes
call | Integer - identifies the call to which the held call will be joined | I | Y |
held | Integer - defines the call to be retrieved | I | Y |
error | Integer - an output parameter that holds the return code for the operation | O | Y |

Return Values

The error parameter is an output parameter that holds the return code for the operation.

Return Value | Description
0 | Success
4000 | Invalid Parameter
9000 | Operation Not Supported. The telephony service provider does not support this function
9001 | Services Not Initialized. The EnterpriseOne telephony integration feature could not initialize the telephony services implementation. Check the log file for more information

Special Handling Instructions and Prerequisites

The call identified by the call parameter must be in the Active state. If the call parameter is -1, the held call is joined to the currently active call.

The call identified by the held parameter must be in the Held state. If the held parameter is –1, the most recently held call is retrieved and joined to the call identified by the call parameter.

Upon successful completion of the Conference Call system function:

  • The party or parties connected to the call identified by the held call are joined to the call identified by the call parameter,

  • All calls connected to the call identified by the held call are children of the call identified by the call parameter and

  • The call handle identified by the held call is destroyed.

The Conference Call system function may not be available on all systems. To determine whether the Conference Call system function is available, issue the call:

  • Conference Call (0, 0, error)

Upon return, the error parameter will hold 9000 if the system call is not available.

Related Functions

Function Name | Function Description | Source Name | Description
Get Call Handle |  | Telephony |
Get Call Handle Count |  | Telephony |
Hold Call |  | Telephony |
Retrieve Call |  | Telephony |

See Also

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Drop Call

Last Modified: B733.1 | November 23, 1998

Drop Call removes a party from a call.

Parameters

Parameter | Description | I/O | Required | Notes
call | integer | I | Y | This parameter identifies the call that is to be dropped.
data | string | I | Y | This parameter specifies application data to be issued with Drop Call command. Refer to the Telephony overview for more information about this parameter.
error | integer | O | Y | This parameter is an output parameter that holds the return code for the operation.

Return Values

The error parameter is an output parameter that holds the return code for the operation.

Return Value | Description
0 | Success.
4000 | Invalid Parameter.
9000 | Operation Not Supported. The telephony service provider does not support this function.
9001 | Services Not Initialized. The EnterpriseOne™ telephony integration feature could not initialize the telephony services implementation. Check the log file for more information.

Special Handling Instructions and Prerequisites

If the call parameter is -1, the currently active call is dropped.

Upon successful completion of the Drop Call system function:

  • The party or parties connected to the call identified by the call parameter are disconnected from the agent terminal.

  • Any call handles that are associated as children of the call handle identified by the call parameter are destroyed.

  • The call handle identified by the call parameter is destroyed.

The Drop Call system function may not be available on all systems. To determine whether the Drop Call system function is available, issue the call

  • Drop Call(0, "", error)

Upon return, the error parameter will hold 9000 if the system call is not available.

Related Functions

Function Name | Function Description | Source Name | Description
Get Call Handle |  | Telephony |
Get Call Handle Count |  | Telephony |
Hold Call |  | Telephony |
Retrieve Call |  | Telephony |

Related Topics

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Extend Call

Last Modified: B733.1 | November 23, 1998

Extend Call places the currently active call on hold and to place an outgoing call.

Parameters

Parameter | Description | I/O | Required | Notes
number | string | I | Y | This parameter identifies the address of the party to call.
data | string | I | Y | Th is parameter specifies application data to be issued with Drop Call command. Refer to the "Overview" for more information about this parameter.
call | integer | O | Y | This parameter is an output parameter that holds the new call handle in the Active state that represents the agent’s connection to the called party.
error | integer | O | Y | This parameter is an output parameter that holds the return code for the operation.

Return Values

The error parameter is an output parameter that holds the return code for the operation.

Return Value | Description
0 | Success.
4000 | Invalid Parameter.
9000 | Operation Not Supported. The telephony service provider does not support this function.
9001 | Services Not Initialized. The EnterpriseOne™ telephony integration feature could not initialize the telephony services implementation. Check the log file for more information.

Special Handling Instructions and Prerequisites

Upon successful completion of the Extend Call system function:

  • The party or parties connected to the call identified by the call handle are on hold.

  • The call identified by the call handle will enter the Held state.

  • A call handle in the Connected state will be created.

  • A call handle in the Active state will be created as the parent of new call handle.

The Extend Call system function may not be available on all systems. To determine whether the Extend Call system function is available, issue the call

  • Extend Call("", "", call, error)

Upon return, the error parameter will hold 9000 if the system call is not available.

Related Functions

Function Name | Function Description | Source Name | Description
Get Call Handle |  | Telephony |
Get Call Handle Count |  | Telephony |
Hold Call |  | Telephony |
Make Call |  | Telephony |
Retrieve Call |  | Telephony |

See Also

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Get Agent State

Last Modified: B733.1 | November 23, 1998

Get Agent State determines the current state of an agent in the automatic call distributor (ACD).

Parameters

Parameter | Description | I/O | Required | Notes
state | integer | O | Y | The state parameter is an output parameter that holds the current state of the agent in the ACD.

Return Values

The state parameter is an output parameter that holds the current state of the agent in the ACD:

Return Value | Description
1 | Unavailable.
2 | Available.
3 | After Call Work.
9000 | Operation Not Supported. The telephony service provider does not support this function.
9001 | Services Not Initialized. The EnterpriseOne telephony integration feature could not initialize the telephony services implementation. Check the log file for more information.

Special Handling Instructions and Prerequisites

This function may not be available on all systems. To determine whether the Get Agent State system function is available, issue the call

  • Get Agent State(state)

Upon return, the state parameter will hold 9000 if the system call is not available.

Related Functions

Function Name | Function Description | Source Name | Description
Log Agent In |  | Telephony |
Log Agent Out |  | Telephony |
Set Agent State |  | Telephony |

See Also

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Get Call Data

Last Modified: B733.1 | November 23, 1998

Get Call Data retrieves application data from a call.

Parameters

Parameter | Description | I/O | Required | Notes
call | integer | I | Y | The call parameter identifies the call that is to be queried for its application data.
data | string | O | Y | The data parameter is an output parameter that holds the application data for the call identified by the call parameter.
error | integer | O | Y | The error parameter is an output parameter that holds the return code for the operation.

Return Values

The error parameter is an output parameter that holds the return code for the operation.

Return Value | Description
0 | Success.
4000 | Invalid Parameter. One or more of the parameters is invalid. Check the debug log for more information.
9000 | Operation Not Supported. The telephony service provider does not support this function.
9001 | Services Not Initialized. The EnterpriseOne telephony integration feature could not initialize the telephony services implementation. Check the log file for more information.

Special Handling Instructions and Prerequisites

If the call parameter is –1, the application data for the currently alerting call is retrieved.

The Get Call Data system function may not be available on all systems. To determine whether the Get Call Data system function is available, issue the call

  • Get Call Data(0, data, error)

Upon return, the error parameter will hold 9000 if the system call is not available.

Related Functions

Function Name | Function Description | Source Name | Description
Drop Call |  | Telephony |
Get Call Handle |  | Telephony |
Get Call Handle Count |  | Telephony |
Get Call Party Number |  | Telephony |
Extend Call |  | Telephony |
Make Call |  | Telephony |
Redirect Call |  | Telephony |

See Also

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Get Call Handle

Last Modified: B733.1 | November 23, 1998

Get Call Handle retrieves a call handle managed by EnterpriseOne on behalf of the logged agent.

Parameters

Parameter | Description | I/O | Required | Notes
index | integer | I | Y | The index parameter specifies the index of the call handle to be retrieved, ranging from 1 to the number returned by the Get Call Handle Count system function.
call | integer | O | Y | The call parameter is an output parameter that holds the requested call handle.

Return Values

The call parameter is an output parameter that holds the requested call handle. If the call parameter is zero upon return, the index parameter is invalid.

Special Handling Instructions and Prerequisites

Because call handles are created and destroyed during the scope of the telephony application, calls are identified by an internal number used in all EnterpriseOne telephony system function calls. The purpose of the Get Call Handle system function is to provide a level of indirection on top of these internal call handles so that EnterpriseOne application developers need not keep track of the call handles managed by EnterpriseOne on behalf of the logged agent.

The Get Call Handle system function is available on all systems.

Related Functions

Function Name | Function Description | Source Name | Description
Get Call Data |  | Telephony |
Get Call Handle Count |  | Telephony |
Get Call Party Number |  | Telephony |

See Also

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Get Call Handle Count

Last Modified: B733.1 | November 23, 1998

Get Call Handle Count is used to obtain the number of call handles managed by EnterpriseOne on behalf of the logged agent.

Parameters

Parameter | Description | I/O | Required | Notes
count | integer | O | Y | The count parameter is an output parameter that holds the number of call handles managed by the application on behalf of the logged agent.

Return Values

The count parameter is an output parameter that holds the number of call handles managed by the application on behalf of the logged agent. Call handles are indexed from 1.

Refer to the Get Call Handle system function for additional information.

Special Handling Instructions and Prerequisites

The Get Call Handle Count system function is available on all systems.

Related Functions

Function Name | Function Description | Source Name | Description
Get Call Data |  | Telephony |
Get Call Handle |  | Telephony |
Get Call Party Number |  | Telephony |

See Also

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Get Call Party Number

Last Modified: B733.1 | November 23, 1998

Get Call Handle Count retrieves caller identification information associated with a call.

Parameters

Parameter | Description | I/O | Required | Notes
call | integer | I | Y | The call parameter identifies the call handle to be queried.
number | string | O | Y | The number parameter is an output parameter that holds the requested information from the specified call.
type | integer | I/O | Y | On input, the type parameter identifies the type of information requested from the specified call. On output, the type parameter identifies the type of information stowed in the number parameter.
error | integer | O | Y | The error parameter is an output parameter that holds the return code for the operation.

Return Values

The number parameter is an output parameter that holds the requested information from the specified call.

The type parameter is used to identify the type of information requested. Valid values are listed in the following table:

Type | Description
-1 | Parent Call Handle. On input, requests the call handle of the parent call. On output, indicates that the number parameter holds the call handle of the parent call.
0 | Unknown. Not a valid input value. On output, indicates that the number parameter has an unknown format.
1 | ANI. On input, requests automatic number identification (ANI) information for the call. On output, indicates that the number parameter holds automatic number identification information.
2 | IVR. On input, requests information from the interactive voice response unit (IVR) for the call. On output, indicates that the number parameter holds interactive voice response unit information.
3 | DNIS. On input, requests dialed number identification service (DNIS) information for the call. On output, indicates the that number parameter holds dialed number identification service information.
4 | Call State. On input, requests state information for the call. On output, indicates that the number parameter holds state information.

If the requested information is available, the number parameter will be populated with the appropriate information. Otherwise, the error parameter will be set to 100 to indicate that the requested information is not available.

When requesting type 4 (call state) information, possible values for the number parameters are listed in t he following table:

Call State | Description
Active | The call is active. There can be at most one call in the Active state. The Active call identifies the controlling call handle for the currently active call.
Alerting | The call is alerting.
Connected | The call is connected to the active call or a held call.
Held | The call is on hold.
Pending | The call has been placed to the telephone network but has not been answered by the called party.

The error parameter is an output parameter that holds the return code for the operation.

Return Value | Description
0 | Success.
100 | Not Available. The requested data type is not available or is not supported.
4000 | Invalid Parameter. One or more of the parameters is invalid. Check the debug log for more information.
9000 | Operation Not Supported. The telephony service provider does not support this function.
9001 | Services Not Initialized. The EnterpriseOne telephony integration feature could not initialize the telephony services implementation. Check the log file for more information.

Special Handling Instructions and Prerequisites

If the call parameter is –1, the application data for the currently active call is retrieved.

The Get Call Party Number system function is available on all systems. However, not all data types are available on some systems. Check the error parameter to determine if the requested information is available.

Related Functions

Function Name | Function Description | Source Name | Description
Call Is Alerting |  | Telephony |
Get Call Handle |  | Telephony |
Get Call Handle Count |  | Telephony |
Get Call Party Number |  | Telephony |

See Also

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Hold Call

Last Modified: B733.1 | November 23, 1998

Hold Call places a call on hold.

Parameters

Parameter | Description | I/O | Required | Notes
call | integer | I | Y | The call parameter identifies the call to be placed on hold.
error | integer | O | Y | The error parameter is an output parameter that holds the return code for the operation.

Return Values

The error parameter is an output parameter that holds the return code for the operation.

Return Value | Description
0 | Success.
4000 | Invalid Parameter. One or more of the parameters is invalid. Check the debug log for more information.
9000 | Operation Not Supported. The telephony service provider does not support this function.
9001 | Services Not Initialized. The EnterpriseOne telephony integration feature could not initialize the telephony services implementation. Check the log file for more information.

Special Handling Instructions and Prerequisites

If the call parameter is -1, the currently active call is placed on hold. The call identified by the call parameter must be in the Active state.

Upon successful completion of the Hold Call system function:

  • The party or parties connected to the call identified by the call handle are on hold.

  • The call identified by the call handle will enter the Held state.

This function may not be available on all systems. To determine whether the Hold Call system function is available, issue the call

  • Hold Call(0, error)

Upon return, the error parameter will hold 9000 if the system call is not available.

Related Functions

Function Name | Function Description | Source Name | Description
Get Call Handle |  | Telephony |
Get Call Handle Count |  | Telephony |
Make Call |  | Telephony |
Retrieve Call |  | Telephony |

See Also

Refer to the Telephony overview" for general information regarding the EnterpriseOne telephony integration feature.


Log Agent In

Last Modified: B733.1 | November 23, 1998

Log Agent In logs the agent into the automatic call distributor (ACD) and to register interest in call progress events generated by the telephony service provider.

Parameters

Parameter | Description | I/O | Required | Notes
extension | string | I | Y | The extension parameter identifies the address of the agent station to be monitored. Call progress events directed to the agent station identified by the extension parameter will be directed to all telephony-enabled EnterpriseOne applications running in the client address space from which this system function was called.
agent | string | I | Y | The agent parameter specifies the agent ID used to log the agent into the ACD.
password | string | I | Y | The password parameter specifies the password for the given agent used to log the agent into the ACD.
error | integer | O | Y | The error parameter is an output parameter that holds the return code for the operation.

Return Values

The error parameter is an output parameter that holds the return code for the operation.

Return Value | Description
0 | Success.
4000 | Invalid Parameter. One or more of the parameters is invalid. Check the debug log for more information.
9000 | Operation Not Supported. The telephony service provider does not support this function.
9001 | Services Not Initialized. The EnterpriseOne telephony integration feature could not initialize the telephony services implementation. Check the log file for more information.

Special Handling Instructions and Prerequisites

Upon successful completion of the Log Agent In system function:

  • The agent is logged into the ACD.

  • All telephony-enabled EnterpriseOne applications running in the client address space from which this system function was called will receive call progress events generated by the telephony service provider.

The Log Agent In system function may not be available on all systems. To determine whether the Log Agent In system function is available, issue the call

  • Log Agent In("", "", "", error)

Upon return, the error parameter will hold 9000 if the system call is not available. Note that if the Log Agent In system function is not available, EnterpriseOne will not be able to log the agent out of the ACD. However, the Log Agent In system function will always at least register interest in call progress events generated by the telephony service provider.

Related Functions

Function Name | Function Description | Source Name | Description
Call Is Alerting |  | Telephony |
Get Agent State |  | Telephony |
Log Agent Out |  | Telephony |
Set Agent State |  | Telephony |

See Also

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Log Agent Out

Last Modified: B733.1 | November 23, 1998

Log Agent Out logs the agent out of the automatic call distributor (ACD) and to unregistered interest in call progress events directed to EnterpriseOne by the telephony service provider.

Parameters

Parameter | Description | I/O | Required | Notes
error | integer | O | Y | The error parameter is an output parameter that holds the return code for the operation.

Return Values

The error parameter is an output parameter that holds the return code for the operation.

Return Value | Description
0 | Success.
4000 | Invalid Parameter. One or more of the parameters is invalid. Check the debug log for more information.
9000 | Operation Not Supported. The telephony service provider does not support this function.
9001 | Services Not Initialized. The EnterpriseOne telephony integration feature could not initialize the telephony services implementation. Check the log file for more information.

Special Handling Instructions and Prerequisites

Upon successful completion of the Log Agent Out system function:

  • The agent is logged out of the ACD.

  • EnterpriseOne no longer receives call progress events from the telephony service provider.

The Log Agent Out system function may not be available on all systems. To determine whether the Log Agent Out system function is available, issue the call

  • Log Agent In("", "", "", error)

Upon return, the error parameter will hold 9000 if the system call is not available. Note that if the Log Agent Out system function is not available, EnterpriseOne will not be able to log the agent out of the ACD. However, the Log Agent Out system function will always at least unregistered interest in call progress events directed to EnterpriseOne by the telephony service provider.

Related Functions

Function Name | Function Description | Source Name | Description
Call Is Alerting |  | Telephony |
Get Agent State |  | Telephony |
Log Agent In |  | Telephony |
Set Agent State |  | Telephony |

Related Topics

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Make Call

Last Modified: B733.1 | November 23, 1998

Make Call places an outgoing call.

Parameters

Parameter | Description | I/O | Required | Notes
number | string | I | Y | The number parameter identifies the address of the party to call.
data | string | I | Y | The data parameter specifies application data to be sent along with the call when the call is placed. Refer to the Telephony overview for more information.
call | integer | O | Y | The call parameter is an output parameter that holds the new call handle in the Active state that represents the agent’s connection to the called party.
error | integer | O | Y | The error parameter is an output parameter that holds the return code for the operation.

Return Values

The error parameter is an output parameter that holds the return code for the operation.

Return Value | Description
0 | Success.
4000 | Invalid Parameter. One or more of the parameters is invalid. Check the debug log for more information.
9000 | Operation Not Supported. The telephony service provider does not support this function.
9001 | Services Not Initialized. The EnterpriseOne telephony integration feature could not initialize the telephony services implementation. Check the log file for more information.

Special Handling Instructions and Prerequisites

Upon successful completion of the Make Call system function:

  • A call handle in the Connected state will be created.

  • A call handle in the Active state will be created as the parent of new call handle.

The Make Call system function may not be available on all systems. To determine whether the Make Call system function is available, issue the call

  • Make Call("", "", call, error)

Upon return, the error parameter will hold 9000 if the system call is not available.

Related Functions

Function Name | Function Description | Source Name | Description
Drop Call |  | Telephony |
Extend Call |  | Telephony |
Get Call Handle |  | Telephony |
Get Call Handle Count |  | Telephony |
Hold Call |  | Telephony |

See Also

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Park Call

Last Modified: B733.1 | November 23, 1998

Park Call redirects an incoming call to an alternate address.

Parameters

Parameter | Description | I/O | Required | Notes
call | integer | I | Y | The call parameter identifies the call to be parked.
number | string | I | Y | The number parameter specifies the address of the device where the call is parked.
error | integer | O | Y | The error parameter is an output parameter that holds the return code for the operation.

Return Values

The error parameter is an output parameter that holds the return code for the operation.

Return Value | Description
0 | Success.
4000 | Invalid Parameter. One or more of the parameters is invalid. Check the debug log for more information.
9000 | Operation Not Supported. The telephony service provider does not support this function.
9001 | Services Not Initialized. The EnterpriseOne telephony integration feature could not initialize the telephony services implementation. Check the log file for more information.

Special Handling Instructions and Prerequisites

If the call parameter is -1, currently active call is rejected. The call identified by the call parameter must be in the Active state.

Upon successful completion of the Park Call system function:

  • The call call handle will be destroyed.

  • Any calls associated with the call handle will be destroyed.

This function may not be available on all systems. To determine whether the Park Call system function is available, issue the call:

  • Park Call(0, "", error)

Upon return, the error parameter will hold 9000 if the system call is not available.

Related Functions

Function Name | Function Description | Source Name | Description
Get Call Handle |  | Telephony |
Get Call Handle Count |  | Telephony |
Hold Call |  | Telephony |

See Also

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Redirect Call

Last Modified: B733.1 | November 23, 1998

Redirect Call redirects an incoming call to an alternate address.

Parameters

Parameter | Description | I/O | Required | Notes
call | integer | I | Y | The call parameter identifies the call to be redirected.
number | string | I | Y | The number parameter specifies the address of the party to which the alerting call is redirected.
data | string | I | Y | The data parameter specifies application specific data that is to be sent along with the call to the specified address.
error | integer | O | Y | The error parameter is an output parameter that holds the return code for the operation.

Return Values

The error parameter is an output parameter that holds the return code for the operation.

Return Value | Description
0 | Success.
4000 | Invalid Parameter. One or more of the parameters is invalid. Check the debug log for more information.
9000 | Operation Not Supported. The telephony service provider does not support this function.
9001 | Services Not Initialized. The EnterpriseOne telephony integration feature could not initialize the telephony services implementation. Check the log file for more information.

Special Handling Instructions and Prerequisites

If the call parameter is -1, currently alerting call is rejected. The call identified by the call parameter must be in the Alerting state.

Upon successful completion of the Redirect Call system function:

  • The alerting call will be redirected to the specified number.

  • The Alerting call handle will be destroyed.

The Redirect Call system function may not be available on all systems. To determine whether the Redirect Call system function is available, issue the call

  • Redirect Call(0, "", "", error)

Upon return, the error parameter will hold 9000 if the system call is not available.

Related Functions

Function Name | Function Description | Source Name | Description
Answer Call |  | Telephony |
Get Call Handle |  | Telephony |
Get Call Handle Count |  | Telephony |
Hold Call |  | Telephony |

See Also

Refer to the Telephony o verview for general information regarding the EnterpriseOne telephony integration feature.


Reject Call

Last Modified: B733.1 | November 23, 1998

Reject Call rejects an incoming call.

Parameters

Parameter | Description | I/O | Required | Notes
call | integer | I | Y | The call parameter identifies the call to be rejected. If the call parameter is -1, currently alerting call is rejected. The call identified by the call parameter must be in the Alerting state.
error | integer | O | Y | The error parameter is an output parameter that holds the return code for the operation.

Return Values

The error parameter is an output parameter that holds the return code for the operation and will be one of:

Return Value | Description
0 | Success.
4000 | Invalid Parameter. One or more of the parameters is invalid. Check the debug log for more information.
9000 | Operation Not Supported. The telephony service provider does not support this function.
9001 | Services Not Initialized. The EnterpriseOne™ telephony integration feature could not initialize the telephony services implementation. Check the log file for more information.

Special handling Instructions and Prerequisites

Upon successful completion of the Reject Call system function:

  • The alerting call will be rejected, typically resulting in a busy signal for the calling party.

  • The Alerting call handle will be destroyed.

The Reject Call system function may not be available on all systems. To determine whether the Reject Call system function is available, issue the call

  • Reject Call(0, error)

Upon return, the error parameter will hold 9000 if the system call is not available.

Related Functions

Function Name | Function Description | Source Name | Description
Answer Call |  | Telephony |
Get Call Handle |  | Telephony |
Get Call Handle Count |  | Telephony |
Hold Call |  | Telephony |

See Also

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Retrieve Call

Last Modified: B733.1 | November 23, 1998

Retrieve Call retrieves a held call and make it the currently active call.

Parameters

Parameter | Description | I/O | Required | Notes
call | integer | I | Y | The call parameter identifies the call to be retrieved. If the call parameter is -1, the call most recently placed on hold is retrieved. The call identified by the call parameter must be in the Held state.
error | integer | O | Y | The error parameter is an output parameter that holds the return code for the operation.

Return Values

The error parameter is an output parameter that holds the return code for the operation and will be one of:

Return Value | Description
0 | Success.
4000 | Invalid Parameter. One or more of the parameters is invalid. Check the debug log for more information.
9000 | Operation Not Supported. The telephony service provider does not support this function.
9001 | Services Not Initialized. The EnterpriseOne™ telephony integration feature could not initialize the telephony services implementation. Check the log file for more information.

Special Handling Instructions and Prerequisites

Upon successful completion of the Retrieve Call system function:

  • The call handle identified by the call parameter will enter the Active state.

  • The agent’s terminal device will activate and connect to the held party or parties.

The Retrieve Call system function may not be available on all systems. To determine whether the Retrieve Call system function is available, issue the call:

  • Retrieve Call(0, error)

Upon return, the error parameter will hold 9000 if the system call is not available.

Related Functions

Function Name | Function Description | Source Name | Description
Get Call Handle |  | Telephony |
Get Call Handle Count |  | Telephony |
Hold Call |  | Telephony |

Related Topics

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Set Agent State

Last Modified: B733.1 | November 23, 1998

Set Agent State sets the current state of the agent in the automatic call distributor (ACD).

Parameters

Parameter | Description | I/O | Required | Notes
state | integer | I | Y | The state parameter specifies the new state of the agent in the ACD. Refer to the "Get Agent State" system function documentation for more information.
error | integer | O | Y | The error parameter is an output parameter that holds the return code for the operation.

Return Values

The error parameter is an output parameter that holds the return code for the operation.

Return Value | Description
0 | Success.
4000 | Invalid Parameter. One or more of the parameters is invalid. Check the debug log for more information.
9000 | Operation Not Supported. The telephony service provider does not support this function.
9001 | Services Not Initialized. The EnterpriseOne telephony integration feature could not initialize the telephony services implementation. Check the log file for more information.

Special handling Instructions and Prerequisites

Upon successful completion of the Set Agent State system function:

  • The current state of the agent in the automatic call distributor (ACD) will reflect the state identified by the state parameter.

The Set Agent State system function may not be available on all systems. To determine whether the Set Agent State system function is available, issue the call

  • Get Agent State(state)

Upon return, the state parameter will hold 9000 if the system call is not available.

Related Functions

Function Name | Function Description | Source Name | Description
Get Agent State |  | Telephony |
Log Agent In |  | Telephony |
Log Agent Out |  | Telephony |

See Also

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Transfer Call

Last Modified: B733.1 | November 23, 1998

Transfer Call transfers a held call to another party.

Parameters

Parameter | Description | I/O | Required | Notes
target | integer | I | Y | The target parameter identifies the party to which the call identified by the call parameter is transferred. If the target parameter is -1, the call identified by the call parameter is transferred to the party connected to the currently active call.
call | integer | I | Y | The call parameter identifies the call to be transferred. If the call parameter is -1, the call most recently placed on hold is transferred. The call identified by the call parameter must be in the Held state.
error | integer | O | Y | The error parameter is an output parameter that holds the return code for the operation.

Return Values

The error parameter is an output parameter that holds the return code for the operation.

Return Value | Description
0 | Success.
4000 | Invalid Parameter. One or more of the parameters is invalid. Check the debug log for more information.
9000 | Operation Not Supported. The telephony service provider does not support this function.
9001 | Services Not Initialized. The EnterpriseOne™ telephony integration feature could not initialize the telephony services implementation. Check the log file for more information.

Special Handling Instructions and Prerequisites

Upon successful completion of the Transfer Call system function:

  • The target call handle and any associated call handles are destroyed.

  • The call handle and any associated call handles are destroyed.

The Transfer Call system function may not be available on all systems. To determine whether the Transfer Call system function is available, issue the call

  • Transfer Call(0, 0, error)

Upon return, the error parameter will hold 9000 if the system call is not available.

Related Functions

Function Name | Function Description | Source Name | Description
Get Call Handle |  | Telephony |
Get Call Handle Count |  | Telephony |
Hold Call |  | Telephony |

Related Topics

Refer to the Telephony overview for general information regarding the EnterpriseOne telephony integration feature.


Tree Overview

Tree

Tree System Functions consist of the following:

 | DeleteTreeNode
app.gif (808 bytes) | ExpandTreeNode
 | ContractTreeNode
app.gif (808 bytes) | Get Node Information
app.gif (808 bytes) | GetNodeLevel
app.gif (808 bytes) | GetTreeNodeHandle
app.gif (808 bytes) | InsertTreeNode
app.gif (808 bytes) | SetTreeBitmapScheme
app.gif (808 bytes) | SetNodeBitmap
app.gif (808 bytes) | SetNodeInformation
app.gif (808 bytes) | SetTreeNodeHandle


Interoperability

Interoperability consists of the following Categories:

app.gif (808 bytes) | XAPI II
app.gif (808 bytes) | Inbound Response Parsing API
 | Outbound XAPI Event Creation API
 | Real-Time Events


XAPI II

XAPI II contains the following APIs:

 | jdeXMLRequest_ParseNextDSByName
app.gif (808 bytes) | jdeXAPIResponse_Add
 | jdeXAPIResponse_Finalize
 | jdeXAPIResponse_Free
 | jdeXAPIResponse_Init
 | jdeXAPIResponse_SimpleSend
 | jdeXML_CheckSystemError
 | jdeXML_GetErrorCount
 | jdeXML_ParseNextDSByName
 | jdeXML_PrepareDSListForInterationByName
 | jdeXML_SetErrors
 | jdeXMLRequest_DeleteXML
 | jdeXMLRequest_GetDSCount
 | jdeXMLRequest_GetDSName
 | jdeXMLRequest_ParseDS
 | jdeXMLRequest_PrepareDSListForIterationByName
 | SampleXAPIRequestParsingAPIUsage
 | SampleXAPIResponseCreationAPIUsage


jdeXAPI_Add

Last Modified: EnterpriseOne| November 6, 2001

The jdeXAPI_Add API is provided to add the EnterpriseOne data into the XAPICall being created. This API must pass the valid XAPI_CALL_ID returned by jdeXAPI_Init API.

Syntax

XAPI_CALL_RETURN jdeXAPI_Add (LPBHVRCOM pBhvrCom, XAPI_CALL_ID ulXAPICallID, PJSTR szFunction, NID szXAPIDSName, LPVOID pXAPIData, int iXAPIDataSize )

Parameters

Parameter | Description
LPBHVRCOM pBhvrCom | This is a pointer to BhvrCom structure used by Business Function. It is needed to create a User Handle (hUser).
XAPI_CALL_ID ulXAPICallID | The unique ID assigned to the XAPICall. This is Generated by jdeXAPI_Init API.
PJSTR szFunction | Name of the Business Function calling the API.
NID szXAPIDSName | The name of the EnterpriseOne data structure. I.e. DSD9800182D.
LPVOID pXAPIData | The data to be passed to IEO Kernel. This is a pointer to the data structure object of szDsTmplName.
int iXAPIDataSize | Size of the data passed. This must be set to sizeof () of the szDsTmplName. I.e. for DSD9800182D, it will be sizeof (DSD9800182D).

Return Values

XAPI_CALL_RETURN : The error/success value.

Example

XAPI_CALL_RETURN eXAPICallReturn = eEventCallSuccess;

eXAPICallReturn = jdeXAPI_Add( lpBhvrCom, ulXAPICallID, "SendOrderPromiseRequest", "D4205010A", &dsD4205010A, sizeof(DSD4205010A));

Additional Notes

None

See Also

· jdeXAPI_Init

· jdeXAPI_Finalize

· jdeXAPI_Free

· jdeXAPI_SimpleSend

· jdeXAPI_IsCallTypeEnabled

· jdeXAPI_CALLS_ENABLED

· Interop Guide


jdeXAPI_CALLS_ENABLED

Last Modified: EnterpriseOne| November 6, 2001

The macro jdeXAPI_CALLS_ENABLED is used to check if XAPICall generation is enabled for an instance of EnterpriseOne or not. It is recommended to call this macro before doing any XAPICall generation. So that the data manipulation can be avoided if the generation is not enabled.

Syntax

BOOL jdeXAPI_CALLS_ENABLED ();

Return Values

BOOL : True if XAPI calls are enabled else False.

Example

#ifdef jdeXAPI_CALLS_ENABLED

XAPI_CALL_RETURN eXAPICallReturn = eEventCallSuccess;

XAPI_CALL_ID ulXAPICallID = 0;

ulXAPICallID = jdeXAPI_Init(lpBhvrCom,

szFunction,

"XAPIOPOUT",

NULL,

&eXAPICallReturn);

#endif

Additional Notes

None

See Also

· jdeXAPI_Init

· jdeXAPI_Add

· jdeXAPI_Finalize

· jdeXAPI_Free

· jdeXAPI_SimpleSend

· jdeXAPI_IsCallTypeEnabled

· Interop Guide


jdeXAPI_Finalize

Last Modified: EnterpriseOne| November 6, 2001

The jdeXAPI_Finalize API is provided to finalize the XAPICall, create an XML document, and pass the document to EVN Kernel.

Syntax

XAPI_CALL_RETURN jdeXAPI_Finalize( LPBHVRCOM pBhvrCom, XAPI_CALL_ID ulXAPICallID, PJSTR szFunction, PJSTR szXAPIMethodIDIn )

Parameters

Parameter | Description
LPBHVRCOM pBhvrCom | This is a pointer to BhvrCom structure used by Business Function. It is needed to create a User Handle (hUser).
XAPI_CALL_ID ulXAPICallID | The unique ID assigned to the XAPICall. This is Generated by jdeXAPI_Init API.
PJSTR szFunction | Name of the Business Function calling the API.
PJSTR szXAPIMethodIDIn | The name of the EnterpriseOne data structure. I.e. DSD9800182D.

Return Values

XAPI_CALL_RETURN : The error/success value.

Example

XAPI_CALL_RETURN eXAPICallReturn = eEventCallSuccess;

eXAPICallReturn = jdeXAPI_Finalize( lpBhvrCom, ulXAPICallID, "SendOrderPromiseRequest", "OrderPromiseCallback");

Additional Notes

None

See Also

· jdeXAPI_Init

· jdeXAPI_Add

· jdeXAPI_Free

· jdeXAPI_SimpleSend

· jdeXAPI_IsCallTypeEnabled

· jdeXAPI_CALLS_ENABLED

· Interop Guide


jdeXAPI_Free

Last Modified: EnterpriseOne| November 6, 2001

The jdeXAPI_Free API is provided to free the XAPICall in case of error during the generation. This API should only be called if jdeXAPI_Add or jdeXAPI_Finalize fails.

Syntax

XAPI_CALL_RETURN jdeXAPI_Free (LPBHVRCOM pBhvrCom, XAPI_CALL_ID ulXAPICallID, PJSTR szFunction )

Parameters

Parameter | Description
LPBHVRCOM pBhvrCom | This is a pointer to BhvrCom structure used by Business Function. It is needed to create a User Handle (hUser).
XAPI_CALL_ID ulXAPICallID | The unique ID assigned to the XAPICall. This is Generated by jdeXAPI_Init API.
PJSTR szFunction | Name of the Business Function calling the API.

Return Values

XAPI_CALL_RETURN : The error/success value.

Example

XAPI_CALL_RETURN eXAPICallReturn = eEventCallSuccess;

eXAPICallReturn = jdeXAPI_Free( lpBhvrCom,

ulXAPICallID,

"SendOrderPromiseRequest");

Additional Notes

None

See Also

· jdeXAPI_Init

· jdeXAPI_Add

· jdeXAPI_Finalize

· jdeXAPI_SimpleSend

· jdeXAPI_IsCallTypeEnabled

· jdeXAPI_CALLS_ENABLED

· Interop Guide


jdeXAPI_Init

Last Modified: EnterpriseOne| November 6, 2001

The jdeXAPI_Init API is provided to initiate the generation of the XAPI Call. The XAPI_CALL_ID returned by the API must be passed to rest of the APIs.

Syntax

XAPI_CALL_ID jdeXAPI_Init (LPBHVRCOM pBhvrCom, PJSTR szFunction, NID szXAPICallType, PJSTR szXAPIScope, XAPI_CALL_RETURN* peXAPICallReturn )

Parameters

Parameter | Description
LPBHVRCOM pBhvrCom | This is a pointer to BhvrCom structure used by Business Function. It is needed to access a User Handle (hUser).
PJSTR szFunction | Name of the Business Function calling the API.
NID szXAPICallType | The name of the XAPICALL. I.e. XAPIOPOUT, XAPIPRJSCH etc.
PJSTR szXAPIScope | The scope of the XAPI Scope. Required by Active.
XAPI_CALL_RETURN* peXAPICallReturn | The error/success value. User has to pass the address of this parameter. So that the API can update the value.

Return Values

XAPI_CALL_ID : The unique ID assigned to the XAPICall.

Example

XAPI_CALL_ID ulXAPICallID = 0;

ulXAPICallID = jdeXAPI_Init( lpBhvrCom, "SendOrderPromiseRequest", "XAPIOPOUT",

NULL,

&eXAPICallReturn);

Additional Notes

None

See Also

· jdeXAPI_Add

· jdeXAPI_Finalize

· jdeXAPI_Free

· jdeXAPI_SimpleSend

· jdeXAPI_IsCallTypeEnabled

· jdeXAPI_CALLS_ENABLED

· Interop Guide


jdeXAPI_IsCallTypeEnabled

Last Modified: EnterpriseOne XE| November 6, 2001

The API jdeXAPI_IsCallTypeEnabled is used to compare the passed XAPICallType against the registered XAPICall in JDE.INI and filtered XAPICall in JDE.INI file. All the APIs provided should call this API before doing any processing. It is recommended to call this API before calling jdeXAPI_SimpleSend to avoid any data manipulation in case of a particular XAPICall not being enabled.

Syntax

BOOL jdeXAPI_IsCallTypeEnabled (NID szXAPICallType /* XAPICall Type */,);

Parameters

Parameter | Description
NID szXAPICallType | XAPICall Type

Return Values

BOOL : True if XAPI Call Type is enbled else False.

Example

if(jdeXAPI_IsCallTypeEnabled("XAPIOPOUT”))

{

iRecordCount = jdeXML_GetDSCount(lpDS->szXMLHandle);

}

Additional Notes

None

See Also

· jdeXAPI_Init

· jdeXAPI_Add

· jdeXAPI_Finalize

· jdeXAPI_Free

· jdeXAPI_SimpleSend

· jdeXAPI_CALLS_ENABLED

· Interop Guide


jdeXAPIResponse_Add

Last Modified: ERP 9.0| October 21, 2002

The jdeXAPIResponse_Add is provided to add the EnterpriseOne data into the XAPICall being created. This API must pass the valid XAPI_CALL_ID returned by jdeXAPIResponse_Init API.

Syntax

XAPI_CALL_RETURN jdeXAPIResponse_Add ( LPBHVRCOM pBhvrCom, XAPI_CALL_ID ulXAPICallID, PJSTR szFunction, NID szXAPIDSName,LPVOID pXAPIData, LPVOID pXAPIData,int iXAPIDataSize)

Parameters

Parameter | Description
LPBHVRCOM pBhvrCom | This is a pointer to BhvrCom structure used by Business Function. It is needed to create a User Handle (hUser).
XAPI_CALL_ID ulXAPICallID | The unique ID assigned to the XAPICall. This is Generated by jdeXAPI_Init API.
PJSTR szFunction | Name of the Business Function calling the API.
NID szXAPIDSName | The name of the EnterpriseOne data structure. I.e. DSD9800182D.
LPVOID pXAPIData | The data to be passed to IEO Kernel. This is a pointer to the data structure object of szDsTmplName.
int iXAPIDataSize | Size of the data passed. This must be set to sizeof () of the szDsTmplName. I.e. for DSD9800182D, it will be sizeof (DSD9800182D).

Return Values

XAPI_CALL_RETURN: The error/success value.

Example

XAPI_CALL_RETURN eXAPICallReturn = eEventCallSuccess;

eXAPICallReturn = jdeXAPIResponse_Add(lpBhvrCom,

ulXAPICallID,

_J("ProcessSOforDemandScheduling"),

_J("D4206000O"),

&dsD4206000O,

sizeof(DSD4206000O));

Additional Notes

None

See Also

· jdeXAPIResponse_Init

· jdeXAPIRespse_Finalize

· jdeXAPIResponse_Free

· jdeXAPIResponse_SimpleSend

· jdeXAPI_IsCallTypeEnabled

· jdeXAPI_CALLS_ENABLED

· Interop Guide


jdeXAPIResponse_Finalize

Last Modified: ERP 9.0| October 21, 2002

The jdeXAPIResponse_Finalize API is provided to finalize the XAPI response, create an XML document, and pass the document to EVN Kernel.

Syntax

XAPI_CALL_RETURN jdeXAPIResponse_Finalize (

LPBHVRCOM pBhvrCom /* Pointer to BHVRCOM */,

PJSTR pXMLRequestHandle /* Handle to XAPI Request document */

XAPI_CALL_ID ulXAPICallID /* XAPICall ID */,

PJSTR szFunction /* Function Name */,

);

Parameters

Parameter | Description
LPBHVRCOM pBhvrCom | This is a pointer to BhvrCom structure used by Business Function. It is needed to create a User Handle (hUser).
PJSTR pXMLRequestHandle | This is a handle to the outbound XAPI request documents.
XAPI_CALL_ID ulXAPICallID | The unique ID assigned to the XAPICall. This is Generated by jdeXAPI_Init API.
LPSTR szFunction | Name of the Business Function calling the API.

Return Values

XAPI_CALL_RETURN : The error/success value.

Example

XAPI_CALL_RETURN eXAPICallReturn = eEventCallSuccess;

eXAPICallReturn = jdeXAPIResponse_Finalize(lpBhvrCom,

lpDS->szXMLHandle,

ulXAPICallID,

_J("DmdSchXAPISalesOrderProcess"));

Additional Notes

None

See Also

jdeXAPIResponse_Init

jdeXAPIResponse_Add

jdeXAPIResponse_Free

jdeXAPIResponse_SimpleSend

jdeXAPI_IsCallTypeEnabled

jdeXAPI_CALLS_ENABLED

Interop Guide


jdeXAPIResponse_Free

Last Modified: ERP 9.0| October 21, 2002

The jdeXAPIResponse_Free API is provided to free the XAPICall in case of error during the response generation. This API should only be called if jdeXAPIRespnse_Add or jdeXAPIResponse_Finalize fails.

Syntax

XAPI_CALL_RETURN jdeXAPIResponse_Free ( LPBHVRCOM pBhvrCom, XAPI_CALL_ID ulXAPICallID, PJSTR szFunction)

Parameters

Parameter | Description
LPBHVRCOM pBhvrCom | This is a pointer to BhvrCom structure used by Business Function. It is needed to create a User Handle (hUser).
XAPI_CALL_ID ulXAPICallID | The unique ID assigned to the XAPICall. This is Generated by jdeXAPI_Init API.
PJSTR szFunction | Name of the Business Function calling the API.

Return Values

XAPI_CALL_RETURN : The error/success value.

Example

XAPI_CALL_RETURN eXAPICallReturn = eEventCallSuccess;

eXAPICallReturn = jdeXAPIResponse_Free(lpBhvrCom,

ulXAPICallID,

_J("SendOrderPromiseRequest"));

Additional Notes

None

See Also

· jdeXAPIResponse_Init

· jdeXAPIResponse_Add

· jdeXAPIResponse_Finalize

· jdeXAPIResponse_SimpleSend

· jdeXAPI_IsCallTypeEnabled

· jdeXAPI_CALLS_ENABLED

· Interop Guide


jdeXAPIResponse_Init

Last Modified: ERP 9.0| October 21, 2002

The jdeXAPIResponse_Init API is provided to initiate the generation of the XAPI Call. The XAPI_CALL_ID returned by the API must be passed to rest of the APIs.

Syntax

XAPI_CALL_ID jdeXAPIResponse_Init ( LPBHVRCOM pBhvrCom, PJSTR szFunction,NID szXAPICallType, PJSTR szXAPIScope, XAPI_CALL_RETURN* peXAPICallReturn)

Parameters

Parameter | Description
LPBHVRCOM pBhvrCom | This is a pointer to BhvrCom structure used by Business Function. It is needed to access a User Handle (hUser).
PJSTR szFunction | Name of the Business Function calling the API.
NID szXAPICallType | The name of the XAPICALL. I.e. XAPIOPOUT, XAPIPRJSCH etc.
PJSTR szXAPIScope | The scope of the XAPI Scope. Required by Active.
XAPI_CALL_RETURN* peXAPICallReturn | The error/success value. User has to pass the address of this parameter. So that the API can update the value.

Return Values

XAPI_CALL_ID : The unique ID assigned to the XAPICall.

Example

XAPI_CALL_ID ulXAPICallID = 0;

ulXAPICallID = jdeXAPIResponse_Init(lpBhvrCom, _J("DmdSchXAPISalesOrderProcess"),

_J("XAPISOOUT"), NULL, &eXAPICallReturn);

Additional Notes

None

See Also

· jdeXAPIResponse_Add

· jdeXAPIResponse_Finalize

· jdeXAPIResponse_Free

· jdeXAPIResponse_SimpleSend

· jdeXAPI_IsCallTypeEnabled

· jdeXAPI_CALLS_ENABLED

· Interop Guide


jdeXAPIResponse_SimpleSend

Last Modified: ERP 9.0| October 21, 2002

A simple XAPI Response Call can be created by calling jdeXAPIResponse_SimpleSend API. This API is useful if the XAPI response Call contains one EnterpriseOne® data structure.

Syntax

XAPI_CALL_RETURN jdeXAPIResponse_SimpleSend (

LPBHVRCOM pBhvrCom /* pointer to BHVRCOM*/,

PJSTR pXMLHandle /* Handle to XAPI Request document */,

PJSTR szFunction /* Function Name */,

NID szXAPICallType /* type of the XAPICall */,

PJSTR szXAPIScope /* XAPICall scope */,

NID szXAPIDSName /* Template name */,

LPVOID pXAPIData /* Pointer to BSFN data */,

int iXAPIDataSize /* size of BSFN data */);

Parameters

Parameter | Description
LPBHVRCOM pBhvrCom | This is a pointer to BhvrCom structure used by Business Function. It is needed to create a User Handle (hUser).
PJSTR pXMLHandle | This is a handle to the inbound XAPI Request document.
PJSTR szFunction | Name of the Business Function calling the API.
NID szXAPICallType | The name of the XAPICALL. I.e. XAPIOPOUT, XAPIPRJSCH etc.
PJSTR szXAPIScope | The scope of the XAPICall. Required by Active.
NID szXAPIDSName | The name of the EnterpriseOne data structure. I.e. DSD9800182D.
LPVOID pXAPIData | The data to be passed to IEO Kernel. This is a pointer to the data structure object of szDsTmplName.
int iXAPIDataSize | Size of the data passed. This must be set to sizeof () of the szDsTmplName. I.e. for DSD9800182D, it will be sizeof (DSD9800182D).

Return Values

XAPI_CALL_RETURN : The error/success value.

Example

XAPI_CALL_RETURN eXAPICallReturn = eEventCallSuccess;

eXAPICallReturn = jdeXAPIResponse_SimpleSend( lpBhvrCom,

lpDS->szXMLHandle,

_J("XAPITestRequest"),

_J("XAPIDEMO"),

_J(""),

_J("D907001A"),

lpDS,

sizeof(DSD907001A));

Additional Notes

None

See Also

· jdeXAPIResponse_Init

· jdeXAPIResponse_Add

· jdeXAPIResponse_Finalize

· jdeXAPIResponse_Free

· jdeXAPI_IsCallTypeEnabled

· jdeXAPI_CALLS_ENABLED

· Interop Guide


jdeXAPI_SimpleSend

Last Modified: EnterpriseOne| November 6, 2001

A simple XAPICall can be created by calling jdeXAPI_SimpleSend API. This API is useful if the XAPICall contains one EnterpriseOne® data structure.

Syntax

XAPI_CALL_RETURN jdeXAPI_SimpleSend( LPBHVRCOM pBhvrCom, PJSTR szFunction, NID szXAPICallType, PJSTR szXAPIScope, NID szXAPIDSName, LPVOID pXAPIData, int iXAPIDataSize, PJSTR szXAPIMethodIDIn )

Parameters

Parameter | Description
LPBHVRCOM pBhvrCom | This is a pointer to BhvrCom structure used by Business Function. It is needed to create a User Handle (hUser).
PJSTR szFunction | Name of the Business Function calling the API.
NID szXAPICallType | The name of the XAPICALL. I.e. XAPIOPOUT, XAPIPRJSCH etc.
PJSTR szXAPIScope | The scope of the XAPICall. Required by Active.
NID szXAPIDSName | The name of the EnterpriseOne data structure. I.e. DSD9800182D.
LPVOID pXAPIData | The data to be passed to IEO Kernel. This is a pointer to the data structure object of szDsTmplName.
int iXAPIDataSize | Size of the data passed. This must be set to sizeof () of the szDsTmplName. I.e. for DSD9800182D, it will be sizeof (DSD9800182D).
PJSTR szXAPIMethodIDIn | Callback Method Name

Return Values

XAPI_CALL_RETURN : The error/success value.

Example

XAPI_CALL_RETURN eXAPICallReturn = eEventCallSuccess;

eXAPICallReturn = jdeXAPI_SimpleSend( pBhvrCom,

"APIDRVFunction",

IEO_XAPI_OPOUT,

"",

"D4205010A",

&zDataH,

sizeof(zDataH),

"GetComputerID" );

Additional Notes

None

See Also

· jdeXAPI_Init

· jdeXAPI_Add

· jdeXAPI_Finalize

· jdeXAPI_Free

· jdeXAPI_IsCallTypeEnabled

· jdeXAPI_CALLS_ENABLED

· Interop Guide


SampleXAPIRequestParsingAPIUsage

Last Modified: ERP 9.0| October 21, 2002

Example

int iXMLRecordCount = 0;

int iCurrentRecord = 0;

NID nidDSName;

ID idReturnValue = ER_SUCCESS;

ID idSORecordCount = ER_ERROR; /*Return Code*/

MATH_NUMERIC mnBatchNumber = {0};

unsigned long lBatchNumber = {0};

DSD4206030A dsD4206030A = {0}; /* CacheProcessInboundDemandRequest B4206030.c */

DSD4206000I dsD4206000I = {0}; /* Demand scheduling inbound DSTR */

iXMLRecordCount = jdeXMLRequest_GetDSCount(lpDS->szXMLHandle);

if( iXMLRecordCount > 0)

{

for ( iCurrentRecord = 0; iCurrentRecord < iXMLRecordCount; iCurrentRecord++)

{

memset((void *)(&dsD4206000I), (int)(_J('\0')), sizeof(DSD4206000I));

memset((void *)(nidDSName), (int)(_J('\0')), sizeof(NID));

if(jdeXMLRequest_GetDSName(lpDS->szXMLHandle,

iCurrentRecord,

nidDSName))

{

/* Retrieving data*/

if (jdeStricmp(nidDSName, (const JCHAR *)_J("D40R0180B")) == 0)

{

if (jdeXMLRequest_ParseDS(lpDS->szXMLHandle,

iCurrentRecord,

&dsD4206000I,

sizeof(DSD4206000I)))

{

/* Get next number for the batch number of the inbound INVRPT record*/

if ( dsD4206000I.cInventoryAdvisement == _J('1'))

{

lBatchNumber = JDB_GetInternalNextNumber();

LongToMathNumeric(lBatchNumber, &mnBatchNumber);

FormatMathNumeric(dsD4206000I.szBatch,&mnBatchNumber);

}

/* Setup cancel flag for pending delete record */

if ( dsD4206000I.cPendingDelete == _J('1'))

{ /* Flag set as 1 for any cancel demand record */

dsD4206000I.cCancelFlag = _J('1');

}

else

{ /* Flag set as 9 for any non cancel demand record */

dsD4206000I.cCancelFlag = _J('9');

}

/* Load parms for cache */

memset((void *)(&dsD4206030A), (int)(_J('\0')), sizeof(DSD4206030A));

I4206000_LoadParmsToCache(&dsD4206000I, &dsD4206030A);

MathCopy(&dsD4206030A.mnJobnumberA, lpmnJobNumber) ;

/* Add the DSTR to cache */

idReturnValue = jdeCallObject( _J("CacheProcessInboundDemandRequest") ,

(LPFNBHVR)NULL ,

lpBhvrCom ,

lpVoid ,

(LPVOID)&dsD4206030A,

(CALLMAP *) NULL,

(int) 0,

(JCHAR*)NULL ,

(JCHAR*)NULL ,

(int) 0 );

/* Write XML DSTR to cache fail */

if (idReturnValue == ER_ERROR)

{

jdeErrorSet(lpBhvrCom, lpVoid, (ID) 0, _J("032E"), (LPVOID) NULL);

}

}

else

{ /* warning XML parse fail */

jdeErrorSet(lpBhvrCom, lpVoid, (ID) 0, _J("40R46"), (LPVOID) NULL);

}

} /* end if */

}/* end if DS name */

}/* end for - looping all matching XML DSTR */

/* Ensure there is at least one record */

idSORecordCount = ER_SUCCESS;

}/*if( iXMLRecordCount > 0) */

return idSORecordCount;

Additional Notes

None

See Also

· jdeXMLRequest_GetDSCount

· jdeXMLRequest_GetDSName

· jdeXMLRequest_ParseDS

· jdeXMLRequest_DeleteXML

· Interop Guide


SampleXAPIResponseCreationAPIUsage

SampleXAPIResponseEventCreationAPIUsage

Last Modified: ERP 9.0| October 21, 2002

Example

JDEBFRTN (ID) JDEBFWINAPI SendOrderPromiseRequest (LPBHVRCOM lpBhvrCom, LPVOID lpVoid, LPDSD4205010 lpDS)

{

/************************************************************************

* Variable declarations

************************************************************************/

char cPromisableLine = ' ';

int nHeaderBackOrderAllowed = ' ';

HUSER hUser ;

ID JDEDBResult = JDEDB_PASSED;

BOOL bExit = FALSE;

BOOL bB4001040Called = FALSE;

BOOL bXAPIInUse = FALSE;

BOOL bAtLeastOneDetail = FALSE;

#ifdef jdeXAPI_CALLS_ENABLED

XAPI_CALL_ID ulXAPICallID = 0;

XAPI_CALL_RETURN eXAPICallReturn = eEventCallSuccess;

#endif

/************************************************************************

* Declare structures

************************************************************************/

DSD4001040 dsD4001040 = {0};

DSD4205020 dsD4205020 = {0};

DSD4205040 dsD4205040 = {0}; /* Header Info */

DSD4205050 dsD4205050 = {0}; /* Detail Info */

DSD4205010A dsD4205010A = {0}; /* Query Header */

DSD4205010B dsD4205010B = {0}; /* Query Detail */

DSD0100042 dsD0100042 = {0};

LPDSD4205040H lpDSD4205040H = (LPDSD4205040H) NULL;

LPDSD4205050D lpDSD4205050D = (LPDSD4205050D) NULL;

/************************************************************************

* Declare pointers

************************************************************************/

/************************************************************************

* Check for NULL pointers

************************************************************************/

if ((lpBhvrCom == (LPBHVRCOM) NULL) ||

(lpVoid == (LPVOID) NULL) ||

(lpDS == (LPDSD4205010) NULL))

{

jdeErrorSet (lpBhvrCom, lpVoid, (ID) 0, "4363", (LPVOID) NULL);

return ER_ERROR;

}

/* Retrieving hUser */

JDEDBResult = JDB_InitBhvr (lpBhvrCom, &hUser, (char *)NULL, JDEDB_COMMIT_AUTO ) ;

if ( JDEDBResult == JDEDB_FAILED )

{

jdeSetGBRError ( lpBhvrCom, lpVoid, (ID) 0, "4363" ) ;

return ER_ERROR ;

}

/************************************************************************

* Set pointers

************************************************************************/

/************************************************************************

* Main Processing

************************************************************************/

/*-----------------------------------------------------*/

/* Setting Up ErrorCode */

lpDS->cErrorCode = '0';

/*-----------------------------------------------------*/

/* Determing if XAPI is ready to be used */

bXAPIInUse = FALSE;

#ifdef jdeXAPI_CALLS_ENABLED

if(jdeXAPI_IsCallTypeEnabled("XAPIOPOUT") &&

jdeXAPI_IsCallTypeEnabled("XAPIOPIN") )

{

bXAPIInUse = TRUE;

}

#endif

/*-----------------------------------------------------*/

/* Data validation and defaults. */

/* When Display Before Accecpt Mode is on,validate Key */

/* Information.Otherwise retrieve it from Header Record*/

if((lpDS->cDisplayBeforeAcceptMode == '1') &&

((MathZeroTest(&lpDS->mnOrderNumber) == 0) ||

(IsStringBlank(lpDS->szOrderType)) ||

(IsStringBlank(lpDS->szOrderCompany))))

{

bExit = TRUE;

}

else

{

MathCopy(&dsD4205040.mnOrderNumber,&lpDS->mnOrderNumber);

strncpy(dsD4205040.szOrderType,

lpDS->szOrderType,

sizeof(dsD4205040.szOrderType));

strncpy(dsD4205040.szComputerID,

lpDS->szOrderCompany,

sizeof(dsD4205040.szOrderCompany));

dsD4205040.cUseCacheOrWF = lpDS->cUseCacheOrWF;

strncpy(dsD4205040.szComputerID,

lpDS->szComputerID,

sizeof(dsD4205040.szComputerID));

MathCopy(&dsD4205040.mnJobNumber,&lpDS->mnJobNumber);

jdeCallObject( "GetSalesOrderHeaderRecord",

NULL,

lpBhvrCom, lpVoid,

(LPVOID)&dsD4205040,

(CALLMAP *) NULL,

(int) 0,

(char *) NULL,

(char *) NULL,

(int) 0 ) ;

lpDSD4205040H = (LPDSD4205040H)jdeRemoveDataPtr(hUser, (ulong)dsD4205040.idHeaderRecord);

if (lpDSD4205040H == NULL)

{

bExit = TRUE;

}

}

/*-----------------------------------------------------*/

/* Set error if we're exiting at this point */

if (bExit == TRUE)

{

lpDS->cErrorCode = '1';

/* Sales Order Header Not Found */

strncpy(lpDS->szErrorMessageID,

"072T",

sizeof(lpDS->szErrorMessageID));

if (lpDS->cSuppressError != '1')

{

jdeErrorSet (lpBhvrCom, lpVoid, (ID) 0, "072T", (LPVOID) NULL);

}

}

/*-----------------------------------------------------*/

/* Default Promising Flag is always 1 for Xe */

lpDS->cDefaultPromisingFlags = 1;

if (bExit == FALSE)

{

/*-----------------------------------------------------*/

/* Call XAPIInit */

#ifdef jdeXAPI_CALLS_ENABLED

if(bXAPIInUse == TRUE)

{

ulXAPICallID = jdeXAPI_Init( lpBhvrCom, "SendOrderPromiseRequest",

"XAPIOPOUT",

NULL,

&eXAPICallReturn);

if (eXAPICallReturn != eEventCallSuccess)

{

bExit = TRUE;

}

}

#endif

if (bExit == FALSE)

{

/*-----------------------------------------------------*/

/* Loading Header Information */

I4205010_PopulateQueryHeader(lpDS,&dsD4205010A,

lpDSD4205040H,&dsD0100042,hUser,lpVoid,lpBhvrCom);

nHeaderBackOrderAllowed = dsD4205010A.nAllowBackorders;

/*-----------------------------------------------------*/

/* Adding Header Information */

#ifdef jdeXAPI_CALLS_ENABLED

if(bXAPIInUse == TRUE)

{

eXAPICallReturn = jdeXAPI_Add( lpBhvrCom,

ulXAPICallID,

"SendOrderPromiseRequest",

"D4205010A",

&dsD4205010A,

sizeof(DSD4205010A));

if (eXAPICallReturn != eEventCallSuccess)

{

bExit = TRUE;

}

}

#endif

}

}

if (bExit == FALSE)

{

/*-----------------------------------------------------*/

/* Loading Detail Information */

MathCopy(&dsD4205050.mnOrderNumber,&lpDS->mnOrderNumber);

strncpy(dsD4205050.szOrderType,lpDS->szOrderType,

sizeof(dsD4205050.szOrderType));

strncpy(dsD4205050.szOrderCompany,lpDS->szOrderCompany,

sizeof(dsD4205050.szOrderCompany));

dsD4205050.cUseCacheOrWF = lpDS->cUseCacheOrWF;

strncpy(dsD4205050.szComputerID,lpDS->szComputerID,

sizeof(dsD4205050.szComputerID));

MathCopy(&dsD4205050.mnJobNumber,&lpDS->mnJobNumber);

if (lpDSD4205040H->cActionCode != 'A')

{

dsD4205050.cCheckTableAfterCache = '1';

}

else

{

dsD4205050.cCheckTableAfterCache = '0';

}

jdeCallObject( "GetSalesOrderDetailRecordOP",

NULL,

lpBhvrCom, lpVoid,

(LPVOID)&dsD4205050,

(CALLMAP *) NULL,

(int) 0, (char *) NULL,

(char *) NULL, (int) 0 ) ;

if (dsD4205050.cRecordFound != '1')

{

bExit = TRUE;

lpDS->cErrorCode = '1';

/* Sales Order Detail Not Found */

strncpy(lpDS->szErrorMessageID,"4162",

sizeof(lpDS->szErrorMessageID));

if (lpDS->cSuppressError != '1')

{

jdeErrorSet (lpBhvrCom, lpVoid, (ID) 0, "4162", (LPVOID) NULL);

}

}

while ((dsD4205050.cRecordFound == '1') && (bExit == FALSE))

{

lpDSD4205050D = (LPDSD4205050D)jdeRemoveDataPtr( hUser,

(ulong)dsD4205050.idDetailRecord);

/* Reset flags */

cPromisableLine = '0';

bB4001040Called = FALSE;

/*------------------------------------------------------*/

/* Evaluate the Record from F4211 (cDataSource = 2) to */

/* find out if we should promise the line else find out */

/* from Order Promising Detail.*/

if(dsD4205050.cDataSource == '1')

{

if (lpDSD4205050D->cOPPromiseLineYN == 'Y')

{

cPromisableLine = '1';

}

}

else if(dsD4205050.cDataSource == '2')

{

MathCopy ( &dsD4001040.mnShortItemNumber,

&lpDSD4205050D->mnShortItemNumber);

strncpy ( dsD4001040.szBranchPlant,

lpDSD4205050D->szBusinessUnit,

sizeof(dsD4001040.szBranchPlant));

jdeCallObject ( "GetItemMasterDescUOM",

NULL,

lpBhvrCom, lpVoid,

(LPVOID)&dsD4001040,

(CALLMAP *) NULL,

(int) 0, (char *) NULL,

(char *) NULL, (int) 0 ) ;

bB4001040Called = TRUE;

cPromisableLine = I4205010_IsLinePromisable(lpBhvrCom,lpVoid,

hUser,lpDS,lpDSD4205050D,dsD4001040.cStockingType);

}

if (cPromisableLine == '1')

{

/* Set this flag if at least one promisable detail record exists. */

bAtLeastOneDetail = TRUE;

if (bB4001040Called == FALSE)

{

MathCopy (&dsD4001040.mnShortItemNumber,

&lpDSD4205050D->mnShortItemNumber);

strncpy ( dsD4001040.szBranchPlant,

lpDSD4205050D->szBusinessUnit, sizeof(dsD4001040.szBranchPlant));

jdeCallObject ( "GetItemMasterDescUOM",

NULL,

lpBhvrCom, lpVoid,

(LPVOID)&dsD4001040,

(CALLMAP *) NULL,

(int) 0, (char *) NULL,

(char *) NULL, (int) 0 ) ;

}

I4205010_PopulateQueryDetail( lpDS,&dsD4205010B,

lpDSD4205050D,

&dsD4001040,

&dsD4205010A,

&dsD0100042,

cPromisableLine,

hUser,

lpVoid,

lpBhvrCom);

#ifdef jdeXAPI_CALLS_ENABLED

if(bXAPIInUse == TRUE)

{

eXAPICallReturn = jdeXAPI_Add( lpBhvrCom,

ulXAPICallID,

"SendOrderPromiseRequest",

"D4205010B",

&dsD4205010B,

sizeof(DSD4205010B));

if (eXAPICallReturn != eEventCallSuccess)

{

bExit = TRUE;

}

}

#endif

}

/*-----------------------------------------------------*/

/* Fetching the next Detail Record */

MathCopy(&dsD4205050.mnOrderNumber,&lpDS->mnOrderNumber);

strncpy(dsD4205050.szOrderType,lpDS->szOrderType,

sizeof(dsD4205050.szOrderType));

strncpy(dsD4205050.szOrderCompany,lpDS->szOrderCompany,

sizeof(dsD4205050.szOrderCompany));

dsD4205050.cUseCacheOrWF = lpDS->cUseCacheOrWF;

strncpy(dsD4205050.szComputerID,lpDS->szComputerID,

sizeof(dsD4205050.szComputerID));

MathCopy(&dsD4205050.mnJobNumber,&lpDS->mnJobNumber);

if (lpDSD4205040H->cActionCode != 'A')

{

dsD4205050.cCheckTableAfterCache = '1';

}

else

{

dsD4205050.cCheckTableAfterCache = '0';

}

jdeCallObject( "GetSalesOrderDetailRecordOP",

NULL,

lpBhvrCom, lpVoid,

(LPVOID)&dsD4205050,

(CALLMAP *) NULL,

(int) 0, (char *) NULL,

(char *) NULL, (int) 0 ) ;

}

if (!bAtLeastOneDetail)

{

bExit = TRUE;

lpDS->cErrorCode = '1';

/* Sales Order Detail Not Found */

strncpy(lpDS->szErrorMessageID,"4162",

sizeof(lpDS->szErrorMessageID));

if (lpDS->cSuppressError != '1')

{

jdeErrorSet (lpBhvrCom, lpVoid, (ID) 0, "4162", (LPVOID) NULL);

}

}

if (bExit == FALSE)

{

#ifdef jdeXAPI_CALLS_ENABLED

if(bXAPIInUse == TRUE)

{

eXAPICallReturn = jdeXAPI_Finalize( lpBhvrCom,

ulXAPICallID,

"SendOrderPromiseRequest",

"OrderPromiseCallback");

if (eXAPICallReturn != eEventCallSuccess)

{

bExit = TRUE;

}

}

#endif

}

/*-----------------------------------------------------*/

/* Call B4205020 in Add Mode */

if((bExit == FALSE) &&

(lpDS->cDisplayBeforeAcceptMode != '1') &&

(lpDS->cUseCacheOrWF == '2'))

{

MathCopy(&dsD4205020.mnOrderNumber,&lpDS->mnOrderNumber);

strncpy(dsD4205020.szOrderType,lpDS->szOrderType,

sizeof(dsD4205020.szOrderType));

strncpy(dsD4205020.szOrderCompany,lpDS->szOrderCompany,

sizeof(dsD4205020.szOrderCompany));

strncpy(dsD4205020.szComputerID,lpDS->szComputerID,

sizeof(dsD4205020.szComputerID));

MathCopy(&dsD4205020.mnJobNumber,&lpDS->mnJobNumber);

jdeCallObject( "MaintainOPWorkFile",

NULL,

lpBhvrCom, lpVoid,

(LPVOID)&dsD4205020,

(CALLMAP *) NULL,

(int) 0, (char *) NULL,

(char *) NULL, (int) 0 ) ;

}

}

/************************************************************************

* Function Clean Up

************************************************************************/

#ifdef jdeXAPI_CALLS_ENABLED

if (eXAPICallReturn != eEventCallSuccess)

{

/*-----------------------------------------------------*/

/* CleanUp */

if(bXAPIInUse == TRUE)

{

jdeXAPI_Free( lpBhvrCom,

ulXAPICallID,

"SendOrderPromiseRequest");

}

lpDS->cErrorCode = '1';

/* System Error - no reasonable error messages exist in Xe. */

strncpy(lpDS->szErrorMessageID,"018Y",

sizeof(lpDS->szErrorMessageID));

if (lpDS->cSuppressError != '1')

{

jdeErrorSet (lpBhvrCom, lpVoid, (ID) 0, "018Y", (LPVOID) NULL);

}

}

#endif

if(lpDSD4205040H != (LPDSD4205040H)NULL)

{

jdeFree((void *)lpDSD4205040H);

}

if(lpDSD4205050D != (LPDSD4205050D)NULL)

{

jdeFree((void *)lpDSD4205050D);

}

return (ER_SUCCESS);

}

Additional Notes

None

See Also

· jdeXAPIResponse_Init

· jdeXAPIResponse_Add

· jdeXAPIResponse_Finalize

· jdeXAPIResponse_Free

· jdeXAPIResponse_SimpleSend

· jdeXAPI_IsCallTypeEnabled

· jdeXAPI_CALLS_ENABLED

· Interop Guide


Inbound Response Parsing API

Inbound Response Parsing API consists of the following Categories:

 | JdeXML_DeleteXML
app.gif (808 bytes) | JdeXML_GetDSCount
 | JdeXML_GetDSName
 | JdeXML_ParseDS
 | SampleXAPIResponseParsingAPIUsage


SamleXAPIResponseParsingAPIUsage

SampleXAPIResponseParsingAPIUsage

Last Modified: EnterpriseOne| November 6, 2001

Example

JDEBFRTN (ID) JDEBFWINAPI OrderPromiseCallback (LPBHVRCOM lpBhvrCom, LPVOID lpVoid, LPDSD4205060 lpDS)

{

BOOL bExit;

BOOL bClientFound;

int x;

int iRecordCount;

int iCurrentRecord;

int iHeaderCount;

NID nidDSName;

char cDisplayBeforeAcceptMode;

char szOrderNum[32];

char szOrderType[3];

char szOrderCompany[6];

int iLength = 0;

int iPipeCount = 0;

char b4buf[128];

char szLogModule[42] = "OrderPromiseCallback";

char szLogString[270] = {0};

BOOL bLoggingOn = TRUE;

DSD4205030A dsD4205030A = {0};

DSD4205030B dsD4205030B = {0};

DSD4205030 dsD4205030 = {0};

if ( (lpBhvrCom == (LPBHVRCOM) NULL)

|| (lpVoid == (LPVOID) NULL)

|| (lpDS == (LPDSD4205060) NULL))

{

jdeErrorSet (lpBhvrCom, lpVoid, (ID) 0, "4363", (LPVOID) NULL);

return ER_ERROR;

}

iRecordCount= 0;

iCurrentRecord = 0;

iHeaderCount = 0;

cDisplayBeforeAcceptMode = ' ';

bExit = FALSE;

bClientFound = FALSE;

iLength = 0;

iPipeCount = 0;

memset(szOrderNum,'\0',sizeof(szOrderNum));

memset(szOrderType,'\0',sizeof(szOrderType));

memset(szOrderCompany,'\0',sizeof(szOrderCompany));

memset(&dsD4205030A,'\0',sizeof(dsD4205030A));

memset(&dsD4205030,'\0',sizeof(dsD4205030));

_strtime( b4buf );

sprintf(szLogString, "Entering CallBack, %s",b4buf );

jdeWriteLog(szLogModule, 0, szLogString);

#ifdef jdeXAPI_CALLS_ENABLED

if(jdeXAPI_IsCallTypeEnabled("XAPIOPOUT") &&

jdeXAPI_IsCallTypeEnabled("XAPIOPIN") )

{

iRecordCount = jdeXML_GetDSCount(lpDS->szXMLHandle);

_strtime( b4buf );

sprintf(szLogString, "GetDSCount, %s, Num DS %d",b4buf,iRecordCount );

jdeWriteLog(szLogModule, 0, szLogString);

iHeaderCount = 0;

_strtime( b4buf );

sprintf(szLogString, "BeginParse, %s",b4buf );

jdeWriteLog(szLogModule, 0, szLogString);

if (iRecordCount > 0)

{

for (iCurrentRecord = 0; iCurrentRecord < iRecordCount; iCurrentRecord++)

{

jdeXML_GetDSName(lpDS->szXMLHandle,

iCurrentRecord,

nidDSName);

if (jdestrcmp(nidDSName,(const char*)"D4205030A") == 0)

{

jdeXML_ParseDS( lpDS->szXMLHandle,

iCurrentRecord,

&dsD4205030A,

sizeof(DSD4205030A));

}

else

{

jdeXML_ParseDS( lpDS->szXMLHandle,

iCurrentRecord,

&dsD4205030B,

sizeof(DSD4205030B));

}

}

_strtime( b4buf );

sprintf(szLogString, "EndParse, %s , Num Recs, %d",b4buf, iCurrentRecord );

jdeWriteLog(szLogModule, 0, szLogString);

}

if (iCurrentRecord == iRecordCount)

{

jdeXML_DeleteXML(lpDS->szXMLHandle);

}

}

#endif

return (ER_SUCCESS);

}

Additional Notes

None

See Also

· jdeXML_GetDSCount

· jdeXML_GetDSName

· jdeXML_ParseDS

· jdeXML_DeleteXML

· Interop Guide


Outbound XAPI Event Creation API

Home

Outbound XAPI Event Creation APIs

Below are the Outbound XAPI Event Creation APIs:

 | jdeXAPI_Add
app.gif (808 bytes) | jdeXAPI_CALLS_Enabled
 | jdeXAPI_Finalize
 | jdeXAPI_Free
 | jdeXAPI_Init
 | jdeXAPI_IsCallTypeEnabled
 | jdeXAPI_SimpleSend
 | SampleXAPIEventCreationAPIUsage


SampleXAPIEventCreationAPIUsage

Last Modified: EnterpriseOne| November 6, 2001

Example

JDEBFRTN (ID) JDEBFWINAPI SendOrderPromiseRequest (LPBHVRCOM lpBhvrCom, LPVOID lpVoid, LPDSD4205010 lpDS)

{

/************************************************************************

* Variable declarations

************************************************************************/

char cPromisableLine = ' ';

int nHeaderBackOrderAllowed = ' ';

HUSER hUser ;

ID JDEDBResult = JDEDB_PASSED;

BOOL bExit = FALSE;

BOOL bB4001040Called = FALSE;

BOOL bXAPIInUse = FALSE;

BOOL bAtLeastOneDetail = FALSE;

#ifdef jdeXAPI_CALLS_ENABLED

XAPI_CALL_ID ulXAPICallID = 0;

XAPI_CALL_RETURN eXAPICallReturn = eEventCallSuccess;

#endif

/************************************************************************

* Declare structures

************************************************************************/

DSD4001040 dsD4001040 = {0};

DSD4205020 dsD4205020 = {0};

DSD4205040 dsD4205040 = {0}; /* Header Info */

DSD4205050 dsD4205050 = {0}; /* Detail Info */

DSD4205010A dsD4205010A = {0}; /* Query Header */

DSD4205010B dsD4205010B = {0}; /* Query Detail */

DSD0100042 dsD0100042 = {0};

LPDSD4205040H lpDSD4205040H = (LPDSD4205040H) NULL;

LPDSD4205050D lpDSD4205050D = (LPDSD4205050D) NULL;

/************************************************************************

* Declare pointers

************************************************************************/

/************************************************************************

* Check for NULL pointers

************************************************************************/

if ((lpBhvrCom == (LPBHVRCOM) NULL) ||

(lpVoid == (LPVOID) NULL) ||

(lpDS == (LPDSD4205010) NULL))

{

jdeErrorSet (lpBhvrCom, lpVoid, (ID) 0, "4363", (LPVOID) NULL);

return ER_ERROR;

}

/* Retrieving hUser */

JDEDBResult = JDB_InitBhvr (lpBhvrCom, &hUser, (char *)NULL, JDEDB_COMMIT_AUTO ) ;

if ( JDEDBResult == JDEDB_FAILED )

{

jdeSetGBRError ( lpBhvrCom, lpVoid, (ID) 0, "4363" ) ;

return ER_ERROR ;

}

/************************************************************************

* Set pointers

************************************************************************/

/************************************************************************

* Main Processing

************************************************************************/

/*-----------------------------------------------------*/

/* Setting Up ErrorCode */

lpDS->cErrorCode = '0';

/*-----------------------------------------------------*/

/* Determing if XAPI is ready to be used */

bXAPIInUse = FALSE;

#ifdef jdeXAPI_CALLS_ENABLED

if(jdeXAPI_IsCallTypeEnabled("XAPIOPOUT") &&

jdeXAPI_IsCallTypeEnabled("XAPIOPIN") )

{

bXAPIInUse = TRUE;

}

#endif

/*-----------------------------------------------------*/

/* Data validation and defaults. */

/* When Display Before Accecpt Mode is on,validate Key */

/* Information.Otherwise retrieve it from Header Record*/

if((lpDS->cDisplayBeforeAcceptMode == '1') &&

((MathZeroTest(&lpDS->mnOrderNumber) == 0) ||

(IsStringBlank(lpDS->szOrderType)) ||

(IsStringBlank(lpDS->szOrderCompany))))

{

bExit = TRUE;

}

else

{

MathCopy(&dsD4205040.mnOrderNumber,&lpDS->mnOrderNumber);

strncpy(dsD4205040.szOrderType,

lpDS->szOrderType,

sizeof(dsD4205040.szOrderType));

strncpy(dsD4205040.szComputerID,

lpDS->szOrderCompany,

sizeof(dsD4205040.szOrderCompany));

dsD4205040.cUseCacheOrWF = lpDS->cUseCacheOrWF;

strncpy(dsD4205040.szComputerID,

lpDS->szComputerID,

sizeof(dsD4205040.szComputerID));

MathCopy(&dsD4205040.mnJobNumber,&lpDS->mnJobNumber);

jdeCallObject( "GetSalesOrderHeaderRecord",

NULL,

lpBhvrCom, lpVoid,

(LPVOID)&dsD4205040,

(CALLMAP *) NULL,

(int) 0,

(char *) NULL,

(char *) NULL,

(int) 0 ) ;

lpDSD4205040H = (LPDSD4205040H)jdeRemoveDataPtr(hUser, (ulong)dsD4205040.idHeaderRecord);

if (lpDSD4205040H == NULL)

{

bExit = TRUE;

}

}

/*-----------------------------------------------------*/

/* Set error if we're exiting at this point */

if (bExit == TRUE)

{

lpDS->cErrorCode = '1';

/* Sales Order Header Not Found */

strncpy(lpDS->szErrorMessageID,

"072T",

sizeof(lpDS->szErrorMessageID));

if (lpDS->cSuppressError != '1')

{

jdeErrorSet (lpBhvrCom, lpVoid, (ID) 0, "072T", (LPVOID) NULL);

}

}

/*-----------------------------------------------------*/

/* Default Promising Flag is always 1 for Xe */

lpDS->cDefaultPromisingFlags = 1;

if (bExit == FALSE)

{

/*-----------------------------------------------------*/

/* Call XAPIInit */

#ifdef jdeXAPI_CALLS_ENABLED

if(bXAPIInUse == TRUE)

{

ulXAPICallID = jdeXAPI_Init( lpBhvrCom, "SendOrderPromiseRequest",

"XAPIOPOUT",

NULL,

&eXAPICallReturn);

if (eXAPICallReturn != eEventCallSuccess)

{

bExit = TRUE;

}

}

#endif

if (bExit == FALSE)

{

/*-----------------------------------------------------*/

/* Loading Header Information */

I4205010_PopulateQueryHeader(lpDS,&dsD4205010A,

lpDSD4205040H,&dsD0100042,hUser,lpVoid,lpBhvrCom);

nHeaderBackOrderAllowed = dsD4205010A.nAllowBackorders;

/*-----------------------------------------------------*/

/* Adding Header Information */

#ifdef jdeXAPI_CALLS_ENABLED

if(bXAPIInUse == TRUE)

{

eXAPICallReturn = jdeXAPI_Add( lpBhvrCom,

ulXAPICallID,

"SendOrderPromiseRequest",

"D4205010A",

&dsD4205010A,

sizeof(DSD4205010A));

if (eXAPICallReturn != eEventCallSuccess)

{

bExit = TRUE;

}

}

#endif

}

}

if (bExit == FALSE)

{

/*-----------------------------------------------------*/

/* Loading Detail Information */

MathCopy(&dsD4205050.mnOrderNumber,&lpDS->mnOrderNumber);

strncpy(dsD4205050.szOrderType,lpDS->szOrderType,

sizeof(dsD4205050.szOrderType));

strncpy(dsD4205050.szOrderCompany,lpDS->szOrderCompany,

sizeof(dsD4205050.szOrderCompany));

dsD4205050.cUseCacheOrWF = lpDS->cUseCacheOrWF;

strncpy(dsD4205050.szComputerID,lpDS->szComputerID,

sizeof(dsD4205050.szComputerID));

MathCopy(&dsD4205050.mnJobNumber,&lpDS->mnJobNumber);

if (lpDSD4205040H->cActionCode != 'A')

{

dsD4205050.cCheckTableAfterCache = '1';

}

else

{

dsD4205050.cCheckTableAfterCache = '0';

}

jdeCallObject( "GetSalesOrderDetailRecordOP",

NULL,

lpBhvrCom, lpVoid,

(LPVOID)&dsD4205050,

(CALLMAP *) NULL,

(int) 0, (char *) NULL,

(char *) NULL, (int) 0 ) ;

if (dsD4205050.cRecordFound != '1')

{

bExit = TRUE;

lpDS->cErrorCode = '1';

/* Sales Order Detail Not Found */

strncpy(lpDS->szErrorMessageID,"4162",

sizeof(lpDS->szErrorMessageID));

if (lpDS->cSuppressError != '1')

{

jdeErrorSet (lpBhvrCom, lpVoid, (ID) 0, "4162", (LPVOID) NULL);

}

}

while ((dsD4205050.cRecordFound == '1') && (bExit == FALSE))

{

lpDSD4205050D = (LPDSD4205050D)jdeRemoveDataPtr( hUser,

(ulong)dsD4205050.idDetailRecord);

/* Reset flags */

cPromisableLine = '0';

bB4001040Called = FALSE;

/*------------------------------------------------------*/

/* Evaluate the Record from F4211 (cDataSource = 2) to */

/* find out if we should promise the line else find out */

/* from Order Promising Detail.*/

if(dsD4205050.cDataSource == '1')

{

if (lpDSD4205050D->cOPPromiseLineYN == 'Y')

{

cPromisableLine = '1';

}

}

else if(dsD4205050.cDataSource == '2')

{

MathCopy ( &dsD4001040.mnShortItemNumber,

&lpDSD4205050D->mnShortItemNumber);

strncpy ( dsD4001040.szBranchPlant,

lpDSD4205050D->szBusinessUnit,

sizeof(dsD4001040.szBranchPlant));

jdeCallObject ( "GetItemMasterDescUOM",

NULL,

lpBhvrCom, lpVoid,

(LPVOID)&dsD4001040,

(CALLMAP *) NULL,

(int) 0, (char *) NULL,

(char *) NULL, (int) 0 ) ;

bB4001040Called = TRUE;

cPromisableLine = I4205010_IsLinePromisable(lpBhvrCom,lpVoid,

hUser,lpDS,lpDSD4205050D,dsD4001040.cStockingType);

}

if (cPromisableLine == '1')

{

/* Set this flag if at least one promisable detail record exists. */

bAtLeastOneDetail = TRUE;

if (bB4001040Called == FALSE)

{

MathCopy (&dsD4001040.mnShortItemNumber,

&lpDSD4205050D->mnShortItemNumber);

strncpy ( dsD4001040.szBranchPlant,

lpDSD4205050D->szBusinessUnit, sizeof(dsD4001040.szBranchPlant));

jdeCallObject ( "GetItemMasterDescUOM",

NULL,

lpBhvrCom, lpVoid,

(LPVOID)&dsD4001040,

(CALLMAP *) NULL,

(int) 0, (char *) NULL,

(char *) NULL, (int) 0 ) ;

}

I4205010_PopulateQueryDetail( lpDS,&dsD4205010B,

lpDSD4205050D,

&dsD4001040,

&dsD4205010A,

&dsD0100042,

cPromisableLine,

hUser,

lpVoid,

lpBhvrCom);

#ifdef jdeXAPI_CALLS_ENABLED

if(bXAPIInUse == TRUE)

{

eXAPICallReturn = jdeXAPI_Add( lpBhvrCom,

ulXAPICallID,

"SendOrderPromiseRequest",

"D4205010B",

&dsD4205010B,

sizeof(DSD4205010B));

if (eXAPICallReturn != eEventCallSuccess)

{

bExit = TRUE;

}

}

#endif

}

/*-----------------------------------------------------*/

/* Fetching the next Detail Record */

MathCopy(&dsD4205050.mnOrderNumber,&lpDS->mnOrderNumber);

strncpy(dsD4205050.szOrderType,lpDS->szOrderType,

sizeof(dsD4205050.szOrderType));

strncpy(dsD4205050.szOrderCompany,lpDS->szOrderCompany,

sizeof(dsD4205050.szOrderCompany));

dsD4205050.cUseCacheOrWF = lpDS->cUseCacheOrWF;

strncpy(dsD4205050.szComputerID,lpDS->szComputerID,

sizeof(dsD4205050.szComputerID));

MathCopy(&dsD4205050.mnJobNumber,&lpDS->mnJobNumber);

if (lpDSD4205040H->cActionCode != 'A')

{

dsD4205050.cCheckTableAfterCache = '1';

}

else

{

dsD4205050.cCheckTableAfterCache = '0';

}

jdeCallObject( "GetSalesOrderDetailRecordOP",

NULL,

lpBhvrCom, lpVoid,

(LPVOID)&dsD4205050,

(CALLMAP *) NULL,

(int) 0, (char *) NULL,

(char *) NULL, (int) 0 ) ;

}

if (!bAtLeastOneDetail)

{

bExit = TRUE;

lpDS->cErrorCode = '1';

/* Sales Order Detail Not Found */

strncpy(lpDS->szErrorMessageID,"4162",

sizeof(lpDS->szErrorMessageID));

if (lpDS->cSuppressError != '1')

{

jdeErrorSet (lpBhvrCom, lpVoid, (ID) 0, "4162", (LPVOID) NULL);

}

}

if (bExit == FALSE)

{

#ifdef jdeXAPI_CALLS_ENABLED

if(bXAPIInUse == TRUE)

{

eXAPICallReturn = jdeXAPI_Finalize( lpBhvrCom,

ulXAPICallID,

"SendOrderPromiseRequest",

"OrderPromiseCallback");

if (eXAPICallReturn != eEventCallSuccess)

{

bExit = TRUE;

}

}

#endif

}

/*-----------------------------------------------------*/

/* Call B4205020 in Add Mode */

if((bExit == FALSE) &&

(lpDS->cDisplayBeforeAcceptMode != '1') &&

(lpDS->cUseCacheOrWF == '2'))

{

MathCopy(&dsD4205020.mnOrderNumber,&lpDS->mnOrderNumber);

strncpy(dsD4205020.szOrderType,lpDS->szOrderType,

sizeof(dsD4205020.szOrderType));

strncpy(dsD4205020.szOrderCompany,lpDS->szOrderCompany,

sizeof(dsD4205020.szOrderCompany));

strncpy(dsD4205020.szComputerID,lpDS->szComputerID,

sizeof(dsD4205020.szComputerID));

MathCopy(&dsD4205020.mnJobNumber,&lpDS->mnJobNumber);

jdeCallObject( "MaintainOPWorkFile",

NULL,

lpBhvrCom, lpVoid,

(LPVOID)&dsD4205020,

(CALLMAP *) NULL,

(int) 0, (char *) NULL,

(char *) NULL, (int) 0 ) ;

}

}

/************************************************************************

* Function Clean Up

************************************************************************/

#ifdef jdeXAPI_CALLS_ENABLED

if (eXAPICallReturn != eEventCallSuccess)

{

/*-----------------------------------------------------*/

/* CleanUp */

if(bXAPIInUse == TRUE)

{

jdeXAPI_Free( lpBhvrCom,

ulXAPICallID,

"SendOrderPromiseRequest");

}

lpDS->cErrorCode = '1';

/* System Error - no reasonable error messages exist in Xe. */

strncpy(lpDS->szErrorMessageID,"018Y",

sizeof(lpDS->szErrorMessageID));

if (lpDS->cSuppressError != '1')

{

jdeErrorSet (lpBhvrCom, lpVoid, (ID) 0, "018Y", (LPVOID) NULL);

}

}

#endif

if(lpDSD4205040H != (LPDSD4205040H)NULL)

{

jdeFree((void *)lpDSD4205040H);

}

if(lpDSD4205050D != (LPDSD4205050D)NULL)

{

jdeFree((void *)lpDSD4205050D);

}

return (ER_SUCCESS);

}

Additional Notes

None

See Also

· jdeXAPI_Init

· jdeXAPI_Add

· jdeXAPI_Finalize

· jdeXAPI_Free

· jdeXAPI_SimpleSend

· jdeXAPI_IsCallTypeEnabled

· jdeXAPI_CALLS_ENABLED

· Interop Guide


Real-Time Events

Real-Time Level Events consist of the following:

jdeIEO_CreateSingleEvent

jdeIEO_EventAdd

app.gif (808 bytes)

jdeIEO_EventFinalize

app.gif (808 bytes)

jdeIEO_EventFree

app.gif (808 bytes)

jdeIEO_EventInit

app.gif (808 bytes)

jdeIEO_isEventTypeEnabled

app.gif (808 bytes)

jdeIEO_REALTIME_ENABLED


jdeIEO_CreateSingleEvent

Last Modified: EnterpriseOne| November 9, 2000

The purpose of this API is to create a SingleEvent. It is similar to calling jdeIEO_EventInit, jdeIEO_EventAdd, jdeIEO_EventFinalize APIs to create an aggregate event with only one partial event.

Syntax

IEO_EVENT_RETURN jdeIEO_CreateSingleEvent(LPBHVRCOM pBhvrCom, PJSTR szFunction, NID szEventType, PJSTR szEventScope, NID szDsTmpl, LPVOID pData, int iDataSize, IEO_EVENT_FLAG eEventFlag)

Parameters

Parameter | Notes | Usage
LPBHVRCOM pBhvrCom | Pointer to the Behavior Communication Structure. |
PJSTR szFunction | Name of the Business Function calling the API. |
NID szEventType | The name of the Event. I.e. SOADD, JDESOOUT. |
PJSTR szEventScope | The scope of the Event. |
NID szDsTmpl | The name of the OneWorld data structure. I.e. D9800182D. |
LPVOID pData | The data to be passed to IEO Kernel. This is a pointer to the data structure object of szDsTmplName. |
int iDataSize | Size of the data passed. This must be set to sizeof () of the szDsTmplName. I.e. for D9800182D, it will be sizeof (DSD9800182D). |
IEO_EVENT_FLAG eEventFlag | Flag for future use. |

Return Value

IEO_EVENT_RETURN: The error/success value.

Example

IEO_EVENT_RETURN eEventReturn = eEventCallSuccess;

eEventReturn = jdeIEO_CreateSingleEvent( lpBhvrCom,

    “RealTimeEventsTest”,

    “JDERTOUT”,

    “SalesOrder”,

    “D55RTTEST”,

    &zRTTest,

    sizeof(zRTTest),

    0 );

Additional Notes

None

See Also

· -jdeIEO_EventInit

· -jdeIEO_EventAdd

· -jdeIEO_EventFinalize

· -jdeIEO_EventFree

· -jdeIEO_IsEventTypeEnabled

· -jdeIEO_REALTIME_ENABLED


jdeIEO_EventAdd

Last Modified: EnterpriseOne| November 9, 2000

The purpose of this API is to validate the EventID by mapping it to already created PartialEventInfo structure, validate the data, increment the PartialEventCount and pass the Event Data to IEO Kernel.

Syntax

IEO_EVENT_RETURN jdeIEO_EventAdd (LPBHVRCOM pBhvrCom, IEO_EVENT_ID ulEventNumber, PJSTR szFunction, NID szSingleEventType, NID szDsTmpl,LPVOID pData, int iDataSize, IEO_EVENT_FLAG eEventFlag)

Parameters

Parameter | Notes | Usage
LPBHVRCOM pBhvrCom | Pointer to the Behavior Communication Structure. |
IEO_EVENT_ID ulEventNumber | The unique ID assigned to the RealTimeEvent. This is Generated by jdeIEO_EventInit API. |
PJSTR szFunction | Name of the Business Function calling the API. |
NID szSingleEventType | The name of the Event. I.e. SOADD, JDESOOUT. | This value is only used for SingleEvent if the main event is a CompositeEvent.
NID szDsTmplName | The name of the OneWorld data structure. I.e. D9800182D. |
LPVOID pData | The data to be passed to IEO Kernel. This is a pointer to the data structure object of szDsTmplName. |
int iDataSize | Size of the data passed. This must be set to sizeof () of the szDsTmplName. I.e. for D9800182D, it will be sizeof (DSD9800182D). |
IEO_EVENT_FLAG eEventFlag | Flag for future use. |

Return Value

IEO_EVENT_RETURN: The error/success value.

Example

eEventReturn = jdeIEO_EventAdd ( pBhvrCom,

szEventID,

“MyFunction2”,

“SODOCBEGIN”, // EventType for SingleEvent

“D55TEST01”,

&zD55TEST01,

sizeof(zD55TEST01));

Additional Notes

None

See Also

· -jdeIEO_EventInit

· -jdeIEO_EventFinalize

· -jdeIEO_EventFree

· -jdeIEO_CreateSingleEvent

· -jdeIEO_IsEventTypeEnabled

· -jdeIEO_REALTIME_ENABLED


jdeIEO_EventFinalize

Last Modified: EnterpriseOne| November 9, 2000

The purpose of the API is to send a notification to IEO Kernel to finalize the RealTime Event and send it to EVN Kernel.

Syntax

IEO_EVENT_RETURN jdeIEO_EventFinalize (LPBHVRCOM pBhvrCom, IEO_EVENT_ID ulEventNumber, PJSTR szFunction, IEO_EVENT_FLAG eEventFlag)

Parameters

Parameter | Notes | Usage
LPBHVRCOM pBhvrCom | Pointer to the Behavior Communication Structure. |
IEO_EVENT_ID ulEventNumber | The unique ID assigned to the RealTimeEvent. | This is Generated by jdeIEO_EventInit API.
PJSTR szFunction | Name of the Business Function calling the API. |
IEO_EVENT_FLAG eEventFlag | Flag for future use. |

Return Value

IEO_EVENT_RETURN: The error/success value.

Example

eEventReturn = jdeIEO_EventFinalize (pBhvrCom,

EventID,

“MyFunction4”);

Additional Notes

None

See Also

· -jdeIEO_EventInit

· -jdeIEO_EventAdd

· -jdeIEO_EventFree

· -jdeIEO_CreateSingleEvent

· -jdeIEO_IsEventTypeEnabled

· -jdeIEO_REALTIME_ENABLED


jdeIEO_EventFree

Last Modified: EnterpriseOne| November 9, 2000

The purpose of the API is to free the RealTime Event. This API must be called in case of error from jdeIEO_EventAdd or jdeIEO_EventFinalize (i.e. Anytime after calling jdeIEO_EventInit).

Syntax

IEO_EVENT_RETURN jdeIEO_EventFree (LPBHVRCOM pBhvrCom, IEO_EVENT_ID ulEventNumber, PJSTR szFunction, IEO_EVENT_FLAG eEventFlag)

Parameters

Parameter | Notes | Usage
LPBHVRCOM pBhvrCom | Pointer to the Behavior Communication Structure. |
IEO_EVENT_ID ulEventNumber | The unique ID assigned to the RealTimeEvent. | This is Generated by jdeIEO_EventInit API.
PJSTR szFunction | Name of the Business Function calling the API. |
IEO_EVENT_FLAG eEventFlag | Flag for future use. |

Return Value

IEO_EVENT_RETURN: The error/success value.

Example

None

Additional Notes

None

See Also

· -jdeIEO_EventInit

· -jdeIEO_EventAdd

· -jdeIEO_EventFinalize

· -jdeIEO_CreateSingleEvent

· -jdeIEO_IsEventTypeEnabled

· -jdeIEO_REALTIME_ENABLED


jdeIEO_EventInit

Last Modified: EnterpriseOne November 9, 2000

The purpose of this API is to validate the EventType against the INI setting, communicate with IEO Kernel to generate the unique ID for the RealTime Event, create a RealTime Event as a container in the IEO Kernel, and return the EventID back.

Syntax

IEO_EVENT_ID jdeIEO_EventInit(LPBHVRCOM pBhvrCom,IEO_EVENT_TYPE eEventType, PJSTR szFunction, NID szEventType, PJSTR szEventScope, IEO_EVENT_FLAG eEventFlag,IEO_EVENT_RETURN *peEventReturn)

Parameters

Parameter | Notes | Usage
LpBhvrCom pBhvrCom | Pointer to the Behavior Communication Structure. |
IEO_EVENT_TYPE eEventType | Type of the event to create. Valid values are, eEventComposite, eEventAggregate, and eEventSingle. |
PJSTR szFunction | Name of the Business Function calling the API. |
NID szEventType | The name of the OneWorld Event. I.e. RTSOADD, JDESOOUT etc. |
PJSTR szEventScope | The scope of the Event. Required by Active. |
IEO_EVENT_FLAG eEventFlag | Flag for future use. |
IEO_EVENT_RETURN *peEventReturn | The error/success value. User has to pass the address of this parameter. So that the API can update the value. | User has to pass the address of this parameter. So that the API can update the value.

Return Value

IEO_EVENT_ID: The unique ID assigned to the RealTimeEvent.

Example

IEO_EVENT_RETURN eEventReturn = eEventCallSuccess;

IEO_EVENT_ID szEventID = jdeIEO_EventInit (pBhvrCom,

eEventAggregate,

"MyFunction1",

"JDESOOUT" // EventType for AggregateEvent

"EventScope1",

0,

&eEventReturn);

Additional Notes

None

See Also

· -jdeIEO_EventAdd

· -jdeIEO_EventFinalize

· -jdeIEO_EventFree

· -jdeIEO_CreateSingleEvent

· -jdeIEO_IsEventTypeEnabled

· -jdeIEO_REALTIME_ENABLED


jdeIEO_IsEventTypeEnabled

Last Modified: EnterpriseOne| November 8, 2000

The API jdeIEO_IsEventTypeEnabled is used to compare the passed EventType against the registered Events in IEO.INI and filtered Events in JDE.INI file. All the APIs provided do call this API before doing any processing. It is recommended to call this API before calling jdeIEO_CreateSingleEvent to avoid any data manipulation in case of a particular event not being enabled.

Syntax

BOOL jdeIEO_IsEventTypeEnabled (

  NID             szEventType       /* Event Type */

);

Parameters

Parameter | Notes | Usage
-NID szEventType | The name of the Event. I.e. SOADD, JDESOOUT. | Name of the event to be compared.

Return Value

BOOL: Returns TRUE/FALSE

Example

None

Additional Notes

None

See Also

· -jdeIEO_EventInit

· -jdeIEO_EventAdd

· -jdeIEO_EventFinalize

· -jdeIEO_EventFree

· -jdeIEO_CreateSingleEvent

· -jdeIEO_REALTIME_ENABLED


jdeIEO_REALTIME_ENABLED

Last Modified: EnterpriseOne| November 8, 2000

The macro jdeIEO_REALTIME_ENABLED is used to check if RealTime event generation is enabled for an instance of OneWorld or not. It is recommended to call this macro before doing any RealTime event generation. So that the data manipulation can be avoided if the generation is not enabled.

Syntax

BOOL jdeIEO_REALTIME_ENABLED ();

Parameters

Parameter | Notes | Usage

Return Value

BOOL: returns TRUE/FALSE

Example

None

Additional Notes

None

See Also

· -jdeIEO_EventInit

· -jdeIEO_EventAdd

· -jdeIEO_EventFinalize

· -jdeIEO_EventFree

· -jdeIEO_CreateSingleEvent

· -jdeIEO_IsEventTypeEnabled


Events

Events consist of the following:

 | Batch Application Events
 | Constant Events
app.gif (808 bytes) | Interactive Application Events
app.gif (808 bytes) | Table Conversion Events
app.gif (808 bytes) | Table Events


Batch Application Events

Batch Application Events give you flexibility and control over how your reports are processed. For example, you can hide or show an object, hide or show a section, or generate a message.

Batch Application Events consist of the following Categories:

app.gif (808 bytes) | Section Level Events
app.gif (808 bytes) | Page Footer Section Level Events
app.gif (808 bytes) | Page Header Section Level Events
app.gif (808 bytes) | Report Footer Section Level Events
app.gif (808 bytes) | Report Header Section Level Events
app.gif (808 bytes) | Variable Events


AfterRecordIsDeleted

Last Modified: B733

AfterRecordIsDeleted executes after JDEBASE middleware deletes a record from the table

Available On

  • All EnterpriseOne defined tables

Available Objects

  • System Values (SL)

  • Table Columns (TK)

  • User Defined Variables (VA)

Typical Usage

This event is used for ensuring database integrity across different relational tables in the database. This event can also be used for sending messages to supervisors or for auditing Functions. For example, if an item is deleted from the Item Master (F4101) there is a corresponding delete from the Bulk Item Master (F41011) for database integrity.

Additional Notes

Attach logic for deleting related table records on this event.

Processing Sequence

  1. This event is executed followed by the actual deletion from the database by the middleware, then based on the whether the deletion was successful or not, this event will execute.


AfterRecordIsFetched

Last Modified: B733

AfterRecordIsFetched executes after record is fetched from the database and the JDEBASE middleware has it in the buffer, but not passed on to the application.

Available On

  • All EnterpriseOne defined tables

Available Objects

  • System Values (SL)

  • Table Columns (TK)

  • User Defined Variables (VA)

Typical Usage

This event is processed after a Fetch has been done from the table and the columns are in the buffer. This is a good time to work with the values that will be passed on the application.

An example of this would be in the F0901 table where on this event Table ER logic will test to see if the user has a language preference set. If not, it will use the default account descriptions in the F0901 file. If the user does have a language preference, the ER will test to see if an alternative account description exists for the set language preference. If an alternative description does exist in the F0901D file for the set language preference, it will be used instead of the default description. Otherwise, the default description will be used from the F0901 file.

Additional Notes

The EnterpriseOne application will not distinguish between any TK values changed in the buffer, for example, on this event, versus a value coming from the database table.

Processing Sequence

The Before Record is Fetched event is executed followed by the actual fetch from the database by the middleware, and then based on the whether the fetch was successful or not, this event will execute.


AfterRecordIsInserted

Last Modified: B733

AfterRecordIsInserted executes after JDEBASE middleware inserts a record into the table.

Available On

  • All EnterpriseOne defined tables

Available Objects

  • System Values (SL)

  • Table Columns (TK)

  • User Defined Variables (VA)

Typical Usage

This event is processed after an Insert has been done in the table. It is typically used for audit, sending informational messages, or inserting records in other tables for database integrity. For example, in the Order Approval Audit (F4818) Table, a Send Message system function is called to send a message to a designated supervisor.

Additional Notes

On this event, attach logic for inserting records in related tables.

Processing Sequence

  1. This event will not execute If the insert failed.


AfterRecordIsUpdated

Last Modified: B733

AfterRecordIsUpdated executes after a record is updated in the database by the JDEBASE middleware.

Available On

  • All EnterpriseOne defined tables

Available Objects

  • System Values (SL)

  • Table Columns (TK)

  • User Defined Variables (VA)

Typical Usage

The logic on this event is executed after the middleware has updated the record in the database. It is typically used for audit, sending informational messages, or updating records in other tables for database integrity. For example, in the Order Approval Audit Table (F4818), a Send Message system function is called to send a message to a designated supervisor.

Additional Notes

On this process, attach logic for updating related tables.

Processing Sequence

This event will not execute if the update failed.


BeforeRecordIsDeleted

Last Modified: B733

BeforeRecordIsDeleted is triggered when an application calls the JDEBASE to Delete a record in this table.

Available On

  • All EnterpriseOne defined tables

Available Objects

  • System Values (SL)

  • Table Columns (TK)

  • User Defined Variables (VA)

Typical Usage

This event rule is called before a record is deleted in the table. Is used for audit, and sending informational messages. For example, in the Shipment Header Table (F4215), a delete to multiple other tables, such as the Routing Steps Table (F4941), is done.

Additional Notes

Do not attach logic to delete related tables on this event as the Delete to this table might fail while other related tables would have been deleted. Attach logic for that process on the After Record is Deleted event.

Processing Sequence

This event executes after the application submits a request to the middleware to delete a record from the database. This event executes if the middleware is unable to delete this record. The After Record is Deleted event will not take place if the delete is unsuccessful.


BeforeRecordIsFetched

Last Modified: B733

When EnterpriseOne application requests the JDEBASE middleware to fetch a record from the database.

Available On

  • All EnterpriseOne defined tables

Available Objects

  • System Values (SL)

  • Table Columns (TK)

  • User Defined Variables (VA)

Typical Usage

This event rule is called before a record is fetched from the table. It is used for sending informational messages or checking certain conditions that might affect the fetch.

Additional Notes

The request from the application to the middleware for the fetch has not yet been processed on this event. The actual fetch happens next and then populates the buffer.

Processing Sequence

After the application submits a request to the middleware to fetch a record from the database this event will be executed. If the middleware is unable to fetch this record, this event will still execute. The After Record is Fetched event will not take place if the fetch was unsuccessful.


BeforeRecordIsInserted

Last Modified: B733

After an application has issued a request for a record to be inserted and before the JDEBASE middleware actually inserts the record into the database.

Available On

  • All EnterpriseOne defined tables

Available Objects

  • System Values (SL)

  • Table Columns (TK)

  • User Defined Variables (VA)

Typical Usage

This event rule is called before a record is inserted in the table. It is typically used for audit, sending informational messages, or inserting or updating records in other tables for database integrity or message files.

This event can also be used to stamp audit information (for example, date, time, user ID, or program ID) on records being Inserted in the database.

For example, in the Held Orders Table (F4209), a message is sent to users depending on a certain code in the table buffer and the PPAT Message (F01131) table is updated.

Additional Notes

Do not attach logic to insert records in related tables on this event as the insert to this table might fail while other related tables would have had records inserted whether or not the actual Insert to this table was successful or not. Attach logic for Inserting records to related tables on the After Record is Inserted event.

TK column values in the buffer might be changed at this point, which will affect the table update.

Processing Sequence

  1. The event is executed after the application submits a request to the middleware to Insert a record into the database. This event will execute even if the middleware is unable to insert this record. The After Record is Inserted event will not take place if the Insert was unsuccessful.


BeforeRecordIsUpdated

Last Modified: B733

BeforeRecordIsUpdated is triggered when an application calls the JDEBASE middleware to update a record in the database.

Available On

  • All EnterpriseOne defined tables.

Available Objects

  • System Values (SL)

  • Table Columns (TK)

  • User Defined Variables (VA)

Typical Usage

This event rule is called before a record is updated in the table. It is typically used for audit, sending informational messages, or updating records in other tables for database integrity.

This event can also be used for retrieving and writing records to the Cache.

This event can also be used to stamp audit info (for example, date, time, user ID, or program ID) on records being updated in the database.

For example, in the Employee Master (F060116) table, an update is tracked and all columns in the table being updated are tracked for audit Functions. This is the point when they record the information when it is being updated. Logic attached to the After record is Fetched event, would have captured the initial picture of the record in the Cache and can be used at this event for comparison.

Additional Notes

Do not attach logic to update related tables on this event as the Update to this table might fail while other related tables would have been updated. Attach logic for that process on the After Record is Updated event.

Processing Sequence

This event executes after the application submits a request to the middleware to update a record from the database. This event will still execute if the middleware is unable to update this record. The After Record is Updated event will not take place if the Update was unsuccessful.


CurrencyConversionIsOn

Last Modified: B733

CurrencyConversionIsOn is used to alter the currency decimal in a currency related amount field.

Available On

  • All EnterpriseOne defined tables

Available Objects

  • System Values (SL)

  • Table Columns (TK)

  • User Defined Variables (VA)

Typical Usage

Based upon the action of the database request, this event will call ‘After Record is Fetched’ on Inquiry mode and ‘Before Record is Added’ on Add/Update mode. Internally, these two events are executed by the Currency Conversion is On event, user does not need to enter logic in these two events.

Use this event to retrieve the currency code and currency decimal to a currency amount field.

For example, in the Account Ledge Table (F0911) currency decimal and currency code are needed for all the currency amount fields. A business function with special currency logic is used to retrieve the currency information and pass it back to the database. This currency information is stored within the amount field structure.

Additional Notes

Refer to the EnterpriseOne Currency Processing document for more information.

Processing Sequence

Called whenever Currency is turned on in EnterpriseOne.


Constant Events

Constant Events consist of the following:

 | DoConstant
app.gif (808 bytes) | EndConstant
 | InitializeConstant
app.gif (808 bytes) | SkipConstant


DoConstant

Last Modified: B733.2 | September 29, 1999

DoConstant occurs just before the font and color are selected for the report constant and before the value is output to the page. This is your last chance to manipulate the value or display attributes of the object before output.

Available On

This event is available at the Object Level for report constant objects only.

Available Objects

List field types (such as RV, VA).

Typical Usage

As this is the last chance to modify the value, it is typically used to change the value to be printed.

Processing Sequence

  • Initialize Constant

  • Do Constant

  • End Constant


EndConstant

Last Modified: B733.2 | September 29, 1999

EndConstant occurs immediately after the constant has been processed.

Available On

This event is only available to report constants. It is not applicable to the entire report or sections within the report.

Available Objects

List field types (such as BC, RV, VA)

Typical Usage

After a constant has been processed, this event rule logic can be processed.

Processing Sequence

  • Initialize Constant

  • Do Constant

  • End Constant

Event Rule logic

Process next object.


InitializeConstant

Last Modified: B733.2 | September 29, 1999

InitializeConstant is invoked each time before a report constant is to be processed.

Available On

This event is only available to report constants. It is not applicable to the entire report or sections within the report.

Available Objects

List field types (such as, BC, RV, VA).

Typical Usage

This event occurs before the constant’s position has been calculated on the page.

Processing Sequence

  • Initialize Constant

  • Do Constant

  • End Constant


SkipConstant

Last Modified: B733.2 | September 29, 1999

If a constant object will not fit on the current page, the UBE will issue a SkipConstant message, which will cause the object to be bypassed until the next page begins processing.

Available On

This event is only available at the object level, for report constants only.

Available Objects

List field types (such as RV, VA).

Typical Usage

The typical use of this event is to change the value of a constant at the page break.

Processing Sequence

  • Skip Constant

  • Process Next Object (Init-Do-End Object or Constant)

  • Adv Section


Interactive Application Events

Interactive Application Events are events that may occur during processing of an interactive application.

Interactive Application Events consist of the following:

Control Events

Form Events

Tab Control


Control Events

Control events are inherited based on the type of control selected and cannot be changed.

Control Events consist of the following categories:

 | Button Control Events
 | Edit Control Events
 | Grid Control Events
app.gif (808 bytes) | Hyperitem Control Events
 | Parent/Child Control Events


Button Control Events

Button Control Events consist of the following:

 | ButtonClicked
app.gif (808 bytes) | CheckboxSectionChanged
app.gif (808 bytes) | Director Back Button Clicked
app.gif (808 bytes) | Director Cancel Button Clicked
app.gif (808 bytes) | Director Next Button Clicked
app.gif (808 bytes) | Disable Characterization
 | PostButtonClicked
app.gif (808 bytes) | RadioButtonSelectionChanged
app.gif (808 bytes) | SelectionChanged


ButtonClicked

Last Modified: EnterpriseOne | May 07, 2000

Event Rules attached to ButtonClicked occur when a push button is clicked.

Available On

  • All form types

Available Objects

  • All objects are available

Typical Usage

This event used Form Interconnect to a related form. It uses Hide/Show Grid in a Headerless/Detail and Header/Detail form (for example, the Option Button). Hide button and group common event rule logic in this event so that the same logic can be executed with a push of the button at various events. Used in conjunction with the Push Button system function.

Processing Sequence

  1. When the button is clicked, the control receives a button clicked message.

  2. The API JDERTDftPushButtonProc is called from Windows, where the ButtonClicked event rule will be called.

For the OK button, an error set will stop processing.


CheckboxSelectionChanged

Last Modified: B733.2 | May 27, 1999

Event Rules attached to CheckboxSelectionChanged occur when the check box is changed. Behaviors occur when the check box is clicked on and off.

To assign rules to the values of the check box, attach If/While statements to this event. This allows a behavior to occur only when the box is checked.

Available On

  • Find/Browse

  • Fix/Inspect

  • Header Detail

  • Headerless Detail

  • Search/Select

  • Parent/Child Browse

Available Objects

  • All objects are available

Typical Usage

This event assigns values to Form Controls that have Y/N or 1/0 as allowed values. Use check boxes to indicate True/False or Yes/No values, and then set up rules that relate to those values.

Additional Notes

Check box events are similar to Radio Button events. See also If/While Clauses, Radio Button Control Events.

Testing the value of the checkbox on this event will yield the new value of the selection.

Processing Sequence

The event is executed when the main dialog procedure receives a button clicked notification. The API that calls the event rules is jdeMaintainDftCheckBox.


Director Back Button Clicked - API_Events

DirectorBackButtonClicked

Last Modified: EnterpriseOne | July 14, 2000

This is a form level event rule that will be triggered when users click the Previous button. This event will only be triggered if the application is within the universal director frame-work.

Available On

This event is a form level event.

Available Objects

All objects will be available.

Typical Usage

This is used within the universal director frame-work.


Director Cancel Button Clicked - API_Events

Director Cancel Button Clicked

Last Modified: EnterpriseOne| July 20, 2000

This form level event rule is triggered when users click the Cancel button. This event is only triggered if the application is within the universal director frame-work.

Available On

This event is a form level event.

Available Objects

All objects will be available.

Typical Usage

This is used within the universal director frame-work.


Director Next Button Clicked - API_Events

DirectorNextButtonClicked

Last Modified: EnterpriseOne | July 14, 2000

This is a form level event rule that will be triggered when users click the Next button. This event will only be triggered if the application is within the universal director frame-work.

Available On

This event is a form level event.

Available Objects

All objects will be available.

Typical Usage

This is used within the universal director frame-work.


Disable Characterization - API_System Functions

DisableCharacterization

Last Modified: EnterpriseOne | July 14, 2000

This system function will disable all the characterization for the media object in the current session.

Parameters

Parameter | Description | I/O | Required | Notes
Categories |  | I | Y | Stored value created by Set Characterization Cache.

Available Events

Available on all events

Related Topics

· Set Characterization Cache, Clear Characterization Cache


PostButtonClicked

Last Modified: EnterpriseOne | May 07, 2000

Event Rules attached to PostButtonClicked occur when a push-button is clicked immediately after the event rule for “ButtonClicked” is over.

Available On

  • All form types

Available Objects

  • All objects are available

Typical Usage

This event is used to check and set values of variables that may have changed during the button clicked event processing. In addition, the event is used in cases where there is a form interconnect on the button clicked event. The "Post button Clicked" event executes after the button clicked event has finished. Return values from the Form interconnect may be tested on this event to set flags. This may not always be the case if modeless processing is enabled.

Processing Sequence

  1. When the button is clicked, the control receives a button clicked message.

  2. The API JDERTDftPushButtonProc is called from Windows, where the “Button Clicked” event rule will be called.

  3. Immediately after that, the “Post Button Clicked” event would be executed.


RadioButtonSelectionChanged

Last Modified: B733.2 | May 27, 1999

Event Rules attached to RadioButtonSelectionChanged occur when the radio button to which the event is attached is changed. Behaviors occur when the radio button is clicked.

Available On

  • Find/Browse

  • Fix/Inspect

  • Header Detail

  • Headerless Detail

  • Search/Select

  • Parent/Child Browse

Available Objects

  • All objects are available.

Typical Usage

This event is used to display or toggle in a browse form as well as control the hiding and showing of field columns or grid column fields. Additionally, it is used to select from a range of choices, and then relate behaviors to the particular choice selected. Finally, it is used to indicate True/False or Yes/No values, and then set up behaviors that relate to those values

Additional Notes

Every radio button is associated with a data item. Radio buttons with the same data item are referred to as a group of radio buttons. Within a group of radio buttons, only one may be selected at a time. Each radio button in a group of radio buttons requires a unique value. Radio button values are assigned at design time.

For example, assume there are three radio buttons all associated with data item CHAR (a character). The first radio button is labeled "Yes", the second "No", and the third "Maybe". Their respective values (as set up at design time) are Y, N, and M.

FC Yes

Y

FC No

N

FC Maybe

M

Only one radio button can be selected at a time, so the value of CHAR will be Y if Yes is selected, N if No is selected, or M if Maybe is selected.

For clarity of coding, always compare the value (Y, N, M) to the radio button FC being checked (FC Yes, FC No, FC Maybe).

Radio button events are very similar to Check Box events. See also If/While Clauses, Check Box Control Events.

Processing Sequence

  1. A Windows message is received for button clicked which is tapped by the API jdeMaintainDftCheckBox. This API runs the event rule for Radio Button “Selection Changed”.


SelectionChanged

Last Modified: EnterpriseOne | July 17, 2000

This event is used with the radio buttons and check box controls. When the control is turned on or off, Selection Changed event will be triggered.

Available On

This event will only be available on the radio buttons and check box controls on the form level.

Available Objects

All objects are available.

Typical Usage

This event is triggered when the radio button or check box controls changes from off to on or from on to off.


Edit Control Events

Edit Control Events consist of the following:

 | ControlIsEntered
app.gif (808 bytes) | ControlIsExited
 | ControlIsExitedandChanged-Asynch
app.gif (808 bytes) | ControlIsExitedandChanged-Inline
 | PostVisualAssistButtonClicked
app.gif (808 bytes) | Text Clicked
 | VisualAssistButtonClicked


ControlIsEntered

Last Modified: B733.2 | May 27, 1999

ControlIsEntered executes each time a control receives focus.

Available On

  • Find/Browse

  • Fix/Inspect

  • Header Detail

  • Headerless Detail

  • Search/Select

  • Parent/Child Browse

Available Objects

  • Applies to form controls only

Typical Usage

  • Perform initializations related to the control receiving focus

Additional Notes

For performance reasons, this event should be used sparingly.

Processing Sequence

  1. Run the Control Is Entered event rules.

Note: When focus is going from one control to another the Windows operating system sends the EN_SETFOCUS (Control Is Entered) for the control receiving focus before sending the EN_KILLFOCUS (Control is Exited) for the control loosing focus.


ControlIsExited

Last Modified: B733.2 | May 27, 1999

ControlIsExited executes each time a control loses focus. It executes when focus is going to the Cancel button or to another dialog. This event is executed inline.

Available On

  • Find/Browse

  • Fix/Inspect

  • Header Detail

  • Headerless Detail

  • Search/Select

  • Parent/Child Browse

Available Objects

  • All objects are available

Typical Usage

  • Typically, this event is used with exited and changed events to maintain variables.

Additional Notes

For performance reasons should be used sparingly.

Processing Sequence

  1. If the text from the control is different from the formatted data stored internally, store flags about modification

  2. Clear any errors that were set on this control during the Control is Exited ER (from a previous call)

  3. Run the Control is Exited ER

Note: When focus is going from one control to another the Windows operating system sends the EN_SETFOCUS (Control Is Entered) for the control receiving focus before sending the EN_KILLFOCUS (Control Is Exited) for the control loosing focus.


ControlIsExitedandChanged-Asynch

Last Modified: B733.2 | May 27, 1999

ControlIsExitedandChanged-Asynch executes each time a control loses focus if the text in the control has changed since a previous execution of this event. It is not run if the data in the control being left does not pass Data Type validation. It can execute even when focus is going to the cancel button or to another dialog. This event is executed anachronously.

Control is Exited and Changed-Asynch is put on the thread queue after Control is Exited and Changed-Inline event rule is executed.

Available On

  • Find/Browse

  • Fix/Inspect

  • Header Detail

  • Headerless Detail

  • Search/Select

  • Parent/Child Browse

Available Objects

  • All objects are available.

  • Using the Form Control being left in event rule gets the current value of the cell

Typical Usage

  • May be used to run sizable amount of event rule logic and business functions

  • This event should not depend on another ControlIsExitedandChanged-Asynch event because you cannot define the order in which the same two events are processed

  • Do not use this event when validating filters for a Find

Additional Notes

This asynchronous event is executed even if the Control is Exited and Changed-Inline event rule sets an error. The execution of this event rule must finish before the form can be closed.

Processing Sequence

  1. If the cell has not changed by typing since the last execution of this event, stop processing.

  2. Perform Data Type validation for the data in the control. If there are errors, skip to 7.

  3. Clear any errors that were set on this control during the Control is Exited and Changed-Asynch event rule (from a previous call).

  4. Run the Control is Exited and Changed-Asynch event rule. If there are errors, skip to 7.

  5. Perform Data Dictionary validation. If there are errors, skip to 7.

  6. If there is an associated description, make that assignment.

  7. If the control is set in error, a greater than filter is something other than a string, and the value in the field is not a wildcard, then clear the error.

Note: Most errors are cleared on filter fields due to the possibility of wildcards in the database query statement. Wildcards are not allowed in math numeric or dates, so those errors remain. Another idea where errors would be cleared is in filters that are not looking for an equal (exact) match. The idea here, for example, is that a string field set up as an greater than filter where “Elephant” is allowed should not set an error when “A” is entered, even if “A” is not a valid entry. It should accept “A” and find the “Elephant” record on the next Find.

Note: When focus is going from one control to another the Windows operating system sends the EN_SETFOCUS (Control Is Entered) for the control receiving focus before sending the EN_KILLFOCUS (Control is Exited) for the control losing focus.


ControlIsExitedandChanged-Inline

Last Modified: B733.2 | May 27, 1999

ControlIsExitedandChanged-Inline executes each time a control loses focus if the text in the control has changed since a previous execution of this event. It is not run if the data in the control being left does not pass Data Type validation. It can execute even when focus is going to the cancel button or to another dialog. Control is Exited and Changed - Inline executes after the Control is Exited event rule and before Control is Exited and Changed - Asynch event rule is put on the thread queue. This event is executed inline.

Available On

  • Find/Browse

  • Fix/Inspect

  • Header Detail

  • Headerless Detail

  • Search/Select

  • Parent/Child Browse

Available Objects

  • All objects are available.

  • Using the Form Control being left in event rule gets the current value of the cell unless it did not pass Data Type validation.

Typical Usage

  • May be used to run event rule logic, which is required to be completed before running any other process.

Additional Notes

The execution of the Control is Exited and Changed - Asynch event occurs even if this inline event sets errors.

Processing Sequence

  1. If the cell has not changed by typing or event rule since the last execution of this event, stop processing.

  2. Clear any errors that were set on this control during the Control is Exited and Changed - Inline event rule (from a previous call).

  3. Run the Control is Exited and Changed - Inline event rule


PostVisualAssistButtonClicked

Last Modified: B733.2 | May 27, 1999

PostVisualAssistButtonClicked is processed after the visual assist form is closed.

Available On

  • Any form type

Available Objects

  • Available on any control that has a visual assist

Typical Usage

  • Used to check and set values of variables that may have changed during the visual assist form processing.

Processing Sequence

  1. This event is processed after the VisualAssistButtonClicked event.


Text Clicked

Last Modified: B733.2 | May 27, 1999

Text Clicked handles the functionality for static text that is clickable.

Available On

This event is available on all form types.

Available Objects

All field objects are available for this event.

Typical Usage

This event is typically used to transverse to another from or web site.

Additional Notes

None

Processing Sequence

If the text clicked is clickable, then when the user clicks on the text, the Text Clicked Event will be processed.


VisualAssistButtonClicked

Last Modified: B733.2 | May 27, 1999

Visual Assist Button Clicked is processed right after a visual assist button is clicked. It is before runtime brings up the default visual assist form.

Available On

  • Any form

Available Objects

Available on any control that has a visual assist

Typical Usage

  • Perform initialization or validation before the visual assist form opens.

  • Suppress the default visual assist form and brings up an application-defined form using form interconnect.

Processing Sequence

  1. When a visual assist button is clicked, runtime executes this event before it opens the default visual assist form.

  2. After this event, runtime opens the default visual assist form if it is not suppressed.


Grid Control Events

Grid Control Events consist of the following:

 | AddGridRecordtoDB-After
app.gif (808 bytes) | AddGridRecordtoDB-Before
 | AddLastEntryRowtoGrid
app.gif (808 bytes) | AllGridRecsAddedtoDB
 | AllGridRecsDeletedfromDB
app.gif (808 bytes) | AllGridRecsUpdatedtoDB
 | DeleteGridRecfromDB-After
app.gif (808 bytes) | DeleteGridRecfromDB-Before
 | DeleteGridRecVerify-After
app.gif (808 bytes) | DeleteGridRecVerify-Before
 | DoubleClickRowHeader
app.gif (808 bytes) | Get Custom Grid Row
 | Grid Column Clicked
app.gif (808 bytes) | GridRecordIsFetched
 | KillFocusonGrid
app.gif (808 bytes) | RowIsEntered
app.gif (808 bytes) | RowisExited
 | RowisExitedandChanged-Asynch
app.gif (808 bytes) | RowisExitedandChanged-Inline
 | SetFocusonGrid


AddGridRecordtoDB-After

Last Modified: B733

Event Rules attached to AddGridRecordtoDB-After occur after a grid line has been added as a record to the database. Thus, the behaviors are not apparent on the current form and cannot affect the new record that has already been stored in the database.

Available On

  • Headerless/Detail

  • Header/Detail

Available Objects

  • All objects are available

Typical Usage

Use this event to send information from a newly added record to another file (using a Business Purpose).

Additional Notes

This event differs from the corresponding event, Update Grid Record to DB, because the attached behavior occurs only after the addition of a new record to the database.

Processing Sequence

  1. Perform database add.

  2. Run AddGridRecordtoDB - After.

  3. Begin Processing next row.

J.D. Edwards Standards

This event relates to grid records only. To work with form records, use the corresponding form events.


AddGridRecordtoDB-Before

Last Modified: B733

Event Rules attached to AddGridRecordtoDB-Before occur after you press OK to add a grid line record to the database, but before the record is actually added.

Available On

  • Headerless/Detail

  • Header/Detail

Available Objects

  • All objects are available.

Typical Usage

Use this when you want the behavior to affect the saved record. For example, use it to time-stamp a record entered from the grid into the database. If no records are to be added, use the SuppressAdd business function.

Additional Notes

This event differs from the corresponding event, UpdateGridRecordtoDB, because the attached behavior occurs relative to the addition of a new record to the database.

Processing Sequence

  • The BC’s are set up just as they are to be added to database.

  • Run AddGridRecordtoDB - Before.


AddLastEntryRowtoGrid

Last Modified: B733

AddLastEntryRowtoGrid adds an entry row at the bottom of an update grid. Rules attached to this event affect the newly added row.

Available On

  • Headerless/Detail

  • Header/Detail

Available Objects

  • All objects are available

  • Grid columns are for the newly added row

Typical Usage

Use this event to assign line numbers and default values for new lines in Add and Update modes.

Additional Notes

To use this event, you must be working with an update grid. See also Grid Properties.

Processing Sequence

A key is pressed in the entry row or an assignment is made into the entry row.

Run the Add Last Entry Row to Grid event rule.

Physically add the new entry row to the grid.


AllGridRecsAddedtoDB

Last Modified: B733

The Event Rules attached to AllGridRecsAddedtoDB occur after you add grid lines to the database. The behavior occurs after the records have been stored in the database. Thus, the behaviors are not apparent on the current screen and cannot manipulate the grid lines, since they have already been stored in the database.

Available On

  • Headerless/Detail

  • Header/Detail

Available Objects

  • All objects are available.

Typical Usage

Use this event to perform behaviors based on newly added records to the database.

Additional Notes

This event is run even if there is only one grid record being added to the database.

This event runs after the AddGridRecordtoDB-After has run on the last added line in the grid. This event will execute only if the form is in Add mode. If the form is in Add mode, the All Grid Recs Updated to DB event will never execute. The form mode determines which All Grid Recs event will fire.

Processing Sequence

  1. OK is pressed and all the grid records are added to the database.

  2. Run the All Grid Recs Added to DB event rule.


AllGridRecsDeletedFromDB

Last Modified: B733

The event rules attached to AllGridRecsDeletedFromDB occur after grid lines and the corresponding database records have been deleted. The rules attached to this event are not apparent on the current form and cannot manipulate the grid lines or involve the deleted records.

Available On

  • Find/Browse

  • Headerless/Detail

  • Header/Detail

  • Parent/Child Browse

Available Objects

  • All objects are available.

Typical Usage

Use this event to perform behaviors after deletion only.

Additional Notes

This event runs after DeleteGridRecfromDB-After runs on the last deleted line in the grid. This event runs even when only one grid record was selected for deletion.

Processing Sequence

For Find/Browse and Parent/Child Browse forms

  1. Delete all selected grid records. Delete Grid Rec Verify - Before, Delete Grid Rec Verify - After, Delete Grid Rec from DB - Before, and Delete Grid Rec from DB - After are run for each selected row.

  2. Run the All Grid Recs Deleted from DB event rule.

For Header/Detail and Headerless/Detail forms

  1. When OK is pressed delete from the database all records that have been deleted from the grid. Delete Grid Rec from DB - Before, and Delete Grid Rec from DB - After are run for each record that was deleted from the grid.

  2. Run the All Grid Recs Deleted from DB event rule.


AllGridRecsUpdatedtoDB

Last Modified: B733

The event rules attached to AllGridRecsUpdatedtoDB occur after you update multiple grid lines, overwriting existing database records. The behavior occurs after the updated records have been stored in the database. The behaviors are not apparent on the current form and cannot manipulate the grid lines, since they have already been stored in the database.

Available On

  • Headerless/Detail

  • Header Detail

Available Objects

  • All objects are available.

Typical Usage

Use this event to perform behaviors based on the updated records in the database.

Additional Notes

This event will execute even if only one grid record has been updated. This event will execute only if the form is in Update mode. If the form is in Update mode the All Grid Recs Added to DB event will not execute even if there were grid records added. In an update grid, it is possible to have some grid rows that need updated and some that need added. The form mode determines which All Grid Recs event will execute.

Processing Sequence

  1. This event runs after all of the grid rows have been processed on the OK button when the form is in update mode.


DeleteGridRecfromDB-After

Last Modified: B733

The event rules attached to DeleteGridRecfromDB-After occur during OK processing and after deletion from the database are complete. It does not occur if the delete was suppressed or the user did not confirm the delete

Available On

  • Find/Browse

  • Headerless/Detail

  • Header/Detail

  • Parent/Child Browse

Available Objects

  • All objects are available.

Typical Usage

This event can be used to delete related records from other tables (via business functions) once the deletion of the main record is complete.

  • Use this to delete information in other tables and to maintain referential integrity.

Additional Notes

This event occurs after the delete from the database is complete, so it cannot be used to affect the database record or the grid row.

It is important to note that this event occurs immediately after the Delete Verify events for Find/Browse and Parent/Child forms, but it does not occur until the OK processing for Header/Detail and Headerless/Detail forms.

Processing Sequence

  1. Delete the record from the database.

  2. Run the Delete Grid Rec from DB - After event rule.


DeleteGridRecfromDB-Before

Last Modified: B733

The event rules attached to DeleteGridRecfromDB-Before occur after you press OK to delete a database record and after the Verify window is processed, but before the record is deleted.

If you cancel out of the Verify window, the behavior attached to this event will not occur.

Available On

  • Find/Browse

  • Headerless/Detail

  • Header/Detail

  • Parent/Child Browse

Available Objects

  • All objects are available.

  • Business view columns contain the record to be deleted.

Typical Usage

Use this event to update a related record with information from the record about to be deleted, or to log the deletion. The record still exists in the database and the behavior attached to this event may use the record information, if needed.

Additional Notes

This event differs from the corresponding event, Delete Grid Rec Verify, because the attached behavior occurs relative to the deletion rather than the Verify window.

Processing Sequence

  1. This event runs after the verify events but before the database delete. It is the last opportunity to call the Suppress Delete system function.

J. D. Edwards Standards

This event relates to grid records only.


DeleteGridRecVerify-After

Last Modified: B733

The event rules attached to DeleteGridRecVerify-After after deletion is confirmed in the popup Verify window. If you cancel the Verify, the behavior attached to this event will not occur.

Available On

  • Find/Browse

  • Headerless/Detail

  • Header/Detail

  • Parent/Child Browse

Available Objects

  • All objects are available.

  • Grid columns contain the grid record to be deleted

Typical Usage

This event only runs if the user confirmed the delete, so it can be used for corresponding logic.

Additional Notes

This event differs from the corresponding Delete Grid Rec from DB event because the attached behavior occurs relative to the response entered on the Verify window rather the delete action.

Check for errors and suppress delete if needed.

Processing Sequence

  1. This event runs after the Delete Confirmation dialog closes if the user selected Yes.

J. D. Edwards Standards

This event relates to grid records only.


DeleteGridRecVerify-Before

Last Modified: B733

The event rules attached to DeleteGridRecVerify-Before occur after you press Delete for a selected grid record, but before the pop-up Verify window displays. Behaviors occur whether or not confirmation of the deletion is accepted or canceled in the Verify window.

Available On

  • Find/Browse

  • Headerless Detail

  • Header/Detail

  • Parent/Child

Available Objects

  • All objects are available.

  • Grid columns contain the grid record to be deleted

Typical Usage

This event typically provides an opportunity to suppress a delete before the confirmation dialog appears. If a suppress delete is requested in this event, the popup Verify window does not appear.

Additional Notes

This event differs from the corresponding DeleteGridRecordFromDB event because the attached behavior occurs relative to the appearance of the Verify window rather than the delete action

Processing Sequence

  1. This event runs for every grid line selected at the time of the Delete button clicked. It is the first opportunity to call the Suppress Delete system function.

J.D. Edwards Standards

This event relates to grid records only.


DoubleClickRowHeader

Last Modified: B733

For DoubleClickRowHeader to be active, the row header must have been defined through grid properties in FDA. DoubleClickRowHeader is executed upon double clicking the row header.

Available On

  • Search and Select

  • Find/Browse

  • Header/Detail

  • Headerless/Detail

Available Objects

  • All objects are available.

Typical Usage

This event is often used to exit to an attachments screen or to display media objects

Additional Notes

Double clicking on the row header causes this event to execute. Double clicking on the row causes a Press Button of the Select, if there is one, to execute.

Processing Sequence

This event will occur after Set Focus on Grid if focus was not on the grid prior to the double click.

If focus was on the grid, but not on the row that was double clicked

  1. The cell that had focus will first execute the Leave Column events.

  2. The row will execute the Leave Row events.

  3. The double click will be processed.

If focus was on the grid row being double clicked

  1. The Leave Column events will be processed for the cell loosing focus.

  2. The double click will be processed.


Get Custom Grid Row

Last Modified: B733

Get Custom Grid Row executes when additional grid records are required in the grid. This event will execute when the Find button is clicked (first page of data is required), when the user scrolls down on the grid, and when the grid is resized. Get Custom Grid Row is used to allow a page at a time in custom filled grids. The event will continue to execute until a page of rows has been added or until the Continue Custom Fetch system function is not called. After the event has executed 1000 times without a grid row being added, a message will be written to the jde.log, but the event does not stop. This is a potential endless loop if the system function and event are not used properly.

Available On

  • Find Browse

  • Headerless Detail

  • Header Detail

  • Search Select

Available Objects

  • All field types are allowed.

Typical Usage

This event is used for grids that are marked as No Fetch On Grid Business View. Typically, this event is used to insert a single custom grid row. The Find button ER will Open and Select from the tables/caches and the ER on Get Custom Grid Row will Fetch and insert a single row. After the row is inserted, the Continue Custom Fetch system function will be called. If there are no more rows to insert, the tables/caches will be closed and the system function is not called.

Additional Notes

It is possible for the form/fetch to terminate without retrieving all the records. Assume there is more than a single page of data. The user presses find, and the first page is fetched. The user then closes the form. In this situation, the table/cache was opened in the Find ER, but unless the table/cache is closed in End Dialog, it will remain open. Similarly, when the user presses find, the first page is fetched, but then the user changes the criteria and does another find. The table/cache was opened in the Find ER, but unless the table/cache is closed before the next find, it will still be open.

Processing Sequence

If the Find button is pressed

  1. Find button ER

  2. Delete all existing grid rows

  3. Count number of existing grid rows

  4. Do

  5. Clear the Continue Custom Fetch system function flag

  6. Get Custom Grid Row ER

  7. Compare total number of grid rows to former to see if any were added

  8. While more rows are required to have a page and the Continue Custom Fetch system function flag is set

When more pages are required after the first page

  • Count number of existing grid rows

  • Do

  • Clear the Continue Custom Fetch system function flag

  • Get Custom Grid Row ER

  • Compare total number of grid rows to former to see if any were added

  • While more rows are required to have a page and the Continue Custom Fetch system function flag is set


Grid Column Clicked

Last Modified: B733

Grid Column Clicked has been added to handle clickable grid columns.

Available On

  • Available on all for types.

Available Objects

  • All field types are available.

Typical Usage

This event is used traverse to another form or web site.

Processing Sequence

The engine will first check whether a particular grid column being selected is designated to be clickable. If it is, then the Grid Column Clicked event will be processed.


GridRecordIsFetched

Last Modified: B733

GridRecordIsFetched is run each time that the interactive engine fetches a grid record from the database over the business view.

Available On

  • Any form that has a grid.

Available Objects

  • All objects are available

  • Business view columns contain the record just fetched from the database

  • Grid columns do not yet contain the fetched record


KillFocusonGrid

Last Modified: B733

KillFocusonGrid is executed when the grid control looses focus.

Available On

  • Find/Browse

  • Header Detail

  • Headerless Detail

  • Search/Select

  • Parent/Child Browse

Available Objects

  • All objects are available.

Processing Sequence

If a cell had focus, the Leave Column events will execute then the Leave Row events will execute.

Run the Kill Focus on Grid event rule.


RowIsEntered

Last Modified: EnterpriseOne | July 10, 2000

Event Rules attached to the grid occur when the focus is placed on the grid row.

Available On

Headerless/Detail

Header/Detail

Find/Browse

Search/Select

Available Objects

All Objects are available.

Typical Usage

This event is normally used to validate the data before any row events are to be processed.


RowisExited

Last Modified: B733

RowisExited executes each time a grid row looses focus. It is run regardless of changes to the row. This event is executed inline.

Available On

  • Find/Browse

  • Header/Detail

  • Headerless/Detail

  • Search/Select

Available Objects

  • All objects are available.

  • Grid Columns contain the data of the row being left.

Typical Usage

This event is often used to apply conditional defaults to the row being left.

Processing Sequence

  1. If the row was exited, but not the column, send a message to execute the Column is Exited events.

  2. Clear any errors that were set on this row during the Row is Exited event rule (from a previous call).

  3. Run the Row is Exited event rule.


RowisExitedandChanged-Asynch

Last Modified: EnterpriseOne | May 07, 2000

RowisExitedandChanged-Asynch can execute each time a grid row looses focus. It is put on the thread queue immediately after the Row is Exited and Changed-Inline event rule is run. This event is executed anachronously.

For Full Process Grids (in grid properties, Process All Rows in Grid is marked), the event rule on Row is Exited and Changed-Asynch will execute when:

  • Focus is moved to another row or to another control

  • Okay is pressed, and one of the following is true:

    • Event rule has not yet been run for the row

    • A change has occurred on the row since a previous execution of this event

Note: These same rules apply to any row written to a grid, by means of a system function, with the “Updateable” flag as ‘YES’. If the “Updateable” flag is ‘NO’, then the Row is Exited event rule will never be run for that row.

For Read C Grids (in grid properties, Process All Rows in Grid is not marked), the event rule on Row is Exited and Changed - Asynch will execute when:

    • A change has occurred to the grid row since a previous execution of this event and focus is moved to another row or to another control

    • The OK button is clicked, event rule has not yet been run for the row, and the row was written to the grid, by means of a system function, with the “Updateable” flag as yes.

Available On

  • Header Detail

  • Headerless Detail

Available Objects

  • All objects are available.

  • Grid Columns contain the data of the row being left.

Typical Usage

May be used to run sizable amount of event rule logic, and business functions. This event should not depend on another RowIsExitedandChanged-Asynch event because you cannot define the order in which the same two events are processed.

Additional Notes

This event must complete before the form can be closed.

Processing Sequence

For Full Process Grids and Read C Grids:

  1. If the cell has not changed by typing or event rule since the last execution of this event, skip to the last step in this section.

  2. Clear any errors that were set on this row during the Row is Exited and Changed - Asynch event rule (from a previous call).

  3. Run the Row is Exited and Changed - Asynch event rule.

  4. Clear the flag so that this event is not run again until there is another change in the row.

For All Grid Cells:

  1. Check to see if the data has already been set in error during validation, if it has then stop processing for this cell

  2. Check to see if the data completed validation through data changed processing, if it has then stop processing for this cell

  3. Load the default value if the cell is empty

  4. Check to see if the data is a required entry field, if it is, and it’s empty, set the field in error.

  5. Perform Data Dictionary validation on the data in the cell


RowisExitedandChanged-Inline

Last Modified: EnterpriseOne | May 07, 2000

RowisExitedandChanged-Inline can execute each time a grid row looses focus. It will execute just before the Row is Exited and Changed - Asynch is . This event is executed inline.

For Full Process Grids (in grid properties, Process All Rows in Grid is marked), the event rule on Row is Exited and Changed - Inline will execute when:

  • Focus is moved to another row or to another control

  • Okay is pressed, and one of the following is true:

    1. Event rule has not yet been run for the row

    2. A change has occurred on the row since a previous execution of this event

Note: These same rules apply to any row written to the grid via a system function with the “Updateable” flag as ‘YES’. If the “Updateable” flag is ‘NO’, then the Row is Exited and Changed - Inline event rule will never be run for that row.

For Read C Grids (in grid properties, Process All Rows in Grid is not marked), the event rule on Row is Exited and Changed - Asynch will execute when:

  • A change has occurred to the grid row since a previous execution of this event and focus is moved to another row or to another control

  • Okay is pressed, event rule has not yet been run for the row, and the row was written to the grid via a system function with the “Updateable” flag as yes.

Available On

  • Header Detail

  • Headerless Detail

Available Objects

  • All objects are available.

  • Grid Columns contain the data of the row being left.

Typical Usage

This event is used for processing that must complete before another row can be entered.

Processing Sequence

For Full Process Grids and Read C Grids:

  1. If the cell has not changed by typing or event rule since the last execution of this event, stop processing

  2. Clear any errors that were set on this row during the Row is Exited and Changed - Inline event rule (from a previous call).

  3. Run the Row is Exited and Changed - Inline event rule.

  4. Clear the flag so that this event is not run again until there is another change in the row.


SetFocusonGrid

Last Modified: B733

SetFocusonGrid executes each time focus is moved from any control or any other dialog to the grid. It is important to note that this event will execute when switching between applications with the focus on the grid.

Available On

  • Find/Browse

  • Header Detail

  • Headerless Detail

  • Search/Select

Available Objects

  • All objects are available. All event rules referring to Grid Columns will be performed with the data of, and on, the last line of the grid.

Typical Usage

Replace this text with a description of how the Event is typically used.

Processing Sequence

  1. Run the Set Focus on Grid event rule.


Hyperitem Control Events

Hyperitem Control Events consist of the following:

 | ButtonClicked
app.gif (808 bytes) | PostButtonClicked


Parent Child Control Events

Parent Child Control Events consist of the following:

 | AllGridRecsDeletedFromDB
app.gif (808 bytes) | DeleteGridRecFromDB-After
 | DeleteGridRecFromDB-Before
app.gif (808 bytes) | DeleteGridRecVerify-After
 | DeleteGridRecVerify-Before
app.gif (808 bytes) | DoubleClickOnRowHeader
 | GetCustomTreeNode
app.gif (808 bytes) | KillFocusOnControl
 | NodeisCollapsing
app.gif (808 bytes) | Nodeisexpanding
 | SetFocusOnControl
app.gif (808 bytes) | Tree-BeginDragOperation
 | Tree-CancelDragDrop
app.gif (808 bytes) | Tree-DragOverNode
 | Tree-EndDragDropOperation
app.gif (808 bytes) | TreeNodeIsDeleted
 | TreeNodeLevelChanged
app.gif (808 bytes) | TreeNodeSelectionChanged


Parent/Child AllGridRecsDeletedFromDB

AllGridRecsDeletedFromDB

Last Modified: EnterpriseOne | May 09, 1999

Please refer to the “AllGridRecsDeletedFromDB ” event under the grid category


Parent/Child DeleteGridRecFromDB-After

DeleteGridRecFromDB-After

Last Modified: EnterpriseOne | May 09, 1999

Please refer to the “DeleteGridRec F romDB-After ” event under the grid category.


Parent/Child DeleteGridRecFromDB-Before

DeleteGridRecFromDB-Before

Last Modified: EnterpriseOne | May 09, 1999

Please refer to the “DeleteGridRecfromDB-Before ” event under the grid category.


Parent/Child DeleteGridRecVerify-After

DeleteGridRecVerify-After

Last Modified: EnterpriseOne | May 09, 1999

Please refer to the “DeleteGridRecVerify-After ” event under the grid category.


DeleteGridRecVerify-Before

Last Modified: EnterpriseOne | May 09, 1999

Please refer to the “DeleteGridRecVerify-Before ” event under the grid category.


Parent/Child DoubleClickOnRowHeader

DoubleClickOnRowHeader

Last Modified: EnterpriseOne | May 09, 1999

Please refer to the “DoubleClickRowHeader ” event under the grid category.


GetCustomTreeNode

Last Modified: EnterpriseOne | May 09, 1999

GetCustomTreeNode executes when the Parent/Child form or the tree control needs more data to fill the tree. It is used for implementing page-at-a-time processing by the applications where the tree has to be loaded through system functions and event rules.

Available On

  • Parent/Child Forms and Tree Controls.

Available Objects

  • All form objects are available.

Typical Usage

This event can be used to implement page-at-a-time processing for custom fetched trees or parent/child forms. On this event, the application can use Table I/O to fetch data and use system functions to insert the fetched data into the tree. This event will be executed when the tree needs more data; the user either has clicked the Find button or has scrolled the tree to the bottom.

Additional Notes

There is a similar event for the forms with grids: "Get Custom Grid Row". The only difference is that "Get Custom Tree Node" is used for Parent/Child forms and Tree Controls; however, the "Get Custom Grid Row" event is used for Grids.


Parent/Child KillFocusOnControl

KillFocusOnControl

Last Modified: B733

KillFocusOnControl executes when the parent child control loses the focus.

Available On

  • Parent Child forms

Available Objects

  • All objects are available.


Parent/Child NodeisCollapsing

NodeisCollapsing

Last Modified: B733.1 | June 08, 1999

NodeisCollapsing executes when the user double-clicks on an open node or single clicks the “minus” sign of a node.

Available On

  • Parent/Child Forms

Available Objects

  • All objects are available.

  • Grid Columns contain the data of the row that shows the detail of the node that is collapsing.

Typical Usage

The bitmap for the collapsing node can also changed be calling “Set Tree Node Bitmap” with “Current Node” value for the “Node” parameter.

Additional Notes

This event is executed every time a node is collapsed.

The grid rows always reflect items that are relative to the current parent node in the tree, therefore, after the collapse of a node, the Grid is refreshed with items from the parent of the current node that is being collapsed. The selected row reflects the current node in the tree. The bitmap for the node is also changed to a default closed bitmap only if it is not overridden through the “Set Tree Node Bitmap” system function.


Parent/Child NodeisExpanding

NodeisExpanding

Last Modified: B733.1 | June 08, 1999

NodeisExpanding executes when the user double clicks on a node or single clicks on the “plus” sign of a node.

Available On

  • Parent/Child Forms

Available Objects

  • All objects are available.

  • Grid Columns contain the data of the row that shows the detail of the node that is being expanded.

Typical Usage

The Application developer can use this event to add custom items under the presently expanding node. This can be achieved by first calling the system function “Suppress Fetch on Node Expand” and then adding items by calling “Insert Grid Buffer Row”. The bitmap for the expanding node can also changed by calling “Set Tree Node Bitmap” with “Current Node” value for the “Node” parameter.

Additional Notes

This event is executed only once for each node that is expanded. If the expanding node has children, the tree node bitmap is changed to open bitmap; otherwise, the bitmap is changed to a "leaf" bitmap. Applications can use SetTreeNodeBitmap system functions to override the open or leaf bitmap.


Parent/Child SetFocusOnControl

SetFocusOnControl

Last Modified: B733

SetFocusOnControl executes when the parent child control receives the focus.

Available On

  • Parent Child Form types.

Available Objects

  • All objects are available.


Parent/Child Tree-BeginDragOperation

Tree-BeginDragOperation

Last Modified: B733

Tree-BeginDragOperation executes when the user starts dragging a node in the tree. This event is only executed if the application developer has the drag and drop feature enabled.

Available On

  • Parent Child Forms.

Available Objects

  • All objects are available.

  • Grid Columns contain the data of the row that shows the detail of the node that is being dragged.

Typical Usage

Use this event to save the grid column values of the node (and row) that is being dragged into either grid buffers or variables so that they can be used when the user has finished the drag and drop operation. The reason for saving off the grid column values is that when the user has dropped the node, the grid column values change to that of the node on which the dragged node has been dropped. The grid column values of the node that was dragged are replaced.

Additional Notes

The grid columns are also updated during the dragging process, when the user passes over a node in the tree. The node over which the user is moving gets highlighted and the grid columns now contain data for this node.


Parent/Child Tree-CancelDragDrop

Tree-CancelDragDrop

Last Modified: B733

Tree-CancelDragDrop executes if the user drops (or releases) the dragged node when it is not on a valid node or outside the tree. This event is also executed if the user chooses the Cancel button from the popup menu that appears when the user uses the right mouse button during a mouse drag and drop operation.

Available On

  • Parent Child Forms.

Available Objects

  • All objects are available.

  • Grid Columns contain the data of the row that shows the detail of the node that was initially dragged.

Typical Usage

The developer can use this event to undo steps they may have taken during the “Tree-BeginDragOperation”.


Parent/Child Tree-DragOverNode

Tree-DragOverNode

Last Modified: B733

Tree-DragOverNode executes when the user is in the process of dragging a node and is right above a node in the tree control. This node gets highlighted and the grid columns are updated with the values corresponding to this node. This event is only executed if the application developer has the drag and drop featured enabled.

Available On

  • Parent Child Forms.

Available Objects

  • All objects are available.

  • Grid Columns contain the data of the row that contains the detail of the node over which the dragged node is passing.

Typical Usage

During this event, the application developer can inspect the grid column values and update the cursor to indicate if the user can or cannot drop the dragged node under the current node. Refer to the system function Set Drag Cursor for details on how to change the cursor.


Parent/Child Tree-EndDragDropOperation

Tree-EndDragDropOperation

Last Modified: B733

Tree-EndDragDropOperation executes when the user has dropped the node that was being dragged. This event is only executed if the application developer has the drag and drop featured enabled.

Available On

  • Parent Child Forms.

Available Objects

  • All objects are available.

  • Grid Columns contain the data of the row that shows the detail of the node on which the dragged node has been dropped.

Typical Usage

During this event, the application developer can update the tables to reflect the new structure of the tree using either business functions or Table IO. They can add a new record under the new parent and delete the record from the old parent if the operation was a MOVE rather than a COPY. To delete the dragged node from the tree, the developer can use the DeleteGridRow system function. To insert a node, the developer can use the InsertGridBufferRow system function.

Additional Notes

This event is not executed if the cursor has been set to NO DROP during the drag over event. Instead, a Cancel Drag Drop event is executed.

Processing Sequence

  • If users make use of the left mouse button for the drag and drop operation, then this event is executed immediately after they release the left mouse button.

  • If users make use of the right mouse button for the drag and drop operation, then a pop up menu comes up when they release the right mouse button. This popup menu has the following options:

Move Here: This specifies that the user wants to move the dragged node. If the user selects this option then the Tree-EndDragDropOperation event will be executed.

Copy Here: This specifies that the user wants to copy the dragged node. If the user selects this option then the Tree-EndDragDropOperation event will be executed.

Within this event, the application developer can check the system variable SV Drag_Mode to check if the operation was a COPY or a MOVE.


TreeNodeIsDeleted

Last Modified: B733.1 | March 09, 1999

TreeNodeIsDeleted executes when a tree node is deleted.

Available On

  • Parent/Child Forms and Tree Controls.

Available Objects

  • All form objects are available in this event.

Typical Usage

This event is executed when a tree node is deleted. It is used for the applications to clean up user data or table handles associated with the deleted node.

Additional Notes

When the user clicks the Find button or closes the form, the current tree is deleted. In this case, the event is executed for all the tree nodes.


TreeNodeLevelChanged

Last Modified: B733

TreeNodeLevelChanged executes when the user changes the selection of a tree node and the currently selected node is at a different level than that of the previously selected node. A typical example is, when the user moves from a parent level node to its child level node or vice versa.

Available On

  • Parent Child Forms.

Available Objects

  • All objects are available.

Typical Usage

This event could be used in a parent/child control with the grid side open to hide/show columns based on the current level of the tree node.

Additional Notes

This event is not executed if the tree node selection moves within the same level in the tree. If processing has to be for such cases, TreeNodeSelectionChanged event should be used.

Processing Sequence

  1. This event does not prohibit the execution of TreeNodeSelectionChanged. In fact, TreeNodeLevelChanged is always executed before TreeNodeSelectionChanged incase both the events occur.


TreeNodeSelectionChanged

Last Modified: B733

TreeNodeSelectionChanged executes when the user changes the selection of a tree node through either the mouse or the keyboard.

Available On

  • Parent Child Forms.

Available Objects

  • All objects are available.

Additional Notes

The TreeNodeLevelChanged event will be executed along with TreeNodeSelectionChanged event if the selection moves to a different level in the tree.


Form Interactive Application Events

Form Events

Form Events consist of the following:

 | AddRecordtoDB-After
app.gif (808 bytes) | AddRecordtoDB-Before
 | ClearScreenAfterAdded
app.gif (808 bytes) | ClearScreenBeforeAdd
 | DialogisInitialized
app.gif (808 bytes) | EndDialog
 | LastGridRecordHasBeenRead
app.gif (808 bytes) | PostDialogisInitialized
 | UpdateRecordtoDB-After
app.gif (808 bytes) | UpdateRecordtoDB-Before
 | WriteGridLine-After
app.gif (808 bytes) | WriteGridLine-Before


AddRecordtoDB-After

Last Modified: B733

Event Rules attached to AddRecordtoDB-After occur after a form record has been added to the database. Any changes made to form controls or business view columns at this event point DO NOT get updated to the database.

Available On

  • Fix/Inspect Form

  • Header Detail Form

  • Headerless Detail Form

Available Objects

  • All objects are available.

Typical Usage

Use this event for processing after a record has been added to the database (For example, Display Total Amounts, Update Balance Files, PO History, Address Book Audit Information, and so forth).

Additional Notes

This event is only executed when adding a new record to the database. It is not executed during Update mode.

Processing Sequence

This event is run just after the add to the database has completed. It will not run if the database returns errors on the add.


AddRecordtoDB-Before

Last Modified: B733

Event Rules attached to AddRecordtoDB-Before occur after you press OK to add a form record to the database, but before the record is actually added to the database. For a Header Detail form, this event pertains to the header record, not the grid records.

Available On

  • Fix/Inspect

  • Header/Detail

  • Available Objects

  • All objects are available.

Typical Usage

Use this event when you want the behavior to affect the saved record. It is also a typical place to call the Suppress Add system function to stop the record from being saved.

Additional Notes

This event is only executed when adding a new record to the database. It is not executed during Update mode.

Processing Sequence

On the OK button in Add mode, if the SuppressAdd function has not been called, this event is run before the add takes place.


ClearScreenAfterAdded

Last Modified: B733

ClearScreenAfterAdded runs after the form has been cleared after an add has occurred. It differs from the ClearScreenBeforeAdd event because it is not run during the initial clear on entering the form.

Available On

  • Fix/Inspect

  • Header Detail

  • Headerless Detail

Available Objects

  • All objects are available.

Processing Sequence

  1. Complete the addition of a database records

  2. Clear all form items.

  3. Run the ClearScreenBeforeAdd event

  4. Run the PostDialogisInitialized event

  5. Run the ClearScreenAfterAdded event


ClearScreenBeforeAdd

Last Modified: B733.1 | June 08, 1999

ClearScreenBeforeAdd runs any time a form is cleared before an add. This may occur if the form is entered in add mode, or if the fetch in update mode fails and the mode switches to add. The event runs after the form controls and business view columns are cleared or changed to the default value.

Available On

  • Fix/Inspect

  • Headerless/Detail

  • Header/Detail

Available Objects

  • All objects are available.

Typical Usage

This event loads default values (other than data dictionary defaults) such as Branch/Plant, Company, and Company Currency.

Additional Notes

Controls flagged as Do Not Clear After Add are not cleared when this logic is performed. This event is also executed when an update/select is requested and the fetch fails.

Processing Sequence

As the form is opening:

  1. Clear all form items

  2. Run the ClearScreenBeforeAdd event

  3. Run the PostDialogisInitialized event

As OK is clicked:

  1. Complete the addition of a database records

  2. Clear all form items

  3. Run the ClearScreenBeforeAdd event

  4. Run the PostDialogisInitialized event

  5. Run the ClearScreenAfterAdded event

J.D. Edwards Standards

Errors issued at this event point cannot be removed at a later stage, forcing the user to exit the form using either the Exit or Cancel button.


DialogisInitialized

Last Modified: B733.1 | June 08, 1999

DialogisInitialized executes each time a form is entered. It executes prior to the form being displayed on the screen.

Available On

  • All form types

Available Objects

  • All objects are available. Form interconnects have been loaded into corresponding business view columns and filter fields, if necessary.

Typical Usage

This event is often used for hiding and showing appropriate to interconnect values or processing options.

Processing Sequence

  1. Memory space is allocated for each data element in the Business View (the header’s Business View, if a Header Detail form). If this form has been called previously, the allocated memory has been stored in the cache and will be reused.

  2. Memory space is allocated for each control on the form. If the control is in the Business View, the control and the Business View will share memory space.

  3. If there is a grid on this form, grid information is initialized.

    1. If this is a Header Detail form, memory space is allocated for each data element in the Business View for the grid. This information is cached, if possible.

    2. Memory space is allocated for each column in the grid. This information is cached, if possible.

  4. Set the text on static fields and buttons. Button security is applied at this time.

  5. Set up the form level and control level helps for this form.

  6. Set up all the ER for this form. ER is not run at this point, but all preliminary validation occurs here, and TAM files are read, if necessary.

  7. Initialize controls to their empty or default values.

  8. Create the hypercontrol (Menu bar, toolbar, and button). Apply button security to hypercontrols.

  9. Assign the Form Interconnect (FI) values to Business View (BC) values.

  10. Run the Dialog is Initialized ER.


EndDialog

Last Modified: B733

DialogisInitialized is the reverse of the DialogisInitialized event and is always run just before a form is closed.

Available On

  • All form types.

Available Objects

  • All objects are available.

Typical Usage

Use this event to free memory allocated during entry in the form.

Additional Notes

This event is run before business view columns are copied to their corresponding form interconnections, so changes should therefore be made to the business view columns where there is automatic copying to propagate correctly.

Processing Sequence

  1. This event runs.

  2. Business view columns are copied to form interconnects.

  3. The form closes.


LastGridRecordHasBeenRead

Last Modified: B733

Event rules attached to LastGridRecordHasBeenRead occur after all grid records have been read into the grid.

Available On

  • Find/Browse

  • Header Detail

  • Headerless Detail

  • Search/Select

Available Objects

  • All objects are available.

Typical Usage

Use this event to write total lines to the grid or display totals on the form level based on grid data. On Header/Detail forms, retrieve the last line number used in a transaction to allow addition of new lines.

Additional Notes

Errors issued at this event point cannot be removed at a later stage, forcing the user to exit the form using either the Exit or Cancel buttons. This event is processed even if no matching records are found.

Processing Sequence

  1. Fetch matching records into grid until fetch fails.

  2. Run this event. If records were fetched, previous event would be last WriteGridLine-After


PostDialogisInitialized

Last Modified: B733.2 | June 08, 1999

PostDialogisInitialized executes after the Dialog is Initialized event. The processing sequence is dependent upon the form options and the mode of the form. This event is executed inline.

Available On

  • Find/Browse

  • Fix/Inspect

  • Header Detail

  • Headerless Detail

  • Search/Select

  • Parent/Child Browse

Available Objects

  • All objects are available.

  • Business view columns contain the record fetched, if any. In Copy Mode or Add Mode, the form interconnections have already been updated.

Typical Usage

To calculate the gross amounts, or modify the database fields before display on the form

Additional Notes

The sequencing of this event depends upon the mode and form options. When this event executes, a form record may or may not have been fetched by the interactive runtime engine. In some cases, it is important to know if a record has been fetched. If this information is required, the system function WasFormRecordFetched can be called.

Processing Sequence

  • For forms entered in Update Mode when the form option "No Fetch On Form Business View" is cleared:

    1. Run the DialogisInitialized event.

    2. Fetch the record from database (this is the header record for transact forms).

    3. Run the PostDialogisInitialized event.

  • For forms entered in Update Mode when the codegen option ‘No Fetch On Form Business View is selected:

    1. Run the DialogisInitialized event.

    2. Run the PostDialogisInitialized event.

  • For forms entered in Copy Mode when the codegen option ‘No Fetch on Form Business View’ is cleared:

    1. Run the DialogisInitialized event.

    2. Fetch the record to be copied from the database (this is the header record for transact forms).

    3. If this is a transact form fetch the detail records (includes running grid record is fetched, etc).

    4. Clear the key fields.

    5. Run the ClearScreenBeforeAdd event.

    6. Run the PostDialogisInitialized event.

  • For forms entered in Copy Mode when the codegen option "No Fetch on Form Business View" is selected:

    1. Run the DialogisInitialized event.

    2. Clear the key fields.

    3. Run the ClearScreenBeforeAdd event.

    4. Run the PostDialogisInitialized event.

  • For forms entered in Add Mode when the codegen option "No Fetch On Form Business View" is selected:

    1. Run the DialogisInitialized event.

    2. Clear the fields

    3. Run the ClearScreenBeforeAdd event.

    4. Run the PostDialogisInitialized event.


UpdateRecordtoDB-After

Last Modified: B733.2 | May 07, 1999

Event Rules attached to UpdateRecordtoDB-After occur after a record has been updated to the database. Any changes made to form controls or business view columns at this event point DO NOT get updated to the database. This is a form level event so grid columns contain the values of the current row.

Available On

  • Fix/Inspect form and grid

  • Header Detail form and grid

  • Headerless Detail grid

Available Objects

  • All objects are available.

Typical Usage

Use this event to perform processing after the record has been updated to the database, for example, Update Balance Files, PO History, or Address Book Audit Information.

Additional Notes

This event is only executed when updating an existing record to the database. It is not executed during Add mode. It applies to form records only.

Processing Sequence

This event runs as soon as the database update is complete as long as the database does not return in error.


UpdateRecordtoDB-Before

Last Modified: B733.2 | May 07, 1999

Event rules attached to UpdateRecordtoDB-Before occur after you click OK to update a record that already exists in the database, but before the record is updated. For a Header/Detail form this event applies to the header and should not be confused with the grid event of a similar name.

Available On

  • Fix/Inspect form and grid

  • Header Detail form and grid

  • Headerless Detail grid

Available Objects

  • All objects are available.

  • Business view columns contain the record about to be updated. The business view columns should be used to alter the record about to be updated.

Typical Usage

Use this event to adjust values being saved to the database, to keep track of totals being saved, or suppress the update all together.

Additional Notes

This event is only executed when updating a record in the database. It is not executed during Add mode. This event updates form records only.

Processing Sequence

After all fields have been validated on OK processing in update mode, this event will run as long as the Suppress Update system function has not been called previously.


WriteGridLine-After

Last Modified: B733.1 | June 08, 1999

WriteGridLine-After runs after a record retrieved from the database has been written out to the grid.

Available On

  • Find/Browse

  • Headerless Detail

  • Header/Detail

  • Search/Select

  • Parent/Child Browse

Available Objects

  • All objects are available.

Typical Usage

This event might be used for totaling or modifying grid column values. It can also be used to hide columns or change grid row attributes.

Processing Sequence

  1. Run the WriteGridLine-Before event.

  2. Run the AddFetchedRecordToGrid event.

  3. Run the WriteGridLine-After event.

Additional Notes

Any changes to GC values during this event will result in an update to the database when OK is clicked.


WriteGridLine-Before

Last Modified: B733.1 | June 08, 1999

WriteGridLine-Before executes for each grid line that is retrieved from the database after the grid column fields have been loaded with business columns but before the grid row has been written.

Available On

  • Search and Select

  • Find/Browse

  • Headerless/Detail

  • Header/Detail

  • Parent/Child Browse

Available Objects

  • All objects are available.

Typical Usage

  • Write custom grid lines.

  • Grid column manipulation (for example, Location formatting, Item Number formatting, and so forth).

  • ny processing that needs to be performed with the grid column values should be performed here, such as business functions that fetch additional information, change presentation of information (Item Number), and so forth. If memory is allocated on a grid level (GENLNG), then this memory needs to be freed on the grid level as well.

  • Defining colors and fonts for the grid.

Additional Notes

Errors issued at this event point cannot be removed at a later stage, forcing the user to exit the form using either the Exit or Cancel buttons.

Any changes to GC values during this event will not result in an update to the database when OK is clicked.


Tab Control

Tab Events

Tab Events consist of the following:

 | TabPageIsInitialized
app.gif (808 bytes) | TabPageIsSelected


TabPageIsInitialized

Last Modified: B733.2 | May 07, 1999

TabPageIsInitialized processes when a page is activated in the tab control for the first time.

Available On

  • Each Page of the Tab Control

Available Objects

  • All Objects are available.

Typical Usage

This event can be used to perform one time initialization for any tab page.

Additional Notes

This event is executed only once for each page, whereas the TabPageIsSelected event is processed each time a page is activated.


TabPageIsSelected

Last Modified: B733.2 | May 07, 1999

TabPageIsSelected processes each time a page is activated in the tab control.

Available On

  • Each Page of the Tab Control

Available Objects

  • All Objects are available.

Additional Notes

This event is executed each time a page is activated, whereas the TabPageIsInitialized event is processed only once for each page.

Processing Sequence

The first time a tab page is activated, this event is always executed after the TabPageIsInitialized event.


Table Conversion Events

Table Conversion Events consist of the following:

 | DataChanged
app.gif (808 bytes) | FormatFetched
 | ProcessBegin
app.gif (808 bytes) | ProcessEnd
 | RowFetched
app.gif (808 bytes) | SetSelectionAppendFlag
 | SetUserSelection


Table Events

Table Events consist of the following:

 | AfterRecordIsDeleted
app.gif (808 bytes) | AfterRecordIsFetched
 | AfterRecordIsInserted
 | AfterRecordIsUpdated
 | BeforeRecordIsDeleted
 | BeforeRecordIsFetched
 | BeforeRecordIsInserted
 | BeforeRecordIsUpdated
 | CurrencyConversionIsOn


jdeFgetcConvert

Last Modified: ERP 9.0 | June 2, 2003

JdeFgetcConvert - Reads a character from the flat file and returns the character in JCHAR format. This function is used by business functions that reference LPBHVRCOM. The LPBHVRCOM contains information to query the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by the Unicode Flat File Encoding Configuration program (P93081).

Syntax

JDERTN(int) JDEWINAPI jdeFgetcConvert(LPBHVRCOM lpBhvrCom, FILE *stream);

Parameters

Parameter | Notes | Usage
lpBhvrCom | ERP behavior communication structure |
stream | File pointer |

Return Value

A JCHAR character or EOF to indicate error or end of file.

Example

JDEBFRTN(ID) JDEBFWINAPI someBusinessFunction(LPBHVRCOM lpBhvrCom,

LPVOID lpVoid, LPDSD12345678 lpDS)

{

FILE *stream;

JCHAR buffer[81];

Int ch, i;

/* open the flat file for read */

stream = jdeFopen(_J(“in_file.txt”), _J(“r”));

if (stream == NULL)

return ER_ERROR;

/* read in first 80 characters and place them in the JCHAR buffer */

i = 0;

ch = jdeFgetcConvert(lpBhvrCom , stream);

while ( ch != EOF && i < 80) {

*(buffer+i) = (JCHAR)ch; /* cast to JCHAR since jdeFgetcConvert return int */

ch = jdeFgetcConvertV1(lpBhvrCom, stream);

if (ch != EOF)

i++;

}

/* \0 terminate the buffer */

*(buffer+i) = 0;

jdeFclose(stream);

}

Additional Notes

None

See Also

· jdeFgetcConvertV1, jdeFgetcConvertV2


jdeFgetcConvertV1

Last Modified: ERP 9.0 | June 2, 2003

jdeFgetcConvertV1 - Reads a character from the flat file in the specified encoding and returns the character in JCHAR format. This function is used when the flat file encoding is known and there is no need to query the Unicode Flat File Encoding Configuration table (F93081).

Syntax

JDERTN(int) JDEWINAPI jdeFgetcConvertV1(JCHAR *pEncoding, FILE *stream);

Parameters

Parameter | Notes | Usage
pEncoding | Encoding name for data in the file | All ICU supported encodings. For example, cp1252
stream | File pointer |

Return Value

A JCHAR character or EOF to indicate error or end of file.

Example

#include <jde.h>

int someSystemFunction()

{

FILE *stream;

JCHAR buffer[81];

Int ch, i;

/* open the flat file for read */

stream = jdeFopen(_J(“in_file.txt”), _J(“r”));

if (stream == NULL)

return -1;

/* read in first 80 characters and place them in the JCHAR buffer */

i = 0;

ch = jdeFgetcConvertV1(_J(“cp1252”) , stream); /* flat file is in cp1252 encoding*/

while ( ch != EOF && i < 80) {

*(buffer+i) = (JCHAR)ch; /* cast to JCHAR since jdeFgetcConvert return int */

ch = jdeFgetcConvertV1((_J(“cp1252”), stream);

if (ch != EOF)

i++;

}

/* \0 terminate the buffer */

*(buffer+i) = 0;

jdeFclose(stream);

return 0;

}

Additional Notes

None

See Also

· jdeFgetcConvert, jdeFgetcConvertV2


jdeFgetcConvertV2

Last Modified: ERP 9.0 | June 2, 2003

jdeFgetcConvertV2 - Reads a character from the flat file and returns the character in JCHAR format. This function is used when a user has a reference to HUSER. The HUSER, ERP application, and version name contains information for querying the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by the Unicode Flat File Encoding Configuration program (P93081).

Syntax

JDERTN(int) JDEWINAPI jdeFgetcConvertV2(HUSER hUser, JCHAR *appName, JCHARE *verName, FILE *stream);

Parameters

Parameter | Notes | Usage
hUser | ERP HUSER |
appName | ERP application name | For example, P01012
verName | ERP application version name | For example, ZJDE0001
stream | File pointer |

Return Value

A JCHAR character or EOF to indicate error or end of file.

Example

#include <jde.h>

int someSystemFunction(HUSER hUser, JCHAR *appName, JCHAR *verName)

{

FILE *stream;

JCHAR buffer[81];

Int ch, i;

/* open the flat file for read */

stream = jdeFopen(_J(“in_file.txt”), _J(“r”));

if (stream == NULL)

return -1;

/* read in first 80 characters and place them in the JCHAR buffer */

i = 0;

ch = jdeFgetcConvertV2(hUser, appName, verName, stream);

while ( ch != EOF && i < 80) {

*(buffer+i) = (JCHAR)ch; /* cast to JCHAR since jdeFgetcConvert return int */

ch = jdeFgetcConvertV2(hUser, appName, verName, stream);

if (ch != EOF)

i++;

}

/* \0 terminate the buffer */

*(buffer+i) = 0;

jdeFclose(stream);

return 0;

}

Additional Notes

None

See Also

· jdeFgetcConvert, jdeFgetcConvertV1


jdeFgetsConvert

Last Modified: ERP 9.0 | June 2, 2003

jdeFgetsConvert - Reads a string from the flat file and returns the string in JCHAR format. This function is used by business functions that reference LPBHVRCOM. The LPBHVRCOM contains information to query the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding.

Syntax

JDERTN(JCHAR *) JDEWINAPI jdeFgetsConvert(LPBHVRCOM lpBhvrCom, JCHAR *buf, jde_n_char n, FILE *stream);

Parameters

Parameter | Notes | Usage
lpBhvrCom | ERP behavior communication structure |
buf | Destination buffer (data will be in Unicode) |
n | Maximum number of characters to read |
stream | File pointer |

Return Value

A JCHAR string, or NULL if failed or EOF.

Example

JDEBFRTN(ID) JDEBFWINAPI someBusinessFunction(LPBHVRCOM lpBhvrCom,

LPVOID lpVoid, LPDSD12345678 lpDS)

{

FILE *stream;

JCHAR buffer[256];

Int ch, i;

/* open the flat file for read */

stream = jdeFopen(_J(“in_file.txt”), _J(“r”));

if (stream == NULL)

return ER_ERROR;

/* read a line or up first 255 characters and place them in the JCHAR buffer */

jdeFgetsConvert(lpBhvrCom , buffer, 255, stream);

jdeFclose(stream);

}

Additional Notes

None

See Also

· jdeFgetsConvertV1, jdeFgetsConvertV2


jdeFgetsConvertV1

Last Modified: ERP 9.0 | June 2, 2003

jdeFgetsConvertV1 - Reads a string from the flat file in the specified encoding and returns the string in JCHAR format. This function is used when the flat file encoding is known and there is no need to query the Unicode Flat File Encoding Configuration table (F93081).

Syntax

JDERTN(JCHAR *) JDEWINAPI jdeFgetsConvertV1(JCHAR *pEncoding, JCHAR *buf, jde_n_char n, FILE *stream);

Parameters

Parameter | Notes | Usage
pEncoding | Encoding name for data in the file | All ICU supported encodings. For example, cp1252
buf | Destination buffer (data will be in Unicode) |
n | Maximum number of characters to read |
stream | File pointer |

Return Value

A JCHAR string, or NULL if failed or EOF.

Example

#include <jde.h>

int someSystemFunction()

{

FILE *stream;

JCHAR buffer[256];

Int ch, i;

/* open the flat file for read */

stream = jdeFopen(_J(“in_file.txt”), _J(“r”));

if (stream == NULL)

return -1;

/* read a line or up first 255 characters and place them in the JCHAR buffer */

jdeFgetsConvertV1(_J(“cp1252”) , buffer, 255, stream); /* flat file in cp1252 encoding */

jdeFclose(stream);

return 0;

}

Additional Notes

None

See Also

· jdeFgetsConvert, jdefGetsConvertV2


jdeFgetsConvertV2

Last Modified: ERP 9.0 | June 2, 2003

jdeFgetsConvertV2 - Reads a string from the flat file and returns the string in JCHAR format. This function is used when a user has a reference to HUSER. The HUSER, ERP application, and version name contains information to query the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by the Unicode Flat File Encoding Configuration program (P93081).

Syntax

JDERTN(JCHAR *) JDEWINAPI jdeFgetsConvertV2(HUSER hUser, JCHAR *appName, JCHAR *verName, JCHAR *buf,jde_n_char n, FILE *stream);

Parameters

Parameter | Notes | Usage
hUser | ERP HUSER |
appName | ERP application name | For example, P01012
verName | ERP application version name | For example, ZJDE0001
buf | Data buffer (in Unicode) |
n | Maximum number of characters to read |
stream | File pointer |

Return Value

A JCHAR string, or NULL if failed or EOF.

Example

#include <jde.h>

int someSystemFunction(HUSER hUser, JCHAR *appName, JCHAR *verName)

{

FILE *stream;

JCHAR buffer[256];

Int ch, i;

/* open the flat file for read */

stream = jdeFopen(_J(“in_file.txt”), _J(“r”));

if (stream == NULL)

return -1;

/* read a line or up first 255 characters and place them in the JCHAR buffer */

jdeFgetsConvertV2(hUser, appName, verName , buffer, 255, stream);

jdeFclose(stream);

return 0;

}

Additional Notes

None

See Also

· jdeFgetsConvert, jdeFgetsConvertV1


jdeFprintfConvert

Last Modified: ERP 9.0 | June 2, 2003

jdeFprintfConvert – Prints formatted data to the flat file in the configured encoding. This function is used by business functions that reference LPBHVRCOM. The LPBHVRCOM contains information to query the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by the Unicode Flat File Encoding Configuration program (P93081).

Syntax

JDERTN(int) JDEWINAPI jdeFprintfConvert(LPBHVRCOM lpBhvrCom, FILE *stream, const JCHAR *format, /*[pointer,]*/...);

Parameters

Parameter | Notes | Usage
lpBhvrCom | ERP behavior communication structure |
stream | File pointer |
format | Format control string |

Return Value

Number of fields converted and assigned.

Example

JDEBFRTN(ID) JDEBFWINAPI someBusinessFunction(LPBHVRCOM lpBhvrCom,

LPVOID lpVoid, LPDSD12345678 lpDS)

{

FILE *stream;

int i = 10;

double d = 1.5;

JCHAR *s = _J(“Test String”);

/* open the flat file for write */

stream = jdeFopen(_J(“out_file.txt”), _J(“w”));

if (stream == NULL)

return ER_ERROR;

/* write to file in configured encoding */

jdeFprintfConvert(lpBhvrCom , stream, _J(“%d %f %ls\n”), i, d , s);

jdeFclose(stream);

}

Additional Notes

None

See Also

· jdeFprintfConvertV1, jdeFprintfConvertV2


jdeFprintfConvertV1

Last Modified: ERP 9.0 | June 2, 2003

jdeFprintfConvertV1 – Prints formatted data to a flat file in the encoding specified. This function is used when the flat file encoding is known and there is no need to query the Unicode Flat File Encoding Configuration table (F93081) for flat file encoding.

Syntax

JDERTN(int) JDEWINAPI jdeFprintfConvertV1(JCHAR *pEncoding, FILE *stream, const JCHAR *format, /*[pointer,]*/...);

Parameters

Parameter | Notes | Usage
pEncoding | Encoding name for data in the file | All ICU supported encodings For example, cp1252
stream | File pointer |
format | Format control string |

Return Value

Number of fields converted and assigned.

Example

int someSystemFunction( )

{

FILE *stream;

int i = 10;

double d = 1.5;

JCHAR *s = _J(“Test String”);

/* open the flat file for write */

stream = jdeFopen(_J(“out_file.txt”), _J(“w”));

if (stream == NULL)

return -1;

/* write to file in cp1252 encoding */

jdeFprintfConvertV1(_J(“cp1252”) , stream, _J(“%d %f %ls\n”), i, d , s);

jdeFclose(stream);

return 0;

}

Additional Notes

None

See Also

· jdeFprintfConvert, jdeFprintfConvertV2


jdeFprintfConvertV2

Last Modified: ERP 9.0 | June 2, 2003

jdeFprintfConvertV2 – Prints formatted data to file stream in the configured encoding. This function is used when the user has a reference to HUSER. The HUSER, ERP application, and version name contains information to query the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by P93081.

Syntax

JDERTN(int) JDEWINAPI jdeFprintfConvertV2(HUSER hUser, JCHAR *appName, JCHAR *verName, FILE *stream, const JCHAR *format,/*[pointer,]*/...);

Parameters

Parameter | Notes | Usage
hUser | ERP HUSER |
appName | ERP application name | For example, P01012
verName | ERP application version name | For example, ZJDE0001
stream | File pointer |
format | Format control string |

Return Value

Number of fields converted and assigned.

Example

int someSystemFunction(HUSER hUser, JCHAR *appName, JCHAR *verName )

{

FILE *stream;

int i = 10;

double d = 1.5;

JCHAR *s = _J(“Test String”);

/* open the flat file for write */

stream = jdeFopen(_J(“out_file.txt”), _J(“w”));

if (stream == NULL)

return -1;

/* write to file in cp1252 encoding */

jdeFprintfConvertV2(hUser, appName, verName , stream, _J(“%d %f %ls\n”), i, d , s);

jdeFclose(stream);

return 0;

}

Additional Notes

None

See Also

· jdeFprintfConvert, jdeFprintfConvertV1


jdeFputcConvert

Last Modified: ERP 9.0 | June 2, 2003

jdeFputcConvert – Writes a character to a flat file in the configured encoding. This function is used by business functions that reference LPBHVRCOM. The LPBHVRCOM contains information to query the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by the Unicode Flat File Encoding Configuration program (P93081).

Syntax

JDERTN(int) JDEWINAPI jdeFputcConvert(LPBHVRCOM lpBhvrCom, int c, FILE *stream);

Parameters

Parameter | Notes | Usage
lpBhvrCom | ERP behavior communication structure |
c | A JCHAR |
stream | File pointer |

Return Value

Character written or End of file (EOF) if failed.

Example

JDEBFRTN(ID) JDEBFWINAPI someBusinessFunction(LPBHVRCOM lpBhvrCom,

LPVOID lpVoid, LPDSD12345678 lpDS)

{

FILE *stream;

/* open the flat file for write */

stream = jdeFopen(_J(“out_file.txt”), _J(“w”));

if (stream == NULL)

return ER_ERROR;

/* write a JCHAR to file in configured encoding */

jdeFputcConvert(lpBhvrCom , _J(‘a’), stream);

jdeFclose(stream);

}

Additional Notes

None

See Also

· jdeFputcConvertV1, jdeFputcConvertV2


jdeFputcConvertV1

Last Modified: ERP 9.0 | May 28, 2003

jdeFputcConvertV1 – Writes a character to a flat file in the specified encoding. This function is used when the flat file encoding is known and there is no need to query the Unicode Flat File Encoding Configuration table (F93081) for flat file encoding.

Syntax

JDERTN(int) JDEWINAPI jdeFputcConvertV1(JCHAR *pEncoding, int c, FILE *stream);

Parameters

Parameter | Notes | Usage
pEncoding | Encoding name for the data in the file | All ICU supported encodings
c | A JCHAR |
stream | File pointer |

Return Value

End of file (EOF) if failed.

Example

int someSystemFunction()

{

FILE *stream;

/* open the flat file for write */

stream = jdeFopen(_J(“out_file.txt”), _J(“w”));

if (stream == NULL)

return -1;

/* write a JCHAR to file in cp1252 encoding */

jdeFputcConvertV1(_J(“cp1252”), _J(‘a’), stream);

jdeFclose(stream);

return 0;

}

Additional Notes

None

See Also

· jdeFputcConvert, jdeFputcConvertV2


jdeFputcConvertV2

Last Modified: ERP 9.0 | June 2, 2003

jdeFputcConvertV2 - Writes a character to a flat file in configured encoding. This function is used when the user has a reference to HUSER. The HUSER, ERP application, and version name contains information for querying the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by the Unicode Flat File Encoding Configuration program (P93081).

Syntax

JDERTN(int) JDEWINAPI jdeFputcConvertV2(HUSER hUser, JCHAR *appName, JCHAR *verName, int c, FILE *stream);

Parameters

Parameter | Notes | Usage
hUser | ERP HUSER |
appName | ERP application name | For example, P01012
verName | ERP application version name | For example, ZJDE0001
c | A JCHAR |
stream | File pointer |

Return Value

End of file (EOF) if failed.

Example

int someSystemFunction(HUSER hUser, JCHAR *appName, JCHAR *verName)

{

FILE *stream;

/* open the flat file for write */

stream = jdeFopen(_J(“out_file.txt”), _J(“w”));

if (stream == NULL)

return -1;

/* write a JCHAR to file in configured encoding */

jdeFputcConvertV2(hUser, appName, verName, _J(‘a’), stream);

jdeFclose(stream);

return 0;

}

Additional Notes

None

See Also

· jdeFputcConvert, jdeFputcConvertV1


jdeFputsConvert

Last Modified: ERP 9.0 | June 2, 2003

jdeFputsConvert – Writes a string to the flat file in configured encoding. This function is used by business functions that reference LPBHVRCOM. The LPBHVRCOM contains information to query the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by the Unicode Flat File Encoding Configuration program (P93081).

Syntax

JDERTN(jde_n_char) JDEWINAPI jdeFputsConvert(LPBHVRCOM lpBhvrCom, const JCHAR *buf, FILE *stream);

Parameters

Parameter | Notes | Usage
lpBhvrCom | ERP behavior communication structure |
buf | Data buffer (in Unicode) |
stream | File pointer |

Return Value

A nonnegative number if successful or end of file (EOF).

Example

JDEBFRTN(ID) JDEBFWINAPI someBusinessFunction(LPBHVRCOM lpBhvrCom,

LPVOID lpVoid, LPDSD12345678 lpDS)

{

FILE *stream;

/* open the flat file for write */

stream = jdeFopen(_J(“out_file.txt”), _J(“w”));

if (stream == NULL)

return ER_ERROR;

/* write JCHAR string to file in configured encoding */

jdeFputsConvert(lpBhvrCom , _J(“Write a Line to flat file\n”), stream);

jdeFclose(stream);

}

Additional Notes

None

See Also

· jdeFputsConvertV1, jdeFputsConvertV2


jdeFputsConvertV1

Last Modified: ERP 9.0 | June 2, 2003

jdeFputsConvertV1 - Writes a string to the flat file in specified encoding. This function is used when the flat file encoding is known and there is no need to query the Unicode Flat File Encoding Configuration table (F93081) for flat file encoding.

Syntax

JDERTN(jde_n_char) JDEWINAPI jdeFputsConvertV1(JCHAR *pEncoding, const JCHAR *buf, FILE *stream);

Parameters

Parameter | Notes | Usage
pEncoding | Encoding name for the data in the file | All ICU supported encodings. For example, cp1252
buf | Data buffer (in Unicode) |
stream | File pointer |

Return Value

A nonnegative number if successful or end of file (EOF).

Example

int someSystemFunction( )

{

FILE *stream;

/* open the flat file for write */

stream = jdeFopen(_J(“out_file.txt”), _J(“w”));

if (stream == NULL)

return -1;

/* write JCHAR string to file in cp1252 encoding */

jdeFputsConvertV1(_J(“cp1252”) , _J(“Write a Line to flat file\n”), stream);

jdeFclose(stream);

return 0;

}

Additional Notes

None.

See Also

· jdeFputsConvert, jdeFputsConvertV2


jdeFputsConvertV2

Last Modified: ERP 9.0 | June 2, 2003

jdeFputsConvertV2 - Writes a string to the flat file in configured encoding. This function is used when a user has a reference to HUSER. The HUSER, ERP application, and version name contains information for querying the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by the Unicode Flat File Encoding Configuration program (P93081).

Syntax

JDERTN(jde_n_char) JDEWINAPI jdeFputsConvertV2(HUSER hUser, JCHAR *appName, JCHAR *verName, const JCHAR *buf, FILE *stream);

Parameters

Parameter | Notes | Usage
hUser | ERP HUSER |
appName | ERP application name | For example, P01012
verName | ERP application version name | For example, ZJDE0001
buf | Data buffer (in Unicode) |
stream | File pointer |

Return Value

A nonnegative number if successful, or end of file (EOF).

Example

int someSystemFunction(HUSER hUser )

{

FILE *stream;

/* open the flat file for write */

stream = jdeFopen(_J(“out_file.txt”), _J(“w”));

if (stream == NULL)

return -1;

/* write JCHAR string to file in cp1252 encoding */

jdeFputsConvertV2(hUser, appName, verName , _J(“Write a Line to flat file\n”), stream);

jdeFclose(stream);

return 0;

}

Additional Notes

None

See Also

· jdeFputsConvert, jdeFputsConvertV1


jdeFreadConvert

Last Modified: ERP 9.0 | June 2, 2003

jdeFreadConvert - Reads character data from the flat file in the configured encoding and returns the characters in JCHAR format. This function is used by business functions that reference LPBHVRCOM. The LPBHVRCOM contains information to query the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by the Unicode Flat File Encoding Configuration program (P93081).

Syntax

JDERTN(size_t) JDEWINAPI jdeFreadConvert(LPBHVRCOM lpBhvrCom, JCHAR *buf, jde_n_char size, size_t count, FILE *stream);

Parameters

Parameter | Notes | Usage
lpBhvrCom | ERP behavior communication structure |
buf | Destination buffer (data will be in Unicode) |
size | Item size, number of characters |
count | Maximum number of “Items” to be written |
stream | File pointer |

Return Value

Number of full “Items” read from the file.

Example

JDEBFRTN(ID) JDEBFWINAPI someBusinessFunction(LPBHVRCOM lpBhvrCom,

LPVOID lpVoid, LPDSD12345678 lpDS)

{

FILE *stream;

JCHAR buffer[256];

/* open the flat file for read */

stream = jdeFopen(_J(“in_file.txt”), _J(“r”));

if (stream == NULL)

return ER_ERROR;

/* read 256 characters and place them in the JCHAR buffer */

jdeFreadConvert (lpBhvrCom , buffer, DIM(buffer), 1, stream);

jdeFclose(stream);

}

Additional Notes

None

See Also

· jdeFreadConvertV1, jdeFreadConvertV2


jdeFreadConvertV1

Last Modified: ERP 9.0 | June 2, 2003

jdeFreadConvertV1 - Reads character data from a flat file in the specified encoding and returns the characters in JCHAR format. This function is used when the flat file encoding is known and there is no need to query the Unicode Flat File Encoding Configuration table (F93081) for flat file encoding.

Syntax

JDERTN(size_t) JDEWINAPI jdeFreadConvertV1(JCHAR *pEncoding, JCHAR *buf, jde_n_char size, size_tcount, FILE *stream);

Parameters

Parameter | Notes | Usage
pEncoding | Encoding name for data in the file | All ICU supported encodings. For example, cp1252
buf | Destination buffer (data will be in Unicode) |
size | Item size, number of characters |
count | Maximum number of “Items” to read |
stream | File pointer |

Return Value

Number of full “Items” read from the file.

Example

int someSystemFunction( )

{

FILE *stream;

JCHAR buffer[256];

/* open the flat file for read */

stream = jdeFopen(_J(“in_file.txt”), _J(“r”));

if (stream == NULL)

return -1;

/* read 256 characters and place them in the JCHAR buffer */

jdeFreadConvertV1(_J(“cp1252”) , buffer, DIM(buffer), 1, stream);

jdeFclose(stream);

return 0;

}

Additional Notes

None

See Also

· jdeFreadConvert, jdeFreadConvertV2


jdeFreadConvertV2

Last Modified: ERP 9.0 | June 2, 2003

jdeFreadConvertV2 - Reads character data from a flat file in the configured encoding and returns the characters in JCHAR format. This function is used when a user has a reference to HUSER. The HUSER, ERP application, and version name contains information for querying the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by the Unicode Flat File Encoding Configuration program (P93081).

Syntax

JDERTN(size_t) JDEWINAPI jdeFreadConvertV2(HUSER hUser, JCHAR *appName, JCHAR *verName, JCHAR *buf,jde_n_char size, size_t count, FILE *stream);

Parameters

Parameter | Notes | Usage
hUser | ERP HUSER |
appName | ERP application name | For example, P01012
verName | ERP application version name | For example, ZJDE0001
buf | Destination buffer (data will be in Unicode) |
size | Item size, number of characters |
count | Maximum number of "Items" to read |
stream | File pointer |

Return Value

Number of full “Items” read from the file.

Example

int someSystemFunction(HUSER hUser, JCHAR *appName, JCHAR *verName )

{

FILE *stream;

JCHAR buffer[256];

/* open the flat file for read */

stream = jdeFopen(_J(“in_file.txt”), _J(“r”));

if (stream == NULL)

return -1;

/* read 256 characters and place them in the JCHAR buffer */

jdeFreadConvertV2(hUser, appName, verName, buffer, DIM(buffer), 1, stream);

jdeFclose(stream);

return 0;

}

Additional Notes

None

See Also

· jdeFreadConvert, jdeFreadConvertV1


jdeFscanfConvert

Last Modified: ERP 9.0 | May 28, 2003

jdeFscanfConvert - Reads formatted data from the flat file in the configured encoding and returns the character in JCHAR format. This function is used by business functions that reference LPBHVRCOM. The LPBHVRCOM contains information to query the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by the Unicode Flat File Encoding Configuration program (P93081).

Syntax

JDERTN(int) JDEWINAPI jdeFscanfConvert(LPBHVRCOM lpBhvrCom, FILE *stream, const JCHAR *format,/*[pointer,]*/...);

Parameters

Parameter | Notes | Usage
lpBhvrCom | ERP behavior communication structure |
stream | File pointer |
format | Format control string |

Return Value

Number of full fields converted and assigned.

Example

JDEBFRTN(ID) JDEBFWINAPI someBusinessFunction(LPBHVRCOM lpBhvrCom,

LPVOID lpVoid, LPDSD12345678 lpDS)

{

FILE *stream;

JCHAR buffer[256];

/* open the flat file for read */

stream = jdeFopen(_J(“in_file.txt”), _J(“r”));

if (stream == NULL)

return ER_ERROR;

/* read a string and place them in the JCHAR buffer */

jdeFscanfConvert (lpBhvrCom , stream, _J(“%ls”), buffer);

jdeFclose(stream);

}

Additional Notes

None

See Also

· jdeFscanfConvertV1, jdeFscanfConvertV2


jdeFscanfConvertV1

Last Modified: ERP 9.0 | June 2, 2003

jdeFscanfConvertV1 - Reads formatted character data from the flat file in the specified encoding and returns the character in JCHAR format. This function is used when the flat file encoding is known and there is no need to query the Unicode Flat File Encoding Configuration table (F93081) for flat file encoding.

Syntax

JDERTN(int) JDEWINAPI jdeFscanfConvertV1(JCHAR *pEncoding, FILE *stream, const JCHAR *format,/*[pointer,]*/...);

Parameters

Parameter | Notes | Usage
pEncoding | Encoding name for data in the file | All ICU supported encodings. For example, cp1252
stream | File pointer |
format | Format control string |

Return Value

Number of fields converted and assigned.

Example

int someSystemFunction( )

{

FILE *stream;

JCHAR buffer[256];

/* open the flat file for read */

stream = jdeFopen(_J(“in_file.txt”), _J(“r”));

if (stream == NULL)

return -1;

/* read a string and place them in the JCHAR buffer */

jdeFscanfConvertV1(_J(“cp1252”) , stream, _J(“%ls”), buffer);

jdeFclose(stream);

return 0;

}

Additional Notes

None

See Also

· jdeFscanfConvert, jdeFscanfConvertV2


jdeFscanfConvertV2

Last Modified: ERP 9.0 | June 2, 2003

jdeFscanfConvertV2 - Reads formatted data from the flat file in the configured encoding and returns the character in JCHAR format. This function is used when A user has a reference to HUSER. The HUSER, ERP application, and version name contains information for querying the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by the Unicode Flat File Encoding Configuration program (P93081).

Syntax

JDERTN(int) JDEWINAPI jdeFscanfConvertV2(HUSER hUser, JCHAR *appName, JCHAR *verName, FILE *stream, const JCHAR *format,/*[pointer,]*/...););

Parameters

Parameter | Notes | Usage
hUser | ERP HUSER |
appName | ERP application name | For example, P01012
verName | ERP application version name | For example, ZJDE0001
stream | File pointer |
format | Format control string |

Return Value

Number of fields converted and assigned.

Example

int someSystemFunction( HUSER hUser, JCHAR *appName, JCHAR *verName)

{

FILE *stream;

JCHAR buffer[256];

/* open the flat file for read */

stream = jdeFopen(_J(“in_file.txt”), _J(“r”));

if (stream == NULL)

return -1;

/* read a string and place them in the JCHAR buffer */

jdeFscanfConvertV2(hUser, appName, verName , stream, _J(“%ls”), buffer);

jdeFclose(stream);

return 0;

}

Additional Notes

None

See Also

· jdeFscanfConvert, jdeFscanfConvertV1


jdeFwriteConvert

Last Modified: ERP 9.0 | May 28, 2003

jdeFwriteConvert – Writes character data to the flat file in the configured encoding. This function is used by business functions that reference LPBHVRCOM. The LPBHVRCOM contains information to query the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by the Unicode Flat File Encoding Configuration program (P93081).

Syntax

JDERTN(size_t) JDEWINAPI jdeFwriteConvert(LPBHVRCOM lpBhvrCom, JCHAR *buf, jde_n_char size, site_t count, FILE *stream);

Parameters

Parameter | Notes | Usage
lpBhvrCom | ERP behavior communication structure |
buf | Buffer that contains Unicode characters |
size | Item size, number of characters |
count | Maximum number of "Items" to be written |
stream | File pointer |

Return Value

Number of full "Items" written to the file.

Example

JDEBFRTN(ID) JDEBFWINAPI someBusinessFunction(LPBHVRCOM lpBhvrCom,

LPVOID lpVoid, LPDSD12345678 lpDS)

{

FILE *stream;

JCHAR buffer[256];

/* open the flat file for write */

stream = jdeFopen(_J(“out_file.txt”), _J(“w”));

if (stream == NULL)

return ER_ERROR;

jdeStrcpy(buffer, _J(“Test string”));

/* write a JCHAR string to flat file */

jdeFwriteConvert (lpBhvrCom , buffer, jdeStrlen(buffer), 1, stream);

jdeFclose(stream);

}

Additional Notes

None

See Also

· jdeFwriteConvertV1, jdeFwriteConvertV2


jdeFwriteConvertV1

Last Modified: ERP 9.0 | June 2, 2003

jdeFwriteConvertV1 - Writes character data to flat file in specified encoding. This function is used when the flat file encoding is known and there is no need to query the Unicode Flat File Encoding Configuration table (F93081) for flat file encoding.

Syntax

JDERTN(size_t) JDEWINAPI jdeFwriteConvertV1(JCHAR *pEncoding, JCHAR *buf, jde_n_char size, size_tcount, FILE *stream);

Parameters

Parameter | Notes | Usage
pEncoding | Encoding name for data to be written to the file | All ICU supported encodings. For example, cp1252
buf | Buffer that contains Unicode character(s) |
size | Item size, number of characters |
count | Maximum number of "Items" to be written |
stream | File pointer |

Return Value

Number of full “Items” written to the file.

Example

int someSystemFunction( )

{

FILE *stream;

JCHAR buffer[256];

/* open the flat file for write */

stream = jdeFopen(_J(“out_file.txt”), _J(“w”));

if (stream == NULL)

return -1;

jdeStrcpy(buffer, _J(“Test string”));

/* write a JCHAR string to flat file */

jdeFwriteConvertV1(_J(“cp1252”) , buffer, jdeStrlen(buffer), 1, stream);

jdeFclose(stream);

return 0;

}

Additional Notes

None

See Also

· jdeFwriteConvert, jdeFwriteConvertV2


jdeFwriteConvertV2

Last Modified: ERP 9.0 | June 2, 2003

jdeFwriteConvertV2 - Writes character data to the flat file in configured encoding. This function is used when the user has a reference to HUSER. The HUSER, ERP application, and version name contains information for querying the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by the Unicode Flat File Encoding Configuration program (P93081).

Syntax

JDERTN(size_t) JDEWINAPI jdeFwriteConvertV2(HUSER hUser, JCHAR *appName, JCHAR *verName, JCHAR *buf,jde_n_char size, size_t count, FILE *stream);

Parameters

Parameter | Notes | Usage
hUser | ERP HUSER |
appName | ERP application name | For example, P01012
verName | ERP application version name | For example, ZJDE0001
buf | Buffer that contains Unicode character(s) |
size | Item size, number of characters |
count | Maximum number of "Items" to be written |
stream | File pointer |

Return Value

Number of full “Items” written to the file.

Example

int someSystemFunction(HUSER hUser, JCHAR *appName, JCHAR *verName )

{

FILE *stream;

JCHAR buffer[256];

/* open the flat file for write */

stream = jdeFopen(_J(“out_file.txt”), _J(“w”));

if (stream == NULL)

return -1;

jdeStrcpy(buffer, _J(“Test string”));

/* write a JCHAR string to flat file */

jdeFwriteConvertV2(hUser, appName, verName , buffer, jdeStrlen(buffer), 1, stream);

jdeFclose(stream);

return 0;

}

Additional Notes

None

See Also

· jdeFwriteConvert, jdeFwriteConvertV1


jdeGetEncodingNameV1

Last Modified: ERP 9.0 | May 28, 2003

jdeGetEncodingNameV1 queries the encoding configuration table to determine the encoding name. This function is used by business functions that reference LPBHVRCOM. The LPBHVRCOM contains information to query the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by the Unicode Flat File Encoding Configuration program (P93081).

Syntax

JDERTN(JCHAR *) JDEWINAPI jdeGetEncodingNameV1(LPBHVRCOM lpBhvrCom, JCHAR *enc);

Parameters

Parameter | Notes | Usage
lpBhvrCom | ERP behavior communication structure |
Enc | Output buffer for the encoding name |

Return Value

Encoding name; for example, "CP1252". NULL if no encoding found or if an error occurs.

Example

JDEBFRTN(ID) JDEBFWINAPI someBusinessFunction(LPBHVRCOM lpBhvrCom,

LPVOID lpVoid, LPDSD12345678 lpDS)

{

JCHAR enc[31];

jdeGetEncodingNameV1(lpBhvrCom, enc);

}

Additional Notes

None

See Also

· jdeGetEncodingNameV2


jdeGetEncodingNameV2

Last Modified: ERP 9.0 | May 28, 2003

jdeGetEncodingNameV2 queries the encoding configuration table to determine the encoding name. This function is used when a user has a reference to HUSER. The HUSER, ERP application, and version name contains information for querying the Unicode Flat File Encoding Configuration table (F93081) for the flat file encoding configured by the Unicode Flat File Encoding Configuration program (P93081).

Syntax

JDERTN(JCHAR *) JDEWINAPI jdeGetEncodingNameV2(HUSER hUser, JCHAR *appName, JCHAR *verName, JCHAR *enc);

Parameters

Parameter | Notes | Usage
hUser | ERP HUSER |
appName | ERP application name or "*ALL" | For example, P01012
verName | ERP application version name or "*ALL" | For example, XJDE0001
enc | Output buffer for the encoding name |

Return Value

Encoding name; for example, "CP1252". NULL if no encoding found or if an error occurs.

Example

int someSystemFunction(HUSER hUser, JCHAR *appName, JCHAR *verName)

{

JCHAR enc[31];

jdeGetEncodingNameV2(hUser, appName, verName, enc);

}

Additional Notes

None

See Also

· jdeGetEncodingNameV1


Address Book

Table: F0101Z2

Date: November 2, 1998; updated May 2003

General Information

Purpose of Transaction

Address Book transactions are used to maintain information about companies and people with whom you do business. The address book contains names, addresses, contact names, and other pertinent information. On the inbound side, this transaction is used to update ERP tables with address book information. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the address book information.

The permanent ERP table primarily affected by this transaction is the Address Book Master table (F0101).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions, changes, and deletions.

The outbound transaction supports additions, changes, and deletions. For changes, both the before and after images can be written.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into ERP - Table F0101Z2

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into ERP, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction (for example, JDEAB)
TNAC | Action Code | "A" = add, "C" = change, "D" = delete (left justified)
DRIN | Direction Indicator | "1" = into ERP (inbound). This indicates that the record was written by a system external to ERP with the intent of pushing the transaction into ERP.
EDSP | Processed flag | When processing for this transaction is complete, ERP updates this to a "Y".

Additional Comments

The following columns EDUS, EDBT, and EDTN must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to ERP. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for ERP to accept the transaction.

Data Item | Description | Notes
AN8 | Address Number | A number that identifies an entry in the Address Book system. Use this number to identify employees, applicants, participants, customers, suppliers, tenants, and any other address book members.
AT1 | Search Type | A user defined code (01/ST) that identifies the kind of address book record you want the system to select when you search for a name or a message.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
ALPH | Alpha Name | The text that names or describes an address. This 40 character alphabetic field appears on a number of forms and reports. You can enter dashes, commas and other special characters. Some special characters, especially the ones used in other languages are allowed too. If Double byte is on, even special characters are not ignored.
ALKY | Long Address Number | A user defined name or number that is unique to the address book number. You can use this field to enter and locate information. You can use it to cross-reference the supplier to a Dun & Bradstreet number, a lease number, or other reference.
TAX | Tax Id | The identification code required by various tax authorities. This can be a social security number, federal or state corporate tax id, sales tax number, and so on. Required for search type E, A, Q and X.
ADD1 | Address Line 1 | The first line of the address for an employee, customer, or supplier in the Address Book system.
CTY1 | City | The city associated with the address
ADDS | State | A user defined code (00/S) for the state or province. This code is usually a postal service abbreviation.
ADDZ | Postal Code | The United States zip code or the postal code attached to the address for delivery in other countries.
CTR | Country | A user defined code (00/CN) that identifies a country. The Address Book system uses the Country code for data selection and address formatting.

Column-Specific Instructions - From ERP - Table F0101Z2

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from ERP, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction. In batch mode this can be any ID, as long as it is in the Address Book.
EDBT | User Batch | Batch number generated within ERP.
EDTN | User Transaction Number | Transaction number generated within ERP to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by ERP as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction (for example, JDEAB).
TNAC | Action Code | "A" = add, "D" = delete, "C" =change (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from ERP (outbound). This indicates that the record was written by ERP to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, ERP updates this to a "Y". For outbound transactions from ERP, these are flagged complete when process log records are written to table F0046.

Data Columns

Data columns in the interface table from ERP (outbound) have the same definitions as they do for transactions coming into ERP (inbound). Refer to the "Into ERP" section for descriptions of required and frequently used columns. Unless otherwise specified, ERP provides all columns from the corresponding source table.

ERP 9.0 Data

The following fields are added to Table F0101Z2 for ERP 9.0.

Data Item | Description | Notes
PRGF | Ready for Purge Flag | Reserved by J.D. Edwards
SCCLTP | Short-cut Type | A code that indicates the type of application shortcut that appears in messages sent by the ERP system to a specific user. Valid values are: Blank Windows. Clicking on the shortcut launches the Windows version of the referenced application. 01 HTML. Clicking on the shortcut launches the Web version of the referenced application.
PA8 | Parent Number | The address book number of the parent company. The system uses this number to associate a particular address with a parent company or location. Any value that you enter in this field updates the Address Organizational Structure Master table (F0150) for the blank structure type. This address number must exist in the Address Book Master table (F0101) for validation purposes. Examples of address book records that would have a parent number include: - subsidiaries with parent companies - branches with a home office - job sites with a general contractor.


AdvanceSection

Last Modified: B733.2 | May 07, 1999

Advance Section should be used if you need to perform processing on object before a fetch. This occurs each time you do a fetch from the database. If this section does not have a business view attached, then this event is processed once.

Available On

  • Section Level event rule only.

Available Objects

  • All section level and global objects.

Typical Usage

This event occurs every time there is a database Fetch.

Additional Notes

If processing needs to be done after the Fetch, use the EventBeforeTabularBreak event.

Processing Sequence

  1. InitSection

  2. AdvanceSection

  3. ((DoTabularBreak), AdvanceSection), repeat

  4. DoSection


AfterLastObjectPrinted

Last Modified: B733.2 | May 07, 1999

AfterLastObjectPrinted should be used to process information after a row has been output. This occurs after a row is printed to an output file.

Available On

  • This is available at the Section Level event rules.

Typical Usage

This can be use to process information after a row has been output.

Processing Sequence

  • Do Object

  • End Object

  • Last Object

  • Advance Section


Batch Cash Receipts

Table: F03B13Z1

Date: November 10, 1998

General Information

Purpose of transaction

Batch Cash Receipt transactions are used to convey information about Cash Receipts and the application of the receipt to a Customer’s Ledger. On the inbound side, this transaction is used to move Cash Receipt into the Automated Receipt Processing. Outbound transactions are not supported.

The permanent OneWorld tables primarily affected by this transaction are the Receipts Header table (F03B13), and the Receipt Detail table (F03B14).

Relationships to other transactions

None.

Transaction specific instructions

The inbound transaction supports additions, changes, and deletions.

Unused fields must be populated by zero(s) or blank space(s), depending on their data types. If you are using our APIs to write to the table(s), our internal database APIs will handle the conversion for you.

Column specific instructions - Into OneWorld – Table F03B13Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi-line transactions (Invoices to be applied), this column must be populated to differentiate each line within a given transaction.
PYID | Payment ID | Leave *BLANK Internally controlled by system
EUPS | Upload Status | Leave *BLANK Internally controlled by system
TYIN | Receipt Type Code | Leave *BLANK Internally assigned by system.

Additional Comments

The following three columns (EDUS, EDBT, AND EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
USER | User ID | ID of the user that has created the transaction. Will be defaulted from the EDUS
CKAM | Check Amount | Must be supplied on first line of a receipt. This will be the Foreign amount on a foreign receipt or Domestic amount of the domestic receipt.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
ICU | Batch Number | If left blank the upload UBE will assign a 9B batch number. If supplied must be created in the F0011 table as 9B batch type user can use the JDE Next Number API to assign.
CKNU | Receipt Number | Will be displayed as the receipt number.
KCO | Document Company | If supplied will be used as a filter in the Know Invoice Match Algorithms R03B50D & R03B50E
DCT | Document Type | If supplied will be used as a filter in the Know Invoice Match Algorithms R03B50D & R03B50E
DOC | Document Number | This field identifies a invoice to processed by the Know Invoice Match Algorithms. This field or the Generic Match field are required for the Know Invoice Match Algorithms.
SFX | Pay Item | If supplied will be used as a filter in the Know Invoice Match Algorithms R03B50D & R03B50E
CTL | Statement Number | Currently not used. Replaced by the Generic Matching Field. Will be removed from the table at a later time.
GMFD | Generic Matching Field | This field can contain a Invoice , Sales Order, Customer Reference (VR01), or a Statement Number. To be used with Know Invoice Algorithms R03B50D & R03B50E. Controlled by processing option on how to search what is entered in the field. This field or the Document Number must be supplied if using Know Invoice Algorithms R03B50D & R03B50E.
VR01 | Receipt Reference | Will be output on the receipt to the receipt reference.
ICUT | Batch Type | If left blank the upload UBE will assign as 9B. If supplied must be set to "9B"
DIC# | Batch Date- CTRY | If left blank the upload UBE will assign. If supplied Set to 19, 20
DICJ | Batch Date | If left blank the upload UBE will assign the current system date. If supplied Date of the batch set when the batch number is assigned
AN8 | Address Number | Address Book Number of the customer to be matched if supplied will be used as a filter in Know Invoice Match R03B50D & R03B50E. Also if customer’s Bank Transit/Acct not supplied and Know Invoice number not entered system will use this address number as the Payor number for the receipt.
DG# | G/L Date- CTRY | Century of the G/L date of the receipt. Will be defaulted from processing option on R03B13Z1I Update Receipt.
DGJ | G/L Date | The G/L date of the receipt. Will be defaulted from processing option on R03B551 Update Receipt Register (JDE Date).
DMTM | Check/Item Date- MO | Month of the receipt date. Will be defaulted from check date DMTJ
DMTD | Check/Item Date- DA | Day of the receipt date. Will be defaulted from check date DMTJ
DMTY | Check/Item Date- YR | Year of the receipt date. Will be defaulted from check date DMTJ
DMT# | Check/Item Date- CTRY | Century of the receipt date. Will be defaulted from check date DMTJ
DMTJ | Check/Item Date | Date of the receipt. Will be defaulted from the G/L date. (JDE Date)
AG | Gross Amount | If using R03B50D Know Invoice with Amount. This is the amount to be applied to the invoice. Foreign or Domestic
FAP | Foreign Open Amount | Not Used will be dropped from database in future release.
RMK | Remark | Output to the receipt header.
GLBA | G/L Bank Account | Will be default from AAI or processing option on R03B13Z1I Update Receipt Register. Used to post deposit amount to bank.
AM | Account Mode | Leave *BLANK will be loaded by R03B13Z1I Update Receipt Register.
CO | Company Number | Defines company number for receipt. Will be defaulted from processing options on R03B13Z1I Update Receipt Register.
CRCD | Currency Code | If currency *ON defines the currency of the receipt. Will default from the customer master or the company base currency.
CRR | Exchange rate | Exchange rate of the receipt. If Blank system defaults F0030 table rate based on receipt date.
CRRM | Currency Mode | Defines if receipt is ‘F’ foreign or ‘D’ domestic. If left blank and currency code different then base currency will be set to F else D. If currency not *ON must be left *BLANK.
CBNK | Customer Bank Account Number | If Customer Bank account/Transit supplied and Address number not entered system will use Bank Table F0030 to assign customer number if bank account/transit found.
TNST | Customer Bank Transit Number | See Customer Bank Account above.
EHBK | Home Bank Account Number | Company’s Bank Account. If supplied will be use to retrieve Company Bank record from F0030 table to assign Company number and Bank Account.
EHTN | Home Bank Transit Number | See Home Bank Account above.
PYIN | Payment Instrument | If supplied will be assigned to receipts payment instrument.


Batch Invoice Processing

Tables: F03B11Z1 and F0911Z1

Date: July 25, 2003

General Information

Purpose of Transaction

Invoice Processing transactions are used to record invoice information when charging a customer for products or services. On the inbound side, this transaction is used to update OneWorld® tables with invoice information. Outbound transactions are not supported.

The permanent OneWorld® tables primarily affected by this transaction are the Customer Ledger table (F03B11) and the Account Ledger table (F0911). The fields in the F0911T have been merged into the F0911 as of ERP 9.0 and the F0911T no longer exists.

Relationships to Other Transactions

Journal Entries, A/P Vouchers and A/R Invoices all use the F0911Z1 file. A/R Invoices will have an EDI - Transaction Type equal to "I". Journal Entry transactions will have an EDI - Transaction Type equal to "J" and A/P Vouchers will have an EDI - Transaction Type equal to "V".

Transaction-Specific Instructions

The inbound transaction supports additions only.

This transaction uses two interface tables - Two Details (F03B11Z1 and F0911Z1). The F03B11Z1 contains information about the invoice and will process into the A/R Ledger. The F0911Z1 contains G/L distribution information and will process into the Account Ledger. The fields in the F0911Z1T have been merged into the F0911Z1 as of ERP 9.0 and the F0911Z1T no longer exists. These CMS related fields will still only be used if the Cost Management System is enabled.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld® - Table F03B11Z1 - Detail

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld®, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (Invoices to be uploaded), this column must be populated to differentiate each line within a given transaction. Pad with zeroes to three characters and number according to the pattern 001, 002, etc.
EDTR | Transaction Type | A code that identifies a particular type of transaction. This field must be = "I".
EDTC | Transaction Action | "A" = add.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld® updates this to a "1". This field must initially be zero.

Additional Comments

The following columns EDUS, EDBT, and EDTN must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld®. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld® to accept the transaction.

Data Item | Description | Notes
AN8 | Customer Number | Valid customer number in F0101
CO | Company | Valid customer number (in F03012) padded with zeroes to five digits
DIVJ | Invoice Date | Julian invoice date. See Note 1.
DIM | Invoice Date - MO | Invoice month. See Note 1.
DID | Invoice Date - DA | Invoice day. See Note 1.
DIY | Invoice Date - YR | Invoice year. See Note 1.
DI# | Invoice Date - CTRY | Invoice century. See Note 1.
DGJ | G/L Date | Julian G/L date. See Note 1.
DGM | G/L Date - MO | G/L month. See Note 1.
DGD | G/L Date - DAY | G/L day. See Note 1.
DGY | G/L Date - YR | G/L year. See Note 1.
DG# | G/L Date - CTRY | G/L century. See Note 1.
DSVJ | Service/Tax Date | Julian service/tax date. See Note 1.
DSVM | Serv/Tax - MO | Service/Tax month. See Note 1.
DSVD | Serv/Tax - DA | Service/Tax day. See Note 1.
DSVY | Serv/Tax - YR | Service/Tax year. See Note 1.
DSV# | Serv/Tax - CTRY | Service/Tax century. See Note 1.
AG | Gross Amount | See Note 2.
ATXA | Taxable Amount | See Note 2.
ACR | Currency Amount | See Note 3.
CTXA | Foreign Taxable Amount | See Note 3.
PST | Pay Status | P - Paid. The voucher or invoice is paid in full. A - Approved for payment, but not yet paid. This applies to vouchers and automatic cash applications. H - Hold pending approval. R - Retainage. % - Withholding applies. ? - Other codes. Validated against UDC 00/PY
CRRM | Mode | D - Domestic F - Foreign 3 - Mode 3 (Future)
CRCD | Currency Code | If in a multi-currency environment, this field must be set to the transaction currency. Validated against F0013.
AM | Account Mode | Populate with a 2.

Additional Comments

Note 1 - Invoice date, G/L date, and Service/Tax date can be populated either through a Julian date field or they can be built through a month/day/year/century combination. In each case, use EITHER the Julian field or all four individual pieces of the date.

Note 2 - For Domestic Invoices, either the Gross Amount or Taxable Amount is required.

Note 3 - For Foreign Invoices, either the Currency Amount or Foreign Taxable Amount is required.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
DOC | Document Number | Will comprise part of the key to the F03B11. The most defining portion of the key to the transaction in the target table. If specified, it must not cause a duplicate entry in F03B11. If left blank, OneWorld® will assign it.
DCT | Document Type | Will comprise part of the key to the F03B11. If left blank, OneWorld® will assign it. Validated against UDC 00/DT.
KCO | Key Company | Will comprise part of the key to the F03B11. If left blank, OneWorld® will assign it. Must be a valid company in F0010.
SFX | Pay Item | Will comprise part of the key to the F03B11. If left blank, OneWorld® will assign it.
ADSC | Discount Available | Enter an amount to represent the discount available for a domestic invoice. If left blank, OneWorld® will assign it based upon the payment terms used.
CDS | Foreign Discount Available | Enter an amount to represent the discount available for a foreign invoice. If left blank, OneWorld® will assign it based upon the payment terms used.
CRR | Exchange Rate | If left blank, OneWorld® will assign this based upon the transaction date, base currency and transaction currency.
TXA1 | Tax Rate/Area | Enter a valid tax rate/area if taxes are to be calculated. Validated against F4008.
EXR1 | Tax Explanation Code | Enter a valid tax explanation code if taxes are to be calculated. Validated against UDC 00/EX.
PTC | Payment Terms Code | Enter a valid payment terms code. If left blank, OneWorld® will assign this based on company constants. Validated against F0014.
DDJ | Due Date | Enter a Julian date. See Note 1.
DDM | Due Date - MO | Due date month. See Note 1.
DDD | Due Date - DA | Due date day. See Note 1.
DDY | Due Date - YR | Due date year. See Note 1.
DD# | Due Date - CTRY | Due date century. See Note 1.
DDNJ | Discount Due Date | Enter a Julian date. See Note 1.
DDNM | Discount Due Date - MO | Discount due date month. See Note 1.
DDND | Discount Due Date - DA | Discount due date day. See Note 1.
DDNY | Discount Due Date - YR | Discount due date year. See Note 1.
DDN# | Discount Due Date - CTRY | Discount due date century. See Note 1.
RMK | Remark | 30 character string field that may be used additional comments.
URC1 | User Reserved Code | 3 character string for a user-defined code
URDT | User Reserved Date |
URAT | User Reserved Amount |
URAB | User Reserved Number |
URRF | User Reserved Reference | 15 character string field

Additional Comments

Note 1 - Due Date and Discount Due Date can be populated either through a Julian date field or they can be built through a month/day/year/century combination. In each case, use EITHER the Julian field or all four individual pieces of the date.

Column-Specific Instructions - Into OneWorld® - Table F0911Z1 - Detail

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld®, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (Invoices to be uploaded), this column must be populated to differentiate each line within a given transaction. Pad with zeroes to three characters and number according to the pattern 001, 002, etc.
EDTR | Transaction Type | A code that identifies a particular type of transaction. This field must be = "I".
EDTC | Transaction Action | "A" = add.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld® updates this to a "1". This field must initially be zero.

Additional Comments

The following columns EDUS, EDBT, and EDTN must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld®. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld® to accept the transaction.

Data Item | Description | Notes
AN8 | Customer Number | Valid customer number from F03012.
CO | Company | Valid customer number padded with zeroes to five digits. Validated F0010.
DIVJ | Invoice Date | Julian invoice date. See Note 1.
DIM | Invoice Date - MO | Invoice month. See Note 1.
DID | Invoice Date - DA | Invoice day. See Note 1.
DIY | Invoice Date - YR | Invoice year. See Note 1.
DI# | Invoice Date - CTRY | Invoice century. See Note 1.
DGJ | G/L Date | Julian G/L date. See Note 1.
DGM | G/L Date - MO | G/L month. See Note 1.
DGD | G/L Date - DAY | G/L day. See Note 1.
DGY | G/L Date - YR | G/L year. See Note 1.
DG# | G/L Date - CTRY | G/L century. See Note 1.
DSVJ | Service/Tax Date | Julian service/tax date. See Note 1.
DSVM | Service/Tax - MO | Service/Tax month. See Note 1.
DSVD | Service/Tax - DA | Service/Tax day. See Note 1.
DSVY | Service/Tax - YR | Service/Tax year. See Note 1.
DSV# | Service/Tax - CTRY | Service/Tax century. See Note 1.
AA | Amount | See Note 2.
ACR | Foreign Amount | See Note 2.
CRRM | Mode | D - Domestic F - Foreign 3 - Mode 3 (future)
CRCD | Currency Code | Validated against F0013.
AM | Account Mode | 1. - The short ID number 2. - The standard long account number 3. - The long (unstructured, 24-byte number)
ANI | Account Number | Valid account number corresponding to the account mode specified. Validated from F0901.
LT | Ledger Type | A user defined code that specifies the type of ledger, such as AA (Actual Amount), BA (Budget Amount), or AU (Actual Units). For Batch Invoices always use AA regardless of whether the invoice is foreign or domestic.
EXA | Explanation | Any non-blank and non-null string

Additional Comments

Note 1 - Invoice date, G/L date, and Service/Tax date can be populated either through a Julian date field or they can be built through a month/day/year/century combination. In each case, use EITHER the Julian field or all four individual pieces of the date.

Note 2 - For Domestic Invoices, the Amount is required. For Foreign Invoice the Foreign Amount is required.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
DOC | Document Number | Will comprise part of the key to the F09B11. The most defining portion of the key to the transaction in the target table. If specified, it must not cause a duplicate entry in F03B11. If left blank, OneWorld® will assign it.
DCT | Document Type | Will comprise part of the key to the F09B11. If left blank, OneWorld® will assign it. Validated against UDC 00/DT.
KCO | Key Company | Will comprise part of the key to the F09B11. If left blank, OneWorld® will assign it. Validated against F0010.
SFX | Pay Item | Will comprise part of the key to the F09B11. If left blank, OneWorld® will assign it.
ADSC | Discount Available | Enter an amount to represent the discount available for a domestic invoice. If left blank, OneWorld® will assign it based upon the payment terms used.
CDS | Foreign Discount Available | Enter an amount to represent the discount available for a foreign invoice. If left blank, OneWorld® will assign it based upon the payment terms used.
TXA1 | Tax Rate/Area | Enter a valid tax rate/area if taxes are to be calculated. Validated against F4008.
EXR1 | Tax Explanation Code | Enter a valid tax explanation code if taxes are to be calculated. Validated against UDC 00/EX.
PTC | Payment Terms Code | Enter a valid payment terms code. If left blank, OneWorld® will assign this based on company constants. Validated against F0014.
DDJ | Due Date | Enter a Julian date. See Note 1.
DDM | Due Date - MO | Due date month. See Note 1.
DDD | Due Date - DA | Due date day. See Note 1.
DDY | Due Date - YR | Due date year. See Note 1.
DD# | Due Date - CTRY | Due date century. See Note 1.
DDNJ | Discount Due Date | Enter a Julian date. See Note 1.
DDNM | Discount Due Date - MO | Discount due date month. See Note 1.
DDND | Discount Due Date - DA | Discount due date day. See Note 1.
DDNY | Discount Due Date - YR | Discount due date year. See Note 1.
DDN# | Discount Due Date - CTRY | Discount due date century. See Note 1.
RMK | Remark | 30 character string field that may be used additional comments.
URC1 | User Reserved Code | 3 character string for a user-defined code
URDT | User Reserved Date |
URAT | User Reserved Amount |
URAB | User Reserved Number |
URRF | User Reserved Reference | 15 character string field

Additional Comments

Note 1 - Due Date and Discount Due Date can be populated either through a Julian date field or they can be built through a month/day/year/century combination. In each case, use EITHER the Julian field or all four individual pieces of the date.

Column-Specific Instructions -Into OneWorld® - Table F0911Z1. NOTE: Before ERP 9.0, these fields were in a separate tag file (F0911Z1T). As of ERP 9.0, the fields in the F0911Z1T have been merged into the F0911Z1 and the F0911Z1T no longer exists.

NOTE: These fields should only be populated if the Cost Management System is enabled.

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld®, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (Invoices to be uploaded), this column must be populated to differentiate each line within a given transaction. Pad with zeroes to three characters and number according to the pattern 001, 002, etc.

Additional Comments

The following columns EDUS, EDBT, and EDTN must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld®. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
PM01 | Managerial Posting Code 1 | Note: 10 fields are available - named PM01, PM02, etc.
ABT1 | Managerial Analysis Type 1 | Note: 4 fields are available - named ABT1, ABT2, etc. A user defined code (00/ST) that is used with the Managerial Analysis Code field to identify the type of managerial analysis code and the type of editing. On the User Defined Codes form, the second line of the description controls how the system performs editing. This is either hard-coded (as shown in the second line of description) or can be user defined. For example: A - Alphanumeric field, do not edit N - Numeric field, right justify and zero fill C - Alphanumeric field, right justify and blank fill U - User Defined Managerial Analysis Type
ABR1 | Managerial Analysis Code 1 | Note: 4 fields are available - named ABR1, ABR2, etc. A managerial analysis code can be, for example, an equipment item number or an address book number. If you enter a managerial analysis code, you must also specify the managerial analysis type. This field acts the same and is edited the same as the Subledger field. The difference is that the system does not post a managerial analysis code to the Account Balances file (F0902).
ITM | Item Number | An inventory item number. The system provides three separate item numbers plus an extensive cross reference capability to alternate item numbers (see data item XRT) to accommodate substitute item numbers, replacements, bar codes, customer numbers, supplier numbers, and so forth. The item numbers are: 1. - Item Number (short) - An eight-digit, computer assigned item number. 2. - 2nd Item Number - The 25-digit, free form, user defined alphanumeric item number. 3. - 3rd Item Number - Another 25-digit, free form, user defined alphanumeric item number.


BeforeLevelBreak

Last Modified: B733.2 | May 24, 1999

BeforeLevelBreak should be used to do processing after a fetch, but before any level breaks are checked.

Available On

  • This Event is available at Tabular Section Level event rules.

Typical Usage

This is used to process event rules at a stage where the records are fetched from the Database but nothing has been done to see if there should occur a level break.

Processing Sequence

  1. Advance Section

  2. Before Level Break

  3. Advance Section

  4. Tabular Break


Bill of Material

Table: F3002Z1

Date: October 30, 1998

General Information

Purpose of Transaction

Bill of material transactions are used to record the details of the specific components and quantities that are used to assemble parent items and provides the foundation for costing and planning activities. On the inbound side, this transaction is used to update OneWorld tables with bill of material information. On the outbound side, this transaction is used to generate records that that can be used by a third party to update their system with the bill of material information.

The permanent OneWorld table primarily affected by this transaction is the Bill of Material Master File (F3002).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions, changes, and deletions.

The outbound transaction supports additions, changes, and deletions.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F3002Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDEBOM"
TNAC | Action Code | "A" = add, "C" = change, "D" = delete (left justified)
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
KIT | Parent Item Short | Required - Validated against F4101
MMCU | Parent Branch | Required - Validated against F0006
BQTY | Batch Quantity | Required
TBM | Type of Bill | Required - User defined code 40/TB
CPNT | Component Line Number | Required
SBNT | Substitute Item Number Sequence | Required
COBY | Co-Product/By-Product | Required, blank is allowed - User defined code H40/CO

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
ITM | Component Item | This is not a key field but needed because bill is made of components. This field is validated against item master file F4101.
EFFF | Effective From Date | If left blank the default values will be defaulted by the Master BSFN. The date is also validated against data dictionary edits.
EFFT | Effective Thru Date | If left blank the default values will be defaulted by the Master BSFN. The date is also validated against data dictionary edits.
OPSQ | Operation Sequence | This field is also used most commonly and defines the sequence of operations performed on components to make a kit item. This field is also validated against data dictionary edits.

Column-Specific Instructions -From OneWorld - Table F3002Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDEBOM"
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.

Data Columns

Data columns in the interface table from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld " section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.


Budget Balance Batch Processing

Table: F0902Z1

Date: February 1, 1999

General Information

Purpose of Transaction

Budget transactions are used to add or adjust period, requested, approved and/or final account balances for Accounts of Budget Ledger type. On the inbound side, this transaction is used to update OneWorld tables with budget information. Outbound transactions are not supported.

The permanent OneWorld table affected by this transaction is the Account Balance table (F0902)

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions and updates only.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F0902Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
CTID | Machine Key | Suggested use is to identify the computer ID that processed the records.
IST | Batch Status | When processing for this transaction is complete, OneWorld updates this to a "D". This field must be blank.

Additional Comments

The first two columns (EDUS and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
AID | Account ID | Short Account ID.
CTRY | Century |
FY | Fiscal Year |
FQ | Fiscal Quarter | Obsolete
LT | Ledger Type | Ledger type of the transaction - User defined code 09/LT
SBL | Subledger |
SBLT | Subledger Type | Subledger type - User defined code 00/ST
CRCD | Currency Code | Currency code of transaction if foreign. Validated against table F0013.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
CO | Company | Validated against table F0010.
AN01 | Net Amount Period 01 |
AN02 | Net Amount Period 02 |
AN03 | Net Amount Period 03 |
AN04 | Net Amount Period 04 |
AN05 | Net Amount Period 05 |
AN06 | Net Amount Period 06 |
AN07 | Net Amount Period 07 |
AN08 | Net Amount Period 08 |
AN09 | Net Amount Period 09 |
AN10 | Net Amount Period 10 |
AN11 | Net Amount Period 11 |
AN12 | Net Amount Period 12 |
AN13 | Net Amount Period 13 |
AN14 | Net Amount Period 14 |
BORG | Original/Beginning Budget | Final Budget Amount.
BREQ | Requested Budget |
BAPR | Approved Budget |
MCU | Business Unit | Validated against table F0006.
OBJ | Object Account |
SUB | Subsidiary |

Additional Comments

Period amounts should be used when the annual amounts are not used. The annual amounts should be used if period amounts are not used.


Callback Function Format1.htm

Callback Function Format 1

Last Modified: EnterpriseOne | June 06, 2006

This is the function prototype of callback functions, which is used by event types for start and end of documents.

Syntax

XRCS_CallbackStatus ( * PCALLBACK_FORMAT1) ( void *pContext);

Parameters

pContext

Input. A pointer to the context, which was specified during setup.


Callback Function Format2.htm

Callback Function Format 2

Last Modified: EnterpriseOne | June 06, 2006

This is the function prototype of callback functions, which is used by the event type for start of an element. The attribute information is returned in an array. If no attribute information exists, the number of elements is set to zero, and the array pointer is set to NULL.

Each element of the attribute array consists of the data structure XRCS_ATTR_INFO. That structure contains three null-terminated strings: one for the local name of the attribute, one for the qualified name of the attribute, and one for the value of the attribute.

Syntax

XRCS_CallbackStatus ( * PCALLBACK_FORMAT2) (

void * pContext,

const JCHAR * szUri,

const JCHAR * szLocalname,

const JCHAR * szQname,

unsigned int nNumAttrs,

const XRCS_ATTR_INFO * pAttributes

);

Parameters

pContext | Input. A pointer to the context, which was specified during setup.
szUri | Input. A null-terminated string for URI (namespace).
szLocalname | Input. A null-terminated string for local name.
szQname | Input. A null-terminated string for qualified name.
nNumAttrs | Input. The number of elements in the array of attribute information.
pAttributes | Input. An array of attribute information.


Callback Function Format3.htm

Callback Function Format 3

Last Modified: EnterpriseOne | June 06, 2006

This is the function prototype of callback functions, which is used by the event type for end of element.

Syntax

XRCS_CallbackStatus ( * PCALLBACK_FORMAT3) (

void * pContext,

const JCHAR * szUri,

const JCHAR * szLocalname,

const JCHAR * szQname

);

Parameters

pContext | Input. A pointer to the context, which was specified during setup.
szUri | Input. A null-terminated string for URI (namespace).
szLocalname | Input. A null-terminated string for local name.
szQname | Input. A null-terminated string for qualified name.


Callback Function Format4.htm

Callback Function Format 4

Last Modified: EnterpriseOne | June 06, 2006

This is the function prototype of callback functions, which is used by event types for characters and ignorable white space. For the event type of the characters, the complete character string is returned, even if the SAX parser returns it to the XercesWrapper code as a series of partial strings.

The event for ignorable white space occurs only when using schemas and other special features. This version of the SAX parser interface does not include a method to set up schemas. Therefore, any callback functions which are set up for ignorable white space will never be called. After schema-setup is added in a later version, the ignorable white space callbacks will be called. Without schemas, all text is returned using the event type for the characters.

Syntax

XRCS_CallbackStatus ( * PCALLBACK_FORMAT4) (

void * pContext,

const JCHAR * szText

);

Parameters

pContext | Input. A pointer to the context, which was specified during setup.
szText | Input. A null-terminated character string.


Callback Function Format5.htm

Callback Function Format 5

Last Modified: EnterpriseOne | June 06, 2006

This is the function prototype of callback functions, which is used by event types for warnings, errors, and fatal errors. The enum for callback type makes it possible for one callback function to handle all three error types. The line and column numbers are approximate, and may point to the position following the actual error. That is because the SAX parser may have already moved its pointers to the next element, before an error is encountered with the current element.

The XML file name is usually found in either szPublicId or szSystemId. The other one is usually an empty (zero-length) string. The error message text (szMessage) is sometimes an empty (zero-length) string.

Syntax

XRCS_CallbackStatus ( * PCALLBACK_FORMAT5) (

void * pContext,

XRCS_CallbackType eCallbackType,

int nLineNum,

int nColNum,

const JCHAR * szPublicId,

const JCHAR * szSystemId,

const JCHAR * szMessage

);

Parameters

pContext | Input. A pointer to the context, which was specified during setup.
eCallbackType | Input. An enum indicating type of error event.
nLineNum | Input. A line number where error occurred.
nColNum | Input. The column number where error occurred.
szPublicId | Input. The null-terminated name of XML file.
szSystemId | Input. The null-terminated name of XML file.
szMessage | Input. The null-terminated text of error message.


Callback Functions.htm

Callback Functions

Last Modified: EnterpriseOne | June 06, 2006

Because the available data is different for each event type, the callback functions have specified parameter lists (function prototypes), based upon the associated type of SAX parsing event. All callback functions receive the context pointer, which was set up before parsing begins. Additional parameters correspond to the type of event.

All values passed into the callback functions must be considered temporary. If the data needs to be kept, it should be copied elsewhere. Data should never be saved using a reference pointer to the passed-in data. Also, the passed-in data must never be modified. That memory, used to pass data into the callback functions, will either be freed or reused upon return from the callback function.

All callback functions return an enum value, which indicates whether the parsing should continue or terminate. Whenever a callback function requests a termination, the XML parsing will stop, and the parse function itself will return an error code.

The context pointer must always be cast to (void *). The callback function must always be cast to (void *). Without the (void *) casts, the code will work on most systems. However, it will not build on Linux systems without the explicit casts.


Condition-Based Alerts

Table: F1310Z1

Date: January 30, 2004

General Information

Purpose of Transaction

Condition-based alerts transactions are used to record the alert condition of a piece of equipment. This alert is used within the EnterpriseOne system to trigger investigation of the equipment and/or a resulting response (i.e. work order creation or maintenance work). On the inbound side, this transaction is used to update EnterpriseOne tables with condition-based alert information and optionally perform any automated processing such as creating work orders or updating the preventive maintenance system.

The permanent EnterpriseOne table primarily affected by this transaction is the Condition Based Alerts (F1310) table.

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions only.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into EnterpriseOne - Table F1310Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into EnterpriseOne, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "CBMALERT”
TNAC | Action Code | "A" = add (left justified)
DRIN | Direction Indicator | "1" = into EnterpriseOne (inbound). This indicates that the record was written by a system external to EnterpriseOne with the intent of pushing the transaction into EnterpriseOne.
EDSP | Processed flag | When processing for this transaction is complete, EnterpriseOne updates this to a "Y".

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to EnterpriseOne. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for EnterpriseOne to accept the transaction.

Data Item | Description | Notes
NUMB | Asset Item Number | This field may be required if the processing options for the Inbound Condition Based Alerts (R1310Z1I) program indicates the equipment number is used for validation and display.
APID | Unit Number | This field may be required if the processing options for the Inbound Condition Based Alerts (R1310Z1I) program indicates the unit number is used for validation and display.
ASID | Serial Number | This field may be required if the processing options for the Inbound Condition Based Alerts (R1310Z1I) program indicates the serial number is used for validation and display.
PRODM | Product Model | This field may be required if the processing options for the Inbound Condition Based Alerts (R1310Z1I) program indicates the serial number used for validation and display. Product model is used in conjunction with the serial number to determine a unique equipment record.
TYRP | Automated Response Type | Required - This field is validated against UDC 13/AR (Automated Response Type).
DL01 | Alert Description | Required
EVTDT | Event Date | This field may be required if the Event Time UTC (EVTUTC) field is not passed into the system. The system will first check the Event Time UTC field to determine the Event Date and Time. If one does not exist, then this Event Date field is required. See also: EVTUTC in the frequently used optional data columns section below.
EVTTM | Event Time | This field may be required if the Event Time UTC (EVTUTC) field is not passed into the system. The system will first check the Event Time UTC field to determine the Event Date and Time. If one does not exist, then this Event Time field is required. See also: EVTUTC in the frequently used optional data columns section below.
PDFL | Alert Level | Required - This field is validated against UDC 13/AL (Alert Level). This field must be populated with a non-blank value.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item

Description

Notes and default logic

MELC

Measurement Location

A code used to define a measurement location on a piece of equipment. This code can be used to indicate where on the equipment a measurement or alert originated from. This field is validated against UDC 13/LC (Measurement Location).

EVTUTC

Event Time UTC

The time of an event, based on the Universal Time Coordinate (UTC). UTC Time is the number of seconds elapsed since Midnight on January 1, 1970 in Greenwich, England. UTC Time used to be called Greenwich Mean Time (GMT). If this field is passed in, the system will determine the Event Date and Event Time values for the condition-based alert record.

TIMEZONES

Time Zone

A code used to indicate the time zone. This field is used in conjunction with the date and time fields. This field is validated against UDC H91/TZ (Time Zones).

DSAVNAME

Daylight Savings Rule Name

Unique name identifying a daylight savings rule. Use daylight savings rules to adjust time for a geographic and political locale. This field is validated against the Daylight Savings Rules (F00085) table.

SNDN

Send Notification Message

A code that indicates whether a notification message is sent when a condition-based alert is entered into the system. Enter a value of 1 or Y to send a notification message. Enter a value of 0 or N to not send a notification message.

NOTR

Notification Recipient

An address book number that identifies the recipient of an alert notification message. This number can be a single person, or a distribution list. The system validates this number against the Address Book (F0101) table. If you don’t pass a number into this field, and you are sending a notification message, the system will attempt to retrieve a notification recipient from the message sequences and message rules setup. Message sequences can be setup using the Condition-Based Message Sequences (P1315) program. Message rules can be setup using the Condition-Based Maintenance Message Rules (P1316) program.

NSTT

Notification Structure Type

A user defined code (01/TS) that identifies a type of organizational structure that has its own hierarchy in the Address Book system (for example, e-mail). Use this field when you wish to send a notification message to a distribution list. This field is validated against UDC 01/TS (Parent/Child Structure Type). Note: This field can be loaded automatically from condition-based message rules. Please see the Notification Recipient notes above for more information.

INVR

Investigation Recipient

An address book number that identifies the recipient of an alert investigation request. This number can be a single person, or a distribution list. The system validates this number against the Address Book (F0101) table. If you don’t pass a number into this field, and you are sending an investigation message, the system will attempt to retrieve an investigation recipient from the message sequences and message rules setup. Message sequences can be setup using the Condition-Based Message Sequences (P1315) program. Message rules can be setup using the Condition-Based Maintenance Message Rules (P1316) program.

ISTT

Investigation Structure Type

A user defined code (01/TS) that identifies a type of organizational structure that has its own hierarchy in the Address Book system (for example, e-mail). Use this field when you wish to send an investigation message to a distribution list. This field is validated against UDC 01/TS (Parent/Child Structure Type). Note: This field can be loaded automatically from condition-based message rules. Please see the Investigation Recipient notes above for more information.

DOCO

Model Work Order

A number that identifies a model work order. This field is used when the Automated Response Type field is set to a ‘3’. This field is validated against the Work Order Master (F4801) table.

SRVT

Service Type

A code that indicates the preventive maintenance service to be performed. This field is validated against UDC 12/ST (Service Types).

If the Automated Response Type field is set to a ‘3’, the system uses this code, in conjunction with the equipment number, to retrieve the default values for maintenance rules from the Maintenance Rules table (F1393).

If the Automated Response Type field is set to a ‘4’, the system uses this code, in conjunction with the equipment number, to update the Maintenance Schedule File (F1207) table with the alert level from the condition-based alert.


ClearSpace

Last Modified: B733

ClearSpace occurs when a section reaches its end. If there is a need to process any information at the time a Section is completed, this is the event at which to attach the ER.

Available On

  • This event is available at the Section Level ER.

Typical Usage

This event is used to perform some tasks that need to be done after a section is completed.

Processing Sequence

  1. End Section

  2. Clear Space


ColumnInclusion

Last Modified: B733

ColumnInclusion occurs right after a record is fetched.


Customer Master

Table: F03012Z1

Date: November 2, 1998; updated May 2003

General Information

Purpose of Transaction

Customer Master transactions are used to maintain information about customer information and processing instructions that ERP uses to process accounts receivable transactions. On the inbound side, this transaction is used to update ERP tables with customer information. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the customer information.

The permanent ERP tables primarily affected by this transaction is the Customer Master table (F0301) and the Customer Master by Line of Business table (F03012).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions, changes, and deletions.

The outbound transaction supports additions, changes, and deletions. For changes, both the before and after images can be written.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into ERP - Table F03012Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into ERP, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction (for example, JDECM)
TNAC | Action Code | "A" = add, "C" = change, "D" = delete (left justified)
DRIN | Direction Indicator | "1" = into ERP (inbound). This indicates that the record was written by a system external to ERP with the intent of pushing the transaction into ERP.
EDSP | Processed flag | When processing for this transaction is complete, ERP updates this to a "Y".

Additional Comments

The following columns EDUS, EDBT, and EDTN must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to ERP. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for ERP to accept the transaction.

Data Item | Description | Notes
AN8 | Customer Number | A number that identifies a customer in the Address Book system.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
ALKY | Long Address Number | A user defined name or number that is unique to the address book number. You can use this field to enter and locate information. You can use it to cross reference the supplier to a Dun & Bradstreet number, a lease number, or another reference.
SITO | Send Invoice To | A user defined code (H00/SI) that identifies the address where accounts receivable invoices are sent (for example: C = Customer, P = Parent)
TRAR | Payment Terms | A code that indicates the default payment terms for a customer. Payment terms determine due dates and discounts, and are used as a default value when you create invoices. Validated against table F0014.
CRCA | A/B Amount Codes | The currency in which amounts are stored. The currency you specify is used to record and store transaction history. Validated against table F0013.
ACL | Credit Limit | The credit limit for a customer.
CRCD | Currency Code | Default transaction currency. Validated against table F0013.

Column-Specific Instructions - From ERP - Table F03012Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from ERP, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within ERP.
EDTN | User Transaction Number | Transaction number generated within ERP to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by ERP as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction (for example, JDECM)
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from ERP (outbound). This indicates that the record was written by ERP to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, ERP updates this to a "Y". For outbound transactions from ERP, these are flagged complete when process log records are written to table F0046.

Data Columns

Data columns in the interface from ERP (outbound) have the same definitions as they do for transactions coming into ERP (inbound). Refer to the "Into ERP" section for descriptions of required and frequently used columns. Unless otherwise specified, ERP provides all columns from the corresponding source table.

ERP 9.0 Data

The following fields are added to Table F03012Z1 for ERP 9.0.

Data Item | Description | Notes
PRGF | Ready for Purge Flag | Reserved by J.D. Edwards
BYAL | Bypass Audit Logging | An option that specifies whether to bypass the audit logging process for sales order changes.
BSC | Buying Segment Code | A value that groups customers with similar buying habits.
ASHL | Allow Shipping of Held Lots | An option that indicates whether the system can ship lots that are on hold. If you do not choose this option, the system does not ship lots that are on hold.
PRSN | Preference Schedule | A user defined code (40/AP) that identifies the advanced preference schedule that the system uses when resolving preferences. The advanced preference schedule determines which preferences the system resolves when using the advanced preference functionality. You cannot maintain preference schedules directly through user defined codes, but you can maintain preference schedules by using the Price Adjustment Schedule program (P4070).
OPBO | OP Business Objective | A value that specifies a default business objective to send outbound to order promising before an order has been promised. A business objective is a grouping of business rules that fulfill a sales order. For sales order detail lines, this value specifies the business objective that is selected by order promising after an order has been promised.
APSB | APS Business Unit | Future use – APS An option that indicates that the business unit or branch/plant is an APS location.


Cycle Counts

Table: F4141Z1

Date: August 31, 1998

General Information

Purpose of Transaction

Cycle count transactions are used to record data such as item numbers, descriptions, locations, and quantities, which are used to update online inventory records. On the inbound side, this transaction is used to update OneWorld tables with item-based inventory counting information. Outbound transactions are not supported through this table.

The permanent OneWorld tables primarily affected by this transaction are the Cycle Count Header table (F4140) and the Cycle Count Transaction table (F4141) updated through Cycle Count Unedited Transactions Inbound Processor (R4141Z1I). Ultimately, the transactions will be processed by Cycle Count Update (R41413), which updates the quantity on hand in the Item Location table (F41021) with any variance found between the quantity on hand and the counted quantity. The variances are also written to the Item Ledger (F4111) and Account Ledger (F0911) tables.

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions only.

If the cycle count is for an existing item/location then the Reset Frozen Value row exit from Cycle Count Review (P41240) should be used to populate the Quantity - Total Primary on Hand (TQOH) and Amount - Total Primary on Hand (TAOH) fields in F4141 before processing through Cycle Count Update. Otherwise the entire quantity counted will be considered a variance.

Quantity - Total Primary on Hand (TQOH), Amount - Total Primary on Hand (TAOH), Amount - Unit Cost (UNCS), Amount - Total Primary Counted (TACT) and Quantity - Total Primary Counted (TQCT) should be populated with zero. Aisle (AISL) and Bin (BIN) should be populated with a valid value or blanks. Category - G/L (GLPT) should be populated with a value from the 41/9 UDC table.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F4141Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDECYCLE".
TNAC | Action Code | "A", "00", or "02 for Add.
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
ITM | Item Number - Short | If provided, must exist in F4101
LITM | 2nd Item Number | If provided, must exist in F4101
AITM | 3rd Item Number | If provided, must exist in F4101
MCU | Branch/Plant | Must exist in Item Branch File (F4102)
LOCN | Location |
LOTN | Lot/Serial Number |
STUN | Storage Unit Number | (Only used by Warehouse items)
TRQT | Quantity Available | Quantity counted, not necessarily in primary UOM
UOM | Unit of Measure as Input | UDC values from 00/TT, the unit of measure of the Quantity Available field

Additional Comments

One of the first three columns (ITM, LITM, or AITM) must be populated.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and Default logic
EDCT | EDI Document Type |
EDFT | EDI - Translation Format |
EDDT | EDI - Transmission Date |
EDDL | EDI - Detail Lines Processed |
PNID | Trading Partner ID |
CYNO | Cycle Count Number | The most defining portion of the key to the transaction in the target table. If specified, it must not cause a duplicate entry in the target table. Otherwise the value should be zero and OneWorld will assign a Cycle Count Number and create a Cycle Count Header (F4140) record.
CCCD | Cycle Count Code | Assigned the value of "1" by R4141Z1I which indicates the item has been counted.
SRP1 | Sales Catalog Section | UDC values from 41/S1. May be used to filter records in Cycle Count Entry (P4141) or in data selection when running Cycle Count Update (R41413)
SRP2 | Sub Section | UDC values from 41/S2. May be used to filter records in Cycle Count Entry (P4141) or in data selection when running Cycle Count Update (R41413)
SRP3 | Sales Category Code 3 | UDC values from 41/S3. May be used to filter records in Cycle Count Entry (P4141) or in data selection when running Cycle Count Update (R41413)
SRP4 | Sales Category Code 4 | UDC values from 41/S4. May be used to filter records in Cycle Count Entry (P4141) or in data selection when running Cycle Count Update (R41413)
SRP5 | Sales Category Code 5 | UDC values from 41/S5. May be used to filter records in Cycle Count Entry (P4141) or in data selection when running Cycle Count Update (R41413)
CNTJ | Date - Counted | May be used to filter records in Cycle Count Entry (P4141) or in data selection when running Cycle Count Update (R41413)
CNTB | Counted By | May be used to filter records in Cycle Count Entry (P4141) or in data selection when running Cycle Count Update (R41413)


deGTAddUpdate_Image_jdeGTAddUpdate_ImageKeyStr.htm

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function adds or updates image record types to the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_Image(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_ImageKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structures that stores the data to be updated.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

Parameter pData in MODATA must contain a valid pointer to update the text or shortcut media object type.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_ImageKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_Image(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


Detail Forecast

Table: F3460Z1

Date: October 30, 1998

General Information

Purpose of Transaction

Detail forecast transaction are used to project demand at the single-item level according to each item’s individual history. On the inbound side, the transaction is used to update OneWorld tables with detail forecast information. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the detail forecast information.

The permanent OneWorld table primarily affected by this transaction is the forecast File (F3460).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions, changes, and deletions.

The outbound transaction supports additions, changes, and deletions. For changes, both the before and after images can be written.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F3460Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDEFC"
TNAC | Action Code | "A" = add, "C" = change, "D" = delete (left justified)
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
MCU | Branch/Plant | Branch Plant for the Item Number. Validated against "Item Branch File" (F4102).
TYPF | Forcast Type | UDC values from 34/DF, Forecast Type for the Item Number.
DRQJ | Requested Date | Requested Date for Forecast. Validated against standard Data Dictionary edits.
AN8 | Address Number | Customer Number for the Forecast. Blank for all Customers. Validated against standard Data Dictionary edits.
ITM | Item Number - Short | See Note 1.
LITM | 2nd Item Number | See Note 1.
AITM | 3rd Item Number | See Note 1.

Additional Comments

Note 1 - One of the three columns (ITM, LITM and AITM) must be populated. Entered column is validated against "Item Master File" (F4101).

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and Default logic
DCTO | Order Type | Validated against standard Data Dictionary edits. If left blank, defaults the value "FC".
BPFC | Bypass Forcing | Validated against standard Data Dictionary edits. If left blank, defaults the value "N".

Column-Specific Instructions - From OneWorld - Table F3460Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and Default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDEFC"
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.

Data Columns

Data columns in the interface table from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld " section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.


Distribution

Home | Financial | HR Payroll | Logistics | Manufacturing

Distribution Interface Tables

Distribution Interoperability Interface Table consist of the following:

Outbound Sales Order Entry

Outbound Shipment Confirmation

Purchase Order Entry

Purchase Order Receipts


DoBalanceAuditor

Last Modified: B733.1 | April 19, 1999

Event Rules for this event process form interconnect information and generate the Balance Auditor link information to be displayed in the PDF file.

Available On

  • This event is available at the section level of the tabular sections.

Typical Usage

Generally, the event rules for this event will be automatically generated through the Balance Auditor setup screens accessed through the section properties dialog. If this is the case, only form interconnect event rules will be written. This is the only event that form interconnect event rules are supported.

Additional Notes

While most of the event rules for this event will be automatically generated, the user does have the option to add their own custom logic. Users must realize that this event only processes for numeric variables in tabular sections. Although the event is accessed at the section level of event rule, it actually occurs during the object processing.

Processing Sequence

  1. InitObject

  2. DoObject

  3. DoBalanceAuditor (only if the current object is numeric and the current section is tabular)

  4. EndObject


DoColumnHeading

Last Modified: B733.1 | April 19, 1999

DoColumnHeading event will happen once for every column header that is printed on a report. This applies to both columnar and tabular style sections. This also applies to when column headers are reprinted after a page break has occurred. Regardless of why the column headings are printing, this event will be executed.

Available On

  • This event is available on column header objects only.

Typical Usage

Typically, this event would be used to conditionally change the value of the column header information to be printed.

Processing Sequence

  • Initialize Section

  • Advance Section

  • Do Section

  • DoColumnHeading (Once for every column header in the section)

  • Initialize Object

  • Do Object

  • End Object


DoSection

Last Modified: B733.2 | May 24, 1999

DoSection occurs after Advance Section after values have been assigned to print out to a printer or an output file. This event occurs before any information for the current record is written to the PDF file. This event occurs before DoCell (if Tabular cells exist) and before DoVariable/DoConstant.

Available On

  • Section level event rules.

Available Objects

  • All Section Level Objects and Global Variables.

Typical Usage

Typical usage is if there is a need for processing after the values have been assigned to print to the PDF file/printer. Here the values to be printed are ready and so if there is a need for post processing, this is the place to do it.

Processing Sequence

  1. Advance Section

  2. Do Section

  3. Do Object

  4. End Object

  5. Advance Section


DoTabularBreak

Last Modified: B733.2 | May 07, 1999

DoTabularBreak occurs when any of the business view fields set as level breaks change. This is only valid for tabular sections. Use this to do processing that requires a change of values in any of the level break fields.

Available On

  • This Event is available only in a Tabular Section with Tabular Breaks specified. Also this event is available only at the Section level event rules.

Available Objects

  • The available objects are the business columns and RV fields.

Typical Usage

The typical usage would be to do any processing that requires a change of value in any of the Level Break fields.

Additional Notes

The Level Break fields are always one of the sequencing (sorting) fields.

Processing Sequence

  1. Advance Section

  2. Do Tabular Break

  3. Do Section.


DoVariable

Last Modified: B733

DoVariable occurs just before the font and color are selected for the report object and before the value of the object is translated into a printable string of characters and output to the page. This is your last chance to manipulate the value or display attributes of the object before output.

Available On

  • This event is available at the Object Level.

Typical Usage

As this is the last chance to modify the value, typically it is used to reformat the value or update currency information.

Processing Sequence

  1. Init Variable

  2. Do Variable

  3. End Variable


Dynamic Logging APIs.htm

Dynamic Logging APIs

This section discusses dynamic logging APIs.

You use these APIs to call the dynamic logging functions. The APIs insert the filename and line number info into the log message that is output when the logging level changes. These logging levels affect what is written to the jdedebug.log files. The logging APIs will write messages to the jdedebug.log files to indicate the logging levels have changed

If you set any dynamic logging options using these APIs, those settings take precedence over the settings in the jde.ini file, but only for kernels that have been changed with these APIs. All other kernels use the jde.ini settings.


EndBrkSection

Last Modified: B733 | May 07, 1999

Event Rules attached to this event occur after a Level Break finishes. After the event has terminated, the Level Break Header begins processing.

Available On

  • The End Break Section Event is only visible to a section. It cannot be set for an object or the entire report.

Typical Usage

In order to process Event Rule logic immediately after a Level Break.

Processing Sequence

  1. Level Break finishes.

  2. Clears totals to accumulate new ones for next Break.

  3. Processes Level Breaks Header.


EndLvlBrkFooterSection

Last Modified: B733.2 | May 07, 1999

EndLvlBrkFooterSection should be used to do processing immediately after a level break footer.

Available On

  • The End Level Break Footer Section Event is only visible to a section. It cannot be set for an object or the entire report.

Typical Usage

In order to process Event Rule logic immediately after a Level Break Footer.

Processing Sequence

  1. Level Break Footer finishes.

  2. Process event rules for the End Level Break Footer.

  3. Begin Header Section for next Section.


EndLvlBrkHeaderSection

Last Modified: B733.2 | May 07, 1999

EndLvlBrkHeaderSection should be used to do processing immediately after a level break header.

Available On

  • The End Level Break Header Section Event is only visible to a section. It cannot be set for an object or the entire report.

Typical Usage

In order to process Event Rule logic immediately after a Level Break Header.

Processing Sequence

  1. Level Break Header finishes.

  2. Process event rules for the End Level Break Header.

  3. Begin processing objects for the body of section.


EndOfReport

Last Modified: B733

EndOfReport sends INIT_PAGE_FOOTER and INIT_REPORT_FOOTER messages.

Available On

This event is currently unavailable.

Typical Usage

The typical use of this event is to update the values of global variables after all the level one sections are processed and before Page Footer and Report Footer are processed.


EndPageHeader

Last Modified: B733.2 | May 07, 1999

EndPageHeader after the page header finishes processing. Use this to do processing immediately after a page header.

Available On

  • The End Page Header Event is only visible from a Page Header section.

Typical Usage

In order to process Event Rule logic immediately after a Page Header.

Additional Notes

This event can handle multiple Page Headers, as well as headers that reprint on a page break.

Processing Sequence

  1. A Page Break occurs

  2. Process Initial Page Header Section

  3. Process Do Section for Page Header

  4. Process End Page Header

  5. Check for another page header, if one exists then repeat


EndReportFooter

Last Modified: B733.2 | May 07, 1999

EndReportFooter occurs after the report footer processes. After processing finishes, the report terminates. Use this to do processing immediately after a report footer.

Available On

  • The End Report Footer Event is only visible from a Report Footer section.

Typical Usage

In order to process Event Rule logic immediately after a Report Footer.

Additional Notes

This event can handle multiple Report Footers.

Processing Sequence

  1. Process the Initial Report Footer Section event

  2. Process the Do Section for Report Footer event

  3. Process the End Report Footer event

  4. Check for another report header, if one exists then repeat


EndReportHeader

Last Modified: B733.2 | May 07, 1999

EndReportHeader occurs after the report header processes. Then the report processes the page header for a report. Use this to do processing immediately after a report header.

Available On

  • The End Report Header Event is only visible from a Report Header section.

Typical Usage

In order to process Event Rule logic immediately after a Report Header.

Additional Notes

This event can handle multiple Report Headers.

Processing Sequence

  1. Report processing begins

  2. Process the Initial Report Header Section event

  3. Process the Do Section for Report Header

  4. Process the End Report Header event

  5. Check for another report header, if one exists then repeat


EndSection

Last Modified: B733.2 | May 07, 1999

EndSection occurs after a batch process has completed processing the last set of section values. Use this to do processing immediately after a section ends. This event is useful for last record and end of file procedures.

Available On

  • The End Section Event is only visible to a section. It cannot be set for an object or the entire report.

Typical Usage

In order to process Event Rule logic immediately after a Section Ends.

Additional Notes

When a section is placed within a “parent” section, and is joined to the parent section by selected key values, it becomes a “child” section. The entire child section is processed for each associated set of parent section values. An EndSection event occurs each time the child section is completed.

Processing Sequence

  1. Section completes processing the objects within the section.

  2. Clears totals to accumulate new ones for next Section.

  3. Begin processing Section footer, if one exists.


EndVariable

Last Modified: B733.2 | May 07, 1999

EndVariable occurs immediately after the object has been processed, even if the object is invisible or suppressed.

Available On

  • This event is only available to report objects. It is not applicable to the entire report or sections within the report.

Typical Usage

After an object has been processed, event rule logic may be processed.

Processing Sequence

  1. Process the Report Variable object.

  2. Event Rule logic.

  3. Process next object.


Errors and Warnings.htm

Errors and Warnings

Last Modified: EnterpriseOne | June 06, 2006

After a parser fatal error, the parse function returns an error status, regardless of whether the callback functions return "continue" or "terminate." When the SAX parser encounters a fatal error, it first calls the fatal error callbacks, and then stops parsing.

If multiple fatal-error callbacks are set up, returning the "terminate" return code will skip the remaining callbacks and stop parsing immediately. If multiple fatal-error callbacks are set up, returning the "continue" return code will enable the remaining callbacks to run, and then stop parsing. If only one fatal-error callback is set up, then the return code does not matter because parsing will always stop after that callback finishes.

The SAX parser interface project did not change the threading capabilities of the XercesWrapper code. It uses the same initialization code as the DOM parser. Both parsers are not completely threadsafe, particularly for initialization and termination. The calling functions are responsible for all thread control.

If the MS Windows VC++ build uses the /W4 switch (warning level 4), the system will issue compiler warnings for the callback function casting, in the calls to XRCS_setCallback and XRCS_setCallbackWithOption. The /W4 switch appears to be the default for business function builds. To eliminate the warnings, add this block of code before the first call to XRCS_setCallback or XRCS_setCallbackWithOption. The block of code can be placed in a header file, if multiple files setting up callbacks exist:

#ifdef JDENV_PC

/* Do not display warning for callback functions -- ignore warning

* for conversion of function pointer to data pointer (void *).

* Compiler normally displays this warning when using /W4 warnings level.

*/

#pragma warning (disable:4054)

#endif


Financials Interface Tables

Home | Distribution | HR Payroll | Logistics | Manufacturing

Financial Interface Tables

Financial Interoperability Interface Tables Include the Following:

Address Book

Batch Cash Receipts

Batch Invoice Processing

Budget Balance Batch Processing

Condition-Based Alerts

Customer Master

Fixed Asset Master

Inbound Voucher

Journal Entry

Payment Order with Remittance

Supplier Master


Fixed Asset Master

Tables: F1201Z1, F1217Z1

Date: November 12, 1998

General Information

Purpose of Transaction

Fixed Asset Master transactions are used to record fixed asset information, which can be updated on a daily, monthly, quarterly, or annual basis. On the inbound side, this transaction is used to update OneWorld tables with fixed asset information. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the fixed asset information.

The permanent OneWorld tables primarily affected by this transaction are the Asset Master (F1201), Status History table (F1307), Parent History table (F1212), Equipment Master Extension table (F1217), Item Balances table (F1202) and the Location Tracking Table (F1204).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions, changes, and deletions.

The outbound transaction supports additions, changes, and deletions. For changes, both the before and after images can be written.

The Equipment Tag Interface table (F1217Z1) will contain records linked through a one-to-one relationship to the Asset Master Interface table (F1201Z1) when the transaction is a CSMS-based or CSMS-bound transaction. Other transactions from or for Equipment Management and Fixed Assets will not have a corresponding "child" record in this table. The one-to-one relationship is through the Asset Number (NUMB) within both tables.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F1201Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Type of the transaction. “JDEFA” = Fixed Assets “JDEEM” = Equipment Management “JDECSMS” = Customer Service Management
TNAC | Action Code | “02” = Add, “UA” = Change, “03” = Delete
DRIN | Direction Indicator | “1” = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".
EDTY | Record Type | Type of the record. “1” = Asset Master, “2” = Equipment Tag If the type is “1”, the inbound record will be placed into the F1201Z1. If the type is “2”, the inbound record will be placed into the F1217Z1.

Additional Comments

The following columns EDUS, EDBT, and EDTN must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
NUMB | Asset Number | An 8-digit number that uniquely identifies an asset.
CO | Company | A code that identifies the company that owns or is assigned to an asset or a group of assets. Must be valid within F0010, Company Constants.
MCU | Cost Center | The accounting entity assigned to the asset that is responsible for the asset’s cost or expense. Must be valid within F0006, Business Unit Master.
DL01 | Description 01 | A user defined name or remark that describes an asset.
DAJ | Date Acquired | The date the company acquired the asset.
AMCU | Asset Cost Account Cost Center | The business unit to which the system charges original acquisition cost and any supplemental capital additions. Must be valid within F0006, Business Unit Master. Also, must be a valid account (along with AOBJ and ASUB) within F0901, Account Master.
AOBJ | Asset Cost Account Object | The object account to which the original acquisition cost and any supplemental capital additions have been charged. Must be a valid account (along with AMCU and ASUB) within F0901, Account Master.
ASUB | Asset Cost Account Subsidiary | The subsidiary account to which the original acquisition cost and any supplemental capital additions have been charged. Must be a valid account (along with AMCU and AOBJ) within F0901, Account Master.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
APID | Unit Number | A 12-character alphanumeric code used as an alternate identification number for an asset.
ASID | Serial Number | A 25-character alphanumeric code used an alternate identification number for an asset.
AAID | Parent Number | An 8-digit number that groups related components together.
DL02 | Description 02 | Additional text that further describes or clarifies an asset.
DL03 | Description 03 | Additional text that further describes or clarifies an asset.
UITM | Inventory Item Number | A number that the system assigns to an item within the Inventory system. Must be valid within F4101, Item Master.
DSP | Date Disposed | The date the asset was disposed.
LOC | Location | The current physical location of an asset.
EFTB | Location Start Effective Date | The date on which an asset’s location becomes active.
SBLI | Subledger Inactive Code | A code in that indicates whether a specific subledger is active or inactive.
EQST | Equipment Status | A user defined code (12/ES) that identifies the equipment or disposal status of an asset.
ARCQ | Current Item Quantity | The current number of units for an asset.
AROQ | Original Item Quantity | The original number of units for an asset.
AN8 | Employee Number | A number that identifies an entry in the Address Book system. Must be valid within F0101, Address Book Master.
KITL | Model # / Parts List | A number that is used for memo purposes only.
AFE | Authorization for Expenditure Number | Authorization for Expenditure unit number.
RMK | Remark 1 | A generic field that you use for a remark, description, name, or address.
RMK2 | Remark 2 | A generic field that you use for a remark, description, name, or address.

Column-Specific Instructions - Into OneWorld - Table F1217Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Type of the transaction. “JDEFA” = Fixed Assets “JDEEM” = Equipment Management “JDECSMS” = Customer Service Management
TNAC | Action Code | “02” = Add, “UA” = Change, “03” = Delete
DRIN | Direction Indicator | “1” = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".
EDTY | Record Type | Type of the record. “1” = Asset Master, “2” = Equipment Tag If the type is “1”, the inbound record will be placed into the F1201Z1. If the type is “2”, the inbound record will be placed into the F1217Z1.

Additional Comments

The following columns EDUS, EDBT, and EDTN must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

This interface table will contain records linked through a one-to-one relationship to the Asset Master Interface table (F1201Z1) only when the transaction is a CSMS-based or CSMS-bound transaction. The one-to-one relationship is through the Asset Number (NUMB) within both tables.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
NUMB | Asset Number | An 8-digit number that uniquely identifies an asset.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
CTR | Country | A user defined code (00/CN) that identifies a country.
MMCU | Branch | A code that represents a high-level business unit. Must be valid within F0006, Business Unit Master.
DOCO | Order Number | The number that identifies an order number. Must be valid (along with DCTO, KCOO and LNID) within F4211, Sales Order Detail File.
DCTO | Order Type | A user defined code (00/DT) that identifies the type of order document. Must be valid (along with DOCO, KCOO and LNID) within F4211, Sales Order Detail File.
KCOO | Order Company | A company number that, along with order number and order type, uniquely identifies an order document. Must be valid within F0010, Company Constants File. Also, must be valid (along with DOCO, DCTO and LNID) within F4211, Sales Order Detail File.
LNID | Line Number | A number that identifies multiple occurrences of line numbers within an order. If multiple line entry, must be valid (along with DOCO, DCTO and KCOO) within F4211, Sales Order Detail File.
PRODF | Product Family | A user defined code (17/PA) that identifies an inventory item into a group for customer service.
PRODM | Product Model | A user defined code (17/PM) that identifies an inventory item into a model for customer service.

Column-Specific Instructions - From OneWorld - Table F1201Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Type of the transaction. “JDEFA” = Fixed Assets “JDEEM” = Equipment Management “JDECSMS” = Customer Service Management
TNAC | Action Code | “02” = Add, “UA” = Change, “03” = Delete. When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.
EDTY | Record Type | Type of the record. “1” = Asset Master, “2” = Equipment Tag If the type is “1”, the outbound record will be placed into the F1201Z1. If the type is “2”, the outbound record will be placed into the F1217Z1.

Data Columns

Data columns in the interface table from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld " section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.

Column-Specific Instructions - From OneWorld - Table F1217Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Type of the transaction. “JDEFA” = Fixed Assets “JDEEM” = Equipment Management “JDECSMS” = Customer Service Management
TNAC | Action Code | “02” = Add, “UA” = Change, “03” = Delete. When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.
EDTY | Record Type | Type of the record. “1” = Asset Master, “2” = Equipment Tag If the type is “1”, the outbound record will be placed into the F1201Z1. If the type is “2”, the outbound record will be placed into the F1217Z1.

Additional Comments

This Interface table will contain records linked through a one-to-one relationship to the Asset Master Interface table (F1201Z1) only when the transaction is a CSMS-based or CSMS-bound transaction. The one-to-one relationship is through the Asset Number (NUMB) within both tables.

Data Columns

Data columns in the interface table from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld " section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.


Flat File - Unicode Encoding

Flat File - Unicode Encoding consists of the following Categories:

app.gif (808 bytes) | jdeFgetcConvert
app.gif (808 bytes) | jdeFgetcConvertV1
 | jdeFgetcConvertV2
 | jdeFgetsConvert
 | jdeFgetsConvertV1
 | jdeFgetsConvertV2
 | jdeFprintfConvert
 | jdeFprintfConvertV1
 | jdeFprintfConvertV2
 | jdeFputcConvert
 | jdeFputcConvertV1
 | jdeFputcConvertV2
 | jdeFputsConvert
 | jdeFputsConvertV1
 | jdeFputsConvertV2
 | jdeFreadConvert
 | jdeFreadConvertV1
 | jdeFreadConvertV2
 | jdeFscanfConvert
 | jdeFscanfConvertV1
 | jdeFscanfConvertV2
 | jdeFwriteConvert
 | jdeFwriteConvertV1
 | jdeFwriteConvertV2
 | jdeGetEncodingNameV1
 | jdeGetEncodingNameV2


JDB_GetTableProperties

First Available: B9

Last Modified:

JDB_GetTableProperties allows users to get property values for a table (i.e., Maximum Identifier Length, Max Number Of Columns in Table, etc.,). This API could be called either for a particular database or for EnterpriseOne supported values.

Syntax

JDEDB_RESULT JDB_GetTableProperties (char * DBTypeVer, char * PropertyName, int * PropertyValue)

Parameters

Parameter | Notes | Usage
DBTypeVer | NULL or EnterpriseOne or Valid Database name/version (UDC H93/DV). | When a NULL is passed, this API will return the LCD of Maximum of all values or GCD of Minimum of all values. For EnterpriseOne, EnterpriseOne supported limits will be returned and for a specific Database, valid database values would be returned otherwise.
PropertyName | Valid | PropertyName is passed as a string. Valid strings will be one of the following: MaxTableNameLength, MaxIndexNameLength, MaxColumnNameLength, MaxNumberColumnsInTable, MaxNumberColumnsInIndex, MaxNumberIndexesInTable, MaxNumberBLOBInTable, MaxTotalRowLength, MaxTotalIndexLength, MinTableNameLength, MinIndexNameLength, MinColumnNameLength, MinNumberColumnsInTable, MinNumberColumnsInIndex, MinNumberIndexesInTable, MinNumberBLOBInTable, MinTotalRowLength, MinTotalIndexLength
PropertyValue | Return value | The property value will be returned as a pointer to an integer.

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this API succeeds
JDEDB_FAILED | Return value if this API fails

Example

rcode = JDB_GetTableProperties(NULL, "MaxTableNameLength", &PropertyValue);

if (rcode == JDEDB_PASSED)

{

jdeTraceSz1(NULL, “Maximum Table Name Length = %d”, PropertyValue);

return JDEDB_PASSED;

}

else

{

jdeWriteLog(NULL,0, “Failed to get table properties”);

return JDEDB_FAILED;

}

Additional Notes

See Also

· JDB_ValidateTableSpecs


Homepage

Copyright J.D. Edwards World Source Company, 1999-2003

All Rights Reserved

Interoperability Interface Tables

You can use the interoperability interface tables to interface with OneWorld applications. These interoperability interface documents contain information such as the fields you are required to use for specific transactions into and out of OneWorld.

Distribution

Financial

HR Payroll

Logistics

Manufacturing

See Also

  1. The Interoperability Guide for complete information about designing and enabling interoperation between J.D. Edwards. ERP and external products.

Comments

If you wish to make comments about this application,

please take the time to fill out the following

information. All fields are required.

Name

Company Name

Customer / Employee Number

E-Mail Address


HR Payroll Interface Tables

HR Payroll Interoperability Interface Tables Include the Following:

Time Entry


Inbound Response Parsing API

Inbound Response Parsing API consists of the following APIs:

 | jdeXML_DeleteXML
app.gif (808 bytes) | jdeXML_GetDSCount
 | jdeXML_GetDSName
 | jdeXML_ParseDS
 | SampleXAPIResponseParsingAPIUsage


Inbound Voucher

Tables: F0411Z1, F0411Z3, F0911Z1

Date: October 29, 1998; Updated May 20003

General Information

Purpose of Transaction

Inbound Voucher transactions are used to record voucher information prior to issuing a payment to your supplier. On the inbound side, this transaction is used to update ERP tables with voucher information. Outbound transactions are not supported.

The permanent ERP tables primarily affected by this transaction are the Accounts Payable Ledger (F0411) and the Account Ledger (F0911).

Relationships to Other Transactions

The F0911Z1 transaction file is also used by A/P Vouchers and Journal Entries. A/R Invoice transactions will have an EDI - Transaction Type equal to "I", A/P Vouchers will have an EDI - Transaction Type equal to "V", and Journal Entries will have an EDI - Transaction Type equal to "J".

Transaction-Specific Instructions

This transaction supports additions, changes, and deletions.

This transaction uses two interface tables - Header (F0911Z1) and Detail (F0411Z1).

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into ERP - Table F0411Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into ERP, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user. This field, in combination with EDTN and EDUS, uniquely identifies a specific voucher entry. This field also acts as a level break and causes the assignment of a J.D. Edwards batch number each time this value changes.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
EDTR | Transaction Type | A code that identifies a particular type of transaction. This field must be = "V".
EDTC | Transaction Action | "A" = add, "C" = change, "D" = delete (left-justified)
EDSP | Processed flag | When processing for this transaction is complete, ERP updates this to a "1". This field must be zero.

Additional Comments

The following columns EDUS, EDBT, and EDTN must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to ERP. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

For a given voucher, if there is a corresponding record in the F0911Z1 table, the values in the first three columns of F0411Z1 table must match the values in the first three columns of the corresponding records in F0911Z1 table.

Required Data Columns

Required data columns are those that you must populate for ERP to accept the transaction.

Data Item | Description | Notes
AN8 | Supplier Number | A number that identifies an entry in the Address Book system (F0101). Use this number to identify employees, applicants, customers, suppliers, tenants, and any other address book members.
DGJ | G/L Date | A date that identifies the financial period to which the transaction is posted. The G/L date should be loaded as a 6-character Julian date. This field is a required field in order to add a transaction.
CO | Company | A code that identifies a specific organization, fund, entity, and so on. The company code must already exist in the Company Constants table (F0010) and must identify a reporting entity that has a complete balance sheet.
AG | Gross Amount | The gross amount of an invoice or voucher pay item. This amount is required in order to enter amounts in domestic mode (CRRM = D). The amount cannot be zero.

Column-Specific Instructions - Into ERP - Table F0911Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into ERP, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify a batch of transactions within the specified user.
EDBT | User Batch | This field, in combination with EDTN and EDUS, uniquely identifies a specific voucher entry. This field also acts as a level break and causes the assignment of a J.D. Edwards batch number each time this value changes. This number must match the number loaded into the EDBT field in the F0411Z1 table.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
EDTR | Transaction Type | A code that identifies a particular type of transaction. This field must be = "V".
EDTC | Transaction Action | "A" = add, "C" = change, "D" = delete (left-justified)
EDSP | Processed flag | When processing for this transaction is complete, ERP updates this to a "1". This field must be zero.

Additional Comments

The following columns EDUS, EDBT, and EDTN must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to ERP. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for ERP to accept the transaction.

Data Item | Description | Notes
DGJ | G/L Date | A date that identifies the financial period to which the transaction is posted. The G/L date should be loaded as a 6-character Julian date. This field is a required field in order to add a transaction. This number must match the number loaded into the DGJ field in the F0411Z1 table.
ANI | G/L Account Number | A field that identifies an account in the general ledger. The G/L account number should be left justified in the field regardless of the length of the business unit. You may not substitute the fields for business unit (MCU), object (OBJ), and subsidiary (SUB) in place of the G/L account number (ANI).
AA | Amount | A number that identifies the actual amount. Type debits with no sign or a plus sign. Type credits with a minus sign either before or after the amount. You can use decimals, currency symbols, and commas. You can have as many lines of distribution as necessary as long as the amounts for all the distribution lines total the gross amount entered in the AG field in the F0411Z1 table. This field cannot be zero.
LT | Ledger Type | A user defined code (09/LT) that specifies the type of ledger. Unless you are processing foreign transactions, you can leave this field blank to accept the data dictionary default of AA. For transactions that are foreign, enter CA.

ERP 9.0 Data

The following fields are added to Table F0411Z3 for ERP 9.0.

Data Item | Description | Notes
TNST | Transit Number - Bank | The number assigned to a particular bank by the Federal Reserve to facilitate the clearing of funds.
YC01 through YC10 | Category Code – A/P Ledger 01 through Category Code – A/P Ledger 10 | Reserved by J.D. Edwards.
DTXS | Deferred Tax Status - VAT | Reserved by J.D. Edwards.
BCRC | Base Company Currency | A code that represents the currency of the company for a transaction. For a foreign currency transaction, this is the currency code of the domestic side of the transaction.
ATAD | General Ledger Amount to Distribute | The amount of the transaction that must be posted to the general ledger for the transaction to balance. Depending on the tax information provided, the value of this field might be different from the gross or taxable amount of the transaction.
CTAD | Foreign Amount to Distribute | For a journal entry with VAT, this represents the amount to be expensed in foreign currency.
NRTA | Non-recoverable Tax Amount | The portion of the tax amount for which you cannot take a credit.
FNRT | Foreign Non-recoverable Tax Amount | The portion of the foreign tax amount for which you cannot take a credit.
TAXP | Non-taxable Flag | A flag that indicates a voucher was created by the Procurement system.
PRGF | Ready for Purge | Reserved by J.D. Edwards.
GFL5 and GFL6 | Generic Flag | Reserved by J.D. Edwards.
GAM1 and GAM2 | Generic Amount | Reserved by J.D. Edwards.
GEN4 and GEN5 | Generic String | Reserved by J.D. Edwards.
WTAD | Withholding Tax Amount Domestic | Future use.
WTAF | Withholding Tax Amount Foreign | Future use. A flag that indicates the voucher pay item was created by summarizing purchase order items.
SMMF | Summary Flag | A flag that indicates the voucher pay item was created by summarizing purchase order items.


InitializePageFooter

Last Modified: B733.2 | May 07, 1999

InitializePageFooter occurs at the beginning of the report after any report header logic and before the page header section processes for the first time. Use this to initialize values to be printed in the current page footer section. These assignments typically depend on information processed so far on that page.

Available On

  • This event is only available at the section level of a page footer section.

Available Objects

  • Business view column fields are not allowed here because a page footer can not have a business view attached.

Typical Usage

The typical use for this event would be to initialize values that will be printed in the current page footer section. These assignments would typically depend on information that has been processed so far on that page.

Additional Notes

This event occurs once for every page break that occurs, and once at the end of the report.

Processing Sequence

Scenario A

  • Page Break (due to a section overflowing a page)

  • InitPageFooter

  • InitPageHeader (for the next page, if applicable)

  • DoSection (for the section that did not completely print)

Scenario B

  • EndSection (for the last section of the report)

  • InitPageFooter

  • InitReportFooter (if applicable)


InitializePageHeader

Last Modified: B733.2 | May 07, 1999

InitializePageHeader occurs at the beginning of a report after any report header logic and before the page header section processes for the first time. It also processes every time a page break occurs. Use this to initialize values that cannot be set until after the report header logic executes. This is similar to Init Section for a normal group, columnar, or tabular section, except that it is only processed for a page header section.

Available On

  • This event is only available at the section level of a page header section.

Available Objects

Business view column fields are not allowed here because a page header can not have a business view attached.

Typical Usage

The typical use for this event would be to initialize values that can not be set until after the report header logic has been executed. This event is similar to the InitSection event for a normal group, columnar or tabular section except that it is only processed for a page header section.

Additional Notes

This event occurs once for every page break that occurs, and once at the beginning of the report.

Processing Sequence

Scenario A

  1. Page Break (due to a section overflowing a page)

  2. InitPageFooter (if applicable)

  3. InitPageHeader (for the next page)

  4. DoSection (for the section that did not completely print)

Scenario B

  1. InitReportHeader (if applicable)

  2. DoSection (for report header, if applicable)

  3. EndReportHeader (if applicable)

  4. InitPageHeader

  5. DoSection (for page header)

  6. EndPageHeader


InitializeReportFooter

Last Modified: B733.2 | May 07, 1999

InitializeReportFooter occurs once at the very end of a report after everything else processes and before the report footer prints. use this to initialize values to print in the report footer.

Available On

  • This event is only available at the section level of a report footer section.

Available Objects

  • Business view column fields are not allowed here because report footers cannot have a business view attached.

Typical Usage

The typical use for this would be to initialize values to print in the report footer. Usually these values could not be calculated or assigned until the rest of the report has completed processing

Processing Sequence

  1. EndSection (for the last section of the report)

  2. InitPageFooter (if applicable)

  3. InitReportFooter


InitializeReportHeader

Last Modified: B733.2 | May 07, 1999

InitializeReportHeader processes once at the very beginning of the report before anything else in the report processes. Use this to initialize values at the beginning of a report. This is similar to Init Section for a normal group, columnar, or tabular section except that it only processes for a report header section.

Available On

  • This event is only available at the section level of a report header section.

Available Objects

Business view column fields are not allowed here because a report header cannot have a business view attached.

Typical Usage

The typical use for this event would be to initialize values at the beginning of the report, before any other Event Rule logic is processed. This event is similar to the InitSection event for a normal group, columnar or tabular section except that it is only processed for a report header section.

Processing Sequence

  1. InitReportHeader

  2. DoSection (for report header)

  3. EndReportHeader

  4. InitPageHeader (if applicable)

  5. DoSection (for page header) (if applicable)

  6. EndPageHeader (if applicable)


InitializeSection

Last Modified: B733.2 | May 07, 1999

InitializeSection occurs when a batch process encounters a section for the first time. Use this to do processing immediately before a section begins. This is useful for working with global variables or performing other preparatory procedures. For conditional sections, this event will be processed each time the section is called.

Available On

The End Section Event is only visible to a section. It cannot be set for an object or the entire report.

Typical Usage

In order to process Event Rule logic immediately before a Section Begins. This is a good point for working with global variables or performing other preparatory procedures.

Additional Notes

Initialize Section occurs before any of the structures or pointers related to the section have been established. Do not attempt to manipulate data which is only valid within the current section (since the pointers do not exist yet).

Processing Sequence

  1. Previous section terminates.

  2. Process Initialize Section Event Rules.

  3. Process section objects.


InitializeVariable

Last Modified: B733

InitializeVariable is invoked each time a report object, or variable, is to be processed.

Available On

  • This event is only available to report objects. It is not applicable to the entire report or sections within the report.

Typical Usage

After an object has been processed, event rule logic may be processed. When invoking this process, the object’s position on the page has not yet been determined, so this would be a good time to perform processing that would affect the calculation of the object’s position.

Processing Sequence

  1. Process the Report Variable object.

  2. Event Rule logic.

  3. Process next object.


InitLvlBrkFooterSection

Last Review: May 10, 2000

InitLvlBrkFooterSection is to be used to do processing immediately before a level break footer.

Available On

  • The Initialize Level Break Footer Section Event is only visible to a section. It cannot be set for an object or the entire report.

Typical Usage

In order to process Event Rule logic immediately before a Level Break Footer.

Processing Sequence

  1. Level break occurs.

  2. Process event rules for the Initialize Level Break Footer.

  3. Process objects of Level Break Footer.


InitLvlBrkHeaderSection

Last Modified: B733.2 | May 07, 1999

InitLvlBrkHeaderSection should be used to do processing immediately before a level break header.

Available On

  • The Initialize Level Break Header Section Event is only visible to a section. It cannot be set for an object or the entire report.

Typical Usage

In order to process Event Rule logic immediately before a Level Break Header.

Processing Sequence

  1. Level Break Header finishes.

  2. Process event rules for the End Level Break Header.

  3. The End Level Break Header tries to locate the header section, if it does, it sends the DO_BREAK_HEADER message for the header section; otherwise, it sends the INIT_BREAK_HEADER message for the next level.

  4. Begin processing objects for the body of section.


Inventory Item Cost

Table: F4105Z1

Date: August 31, 1998

General Information

Purpose of Transaction

Inventory Item Cost transactions are used to track inventory costs. On the inbound side, this transaction is used to update OneWorld tables with inventory cost information. On the outbound side, this transaction is used to generate records that that can be used by a third party to update their system with the inventory cost information.

The permanent OneWorld table primarily affected by this transaction is the Item Cost File (F4105).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions, changes, and deletions.

The outbound transaction supports additions, changes, and deletions. For changes, both the before and after images can be written.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F4105Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDEIC"
TNAC | Action Code | "A" = add, "C" = change, "D" = delete (left justified)
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
ITM | Item Number (short) | Validated against table F4101.
MCU | Business Unit | Validated against table F41001.
LEDG | Cost Method | Validated against UDC 40/CM.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
EDCT | Document Type | Optional.
EDFT | Translation Format | Optional.
EDDT | Transmission Date | Optional.
EDDL | Number of Detail Lines | Optional.
PNID | Trading Partner | Optional.
ITM | Item Number | Specify on Add. (Cost level 1)
LITM | 2nd Item Number | Specify on Add. (Cost level 1)
AITM | 3rd Item Number | Optional.
MCU | Business Unit | Specify on Add if Cost Level of item a 2 or 3.
LOCN | Location | Specify on Add if Cost Level of item a 3.
LOTN | Lot/SN | Specify on Add if Cost Level of item a 3.
LOTG | Lot Grade | Optional.
LEDG | Cost Method | Specify on Add.
UNCS | Unit Cost | Specify on Add.
CSPO | Purchasing Costing Selection | “P” if Purchasing costing method for item.
CSIN | Inventory Costing Selection | “I” if Sales/Inventory costing method for item.

Column-Specific Instructions - From OneWorld - Table F4105Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDEIC"
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Data Columns

Data columns in the interface table from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld " section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.


Item Master

Tables: F4101Z1, F4101Z1A

Date: December 04, 1998

General Information

Purpose of Transaction

Item Master transactions are used to record information about items your stock. On the inbound side, this transaction is used to update OneWorld tables with Item Master information. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the Item Master information.

The permanent OneWorld tables primarily affected by this transaction are the Item Master table (F4101), Item Branch table (F4102), Item Master Tag table (F4101T), Bulk Item Master table (F41011), Bulk Depot/Product Information table (F41022), Item Profile table (F46010), Item Shipping Information table (F4908), Item Master-Customer Service Extension table (F4117), and the Item Master-Customer Service Extension table (F41171).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions, changes, and deletions.

The outbound transaction supports additions, changes, and deletions. For changes, both the before and after images can be written.

This transaction uses two interface tables - F4101Z1 and an additional Detail table F4101Z1A.

The F4101Z1 table contains information from the Item Master (F4101), Item Branch (F4102), and Item Master Tag (F4101T) files. Each F4101Z1 record can have only one F4101Z1A detail record.

The detail table F4101Z1A record should also be provided when sending information from one of these files: Bulk Item Master (F41011), Bulk Depot/Product Information (F41022), Item Shipping Information (F4908), Item Master - Customer Service Extension (F4117), Item Branch Master - Customer Service Extension (F41171), or Item Profile (F46010). Each F4101Z1A record must have a parent F4101Z1 record.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F4101Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction. The item master transaction is not multi line.
TYTN | Transaction Type | Name of the transaction - "JDEITEM"
TNAC | Action Code | "A" = add, "C" = change, "D" = delete (left justified)
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". Blank indicates the transaction has not been successfully processed.

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
ITM | Item Number - Short | Required for a change or delete. When provided for a change or delete transaction, this value must exist in the Item Master (F4101). See Note 1.
LITM | 2nd Item Number | See Note 1.
AITM | 3rd Item Number | See Note 1.
MCU | Branch/Plant | Must exist in Item Branch File (F4102) if performing a branch level transaction, otherwise should be blank.
ITBR | Update Item Branch | Value of “1” for item level transactions, “2” for branch level transactions.
DSC1 | Description | A brief description of the item.
STKT | Stocking Type | Value from UDC table 41/I.

Additional Comments

Note 1 - One of the three columns ITM, LITM, or AITM must be populated for an add.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and Default logic
UPCN | UPC Number | If UCC 128 information is included in the transaction either the UPC Number or the Aggregate SCC Code (PI=0) must be populated. If this field is provided, the Unit of Measure - UPC (Value from UDC table 00/UM) must also be provided.
SCCO | Aggregate SCC Code (PI-0) | If UCC 128 information is included in the transaction either the UPC Number or SCC0 must be populated. If this field is provided, the Unit of Measure - SCC (PI=0) and Unit of Measure - Aggregate UPC (Value from UDC table 00/UM) must also be provided.

Additional Comments

If UCC 128 information is included in the transaction, either the UPC Number (UPCN) or the Aggregate SCC Code (PI=0) (SCC0) must be populated.

Column-Specific Instructions - Into OneWorld - Table F4101Z1A

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction. The item master transaction is not multi line.
TYTN | Transaction Type | Name of the transaction - "JDEITEM"
TNAC | Action Code | "A" = add, "C" = change, "D" = delete (left justified)
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". Blank indicates the transaction has not been successfully processed.

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

For a given Item Master record, each entry in the F4101Z1A table must have a parent record in the F4101Z1 table.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
ITM | Item Number - Short | Required for a change or delete. When provided for a change or delete transaction, this value must exist in the Item Master (F4101). See Note 1.
LITM | 2nd Item Number | See Note 1.
AITM | 3rd Item Number | See Note 1.
MCU | Branch/Plant | Must exist in Item Branch File (F4102) if performing a branch level transaction, otherwise should be blank
ITBR | Update Item Branch | Value of “1” for item level transactions, “2” for branch level transactions

Additional Comments

Note 1 - One of the three columns ITM, LITM, or AITM must be populated for an add.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and Default logic
PRODM | Product Model | Either Product Model (Value from UDC 17/PM) or Product Family (Value from UDC 17/PA) is required when including Customer Service Management information.
PRODF | Product Family | Either Product Model (Value from UDC 17/PM) or Product Family (Value from UDC 17/PA) is required when including Customer Service Management information.

Additional Comments

None.

Column-Specific Instructions - From OneWorld - Table F4101Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and Default
EDUS | User ID | User ID who instigated the transaction
EDBT | User Batch | Batch number generated within OneWorld
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN. The item master transaction is not multi line.
TYTN | Transaction Type | Name of the transaction - "JDEITEM"
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". The value for transactions that have not been successfully processed is blank. For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Data Columns

Data columns in the interface table from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld " section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.

Column-Specific Instructions - From OneWorld - Table F4101Z1A

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and Default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN. The item master transaction is not multi line.
TYTN | Transaction Type | Name of the transaction - "JDEITEM"
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". The value for transactions that have not been successfully processed is blank. For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Additional Comments

For a given Item Master record, each entry in the F4101Z1A table will have a parent record in the F4101Z1 table.

Data Columns

Data columns in the interface table from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld" section for descriptions of required and frequently used columns. OneWorld provides all columns from the corresponding source tables with the exception of the columns listed under Additional Comments.


JDB_FetchKeyed

JDB_SetSelectionX

Last Modified: EnterpriseOne | June 06, 2000

JDB_SetSelectionX enables users to define any type of selection on a table associated with a specific initialized request handle. This API will allow us to set precedence on the conditions for the select. Example: We can create a select statement: SELECT * FROM TABLE-NAME WHERE ((COL1 = X AND COL2 = Y) OR (COL 3 = Z)).

Syntax

JDEDB_RESULT JDB_SetSelectionX(HREQUEST hRequest, LPNEWSELECT lpSelect, ushort nNum, JDEDB_SET nSet)

Parameters

Parameter | Notes | Usage
hRequest | NULL or valid request handle. | JDB will identify all requests made to the particular table by this request handle.
lpSelect | Pointer to array of SELECT structures. | This structure identifies the type of selection to process.
nNum | Number of SELECT structures passed. This must equal the number of structures passed. |
nSet | Replace or append the last selection. |

Return Value

Return Value | Description
JDEDB_PASSED | Return value if this succeeds
JDEDB_FAILED | Return value if this fails

Example

/* Declare variables associated with JDB_SetSelectionX */

HREQUEST hRequest = NULL;

LPSELECT lpNewSelect = NULL;

int nNum = 2;

char szSelectionAlphaName[10];

/* Allocate memory by calling the JDE memory allocation routine */

lpNewSelect = jdeAllocReturnIfError(COMMON_POOL,nNumSelect*sizeof(SELECTSTRUCT), MEM_ZEROINIT);

if(lpNewSelect == NULL)

{

return (0);

} /* END IF */

/* Set a custom selection. Equivalent to the "where" clause in a SQL statement*/

/* The following two structures for selection contain data specifying that in table F0101, select only records that have the field ids NID_AN8 and NID_AN81 equal to each other AND the NID_ALPH field containing the string “EnterpriseOne”*/

/* Selection Criteria : this criteria will select records having field ABAN8=ABAN81. It also specifies that this selection will be ANDed with another selection*/

jdeNIDcpy(lpSelect[0].Item1.szDict ,NID_AN8);

jdeNIDcpy(lpSelect[0].Item1.szTable ,NID_F0101);

lpSelect[0].Item1.idInstance = 0;

jdeNIDcpy(lpSelect[0].Item2.szDict ,NID_AN81);

jdeNIDcpy(lpSelect[0].Item2.szTable, NID_F0101);

lpSelect[0].Item2.idInstance = 0;

lpSelect[0].lpValue = NULL;

lpSelect[0].nValues = 0;

lpSelect[0].nCmp = JDEDB_CMP_EQ;

lpSelect[0].nAndOr = JDEDB_ANDOR_AND;

/* Selection Criteria : this criteria will select records having ABALPH = “EnterpriseOne” */

strcpy(szSelectionAlphaName, “EnterpriseOne”);

jdeNIDcpy(lpSelect[1].Item1.szDict , NID_ALPH);

jdeNIDcpy(lpSelect[1].Item1.szTable, NID_F0101);

lpSelect[1].Item1.idInstance = 0;

jdeNIDclear(lpSelect[1].Item2.szDict);

jdeNIDclear(lpSelect[1].Item2.szTable);

lpSelect[1].Item2.idInstance = 0;

lpSelect[1].lpValue = szSelectionAlphaName;

lpSelect[1].nValues = 1;

lpSelect[1].nAndOr = JDEDB_ANDOR_AND;

lpSelect[1].nCmp = JDEDB_CMP_EQ;

/* Create WHERE clause */

rcode = JDB_SetSelectionX(hRequest, lpNewSelect, nNum, JDEDB_SET_REPLACE);

if(rcode != JDEDB_PASSED)

{

printf(“JDB_SetSelectionX failed\n”);

} /* END IF */

See Also

· · JDB_SetSelection

· · JDB_SetLowerLimit


JDB_TextSearchClearSelection

JDB_TextSearchCloseView

Syntax

JDERTN (JDEDB_RESULT) JDEWINAPI JDB_TextSearchCloseView(HREQUEST hRequest);

Description

This API closes a business view that was opened for text searches.

Parameters

hRequest

Input, required. The request handle that defines the context in which the business view is to be closed.

Returns

This API can return these values:

Value | Description
JDEDB_PASSED | The business view was closed successfully.
JDEDB_FAILED | The business view was not closed.

Example

DBDB_RESULT nResult;

nResult = JDB_TextSearchCloseView(hRequest);


jdeCacheAdd.htm

jdeCacheAdd

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheAdd adds a record to the cache identified by the cache handle hCache that was obtained from the call to jdeCacheInit. The sequence order of the added record is determined by the index that was passed to jdeCacheInit.

Syntax

JDECM_RESULT jdeCacheAdd (HCACHE hCache, void * lpData, long nDataSize)

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
lpData | Input. This is the full structure from which the offsets of the columns that make up the index keys were established. In a JDB environment, the structure represents one record. Use memset() on this structure before adding elements to it.
nDataSize | Input. The size of the structure record that is being passed with the data.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

...

/*initialize cache*/

...

/*add a record*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing 12345");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");


jdeDate

jdeDate consist of the following APIs:

JDB_RetrieveF0010RowUsingCompanyNumber

JDB_RetrieveF0013RowUsingCurrencyCode

JDB_RetrieveF0025RowUsingLedgerType

jdeGetCurrencyCode

jdeGetDataBaseAction

jdeMathCopyCurrencyInfo

jdeMathSetCurrencyCode

jdeMathSetCurrencyDecimals

jdeUpdateMathCurrency

ParseNumericStringEx

ZeroMathNumericEx


jdeGTDelete_Image/jdeGTDelete_ImageKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes specific image record types from the F00165 table based on the pMOData parameter.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_Image(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_ImageKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_ImageKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Image(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTDelete_OLE_jdeGTDelete_OLEKeyStr.htm

jdeGTDelete_OLE/jdeGTDelete_OLEKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes specific OLE record types from the F00165 table based on pMOData.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_OLE(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_OLEKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_OLEKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_OLE(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTDelete_Shortcut_jdeGTDelete_ShortcutKeyStr.htm

jdeGTDelete_Shortcut/jdeGTDelete_ShortcutKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes specific shortcut record types from the F00165 table based on the pMOData parameter.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_Shortcut(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_ShortcutKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_ShortcutKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Shortcut (_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTDelete_Text_jdeGTDelete_TextKeyStr.htm

jdeGTDelete_Text/jdeGTDelete_TextKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes a specific record type from the F00165 table based on pMOData.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_Text(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_TextKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_TextKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Text(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTDelete_Vendor_jdeGTDelete_VendorKeyStr.htm

jdeGTDelete_Vendor/jdeGTDelete_VendorKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes specific vendors or third-party software record types from the F00165 table based on the pMOData parameter.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_Vendor(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_VendorKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_VendorKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Vendor(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTFreeMOData.htm

jdeGTFreeMOData

Last Modified: EnterpriseOne | June 06, 2006

This function frees the memory pointer of the allocated array of the MODATA structure. It also frees any memory pointer of the pData member in MODATA.

Syntax

JDERTN(void) JDEWINAPI jdeGTFreeMOData(

LPMODATA lpMOData,

long lNumOfRec

);

Parameters

lpMOData | Input, required. Allocate memory of the array of pointer to MODATA structure. The memory is freed along with any pData pointer.
INumOfRec | Input, required. The number of elements in the array pointer.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_TextKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Text(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTGet_AllMOType_jdeGTGet_AllMOTypeKeyStr.htm

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves all record types from the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_AllMOType(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_AllMOTypeKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeFreeMOData(pMOData, lTotalRec);

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeFreeMOData(pMOData, lTotalRec);

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTGet_GenericText_jdeGTGet_GenericTextKeyStr.htm

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves the text record type from the F00165 table and converts the retrieved RTF text to plain text.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_GenericText(

PJSTR szObjectName,

LPVOID lpMODSKey,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_GenericTextKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_GenericTextKeyStr (_J("ABGT"), _J("1"), 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_TextKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_GenericText(_J("ABGT"), &dsABGT, 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Text(_J("ABGT") , &dsABGT, pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTGet_HTML_jdeGTGet_HTMLKeyStr.htm

XRCS_setCallback

Last Modified: EnterpriseOne | June 06, 2006

This function sets up the given callback function for the given SAX parsing event. The function prototype of the callback function must correspond to the type of callback. The callback function must be cast to (void *). The context pointer must be cast to (void *). The context pointer typically points to a user-defined data structure, where the callback functions can maintain the state of the parsing. The context pointer may be set to NULL if it is not needed.

You can set up multiple callback functions for the same parsing event type. However, the order in which they are called cannot be specified.

Syntax

XRCS_Status XRCS_setCallback( const XRCS_hParser hParser
, XRCS_CallbackType eCallbackType
, void *pCallbackFunction
, void *pContext
);

Parameters

hParser | Input. A valid parser handle.
eCallbackType | Input. A type of callback, specified by enum value.
pCallbackFunction | Input. A pointer to callback function.
pContext | A pointer to be passed to the callback function.


jdeGTGet_Image_jdeGTGet_ImageKeyStr.htm

jdeGTGet_Image/jdeGTGet_ImageKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves the image record type from the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_Image(

PJSTR szObjectName,

LPVOID lpMODSKey,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_ImageKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_ImageKeyStr (_J("ABGT"), _J("1"), 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_ImageKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_Image(_J("ABGT"), &dsABGT, 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Image(_J("ABGT") , &dsABGT, pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTGet_OLE_jdeGTGet_OLEKeyStr.htm

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves the OLE record type from the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_OLE(

PJSTR szObjectName,

LPVOID lpMODSKey,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_OLEKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_OLEKeyStr (_J("ABGT"), _J("1"), 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_OLEKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_OLE(_J("ABGT"), &dsABGT, 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_OLE(_J("ABGT") , &dsABGT, pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTGet_RTFText_jdeGTGet_RTFTextKeyStr.htm

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves the text record type from the F00165 table and does not affect the RTF text.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_RTFText(

PJSTR szObjectName,

LPVOID lpMODSKey,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_RTFTextKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName

Input, required. GT data structure name. Primary unique key.

lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_RTFTextKeyStr (_J("ABGT"), _J("1"), 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_TextKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_RTFText(_J("ABGT"), &dsABGT, 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Text(_J("ABGT") , &dsABGT, pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTGet_Shortcut_jdeGTGet_ShortcutKeyStr.htm

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves the shortcut record type from the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_Shortcut(

PJSTR szObjectName,

LPVOID lpMODSKey,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_ShortcutKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName

Input, required. GT data structure name. Primary unique key.

lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_ShortcutKeyStr (_J("ABGT"), _J("1"), 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_ShortcutKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_Shortcut(_J("ABGT"), &dsABGT, 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Shortcut(_J("ABGT") , &dsABGT, pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTGet_Vendor_jdeGTGet_VendorKeyStr.htm

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves the vendor record type from the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_Vendor(

PJSTR szObjectName,

LPVOID lpMODSKey,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_VendorKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_VendorKeyStr (_J("ABGT"), _J("1"), 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_VendorKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_Vendor(_J("ABGT"), &dsABGT, 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Vendor(_J("ABGT") , &dsABGT, pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeGTGetCount_jdeGTGetCountKeyStr.htm

jdeGTGetCount/jdeGTGetCountKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves the number of media object records the F00165 table.

Syntax

JDERTN(long) JDEWINAPI jdeGTGetCount(

PJSTR szObjectName,

LPVOID lpMODSKey,

MOTYPE nMOType

);

JDERTN(long) JDEWINAPI jdeGTGetCountKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

MOTYPE nMOType

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOType | Input, required. Media object type.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
>0 | Number of records found.
≤ | Either no records exist or the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

long lTotalRecFound = 0;

BOOL bSuccess = TRUE;

lTotalRecFound = jdeValidateGTExist(_J("ABGT") , &dsABGT, OBJ_RTFTEXT);

if (lTotalRecFound > 0)

{

bSuccess = TRUE;

}

else

{

bSuccess = FALSE;

}

return;

This is the second example of how to use this API:

long lTotalRecFound = 0;

DSABGT dsABGT = {0};

BOOL bSuccess = TRUE;

ParseNumericString(&dsABGT.mnAddressNumber, J("1"));

lTotalRecFound = jdeValidateGTExist(_J("ABGT") , &dsABGT, OBJ_RTFTEXT);

if (lTotalRecFound > 0)

{

bSuccess = TRUE;

}

else

{

bSuccess = FALSE;

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr


jdeValidateGTExist_jdeValidateGTExistWithKeyStr.htm

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function checks whether any media object records exist in F00165 table.

Syntax

JDERTN(long) JDEWINAPI jdeValidateGTExist(

PJSTR szObjectName,

LPVOID lpMODSKey,

MOTYPE nMOType

);

JDERTN(long) JDEWINAPI jdeValidateGTExistWithKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

MOTYPE nMOType

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOType | Input, required. Media object type.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

BOOL bSuccess = TRUE;

JDBReturn = jdeValidateGTExistWithKeyStr (_J("ABGT") , J("1"), OBJ_JDEALL);

if (JDBReturn == JDEDB_PASSED)

{

bSuccess = TRUE;

}

else

{

bSuccess = FALSE;

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

DSABGT dsABGT = {0};

BOOL bSuccess = TRUE;

ParseNumericString(&dsABGT.mnAddressNumber, J("1"));

JDBReturn = jdeValidateGTExist(_J("ABGT") , &dsABGT, OBJ_JDEALL);

if (JDBReturn == JDEDB_PASSED)

{

bSuccess = TRUE;

}

else

{

bSuccess = FALSE;

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr


Journal Entry

Tables: F9011Z1, F0911Z1T

Date: August 31, 1998

General Information

Purpose of Transaction

Journal entry transactions are used to add transactions to accounts in your general ledger. On the inbound side, this transaction is used to update OneWorld tables with journal entry information. Outbound transactions are not supported.

The permanent OneWorld table primarily affected b y this transaction is the Account Ledger table (F0911).

Relationships to Other Transactions

The F0911Z1 transaction file is also used by A/P Vouchers and A/R Invoices. Journal entry transactions will have an EDI - Transaction Type equal to "J", A/P vouchers will have an EDI - Transaction Type equal to "V", and A/R invoices will have an EDI - Transaction Type equal to "I".

Transaction-Specific Instructions

The inbound transaction supports additions only.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F0911Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
EDTR | Transaction Type | A code that identifies a particular type of transaction. This field will be "J" for journal entries, "I" for invoices, or "V" for vouchers.
EDTC | Transaction Action | "A" = add.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "1". This field must be zero.

Additional Comments

The columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
DCT | Document Type | Document type of the transaction. Example "JE" for journal entry. The value in this field must exist in the 00/DT UDC table.
DGJ | G/L Date | G/L date of transaction.
ANI | Account Number | Account to use for the line of the transaction. This account number must exist in the Account Master table (F0901).
AM | Account Mode | The type of account loaded in ANI. Examples “1” = Long account, “2” = Short. The value in this field must exist in the H09/AM UDC table.
AA | Amount | Amount for the line of the transaction.
EXA | Explanation | Description for the transaction.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and Default logic
DOC | Document Number | The most defining portion of the key to the transaction in the target table. If specified, it must not cause a duplicate entry in the target table. If left blank, OneWorld will assign it.
KCO | Key Company | This field is also a key in defining the transaction table. If the field is left blank the default value will be the company of the account on the first line of the transaction. If a value is filled in this field, it must exist in the Company Constants table (F0010).
ICU | Batch Number | The batch number that this transaction will reside in. If this field is left blank the batch number is automatically assigned. If a value is filled in this field it must exist in the Batch Control Records table (F0011).
ICUT | Batch Type | Type of batch that this transaction will be written to. Example "G" = general ledger. The value in this field must exist in the 98/IT UDC table.
AID | Account ID | Short Account ID. This value can be passed in instead of ANI. If AID is passed in then account mode (AM) must be “1”. The value passed in this field must exist in the Account Master table (F0901).
SBL | Subledger | This field will be validated according to the subledger type entered.
SBLT | Subledger Type | This value must exist in the 00/ST UDC table.
LT | Ledger Type | Ledger type of the transaction. The value entered must exist in the 09/LT UDC table.
CRCD | Currency Code | Currency code of transaction if foreign. The value entered in this field must exist in the Currency codes table (F0013).
U | Units | Units for this transaction.
UN | Units of Measure | If units (U) are passed in then UM must also be populated. The value in this filed must exist in the 00/UM UDC table.
EXR | Remark | Line level description.

Data Columns Not Updated

Following is a list of columns that will not be passed through to the resulting transaction. These fields are not parameters passed into the Journal Entry Master Business Function (B0900049), which is called to write the resulting F0911 records. Therefore, they will not be written to the F0911.

Data Item | Description | Notes and Default logic
FZ | Fiscal Quarter |
R3 | Reference 3 |
ODCT | Document Type - Original |
OSFX | Document Pay Item - Original |
ALLT | G/L Posting Code - Alternate T |
ALLU | G/L Posting Code - Alternate U |
ALLV | G/L Posting Code - Alternate V |
ALLW | G/L Posting Code - Alternate W |
ALLZ | G/L Posting Code - Alternate Z |
PYID | Payment ID |


Kanban Processing

Table: F30161Z1

Date: January 25, 1999

General Information

Purpose of Transaction

Kanban transactions are used to indicate to producing work centers what has been consumed and what needs to be produced next. On the inbound side, this transaction is used to update OneWorld tables with Kanban information.

Outbound Kanban processing transactions do not use this interface table. To perform outbound Kanban Processing, the interoperability processing options for Work Order Completions, Work Order Employee Time Entry, Work Order Inventory Issues, Sales Order Entry, Purchase Order entry, Shipment confirmation, Purchase receipt, and Inventory transfer must be turned on. See the Interface Table User Guides for each of these transactions for more information.

The permanent OneWorld tables primarily affected by this transaction are the Work Order Routing table (F3112), the Work Order Parts List table (F3111), the Work Order Time Transactions table (F31122), the Sales Order Header table (F4201), the Sales Order Detail table (F4211), the Purchase Order Header table (F4301), the Purchase Order Detail table (F4311), the Work Order Master table (F4801), the Rate schedule Master table (F3104), the Rate schedule Transaction table (F3114), and the Item Ledger table (F4111).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions only.

This transaction must have corresponding records in Kanban Master (F3016), Kanban Card Detail (F30161), Item Master (F4101), Item Branch File (F4102), and Item Location (F41021).

Depending on the source type (REPT) in the Kanban Master Table (F3016), Kanban transactions are used to create Super Backflush , Sales order, Purchase Order, Work Order, Rate Schedule or Inventory transfer transactions.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F30161Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested Use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDEKNB"
TNAC | Action Code | "A" = add
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
KID1 | Kanban ID | Must be in F3016 and F30161 tables.
CDN | Deposit number or Card Number | Must be the same as in F30161 table. Validated against F3016 table.
KBST | Kanban Status | This is what drives the transaction, enter: “1” : to check in the Kanban “2” : to check out the Kanban “3” : to complete the Kanban Validated against UDC 31/KS.
SHFT | Shift Code | This is required for source type 1. It is used for Super Backflush transactions. Validated against UDC 06/SH.
AN8 | Address Number | This is the employee number required for source type 1 and time entry transactions. If left blank time entry transaction will not be created. Validated against the address book table F0101.

Additional Comments

Note that the Kanban Status (KBST) in F30161Z1 means the action to be taken as described above, but the Kanban Status in F3016 and F30161 has a different meaning. “1” means The Kanban is at the consuming location ready to be used, “2” means The Kanban is empty and needs replenishment, and “3” means Replenishment has been completed.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and Default logic
TRQT | Transaction Quantity | If left blank the container size from F3016 is used.


Logistics Interface Tables

Logistics Interoperability Interface Tables Include the Following:

Cycle Counts

Inventory Item Cost

Item Master

Warehouse Confirmations


Manufacturing Interface Tables

Manufacturing Interoperability Interface Tables Include the Following:

Bill of Material

Detail Forecast

Kanban Processing

Outbound Work Order Headers

Outbound Work Order Parts List

Outbound Workorder Routing

Planning messages

Quality Management Test Result

Receipt Routing

Routing Master

Super Backflush

Work Center Master

Work Day Calendar

Work Order Completions

Work Order Employee Time Entry

Work Order Inventory Issues


Outbound Sales Order Entry

Tables: F4201Z1, F4211Z1, F49211Z1

Date: October 27, 1998

General Information

Purpose of Transactions

Sales Order Transactions are used to record information about customers and the items they order. On the outbound side, this transaction is used to generate records that that can be used by a third party to update their system with existing sales order information. Inbound transactions are supported through the EDI model only.

The permanent OneWorld tables primarily affected by this transaction are the Sales Order Header File (F4201), the Sales Order Detail File (F4211), and the Sales Order Detail File - Tag File (F49211).

Relationships to Other Transactions

The F4201Z1, F4211Z1, and F49211Z1 transaction files are also used by shipment confirmation. Sales order entry transactions will have a transaction type equal to "JDESOOUT". Shipment confirmations will have a transaction type equal to "JDESHIP".

Transaction-Specific Instructions

The outbound transaction supports additions, changes, and deletions. For changes, both the before and after images can be written.

This transaction uses three interface tables - Header, Detail, and Tag.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - From OneWorld - Table F4201Z1 - Header

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDESOOUT"
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain "UB"; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Additional Comments

For a given sales order, the values in the first three columns will match the values in the first three columns of the corresponding records in the detail table (F4211Z1) and the tag table (F49211Z1).

Data Columns

During outbound transaction, all the data fields in F4201 are written into corresponding fields in F4201Z1.

Column-Specific Instructions - From OneWorld - Table F4211Z1 - Detail

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDESOOUT"
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Additional Comments

For a given sales order, the values in the first three columns will match the values in the first three columns of the corresponding records in the header table (F4201Z1) and the tag table (F49211Z1).

Data Columns

During outbound transaction, all the data fields in F4211 are written into corresponding fields in F4211Z1.

Column-Specific Instructions - From OneWorld - Table F49211Z1 - Tag

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDESOOUT"
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Additional Comments

For a given sales order, the values in the first three columns will match the values in the first three columns of the corresponding records in the header table (F4201Z1) and the detail table (F4211Z1).

Data Columns

During outbound transaction, all the data fields in F49211 are written into corresponding fields in F49211Z1.


Outbound Shipment Confirmation

Tables: F4201Z1, F4211Z1, F49211Z1

Date: October 30, 1998

General Information

Purpose of Transaction

Shipment Confirmation transactions are used to verify that inventory has left the warehouse. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with pre/post shipment confirmation data such as freight calculating, extra shipping documents, or any variety of Post Shipment Confirmation modules. Inbound transactions are supported through the EDI model only.

The permanent OneWorld tables primarily affected by this transaction are the Sales Order Header table (F4201), the Sales Order Detail table (F4211), and the Sales Order Detail Tag table (F49211).

Relationships to Other Transactions

The F4201Z1, F4211Z1, and F49211Z1 transaction files are also used by Sales Order Entry. Shipment Confirmations will have a Transaction Type equal to "JDESHIP". Sales Order Entry transactions will have a Transaction Type equal to "JDESOOUT".

Transaction-Specific Instructions

The outbound transaction supports additions, changes, and deletions. For changes, both the before and after images will be written.

This transaction uses three interface tables - Header, Detail, and Detail Tag. The Detail and the Detail Tag Transactions will be written for each line shipped that already has a detail or tag transaction written (F4211 or F49211record).

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - From OneWorld - Table F4201Z1 - Header

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDESHIP"
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Additional Comments

For a given Shipment Confirmation, the values in the first three columns will match the values in the first three columns of the corresponding records in the detail table (F4211Z1) and the detail tag table (F49211Z1).

Data Columns

OneWorld provides all columns from the corresponding source table.

Column-Specific Instructions - From OneWorld - Table F4211Z1 - Detail

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDESHIP"
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Additional Comments

For a given Shipment Confirmation, the values in the first three columns will match the values in the first three columns of the corresponding records in the header table (F4201Z1) and the detail tag table (F49211Z1).

Data Columns

OneWorld provides all columns from the corresponding source table.

Column-Specific Instructions -From OneWorld - Table F49211Z1 - Detail Tag

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDESHIP"
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Additional Comments

For a given Shipment Confirmation, the values in the first three columns will match the values in the first three columns of the corresponding records in the header table (F4201Z1) and the detail table (F4211Z1).

Data Columns

OneWorld provides all columns from the corresponding source table.


Outbound Work Order Headers

Table: F4801Z1

Date: August 21, 1998

General Information

Purpose of Transaction

Work order header transactions are used to record information about manufacturing work orders for the shop floor. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the work order information. Inbound transactions are not processed through this interface table. Please refer to the Work Order Completions Interface Table User Guide or the Planning Messages Interface Table User Guide for information regarding inbound Add/Update to Manufacturing Work Orders.

The permanent OneWorld table primarily affected by this transaction is the Work Order Master table (F4311).

Relationships to Other Transactions

The F4801Z1 transaction file is also used by Work Order Completions. Work Order Header transactions will have a Transaction Type equal to "JDEWO", Work Order Completions will have a Transaction Type equal to "JDECMP".

Transaction-Specific Instructions

The outbound transaction supports additions, changes, and deletions. For changes, both the before and after images can be written.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - From OneWorld - Table F4801Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and Default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | The Work Order Header system does not batch transactions. Therefore this field will always contain the value "0". No transaction-relevant data is stored in this field.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | For Add and Delete transactions, the Line Number will have a value of 2. For Update Before Image records, the Line Number will have a value of 1. For Update After Image records, the Line Number will have a value of 2.
TYTN | Transaction Type | Name of the transaction - "JDEWO"
TNAC | Action Code | "02" = Add, "03" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Procesed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Data Columns

Data columns in the interface table from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld " section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.

Data Item

Description

Notes and Default

DCTO

Work Order Document Type

A user defined code (00/DT) that identifies the type of document. This code also indicates the origin of the transaction. J.D. Edwards has reserved document type codes for vouchers, invoices, receipts, and time sheets, which create automatic offset entries during the post program. (These entries are not self-balancing when you originally enter them.)
The following document types are defined by J.D. Edwards and should not be
changed:
P Accounts Payable documents
R Accounts Receivable documents
T Payroll documents
I Inventory documents
O Purchase Order Processing documents
J General Accounting/Joint Interest Billing documents
S Sales Order Processing documents

RCD

Reason Code

A user defined code (42/RC) that explains the purpose for a transaction. For example, you can use a code to indicate a transaction that involves returned items, such as goods that were damaged in shipment or the
overshipment of goods.

DGL

Date for Voucher

A date that identifies the financial period to which the transaction is to be posted. The general accounting constants specify the date range for each financial period. You can have up to 14 periods. Generally, period 14 is for audit adjustments.
The system edits this field for PBCO (posted before cutoff), PYEB (prior year ending balance), and so on.

LOTS

Lot Status Code

A user defined code (41/L) that indicates the status of the lot. If this field is blank, it indicates that the lot is approved. All other codes indicate that the lot is on hold.
You can assign a different status code to each location in which a lot resides on Item/Location Information or Location Lot Status Change.

EXPR

Date Expired

The expiration date of the log entry if applicable. For example, consider a submittal requirement for an Insurance Certificate. For such an entry, the termination date for the policy would be entered in the Expired Date field. This date is used by the Submittal Status Update program to update the status field. If the Expired Date is earlier than the current date when you run the program, the system sets the status to N for the log entry.

LOT1

Memo Lot 1

A higher classification or grouping of serial number or lot processed items, maintained within the lot master (F4108).

LOT2

Memo Lot 2

A higher classification or grouping of memo lot 1 maintained within the lot master (F4108).
A higher classification or grouping of memo lot 1 maintained within the lot master (F4108).

DOCO

Work Order Number

Order Number. This is the Unique Identifier of a work order in the J.D. Edwards Manufacturing system.

SFXO

Order Suffix

In the A/R and A/P systems, a code that corresponds to the pay item. In the Sales Order and Purchase Order systems, this code identifies multiple transactions for an original order. For purchase orders, this is always 000.
For sales orders with multiple partial receipts against an order, the first receiver used to record receipt has a suffix of 000, the next has a suffix of 001, the next 002, and so on

RCTO

Related PO/SO/WO Type

A user defined code (00/DT) that indicates the document type of the secondary or related order. For example, a purchase order might be document type OP and might have been created to fill a related work order with document type WO.

RORN

Related PO/SO/WO Number

A number that identifies a secondary purchase order, sales order, or work order associated with the original order. This is for information only.

LNID

Line Number

A number that identifies multiple occurrences, such as line numbers on a purchase order or other document. Generally, the system assigns this number, but in some cases, you can override it.

PTWO

Peg to Work Order

Peg to Work Order

PARS

Parent WO Number

This is the parent work order number. You can use this number to:

  1. Enter default values for newly added work orders, for example, Type, Priority, Status, or Manager.
  2. Group work orders for project setup and reporting

TYPS

Type Work Order

A user defined code (00/TY) that indicates the type classification of a work order or engineering change order.
You can use work order type as a selection criteria for work order approvals.

PRTS

Work Order Priority

A user defined code (00/PR) that indicates the relative priority of a work order or engineering change order in relation to other orders.
A processing option for some forms lets you enter a default value for this field. The value then displays automatically in the appropriate fields on any work order you create on those forms and on the Project Setup form. You can either accept or override the default value.

DL01

Description 01

A user defined name or remark.

STCM

Status Comment

A brief description to explain the status of the work order.

CO

Company

A code that identifies a specific organization, fund, entity, and so on. The company code must already exist in the Company Constants table (F0010) and must identify a reporting entity that has a complete balance sheet. At this level, you can have intercompany transactions.
NOTE: You can use Company 00000 for default values, such as dates and automatic accounting instructions (AAIs). You cannot use Company 00000 for transaction entries.

MCU

Business Unit

An alphanumeric field that identifies a separate entity within a business for which you want to track costs. For example, a business unit might be a warehouse location, job, project, work center, or branch/plant.
You can assign a business unit to a voucher, invoice, fixed asset, employee, and so on, for purposes of responsibility reporting. For example, the system provides reports of open accounts payable and accounts receivable by business units to track equipment by responsible department.
Security for this field can prevent you from locating business units for which you have no authority.
Note: The system uses this value for journal entries if you do not enter a value in the AAI table.

MMCU

Branch

A code that represents a high-level business unit. Use to reference a branch or plant that might have departments or jobs, which represent lower-level business units (data item MCU), subordinate to it. For example:

  • Branch/Plant (MMCU)

  • Dept A (MCU)

  • Dept B (MCU)

  • Job 123 (MCU)

Business unit security is based on the higher-level business unit.

LOCN

Location

A code that identifies inventory locations in a branch/plant. You define the format of the location identifier by branch/plant (P410012).

AISL

Aisle

A code that identifies a location in a warehouse. This code is used in Conjunction with a bin and lot identifier, to indicate a specific, tangible storage area within a warehouse or yard.

BIN

Bin Location

A specific storage location within a warehouse or store. The system uses the bin with an aisle location to identify a storage area whose width, depth, and height can be readily measured.

SRST

WO Status

A user defined code (00/SS) that describes the status of a work order or engineering change order. Any status change from 90 thru 99 automatically updates the date completed.

DCG

Date Status Changed

The date the status last changed.

SUB

Subsidiary

A subdivision of an object account. Subsidiary accounts include more detailed records of the accounting activity for an object account.

AN8

Address Number

A number that identifies an entry in the Address Book system. Use this number to identify employees, applicants, participants, customers, suppliers, tenants, and any other Address Book members.

ANO

Address Number Originator

The address book number of the person who originated the change request.

ANSA

Address Number - Manager

The address book number of a manager or planner.
Note: A processing option for some forms lets you enter a default value for this field based on values for Category Codes 1 (Phase), 2, and 3. Set up the default values on the Default Managers and Supervisors form. After you set up
the default values and the processing option, the information displays automatically on any work orders that you create if the category code criterion is met. (You can either accept or override the default value.)

ANPA

Supervisor

The address book number of the supervisor.
Note: A processing option for some forms allows you to enter a default value for this field based on values for Category Codes 1 (Phase), 2, and 3. Set up the default values on the Default Managers & Supervisor form. After you set up the default values and the processing option, the information displays automatically on any work orders that you create if the category code criterion is met. You can either accept or override the default value.

ANP

Address Number - Assigned to

Address number of the person assigned to do the work.

DPL

Date Planned Complete

The date the work order is planned to be completed.

ANT

Address Number - Inspector

The address book number of the inspector.

NAN8

Next Address Number

An eight-position number used to identify each entry in the Address Book, e.g., employees, customers, suppliers, special mailing addresses, etc.

TRDJ

Date Order Entered

The date that an order was entered into the system. This date determines which effective level is used for inventory pricing.

STRT

Date Start

This is a start date that you can enter, or an automatic start date which the planning system calculates using a backscheduling routine. The routine starts with the required date and offsets the total leadtime to calculate the appropriate start date.

DRQJ

Date Complete

The date that an item is to arrive or that an action is to be complete.

STRX

Date Completed

The date the work order or engineering change order is completed or canceled.

DAP

Date Assigned

The date the person responsible for the work order receives the work order.

DAT

Date Assigned to Inspector

The date assigned for final inspection.

PPDT

Paper Printed

This field indicates the date that the work order paperwork was last printed. A blank field would indicate that the workorder paperwork has not yet been printed.

WR01

Category Code 1

A user defined code (00/W1) that indicates the current stage or phase of development for a work order. You can assign a work order to only one phase code at a time.
Note: Certain forms contain a processing option that allows you to enter a default value for this field. If you enter a default value on a form for which you have set this processing option, the system displays the value in the
appropriate fields on any work orders that you create. The system also displays the value on the Project Setup form. You can either accept or override the default value.

WR02

Category Code 2

User defined code (00/W2), which indicates the type or category of a work order.
Note: A processing option for some forms lets you enter a default value for this field. The value then displays automatically in the appropriate fields on any work orders you create on those forms and on the Project Setup form. (You can either accept or override the default value.)

WR03

Category Code 3

User defined code (00/W3), which indicates the type or category of a work order.
Note: A processing option for some forms lets you enter a default value for this field. The value then displays automatically in the appropriate fields on any work orders you create on those forms and on the Project Setup form. (You can either accept or override the default value.)

WR04

Category Code 4

User defined code (00/W4), that indicates the type or category of a work order.

WR05

Category Code 5

The type or category of work order.

WR06

Category Code 6

A user defined code (00/W6) that indicates the status of the work order.

WR07

Category Code 7

A user defined code (00/W7) that indicates the service type for the work order.

WR08

Category Code 8

The type or category of work order.

WR09

Category Code 9

The type or category of work order.

WR10

Category Code 10

The type or category of work order.

VR01

Reference

An alphanumeric value used as a cross-reference or secondary reference number. Typically, this is the customer number, supplier number, or job number.

VR02

Reference 02

A field available to record reference numbers, such as the supplier's bid document number, quote document, sales order, work order, or job number.

AMTO

Original Amount

The estimated dollar amount that is budgeted for this work order.

SETC

Crew Size

The number of people who work in the specified work center or routing operation. The system multiplies the Run Labor value in the Routing Master table (F3003) by crew size during costing to generate total labor dollars.
If the Prime Load Code is L or B, the system uses the total labor hours for backscheduling. If the Prime Load Code is C or M, the system uses the total machine hours for backscheduling without modification by crew size.

BRT

Revenue Override Markup Rate

The rate the system uses to mark up the revenue amount reflected in the billing of professional services, such as draftsmen, engineers, or consultants fees. This rate does not affect the employee's paycheck. You can use this markup rate as an override rate or as a maximum rate.
The Override Rate Calculator for the Total Revenue markup is:
(Override Rate * Unit) * (1 + Markup %) + Markup Amount
When you specify a Maximum or Cap Rate, the system compares the override rate with the rate from the cost transaction and uses the lower rate as the override rate.
You set up the override/maximum unit rate in the Billing Rate/Markup Table (for World, Cost Plus Markup Table), using generation type 1 to specify a table for revenue/invoice markup rates. You can mark up the revenue amount at a different rate than the invoice amount by using the Billing Rate/Markup Table (for World, Cost Plus Markup Table) with a generation type 2. The value in the Independent Revenue/Invoice field in the constants controls this function.

PAYT

Pay Type

A code to define the type of pay, deduction, benefit or accrual.
Pay types are numbered from 1 to 999 Deductions and benefits from 1000 to
9999. At the present time, the following codes have been "hardcoded":
801 Sick Time Taken
802 Vacation Time Taken
8001 Accruing Sick Time (but not available)
8002 Available Sick Time
8003 Accruing Vacation Time (but not available)
8004 Available Vacation Time
8010 Washington State Industrial Insurance
8020 Oregon Second Injury Insurance NOTE: We ask that you not use the 8000 series so that we may reserve them for other hardcoded purposes that may arise from time to time.

AMTC

Amount Change To

The dollar amount changed from the original dollars budgeted for this Work
Order.

HRSO

Hours Estimated

HRSC

Change to Original Hours

The number of hours changed to the original hours budgeted.

AMTA

Amount Actual

The actual dollars accumulated for the work order.

HRSA

Actual Hours

The actual hours accumulated for the work order.

ITM

Item No - Short

End Item Number

LITM

Item No - 2nd

End Item Number

AITM

Item No - 3rd

End Item Number

NUMB

Asset Item Number

Asset Item Number

APID

Unit Number

A 12-character alphanumeric code used as an alternate identification number
for an asset. This number is not required, nor does the system assign a number if you leave the field blank when you add an asset. If you use this number, it must be unique. For equipment, this is typically the number stenciled on the equipment.

UORG

Quantity Ordered

The quantity of units affected by this transaction.

SOBK

Quantity Backordered/Held

The number of units backordered in Sales Order Management or in Work Order Processing, using either the entered or the primary unit of measure defined for this item.

SOCN

Quantity Scrapped

The number of units canceled in Sales Order or Work Order Processing, using either the entered or the primary unit of measure defined for this item.
In manufacturing, this can also be the number of units scrapped to date.

SOQS

Quantity Shipped

The number of units committed for shipment in Sales Order Entry, using either the entered or the primary unit of measure defined for this item.
In the Manufacturing system and Work Order Time Entry, this field can indicate completed or scrapped quantities. The quantity type is determined by the type code entered.

QTYT

Quantity Shipped to Date

In Work Order Processing, this field identifies the total quantity completed or consumed on a work order to date basis.

UOM

Unit of Measure as Input

A user defined code (00/UM) that indicates the quantity in which to express an inventory item, for example, CS (case) or BX (box).

SHNO

Message Number

A user defined code (48/SN) that is assigned to a standard note, Message, or general narrative explanation. You can use this code to add instructional information to a work order. You set up codes for this field on Standard Description.

PBTM

Hours Begin Time

Future

TBM

Type BOM

A user defined code (40/TB), that designates the type of bill of material. You can define different types of bills of material for different uses. For example:
M (Default)Standard manufacturing bill
RWK Rework bill
SPR Spare parts bill
The system enters bill type M in the work order header when you create a work order, unless you specify another bill type. The system reads the bill type code on the work order header to know which bill of material to use to create the work order parts list. MRP uses the bill type code to identify the bill of material to use when it attaches MRP messages. Batch bills of material must be type M for shop floor control, product costing, and MRP processing.

TRT

Type of Routing

User defined code (40/TR) that designates the type of routing.
You can define different types of routing instructions for different uses.
For example:
M Standard Manufacturing Routing
RWK Rework Routing
RSH Rush Routing
You define the routing type on the work order header. The specific type of routing defined will then be used in the work order routing. Product Costing and Capacity Planning systems use only M type routings.

SHTY

WO Pick List Printed

A code to designate whether or not the Work Order Pick List has been printed for a Work Order. If a 1 is in this code, the Work Order Pick List has been printed.

PEC

Posting Edit Code

A code that controls G/L posting and account balance updates in the Account Master table (F0901). Valid codes are:
blank Allows all posting. Posts subledgers in detailed format for every account transaction. Does not require subledger entry.
B Only allows posting to budget ledger types starting with B or J.
I Inactive account. No posting allowed.
L Subledger and type are required for all transactions. Posts Subledgers in detailed format for every account. The system stores the subledger and type in the Account Ledger and Account Balances tables. If you want to report on subledgers in the Financial Reporting feature, you should use this code.
M Machine-generated transactions only (post program creates offsets).
N Non-posting. Does not allow any post or account balance updates. In the Job Cost system, you can still post budget quantities.
S Subledger and type are required for all transactions. Posts subledgers in summary format for every transaction. The system stores the subledger detail in the Account Ledger table. This code is not valid for budget entry programs.
U Unit quantities are required for all transactions.
X Subledger and type must be left blank for all transactions. Does not allow subledger entry for the account.

PPFG

Variance Flag

A 1 in this field indicates that this work order has had work order activity
run against it in update mode. A 2 in this field indicates that this work
order has had the appropriate variances calculated and reported to the general ledger.

BM

Bill of Material YN

Future

RTG

Route Sheet N

A code to inhibit printing or the routing instructions on the work order.

SPRT

WO Flash Message

A user defined code (00/WM) that indicates a change in the status of a work order. The system indicates a changed work order with an asterisk (*) in the appropriate report or inquiry form field. The flash message is highlighted in the Description field of the work order.

UNCD

Freeze Code

A code that indicates if the order is frozen. MPS/MRP will not plan for frozen orders.
Valid codes are:
Y Yes, freeze the order
N No, do not freeze the order (Default)

INDC

Indeted Code

The work description will be indented to the right up to nine spaces.

RESC

Resequence Code

You can use the resequence code to rearrange work items within a cost code.
If you are using a GANTT chart for your planning, your chart will be sequenced by:

  1. Cost Code,
  2. Resequence Code, and
  3. Work Order Number.

MOH

Amount Mile or Hour

The meter reading, in units such as miles or hours, at which you want to receive a reminder message about an asset. If you use this field, you must run the Update Message Log program on a regular basis.

TDT

Scheduled Tickler

The date that you want to receive a reminder message about an asset.

POU

Amount Budget Changed

The dollar amount (or quantity) required in addition to the budget (original + actual) to complete an item.

PC

Percent Complete

A measurement that identifies the progress being made on an item such as an account, work order, and so on. (It is not always a calculated field and may need to be updated manually.)

LTLV

Leadtime Level

LTCM

Leadtime Cumulative

The total number of days required to build an item from its lowest level components to the final assembly. The system calculates the value differently for manufactured and purchased items.
Manufactured - The total of all level lead times for all manufactured items, plus the highest cumulative lead time of all its components.
Purchased - The item's level leadtime. Purchased item lead times are included in the calculation of cumulative lead times.
You can enter this value manually or you can have the system calculate it when you run the Lead time Rollup program.

CTS1

Unaccounted Direct Labor

The number of unaccounted direct labor hours associated with a specific operation for a work order.

LOTN

Lot/Serial Number

A number that identifies a lot or a serial number. A lot is a group of items with similar characteristics.

LOTP

Lot Potency

A code that indicates the potency of the lot expressed as a percentage of active or useful material (for example, the percentage of alcohol in a solution). The actual potency of a lot is defined in the Lot Master table
(F4108).

LOTG

Lot Grade

This field contains the grade of a lot expressed as an alphanumeric code. The grade is used to indicate the quality of the lot. For example:
A1 premium grade
A2 secondary grade
The grade for a lot is stored in Lot Master table (F4108).

RAT1

Ratio Critical Priority 1

RAT2

Ratio Critical Priority 2

DCT

Doc Type

A user defined code (00/DT) that identifies the origin and purpose of the transaction.
J.D. Edwards reserves several prefixes for document types, such as vouchers, invoices, receipts, and timesheets.
The reserved document type prefixes for codes are:
P Accounts payable documents
R Accounts receivable documents
T Time and Pay documents
I Inventory conversion issues
O Ordering document types
The system creates offsetting entries as appropriate for these document types
when you post batches.

SBLI

Subledger Inactive Code

A code in WorldSoftware, or an option in OneWorld software, that indicates whether a specific subledger is active or inactive. Any value other than blank indicates that a subledger is inactive. Examples are jobs that are closed, employees that have been terminated, or assets that have been disposed. If a subledger becomes active again, set this field back to blank.
If you want to use subledger information in the tables for reports but want to prevent transactions from posting to the master record, enter a value in this field.

RKCO

Related Key Company`

This is the key company associated with the related order document number.

BREV

Bill Rev Level

Indicates the revision level of a bill of material. It is usually used in conjunction with an engineering change notice or order (ECN or ECO). The revision level of the bill of material should match the revision level of its
associated routing (data item RREV), although the system does not check this. This value is defined and maintained by the user.

RREV

Routing Rev Level

Indicates the revision level of a routing. It is usually used in conjunction with an engineering change notice or order (ECN or ECO). The revision level of the routing should match the revision level of its associated bill of material (data item BREV), although the system does not check this.
This value is user defined and not maintained by the system.

DRWC

Drawing Change

Indicates whether the engineering change order involves a drawing change.
Valid values are:
Y Yes, a drawing change is involved.
N No, a drawing change is NOT involved.
If you leave this field blank, the system uses N.

RTCH

Routing Change

Indicates whether the engineering change order involves a routing change.
Valid values are:
Y Yes, a routing change is involved.
N No, a routing change is not involved.
If you leave this field blank, the system uses N.

PNRQ

New Part Number

Indicates whether a new part number is required for an engineering change
order. Valid values are:
Y Yes, a new part number is required.
N No, a new part number is not required.
If you leave this field blank, the system uses N.

REAS

Reason for ECO

User defined code (40/CR), that indicates the reason for an
engineering change order.

PHSE

Phase In

User defined code (40/ PH), that indicates how an engineering change order will be phased in.

XDSP

Existing Disposition

User defined code (40/ED), that identifies the disposition of the
existing item affected by the engineering change order.

BOMC

BOM Change

Indicates whether the engineering change order involves a bill of material change. Valid values are:
Y Yes, a bill of material change is involved.
N No, a bill of material change is not involved.
If left blank the system uses N.

AAID

Parent Number

A parent number groups related components together. Each item of property and piece of equipment can be associated with a parent item, if desired. For example, a mobile telephone can be associated with a specific automobile (the
parent), a printer can be associated with a computer (the parent), or a flat bed can be associated with a specific truck chassis (the parent).
NOTE: If this is a data entry field, the default value is the asset number.
For example, if the asset number is 123, the system assigns 123 to the parent number.

NTST

Next Status WO

The next status for a work order, according to the work order activity rules, as the work order flows through the chain of approval.

XRTO

Critical WO

The criticality of a work order

ESDN

Estimated Down time

This is the estimated duration of a work order. It defines how long the piece of equipment will be down in order to complete the work order, which is different than total estimated hours.

ACDN

Actual Down time

This is the actual duration of a work order. It defines how long the piece of equipment was down in order to complete the work order, which is different than total actual hours.

SAID

Service Address Number

A unique numeric identifier for a physical location at which utility service is delivered. A service address often corresponds to a parcel of land or a unit in an apartment building, etc. This identifier will be assigned by the system through Next Numbers if it is not provided when adding a new service address.

MPOS

Meter Position

A slot, either physical or figurative, into which a meter may be placed in
order to measure consumption of a utility service. A meter position may or may not actually contain a meter. Giving each position a separate identifier helps to clarify the physical layout of a service address that is served by multiple utility meters.

APRT

Approval Type

A user defined code (48/AP) indicating the type of work order approval path that a work order follows. You can use processing options to specify a default approval type based on the type of work order.

AMLC

Amount Estimated Labor

This is the estimated labor cost of a work order.

AMMC

Amount Estimated Material

This is the estimated material cost of a work order

AMOT

Other Estimated Amount

LBAM

Amount Actual Labor

MTAM

Amount Actual Material

URCD

User Reserved Code

URDT

User Reserved Date

URAT

User Reserved Amount

URAB

User Reserved Number

URRF

User Reserved Ref

TORG

Transaction Originator

The person who originally entered the transaction.

USER

User Id

For OneWorld, the identification code for a user profile.

PID

Program Id

The name of the OneWorld batch or interactive application (interactive or
batch object). For example, the name of the Sales Order Processing interactive application is P4210, and the name of the Print Invoices batch process report
is R42565.

JOBN

Workstation Id

The job number (work station ID) that executed the particular job.

UPMJ

Date Updated

The date of the last update to the file record.

TDAY

Time Updated

The computer clock in hours:minutes:seconds.

LINE

Line/Cell Id

Defines a production line or cell. Detailed work center operations can be defined inside the line or cell. For Rate-Based Manufacturing to use this value for reporting, this value must match the line cell in the header

MWDH

Month/Week/Day/Shift

A code that determines the frequency of the schedule. Valid codes are:

  • Monthly

  • Weekly

  • Daily

  • Per Shift

SHFT

Shift Code

A user defined code (06/SH) that identifies daily work shifts. In payroll systems, you can use a shift code to add a percent or amount to the
hourly rate on a timecard.

SCSP

Schedule Spread

A code that determines whether the schedule quantity is to be spread across
all workdays or consolidated on a specific day. Valid codes are:

  • 00 Spread across all workdays.

Consolidated on the first day of the week (Sunday) if the schedule is weekly. Consolidated on the first day of the month if the schedule is monthly.

  • 07 Consolidated on the seventh day of the week (Saturday) if the schedule is weekly. Consolidated on the seventh day of the month if the schedule is monthly.

  • 08-31 Consolidated on that day of the month. Valid only with monthly schedules.

SRCN

Serialized Components


Outbound Work Order Parts List

Table: F3111Z1

Date: November 18, 1998

General Information

Purpose of Transaction

Work Order Parts List transactions are used to record information about parts requirements for maintenance tasks. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the work order parts list information. Inbound transactions are not processed through this interface table. Please refer to the Planning Messages Interface Table User Guide for information regarding inbound Work Parts List transactions.

The permanent OneWorld tables primarily affected by this transaction are the Work Order Master File (F4801) and the Work Order Parts List table (F3111).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The outbound transaction supports additions, changes, and cancellations. Cancellations are treated the same way as changes. For changes, both the before and after images can be written.

This transaction used two interface tables - Header (F4801Z1) and Detail (F3111Z1). Attachment of the Work Order Parts List will update the work order header. As the work order header is updated, the effect of the activity will also trigger transactions to be written to the Outbound Work Order Header Transaction table (F4801Z1). Please refer to the Outbound Work Order Header Interface Table User Guide for more information regarding the F4801Z1 Interface Table.

This transaction will have corresponding records in the Work Order Parts List File (F3111) and the Work Order Master File (F4801).

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - From OneWorld - Table F3111Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | The Work Order Header system does not batch transactions. Therefore this field will always contain the value "0". No transaction-relevant data is stored in this field.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | For Add and Delete transactions, the Line Number will have a value of 2. For Update Before Image records, the Line Number will have a value of 1. For Update After Image records, the Line Number will have a value of 2.
TYTN | Transaction Type | Name of the transaction - "JDEPL"
TNAC | Action Code | "02" = Add, "03" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Data Columns

During outbound transaction, all the data fields in F3111 are written into corresponding fields in F3111Z1.


Outbound Workorder Routing

Table: F3112Z1

Date: November 03, 1998

General Information

Purpose of Transaction

Work Order Routing transactions are used to record information on which work center is responsible for each maintenance task on a work order. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the work order routing information. Inbound transactions are not processed through this interface table. Please refer to the Planning Messages Interface Table User Guide for information regarding Inbound Work Order Routing.

The permanent OneWorld tables primarily affected by this transaction are the Work Order Master File (F4801) and the Work Order Routing table (F3112).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The outbound transaction supports additions, changes, and deletions. For changes, both the before and after images can be written.

This transaction used two interface tables - Header (F4801Z1) and Detail (F3112Z1). Attachment of the Work Order Routing will update the work order header. As the work order header is updated, the effect of the activity will also trigger transactions to be written to the Outbound Work Order Header Transaction table (F4801Z1). Please refer to the Outbound Work Order Header Interface Table User Guide for more information regarding the F4801Z1 Interface Table.

This transaction will have corresponding records in the Work Order Routing File (F3112) and the Work Order Master File (F4801).

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - From OneWorld - Table F3112Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and Default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction (for example, JDEROU)
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Data Columns

During outbound transaction, all the data fields in F3112 are written into corresponding fields in F3112Z1.


New Documents

New Documents consist of links to newly added documentation for the current release. The following are new documents for the EnterpriseOne Xe.

NEW

Document Name

AccessMediaObject

ActivateItem

AddSegment

ClearCharacterizationCache

DeleteItem

DirectorBackButtonClicked

DirectorCancelButtonClicked

DirectorNextButtonClicked

DisableCharacterization

GetOLEItem

InsertURL

JDB_GetLastDBError

JDB_GetUserLevelCount

JDB_GetEnvLevelCount

JDB_DropSingleIndex

JDB_CreateSingleIndex

SetTextColor

InsertText

SetCursorPosition

ubeReport_StopBatchProcess

ubeReport_StopBatchProcessWithError

CompleteActivityInline

Start Process Inline

jdeCacheGetIndex

jdeCacheGetNumCursors

jdeCacheInitMultipleIndex

jdeCacheInitMultipleIndexUser

jdeCacheInitUser

jdeCacheSetIndex

RowIsEntered

RunExecutable

SelectionChanged

SetTabPageText

SystemFunctions

UpdateSegment


Page Footer Section Level Events

Page Footer Section Level Events consist of the following:

InitializePageFooter


Page Header Section Level Events

Page Header Section Level Events consist of the following:

 | EndPageHeader
app.gif (808 bytes) | InitializePageHeader


Report Footer Section Level Events

Report Footer Section Level Events consist of the following:

 | EndReportFooter
app.gif (808 bytes) | InitializeReportFooter


Report Header Section Level Events

Report Header Section Level Events consist of the following:

 | EndReportHeader
app.gif (808 bytes) | InitializeReportHeader


Section Level Events

Section Level Events consist of the following:

AdvanceSection

AfterLastObjectPrinted

BeforeLevelBreak

DoBalanceAuditor

DoColumnHeading

DoSection

DoTabularBreak

EndBrkSection

EndLvlBrkFooterSection

EndLvlBrkHeaderSection

EndOfReport

EndSection

EndVariable

InitLvlBrkFooterSection

InitLvlBrkHeaderSection

InitializeSection

RefreshSection

SupendSection


Updated Documents

Updated Documents consist of links to updated documents for the current release. The links are listed in Date updated order with the most currently updated document appearing first. The following are current updated documents for EnterpriseOne Xe.

Updated Documents

Document Name | Document Name
JDB_AssignColumnValue | JDB_InitEnvOvr()
JDB_ClearColBuffer | JDB_InitSecondaryEnv()
JDB_DeleteCurrent | Update Process Instance Attributes
JDB_DeleteTable | UpdateProcessInstanceAttributeSingle
JDB_DeleteView | Complete Activity
JDB_Fetch | Get Process Instance For Key
JDB_FetchKeyed | Get Process Instance Attributes
JDB_FetchMatchingKey | Get Activity Instance For Key
JDB_FreeBuffer | Start Process
JDB_GetEnv | jdeCacheAdd
JDB_GetObjectDataSource | jdeCacheClear
JDB_GetTableColInfo | jdeCacheCloseCursor
JDB_GetTableColValue | jdeCacheDelete
JDB_RetrieveF0010RowUsingCompanyNumber | jdeCacheDeleteAll
JDB_RetrieveF0013RowUsingCurrencyCode | jdeCacheFetch
JDB_RetrieveF0025RowUsingLedgerType | jdeCacheFetchPosition
JDB_SetF986110 | jdeCacheFetchPositionByRef
JDB_SetF98DR | jdeCacheGetNumRecords
JDB_SetOCM | jdeCacheInit
JDB_SetRequestTriggerOption | jdeCacheOpenCursor
JDB_SetSelectionX | jdeCacheResetCursor
JDB_SetSequencing | jdeCacheTerminate
JDB_SetUserTriggerOption | jdeCacheTerminateAll
jdeCacheUpdate |


Variable Events

Variable Events consist of the following:

 | ClearSpace
app.gif (808 bytes) | ColumnInclusion
app.gif (808 bytes) | DoVariable
 | InitializeVariable
app.gif (808 bytes) | SkipVariable
app.gif (808 bytes) | SuspendVariable


ClearGridLine (Obsolete)

First Available: N/A

Last Modified: B73.3 (June 04, 1998)

Please refer to the corresponding system function documented under Grid system functions.

See Also

  • ClearGridBuffer


Payment Order with Remittance

Tables:F0413Z1, F0414Z1

August 31, 1998; Updated May 2003

General Information

Purpose of Transaction

Payment Order with Remittance transactions are used to issue payment for items or services received. Payments to vouchers or issuing drafts to vouchers for payments can be handled using this transaction. Automatic Payments is used to pay many different payments, while Manual Payments with Match and Manual Payments without Voucher Match are used to pay single payees at a time. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the payment information. Inbound transactions are not supported.

The permanent ERP tables primarily affected by this transaction are the Accounts Payable Matching Document Detail table (F0414) and the Accounts Payable - Matching Document table (F0413).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The outbound transaction supports additions, changes, and deletions.

Draft P1 records are not written to the P0411Z1.

This transaction uses two interface tables - Header (F0413Z1) and Detail (F0414Z1).

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - From ERP - Table F0413Z1 - Header

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from ERP, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDEPYMNT"
TNAC | Action Code | "A" = add, "C" = change, "D" = delete (left justified)
EDSP | Processed flag | When processing for this transaction is complete, ERP updates this to a "Y". For outbound transactions from ERP, these are flagged complete when process log records are written to table F0046.
DRIN | Direction Indicator | "2" = from ERP (outbound). This indicates that the record was written by ERP to be used by other systems.

Additional Comments

For every F0413Z1 there may be more than one F0414Z1. The key for the F0413Z1 is Payment ID, while the key for the F0414Z1 is Payment ID and Line Number.

Data Columns

During outbound transaction, all the data fields in F0413 are written into corresponding fields in F0413Z1.

Column-Specific Instructions - From ERP - Table F0413Z1 - Detail

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into ERP, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within ERP.
EDTN | User Transaction Number | Transaction number generated within ERP to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by ERP as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDEPYMNT"
TNAC | Action Code | "A" = add, "C" = change, "D" = delete (left justified)
EDSP | Processed flag | "2" = from ERP (outbound). This indicates that the record was written by ERP to be used by other systems.
DRIN | Direction Indicator | When processing for this transaction is complete, ERP updates this to a "Y". For outbound transactions from ERP, these are flagged complete when process log records are written to table F0046.

Additional Comments

For every F0413Z1 there may be more than one F0414Z1. The key for the F0413Z1 is Payment ID, while the key for the F0414Z1 is Payment ID and Line Number.

Data Columns

During outbound transaction, all the data fields in F0414 are written into corresponding fields in F0414Z1.

ERP 9.0 Data

The following fields are added to Table F0413Z1 for ERP 9.0.

Data Item | Description | Notes
MIP | Multi-currency Intercompany Flag | Reserved by J.D. Edwards.
LRFL | Localization Reserved Flag | Localization flag.
PRGF | Ready for Purge | Reserved by J.D. Edwards.
GFL7 and GFL8 | Generic Flag | Reserved by J.D. Edwards.
GAM3 and GAM4 | Generic Amount | Reserved by J.D. Edwards.
GEN6 and GEN7 | Generic String | Reserved by J.D. Edwards.

The following fields are added to Table F0414Z1 for ERP 9.0.

Data Item | Description | Notes
BCRC | Base Company Currency Code | A code that represents the currency of the company for a transaction. For a foreign currency transaction, this is the currency code of the domestic side of the transaction.
LRFL | Localization Reserved Flag | Localization flag.
GFL7 and GFL8 | Generic Flag | Reserved by J.D. Edwards
GAM3 and GAM4 | Generic Amount | Reserved by J.D. Edwards
GEN6 and GEN7 | Generic String | Reserved by J.D. Edwards
DRCO | Discount Reason Code | A code that specifies the reason that a discount is given.


Planning Messages

Table: F3411Z1

Date: October 30, 1998

General Information

Purpose of Transaction

Planning Messages transactions are used to store the action messages generated when you run Material Requirements Plan (MRP) or Master Production Schedule (MPS). On the inbound side, this transaction is used to populate OneWorld tables with planning messages generated by a third party system. Outbound transactions are not supported.

The permanent OneWorld table primarily affected by this transaction is the MPS/MRP/DRP Message table (F3411).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports adding of Messages or Processing of Messages.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F3411Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDEMSG"
TNAC | Action Code | "A" = add, "C" = change, "D" = delete (left justified)
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
ITM | Item Number | The Item Number to which this message will affect. This item number is in the J.D. Short Item Number format.
MCU | Demand Branch | Demand Branch is the site or branch for the work order or purchase order. For inter-plant orders, this is the plant "demanding" the order. MCU is right-justified.
MMCU | Supply Branch | Supply Branch is used in when the order is for inter-plant demands. For work orders or purchase orders, the Supply Branch is left blank. MMCU is right-justified.
MSGT | Message Type | Message Code is the action of the message. The Message Code must exist in the 34/MT User Defined Code. Examples of valid codes are “C”(Cancel An Order), “D”(Defer Order), “E”(Expedite Order), “G”(Increase Order Qty to), “L”(Decrease Order Qty to), “O”(Order), “P”(Firmed Order) etc.
MSGA | Message Control | Message Control will flag the message as processed or unprocessed by the J.D. Edwards Messages Processing System. For messages which need to be processed, vendors must set this field to a blank character.
HCLD | Hold Code | Hold Code will indicate how the message was created (system or user-entered) and whether or not the message is on hold status. Valid values are “A” (System Generated), “M” (Manually Entered) or “Z” (On Hold). Vendors should use the value of “A” for messages that the planning engine generates.
KCOO | Order Key Company | Order Key Company is a number in string format, which if used along with an order number and order type, will uniquely identify a J.D. Edwards order document (such as a purchase order, a contract, a sales order etc). If the message is a planned order where the order number is unknown, set this field to blanks. Blanks are valid. If there is Key Company value, this field must be left-padded with zeros.
DOCO | Order Number | Order Number is a unique identifier for orders (such as purchase orders, work orders). If the message is a planned order where the order number is unknown, set this field to zero. If the message is a change to an existing order, the order number must exist in the J.D. Edwards Database.
DCTO | Order Type | The Order Type value must be defined in the 00/DT User Defined Code. This field must be populated.
LNID | Line Number | Line Number is a number which identifies multiple occurrences, such as line numbers on a purchase order. If the message is a planned order where the order number is unknown, set this field to zero.
SFXO | Order Suffix | Order Suffix is used for purchase order messages and this code identifies multiple transactions for an original order. If the message is a planned order where the order number is unknown, set this field to zero.
DSC1 | Description | The Description is free-form and will not be validated. This field is populated when the message is a warning type message or when a message is an order quantity change. It will give a brief description of what the warning is. Example: "W.O. Missing Parts List" or "Manual Adjustment Necessary".
TRQT | Transaction Quantity | The transaction quantity is used to specify the quantity of the item it terms of the Primary Unit of Measure. If the message is a planned order, this field will indicate the quantity to order. If this message is an order quantity change, this field will indicate the new quantity of the order.
VEND | Vendor | The Vendor field will indicate the supplier for the item. This field will usually be used for purchase order related messages. Otherwise use zero. The Vendor number must exist in the JDE Address Book table.
DRQJ | Request Date | The Request Date must be a valid date. If the message is a change to the order dates then this date is the original date that the order will be completed or the original date that the items arrive.
STRT | Start Date | The Start Date must be a valid date. It can be the same value as the Request Date but never later than it.
RSTJ | Recommended Start Date | The Recommended Start Date must be a valid date. If the message is a planned order, then it will be the date that the order will need to be started. If the message is a change to the order dates then this date is the new date that the order will be started on.
RRQJ | Recommended Complete Date | The Recommended Complete Date must be a valid date. If the message is a planned order, then this is the date that the order will be completed or the date that the items arrive. If the message is a change to the order dates then this date is the new date that the order will be completed on.
UKID | Unique Key ID | Always pass in the value of zero
PFLG | Processing Flag | The Processing Flag will instruct the J.D. Edwards Inbound Messages Sytem to act on the incoming message immediately or to write the message into the J.D. Edwards Messages System for later processing/action. “1” - AutoProcess Immediately “ “ - (Blank Char) Do Not Act, store as a message in Message table (F3411).

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and Default logic
USER | User ID | Originator of Record. Can be the same value as User ID(EDUS).
PID | Program ID | Program which wrote the record. Can be any useful reference to a program or vendor.
JOBN | Work Station ID | Machine which ran the program.
UPMJ | Date Updated | Date on which this record was written in MM/DD/YY format.
TDAY | Time Updated | Time in special format which the record was written.


Purchase Order Entry

Tables: F4301Z1, F4311Z1

Date: October 28, 1998

General Information

Purpose of Transaction

Purchase order entry transactions are used to record information about purchase orders. On the inbound side, this transaction is used to update OneWorld tables with purchase order information. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the purchase order information.

The permanent OneWorld tables primarily affected by this transaction are the Purchase Order Header table (F4301) and Purchase Order Detail table (F4311).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions only.

The outbound transaction supports additions, changes, and cancellations. Cancellations are treated the same way as changes. For changes, both the before and after images can be written.

This transaction uses two interface tables - Header and Detail.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F4301Z1 - Header

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDEPOIN"
TNAC | Action Code | "A" = add (left justified)
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

For a given purchase order, the values in the first three columns must match the values in the first three columns of the corresponding records in the detail table (F4311Z1).

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
AN8 | Supplier Number | Supplier from whom you are ordering. Checked against the Address Book Master table (F0101).
MCU | Branch/Plant | Branch/Plant of the purchase order. Checked against the Business Unit Master table (F0006).

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
DGL | G/L Date |
SFXO | Order Suffix |

Column-Specific Instructions - Into OneWorld - Table F4311Z1 - Detail

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDEPOIN"
TNAC | Action Code | "A" = add (left justified)
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".

Additional Comments

For a given purchase order, the values in the first three columns must match the values in the first three columns of the corresponding records in the header table (F4301Z1).

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
MCU | Branch/Plant | Branch/Plant of the purchase order. Checked against the Business Unit Master table (F0006).
UITM | Item Number | If the line type of the order is “s”, an item number must be entered. Checked against the Item Branch table (F4102).
ANI | Account Number | If the line type is a “B” or “J”, an account number must be entered. Converted and checked against the Account Master table (F0901).

Additional Comments

One of the two columns UITM or ANI must be populated.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
DGL | G/L Date |
SFXO | Order Suffix |
LNTY | Line Type | Checked against the Line Type Control Constants File table (F40205).

Column-Specific Instructions - From OneWorld - Table F4301Z1 - Header

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDEPOOUT"
TNAC | Action Code | "A" = add (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain "UB"; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.
EDCT | Document Type | Same value as Order Type (DCTO). Used along with Transaction Type in Data Export Control to determine the specific type of transaction.

Additional Comments

For a given purchase order, the values in the first three columns will match the values in the first three columns of the corresponding records in the detail table (F4311Z1).

Data Columns

Data columns in the interface table from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld " section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.

Column-Specific Instructions - From OneWorld - Table F4311Z1 - Detail

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDEPOOUT"
TNAC | Action Code | "A" = add (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain "UB"; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.
EDCT | Document Type | Same value as Order Type (DCTO). Used along with Transaction Type in Data Export Control to determine the specific type of transaction.

Additional Comments

For a given purchase order, the values in the first three columns will match the values in the first three columns of the corresponding record in the header table (F4301Z1).

Data Columns

Data columns in the interface table from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld " section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.


Purchase Order Receipts

Table: F43121Z1

Date: August 31, 1998

General Information

Purpose of Transaction

Purchase order receipt transactions are used to record receipt information. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the receipt information. Inbound transactions are not supported.

The permanent OneWorld table primarily affected by this transaction is the Purchase Order Receiver table (F43121).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The outbound transaction supports additions only.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions: From OneWorld - Table F43121Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and Default
EDUS | User ID | User ID who instigated the transaction
EDBT | User Batch | Batch number generated within OneWorld
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN
TYTN | Transaction Type | Name of the transaction - "JDER"
TNAC | Action Code | "A" = add
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046
EDCT | Document Type | Same value as Order Type (DCTO). Used along with Transaction Type in Data Export Control to determine the specific type of transaction.

Data Columns

OneWorld provides all columns from the corresponding source table


Quality Management Test Result

Quality Management Test Results

Table: F3711Z1

Date: March 02, 2000

General Information

Purpose of transaction

The Quality Management Test Results Transaction allows users to import test results, entered into a third party system (e.g. LIMS), into the J. D. Edwards OneWorld Tables.

The permanent OneWorld table that is directly effected by the import transaction is Test Results Table (F3711).

Relationships to other transactions

None.

Transaction specific instructions

  • The inbound transaction currently supports additions only.

  • The inbound transaction must have corresponding records in the Test Definitions Master File Table (F3701) and the Preference Profile - Quality Management Table (F40318).

  • Unused fields must be populated by zero(s) or blank space(s), depending on their data types. If you are using our API's to write to the table(s), our internal database API's will handle the conversion for you.

  • Work Center messages are used to help the user identify problems that occurred during the transaction. Messages are line specific and should appear anytime a record runs in error. Otherwise, if the process is completes successfully, a message is sent stating that the entire transaction ran without error.

Column specific instructions Into OneWorld – Table F3711Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi-line transactions (Journal Entries, Sales Orders, etc.), this column must be populated to differentiate each line within a given transaction.
EDDT | Transmission Date | Suggested use is to identify the date the transaction was written to the interface table.
TYTN | Transaction Type | Name of the transaction – "JDEQMTR"
TNAC | Action Code | "A" = add
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". The next time the interface program is executed records that have a value other than a blank space in the EDSP field will be ignored.

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table (Primary Key). You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction. The only exceptions are those cases where you must populate at least one of several columns, but you make the choice - these are listed here.

Data Item | Description | Notes
ITM | Item Number - Short | Used in Business Function calls to build the Preference Profile.
MCU | Business Unit | Used in Business Function calls to build the Preference Profile.
QTST | Test ID | Used to retrieve records from the Preference Profile.
MCU2 | Business Unit 2 | Used to retrieve records from the Preference Profile.
QVAL | Test Value | The imported test value.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
DCTO | Order Type | Used to identify the type of transaction the test results are associated with (Example: WO, SO).
DOCO | Document (Order No, Invoice, etc.) | The Order Number.
KCOO | Order Company (Order Number) | The Order Number of the Ordering Company, or blank
LNID | Line Number | This field is valid only for test entered against a particular Sales Order Line, else the field should be zero.
LOTN | Lot/Serial Number | The Lot Number that the test results are entered against.
LOCN | Location | The Location that the test results are entered against.
AN8 | Address Number | Used in Business Function calls to build the Preference Profile.

Additional Comments

The above fields are populated based on how test results are performed. There are numerous ways to enter test results. For example, test results may be related to the following:

  • The Lot, Location and Item being tested

  • The Work Order Number along with the Lot and Item being tested

  • Or a Sales Order Line

There is no way to specifically identify the required 'key' fields. Based on how and when testing is performed, determines what fields from the above list is required

.


Receipt Routing

Table: F43092Z1

Date: August 31, 1998

General Information

Purpose of Transaction

Receipt Routing transactions are used to convey information about the routing or disposition of an item on a purchase order after the receipt of the item. On the inbound side, it is used to move items through receipt routing to a new operation or to perform a disposition. On the outbound side, it is used to convey information about items that have gone through the disposition process.

The permanent OneWorld tables primarily affected by this transaction are the Purchase Order Receipt Routing table (F43092), the Receipt Routing Ledger table (F43099), and the Purchase Order Receiver table (F43121).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions only, which are new movements or dispositions.

The outbound transaction supports additions only, which are new dispositions.

Outbound transactions will only be recorded for dispositions. Movements are not written to the F43092Z1.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F43092Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDERR"
TNAC | Action Code | "A" = add (left justified)
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
DOCO | Order Number | Order Number on Receipt. Checked against the Purchase Order Receiver File table (F43121).
DCTO | Order Type | Order Type on Receipt. Checked against the Purchase Order Receiver File table (F43121).
KCOO | Order Company | Order Company on Receipt. Checked against the Purchase Order Receiver File table (F43121).
SFXO | Order Suffix | Order Suffix on Receipt. Checked against the Purchase Order Receiver File table (F43121).
LNID | Line Number | Line Number on Receipt. Checked against the Purchase Order Receiver File table (F43121).
NLIN | Receipt Line Number | Receipt Line Number on Receipt. Checked against the Purchase Order Receiver File table (F43121).
OPRC | Operation Code Form | If movement, then moving from this sequence. If disposition, then dispositioning this record. Defined in UDC 43/OC.
OPRT | Operation Code To | If blank or is same as OPRC, then assumption is that a disposition is requested. Otherwise, movement is requested to this operation sequence. Defined in UDC 43/OC.
UOM | Unit of Measure | Unit of measure of item being moved or dispositioned. Defined in UDC 00/UM.
ITM | Short Item Number | Checked against the Item Branch table (F4102) and Purchase Order Receiver File table (F43121).
QTYM | Quantity To Move |

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and Default logic
DGL | G/L Date |
RCD1 | Returned Reason | Defined in UDC 42/RC.
RCD2 | Reworked Reason | Defined in UDC 42/RC.
RCD3 | Scrapped Reason | Defined in UDC 42/RC.
RCD4 | Rejected Reason | Defined in UDC 42/RC.
RCD 5 | Adjucted Reason | Defined in UDC 42/RC.
DRQJ | Requested Date |
PDDJ | Promised Delivery Date |

Column-Specific Instructions - From OneWorld - Table F43092Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and Default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDERR"
TNAC | Action Code | "A" = add (left justified)
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.
EDCT | Document Type | Same value as Order Type (DCTO). Used along with Transaction Type in Data Export Control to determine the specific type of transaction.

Data Columns

Data columns in the interface table from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld " section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.


RefreshSection

Last Modified: B733.2 | May 07, 1999

The first time the UBE encounters a child section; it issues an initialize section event. Each subsequent time the child section is to be processed, the batch process uses Refresh Section. At this point, the internal structures and pointers for the child section have been established and the UBE is about to select a new group of records for the child section. This logic also works for the level break sections. use this to set the object values of level two sections based on the parent section. You can also use this event to reset or modify data selection and sequencing of the child section.

Available On

  • Any level two section (child- level break header - level break footer-total section)

Typical Usage

The typical use of this event is to set the object values of level two sections based on the parent section. In addition, it is used for resetting/modifying data selection/sequencing of the child section.

Processing Sequence

  1. Refresh Section

  2. Adv Section


Routing Master

Table: F3003Z1

Date: November 2, 1998

General Information

Purpose of Transaction

Routing Master transactions are used to define the sequence of operations necessary to manufacture an item. On the inbound side, this transaction is used to update OneWorld tables with routing information. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the routing information.

The permanent OneWorld table primarily affected by this transaction is the Routing Master File (F3003).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions, changes and deletions.

The outbound transaction supports additions, changes, and deletions. For changes, both the before and after images can be written.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F3003Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDEROU"
TNAC | Action Code | "A" = add, "C" = change, "D" = delete (left justified)
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
TRT | Type Routing | Value must exist in UDC 40/TR
KIT | Parent Item Number | Value must be a valid short item number.
MMCU | Branch | Value must exist in Business Unit Table (F0006)
BQTY | Batch Quantity | Value must be numeric.
OPSQ | Operation Sequence Number | Value must be numeric.
EFFF | Effective Form Date | Value must be a valid date.
LINE | Line/ Cell Identifier | Value must exist in Business Unit Table (F0006)
OPSC | Type Operation Code | Value must exist in UDC 30/OT

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and Default logic
MCU | Business Unit | Work Center name for the routing operations step

Column-Specific Instructions - From OneWorld - Table F3003Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and Default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDEROU"
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Data Columns

Data columns in the interface table from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld " section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.


SetFocusOnControl

Last Modified: B733

SetFocusOnControl executes when the parent child control receives the focus.

Available On

§ Parent Child Form types

Available Objects

§ All objects are available.


SetTabPageText

Last Modified: EnterpriseOne | July 10, 2000

This system function allows the user to override the title on the tab.

Parameters

Parameter | Description | I/O | Required | Notes
Tab Control | Tab Control | I | Y | FC Tab Control
Tab page | Tab page | I | Y | TB Name of Tab Page
Text | Text | I | N | New text to replace the tab tile.

Return Values

None

Special Handling Instructions and Prerequisites

· At least one tab page must exist.

Available Events

Available for all events

Related Topics

· Hide Tab Page, Set Current Tab Page


SkipVariable

Last Modified: B733

If an object will not fit on the current page, the UBE will issue a SkipVariable, which will cause the object to be bypassed until the next page begins processing.

Available On

  • This event is only available at the object level.

Typical Usage

The typical use of this event is to change the value of an object at the page break.

Processing Sequence

  • Skip Object

  • Process Next Object (Init-Do-End Object)

  • Adv Section


JDB_TextSearchClearSelection

TextSearchIndexClearing

Last Modified: EnterpriseOne | June 06, 2006

This API clears a text search index build. Text searches do not work on a text search index that has been cleared.

Syntax

JDERTN (TEXTSEARCH_INDEXING_RESULT) JDEWINAPI TextSearchIndexClearing (

HUSER lpUser,

JCHAR* lpszDataSourceName,

JCHAR* lpszBusinessView

);

Parameters

lpUser | Input, required. The user handle that defines the context in which to modify the text search index.
lpszDataSource | Input, required. The data source that defines the location of the data included in the text search index.
lpszBusinessView | Input, required. The business view that defines the data and media objects to include in the text search index.

Additional Notes

Clear a text search index when users no longer need to issue text searches against it. Clearing a text search index releases the system resources associated with it.

Return Values

This API can return these values:

Value | Description
TEXTSEARCH_INDEXING_SUCCESS | The full text search index build completed successfully.
TEXTSEARCH_INDEXING_FAIL | The full text search index build failed.

Example

TEXTSEARCH_INDEXING_RESULT nResult;

nResult = TextSearchIndexClearing(lpUser, _J("My Business Data Source"), _J("V0101C"));

Click to jump to top of page Click to jump to parent topic TextSearchIndexOptimizing

Last Modified: EnterpriseOne | June 06, 2006

This API optimizes a text search index build which reorganizes an existing text search index to facilitate faster text searches.

Syntax

JDERTN (TEXTSEARCH_INDEXING_RESULT) JDEWINAPI TextSearchIndexOptimizing (

HUSER lpUser,

JCHAR* lpszDataSourceName,

JCHAR* lpszBusinessView

);

Parameters

lpUser | Input, required. The user handle that defines the context in which to optimize the text search index.
lpszDataSource | Input, required. The data source that defines the location of the data included in the text search index.
lpszBusinessView | Input, required. The business view that defines the data and media objects included in the text search index.

Additional Notes

Incremental text search index builds reduce the efficiency of text searches. Optimizing text search index reorganizes the data modified by incremental builds in order to improve text search performance.

Return Values

This API can return these values:

Value | Description
TEXTSEARCH_INDEXING_SUCCESS | The full text search index build completed successfully.
TEXTSEARCH_INDEXING_FAIL | The full text search index build failed.

Example

TEXTSEARCH_INDEXING_RESULT nResult;

nResult = TextSearchIndexOptimizing(lpUser, _J("My Business Data Source"), _J("V0101C"));

Click to jump to parent topic Dynamic Logging APIs

This section discusses dynamic logging APIs.

You use these APIs to call the dynamic logging functions. The APIs insert the filename and line number info into the log message that is output when the logging level changes. These logging levels affect what is written to the jdedebug.log files. The logging APIs will write messages to the jdedebug.log files to indicate the logging levels have changed

If you set any dynamic logging options using these APIs, those settings take precedence over the settings in the jde.ini file, but only for kernels that have been changed with these APIs. All other kernels use the jde.ini settings.

Click to jump to top of page Click to jump to parent topic chgOutputLoggingLevel

Last Modified: EnterpriseOne | June 06, 2006

Use this API to turn debug logging on or off. If output logging is turned off, all other logging levels are also turned off, except EVN SaveEVNDoc and IEO Trace logging levels. Those settings are not affected by chgOutputLoggingLevel, which you must disable manually if necessary.

If output logging is turned off, calling this API to turn it off again does not result in another log message indicating that output logging was turned off.

If the level parameter is something other than 0 or 1, an error message is written to the log indicating that the API was called with incorrect parameters. This message is not written if output logging is turned off. Output logging must be turned on for any other logging levels to have an effect. If output logging is turned off, but other logging levels are turned on, the logging output is formatted and prepared for output, but is not written to the log file. This results in a performance reduction without the benefit of extra logging.

Syntax

bool chgOutputLoggingLevel (int level);

Ini File Equivalent

[DEBUG] Output=FILE LogErrors=1

Parameters

level

Input, required. The logging level. Must be either 0 or 1.

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1);

/* turns on output logging and writes a message in the log to indicate that it was turned on */

chgOutputLoggingLevel(0);

/* turns off debug logging, and turns off all other logging levels except for IEO Trace and EVN Save Doc levels. These must

be turned off manually if appropriate */

Click to jump to top of page Click to jump to parent topic chgIPCTraceLevel

Last Modified: EnterpriseOne | June 06, 2006

Use this API to change the IPC Trace logging level.

If you call this function with a valid non-zero level parameter, you should also ensure that output logging is on. If not, no log messages will be written and performance will suffer. Turn output logging on by calling: chgOutputLoggingLevel(1);.

If you call this function with a level parameter outside the valid range, an error message is written to the logs. This message does not appear if output logging is turned off.

Syntax

bool chgIPCTraceLevel (int level);

Ini File Equivalent

[JDEIPC] ipcTrace=x

Parameters

level

Input, required. The logging level. Must be in the range 0–3.

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1);

/* turn on output logging so log messages will be seen */

chgIPCTraceLevel(2);

/* set IPC Trace to level 2 */

chgIPCTraceLevel(0); /* turn off IPCTrace */

chgOutputLogging(0); /* turn off debug logging (and all other logging types) */

See Also

chgOutputLoggingLevel(1)

Click to jump to top of page Click to jump to parent topic chgNetTraceLevel

Last Modified: EnterpriseOne | June 06, 2006

Use this API to change the Net Trace logging level.

If you call this function with a valid non-zero level parameter, you should also ensure that output logging is on. If not, no log messages will be written and performance will suffer. Turn output logging on by calling: chgOutputLoggingLevel(1);.

If you call this function with a level parameter outside the valid range, an error message is written to the logs. This message does not appear if output logging is turned off.

Syntax

bool chgNetTraceLevel (int level);

Ini File Equivalent

[JDENET] netTrace=x

Parameters

level

Input, required. The logging level. Must be in the range 0–7.

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1); /* turn on output logging so log messages will be seen */

chgNetTraceLevel (2); /* set Net Trace to level 2 */

chgNetTraceLevel (0); /* turn off Net Trace */

chgOutputLoggingLevel(0); /* turn off output logging */

See Also

chgOutputLoggingLevel(1)

Click to jump to top of page Click to jump to parent topic chgTAMTraceLevel

Last Modified: EnterpriseOne | June 06, 2006

Use this API to change the TAM Trace logging level.

If you call this function with a valid non-zero level parameter, you should also ensure that output logging is on. If not, no log messages will be written and performance will suffer. Turn output logging on by calling: chgOutputLoggingLevel(1);.

If you call this function with a level parameter outside the valid range, an error message is written to the logs. This message does not appear if output logging is turned off.

Syntax

bool chgTAMTraceLevel (int level);

Ini File Equivalent

[DEBUG] TAMTraceLevel=x

Parameters

level

Input, required. The logging level. Must be in the range 0–9.

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1); /* turn on output logging so log messages will be seen */

chgTAMTraceLevel (5); /* set TAM Trace to level 5 */

chgTAMTraceLevel (0); /* turn off TAM trace logging */

chgOutputLoggingLevel(0); /* turn off debug logging */

Click to jump to top of page Click to jump to parent topic chgCMTraceLevel

Last Modified: EnterpriseOne | June 06, 2006

Use this API to change the CM Trace logging level.

If you call this function with a valid non-zero level parameter, you should also ensure that output logging is on. If not, no log messages will be written and performance will suffer. Turn output logging on by calling: chgOutputLoggingLevel(1);.

If you call this function with a level parameter outside the valid range, an error message is written to the logs. This message does not appear if output logging is turned off.

chgCMTraceLevel works in conjunction with chgCMTraceFilter. You must set the cache logging filter with this API. If the filter is not set when you call chgCMTraceLevel, the cache logging filter will be set to “ALL”, which means that all cache logging messages will be seen, assuming that output logging is also on.

Ini File Equivalent

[DEBUG] CMTrace=1 CMTraceFilter=ALL

Syntax

bool chgCMTraceLevel (int level);

Parameters

level

Input, required. The logging level. Must be either 0 or 1.

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1);

/* turn on output logging so log messages will be seen */

chgCMTraceFilter(_J("ALL"));

/* set filter to ALL meaning all cache logging will be seen*/

chgCMTraceLevel (1);

/* turn cache logging on */

chgCMTraceLevel (0);

/* turn cache logging off */

chgOutputLoggingLevel(0);

/* turn off debug logging */

Click to jump to top of page Click to jump to parent topic chgCMTraceFilter

Last Modified: EnterpriseOne | June 06, 2006

Use this function to set the cache logging filter. This filter enables or prevents certain cache messages from being seen.

Syntax

bool chgCMTraceFilter (jchar filter);

Ini File Equivalent

[DEBUG] CMTraceFilter=nnnnnnnn

Parameters

filter

Input, optional. A comma or semicolon-delimited string of up to 256 characters. If the filter is longer than 256 characters, it is truncated at the 256th character. If the parameter is blank or consists of white space, the filter is set to “ALL”, meaning that all cache logging should be output to the log.

Return Values

This API always returns true.

Example

chgOutputLoggingLevel(1);

/* turn on output logging so log messages will be seen */

chgCMTraceFilter(_J("ALL"));

/* set filter to ALL meaning all cache logging will be seen*/

chgCMTraceLevel (1);

/* turn cache logging on */

chgPSThreadTraceLevel

Last Modified: EnterpriseOne | June 06, 2006

Use this API to change the PSThread Trace logging level.

If you call this function with a valid non-zero level parameter, you should also ensure that output logging is on. If not, no log messages will be written and performance will suffer. Turn output logging on by calling: chgOutputLoggingLevel(1);.

If you call this function with a level parameter outside the valid range, an error message is written to the logs. This message does not appear if output logging is turned off.

Note. Setting this value to 3 results in an extremely large amount of logging and will severely affect performance on the Enterprise server. Do not use level 3 unless you are working with PSThread code and understand the performance degradation.

Ini File Equivalent

[DEBUG] ThreadTraceLevel=x

Syntax

bool chgPSThreadTraceLevel (int level);

Parameters

level

Input, required. The trace level. Must be in the range 0–3.

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1);

/* turn on output logging so log messages will be seen */

chgPSThreadTraceLevel (1);

/* set PSThread Trace to level 1 */

chgPSThreadTraceLevel (0);

/* turn off PSThread logging */

chgOutputLoggingLevel(0);

/* turn off debug logging */

Click to jump to top of page Click to jump to parent topic chgSecTraceLevel

Last Modified: EnterpriseOne | June 06, 2006

Use this API to change the security trace logging level.

If you call this function with a valid non-zero level parameter, you should also ensure that output logging is on. If not, no log messages will be written and performance will suffer. Turn output logging on by calling: chgOutputLoggingLevel(1);.

If you call this function with a level parameter outside the valid range, an error message is written to the logs. This message does not appear if output logging is turned off.

Syntax

bool chgSecTraceLevel (int level);

Ini File Equivalent

[SECURITY] secTrace=x

Parameters

level

Input, required. The trace level. Must be in the range 0–2.

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1);

/* turn on output logging so log messages will be seen */

chgSecTraceLevel (2);

/* set security Trace to level 2 */

chgSecTraceLevel (0);

/* turn off secTrace */

chgOutputLoggingLevel(0);

/* turn off debug logging */

Click to jump to top of page Click to jump to parent topic chgSaveEVNDoc

Last Modified: EnterpriseOne | June 06, 2006

Use this API to change the Save EVN Doc value.

If you call this function with a valid non-zero level parameter, you should also ensure that output logging is on. If not, no log messages will be written and performance will suffer. Turn output logging on by calling: chgOutputLoggingLevel(1);.

If you call this function with a level parameter outside the valid range, an error message is written to the logs. This message does not appear if output logging is turned off.

This function is available only with EVN kernels.

Syntax

bool chgSaveEVNDoc (int level);

Ini File Equivalent

[Interoperability] SaveEVNDoc=1

Parameters

level

Input, required. The save value. Must be either 0 or 1.

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1);

/* turn on output logging so log messages will be seen */

chgSaveEVNDoc (1);

/* set Save EVN Doc level to 1 */

chgSaveEVNDoc (0);

/* turn off SaveEVNDoc*/

Click to jump to top of page Click to jump to parent topic chgIEOTraceLevels

Last Modified: EnterpriseOne | June 06, 2006

Use this API to change the IEO Trace levels.

If you call this function with a valid non-zero level parameter, you should also ensure that output logging is on. If not, no log messages will be written and performance will suffer. Turn output logging on by calling: chgOutputLoggingLevel(1);.

If you call this function with a level parameter outside the valid range, an error message is written to the logs. This message does not appear if output logging is turned off.

Ini File Equivalent

[Interoperability] Level=PERF,TRACE,DOC,DATA,EVENTS

Syntax

bool chgIEOTraceLevels (int level);

Parameters

The parameter level is a bitmap of the following values. To turn on the levels, add together the value in the table below for the values you want to turn on. All other levels will be turned off.

Logging Type | Value | Hex
EVENTS | 1 | 0x01
DATA | 2 | 0x02
PERF | 4 | 0x04
DOC | 8 | 0x08
TRACE | 16 | 0x10

Return Values

This API can return these values:

Value | Description
True | Indicates that the API turned logging on.
False | Indicates that the API turned logging off.

Example

chgOutputLoggingLevel(1);

/* turns on output logging and outputs a message in the log to indicate that it was turned on */

chgOutputLoggingLevel(0);

/* turns off debug logging, and turns off all other logging levels except for IEO Trace and EVN Save Doc levels. These must

be turned off manually if appropriate */

Click to jump to top of page Click to jump to parent topic jdeCacheAdd

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheAdd adds a record to the cache identified by the cache handle hCache that was obtained from the call to jdeCacheInit. The sequence order of the added record is determined by the index that was passed to jdeCacheInit.

Syntax

JDECM_RESULT jdeCacheAdd (HCACHE hCache, void * lpData, long nDataSize)

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
lpData | Input. This is the full structure from which the offsets of the columns that make up the index keys were established. In a JDB environment, the structure represents one record. Use memset() on this structure before adding elements to it.
nDataSize | Input. The size of the structure record that is being passed with the data.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

...

/*initialize cache*/

...

/*add a record*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing 12345");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

jdeCacheClear

Click to jump to top of page Click to jump to parent topic Last Modified: EnterpriseOne | June 06, 2006

jdeCacheClear deletes all the records in the cache. It does not terminate the cache.

Syntax

JDECM_RESULT jdeCacheClear(HCACHE hCache);

Parameters

hCache

Input. A cache handle that uniquely identifies the cache.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

...

/*initialize cache*/

...

/*add some records*/

...

/*do something*/

...

if (jdeCacheClear(hCache)==JDECM_FAILED)

printf("jdeCacheClearCache Failed !\n");

if (jdeCacheGetNumRecords(hCache)!=0)

printf("Still have records in cache after jdeCacheClearCache !\n");

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheCloseCursor

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheCloseCursor closes a cursor pointing to the data set within a cache. The cursor is closed regardless of its position within the data set. A subsequent call to any cursor API except for jdeCacheOpenCursor will fail.

Note. For multiple opened HJDECURSORs, this API must be called to close all opened HJDECURSOR before the cache is terminated.

Syntax

JDECM_RESULT jdeCacheCloseCursor (HCACHE hCache, HJDECURSOR hCursor);

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache, associated with hcache, that you want to close. Use this cursor handle in calls to Data Manipulation APIs to reference records in the cache.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

...

/*initialize cache*/

...

/*add some records*/

...

/*open a cursor*/

...

/*do something*/

...

if (jdeCacheCloseCursor(hCache,hCursor)==JDECM_FAILED)

printf("jdeCacheCloseCursor Failed\n");

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheDelete

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheDelete deletes the record that is pointed to by the cursor. If the cache is not empty and the cursor is open, the record currently being pointed to by HJDECURSOR is deleted.

Syntax

JDECM_RESULT jdeCacheDelete (HCACHE hCache, HJDECURSOR hCursor)

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache associated with hcache. Use this cursor handle in calls to Data Manipulation APIs to reference records in the cache.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

char ret_Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 10;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

..

/*add records*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "12345");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "67890");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

/*open a cursor*/

...

/*fetch position*/

memset(ret_Data,0x00,sizeof(ret_Data));

if (jdeCacheFetchPosition(hCache,hCursor,Data,2,ret_Data,sizeof(ret_Data))==JDECM_FAILED)

printf("Record not found\n");

/*delete the key that the cursor points at*/

if (jdeCacheDelete(hCache,hCursor)==JDECM_FAILED)

printf("Delete record failed\n");

...

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheDeleteAll

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheDeleteAll deletes all records matching the given key from the cache identified by the cache handle hCache that was obtained from the call to jdeCacheInit. This API works well when deleting records based on a partial key.

Syntax

JDECM_RESULT jdeCacheDeleteAll (HCACHE hCache, HJDECURSOR hCursor, void * lpKey, short int nNumKeys)

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache associated with hcache. Use this cursor handle in calls to Data Manipulation APIs to reference records in the cache.
lpKey | Input. Use memset() on this key before adding elements to it. The number, order, and type of the elements in this structure must match that of the defined index keys.
nNumKeys | Input. The number of keys in lpKey. If this number is less than the total defined in jdeCacheInit, the key is treated as a partial key.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 10;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

...

/*add records*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "12345");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "67890");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

/*open a cursor*/

...

/*delete all the records with the first key is "Testing"*/

if (jdeCacheDeleteAll(hCache,hCursor,Data,1)==JDECM_FAILED)

printf("Delete record failed\n");

...

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheFetch

Last Modified: EnterpriseOne | June 06, 2006

JdeCacheFetch advances the cursor to the next record in the dataset relative to the current cursor position and retrieves the record. This becomes the new position associated with HJDECURSOR. This API does not search for a record in the cache. Instead, it fetches the next record after the record that the passed HJDECURSOR is currently pointing to. The API is ideal for performing sequential fetches.

First, the passed HJDECURSOR is checked to see if it's the current ACTIVE cursor. If it is not, the Cursor Manager is referenced and the appropriate HJDECURSOR is obtained and made to be the active HJDECURSOR. If the cache is not empty and the cursor is open, the cursor is advanced to the next record in the data set related to the current cursor position before fetching the record at the new cursor position.

The IpData must be at least the same size as the data set that was added. If you have added different sizes of data sets to the same cache, you must use the size of the largest data set in IpData. If you do not, you might cause memory to be overridden.

Syntax

JDECM_RESULT jdeCacheFetch (HCACHE hCache, HJDECURSOR hCursor, void *lpData, void * lpNull);

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache associated with hcache. Use this cursor handle in calls to Data Manipulation APIs to reference records in the cache.
lpData | Output. Pointer structure to be filled with the fetched data.
lpNull | Input. Must be NULL. Reserved for future use.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

char ret_Data[100];

void lpNull= NULL;

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 10;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

...

/*add records*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "12345");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "67890");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

/*open a cursor*/

...

/*fetch position the cursor to the first record that has the key "Testing"*/

memset(ret_Data,0x00,sizeof(ret_Data));

if (jdeCacheFetchPosition(hCache,hCursor,Data,1,ret_Data,sizeof(ret_Data))==JDECM_FAILED)

printf("Record not found\n");

/*continue fetching*/

memset(ret_Data,0x00,sizeof(ret_Data));

if (jdeCacheFetch(hCache,hCursor,Data,lpNull)==JDECM_FAILED)

printf("jdeCacheFetch Failed\n");

...

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheFetchPosition

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheFetchPosition retrieves the record that corresponds to the given key. You can use this API to position the HJDECURSOR at a specific location within the data set. When you make a call to jdeCacheFetch, it starts fetching from the next position. This is useful for making sequential fetches beginning at a specific location in the cache.

First, the passed HJDECURSOR is checked to see if it's the current active cursor. If it is not, then the Cursor Manager is accessed and the appropriate HJDECURSOR is obtained and made to be the active HJDECURSOR. If the cache is not empty and the cursor is open, then the passed number of keys is checked to see if they constitute a partial index. If they do, then the partial key is used to fetch the first record that matches the given partial key. If the cache is not empty and the cursor is open, the record that matches the given key will be returned and the cursor will point to the founded record.

Syntax

JDECM_RESULT jdeCacheFetchPosition (HCACHE hCache, HJDECURSOR hCursor, void *lpKey, short int nNumColsInKey, void * lpData, long nDataSize)

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache associated with hcache. Use this cursor handle in calls to Data Manipulation APIs to reference records in the cache.
lpKey | Input. Use memset() on this structure before adding elements to it. The number, order, and type of the elements in this structure must match that of the defined index keys.
nNumColsInKey | Input. The number of columns in the passed key with which you want the search to be made. This allows for partial indexing. Only the columns starting from the first column to the number of columns specified may be used. They must be in succession. If this number is less than the total that was defined in jdeCacheInit, then the key is treated as a partial key.
lpData | Output. The offsets of the columns constituting the index keys that were established from this full structure. In a JDB environment, the structure represents one record.
nDataSize | Input. Use sizeof() to get the size of the structure that is being passed with the data.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

char ret_Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 10;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

...

/*add records*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "12345");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "67890");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

/*open a cursor*/

...

/*fetch position the cursor to the first record that has the key "Testing 67890"*/

memset(ret_Data,0x00,sizeof(ret_Data));

if (jdeCacheFetchPosition(hCache,hCursor,Data,2,ret_Data,sizeof(ret_Data))==JDECM_FAILED)

printf("Record not found\n");

...

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheFetchPositionByRef

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheFetchPositionByRef retrieves the memory address of the one and only one data block in cache.

If more than one record exists in cache, this API will return failed. If the cache is empty, this API will return failed. This API will always return the same memory address.

Note. Do not free the returned data pointer address. This action may cause a memory violation problem on certain platforms.

Syntax

JDECM_RESULT jdeCacheFetchPositionByRef(HCACHE hCache, void **lplpData)

Parameters

hCache | Pointer to Data Cache memory. The cache handle must be initialized before calling this API. If the cache handle is NULL, this API will return fail. If the cache handle is not initialized or is an invalid memory, it will cause a memory violation problem. Therefore, the best way to avoid the memory violation problem is to always set the cache handle to NULL where it is defined. Input
lplpData | Output. Pointer to the data block in cache.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

void *lpData=NULL; /*a data pointer*/

/*Initialize cache handle and adds a record*/

...

if (jdeCacheFetchPositionByRef(hCache,&lpData)==JDECM_FAILED)

printf("jdeCacheFetchPositionByRef Failed !! \n");

...

/*Free the cache*/

...

Click to jump to top of page Click to jump to parent topic jdeCacheGetIndex

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheGetIndex enables you to retrieve the ID of the index to which the cursor is pointing. Use this API when you are using multiple indexes.

Syntax

long int jdeCacheGetIndex(HCACHE hCache, HJDECURSOR hCursor)

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache associated with hcache. Use this cursor handle used in calls to Data Manipulation APIs to reference records in the cache.

Return Values

This API can return this value:

long int

The ID of the Index to which the cursor is pointing.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[2];

short int nNumindexes = 2;

char szCacheName[20];

long int nKeyID = 2;

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up multiple indexes structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT)*2);

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

Index[1].nKeyID = 2;

Index[1].nNumSegments = 1;

Index[1].CacheKey[0].nOffset = 10;

Index[1].CacheKey[0].nSize=5;

Index[1].CacheKey[0].idDataType = EVDT_STRING;

/*initialize multiple indexes*/

if (jdeCacheInitMultipleIndex(hUser, &hCache, szCacheName, Index, nNumindexes)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*add some records*/

...

/*open cursor*/

...

if (jdeCacheSetIndexNumCursors(hCache,hCursor,nKeyID)==JDECM_FAILED)

printf("Set Index ID failed !!\n");

/*do something*

if (jdeCacheGetIndexNumCursors(hCache,hCursor)!=nKeyID)

printf("Cursor point at the wrong Index!!\n");

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheGetNumCursors

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheGetNumCursors returns the total number of cursors currently opened in the cache identified by hCache.

Syntax

short int jdeCacheGetNumCursors(HCACHE hCache)

Parameters

hCache

Input. A cache handle that uniquely identifies the cache.

Return Values

This API can return this value:

Value | Description
short int | Total number of cursors currently in the cache.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up an index structure*/

...

/*initialize cache*/

...

/*add some records*/

...

/*open cursor*/

...

if (jdeCacheGetNumCursors(hCache)<1)

printf("No cursor was opened in cache[%s]\n",szCacheName);

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheGetNumRecords

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheGetNumRecords returns the total number of records currently stored in the cache identified by hCache. You can use it to check if the cache is empty.

Syntax

long int jdeCacheGetNumRecords (HCACHE hCache);

Parameters

hCache

Input. A cache handle that uniquely identifies the cache.

Return Values

This API can return this value:

Value |  | Description
long int | Total number of records currently in the cache.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

...

/*initialize cache*/

...

/*add some records*/

...

if (jdeCacheGetNumRecords(hCache)<1)

printf("No records was added to cache[%s]\n",szCacheName);

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheInit

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheInit initializes a named cache, associates the initialized cache with a user and returns a handle to the initialized cache. This API:

1. Creates a cache in memory.

2. Creates an index that will be used to access records in the cache.

3. Names the cache with the name passed with szCacheName.

4. Associates the cache with a cache handle (HCACHE) that the user will use to reference the cache in call to JDE Cache APIs.

You can initialize more than one cache handle using the same cache name, but the lpIndex structure must be an exact match. jdeCacheInit creates a cache with 100 cursors. To create a cache and define the number of cursors, use jdeCacheInitEx.

Note. Without a call to this API or to jdeCacheInitEx, none of the JDECache APIs will work.

Syntax

JDECM_RESULT jdeCacheInit (HUSER hUser, HCACHE *hCache, char * szCacheName, JDECMINDEXSTRUCT *lpIndex);

Parameters

hUser | Input. The user handle obtained from a call to the JDB_ API. It cannot be NULL. The created cache is associated with this handle.
hCache | Output. This cache handle identifies the cache on every call to a JDE Cache API. This means that if a NULL is returned by this API, then any subsequent call to the operational JDE Cache APIs will fail. It is always the first parameter to all the other JDE Cache APIs except for this API and jdeCacheTerminate. There is no limit for the number of cache handles that can be initialized. Do not reuse this handle without having called a jdeCacheTerminate; otherwise, a memory leak will occur.
szCacheName | Input, required. A unique cache identifier. If there is more than one cache, they all should have distinct names. szCacheName cannot be longer than 45 characters.
lpIndex | Input. This index references the data in the cache. It must point to one and only one JDECMINDEXSTRUCT. There cannot be more than 25 CacheKeys in one lpIndex.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

if (jdeCacheInit(hUser, &hCache, szCacheName, Index)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheInitEx

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheInitEx initializes a named cache, associates the initialized cache with a user and returns a handle to the initialized cache. This API:

1. Creates a cache in memory.

2. Creates an index that will be used to access records in the cache.

3. Names the cache with the name passed with szCacheName.

4. Associates the cache with a cache handle (HCACHE) that the user will use to reference the cache in call to JDE Cache APIs.

5. Enables the caller to pass the maximum number of cursors within the range 1 to 100.

You can initialize more than one cache handle using the same cache name, but the lpIndex structure must be an exact match.

Note. Without a call to this API or to jdeCacheInit, none of the JDECache APIs will work.

Syntax

JDECM_RESULT jdeCacheInitEx (HUSER hUser, HCACHE * hCache, JCHAR * szCacheName, JDECMINDEXSTRUCT *lpIndex,short int nSizeCursors);

Parameters

hUser | Input. The user handle obtained from a call to the JDB_ API. It cannot be NULL. The created cache is associated with this handle.
hCache | Output. This cache handle identifies the cache on every call to a JDE Cache API. This means that if a NULL is returned by this API, then any subsequent call to the operational JDE Cache APIs will fail. It is always the first parameter to all the other JDE Cache APIs except for this API and jdeCacheTerminate. There is no limit for the number of cache handles that can be initialized. Do not reuse this handle without having called a jdeCacheTerminate; otherwise, a memory leak will occur.
szCacheName | Input, required. A unique cache identifier. If there is more than one cache, they all should have distinct names. szCacheName cannot be longer than 45 characters.
lpIndex | Input. This index references the data in the cache. It must point to one and only one JDECMINDEXSTRUCT. There cannot be more than 25 CacheKeys in one lpIndex.
nSizeCursors | Input. The maximum number of cursors per cache. It must be in the range from 1 to 100.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

short int nMaxCursors = 10;

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 30;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

if (jdeCacheInit(hUser, &hCache, szCacheName, Index, nMaxCursors ) == JDECM_FAILED )

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheInitMultipleIndex

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheInitMultipleIndex initializes a named multiple indexes cache, associates the initialized cache with a user and returns a handle to the initialized cache. This API accomplishes four things:

1. Creates a cache in memory.

2. Creates indexes that will be used to access records in the cache.

3. Names the cache with the name passed with szCacheName.

4. Associates the cache with a cache handle (HCACHE) that the user will use to reference the cache in call to JDE Cache APIs.

More than one cache handle can be initialized by using the same cache name, but the lpIndex structure must be an exact match.

Note. Without a call to this API or to jdeCacheInitMultipleindexes, none of the JDECache API will work.

Syntax

JDECM_RESULT jdeCacheInitMultipleIndex(HUSER hUser, HCACHE * hCache, char * szCacheName,JDECMINDEXSTRUCT *lpIndex, short int

nNumindexes)

Parameters

hUser | Input. The user handle obtained from a call to the JDB_ API. It cannot be NULL. The created cache is associated with this handle.
hCache | Output. This cache handle identifies the cache on every call to a JDE Cache API. This means that if a NULL is returned by this API, then any subsequent call to the operational JDE Cache APIs will fail. It is always the first parameter to all the other JDE Cache APIs except for this API and jdeCacheTerminate. There is no limit for the number of cache handles that can be initialized. Do not reuse this handle without having called a jdeCacheTerminate; otherwise, a memory leak will occur.
szCacheName | Input, required. A unique cache identifier. If there is more than one cache, they all should have distinct names. szCacheName cannot be longer than 45 characters.
lpIndex | Input. This index references the data in the cache. It must point to one and only one JDECMINDEXSTRUCT. There cannot be more than 25 CacheKeys in one lpIndex.
nNumindexes | Input. Total number of indexes declared in lpIndex.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[2];

short int nNumindexes = 2;

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up multiple indexes structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT)*2);

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

Index[1].nKeyID = 2;

Index[1].nNumSegments = 1;

Index[1].CacheKey[0].nOffset = 10;

Index[1].CacheKey[0].nSize=5;

Index[1].CacheKey[0].idDataType = EVDT_STRING;

/*initialize multiple indexes*/

if (jdeCacheInitMultipleIndex(hUser, &hCache, szCacheName, Index, nNumindexes)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheInitMultipleindexEx

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheInitMultipleindexes initializes a named multiple indexes cache, associates the initialized cache with a user and returns a handle to the initialized cache. This API accomplishes four things:

1. Creates a cache in memory.

2. Creates indexes that will be used to access records in the cache.

3. Names the cache with the name passed with szCacheName.

4. Associates the cache with a cache handle (HCACHE) that the user will use to reference the cache in call to JDE Cache APIs.

5. Enables the caller to pass the maximum number of cursors within the range 1 to 100.

More than one cache handle can be initialized by using the same cache name, but the lpIndex structure must be an exact match.

Note. Without a call to this API or to jdeCacheInitMultipleIndex, none of the JDECache API will work.

Syntax

JDECM_RESULT jdeCacheInitMultipleindexes(HUSER hUser, HCACHE * hCache, char * szCacheName, JDECMINDEXSTRUCT *lpIndex, short

int nNumindexes, short int nSizeCursors);

Parameters

hUser | Input. The user handle obtained from a call to the JDB_ API. It cannot be NULL. The created cache is associated with this handle.
hCache | Output. This cache handle identifies the cache on every call to a JDE Cache API. This means that if a NULL is returned by this API, then any subsequent call to the operational JDE Cache APIs will fail. It is always the first parameter to all the other JDE Cache APIs except for this API and jdeCacheTerminate. There is no limit for the number of cache handles that can be initialized. Do not reuse this handle without having called a jdeCacheTerminate; otherwise, a memory leak will occur.
szCacheName | Input, required. A unique cache identifier. If there is more than one cache, they all should have distinct names. szCacheName cannot be longer than 45 characters.
lpIndex | Input. This index references the data in the cache. It must point to one and only one JDECMINDEXSTRUCT. There cannot be more than 25 CacheKeys in one lpIndex.
nNumindexes | Input. Total number of indexes declared in lpIndex.
nSizeCursors | Input. The maximum number of cursors per cache. It must be in the range from 1 to 100.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[2];

char szCacheName[20];

short int nMaxCursors = 10;

short totalIndexes = 2

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT)*2);

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 30;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

Index[1].nKeyID = 2;

Index[1].nNumSegments = 2;

Index[1].CacheKey[0].nOffset = 50;

Index[1].CacheKey[0].nSize=10;

Index[1].CacheKey[0].idDataType = EVDT_STRING;

Index[1].CacheKey[1].nOffset = 80;

Index[1].CacheKey[1].nSize=10;

Index[1].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

if (jdeCacheInitMultipleindexes(hUser, &hCache, szCacheName, Index , totalIndexes, nMaxCursors ) == JDECM_FAILED )

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheInitMultipleIndexUser

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheInitMultipleIndexUser initializes a named multiple indexes cache, associates the initialized cache with a user and returns a handle to the initialized cache. This API accomplishes five things:

1. Creates a cache in memory.

2. Creates indexes that will be used to access records in the cache.

3. Makes the cache name to be unique per application.

4. Names the cache with the created unique name.

5. Associates the cache with a cache handle (HCACHE) that the user will use to reference the cache in call to JDE Cache APIs.

More than one cache handles can be initialized by using the same cache name, but the lpIndex structure must be an exact match.

Note. Without a call to this API, none of the jdeCache APIs will work

Syntax

JDECM_RESULT jdeCacheInitMultipleIndexUser(HUSER hUser, HCACHE * hCache, char * szCacheName,JDECMINDEXSTRUCT *lpIndex, short

int nNumindexes, LPBHVRCOM lpBhvrCom)

Parameters

hUser | Input. The user handle obtained from a call to the JDB_ API. It cannot be NULL. The created cache is associated with this handle.
hCache | Output. This cache handle identifies the cache on every call to a JDE Cache API. This means that if a NULL is returned by this API, then any subsequent call to the operational JDE Cache APIs will fail. It is always the first parameter to all the other JDE Cache APIs except for this API and jdeCacheTerminate. There is no limit for the number of cache handles that can be initialized. Do not reuse this handle without having called a jdeCacheTerminate; otherwise, a memory leak will occur.
szCacheName | Input, required. A unique cache identifier. If there is more than one cache, they all should have distinct names. szCacheName cannot be longer than 45 characters.
lpIndex | Input. This index references the data in the cache. It must point to one and only one JDECMINDEXSTRUCT. There cannot be more than 25 CacheKeys in one lpIndex.
nNumindexes | Input. Total number of indexes declared in lpIndex.
lpBhvrCom | Input. Pointer to behavior com structure. This structure will provide cache with the unique manual commit hUuser address used to make cache unique per application.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[2];

short int nNumindexes = 2;

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up multiple indexes structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT)*2);

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

Index[1].nKeyID = 2;

Index[1].nNumSegments = 1;

Index[1].CacheKey[0].nOffset = 10;

Index[1].CacheKey[0].nSize=5;

Index[1].CacheKey[0].idDataType = EVDT_STRING;

/*initialize multiple indexes*/

if (jdeCacheInitMultipleIndexUser(hUser, &hCache, szCacheName, Index, nNumindexes, lpBhvrCom)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheInitUser

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheInitUser initializes a named cache, associates the initialized cache with a user and returns a handle to the initialized cache. This API accomplishes five things:

1. Creates a cache in memory

2. Creates an index that will be used to access records in the cache.

3. Makes the cache name to be unique per application.

4. Names the cache with the created unique name.

5. Associates the cache with a cache handle (HCACHE) that the user will use to reference the cache in call to JDE Cache APIs.

More than one cache handles can be initialized by using the same cache name, but the lpIndex structure must be an exact match.

Syntax

JDECM_RESULT jdeCacheInitUser(HUSER hUser, HCACHE * hCache, char * szCacheName , JDECMINDEXSTRUCT * lpIndex, LPBHVRCOM lpBhvrCom)

Parameters

hUser | Input. The user handle obtained from a call to the JDB_ API. It cannot be NULL. The created cache is associated with this handle.
hCache | Output. This cache handle identifies the cache on every call to a JDE Cache API. This means that if a NULL is returned by this API, then any subsequent call to the operational JDE Cache APIs will fail. It is always the first parameter to all the other JDE Cache APIs except for this API and jdeCacheTerminate. There is no limit for the number of cache handles that can be initialized. Do not reuse this handle without having called a jdeCacheTerminate; otherwise, a memory leak will occur.
szCacheName | Input, required. A unique cache identifier. If there is more than one cache, they all should have distinct names. szCacheName cannot be longer than 45 characters.
lpIndex | Input. This index references the data in the cache. It must point to one and only one JDECMINDEXSTRUCT. There cannot be more than 25 CacheKeys in one lpIndex.
lpBhvrCom | Input. Pointer to behavior com structure. This structure will provide cache with the unique manual commit hUuser address used to make cache unique per application.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

if (jdeCacheInitUser(hUser, &hCache, szCacheName, Index, lpBhvrCom)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*do something*/

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheOpenCursor

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheOpenCursor opens a cursor for use. Without opening a cursor, all calls to the JDE Cache Data Manipulating APIs will fail. When a cursor is opened, the cache is first checked to see if it contains any records. If it does then the number of cursors for this cache is checked. If the number is less than the maximum permitted, a new cursor is created and added to the JDE Cache Cursor Manager. This cursor is then assigned to be the current ACTIVE HJDECURSOR for the HCACHE.

Note. The maximum number of open cursors on any one cache is 100

Syntax

JDECM_RESULT jdeCacheOpenCursor (HCACHE hCache, HJDECURSOR * hCursor);

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache associated with hCache. Use this cursor handle used in calls to Data Manipulation APIs to reference records in the cache.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

...

/*initialize cache*/

...

/*add some records*/

...

/*open a cursor*/

if (jdeCacheOpenCursor(hCache,&hCursor)==JDECM_FAILED)

printf("Open cursor failed !\n")

...

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheResetCursor

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheResetCursor resets a cursor, for example, it repositions the cursor to point to the first record in the data set using the first index. The passed cursor is assigned to be the ACTIVE HJDECURSOR cursor for the cache, and if the cache is not empty, then the repositioning takes place.

Syntax

JDECM_RESULT jdeCachResetCursor (HCACHE hCache, HJDECURSOR hCursor);

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache associated with hCache. Use this cursor handle used in calls to Data Manipulation APIs to reference records in the cache.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

...

/*initialize cache*/

...

/*add some records*/

...

/*open a cursor*/

...

/*do something*/

...

if (jdeCacheGetNumRecords(hCache)>0)

{

if (jdeCacheResetCursor(hCache,hCursor)==JDECM_FAILED)

printf("jdeCacheResetCursor Failed, something very bad happened\n");

}

else

printf("The cache is empty and there is no record for the cursor to point at\n");

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheSetIndex

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheSetIndex enables you to set a cursor point to a desired index field by passing in the index ID. Use this API when you are using multiple indexes.

Syntax

JDECM_RESULT jdeCacheSetIndex(HCACHE hCache, HJDECURSOR hCursor, long int nIndexID)

Parameters

hCache | Input. A cache handle that uniquely identifies the cache.
hCursor | Input. The cursor pointing to the data set within the cache associated with hCache. Use this cursor handle used in calls to Data Manipulation APIs to reference records in the cache.
nIndexID | Input. One of the declared Index IDs in the Index structure.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[2];

short int nNumindexes = 2;

char szCacheName[20];

long int nKeyID = 2;

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up multiple indexes structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT)*2);

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

Index[1].nKeyID = 2;

Index[1].nNumSegments = 1;

Index[1].CacheKey[0].nOffset = 10;

Index[1].CacheKey[0].nSize=5;

Index[1].CacheKey[0].idDataType = EVDT_STRING;

/*initialize multiple indexes*/

if (jdeCacheInitMultipleIndex(hUser, &hCache, szCacheName, Index, nNumindexes)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return;

}

/*add some records*/

...

/*open cursor*/

...

if (jdeCacheSetIndexNumCursors(hCache,hCursor,nKeyID)==JDECM_FAILED)

printf("Set Index ID failed !!\n");

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheTerminate

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheTerminate dissociates a named cache handle from the cache. This means that the passed cache handle cannot be used to access this cache anymore. This has the effect of destroying the cache being referenced by the cache handle to the calling application. If this is the jdeCacheTerminate call that matches the total number of jdeCacheInit calls, then the cache is not only disassociated from the cache handle but also physically destroyed from memory.

Note. If more than one cache handle with the same cache name is initialized, one call to this API does not terminate all of the cache handles from memory. You can terminate all of them by calling jdeCacheTerminateAll.

Syntax

JDECM_RESULT jdeCacheTerminate (HUSER hUser,HCACHE hCache)

Parameters

hUser | Input. The user handle obtained from a call to the JDB_ API. It cannot be NULL. The destroyed cache is that associated with this handle.
hCache | Output. A cache handle that uniquely identifies the cache. After jdeCacheTerminate returns, this cache cannot be accessed. You must start the caching process again to access this cache.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

if (jdeCacheInit(hUser, &hCache, szCacheName, Index)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheTerminateAll

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheTerminateAll destroys all caches with the same name as the one with the given hCache. The caches are physically removed from memory.

Syntax

JDECM_RESULT jdeCacheTerminateAll (HUSER hUser, HCACHE hCache)

Parameters

hUser | Input. The user handle obtained from a call to the JDB_ API. It cannot be NULL. The destroyed caches are those associated with this handle.
hCache | Output. A cache handle that uniquely identifies the cache. After jdeCacheTerminateAll returns, these caches cannot be accessed. You must start the caching process again to access this cache.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HCACHE hCache1;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char szCacheName1[20];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,”B3200052CMCache”);

memset(szCacheName1,0x00,sizeof(szCacheName1));

strcpy(szCacheName,”B4321234CMCache”);

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

ndex[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 15;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

if (jdeCacheInit(hUser, &hCache, szCacheName, Index)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

...

if (jdeCacheInit(hUser, &hCache1, szCacheName1, Index)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

...

if (jdeCacheInit(hUser, &hCache, szCacheName, Index)==JDECM_FAILED)

{

printf("Initialize cache failed \n");

/*do something*/

return ;

}

/*do something*/

...

/*terminates all caches*/

if (jdeCacheTerminateAll(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminateAll Failed \n");

Click to jump to top of page Click to jump to parent topic jdeCacheUpdate

Last Modified: EnterpriseOne | June 06, 2006

jdeCacheUpdate updates the record that is being pointed to by the passed HJDECURSOR with the passed data. You should use a cursor manipulation API that does not advance the cursor, such as jdeCacheFetch or jdeCacheFetchPosition to position the cursor to the record to be updated before calling this API.

If the cache is not empty and the cursor is open, then the record currently being pointed to by HJDECURSOR is updated.

Syntax

JDECM_RESULT jdeCacheUpdate(HCACHE hCache, HJDECURSOR hCursor, void *lpData, long nDataSize);

Parameters

hCache | Intput. A cache handle that uniquely identifies the cache.
hCursor | Input. Use this cursor handle used in calls to Data Manipulation APIs to reference records in the cache.
lpData | Input. ndPointer structure containing the data to be used to update the cache.
nDataSize | Input. The size of the structure that is being passed with the data.

Return Values

This API can return these values:

Value | Description
JDECM_PASSED | Returned when this API succeeds.
JDECM_FAILED | Returned when this API fails.

Example

HCACHE hCache;

HJDECURSOR hCursor;

JDECMINDEXSTRUCT Index[1];

char szCacheName[20];

char Data[100];

char ret_Data[100];

memset(szCacheName,0x00,sizeof(szCacheName));

strcpy(szCacheName,"B3200052CMCache");

/*set up index structure*/

memset(Index,0x00,sizeof(JDECMINDEXSTRUCT));

Index[0].nKeyID = 1;

Index[0].nNumSegments = 2;

Index[0].CacheKey[0].nOffset = 0;

Index[0].CacheKey[0].nSize=10;

Index[0].CacheKey[0].idDataType = EVDT_STRING;

Index[0].CacheKey[1].nOffset = 10;

Index[0].CacheKey[1].nSize=10;

Index[0].CacheKey[1].idDataType = EVDT_STRING;

/*initialize cache*/

...

/*add records*/

strcpy(Data,"Testing");

strcpy(Data+10, "12345");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

memset(Data,0x00,sizeof(Data));

strcpy(Data,"Testing");

strcpy(Data+10, "67890");

if (jdeCacheAdd(hCache,Data,sizeof(Data))==JDECM_FAILED)

printf("Add record failed !!\n");

/*open a cursor*/

...

/*fetch position the cursor to the first record that has the key "Testing 67890"*/

memset(ret_Data,0x00,sizeof(ret_Data));

if (jdeCacheFetchPosition(hCache,hCursor,Data,2,ret_Data,sizeof(ret_Data))==JDECM_FAILED)

printf("Record not found\n");

/*update the located record*/

memset(Data,0x00,sizeof(Data));

strcpy(Data,"DoneTest");

strcpy(Data+10, "45612");

if (jdeCacheUpdate(hCache,hCursor,Data,sizeof(Data))==JDECM_FAILED)

printf("jdeCacheUpdate Failed\n");

/*do something*/

...

if (jdeCacheTerminate(hUser,hCache)==JDECM_FAILED)

printf("jdeCacheTerminate Failed \n");

Click to jump to parent topic

Click to jump to top of page Click to jump to parent topic jdePPSRand

Last Modified: EnterpriseOne | June 06, 2006

This is a replacement for the standard C API srand(), to be used in conjunction with the API jdePPRand. The jdePPSRand function sets the seed at the process level for a new sequence of pseudo-random numbers to be returned by subsequent calls to jdePPRand. If jdePPSRand is called with the same seed value, the same sequence of pseudo-random numbers is repeated by jdePPRand. If the function jdePPSRand is not called to initialize the seed, the first call to jdePPRand returns a random number with seed equal to 1 and then creates a new seed stored.

Parameters

This API takes the following parameters, which are the same as those for the standard C API srand:

Seed

Input, required. Used to guarantee unique, pseudo-random numbers generated by jdePPRand. Must be an integer greater than zero.

Syntax

void jdePPSRand(int seed)

Return Values

This API has no return values.

Example

This example creates a random number with a seed which is unique for each process. You should call jdePPSRand only once to initialize a seed. After each call to the threadsafe function jdePPRand, a new seed is created and stored internally in the global variable.

void foo(int * rand)

{

jdePPSRand((unsigned)time( NULL ));

*rand=jdePPRand();

}

Click to jump to top of page Click to jump to parent topic jdePPRand

Last Modified: EnterpriseOne | June 06, 2006

This is a threadsafe replacement for the standard C API rand(). jdePPRand returns an unique pseudo-random integer between 0 and RAND_MAX for multithreading process. If the function jdePPSRand is not called to initialize the seed, the first call to the function jdePPRand returns a random number with seed equal to 1 and then creates a new seed stored. Any following call to the function jdePPRand would use the seed created previously to return a random number and then update the seed.

Syntax

int jdePPRand(void);

Parameters

This API takes no parameters.

Return Values

This API can return this value:

Value | Description
An integer | An pseudo-random integer value greater than zero.

Example

This example creates a random number without setting the first seed.

void foo(int *rand)

{

*rand=jdePPRand();

}

Click to jump to top of page Click to jump to parent topic jdeLocaltime

Last Modified: EnterpriseOne | June 06, 2006

This is a threadsafe replacement for the standard C API localtime(). It converts the time passed in by pnTime, to a local time value. This local time is returned in the pzTime buffer parameter allocated and passed in by the caller.

Syntax

void jdeLocaltime(const time_t *pnTime, struct tm *pzTime)

Parameters

This API can take these parameters:

PnTime | A pointer to a time_t structure containing value to convert to local time.
PzTime | Return parameter to store converted local time value.

Return Values

This API has no return values.

Example

Void foo()

{ struct tm today = {0};

struct _timeb ztimeBuffer = {0};

_ftime( &ztimeBuffer );

jdeLocaltime(&ztimeBuffer.time, &today);

}

Click to jump to top of page Click to jump to parent topic jdeGT_CloseTable

Last Modified: EnterpriseOne | June 06, 2006

This function closes the F00165 table and releases the table handle. This API must be invoked after the jdeGT_OpenTable() API is used.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_CloseTable(HREQUEST hRequestGT);

Parameters

hRequestGT

Input, required. GT table handle to be closed and released.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("");

JDBReturn = JDB_InitBhvr(.., &hUser);

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

...

...

}

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

See Also

jdeGT_DeleteData/jdeGT_DeleteDataKeyStr

jdeGT_FetchData/jdeGT_FetchDataEx

jdeGT_InsertData/jdeGT_InsertDataKeyStr

jdeGT_OpenTable

jdeGT_SelectData/jdeGT_SelectDataKeyStr

jdeGT_UpdateData/jdeGT_UpdateDataKeyStr

Click to jump to top of page Click to jump to parent topic jdeGT_DeleteData/jdeGT_DeleteDataKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes a record in the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_DeleteData(

HREQUEST hRequestGT,

PJSTR pszOjbectName,

LPVOID lpMODSKey,

int nSeq

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_DeleteDataKeyStr(

HREQUEST hRequestGT,

PJSTR pszOjbectName,

PJSTR pszGTKeyStr,

int nSeq

);

Parameters

hRequestGT | Input, required. GT table handle to be closed and released.
pszObjectName | Input, required. GT data structure name.
lpMODSKey | Input, required. GT data structure with data loaded (use in jdeGT_SelectData). This data is formatted into the string for TXKY.
pszGTKeyStr | Input, required. GT-formatted string from the GT data structure (use in jdeGT_SelectDataKeyStr).

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Additional Notes

Invoke this API after using the jdeGT_OpenTable() API. This API is used for multiple access of the table within one function scope.

This table describes the MODATA (or LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Example

This is the first of two examples for this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

JCHAR szFormatKey[255] = _J("1");

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

JDBReturn = JDB_InitBhvr(.., &hUser);

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectDataKeyStr (hRequest, szObjectName, szFormatKey, szLang,

OBJ_JDEOLE);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

while (JDBReturn = JDEDB_PASSED)

{

jdeGT_DeleteDataKeyStr(hRequest, szObjectName, szFormatKey, lpGTData->nSeq);

jdeGTFreeMOData(lpGTData, 1);

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

}

}

jdeGTFreeMOData(lpGTData, 1);

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

This is the second example for this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

DSABGT dsAbGT = {0};

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

JDBReturn = JDB_InitBhvr(.., &hUser);

ParseNumericString(dsAbGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectData(hRequest, szObjectName, &dsAbGT, szLang, OBJ_JDEOLE);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

while (JDBReturn = JDEDB_PASSED)

{

jdeGT_DeleteData(hRequest, szObjectName, &dsAbGT, lpGTData->nSeq);

jdeGTFreeMOData(lpGTData, 1);

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

}

}

jdeGTFreeMOData(lpGTData, 1);

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

See Also

jdeGT_CloseTable

jdeGT_FetchData/jdeGT_FetchDataEx

jdeGT_InsertData/jdeGT_InsertDataKeyStr

jdeGT_OpenTable

jdeGT_SelectData/jdeGT_SelectDataKeyStr

jdeGT_UpdateData/jdeGT_UpdateDataKeyStr

Click to jump to top of page Click to jump to parent topic jdeGT_FetchData/jdeGT_FetchDataEx

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves one record from the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_FetchData(

HREQUEST hRequestGT,

LPMODATA *lpMOData

BOOL bConvRTFText

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_FetchDataEx(

HREQUEST hRequestGT,

JCHAR *szObjectName,

JCHAR *szGTKey,

LPMODATA *lpMOData

BOOL bConvRTFText

);

Parameters

hRequestGT | Input, required. GT table handle to be closed and released.
szObjectName | Output. Object name (OBNM)-character array.
szGTKey | Output. Generic text key in the string format (TXKY)-character array.
*lpMOData | Output. Allocated memory for data.
bCovRTFText | Input. TRUE = Convert any RTF text to plain text.

Additional Notes

Invoke this API after using the jdeGT_OpenTable() API. This API is used for multiple access of the table with one function scope.

This table describes the MODATA (or LOMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of three examples for this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

JCHAR szFormatKey[255] = _J("1");

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

JDBReturn = JDB_InitBhvr(.., &hUser);

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectDataKeyStr (hRequest, szObjectName, szFormatKey, szLang,

OBJ_JDEOLE);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

while (JDBReturn = JDEDB_PASSED)

{

jdeGT_DeleteDataKeyStr(hRequest, szObjectName, szFormatKey, lpGTData->nSeq);

jdeGTFreeMOData(lpGTData, 1);

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

}

}

jdeGTFreeMOData(lpGTData, 1);

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

This is the second example of this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

DSABGT dsAbGT = {0};

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

JDBReturn = JDB_InitBhvr(.., &hUser);

ParseNumericString(dsAbGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectData(hRequest, szObjectName, &dsAbGT, szLang, OBJ_JDEOLE);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

while (JDBReturn = JDEDB_PASSED)

{

jdeGT_DeleteData(hRequest, szObjectName, &dsAbGT, lpGTData->nSeq);

jdeGTFreeMOData(lpGTData, 1);

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

}

}

jdeGTFreeMOData(lpGTData, 1);

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

This is the third example of this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

LPMODATA lpGTData = NULL;

JCHAR szGTKey[256] = _J("");

JCHAR szObjName[11] = _J("");

JDBReturn = JDB_InitBhvr(lpBhvrCom, &hUser,(JCHAR *) NULL,

JDEDB_COMMIT_AUTO

);

if (lpDS->idHRequestGT == NULL)

{

JDBReturn = jdeGT_OpenTable (hUser, lpDS->szFromDatasource,

lpDS->szObjectName, &hRequestGT);

lpDS->idHRequestGT = (ID) jdeStoreDataPtr(hUser, hRequestGT);

else

{

hRequestGT = (HREQUEST) jdeRetrieveDataPtr(hUser, lpDS->idHRequestGT);

if (hRequstGT)

{

JDBReturn = jdeGT_SelectData(hRequest, lpDS->szObjectName,

NULL, lpDS->szLang, OBJ_JDEOLE);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchDataEx(hRequest, szObjName, szGTKey, lpGTData, TRUE);

if (JDBReturn = JDEDB_PASSED)

{

jdeStrncpy(lpDS->szGTKeyData, szGTKey, 255);

jdeStrncpy(lpDS->szTextData, lpGTData->pData, 255);

jdeGTFreeMOData(lpGTData, 1);

else

{

jdeRemoveDataPtr(hUser, lpDS->idHRequestGT);

lpDS->idHRequestGT = 0L;

}

}

else

{

jdeRemoveDataPtr(hUser, lpDS->idHRequestGT);

lpDS->idHRequestGT = 0L;

}

if (hRequestGT && lpDS->idHRequestGT == 0)

{

jdeGT_CloseTable(hRequestGT);

}

JDB_FreeBhvr(hUser);

return;

See Also

jdeGT_CloseTable

jdeGT_DeleteData/jdeGT_DeleteDataKeyStr

jdeGT_InsertData/jdeGT_InsertDataKeyStr

jdeGT_OpenTable

jdeGT_SelectData/jdeGT_SelectDataKeyStr

jdeGT_UpdateData/jdeGT_UpdateDataKeyStr

Click to jump to top of page Click to jump to parent topic jdeGT_InsertData/jdeGT_InsertDataKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function inserts a record into the F00165 table.

Syntax

JDERTN(JDEDB_RESULT)JDEWINAPI jdeGT_InsertData(

HREQUEST hRequestGT,

PJSTR pszOjbectName,

LPVOID lpMODSKey,

int nSeq,

PJSTR pszGTLang,

LPMODATA lpMOData

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_InsertDataKeyStr(

HREQUEST hRequestGT,

PJSTR pszOjbectName,

PJSTR pszGTKeyStr,

int nSeq,

PJSTR pszGTLang,

LPMODATA lpMOData

);

Parameters

hRequestGT | Input, required. GT table handle to be closed and released.
pszObjectName | Input, required. GT data structure name.
lpMODSKey | Input, required. GT data structure with data loaded (use in jdeGT_SelectData). This data is formatted into the string for TXKY.
pszGTKeyStr | Input, required. GT formatted string from GT data structure (use in jdeGT_SelectDataKeyStr).
nSeq | Input, required. Sequence number for primary key.
pszGTLang | Input. Language code to be updated.
lpMOData | Input, required. Data to be updated.

Additional Notes

Invoke this API after using the jdeGT_OpenTable() API. This API is used for multiple access of the table with one function scope.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples for this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

JCHAR szFormatKey[255] = _J("1");

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

MODATA dsGTNewData = {0};

JCHAR szText[255] = _J("New Text to be inserted");

JDBReturn = JDB_InitBhvr(.., &hUser);

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectDataKeyStr (hRequest, szObjectName, szFormatKey, szLang,

OBJ_JDEALL);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

if (JDBReturn != JDEDB_PASSED)

{

dsGTNewData.nSeq = 1;

dsGTNewData.nMOType = OBJ_RTFTEXT;

dsGTNewData.pData = szText;

jdeStrcpy(dsGTNewData.szItemName, _J("New Text"));

jdeGT_InsertDataKeyStr(hRequest, szObjectName, szFormatKey, 1, szLang, &dsGTNewData);

}

else

{

jdeGTFreeMOData(lpGTData, 1);

}

}

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

This is the second example for this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

DSABGT dsAbGT = {0};

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

MODATA dsGTNewData = {0};

JCHAR szText[255] = _J("New Text to be inserted");

JDBReturn = JDB_InitBhvr(.., &hUser);

ParseNumericString(dsAbGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectData(hRequest, szObjectName, &dsAbGT, szLang, OBJ_JDEALL);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

if (JDBReturn != JDEDB_PASSED)

{

dsGTNewData.nSeq = 1;

dsGTNewData.nMOType = OBJ_RTFTEXT;

dsGTNewData.pData = szText;

jdeStrcpy(dsGTNewData.szItemName, _J("New Text"));

jdeGT_InsertData(hRequest, szObjectName, &dsAbGT, 1, szLang, &dsGTNewData);

}

else

{

jdeGTFreeMOData(lpGTData, 1);

}

}

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

See Also

jdeGT_CloseTable

jdeGT_DeleteData/jdeGT_DeleteDataKeyStr

jdeGT_FetchData/jdeGT_FetchDataEx

jdeGT_OpenTable

jdeGT_SelectData/jdeGT_SelectDataKeyStr

jdeGT_UpdateData/jdeGT_UpdateDataKeyStr

Click to jump to top of page Click to jump to parent topic jdeGT_OpenTable

Last Modified: EnterpriseOne | June 06, 2006

This function enables the F00165 table to be opened based on the object name or data source. It must be used first if the related functions are to be used. This API is used for multiple access of the table within one function scope.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_OpenTable(

HUSER hUser,

PJSTR pszDataSource,

PJSTR pszObjectName,

HREQUEST *hRequestGT

);

Parameters

hUser | Input, required. User handle.
pszDataSource | Input. If empty, use the default data source from the pszObejctName. Data source has precedence over the object name.
pszObjectName | Input, required if pszDatasource is empty.
hRequestGT | Output. If open table fails, NULL pointer is returned; otherwise, a pointer to the handle is returned.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples for this API, and it demonstrates using data source:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("");

JDBReturn = JDB_InitBhvr(.., &hUser);

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

...

...

}

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

This example demonstrates using object name:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J(" ");

JCHAR szObjectName[11] = _J("ABGT");

JDBReturn = JDB_InitBhvr(.., &hUser);

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

...

...

}

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

See Also

jdeGT_OpenTable

jdeGT_DeleteData/jdeGT_DeleteDataKeyStr

jdeGT_FetchData/jdeGT_FetchDataEx

jdeGT_InsertData/jdeGT_InsertDataKeyStr

jdeGT_SelectData/jdeGT_SelectDataKeyStr

jdeGT_UpdateData/jdeGT_UpdateDataKeyStr

Click to jump to top of page Click to jump to parent topic jdeGT_SelectData/jdeGT_SelectDataKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function enables a data selection to be applied against the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_SelectData(

HREQUEST hRequestGT,

PJSTR pszOjbectName,

LPVOID pdsGTKeyDS,

PJSTR pszLang,

MOTYPE nMOType

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_SelectDataKeyStr(

HREQUEST hRequestGT,

PJSTR pszOjbectName,

PJSTR pszGTKeyStr,

PJSTR pszLang,

MOTYPE nMOType

);

Parameters

hRequestGT | Input, required. GT table handle to be closed and released.
pszObjectName | Input, required. GT data structure name.
pszLang | Input. Language code.
nMOType | Input, required. Media object type.

Additional Notes

Invoke this API after using the jdeGT_OpenTable() API. This API is used for multiple access of the table with one function scope.

This table describes the MODATA (or LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples describing how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

JCHAR szFormatKey[255] = _J("1");

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

JDBReturn = JDB_InitBhvr(.., &hUser);

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectDataKeyStr (hRequest, szObjectName, szFormatKey, szLang,

OBJ_JDEOLE);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

while (JDBReturn = JDEDB_PASSED)

{

jdeGT_DeleteDataKeyStr(hRequest, szObjectName, szFormatKey, lpGTData->nSeq);

jdeGTFreeMOData(lpGTData, 1);

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

}

}

jdeGTFreeMOData(lpGTData, 1);

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

DSABGT dsAbGT = {0};

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

JDBReturn = JDB_InitBhvr(.., &hUser);

ParseNumericString(dsAbGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectData(hRequest, szObjectName, &dsAbGT, szLang, OBJ_JDEOLE);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

while (JDBReturn = JDEDB_PASSED)

{

jdeGT_DeleteData(hRequest, szObjectName, &dsAbGT, lpGTData->nSeq);

jdeGTFreeMOData(lpGTData, 1);

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

}

}

jdeGTFreeMOData(lpGTData, 1);

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

See Also

jdeGT_CloseTable

jdeGT_DeleteData/jdeGT_DeleteDataKeyStr

jdeGT_FetchData/jdeGT_FetchDataEx

jdeGT_InsertData/jdeGT_InsertDataKeyStr

jdeGT_OpenTable

jdeGT_UpdateData/jdeGT_UpdateDataKeyStr

Click to jump to top of page Click to jump to parent topic jdeGT_UpdateData/jdeGT_UpdateDataKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function updates an existing record in the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_UpdateData(

HREQUEST hRequestGT,

PJSTR pszOjbectName,

LPVOID lpMODSKey,

int nSeq,

PJSTR pszGTLang,

LPMODATA lpMOData

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGT_UpdateDataKeyStr(

HREQUEST hRequestGT,

PJSTR pszOjbectName,

PJSTR pszGTKeyStr,

int nSeq,

PJSTR pszGTLang,

LPMODATA lpMOData

);

Parameters

hRequestGT | Input, required. GT table handle to be closed and release.
pszObjectName | Input, required. GT data structure name.
lpMODSKey | Input, required. GT data structure with data loaded (use in jdeGT_SelectData). This data is formatted into the string for TXKY.
nSeq | Input, required. Sequence number for primary key.
pszGTLang. | Input. Language code to be updated.
lpMOData | Input, required. Data to be updated.

Additional Notes

Invoke this API after using the jdeGT_OpenTable() API. This API is used for multiple access of the table with one function scope.

This table describes the MODATA (or LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples describing how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

JCHAR szFormatKey[255] = _J("1");

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

JDBReturn = JDB_InitBhvr(.., &hUser);

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectDataKeyStr (hRequest, szObjectName, szFormatKey, szLang,

OBJ_RTFTEXT);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

if (JDBReturn == JDEDB_PASSED)

{

jdeFree(lpGTData->pData);

lpGTData->pData = jdeAlloc(COMMON_POOL, 255*sizeof(JCHAR), MEM_ZEROINIT);

jdeStrcpy(lpGTData->pData, _J("New Text to be inserted");

jdeGT_UpdateDataKeyStr(hRequest, szObjectName, szFormatKey, lpGTData->nSeq, szLang,

lpGTData);

jdeGTFreeMOData(lpGTData, 1);

}

}

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

This is the second example describing how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

HREQUEST hRequestGT = NULL;

HUSER hUser = NULL;

JCHAR szFromDatasource[51] = _J("Business Data - Adev733o");

JCHAR szObjectName[11] = _J("ABGT");

DSABGT dsAbGT = {0};

JCHAR szLang[3] = _J("");

LPMODATA lpGTData = NULL;

JDBReturn = JDB_InitBhvr(.., &hUser);

ParseNumericString(dsAbGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGT_OpenTable (hUser, szFromDatasource, szObjectName, &hRequestGT);

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_SelectData(hRequest, szObjectName, &dsAbGT, szLang, OBJ_RTFTEXT);

}

if (JDBReturn == JDEDB_PASSED)

{

JDBReturn = jdeGT_FetchData(hRequest, lpGTData, FALSE;

if (JDBReturn == JDEDB_PASSED)

{

jdeFree(lpGTData->pData);

lpGTData->pData = jdeAlloc(COMMON_POOL, 255*sizeof(JCHAR), MEM_ZEROINIT);

jdeStrcpy(lpGTData->pData, _J("New Text to be inserted");

jdeGT_UpdateData(hRequest, szObjectName, &dsAbGT, lpGTData->nSeq, szLang,

lpGTData);

jdeGTFreeMOData(lpGTData, 1);

}

}

jdeGT_CloseTable(hRequestGT);

JDB_FreeBhvr(hUser);

return;

See Also

jdeGT_UpdateData/jdeGT_UpdateDataKeyStr

jdeGT_DeleteData/jdeGT_DeleteDataKeyStr

jdeGT_FetchData/jdeGT_FetchDataEx

jdeGT_InsertData/jdeGT_InsertDataKeyStr

jdeGT_OpenTable

jdeGT_SelectData/jdeGT_SelectDataKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

Last Modified: EnterpriseOne | June 06, 2006

This function adds or updates all record types to the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_AllMOType(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_AllMOTypeKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_AllMOTypeWithLang(

PJSTR szObjectName,

LPVOID lpMODSKey,

PJSTR szLanguage,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
szLanguage | Input. Language code.
pMOData | Input, required. Array of data structure that stores the data to be updated.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

Parameter pData in MODATA must contain a valid pointer to update the text or shortcut media object type.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples demonstrating how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_AllMOTypeKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example demonstrating how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_AllMOType(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function adds or updates HTML, URL, and File record types to the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_HTML(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_HTMLKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structures that stores the data to be updated.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

Parameter pData in MODATA must contain a valid pointer to update the text or shortcut media object type.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_HTMLKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_HTML (_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function adds or updates image record types to the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_Image(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_ImageKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structures that stores the data to be updated.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

Parameter pData in MODATA must contain a valid pointer to update the text or shortcut media object type.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_ImageKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_Image(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function adds or updates OLE record types to the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_OLE(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_OLEKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structures that stores the data to be updated.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

Parameter pData in MODATA must contain a valid pointer to update the text or shortcut media object type.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_OLEKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_OLE(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function adds or updates Shortcut record types to the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_Shortcut (

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_ShortcutKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structures that stores the data to be updated.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

Parameter pData in MODATA must contain a valid pointer to update the text or shortcut media object type.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_ShortcutKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_Shortcut (_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function adds or updates text record types to the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_Text(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_TextKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structures that stores the data to be updated.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

Parameter pData in MODATA must contain a valid pointer to update the text or shortcut media object type.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

The API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_TextKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_Text(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function adds or updates vendor or third-party software record types to the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_Vendor(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTAddUpdate_VendorKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structures that stores the data to be updated.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

Parameter pData in MODATA must contain a valid pointer to update the text or shortcut media object type.

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

The API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_VendorKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTAddUpdate_Vendor (_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes all HTML, URL, and File record types in the F00165 table based on object name (OBNM) and object keys (TXKY).

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllHTML(

PJSTR szObjectName,

LPVOID lpMODSKey

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllHTMLKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

JDBReturn = jdeGTDelete_AllHTMLKeyStr(_J("ABGT") , _J("1"));

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTDelete_AllHTML(_J("ABGT") , &dsABGT);

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes all image record types in the F00165 table based on object name (BNM) and object keys (TXKY).

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllImage(

PJSTR szObjectName,

LPVOID lpMODSKey

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllImageKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples demonstrating how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

JDBReturn = jdeGTDelete_AllImageKeyStr(_J("ABGT") , _J("1"));

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTDelete_AllImage(_J("ABGT") , &dsABGT);

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes all media object record types in the F00165 table based on object name (OBNM) and object keys (TXKY).

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllMOType(

PJSTR szObjectName,

LPVOID lpMODSKey

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllMOTypeKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

JDBReturn = jdeGTDelete_AllMOTypeKeyStr(_J("ABGT") , _J("1"));

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTDelete_AllMOType (_J("ABGT") , &dsABGT);

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes all OLE record types in the F00165 table based on object name (BNM) and object keys (TXKY).

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllOLE(

PJSTR szObjectName,

LPVOID lpMODSKey

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllOLEKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

JDBReturn = jdeGTDelete_AllOLEKeyStr(_J("ABGT") , _J("1"));

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTDelete_AllOLE(_J("ABGT") , &dsABGT);

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes all shortcut record types in the F00165 table based on object name (OBNM) and object keys (TXKY).

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllShortcut(

PJSTR szObjectName,

LPVOID lpMODSKey

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllShortcutKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

JDBReturn = jdeGTDelete_AllShortcutKeyStr(_J("ABGT") , _J("1"));

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTDelete_AllShortcut (_J("ABGT") , &dsABGT);

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes all text record types in the F00165 table based on object name (OBNM) and object keys (TXKY).

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllText(

PJSTR szObjectName,

LPVOID lpMODSKey

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllTextKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

JDBReturn = jdeGTDelete_AllTextKeyStr(_J("ABGT") , _J("1"));

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTDelete_AllText(_J("ABGT") , &dsABGT);

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes all vendor or third-party software record types in the F00165 table based on object name (OBNM) and object keys (TXKY).

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllVendor(

PJSTR szObjectName,

LPVOID lpMODSKey

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_AllVendorKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr

);

Parameters

szObjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY.
pszMOKeyStr | Input, required. Formatted string used for TXKY.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

JDBReturn = jdeGTDelete_AllVendorKeyStr(_J("ABGT") , _J("1"));

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTDelete_AllVendor _J("ABGT") , &dsABGT);

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTDelete_HTML/jdeGTDelete_HTMLKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes specific HTML, URL and file record types from the F00165 table based on the pMOData parameter.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_HTML(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_HTMLKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_HTMLKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_HTML(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTDelete_Image/jdeGTDelete_ImageKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes specific image record types from the F00165 table based on the pMOData parameter.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_Image(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_ImageKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_ImageKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Image(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTDelete_OLE/jdeGTDelete_OLEKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes specific OLE record types from the F00165 table based on pMOData.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_OLE(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_OLEKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_OLEKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_OLE(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTDelete_Shortcut/jdeGTDelete_ShortcutKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes specific shortcut record types from the F00165 table based on the pMOData parameter.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_Shortcut(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_ShortcutKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_ShortcutKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Shortcut (_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTDelete_Text/jdeGTDelete_TextKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes a specific record type from the F00165 table based on pMOData.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_Text(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_TextKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_TextKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Text(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTDelete_Vendor/jdeGTDelete_VendorKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function deletes specific vendors or third-party software record types from the F00165 table based on the pMOData parameter.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_Vendor(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTDelete_VendorKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_VendorKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Vendor(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTFreeMOData

Last Modified: EnterpriseOne | June 06, 2006

This function frees the memory pointer of the allocated array of the MODATA structure. It also frees any memory pointer of the pData member in MODATA.

Syntax

JDERTN(void) JDEWINAPI jdeGTFreeMOData(

LPMODATA lpMOData,

long lNumOfRec

);

Parameters

lpMOData | Input, required. Allocate memory of the array of pointer to MODATA structure. The memory is freed along with any pData pointer.
INumOfRec | Input, required. The number of elements in the array pointer.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_TextKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Text(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves all record types from the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_AllMOType(

PJSTR szObjectName,

LPVOID lpMODSKey,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_AllMOTypeKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_AllMOTypeKeyStr (_J("ABGT"), _J("1"), &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeFreeMOData(pMOData, lTotalRec);

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_AllMOType(_J("ABGT"), &dsABGT, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeFreeMOData(pMOData, lTotalRec);

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves the text record type from the F00165 table and converts the retrieved RTF text to plain text.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_GenericText(

PJSTR szObjectName,

LPVOID lpMODSKey,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_GenericTextKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_GenericTextKeyStr (_J("ABGT"), _J("1"), 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_TextKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_GenericText(_J("ABGT"), &dsABGT, 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Text(_J("ABGT") , &dsABGT, pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves the HTML, URL, and file record type from the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_HTML(

PJSTR szObjectName,

LPVOID lpMODSKey,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_HTMLKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_HTMLKeyStr (_J("ABGT"), _J("1"), 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_HTMLKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_HTML(_J("ABGT"), &dsABGT, 0,&pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_HTML(_J("ABGT") , &dsABGT, pMOData, lTotalRec)

jdeFreeMOData(pMOData, lTotalRec)

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTGet_Image/jdeGTGet_ImageKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves the image record type from the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_Image(

PJSTR szObjectName,

LPVOID lpMODSKey,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_ImageKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_ImageKeyStr (_J("ABGT"), _J("1"), 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_ImageKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_Image(_J("ABGT"), &dsABGT, 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Image(_J("ABGT") , &dsABGT, pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTGet_OLE/jdeGTGet_OLEKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves the OLE record type from the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_OLE(

PJSTR szObjectName,

LPVOID lpMODSKey,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_OLEKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_OLEKeyStr (_J("ABGT"), _J("1"), 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_OLEKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_OLE(_J("ABGT"), &dsABGT, 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_OLE(_J("ABGT") , &dsABGT, pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves the text record type from the F00165 table and does not affect the RTF text.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_RTFText(

PJSTR szObjectName,

LPVOID lpMODSKey,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_RTFTextKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName

Input, required. GT data structure name. Primary unique key.

lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_RTFTextKeyStr (_J("ABGT"), _J("1"), 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_TextKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_RTFText(_J("ABGT"), &dsABGT, 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Text(_J("ABGT") , &dsABGT, pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves the shortcut record type from the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_Shortcut(

PJSTR szObjectName,

LPVOID lpMODSKey,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_ShortcutKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName

Input, required. GT data structure name. Primary unique key.

lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_ShortcutKeyStr (_J("ABGT"), _J("1"), 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_ShortcutKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_Shortcut(_J("ABGT"), &dsABGT, 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Shortcut(_J("ABGT") , &dsABGT, pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves the vendor record type from the F00165 table.

Syntax

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_Vendor(

PJSTR szObjectName,

LPVOID lpMODSKey,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

JDERTN(JDEDB_RESULT) JDEWINAPI jdeGTGet_VendorKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

int nSeq,

LPMODATA pMOData,

long lTotalRec

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOData | Input, required. Array of data structure that stores the data to be deleted.
ITotalRec | Input, required. Indicates the number of array elements in pMOData.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

JDBReturn = jdeGTGet_VendorKeyStr (_J("ABGT"), _J("1"), 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_VendorKeyStr(_J("ABGT") , _J("1"), pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

LPMODATA pMOData = NULL;

long lTotalRec = 0;

DSABGT dsABGT = {0};

ParseNumericString(&dsABGT.mnAddressNumber, _J("1"));

JDBReturn = jdeGTGet_Vendor(_J("ABGT"), &dsABGT, 0, &pMOData, &lTotalRec);

if (JDBReturn == JDEDB_PASSED && pMOData && lTotalRec > 0)

{

jdeGTDelete_Vendor(_J("ABGT") , &dsABGT, pMOData, lTotalRec);

jdeFreeMOData(pMOData, lTotalRec);

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeGTGetCount/jdeGTGetCountKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function retrieves the number of media object records the F00165 table.

Syntax

JDERTN(long) JDEWINAPI jdeGTGetCount(

PJSTR szObjectName,

LPVOID lpMODSKey,

MOTYPE nMOType

);

JDERTN(long) JDEWINAPI jdeGTGetCountKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

MOTYPE nMOType

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOType | Input, required. Media object type.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
>0 | Number of records found.
≤ | Either no records exist or the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

long lTotalRecFound = 0;

BOOL bSuccess = TRUE;

lTotalRecFound = jdeValidateGTExist(_J("ABGT") , &dsABGT, OBJ_RTFTEXT);

if (lTotalRecFound > 0)

{

bSuccess = TRUE;

}

else

{

bSuccess = FALSE;

}

return;

This is the second example of how to use this API:

long lTotalRecFound = 0;

DSABGT dsABGT = {0};

BOOL bSuccess = TRUE;

ParseNumericString(&dsABGT.mnAddressNumber, J("1"));

lTotalRecFound = jdeValidateGTExist(_J("ABGT") , &dsABGT, OBJ_RTFTEXT);

if (lTotalRecFound > 0)

{

bSuccess = TRUE;

}

else

{

bSuccess = FALSE;

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Click to jump to top of page Click to jump to parent topic jdeValidateGTExist/jdeValidateGTExistWithKeyStr

Last Modified: EnterpriseOne | June 06, 2006

This function checks whether any media object records exist in F00165 table.

Syntax

JDERTN(long) JDEWINAPI jdeValidateGTExist(

PJSTR szObjectName,

LPVOID lpMODSKey,

MOTYPE nMOType

);

JDERTN(long) JDEWINAPI jdeValidateGTExistWithKeyStr(

PJSTR szObjectName,

PJSTR pszMOKeyStr,

MOTYPE nMOType

);

Parameters

szOjectName | Input, required. GT data structure name. Primary unique key.
lpMODSKey | Input, required. GT data structure with valid data. The data within the GT data structure is formatted into a string used for TXKY
pszMOKeyStr | Input, required. Formatted string used for TXKY.
pMOType | Input, required. Media object type.

Additional Notes

This table describes the MODATA (or *LPMODATA) data structure definition:

Data Type | Data Description | Note
int | nSeq | Sequence number form MOSEQN.
MOTYPE | nMOType | Media object type.
JCHAR | szUser[11] | User name.
JDEDATE | jdDate | Date updated.
MATH_NUMERIC | mnTime | Time updated.
BOOL | bRTFData | TRUE = RTF Text FALSE = Plain Text or others
JCHAR | szItemName[GT_ITNMSIZE] | Item name
JCHAR | szQueueName[GT_QUESIZE] |
JCHAR | szFileName[GT_FILESIZE] |
PJSTR | pData | Allocate memory for text and shortcut media object type.

This table describes the MOTYPE definition:

Define Type | Note
OBJ_JDEALL | All media object types
OBJ_RTFTEXT | Text media object.
OBJ_JDEIMAGE | Image media object.
OBJ_JDEOLE | OLE media object.
OBJ_MISCJDESHORTCUT | Shortcut media object.
OBJ_MISIMAGEVENDOR | Third-party vendor.
OBJ_MISCHTML | HTML/URL/File media object.

Return Values

This API can return these values:

Value | Description
JDEDB_PASSED | Indicates that the API succeeded.
JDEDB_FAILED | Indicates that the API failed.

Example

This is the first of two examples that demonstrate how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

BOOL bSuccess = TRUE;

JDBReturn = jdeValidateGTExistWithKeyStr (_J("ABGT") , J("1"), OBJ_JDEALL);

if (JDBReturn == JDEDB_PASSED)

{

bSuccess = TRUE;

}

else

{

bSuccess = FALSE;

}

return;

This is the second example of how to use this API:

JDEDB_RESULT JDBReturn = JDEDB_PASSED;

DSABGT dsABGT = {0};

BOOL bSuccess = TRUE;

ParseNumericString(&dsABGT.mnAddressNumber, J("1"));

JDBReturn = jdeValidateGTExist(_J("ABGT") , &dsABGT, OBJ_JDEALL);

if (JDBReturn == JDEDB_PASSED)

{

bSuccess = TRUE;

}

else

{

bSuccess = FALSE;

}

return;

See Also

jdeGTAddUpdate_AllMOType/ jdeGTAddUpdate_AllMOTypeKeyStr/ jdeGTAddUpdate_AllMOTypeWithLang

jdeGTAddUpdate_HTML/jdeGTAddUpdate_HTMLKeyStr

jdeGTAddUpdate_Image/jdeGTAddUpdate_ImageKeyStr

jdeGTAddUpdate_OLE/jdeGTAddUpdate_OLEKeyStr

jdeGTAddUpdate_Shortcut/jdeGTAddUpdate_ShortcutKeyStr

jdeGTAddUpdate_Text/jdeGTAddUpdate_TextKeyStr

jdeGTAddUpdate_Vendor/jdeGTAddUpdate_VendorKeyStr

jdeGTDelete_AllHTML/jdeGTDelete_AllHTMLKeyStr

jdeGTDelete_AllImage/jdeGTDelete_AllImageKeyStr

jdeGTDelete_AllMOType/jdeGTDelete_AllMOTypeStr

jdeGTDelete_AllOLE/jdeGTDelete_AllOLEKeyStr

jdeGTDelete_AllShortcut/jdeGTDelete_AllShortcutKeyStr

jdeGTDelete_AllText/jdeGTDelete_AllTextKeyStr

jdeGTDelete_AllVendor/jdeGTDelete_AllVendorKeyStr

jdeGTFreeMOData

jdeGTGet_AllMOType/jdeGTGet_AllMOTypeKeyStr

jdeGTGet_GenericText/jdeGTGet_GenericTextKeyStr

jdeGTGet_HTML/jdeGTGet_HTMLKeyStr

jdeGTGet_Image/jdeGTGet_ImageKeyStr

jdeGTGet_OLE/jdeGTGet_OLEKeyStr

jdeGTGet_RTFText/jdeGTGet_RTFTextKeyStr

jdeGTGet_Shortcut/jdeGTGet_ShortcutKeyStr

jdeGTGet_Vendor/jdeGTGet_VendorKeyStr

jdeGTGetCount/jdeGTGetCountKeyStr

Click to jump to top of page Click to jump to parent topic DoSendMessagev3

Last Modified: EnterpriseOne | June 06, 2006

This API sends an email, internal or external, based on the recipient's preference.

Syntax

MSGPRTO_RTN(JDEDB_RESULT) DoSendMessageV3(

HUSER hUser,

Recipient * to,

Recipient * cc,

Recipient * bcc,

const JCHAR * pSubject,

const JCHAR * pText,

int numActiveMsg,

const ACTIVE_MSG_INFO_V3 * pActiveMsgArray,

const MSG_TEMPLATE_INFO * pTemplateSub,

const JCHAR * mediaObjectName,

const JCHAR * mediaObjectKey,

const JCHAR * pMailBox

);

Parameters

HUSER hUser | Input, required. The user handle that defines the context in which to send the message.
Recipient * to | Input, required. The ID of the primary individual, group, mailbox, and so forth to whom the message is to be delivered.
Recipient * cc | Input, required. The ID of the individual, group, mailbox, and so forth to whom a courtesy copy of the message is to be delivered.
Recipient * bcc | Input, required. The ID of the individual, group, mailbox, and so forth to whom a blind courtesy copy of the message is to be delivered.
const JCHAR * pSubject | Input, optional. The text to write to the subject line for the email.
const JCHAR * pText | Input, optional. The text to write to the main body for the email.
int numActiveMsg | Input, required. The number of interconnects to specific forms required.
const ACTIVE_MSG_INFO_V3 * pActiveMsgArray | Input, optional. Array holding the shortcuts. NULL is a value.
const MSG_TEMPLATE_INFO * pTemplateSub | Input, optional. A specific text substitution template.
const JCHAR * mediaObjectName | Input, optional. A specific media object used to send the attachment. NULL and <blank> are values.
const JCHAR * mediaObjectKey | Input, optional. The key of the media object used to send the attachment.
const JCHAR * pMailBox | Input, optional. The internal WorkCenter mailbox to which to deliver the email (used only for PPAT).

Example

JDEBFRTN (ID) JDEBFWINAPI functionCRMTest1 (LPBHVRCOM lpBhvrCom, LPVOID lpVoid, LPDSDCRM1 lpDS)

{

JCHAR buffer[1000] = {0};

JDEDB_RESULT rc = JDEDB_PASSED;

Recipient to = {0};

Recipient cc = {0};

HUSER hUser = NULL;

MSG_TEMPLATE_INFO zTemplateInfo = { 0 };

JDB_InitBhvr(lpBhvrCom, &hUser, (JCHAR *)NULL, JDEDB_COMMIT_AUTO);

jdeUTime_Format(buffer, (LPJDEUTIME)&lpDS->DateEntered, NULL);

/*Create TO smtp recipient*/

to.recipientType = RECIPIENT_TYPE_SMTP;

to.smtp = _J("employee@oracle.com");

/*Create CC contact recipient*/

cc.recipientType = RECIPIENT_TYPE_CONTACT;

LongToMathNumeric(1001, &cc.an8);

LongToMathNumeric(0, &cc.idln);

/*Create a template sub with dditem LM1234*/

zTemplateInfo.ddName = (JCHAR*)jdeAlloc( COMMON_POOL , (sizeof(NID)) * sizeof(JCHAR) ,MEM_ZEROINIT );

jdeNIDcpy( zTemplateInfo.ddName , _J("LM1234") );

zTemplateInfo.nbParam = 6;

zTemplateInfo.valueArray = (RT_VALUE*) jdeAlloc(COMMON_POOL, (sizeof(RT_VALUE) * 6) , MEM_ZEROINIT | MEM_RESIZEABLE);

zTemplateInfo.valueArray[0].evdtType = 2;

zTemplateInfo.valueArray[0].value = jdemalloc(sizeof(JCHAR) * (jdeStrlen(_J("1")) + 1));

jdeStrncpyTerminate(zTemplateInfo.valueArray[0].value , (LPVOID)_J("1") , jdeStrlen(_J("1")) + 1 );

zTemplateInfo.valueArray[1].evdtType = 2;

zTemplateInfo.valueArray[1].value = jdemalloc(sizeof(JCHAR) * (jdeStrlen(_J("2")) + 1));

jdeStrncpyTerminate(zTemplateInfo.valueArray[1].value , (LPVOID)_J("2") , jdeStrlen(_J("2")) + 1 );

zTemplateInfo.valueArray[2].evdtType = 2;

zTemplateInfo.valueArray[2].value = jdemalloc(sizeof(JCHAR) * (jdeStrlen(_J("3")) + 1));

jdeStrncpyTerminate(zTemplateInfo.valueArray[2].value , (LPVOID)_J("3") , jdeStrlen(_J("3")) + 1 );

zTemplateInfo.valueArray[3].evdtType = 2;

zTemplateInfo.valueArray[3].value = jdemalloc(sizeof(JCHAR) * (jdeStrlen(_J("4")) + 1));

jdeStrncpyTerminate(zTemplateInfo.valueArray[3].value , (LPVOID)_J("4") , jdeStrlen(_J("4")) + 1 );

zTemplateInfo.valueArray[4].evdtType = 2;

zTemplateInfo.valueArray[4].value = jdemalloc(sizeof(JCHAR) * (jdeStrlen(_J("5")) + 1));

jdeStrncpyTerminate(zTemplateInfo.valueArray[4].value , (LPVOID)_J("5") , jdeStrlen(_J("5")) + 1 );

zTemplateInfo.valueArray[5].evdtType = 2;

zTemplateInfo.valueArray[5].value = jdemalloc(sizeof(JCHAR) *

(jdeStrlen(_J("6")) + 1));

jdeStrncpyTerminate(zTemplateInfo.valueArray[5].value , (LPVOID)_J("6") , jdeStrlen(_J("6")) + 1 );

rc = DoSendMessageV3(

hUser, /*HUSER*/

&to, /*to*/

&cc, /*cc*/

NULL, /*bcc*/

buffer, /*subject*/

buffer, /*messageText*/

0, /*numActiveMsg number of shortcuts*/

NULL, /*pActiveMsgArray optional, NULL allowed */

&zTemplateInfo,/*pTemplateSub optional, NULL allowed */

NULL, /*mediaObjectName optional, NULL or <blank> allowed */

NULL, /*mediaObjectKey optional, NULL or <blank> allowed */

NULL); /*pMailBox optional, only used for PPAT */

FreeActiveMsgTemplate(&zTemplateInfo);

return (ER_SUCCESS);

}

Click to jump to top of page Click to jump to parent topic Structure Used With SAX Parser Interface Functions

Last Modified: EnterpriseOne | June 06, 2006

This structure is used to pass attribute data to the start-element callback functions.

Syntax

typedef struct tagXRCS_Attr_Info XRCS_ATTR_INFO;

struct tagXRCS_Attr_Info {

const JCHAR *szAttrLocalname;

const JCHAR *szAttrQname;

const JCHAR *szAttrValue;

};

Click to jump to top of page Click to jump to parent topic XRCS_initEngine

Last Modified: EnterpriseOne | June 06, 2006

This function performs a one-time initialization of the XercesWrapper and the Xerces parsing code. It must be the first XercesWrapper function called from the client code.

Syntax

XRCS_Status XRCS_initEngine (void);

Click to jump to top of page Click to jump to parent topic XRCS_getParserByType

Last Modified: EnterpriseOne | June 06, 2006

This function initializes a SAX or DOM parser, and returns a handle to it.

Syntax

XRCS_getParserByType(

XRCS_hParser* phParser,

XRCS_ParserType eParserType

);

Parameters

phParser | A valid pointer to a parser handle (address IN, handle OUT).
eParserType | A type of parser (DOM or SAX), specified by enum value (IN).

Click to jump to top of page Click to jump to parent topic XRCS_getParser (DOM only)

Last Modified: EnterpriseOne | June 06, 2006

This function initializes a DOM parser, and returns a handle to it. Do not use this function for the SAX parser. Instead, use XRCS_getParserByType with the type set to XRCS_SAX_PARSER_TYPE.

Syntax

XRCS_Status XRCS_getParser(XRCS_hParser* phParser);

Parameters

phParser

A valid pointer to a parser handle (address IN, handle OUT).

Click to jump to top of page Click to jump to parent topic XRCS_setCallback

Last Modified: EnterpriseOne | June 06, 2006

This function sets up the given callback function for the given SAX parsing event. The function prototype of the callback function must correspond to the type of callback. The callback function must be cast to (void *). The context pointer must be cast to (void *). The context pointer typically points to a user-defined data structure, where the callback functions can maintain the state of the parsing. The context pointer may be set to NULL if it is not needed.

You can set up multiple callback functions for the same parsing event type. However, the order in which they are called cannot be specified.

Syntax

XRCS_Status XRCS_setCallback( const XRCS_hParser hParser
, XRCS_CallbackType eCallbackType
, void *pCallbackFunction
, void *pContext
);

Parameters

hParser | Input. A valid parser handle.
eCallbackType | Input. A type of callback, specified by enum value.
pCallbackFunction | Input. A pointer to callback function.
pContext | A pointer to be passed to the callback function.

Click to jump to top of page Click to jump to parent topic XRCS_setCallbackWithOption

Last Modified: EnterpriseOne | June 06, 2006

This function is the same as XRCS_setCallback, with the ability to specify an option. The type of option that may be specified is based upon the type of parsing event. Some types of options require a value, in which case the value should always be cast to (void *). If no value is required, a NULL can be used. The system currently supports two types of options.

For the start-of-element and end-of-element event types, an optional, specified local name may be passed in. This option type is identified by the enum value, XRCS_CBOPT_ELEM_LOCAL_NAME. The option value would be a null-terminated string (JCHAR *) for the element name. The callback function will be triggered only when the local name for the element matches the passed-in name.

For the characters event type, you have the option to retrieve the text following the end of an element. The option type is identified by the enum value, XRCS_CBOPT_CHARS_AFTER_ELEM. The option value is ignored, so you should set it to NULL. For typical XML data, the characters after the end of an element are just white space and carriage returns and so do not provide any useful information. On the other hand, XML display documents could have useful display information after the end of an element. The default is to ignore any text following the end of an element.

Syntax

XRCS_Status XRCS_setCallbackWithOption(

const XRCS_hParser hParser,

XRCS_CallbackType eCallbackType,

void * pCallbackFunction,

void * pContext,

XRCS_CallbackOptionType eOptionType,

void * OptionValue

);

Parameters

hParser | Input. A valid parser handle.
eCallbackType | Input. A type of callback, specified by enum value.
pCallbackFunction | Input. A pointer to callback function.
pContext | Input. A pointer to be passed to the callback function.
eOptionType | Input. A type of option, specified by enum value.
pOptionValue | Input. A value for the option. Not all options require a value.

Click to jump to top of page Click to jump to parent topic XRCS_parseXMLFile

Last Modified: EnterpriseOne | June 06, 2006

This function parses the given XML file. It is used for both SAX and DOM parsers. For the SAX parser, the document handle pointer is not used, so it must be passed in as NULL. Certain error conditions could cause a process crash if the document handle pointer is not set to NULL for the SAX parser.

The SAX parser will stop parsing the XML text whenever:

· The end of the XML text has been reached.

· A callback has requested to terminate parsing (using its return code).

· The SAX parser encounters a fatal error.

In the first case, the parse function returns XRCS_SUCCESS. In the last two, the parse function returns XRCS_ERROR.

After the callback functions have been set up, the XML parse functions may be called multiple times. Multiple calls might be useful for parsing multiple XML files while using the same group of callback functions.

Syntax

XRCS_Status JDEWINAPI XRCS_parseXMLFile(

const XRCS_hParser hParser,

const JCHAR* szFileName,

XRCS_hDocument* phDoc

);

Parameters

hParser | Input. A valid parser handle.
szFileName | Input. The XML data file to be parsed.
phDoc | Input. A pointer to a DOM document handle. For SAX, pass in NULL.

Click to jump to top of page Click to jump to parent topic XRCS_parseXMLString

Last Modified: EnterpriseOne | June 06, 2006

This function is the same as XRCS_parseXMLFile, with the only difference being the source of the XML text.

Syntax

XRCS_Status JDEWINAPI XRCS_parseXMLString(

XRCS_hParser hParser,

const JCHAR* szXMLString,

XRCS_hDocument* phDoc

);

Parameters

hParser | Input. A valid parser handle.
szXMLString | Input. An XML text string to be parsed.
phDoc | Input. A pointer to a DOM document handle. For SAX, pass in NULL

Click to jump to top of page Click to jump to parent topic XRCS_freeParser

Last Modified: EnterpriseOne | June 06, 2006

This function frees the resources that are used by the parser.

Syntax

XRCS_Status XRCS_freeParser(XRCS_hParser hParser);

Parameters

hParser

Input. A valid parser handle.

Click to jump to top of page Click to jump to parent topic XRCS_terminateEngine

Last Modified: EnterpriseOne | June 06, 2006

This function performs a one-time cleanup of resources used by XercesWrapper and Xerces parsers. It must be the last function called from the client code.

Syntax

XRCS_Status XRCS_terminateEngine(void);

Click to jump to parent topic Callback Functions

Last Modified: EnterpriseOne | June 06, 2006

Because the available data is different for each event type, the callback functions have specified parameter lists (function prototypes), based upon the associated type of SAX parsing event. All callback functions receive the context pointer, which was set up before parsing begins. Additional parameters correspond to the type of event.

All values passed into the callback functions must be considered temporary. If the data needs to be kept, it should be copied elsewhere. Data should never be saved using a reference pointer to the passed-in data. Also, the passed-in data must never be modified. That memory, used to pass data into the callback functions, will either be freed or reused upon return from the callback function.

All callback functions return an enum value, which indicates whether the parsing should continue or terminate. Whenever a callback function requests a termination, the XML parsing will stop, and the parse function itself will return an error code.

The context pointer must always be cast to (void *). The callback function must always be cast to (void *). Without the (void *) casts, the code will work on most systems. However, it will not build on Linux systems without the explicit casts.

Click to jump to top of page Click to jump to parent topic Errors and Warnings

Last Modified: EnterpriseOne | June 06, 2006

After a parser fatal error, the parse function returns an error status, regardless of whether the callback functions return "continue" or "terminate." When the SAX parser encounters a fatal error, it first calls the fatal error callbacks, and then stops parsing.

If multiple fatal-error callbacks are set up, returning the "terminate" return code will skip the remaining callbacks and stop parsing immediately. If multiple fatal-error callbacks are set up, returning the "continue" return code will enable the remaining callbacks to run, and then stop parsing. If only one fatal-error callback is set up, then the return code does not matter because parsing will always stop after that callback finishes.

The SAX parser interface project did not change the threading capabilities of the XercesWrapper code. It uses the same initialization code as the DOM parser. Both parsers are not completely threadsafe, particularly for initialization and termination. The calling functions are responsible for all thread control.

If the MS Windows VC++ build uses the /W4 switch (warning level 4), the system will issue compiler warnings for the callback function casting, in the calls to XRCS_setCallback and XRCS_setCallbackWithOption. The /W4 switch appears to be the default for business function builds. To eliminate the warnings, add this block of code before the first call to XRCS_setCallback or XRCS_setCallbackWithOption. The block of code can be placed in a header file, if multiple files setting up callbacks exist:

#ifdef JDENV_PC

/* Do not display warning for callback functions -- ignore warning

* for conversion of function pointer to data pointer (void *).

* Compiler normally displays this warning when using /W4 warnings level.

*/

#pragma warning (disable:4054)

#endif

Click to jump to top of page Click to jump to parent topic Callback Function Format 1

Last Modified: EnterpriseOne | June 06, 2006

This is the function prototype of callback functions, which is used by event types for start and end of documents.

Syntax

XRCS_CallbackStatus ( * PCALLBACK_FORMAT1) ( void *pContext);

Parameters

pContext

Input. A pointer to the context, which was specified during setup.

Click to jump to top of page Click to jump to parent topic Callback Function Format 2

Last Modified: EnterpriseOne | June 06, 2006

This is the function prototype of callback functions, which is used by the event type for start of an element. The attribute information is returned in an array. If no attribute information exists, the number of elements is set to zero, and the array pointer is set to NULL.

Each element of the attribute array consists of the data structure XRCS_ATTR_INFO. That structure contains three null-terminated strings: one for the local name of the attribute, one for the qualified name of the attribute, and one for the value of the attribute.

Syntax

XRCS_CallbackStatus ( * PCALLBACK_FORMAT2) (

void * pContext,

const JCHAR * szUri,

const JCHAR * szLocalname,

const JCHAR * szQname,

unsigned int nNumAttrs,

const XRCS_ATTR_INFO * pAttributes

);

Parameters

pContext | Input. A pointer to the context, which was specified during setup.
szUri | Input. A null-terminated string for URI (namespace).
szLocalname | Input. A null-terminated string for local name.
szQname | Input. A null-terminated string for qualified name.
nNumAttrs | Input. The number of elements in the array of attribute information.
pAttributes | Input. An array of attribute information.

Click to jump to top of page Click to jump to parent topic Callback Function Format 3

Last Modified: EnterpriseOne | June 06, 2006

This is the function prototype of callback functions, which is used by the event type for end of element.

Syntax

XRCS_CallbackStatus ( * PCALLBACK_FORMAT3) (

void * pContext,

const JCHAR * szUri,

const JCHAR * szLocalname,

const JCHAR * szQname

);

Parameters

pContext | Input. A pointer to the context, which was specified during setup.
szUri | Input. A null-terminated string for URI (namespace).
szLocalname | Input. A null-terminated string for local name.
szQname | Input. A null-terminated string for qualified name.

Click to jump to top of page Click to jump to parent topic Callback Function Format 4

Last Modified: EnterpriseOne | June 06, 2006

This is the function prototype of callback functions, which is used by event types for characters and ignorable white space. For the event type of the characters, the complete character string is returned, even if the SAX parser returns it to the XercesWrapper code as a series of partial strings.

The event for ignorable white space occurs only when using schemas and other special features. This version of the SAX parser interface does not include a method to set up schemas. Therefore, any callback functions which are set up for ignorable white space will never be called. After schema-setup is added in a later version, the ignorable white space callbacks will be called. Without schemas, all text is returned using the event type for the characters.

Syntax

XRCS_CallbackStatus ( * PCALLBACK_FORMAT4) (

void * pContext,

const JCHAR * szText

);

Parameters

pContext | Input. A pointer to the context, which was specified during setup.
szText | Input. A null-terminated character string.

Click to jump to top of page Click to jump to parent topic Callback Function Format 5

Last Modified: EnterpriseOne | June 06, 2006

This is the function prototype of callback functions, which is used by event types for warnings, errors, and fatal errors. The enum for callback type makes it possible for one callback function to handle all three error types. The line and column numbers are approximate, and may point to the position following the actual error. That is because the SAX parser may have already moved its pointers to the next element, before an error is encountered with the current element.

The XML file name is usually found in either szPublicId or szSystemId. The other one is usually an empty (zero-length) string. The error message text (szMessage) is sometimes an empty (zero-length) string.

Syntax

XRCS_CallbackStatus ( * PCALLBACK_FORMAT5) (

void * pContext,

XRCS_CallbackType eCallbackType,

int nLineNum,

int nColNum,

const JCHAR * szPublicId,

const JCHAR * szSystemId,

const JCHAR * szMessage

);

Parameters

pContext | Input. A pointer to the context, which was specified during setup.
eCallbackType | Input. An enum indicating type of error event.
nLineNum | Input. A line number where error occurred.
nColNum | Input. The column number where error occurred.
szPublicId | Input. The null-terminated name of XML file.
szSystemId | Input. The null-terminated name of XML file.
szMessage | Input. The null-terminated text of error message.


Structure Used With SAX Parser Interface Functions.htm

Structure Used With SAX Parser Interface Functions

Last Modified: EnterpriseOne | June 06, 2006

This structure is used to pass attribute data to the start-element callback functions.

Syntax

typedef struct tagXRCS_Attr_Info XRCS_ATTR_INFO;

struct tagXRCS_Attr_Info {

const JCHAR *szAttrLocalname;

const JCHAR *szAttrQname;

const JCHAR *szAttrValue;

};


Super Backflush

Table: F3112Z1

Date: December 08, 1998

General Information

Purpose of Transaction

Super Backflush transactions are used to create backflush transactions against a work order at pay points defined in the routing. On the inbound side, this transaction is used to update OneWorld tables with super backlash information.

Outbound Super Backlash transactions do not use this interface table. To perform outbound Super Backlash, the interoperability processing options for Work Order Completions, Work Order Employee Time Entry, and Work Order Inventory Issues must be turned on. The Super Backlash transaction calls the Master Business Functions for each of these transactions, and the outbound interoperability is performed though them. See the Interface Table User Guides for each of these transactions for more information.

The permanent OneWorld tables primarily affected by this transaction are the Work Order Routing table (F3112), the Work Order Parts List table (F3111), and the Work Order Time Transactions table (F31122).

Relationships to Other Transactions

The F3112Z1 transaction file is also used by Work Order Routing. Super Backlash transactions will have a Transaction Type (TYTN) equal to "JDESBF". Work Order Routing transactions will have a Transaction Type (TYTN) equal to "JDEROU".

Transaction-Specific Instructions

The inbound transaction supports additions only.

This transaction must have corresponding records in Work Order Master File (F4801), Item Master (F4101), Item Branch File (F4102), Item Location (F41021), Work Order Parts List (F3111), Work Order Routing (F3112), and Work Order Time Transactions (F31122).

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F3112Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDESBF"
TNAC | Action Code | "A" = add
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Only records having a pay point B, L, or M are required, The non pay point records are fetched from the F3112 table.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
DOCO | Order Number | Validated against the F4801 table
LINE | Line / Cell | Required in a repetitive environment
OPSQ | Sequence number operation | Validated against F3112 table
AN8 | Address number | This is the address number for the employee for time entry. If this is blank time entry records will not be created in F31122. Validated against the address book table (F0101).
TRDJ | Transaction date |
SOCN | Transaction Quantity Cancelled / Scrapped | Input this quantity for pay points only.
SOQS | Transaction quantity completed | Input this quantity for pay points only.
BFPF | Pay Point Code | Required if the operation is a pay point This is validated against a UDC 30/BF.
UOM | Unit of Measure as input | If left blank UOM from F3112 is used

Additional Comments

One of the columns, SOCN or SOQS, must to be populated for this transaction.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and Default logic
PPRF | Pay point status | This is validated against UDC 31/PP.
OPST | Operation Status Code | This is validated against UDC 31/OS.


Supplier Master

Table: F0401Z1

Date: November 2, 1998

General Information

Purpose of Transaction

Supplier Master transactions are used to maintain information about suppliers and processing instructions that OneWorld uses to process vouchers and payments. On the inbound side, this transaction is used to update OneWorld tables with Supplier information. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the Supplier information.

The permanent OneWorld table primarily affected by this transaction is the F0401.

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions, changes, and deletions.

The outbound transaction supports additions, changes, and deletions. For changes, both the before and after images can be written.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F0401Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction (for example, JDESM)
TNAC | Action Code | "A" = add, "C" = change, "D" = delete (left justified)
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".

Additional Comments

The following columns EDUS, EDBT, and EDTN must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
AN8 | Customer Number | A number that identifies a Customer in the Address Book system. See Note 1.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
TRAP | Payment Terms | A code that indicates the default payment terms for a supplier. Validated against table F0014.
HDPY | Hold Payment | A user defined code (H01/HD) that controls whether you can enter accounts payable vouchers and make payments to this supplier.
RYIN | Payment Instrument | A user defined code (00/PY) that specifies how payments are made by the customer.
CRCP | Currency Code | The currency in which a supplier’s amounts are stored. For example, the Prior Year Vouchered, Year to Date Vouchered, and so forth. Validated against table F0013.

Column-Specific Instructions -From OneWorld - Table F0401Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction (for example, JDESM)
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Data Columns

Data columns in the interface from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld" section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.


SuspendSection

Last Modified: B733.2 | May 07, 1999

SuspendSection processes when an overflow page break occurs. For example, if the information printed does not fit in the space available on a page. This temporarily stops the section processing. Use this to do processing when a page break occurs

Available On

  • Section Level event rules.

Available Objects

  • All Section Objects and Global Variables.

Typical Usage

To do processing when a Page Break occurs due to various reasons.


SuspendVariable

Last Modified: B733

If an object requires multiple lines to print, such as a long text string or column heading, and if only part of the object fits onto a page, then the UBE will issue a SuspendVariable, which causes processing of the object to be halted until the next page has been started. The value of the object has already been partially processed when this event happens, so this would be a risky time for Event Rules to manipulate that value.

Available On

This event is only available at the object level.

Available Objects

List field types (RV, VA, and so forth)

Typical Usage

Typically, this event can be used to modify the value at the page break. Most event rule processing is done before an object is suspended; therefore, use caution when running this event.

Processing Sequence

  1. Suspend Object

  2. Next Object (Init-Do-End Object)

  3. Adv Section


TextSearchFullIndexing.htm

Click to jump to top of page Click to jump to parent topic TextSearchFullIndexing

Last Modified: EnterpriseOne | June 06, 2006

This API builds a text search index which is an indexed copy of JD Edwards EnterpriseOne data and media objects that is optimized for text searches.

Syntax

JDERTN (TEXTSEARCH_INDEXING_RESULT) JDEWINAPI TextSearchFullIndexing(

HUSER lpUser,

JCHAR* lpszDataSource,

JCHAR* lpszBusinessView

);

Parameters

Parameter | Notes | Usage
lpUser | Input, required. The user handle that defines the context in which to build the text search index. |
lpszDataSource | Input, required. The data source that defines the location of the data to include in the text search index. |
lpszBusinessView | Input, required. The business view that defines the data and media objects to include in the text search index. |

Additional Notes

The full text search index build leaves the existing index intact (if one exists) for the duration of the build process. Doing so ensures that searches remain functional throughout the course of the build. When the text search index build is complete, this API clears the previous text search index build instance.

Return Value

This API can return these values:

Value | Description
TEXTSEARCH_INDEXING_SUCCESS | The full text search index build completed successfully.
TEXTSEARCH_INDEXING_FAIL | The full text search index build failed.

Example

TEXTSEARCH_INDEXING_RESULT nResult;

nResult = TextSearchFullIndexing(lpUser, _J("My Business Data Source"), _J("V0101C"));


TextSearchIncrementIndexing.htm

Click to jump to top of page Click to jump to parent topic TextSearchIncrementIndexing

Last Modified: EnterpriseOne | June 06, 2006

This API performs an incremental text search index build which modifies an existing text search index to reflect a change to a single row of JD Edwards EnterpriseOne data or attached media objects.

Syntax

JDERTN (TEXTSEARCH_INDEXING_RESULT) JDEWINAPI TextSearchIncrementIndexing (

HUSER lpUser,

JCHAR* lpszBusinessView,

JCHAR* lpszDataSourceOverride,

TEXTSEARCH_INDEX_MODE mode,

LPKEYINFO lpKeyInfo,

short nKeys

);

Parameters

Parameter | Notes | Usage
lpUser | Input, required. The user handle that defines the context in which to modify the text search index. |
lpszBusinessView | Input, required. The business view that defines the data and media objects to include in the text search index. |
lpszDataSourceOverride | Input, optional. The data source that defines the location of the data to include in the text search index. If this is not provided, the API uses the OCM to determine the data source. |
mode | Input, required. The operation to perform: TEXTSEARCH_INDEX_INSERT, TEXTSEARCH_INDEX_UPDATE, or TEXTSEARCH_INDEX_DELETE. |

Additional Notes

This API provides a mechanism to keep text search indexes synchronized with changes to the corresponding JD Edwards EnterpriseOne data and media objects. However, incremental builds reduce the efficiency of text searches. It is recommended that administrators schedule regular full text search index builds or optimizations in conjunction with applications that call this API.

Return Value

This API can return these values:

Value | Description
TEXTSEARCH_INDEXING_SUCCESS | The full text search index build completed successfully.
TEXTSEARCH_INDEXING_FAIL | The full text search index build failed.

Example

LPKEYINFO lpKeyInfo;

JCHAR szTemp[10];

MATH_NUMERIC mnTemp;

TEXTSEARCH_INDEXING_RESULT nResult;

/* Populate the key information. */

jdeSprintf(szTemp, _J("%d"), 4100);

ParseNumericString(&mnTemp, szTemp);

lpKeyInfo = (LPKEYINFO)jdeAlloc(COMM_POOL, sizeof(KEYINFO), MEM_ZEROINIT);

jdeNIDcpy(lpKeyInfo[0].szDict, NID_AN8);

jdeNIDcpy(lpKeyInfo[0].szTable, NID_F0101);

lpKeyInfo[0].idInstance = 0;

lpKeyInfo[0].lpJDEValue = &mnTemp;

nResult = TextSearchIncrementIndexing(lpUser, _J("V0101C"), NULL, TEXTSEARCH_INDEX_

INSERT, lpKeyInfo, (short)1);


Time Entry

Table: F06116Z1

Date: February 25, 1999

General Information

Purpose of Transaction

Time Entry transactions create time cards into the OneWorld Payroll system. On the inbound side, this transaction allows any third party or custom time collection system to send time card records into the OneWorld table. Outbound transactions are not supported.

The permanent OneWorld table primarily affected by this transaction is the Payroll table (F06116).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions and deletions.

Employee records in error will prevent any records for that employee to be written to the current time card file. All error messages are sent to the user’s workbench with standard level messaging.

All optional fields will default from the Time Entry master business function.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F06116Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
EDTC | Action Code | "A" = add, "D" = delete (left justified)
EDER | Send/Receive Indicator | "R" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of receiving the transaction into OneWorld.
EDSP | Processed flag (0/1) | Enter a "0" for inbound transactions. When processing for this transaction is complete, OneWorld updates this to a "1".
EDTY | EDI Record Type | Not used.
EDSQ | EDI Record Sequence | Not used.
EDCT | EDI Document Type | Not used.
EDTS | EDI Transaction Set | Not used.
EDFT | Translation Format | Not used.
EDDT | EDI Transmission Date | Enter the Julian date of the transmission.
EDDL | Number of Detail Lines | Not used.
EDTR | Transaction Type | "1"
EDGL | Create G/L Record | Not used.

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
AN8 | Address Number | Employee’s address book number
PRTR | Transaction Number | Unique number assigned within the batch
PHRW | Hours Worked | Numeric with implied decimals
DWK | Date Worked | The date used as the actual work date or pay period ending date in Julian format
PDBA | Pay Type Code | Pay types controlled by table F069116
ICU | Batch Number | Unique number assigned to a batch of time card records. May be the same as EDBT.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
ANI | Account Number | A field that identifies an account in the general ledger. You can use one of the following formats for account numbers: o Structured account (business unit.object.subsidiary) o 25-digit unstructured number o 8-digit short account ID number o Speed code The first character of the account indicates the format of the account number. You define the account format in the General Accounting Constants program (P000909). This field will default from the master business function based on labor distribution rules. See Note 1.
MCU | Business Unit | Identifies a separate entity within a business for which you want to track costs. For example, a business unit might be a warehouse location, job, project, work center, or branch/plant. The Business Unit field is alphanumeric. See Note 1.
OBJ | Object Account | The object account portion of a general ledger account. The term "object account" refers to the breakdown of the Cost Code (for example, labor, materials, and equipment) into subcategories (for example, dividing labor into regular time, premium time, and burden). When you are using a flexible chart of accounts, if the object is set to 6 digits, J.D. Edwards recommends that you use all 6 digits. Here, entering 000456 is not the same as entering 456, because the system adds three blank spaces to fill a 6-digit object. See Note 1.
SUB | Subsidiary | A subdivision of an object account. Subsidiary accounts include more detailed records of the accounting activity for an object account.
GMCU | Recharge Business Unit | For Payroll purposes, this Business Unit represents the distribution account where the recharge (billing) amounts are to be posted. The only time that this field will be generated is when you are keying in an employee as a Record Type (RCCD) 2 or 3. In this case the derived distribution account, or entered account, equals this Business Unit.
GOBJ | Recharge Object Account | For Payroll purposes, this represents the account number to which the recharge (billing) amounts are to be posted.
GSUB | Recharge Subsidiary | For Payroll purposes, this is account number where the recharge (billing) amounts are to be posted.
SBL | Subledger | A code that identifies a detailed auxiliary account within a general ledger account. A subledger can be an equipment item number, an address book number, and so forth. If you enter a subledger, you must also specify the subledger type. See Note 2.
SBLT | Subledger Type | A user defined code (00/ST) that is used with the Subledger field to identify the subledger type and subledger editing. On the User Defined Codes form, the second line of the description controls how the system performs editing. This is either hard-coded (as shown in the second line of description) or can be user defined. For example: A Alphanumeric field, do not edit N Numeric field, right justify and zero fill C Alphanumeric field, right justify and blank fill See Note 2.
WR01 | Phase | A user defined code (00/W1) that indicates the current stage or phase of development for a work order. You can assign a work order to only one phase code at a time. This field will be automatically populated from the work order header if the speed coding work order entry is used. See the master business function documentation for more information.
MCUO | Chargeout Business Unit | This business unit represents the location in which the employee worked. It can be used to identify that an employee worked at this location, but charged the time to another business unit. This field is used for deriving rates from the Union Pay Rate table and is used exclusively by the Certified Payroll Register. A value in this field overrides the rates set up in the Union Rates table if the table is set up by job or business unit.
MAIL | Check Route Code | A user defined code (06/CR) that specifies the check routing or mail stop code. This code can be used to sequence the printing of payroll checks to facilitate their handling and delivery.
UN | Union Code | A user defined code (06/UN) that represents the union or plan in which the employee or group of employees work or participate.
JBCD | Job Type | A user defined code (07/G) that defines the jobs within your organization. You can associate pay and benefit information with a job type and apply that information to the employees who are linked to that job type.
JBST | Job Step | A user defined code (06/GS) that designates a specific step, grade, or salary level within a particular job type. The system uses this field in conjunction with job type to determine pay rates by job.
SHFT | Shift Code | A user defined code (06/SH) that identifies daily work shifts. In payroll systems, you can use a shift code to add a percent or amount to the hourly rate on a timecard.
SHD | Shift Differential | An additional rate, expressed in dollars or percent, added to an employee’s hourly rate, depending on the shift worked. This rate can be applied in one of two ways as defined by the Shift Differential Calculation Sequence (data item CMTH).
DTBT | Date Time Clock Start | The date and time which the timecard transaction was created
TCDE | Date Time Clock End | The date and time which the timecard transaction was ended
EQWO | Equipment Worked On | The ID number for the equipment that an employee maintained or repaired, but did not use. For example, an employee might change the oil in the company dump truck. Use this field to direct labor expenses to this piece of equipment.
EQCG | Equipment Worked | The ID number of the equipment an employee used to perform a job. For example, an employee might drive a company dump truck or operate a printing press. Use this field to distribute the cost of using the equipment to the proper account in the general ledger.
QOBJ | Equipment Object Account | Use this field to indicate the object account to which you want the system to distribute equipment utilization charges. If you leave this field blank, the system uses a default value from the Payroll Accounting tables. You can override this value on individual timecards.
ERC | Equipment Rate Code | This user defined code (00/RC) indicates a billing rate, such as DY for daily, MO for monthly, and WK for weekly. You can set up multiple billing rates for a piece of equipment.
EQRT | Billing Rate | The dollar amount for the equipment billing rate. Each equipment item can have numerous billing rates based on the rate code (see Equipment Billing Rate - ERC). The equipment billing rate can consist of up to ten different rates. For example: Billing Rate = $100 $20 = Rate 1 (Ownership Component) $50 = Rate 2 (Operating Component) $25 = Rate 3 (Maintenance Component) $5 = Rate 4 (Other Costs Component)
EQHR | Equipment Hours | The number of hours the equipment was operated. If you leave this field blank, the system uses the hours from employee time entry when you enter an equipment number. If you do not enter employee hours, you must complete this field.
EXR | Explanation - Remark | A name or remark that describes a time card record.
P001 | Cat 001 | This is a Payroll system category code. You can define the use and description of this code to fit the needs of your organization.
P002 | Cat 002 | This is a Payroll system category code. You can define the use and description of this code to fit the needs of your organization.
P003 | Cat 003 | This is a Payroll system category code. You can define the use and description of this code to fit the needs of your organization.
P004 | Cat 004 | This is a Payroll system category code. You can define the use and description of this code to fit the needs of your organization.
EPA | Entered Gross Pay | A lump sum amount, an adjustment amount, or an amount that represents an employee’s gross pay. This amount temporarily overrides any pay calculation that the system normally performs.

Additional Comments

Note 1 - Use either ANI or the MCU, OBJ, and SUB fields. The master business function will use either to create the other(s).

Note 2 - Subledger and Subledger Type must be used together to create a valid combination. For Example a Type W would represent a work order number in the subledger field.


Tree-BeginDragOperation

Last Modified: B733

Tree-BeginDragOperation executes when the user starts dragging a node in the tree. This event is only executed if the application developer has the drag and drop feature enabled.

Available On

§ Parent Child Forms.

Available Objects

§ All objects are available.

§ Grid Columns contain the data of the row that shows the detail of the node that is being dragged.

Typical Usage

Use this event to save the grid column values of the node (and row) that is being dragged into either grid buffers or variables so that they can be used when the user has finished the drag and drop operation. The reason for saving off the grid column values is that when the user has dropped the node, the grid column values change to that of the node on which the dragged node has been dropped. The grid column values of the node that was dragged are replaced.

Additional Notes

The grid columns are also updated during the dragging process, when the user passes over a node in the tree. The node over which the user is moving gets highlighted and the grid columns now contain data for this node.


Tree-CancelDragDrop

Last Modified: B733

Tree-CancelDragDrop executes if the user drops (or releases) the dragged node when it is not on a valid node or outside the tree. This event is also executed if the user chooses the Cancel button from the popup menu that appears when the user uses the right mouse button during a mouse drag and drop operation.

Available On

§ Parent Child Forms.

Available Objects

§ All objects are available.

§ Grid Columns contain the data of the row that shows the detail of the node that was initially dragged.

Typical Usage

The developer can use this event to undo steps they may have taken during the “Tree-BeginDragOperation”.


Tree-DragOverNode

Last Modified: B733

Tree-DragOverNode executes when the user is in the process of dragging a node and is right above a node in the tree control. This node gets highlighted and the grid columns are updated with the values corresponding to this node. This even is only executed if the application developer has the drag and drop feature enabled.

Available On

§ Parent Child Forms.

Available Objects

§ All objects are available.

§ Grid Columns contain the data of the row that contains the detail of the node over which the dragged node is passing.

Typical Usage

During this event, the application developer can inspect the grid column values and update the cursor to indicate if the user can or cannot drop the dragged node under the current node. Refer to the system function Set Drag Cursor for details on how to change the cursor.


Tree-EndDragDropOperation

Last Modified: B733

Tree-EndDragDropOperation executes when the user has dropped the node that was being dragged. This event is only executed if the application developer has the drag and drop feature enabled.

Available On

§ Parent Child Forms.

Available Objects

§ All objects are available.

§ Grid Columns contain the data of the row that shows the detail of the node on which the dragged node has been dropped.

Additional Notes

This event is not executed if the cursor has been set to NO DROP during the drag over event. Instead, a Cancel Drag Drop event is executed.

Processing Sequence

§ If users make use of the left mouse button for the drag and drop operation, then this event is executed immediately after they release the left mouse button.

§ If users make use of the right mouse button for the drag and drop operation, then a pop up menu comes up when they release the right mouse button. This popup menu has the following options:

Move Here: This specifies that the user wants to move the dragged node. If the user selects this option then the Tree-EndDragDropOperation event will be executed.

Copy Here: This sepecifies that the user wants to copy the dragged node. If the user selects this option then the Tree-EndDragDropOperation event will be executed.

Within this event, the application developer can check the system variable SV Drag_Mode to check if the operation was a COPY or a MOVE.


Warehouse Confirmations

Table: F4611Z1

October 21, 1998

General Information

Purpose of Transaction

Warehouse confirmation transactions are used to change certain information on an existing suggestion and then over pick, confirm with variance, straight confirm or cancel the suggestion. On the inbound side, this transaction is used to update OneWorld tables with warehouse confirmation information. Outbound transactions are not supported.

The permanent OneWorld tables primarily affected by this transaction are the Warehouse Suggestions table (F4611), Warehouse Requests table (F4600), Item Location table (F41021), Location Detail Information table (F4602), and the Item Ledger table (F4111).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports changes only, either confirming or canceling the suggestion.

It is assumed that the Warehouse Management System created the Request (F4600) and Suggestions (F4611) prior to the inbound suggestion being changed.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F4611Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDESUGST"
TNAC | Action Code | "A" = confirm, "D" = cancel
DRIN | Direction Indicator | 1= into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item

Description

Notes

TYFL

Warehouse Code

Cannot be changed from original suggestion.

OCDE

Origin Code

Cannot be changed from original suggestion.

RQBT

Request Batch Number

Cannot be changed from original suggestion.

RQSQ

Request Sequence Number

Cannot be changed from original suggestion.

SGBT

Suggestion Batch Number

Cannot be changed from original suggestion.

SGSQ

Suggestion Sequence Number

Cannot be changed from original suggestion.

PWAV

Wave Number

Cannot be changed from original suggestion.

PTSK

Task Number

Cannot be changed from original suggestion.

TRIP

Trip Number

Cannot be changed from original suggestion.

MCU

Business Unit

Cannot be changed from original suggestion.

KCOO

Order Company

Cannot be changed from original suggestion.

DOCO

Order Company

Cannot be changed from original suggestion.

DCTO

Order Type

Cannot be changed from original suggestion.

LNID

Line Number

Cannot be changed from original suggestion.

NLIN

Number of Lines

Cannot be changed from original suggestion.

SFXO

Order Suffix

Cannot be changed from original suggestion.

CLID

Confirm Line Number

Cannot be changed from original suggestion.

ITM

Item Number (Short)

Cannot be changed from original suggestion.

LITM

2nd Item Number

Cannot be changed from original suggestion.

AITM

3rd Item Number

Cannot be changed from original suggestion.

UML1

Level 1 Unit of Measure

Can be changed from original suggestion. Verified against the F41002.

UML2

Level 2 Unit of Measure

Can be changed from original suggestion. Verified against the F41002.

UML3

Level 3 Unit of Measure

Can be changed from original suggestion. Verified against the F41002.

UML4

Level 4 Unit of Measure

Can be changed from original suggestion. Verified against the F41002.

UML5

Level 5 Unit of Measure

Can be changed from original suggestion. Verified against the F41002.

TQL1

Level 1 Total Quantity

Can be changed from original suggestion.

TQL2

Level 2 Total Quantity

Can be changed from original suggestion.

TQL3

Level 3 Total Quantity

Can be changed from original suggestion.

TQL4

Level 4 Total Quantity

Can be changed from original suggestion.

TQL5

Level 5 Total Quantity

Can be changed from original suggestion.

EQL1

Level 1 Container Code

Can be changed from original suggestion. Verify against UDC 46/EQ

EQL2

Level 2 Container Code

Can be changed from original suggestion. Verify against UDC 46/EQ

EQL3

Level 3 Container Code

Can be changed from original suggestion. Verify against UDC 46/EQ

EQL4

Level 4 Container Code

Can be changed from original suggestion. Verify against UDC 46/EQ

EQL5

Level 5 Container Code

Can be changed from original suggestion. Verify against UDC 46/EQ

QPL2

Level 2 Quantity Per

Can be changed from original suggestion.

QPL3

Level 3 Quantity Per

Can be changed from original suggestion.

QPL4

Level 4 Quantity Per

Can be changed from original suggestion.

QPL5

Level 5 Quantity Per

Can be changed from original suggestion.

UOM1

Unit of Measure

Can be changed from original suggestion .Verified against the F41002

TQTY

Total Quantity

Can be changed from original suggestion.

CUBE

Used Cubic Dimension

Cannot be changed from original suggestion.

VUMD

Volume Display Unit of Measure

Cannot be changed from original suggestion.

WEIT

Used Weight

Cannot be changed from original suggestion.

UWUM

Unit of Measure Weight

Cannot be changed from original suggestion.

LDFS

From Location Detail Sequence

Can be changed from original suggestion. Verify against the F4602.

FLOC

From Location

Can be changed from original suggestion. Verify against the F4602.

FLOT

From Lot

Can be changed from original suggestion. Verify against the F4602.

STNF

From Storage Unit Number

Can be changed from original suggestion. Verify against the F4602.

LDTS

To Locate Detail Sequence

Can be changed from original suggestion. Verify against the F4602.

TLOC

To Location

Can be changed from original suggestion. Verify against the F4602.

TLOT

To Lot

Can be changed from original suggestion. Verify against the F4602.

STNT

To Storage Unit Number

Cannot be changed from original suggestion.

VSUG

Variance Suggestion

Can be changed from original suggestion.

PHAS

Phase

Cannot be changed from original suggestion.

RSBT

Related Suggestion batch Number

Cannot be changed from original suggestion.

RSSQ

Related Suggestion Sequence Number

Cannot be changed from original suggestion.


Work Center Master

Table: F30006Z1

Date: November 02, 1998

General Information

Purpose of Transaction

Work Center Master transactions are used to record information about all defined work centers. On the inbound side, this transaction is used to update OneWorld tables with work center information. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the work center information.

The permanent OneWorld table primarily affected by this transaction is the Work Center Master File (F30006).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions, changes, and deletions.

The inbound transaction supports additions, changes, and deletions. For changes, both the before and after images can be written.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F30006Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDEWC"
TNAC | Action Code | "A" = add, "C" = change, "D" = delete (left justified)
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
MCU | Business Unit | Value must exist in Business Unit Table (F0006)
Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and Default Logic
CRTW | Critical Work Center | Value must exist in UDC 30/CR
PILC | Prime Load Code | Value must exist in UDC 30/PI
BFPF | Pay Point Code | Value must exist in UDC 30/BF
AVRT | Replenishment Hours | Value must be MATH NUMERIC
WORE | Efficiency | Value must be MATH NUMERIC
WORU | Utilization | Value must be MATH NUMERIC
QMAD | Number of Employees | Value must be MATH NUMERIC
NOMA | Number of Machines | Value must be MATH NUMERIC
MOVD | Move Hours | Value must be MATH NUMERIC
QUED | Queue Hours | Value must be MATH NUMERIC
SETC | Crew Size | Value must be MATH NUMERIC

Column-Specific Instructions - From OneWorld - Table F30006Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDEWC"
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Data Columns

Data columns in the interface table from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld " section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.


Work Day Calendar

Table: F0007Z1

Date: November 02, 1998

General Information

Purpose of Transaction

Work Day Calendar transactions are used to populate Work Day Calendar Records in OneWorld. These records indicate, for a given month and year, whether each day is a work day or a non-work day. On the inbound side, this transaction is used to update OneWorld tables with work day calendar information. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the work day calendar information.

The permanent OneWorld table primarily affected by this transaction is the Work Day Calendar table (F0007).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions, changes and deletions.

The outbound transaction supports additions, changes, and deletions. For changes, both the before and after images can be written.

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F0007Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDEWC"
TNAC | Action Code | "A" = add, "C" = change, "D" = delete (left justified)
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".Additional Comments

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
MCU | Business Unit | Value must exist in Business Unit Table (F0006)
CT | Century | Required. 1 = 2000, 0 = 1900
YR | Year | Required. Year expressed as two digits.
MT | Month | Required. Month expressed as a number. (1-12)
SHFT | Shift | Required. Value must exist in UDC 06/SH. "blank" is valid.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and Default logic
TD01 - TD31 | Type of Day 1 - 31 | Designates work days from no-work days.

Value must exist in UDC 00/TD.

Column-Specific Instructions - From OneWorld - Table F0007Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and Default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDEWC"
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Data Columns

Data columns in the interface table from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld " section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.


Work Order Completions

Table: F4801Z1

October 18, 1998

General Information

Purpose of Transaction

Work Order Completion transaction are used to record the completion of item production to the inventory in the system. On the inbound side, this transaction is used to update OneWorld tables with work order completion information. On the outbound side, this transaction is used to generate records that that can be used by a third party to update their system with the work order completion information.

The permanent OneWorld tables primarily affected by this transaction are the Work Order Master File (F4801), the Item Ledger File (F4111), and the Item Location File (F41021).

Relationships to Other Transactions

The F4801Z1 transaction file is also used by Work Order Headers. Work Order Completions transactions will have a Transaction Type equal to "JDECMP", Work Order Headers will have a Transaction Type equal to "JDEWO".

Transaction-Specific Instructions

The inbound transaction supports additions, changes, and deletions.

The outbound transaction supports additions, changes, and deletions. For changes, both the before and after images can be written.

Completions interoperability program does not handle co/by and unplanned co/by completions. Process end item can be completed but corresponding co/by completions will not be recorded.

This transaction must have corresponding records in Work Order Master File (F4801), Item Master (F4101), and the Item Branch File (F4102).

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F4801Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDECMP"
TNAC | Action Code | "A" = add, "C" = change, "D" = delete (left justified)
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
DOCO | Order Number | Required field. Order Number should exist in F4801 table.
SOQS | Quantity Shipped | Quantity is required if completing a work order.
SOCN | Quantity Canceled | Quantity is required if scrapping a work order.

Additional Comments

One of the two columns, SOQS or SOCN, must be populated.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table although not specifically listed, can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
ITM | Item Number - Short | If left blank, defaulted from F4801. Item Number should exist in Item Master F4101 and Item/Branch F4102.
MCU | Branch/Plant | If left blank, defaulted from F4801. Branch/Plant should exist in Business Unit Master F0006.
LOTN | Lot Number | Lot to which inventory is completed
LOCN | Location | Location to which inventory is completed. Location should exist in Location Master F4100 if Location Control on Branch/Plant constants is checked.
EXPR | Lot Expiration Date | If left blank, defaulted from Lot Master File F4108. If lot master record doesn”t exist them date is calculated using shelf life days from branch/plant constants.
VERS | Version | Version for P31114, if left blank ZJDE0001 will be used

Column-Specific Instructions - From OneWorld - Table F4801Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDECMP"
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Data Columns

Data columns in the interface table from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld " section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.


Work Order Employee Time Entry

Table: F31122Z1

Date: October 31, 1998

General Information

Purpose of Transaction

Work Order Time Entry transactions are used to report hours and quantities against a work order. On the inbound side, this transaction is used to update OneWorld tables with work order time entry information. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the work order time entry information.

The permanent OneWorld table primarily affected by this transaction is the Work Order Time Transactions table (F31122).

Relationships to Other Transactions

None.

Transaction-Specific Instructions

The inbound transaction supports additions only.

The outbound transaction supports additions only.

This transaction must have corresponding records in the Work Order Master File (F4801) and the Work Order Routing File (F3112).

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you..

Column-Specific Instructions - Into OneWorld - Table F31122Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (Journal Entries, Sales Orders, Work Order Employee Time Entries, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDEHQ"
TNAC | Action Code | "A" = add (left justified)
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
DOCO | Order Number | Required field. Validate against F4801.
AN8 | Employee Number | Required field. Validate against F0101.
TYR | Type of Hours | Required field. Validate against UDC (31/TY).
SHFT | Shift Code | Required field. Validate against UDC(06/SH) and F3009.
OPSQ | Operation Sequence Number | Required field. Validate against F3112.
HRW | Hours Workded | Required if Type of Hours = 1, 2, or 3.
SOQS | Quantity Shipped | Required if Type of Hours = 4.
SOCN | Quantity Canceled | Required if Type of Hours = 5.
GPAY | Gross Pay | Required if Type of Hours = 9.

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table, although not specifically listed, can be populated and will be passed along with the transaction.

Data Item

Description

Notes

DCTO

Document Type

If left blank, default from F4801. Value entered will be validated against UDC (00/DT).

KIT

Parent Item Number

If left blank, default from F3112. Value entered will be validated against F4101.

KITL

  2. nd Item Number

If left blank, default from F3112. Value entered will be validated against F4101.

KITA

  3. rd Item Number

If left blank, default from F3112. Value entered will be validated against F4101.

HRT

Employee Rate

If left blank, default from F00191.

UOM

Unit of Measure

If left blank, default from F4801. Value entered will be validated against F41002.

MMCU

Branch/Plant

If left blank, default from F4801. Value entered will be validated against F0006.

DGL

G/L Date

If left blank, default today’s date.

Column-Specific Instructions - From OneWorld - Table F31122Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes and Default
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDEHQ"
TNAC | Action Code | "A" = add (left justified).
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Data Columns

Refer to the "Into OneWorld " section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.


Work Order Inventory Issues

Table: F3111Z1

October 18, 1998

General Information

Purpose of Transaction

Work Order Inventory Issues transactions are used to determine the actual quantities of ingredients that are used in the production process according to the routing instructions for the work order. On the inbound side, this transaction is used to update OneWorld tables with inventory issue information. On the outbound side, this transaction is used to generate records that can be used by a third party to update their system with the inventory issue information.

The permanent OneWorld tables primarily affected by this transaction are the Work Order Parts List table (F3111), Item Ledger File (F4111), and the Item Location File (F41021).

Relationships to Other Transactions

The F3111Z1 transaction file is also used by Work Order Parts List. Inventory Issue transactions will have a Transaction Type (TYTN) equal to "JDEII". Work Order Parts List transactions will have a Transaction Type (TYTN) equal to "JDEPL". Also, the Quantity Transaction represents the quantity to be issued. This should be populated.

Transaction-Specific Instructions

The inbound transaction supports additions and changes.

The outbound transaction supports additions and changes. For changes, both the before and after images can be written.

This transaction does not support Advanced Warehousing or Simultaneous Issue and Receipt.

This transaction must have corresponding records in Work Order Master File (F4801), Item Master (F4101), Item Branch File (F4102), and Item Location (F41021).

Unused fields must be populated by zeros or blank spaces, depending on their data types. If you are using our APIs to write to the tables, our internal database APIs will handle the conversion for you.

Column-Specific Instructions - Into OneWorld - Table F3111Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are passing into OneWorld, and generally they do not correspond to columns in the permanent target table.

Data Item | Description | Notes
EDUS | User ID | Suggested use is to identify the user placing transactions in the table.
EDBT | User Batch | Suggested use is to identify a batch of transactions within the specified user.
EDTN | User Transaction Number | Suggested use is to identify a specific transaction with a batch.
EDLN | Line Number | For multi line transactions (journal entries, sales orders, etc.), this column must be populated to differentiate each line within a given transaction.
TYTN | Transaction Type | Name of the transaction - "JDEII"
TNAC | Action Code | "A" = add, "C" = change
DRIN | Direction Indicator | "1" = into OneWorld (inbound). This indicates that the record was written by a system external to OneWorld with the intent of pushing the transaction into OneWorld.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y".

Additional Comments

The first three columns (EDUS, EDBT, and EDTN) must collectively contain values that uniquely identify the transaction within this table. You can populate any combination of these three columns providing the resulting values create a unique identification within this table. The values have no meaning to OneWorld. It is not necessary to populate exactly as suggested. The collective values are used to identify the transaction during the interface processing.

Required Data Columns

Required data columns are those that you must populate for OneWorld to accept the transaction.

Data Item | Description | Notes
DOCO | Order Number | Valid Work Order Number found in the F4801 Work Order Master and F3111 Work Order Parts List
TRQT | Quantity Transaction | Quantity to issue
CPIT | Component Item Number | Valid Component Item found in the F4101 Item Master

Frequently Used Optional Data Columns

Frequently used optional columns are not required to complete a transaction. They are expected to be commonly passed between systems, or they can have a significant influence on the behavior of the transaction if values are provided. Other columns in the table although not specifically listed can be populated and will be passed along with the transaction.

Data Item | Description | Notes and default logic
CPNT | Component Line Number | Related line number on the work order parts list (F3111)
UOM | Unit of Measure | Transaction Unit of Measure. Either Primary unit of measure found in the F4101 Item Master or other unit of measure with a related conversion faction found within the F41002 Item Unit of Measure Conversion table or F41003 Standard Unit of Measure Conversion table.
CMCU | Component Branch | Branch/Plant from which the component is issued from. Validated against the F4102 Item/Branch table.
MTST | Material Status | User Defined Code 31/MS used to update material status
LOCN | Location | Valid Location found in the F41021 Item Location table.
LOTN | Lot/Serial Number | Valid Lot/Serial Number found in the F41021 Item Location table and F4105 Lot Master.
COMM | Committed (H/S) | “H” - Hard , ‘s” - Soft

Column-Specific Instructions - From OneWorld - Table F3111Z1

Control Columns

Control columns are transient columns that exist for the purpose of identifying or controlling the transaction during the interface processing. They generally do not represent any of the actual business data or transaction that you are getting from OneWorld, and generally they do not correspond to columns in the permanent source table.

Data Item | Description | Notes
EDUS | User ID | User ID who initiated the transaction.
EDBT | User Batch | Batch number generated within OneWorld.
EDTN | User Transaction Number | Transaction number generated within OneWorld to identify the transaction within the interface table.
EDLN | Line Number | Sequential number assigned by OneWorld as each row is written to the interface table. Differentiates each row within the transaction identified by EDUS, EDBT, and EDTN.
TYTN | Transaction Type | Name of the transaction - "JDEII"
TNAC | Action Code | "A" = add, "D" = delete (left justified). When rows are logged based on changes to existing transactions, the image of the record before the change will contain “UB”; the image of the record after the change will contain "UA".
DRIN | Direction Indicator | "2" = from OneWorld (outbound). This indicates that the record was written by OneWorld to be used by other systems.
EDSP | Processed flag | When processing for this transaction is complete, OneWorld updates this to a "Y". For outbound transactions from OneWorld, these are flagged complete when process log records are written to table F0046.

Data Columns

Data columns in the interface table from OneWorld (outbound) have the same definitions as they do for transactions coming into OneWorld (inbound). Refer to the "Into OneWorld " section for descriptions of required and frequently used columns. Unless otherwise specified, OneWorld provides all columns from the corresponding source table.